<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8"/>
<meta name='viewport' content='width=device-width, initial-scale=1.0'/>
<meta http-equiv='X-UA-Compatible' content='IE=edge'/>
<link rel="profile" href="https://gmpg.org/xfn/11"/>
<link rel="pingback" href="https://nationalfootballpost.com/xmlrpc.php"/>
<title>Reports: Saints give DC Allen new deal - National Football Post</title>
<link rel="canonical" href="https://nationalfootballpost.com/reports-saints-give-dc-allen-new-deal/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Reports: Saints give DC Allen new deal - National Football Post"/>
<meta property="og:description" content="Reports: Saints give DC Allen new deal The New Orleans Saints signed defensive coordinator Dennis Allen to a new contract, according to multiple reports on Sunday. According to Sports Illustrated, Allen received a three-year deal. Allen, 46, joined the Saints in 2015 as a defensive assistant in 2015 and was promoted to coordinator midway through&hellip;"/>
<meta property="og:url" content="https://nationalfootballpost.com/reports-saints-give-dc-allen-new-deal/"/>
<meta property="og:site_name" content="National Football Post"/>
<meta property="article:publisher" content="http://facebook.com/nationalfootballpost"/>
<meta property="article:tag" content="FLM"/>
<meta property="article:section" content="NFL and College Football Articles"/>
<meta property="article:published_time" content="2019-02-04T03:38:32+00:00"/>
<meta property="article:modified_time" content="2019-02-04T03:38:34+00:00"/>
<meta property="og:updated_time" content="2019-02-04T03:38:34+00:00"/>
<meta property="og:image" content="https://nationalfootballpost.com/wp-content/uploads/2019/02/11217030.jpg"/>
<meta property="og:image:secure_url" content="https://nationalfootballpost.com/wp-content/uploads/2019/02/11217030.jpg"/>
<meta property="og:image:width" content="1100"/>
<meta property="og:image:height" content="769"/>
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="National Football Post &raquo; Feed" href="https://nationalfootballpost.com/feed/"/>
<link rel="stylesheet" type="text/css" href="//nationalfootballpost.com/wp-content/cache/wpfc-minified/2qvnzqgi/7xcbd.css" media="all"/>
<link rel='https://api.w.org/' href='https://nationalfootballpost.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nationalfootballpost.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nationalfootballpost.com/wp-includes/wlwmanifest.xml"/> 
<link rel='shortlink' href='https://nfp.news/11on'/>
<link rel="alternate" type="application/json+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Freports-saints-give-dc-allen-new-deal%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Freports-saints-give-dc-allen-new-deal%2F&#038;format=xml"/>
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','https://www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-5166086-1', 'auto'); ga('send', 'pageview');</script>
<meta name="generator" content="Feed to Post 3.7.5"/>
<link rel="canonical" href="https://footballpost.wpengine.com/newsml/fieldlevelmedia_str_20190203T234440_0800_000029765_1.xml"/><style>.saboxplugin-wrap .saboxplugin-gravatar img{-webkit-border-radius:50%;-moz-border-radius:50%;-ms-border-radius:50%;-o-border-radius:50%;border-radius:50%;}
.saboxplugin-wrap .saboxplugin-authorname a{color:#212121;}
.saboxplugin-wrap .saboxplugin-authorname{font-family:"Roboto Condensed";}
.saboxplugin-wrap .saboxplugin-desc{font-family:Roboto Condensed;}
.saboxplugin-wrap .saboxplugin-desc{font-style:italic;}
.saboxplugin-wrap{margin-top:20px;margin-bottom:10px;padding:5px 5px}
.saboxplugin-wrap .saboxplugin-authorname{font-size:20px;line-height:27px;}
.saboxplugin-wrap .saboxplugin-desc p, .saboxplugin-wrap .saboxplugin-desc{font-size:16px !important;line-height:23px !important;}
.saboxplugin-wrap .saboxplugin-web{font-size:14px;}
.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa:before{font-size:18px;}
.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa{width:36px;height:36px;line-height:36px;}</style><link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-32x32.jpg" sizes="32x32"/>
<link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-192x192.jpg" sizes="192x192"/>
<link rel="apple-touch-icon-precomposed" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-180x180.jpg"/>
<meta name="msapplication-TileImage" content="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-270x270.jpg"/>
<style id="wp-custom-css">.fl-post-cats-tags{padding:0px 0px 0px 0px;border-bottom:4px solid #e6e6e6}
.share-social{border-bottom:4px solid #e6e6e6}
.container{max-width:93%}
.fl-sidebar-left{padding-right:2%;padding-left:0px;}
.fl-post-cats-tags a, .share-social a{text-transform:uppercase;color:#000;font-size:18px;font-weight:600;font-style:normal;}
.fl-archive .fl-post{border-bottom:0px;}
div.share-social{letter-spacing:7px;float:right;padding-top:10px;}
.custom-html-widget li a{font-size:16px;color:#555;font-style:normal;display:block;padding-bottom:4px;font-weight:600;text-transform:uppercase;}
.custom-html-widget li{font-size:14px;color:#7b7b7b;font-style:italic;font-weight:500;text-transform:uppercase;padding-bottom:6px;border-bottom:2px solid #e6e6e6}
.fl-widget-title{border-style:solid;border-width:4px 0px 4px 0px;text-align:center;padding:5px}
.fl-post-title{margin-bottom:0px;}
.fl-post-author{text-transform:uppercase;font-style:italic;font-weight:600;font-size:18px;}
.tooltip-inner{letter-spacing:1px;}
.fl-post-meta-bottom{border-top:none;font-style:italic;margin-top:0;padding-top:10px;float:left;}
.btn-primary{border:none !important;background:0 0 !important;;color:#000 !important;;box-shadow:none !important;;padding:0 !important;;margin-bottom:5px !important;;}
.toptitle h1{font-size:22px;margin-top:5px;margin-bottom:5px;list-style:none;margin:0;padding:0;line-height:40px;width:50%;position:relative;left:25%;margin:0 px;padding:0 px;border:1px solid #AAA;color:white;background:#050505;border-bottom-left-radius:10px;border-bottom-right-radius:10px;font-style:italic;}
.fl-archive .fl-archive-title{display:none;}
.rp4wp-related-post-content{font-size:18px;color:#555;font-style:italic;display:block;font-weight:800;text-transform:uppercase;}</style>
<script data-wpfc-render="false">var Wpfcll={s:[],i:function(){Wpfcll.ss();window.addEventListener('load',function(){window.addEventListener("DOMSubtreeModified",function(e){Wpfcll.ss();Wpfcll.ls(false);},false);Wpfcll.ls(true);});window.addEventListener('scroll',function(){Wpfcll.ls(false);});window.addEventListener('resize',function(){Wpfcll.ls(false);});window.addEventListener('click',function(){Wpfcll.ls(false);});},c:function(e,pageload){var w=document.documentElement.clientHeight || body.clientHeight;var n=pageload ? 0:800;var er=e.getBoundingClientRect();var t=0;var p=e.parentNode;var pr=p.getBoundingClientRect();if(er.x==0 && er.y==0){for(var i=0;i < 10;i++){if(p){if(pr.x==0 && pr.y==0){p=p.parentNode;pr=p.getBoundingClientRect();}else{t=pr.top;break;}}};}else{t=er.top;}if(w - t+n > 0){return true;}return false;},r:function(e,pageload){var s=this;var oc,ot;try{if(s.c(e,pageload)){oc=e.getAttribute("data-wpfc-original-src");ot=e.getAttribute("data-wpfc-original-srcset");if(oc || ot){if(oc){e.setAttribute('src',oc);}if(ot){e.setAttribute('srcset',ot);}e.removeAttribute("data-wpfc-original-src");e.removeAttribute("onload");if(e.tagName=="IFRAME"){e.onload=function(){var s=e.getAttribute("src").match(/templates\/youtube\.html\#(.+)/);var y="https://www.youtube.com/embed/";if(s){try{var i=e.contentDocument || e.contentWindow;if(i.location.href=="about:blank"){e.setAttribute('src',y+s[1]);}}catch(err){e.setAttribute('src',y+s[1]);}}}}}}}catch(error){console.log(error);console.log("==>",e);}},ss:function(){var i=Array.prototype.slice.call(document.getElementsByTagName("img"));var f=Array.prototype.slice.call(document.getElementsByTagName("iframe"));this.s=i.concat(f);},ls:function(pageload){var s=this;[].forEach.call(s.s,function(e,index){s.r(e,pageload);});}};document.addEventListener('DOMContentLoaded',function(){wpfci();});function wpfci(){Wpfcll.i();}</script>
</head>
<body class="post-template-default single single-post postid-102502 single-format-standard fl-preset-default fl-fixed-width fl-scroll-to-top fl-search-active" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="fl-page"> <header class="fl-page-header fl-page-header-fixed fl-page-nav-right fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="fl-page-logo-wrap col-md-3 col-sm-12"> <div class="fl-page-header-logo"> <a href="https://nationalfootballpost.com/"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post"/><meta itemprop="name" content="National Football Post"/></a></div></div><div class="fl-page-fixed-nav-wrap col-md-9 col-sm-12"> <div class="fl-page-nav-wrap"> <nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span><i class="fa fa-bars"></i></span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-top-nav" class="nav navbar-nav navbar-right menu"><li id="menu-item-78448" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a> <ul class="sub-menu"> <li id="menu-item-94464" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li> <li id="menu-item-94463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li> </ul> </li> <li id="menu-item-80343" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a> <ul class="sub-menu"> <li id="menu-item-88321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li> <li id="menu-item-80344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li> <li id="menu-item-78452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li> </ul> </li> <li id="menu-item-78387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a> <ul class="sub-menu"> <li id="menu-item-84427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li> <li id="menu-item-84236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li> </ul> </li> <li id="menu-item-78499" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a> <ul class="sub-menu"> <li id="menu-item-78502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li> <li id="menu-item-78500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li> <li id="menu-item-80079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li> </ul> </li> </ul></div></nav></div></div></div></div></div></header>
<header class="fl-page-header fl-page-header-primary fl-page-nav-centered fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-12 fl-page-header-logo-col"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="https://schema.org/Organization"> <a href="https://nationalfootballpost.com/" itemprop="url"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post"/><meta itemprop="name" content="National Football Post"/></a></div></div></div></div></div><div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span><i class="fa fa-bars"></i></span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-top-nav-1" class="nav navbar-nav menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li> </ul> </li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li> </ul> </li> </ul><div class="fl-page-nav-search"> <a href="javascript:void(0);" class="fa fa-search"></a> <form method="get" role="search" action="https://nationalfootballpost.com/" title="Type and press Enter to search."> <input type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" /> </form></div></div></nav></div></div></header>
<div class="fl-page-content" itemprop="mainContentOfPage"> <div class="fl-archive container"> <div class="row"> <div class="fl-sidebar fl-sidebar-left fl-sidebar-display-desktop col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"> <aside id="custom_html-3" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">RECENT</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/fowler-survives-triple-bogey-to-win-phoenix-open/" title="Fowler survives triple bogey to win Phoenix Open">Fowler survives triple bogey to win Phoenix Open</a> 1 hour ago </li><li ><a href="https://nationalfootballpost.com/reports-saints-give-dc-allen-new-deal/" title="Reports: Saints give DC Allen new deal">Reports: Saints give DC Allen new deal</a> 1 hour ago </li><li ><a href="https://nationalfootballpost.com/patriots-lead-rams-3-0-at-halftime-in-sb-liii-slugfest/" title="Patriots lead Rams, 3-0, at halftime in SB LIII slugfest">Patriots lead Rams, 3-0, at halftime in SB LIII slugfest</a> 1 hour ago </li><li ><a href="https://nationalfootballpost.com/patriots-lead-rams-3-0-halfway-through-slugfest/" title="Patriots lead Rams, 3-0, halfway through slugfest">Patriots lead Rams, 3-0, halfway through slugfest</a> 1 hour ago </li><li ><a href="https://nationalfootballpost.com/patriots-chung-ruled-out-with-arm-injury/" title="Patriots&#8217; Chung ruled out with arm injury">Patriots&#8217; Chung ruled out with arm injury</a> 1 hour ago </li><li ><a href="https://nationalfootballpost.com/panthers-qb-newton-may-recover-by-training-camp/" title="Panthers QB Newton may recover by training camp">Panthers QB Newton may recover by training camp</a> 4 hours ago </li><li ><a href="https://nationalfootballpost.com/report-seahawks-wilson-yet-to-talk-extension/" title="Report: Seahawks, Wilson yet to talk extension">Report: Seahawks, Wilson yet to talk extension</a> 4 hours ago </li><li ><a href="https://nationalfootballpost.com/trump-says-he-wouldnt-steer-son-toward-football/" title="Trump says he wouldn&#8217;t &#8216;steer&#8217; son toward football">Trump says he wouldn&#8217;t &#8216;steer&#8217; son toward football</a> 8 hours ago </li><li ><a href="https://nationalfootballpost.com/report-chiefs-ban-fan-they-say-aimed-laser-at-brady/" title="Report: Chiefs ban fan they say aimed laser at Brady">Report: Chiefs ban fan they say aimed laser at Brady</a> 8 hours ago </li><li ><a href="https://nationalfootballpost.com/nfl-notebook-mahomes-takes-home-mvp/" title="NFL notebook: Mahomes takes home MVP">NFL notebook: Mahomes takes home MVP</a> 23 hours ago </li></ul></div></aside><aside id="custom_html-7" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">FEATURES</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/super-bowl-53-betting-preview/" title="Super Bowl 53 Betting Preview – Best Props Picks, Trends">Super Bowl 53 Betting Preview – Best Props Picks, Trends</a> 12 hours ago </li><li ><a href="https://nationalfootballpost.com/report-brady-defiantly-denies-retirement-question/" title="Report: Brady defiantly denies retirement question">Report: Brady defiantly denies retirement question</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/rams-cooks-responds-to-pats-chung-dig-in-fan-rally/" title="Rams&#8217; Cooks responds to Pats&#8217; Chung dig in fan rally">Rams&#8217; Cooks responds to Pats&#8217; Chung dig in fan rally</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/huge-crowd-sends-patriots-off-to-super-bowl/" title="Huge crowd sends Patriots off to Super Bowl">Huge crowd sends Patriots off to Super Bowl</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/rams-k-zuerlein-optimistic-strained-foot-will-be-good-to-go/" title="Rams K Zuerlein optimistic strained foot will be ‘good to go’">Rams K Zuerlein optimistic strained foot will be ‘good to go’</a> January 27, 2019 </li></ul></div></aside></div><div class="fl-content fl-content-right col-md-9" itemscope="itemscope" itemtype="https://schema.org/Blog"> <article class="fl-post post-102502 post type-post status-publish format-standard hentry category-news tag-flm" id="fl-post-102502" itemscope itemtype="https://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Reports: Saints give DC Allen new deal </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/reports-saints-give-dc-allen-new-deal/"/><meta itemprop="datePublished" content="1 hour ago"/><meta itemprop="dateModified" content="2 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" itemprop="text"> <h2><title>Reports: Saints give DC Allen new deal</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/11217030.jpg" width="1100" height="769" alt="" title="Sep 9, 2018; New Orleans, LA, USA; New Orleans Saints defensive coordinator Dennis Allen during the first quarter of a game against the Tampa Bay Buccaneers at the Mercedes-Benz Superdome. Mandatory Credit: Derick E. Hingle-USA TODAY Sports" data-portal-copyright="Derick E. Hingle-USA TODAY Sports"></p><p> The New Orleans Saints signed defensive coordinator Dennis Allen to a new contract, according to multiple reports on Sunday. </p> </p><p> According to Sports Illustrated, Allen received a three-year deal. </p> </p><p> Allen, 46, joined the Saints in 2015 as a defensive assistant in 2015 and was promoted to coordinator midway through the year after the firing of Rob Ryan. The Saints were historically bad on defense in 2015 and not much better in 2016, but the group has finished 10th (2017) and 14th (2018) in points allowed over the last two seasons. They also finished 17th in yards in 2017 before improving to 14th this season. </p> </p><p> Allen is in his second stint with the Saints after holding two different positions from 2006-10. He also has been the defensive coordinator of the Denver Broncos (2011) and head coach of the Oakland Raiders (2012-14). </p> </p><p> &#8211;Field Level Media</p></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freports-saints-give-dc-allen-new-deal%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Reports: Saints give DC Allen new deal+http://nfp.news/11on" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Reports: Saints give DC Allen new deal&#32;&#32;http://nfp.news/11on" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11on"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<div class="related-post"> <article style="overflow: hidden;margin-bottom: 30px;"> <header class="fl-post-header"> <h2 class="fl-post-title" itemprop="headline"> <a href="https://nationalfootballpost.com/fowler-survives-triple-bogey-to-win-phoenix-open/" rel="bookmark" title="Fowler survives triple bogey to win Phoenix Open">Fowler survives triple bogey to win Phoenix Open</a> </h2> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/fowler-survives-triple-bogey-to-win-phoenix-open/"/><meta itemprop="datePublished" content="1 hour ago"/><meta itemprop="dateModified" content="2 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Fowler survives triple bogey to win Phoenix Open</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12103930.jpg" width="1100" height="733" alt="" title="Feb 3, 2019; Scottsdale, AZ, USA; Rickie Fowler plays his tee shot at the 8th during the final round of the Waste Management Phoenix Open golf tournament at TPC Scottsdale. Mandatory Credit: Allan Henry-USA TODAY Sports" data-portal-copyright="Allan Henry-USA TODAY Sports"/></p> <p></p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Fowler survives triple bogey to win Phoenix Open</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12103930.jpg" width="1100" height="733" alt="" title="Feb 3, 2019; Scottsdale, AZ, USA; Rickie Fowler plays his tee shot at the 8th during the final round of the Waste Management Phoenix Open golf tournament at TPC Scottsdale. Mandatory Credit: Allan Henry-USA TODAY Sports" data-portal-copyright="Allan Henry-USA TODAY Sports"></p><p> Rickie Fowler recovered from a back-side triple-bogey to win the Waste Management Phoenix Open on Sunday in Scottsdale, Ariz. </p> </p><p> Fowler&#8217;s final-round 3-over-par 74 came with birdies on two of the final four holes after his lead disappeared at TPC Scottsdale. </p> </p><p> Fowler finished at 17-under 267 to win by two shots over South Africa&#8217;s Branden Grace, whose final-round 69 wasn&#8217;t enough. </p> </p><p> A year ago, Fowler couldn&#8217;t hold a lead in this tournament entering the final round. This time, he had a four-shot cushion, and he saw that vanish. </p> </p><p> Fowler pulled even with Grace thanks to a birdie on the par-5 No. 15. Another birdie at the par-4 No. 17 after Grace took a bogey on the 17th gave Fowler a two-shot edge. Then Grace hit into the water on No. 17, proving costly. </p> </p><p> Fowler had been pumped up by then as he drove the green on the par-4 17th with a chance at an eagle putt. </p> </p><p> But it wasn&#8217;t easy from there. Fowler&#8217;s tee shot on the 18th ended up buried in the tall grass strips located in a fairway sand trap. Two shots later, he had a short putt for par to clinch the title. </p> </p><p> Fowler, 30, secured his fifth victory on the PGA Tour. It came despite the highest final-round score in the tournament&#8217;s history. </p> </p><p> Fowler made triple at the par-4 11th when his approach rolled past the pin, over the green and into the water behind the green, which was deemed a penalty area. The ball rolled back into the water, costing him another stroke, before Fowler finally got up and down for a 7. He followed up with a bogey 4 on the par-3 No. 12. </p> </p><p> Justin Thomas, who contended all week, had three birdies during his final-round 72 and ended up third at 14 under. </p> </p><p> Matt Kuchar, who joined Thomas and Fowler in the final group, shot 75 and faded to a tie for fourth at 12 under. He shared that with Bubba Watson (71) and Chez Reavie (68) </p> </p><p> Fowler&#8217;s double bogey on No. 5 created the first notable movement on the leaderboard, softened some because Kuchar and Thomas both took bogeys on the hole. </p> </p><p> Defending champion Gary Woodland closed with 72 for his worst round of the tournament and finished tied for seventh at 11-under. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Fowler survives triple bogey to win Phoenix Open');return false;"><span class="op-btn">Read More</span> <span class="count">313 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Ffowler-survives-triple-bogey-to-win-phoenix-open%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Fowler survives triple bogey to win Phoenix Open+http://nfp.news/11om" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Fowler survives triple bogey to win Phoenix Open&#32;&#32;http://nfp.news/11om" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11om"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/patriots-lead-rams-3-0-at-halftime-in-sb-liii-slugfest/" rel="bookmark" title="Patriots lead Rams, 3-0, at halftime in SB LIII slugfest">Patriots lead Rams, 3-0, at halftime in SB LIII slugfest</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/patriots-lead-rams-3-0-at-halftime-in-sb-liii-slugfest/"/><meta itemprop="datePublished" content="1 hour ago"/><meta itemprop="dateModified" content="2 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Patriots lead Rams, 3-0, at halftime in SB LIII slugfest</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12105225-1.jpg" width="1100" height="836" alt="" title="Feb 3, 2019; Atlanta, GA, USA; Los Angeles Rams quarterback Jared Goff (16) is sacked by New England Patriots defensive end Trey Flowers (98) and outside linebacker Dont&#039;a Hightower (54) during the second quarter of Super Bowl LIII at Mercedes-Benz</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Patriots lead Rams, 3-0, at halftime in SB LIII slugfest</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12105225-1.jpg" width="1100" height="836" alt="" title="Feb 3, 2019; Atlanta, GA, USA; Los Angeles Rams quarterback Jared Goff (16) is sacked by New England Patriots defensive end Trey Flowers (98) and outside linebacker Dont'a Hightower (54) during the second quarter of Super Bowl LIII at Mercedes-Benz Stadium. Mandatory Credit: Jason Getz-USA TODAY Sports" data-portal-copyright="Jason Getz-USA TODAY Sports"></p><p> After a scoreless first quarter, Stephen Gostkowski&#8217;s 42-yard field goal with 10:29 remaining in the second quarter gave the New England Patriots a 3-0 lead against the listless Los Angeles Rams at halftime of Super Bowl LIII on Sunday in Atlanta. </p> </p><p> The Rams punted on all six of their first-half possessions, picking up just two first downs. The NFL&#8217;s No. 2 offense in both scoring and yards during the regular season, Los Angeles reached intermission with 57 total yards. </p> </p><p> After missing from 46 yards in the opening quarter, Gostkowski converted his second attempt to cap a seven-play, 39-yard drive. The Patriots tallied 12 first downs and gained 195 yards in the half, as 41-year-old Tom Brady completed 15 of 25 passes for 160 yards with one interception. Julian Edelman had seven catches for 93 yards. </p> </p><p> The Rams crossed midfield three times &#8212; but only barely. They were stopped at the New England 49 once and the 47 twice, the second time with about four minutes left in the half. Patriots linebacker Kyle Van Noy sacked Jared Goff for a 14-yard loss on third-and-2 to force another Rams three-and-out. </p> </p><p> Los Angeles star Todd Gurley started and rushed for 2 yards on the Rams&#8217; first play from scrimmage, but had only two more touches in the half. Dealing with knee inflammation, Gurley missed the last two regular-season games and had only five touches in the NFC Championship at New Orleans. </p> </p><p> After the Rams won the coin toss and deferred, the Patriots opened the action with a 38-yard kickoff return by Cordarrelle Patterson. Following four straight running plays, Brady was intercepted on his first pass attempt of the game. Cornerback Nickell Robey-Coleman deflected a throw intended for Chris Hogan, and linebacker Cory Littleton cradled it before it hit the ground at the 27-yard line. </p> </p><p> Los Angeles couldn&#8217;t take advantage of the takeaway and gave it right back with a three-and-out. </p> </p><p> Starting from its own 12, New England drove 60 yards in 11 plays but came up empty when Gostkowski&#8217;s 46-yard attempt missed wide left. Patriots coach Bill Belichick used two timeouts on the drive, the second with 6:17 remaining in the first quarter. Tight end Rob Gronkowski had his first catch on the drive, a 19-yard gain that took the Pats into Rams territory. </p> </p><p> The Rams crossed midfield on their second possession before Johnny Hekker came on to punt for the second time. L.A. tried to draw New England offsides on fourth-and-3 at the Patriots&#8217; 42-yard line with no luck, taking a delay of game penalty. </p> </p><p> Despite getting inside the Rams&#8217; 35-yard line on each of their first two possessions, the Patriots failed to score a first-quarter touchdown for the ninth time in nine Brady-Belichick Super Bowl appearances. After a failure on fourth-and-1 late in the half, New England had just three points to show on four trips inside the Los Angeles 35. </p> </p><p> New England&#8217;s third possession stalled after John Franklin-Myers sacked and stripped Brady near midfield, with center David Andrews recovering the loose ball. It was the first sack allowed by the Patriots this postseason. </p> </p><p> It was the ninth scoreless first quarter in Super Bowl history, with the Patriots now involved in five of them (they won the previous four). </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Patriots lead Rams, 3-0, at halftime in SB LIII slugfest');return false;"><span class="op-btn">Read More</span> <span class="count">474 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpatriots-lead-rams-3-0-at-halftime-in-sb-liii-slugfest%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Patriots lead Rams, 3-0, at halftime in SB LIII slugfest+http://nfp.news/11oo" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Patriots lead Rams, 3-0, at halftime in SB LIII slugfest&#32;&#32;http://nfp.news/11oo" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11oo"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/patriots-lead-rams-3-0-halfway-through-slugfest/" rel="bookmark" title="Patriots lead Rams, 3-0, halfway through slugfest">Patriots lead Rams, 3-0, halfway through slugfest</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/patriots-lead-rams-3-0-halfway-through-slugfest/"/><meta itemprop="datePublished" content="1 hour ago"/><meta itemprop="dateModified" content="2 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Patriots lead Rams, 3-0, halfway through slugfest</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12105225.jpg" width="1100" height="836" alt="" title="Feb 3, 2019; Atlanta, GA, USA; Los Angeles Rams quarterback Jared Goff (16) is sacked by New England Patriots defensive end Trey Flowers (98) and outside linebacker Dont&#039;a Hightower (54) during the second quarter of Super Bowl LIII at Mercedes-Benz Stadium. Mandatory Credit:</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Patriots lead Rams, 3-0, halfway through slugfest</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12105225.jpg" width="1100" height="836" alt="" title="Feb 3, 2019; Atlanta, GA, USA; Los Angeles Rams quarterback Jared Goff (16) is sacked by New England Patriots defensive end Trey Flowers (98) and outside linebacker Dont'a Hightower (54) during the second quarter of Super Bowl LIII at Mercedes-Benz Stadium. Mandatory Credit: Jason Getz-USA TODAY Sports" data-portal-copyright="Jason Getz-USA TODAY Sports"></p><p> After a scoreless first quarter, Stephen Gostkowski&#8217;s 42-yard field goal with 10:29 remaining in the second quarter gave the New England Patriots a 3-0 lead against the listless Los Angeles Rams at halftime of Super Bowl LIII on Sunday in Atlanta. </p> </p><p> The Rams punted on all six of their first-half possessions, picking up just two first downs. The NFL&#8217;s No. 2 offense in both scoring and yards during the regular season, Los Angeles reached intermission with 57 total yards. </p> </p><p> After missing from 46 yards in the opening quarter, Gostkowski converted his second attempt to cap a seven-play, 39-yard drive. The Patriots tallied 12 first downs and gained 195 yards in the half, as 41-year-old Tom Brady completed 15 of 25 passes for 160 yards with one interception. Julian Edelman had seven catches for 93 yards. </p> </p><p> The Rams crossed midfield three times &#8212; but only barely. They were stopped at the New England 49 once and the 47 twice, the second time with about four minutes left in the half. Patriots linebacker Kyle Van Noy sacked Jared Goff for a 14-yard loss on third-and-2 to force another Rams three-and-out. </p> </p><p> Los Angeles star Todd Gurley started and rushed for 2 yards on the Rams&#8217; first play from scrimmage, but had only two more touches in the half. Dealing with knee inflammation, Gurley missed the last two regular-season games and had only five touches in the NFC Championship at New Orleans. </p> </p><p> After the Rams won the coin toss and deferred, the Patriots opened the action with a 38-yard kickoff return by Cordarrelle Patterson. Following four straight running plays, Brady was intercepted on his first pass attempt of the game. Cornerback Nickell Robey-Coleman deflected a throw intended for Chris Hogan, and linebacker Cory Littleton cradled it before it hit the ground at the 27-yard line. </p> </p><p> Los Angeles couldn&#8217;t take advantage of the takeaway and gave it right back with a three-and-out. </p> </p><p> Starting from its own 12, New England drove 60 yards in 11 plays but came up empty when Gostkowski&#8217;s 46-yard attempt missed wide left. Patriots coach Bill Belichick used two timeouts on the drive, the second with 6:17 remaining in the first quarter. Tight end Rob Gronkowski had his first catch on the drive, a 19-yard gain that took the Pats into Rams territory. </p> </p><p> The Rams crossed midfield on their second possession before Johnny Hekker came on to punt for the second time. L.A. tried to draw New England offsides on fourth-and-3 at the Patriots&#8217; 42-yard line with no luck, taking a delay of game penalty. </p> </p><p> Despite getting inside the Rams&#8217; 35-yard line on each of their first two possessions, the Patriots failed to score a first-quarter touchdown for the ninth time in nine Brady-Belichick Super Bowl appearances. After a failure on fourth-and-1 late in the half, New England had just three points to show on four trips inside the Los Angeles 35. </p> </p><p> New England&#8217;s third possession stalled after John Franklin-Myers sacked and stripped Brady near midfield, with center David Andrews recovering the loose ball. It was the first sack allowed by the Patriots this postseason. </p> </p><p> It was the ninth scoreless first quarter in Super Bowl history, with the Patriots now involved in five of them (they won the previous four). </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Patriots lead Rams, 3-0, halfway through slugfest');return false;"><span class="op-btn">Read More</span> <span class="count">471 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpatriots-lead-rams-3-0-halfway-through-slugfest%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Patriots lead Rams, 3-0, halfway through slugfest+http://nfp.news/11op" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Patriots lead Rams, 3-0, halfway through slugfest&#32;&#32;http://nfp.news/11op" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11op"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/patriots-chung-ruled-out-with-arm-injury/" rel="bookmark" title="Patriots&#8217; Chung ruled out with arm injury">Patriots&#8217; Chung ruled out with arm injury</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/patriots-chung-ruled-out-with-arm-injury/"/><meta itemprop="datePublished" content="1 hour ago"/><meta itemprop="dateModified" content="2 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Patriots' Chung ruled out with arm injury</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12105418.jpg" width="1100" height="786" alt="" title="Feb 3, 2019; Atlanta, GA, USA; New England Patriots strong safety Patrick Chung (23) reacts to an apparent injury during the third quarter against the Los Angeles Rams in Super Bowl LIII at Mercedes-Benz Stadium. Mandatory Credit: Richard Mackson-USA TODAY Sports" data-portal-copyright="Richard Mackson-USA</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Patriots&#8217; Chung ruled out with arm injury</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12105418.jpg" width="1100" height="786" alt="" title="Feb 3, 2019; Atlanta, GA, USA; New England Patriots strong safety Patrick Chung (23) reacts to an apparent injury during the third quarter against the Los Angeles Rams in Super Bowl LIII at Mercedes-Benz Stadium. Mandatory Credit: Richard Mackson-USA TODAY Sports" data-portal-copyright="Richard Mackson-USA TODAY Sports"></p><p> New England Patriots safety Patrick Chung left the field with his right arm in an air cast during the third quarter of Super Bowl LIII. </p> </p><p> Chung, 31, was quickly ruled out for the rest of the game by the Patriots, and CBS reported on the broadcast he headed straight to the X-ray room. </p> </p><p> Chung was injured while attempting a tackle against Los Angeles Rams running back Todd Gurley. He reached in with his right arm, which was crunched between Gurley and Patriots cornerback Jonathan Jones. </p> </p><p> Trainers attended to Chung as he slumped on the ground. A cart came on to the field, but Chung walked off under his own power as the cart followed slowly behind him and several trainers. </p> </p><p> Chung finished the regular season with 84 tackles and an interception. The 10-year pro has 727 career tackles and 11 interceptions. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Patriots&#8217; Chung ruled out with arm injury');return false;"><span class="op-btn">Read More</span> <span class="count">87 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpatriots-chung-ruled-out-with-arm-injury%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Patriots’ Chung ruled out with arm injury+http://nfp.news/11oq" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Patriots&#8217; Chung ruled out with arm injury&#32;&#32;http://nfp.news/11oq" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11oq"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/panthers-qb-newton-may-recover-by-training-camp/" rel="bookmark" title="Panthers QB Newton may recover by training camp">Panthers QB Newton may recover by training camp</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/panthers-qb-newton-may-recover-by-training-camp/"/><meta itemprop="datePublished" content="4 hours ago"/><meta itemprop="dateModified" content="3 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Panthers QB Newton may recover by training camp</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/11872106.jpg" width="1100" height="718" alt="" title="Dec 2, 2018; Tampa, FL, USA; Carolina Panthers quarterback Cam Newton (1) looks on against the Tampa Bay Buccaneers during the second half at Raymond James Stadium. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports"/></p> <p> Carolina Panthers quarterback</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Panthers QB Newton may recover by training camp</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/11872106.jpg" width="1100" height="718" alt="" title="Dec 2, 2018; Tampa, FL, USA; Carolina Panthers quarterback Cam Newton (1) looks on against the Tampa Bay Buccaneers during the second half at Raymond James Stadium. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports"></p><p> Carolina Panthers quarterback Cam Newton might be ready for training camp after his recent shoulder surgery, ESPN reported on Sunday. </p> </p><p> At minimum, Newton is expected to be ready well in time for the start of the 2019 regular season, per the report. </p> </p><p> Newton underwent arthroscopic surgery on his right shoulder after battling discomfort over the second half of the 2018 season before eventually being shut down with two games remaining. </p> </p><p> The team hasn&#8217;t yet announced a timetable for Newton&#8217;s return. </p> </p><p> This marks the second time in three offseasons that Newton has undergone surgery on his passing shoulder. </p> </p><p> The former NFL MVP was optimistic about the shoulder in a radio appearance on Wednesday. </p> </p><p> &#8220;It&#8217;s good. It&#8217;s good,&#8221; Newton told radio station 680 The Fan in Atlanta, adding, &#8220;It&#8217;s better than I thought it would be. With so much going on throughout this season, I was in fear to see what actually was wrong.&#8221; </p> </p><p> Newton passed for 3,395 yards and 24 touchdowns against 13 interceptions last season. Carolina started strong at 6-2 but collapsed with seven straight losses and ended up at 7-9. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Panthers QB Newton may recover by training camp');return false;"><span class="op-btn">Read More</span> <span class="count">126 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpanthers-qb-newton-may-recover-by-training-camp%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Panthers QB Newton may recover by training camp+http://nfp.news/11ol" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Panthers QB Newton may recover by training camp&#32;&#32;http://nfp.news/11ol" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11ol"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/report-seahawks-wilson-yet-to-talk-extension/" rel="bookmark" title="Report: Seahawks, Wilson yet to talk extension">Report: Seahawks, Wilson yet to talk extension</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-seahawks-wilson-yet-to-talk-extension/"/><meta itemprop="datePublished" content="4 hours ago"/><meta itemprop="dateModified" content="3 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Report: Seahawks, Wilson yet to talk extension</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12065841.jpg" width="1100" height="675" alt="" title="Jan 27, 2019; Orlando, FL, USA;Seattle Seahawks quarterback Russell Wilson (3) carries the ball as Pittsburgh Steelers defensive tackle Cameron Heyward (right) defends during the first quarter of the NFL Pro Bowl football game at Camping World Stadium. Mandatory Credit: Reinhold Matay-USA TODAY</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Report: Seahawks, Wilson yet to talk extension</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12065841.jpg" width="1100" height="675" alt="" title="Jan 27, 2019; Orlando, FL, USA;Seattle Seahawks quarterback Russell Wilson (3) carries the ball as Pittsburgh Steelers defensive tackle Cameron Heyward (right) defends during the first quarter of the NFL Pro Bowl football game at Camping World Stadium. Mandatory Credit: Reinhold Matay-USA TODAY Sports" data-portal-copyright="Reinhold Matay-USA TODAY Sports"></p><p> The Seattle Seahawks and quarterback Russell Wilson have yet to have any contract discussions as he approaches the final year of his contract, ESPN reported Sunday. </p> </p><p> Per the report, the sides have not mentioned interest to each other in extending the deal, or talked about what an extension might look like. </p> </p><p> Head coach Pete Carroll told reporters at his end-of-season press conference that signing Wilson to an extension was &#8220;very much in our plans&#8221; for the offseason, but this deal is expected to take some time. According to ESPN, it will likely exceed Aaron Rodgers&#8217; $33.5 million annual average for the largest in NFL history, and could be complicated by the possibility of a work stoppage in 2021 when the CBA expires. </p> </p><p> Wilson&#8217;s last extension &#8212; as he was entering the final year of his rookie contract &#8212; came on the first day of Seahawks training camp in 2015, at the end of July. </p> </p><p> The 30-year-old will make $17 million in 2019, the final year of a four-year, $87.6 million contract that ranked narrowly behind Rodgers for the largest annual average in NFL history at the time it was signed. </p> </p><p> Wilson is coming off of a terrific season, setting a career high in touchdown passes (35) despite his fewest attempts (427) in a season since 2013. He also set a personal best in passer rating (110.9) and equaled a career low in interceptions (seven), while earning his fifth Pro Bowl nod in seven NFL seasons. </p> </p><p> Wilson hasn&#8217;t missed a start since the team drafted him 75th overall in 2012, and he&#8217;s gone 75-36-1 in the regular season as a starter. He has gone 8-5 in the postseason, although the Seahawks haven&#8217;t won a playoff game since 2016 after winning at least one in each of his first five seasons. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Report: Seahawks, Wilson yet to talk extension');return false;"><span class="op-btn">Read More</span> <span class="count">238 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-seahawks-wilson-yet-to-talk-extension%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Seahawks, Wilson yet to talk extension+http://nfp.news/11ok" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Seahawks, Wilson yet to talk extension&#32;&#32;http://nfp.news/11ok" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11ok"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/trump-says-he-wouldnt-steer-son-toward-football/" rel="bookmark" title="Trump says he wouldn&#8217;t &#8216;steer&#8217; son toward football">Trump says he wouldn&#8217;t &#8216;steer&#8217; son toward football</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/trump-says-he-wouldnt-steer-son-toward-football/"/><meta itemprop="datePublished" content="8 hours ago"/><meta itemprop="dateModified" content="7 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Trump says he wouldn't 'steer' son toward football</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/10020251.jpg" width="1100" height="733" alt="" title="Apr 19, 2017; Washington, DC, USA; President Donald Trump (M) holds a team jersey as New England Patriots owner Robert Kraft (R) and Patriots head coach Bill Belichick (L) look on at a ceremony honoring the Super Bowl LI champion New England</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Trump says he wouldn&#8217;t &#8216;steer&#8217; son toward football</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/10020251.jpg" width="1100" height="733" alt="" title="Apr 19, 2017; Washington, DC, USA; President Donald Trump (M) holds a team jersey as New England Patriots owner Robert Kraft (R) and Patriots head coach Bill Belichick (L) look on at a ceremony honoring the Super Bowl LI champion New England Patriots on the South Lawn at the White House. Mandatory Credit: Geoff Burke-USA TODAY Sports" data-portal-copyright="Geoff Burke-USA TODAY Sports"></p><p> President Donald Trump said that he wouldn&#8217;t encourage his youngest son to play football, citing the dangers of the sport. </p> </p><p> Appearing on CBS&#8217;s &#8220;Face the Nation&#8221; on Sunday, Trump was asked in a wide-ranging interview about his son, Barron, and football. </p> </p><p> &#8220;It&#8217;s a very good question,&#8221; Trump said when asked if he would allow Barron to play. &#8220;If he wanted to? Yes. Would I steer him that way? No, I wouldn&#8217;t.&#8221; </p> </p><p> Barron, who turns 13 next month, plays soccer. </p> </p><p> &#8220;He&#8217;s liking soccer. And a lot of people, including me, thought soccer would probably never make it in this country, but it really is moving forward rapidly,&#8221; Trump said. &#8220;I just don&#8217;t like the reports that I see coming out having to do with football. I mean, it&#8217;s a dangerous sport and I think it&#8217;s really tough. I thought the equipment would get better, and it has. The helmets have gotten far better but it hasn&#8217;t solved the problem. </p> </p><p> &#8220;So, you know, I hate to say it because I love to watch football. I think the NFL is a great product, but I really think that as far as my son? Well I&#8217;ve heard NFL players saying they wouldn&#8217;t let their sons play football. So. It&#8217;s not totally unique, but I would have a hard time with it.&#8221; </p> </p><p> Former President Barack Obama, the father of two daughters, said in a 2014 interview that he would not allow his son, if he had one, to play pro football. </p> </p><p> Also Sunday, Trump addressed his relationship with NFL commissioner Roger Goodell. Trump has been extremely critical of players who chose to kneel or sit during the pregame national anthem. He said believes he and Goodell have put aside their differences. </p> </p><p> &#8220;I think so. I mean I was just one that felt very important, you can&#8217;t be kneeling for the national anthem. You have to respect our flag and our country,&#8221; he said. &#8220;I want that as president and I&#8217;d want that as a citizen. &#8230; But they haven&#8217;t been kneeling and they have been respecting the flag and their ratings have been terrific ever since. And a lot of good things happened.&#8221; </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Trump says he wouldn&#8217;t &#8216;steer&#8217; son toward football');return false;"><span class="op-btn">Read More</span> <span class="count">306 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Ftrump-says-he-wouldnt-steer-son-toward-football%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Trump says he wouldn’t ‘steer’ son toward football+http://nfp.news/11oj" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Trump says he wouldn&#8217;t &#8216;steer&#8217; son toward football&#32;&#32;http://nfp.news/11oj" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11oj"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/report-chiefs-ban-fan-they-say-aimed-laser-at-brady/" rel="bookmark" title="Report: Chiefs ban fan they say aimed laser at Brady">Report: Chiefs ban fan they say aimed laser at Brady</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-chiefs-ban-fan-they-say-aimed-laser-at-brady/"/><meta itemprop="datePublished" content="8 hours ago"/><meta itemprop="dateModified" content="7 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Report: Chiefs ban fan they say aimed laser at Brady</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12086241.jpg" width="1100" height="733" alt="" title="Jan 31, 2019; Atlanta, GA, USA; New England Patriots quarterback Tom Brady (12) addresses the media at a press conference for Super Bowl LIII at Hyatt Regency Atlanta. Mandatory Credit: Brett Davis-USA TODAY Sports" data-portal-copyright="Brett Davis-USA TODAY Sports"/></p> <p></p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Report: Chiefs ban fan they say aimed laser at Brady</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12086241.jpg" width="1100" height="733" alt="" title="Jan 31, 2019; Atlanta, GA, USA; New England Patriots quarterback Tom Brady (12) addresses the media at a press conference for Super Bowl LIII at Hyatt Regency Atlanta. Mandatory Credit: Brett Davis-USA TODAY Sports" data-portal-copyright="Brett Davis-USA TODAY Sports"></p><p> A Kansas City Chiefs fan who allegedly aimed a laser pointer at New England Patriots quarterback Tom Brady during the AFC championship game soon will face legal charges, according to ESPN&#8217;s Adam Schefter. </p> </p><p> The Chiefs, Schefter said, were able to identify the fan through eyewitness accounts and videotapes. They are not waiting for a verdict in court, however. The team already has issued a lifetime ban at Arrowhead Stadium for the fan, and the Chiefs reportedly are pushing for &#8220;the harshest penalty possible&#8221; to deter similar incidents in the future. </p> </p><p> Local police reportedly initially wanted to charge the fan with disorderly conduct. </p> </p><p> The NFL had said it would investigate a report by a Kansas City television station that showed the incident. KMBC shot video that showed a green dot flickering around Brady&#8217;s shoulder and face before he threw an interception in the fourth quarter. </p> </p><p> The Patriots declined to comment on the report, and the Chiefs said they were not aware of the incident during the game, which New England won 37-31 in overtime. </p> </p><p> The Patriots face the Los Angeles Rams on Sunday in Super Bowl LIII at 6:30 p.m. ET. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Report: Chiefs ban fan they say aimed laser at Brady');return false;"><span class="op-btn">Read More</span> <span class="count">143 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-chiefs-ban-fan-they-say-aimed-laser-at-brady%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Chiefs ban fan they say aimed laser at Brady+http://nfp.news/11oi" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Chiefs ban fan they say aimed laser at Brady&#32;&#32;http://nfp.news/11oi" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11oi"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/nfl-notebook-mahomes-takes-home-mvp/" rel="bookmark" title="NFL notebook: Mahomes takes home MVP">NFL notebook: Mahomes takes home MVP</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-notebook-mahomes-takes-home-mvp/"/><meta itemprop="datePublished" content="23 hours ago"/><meta itemprop="dateModified" content="22 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>NFL notebook: Mahomes takes home MVP</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12099350.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Atlanta, GA, USA; Most Valuable Player winner Patrick Mahomes of the Kansa City Chiefs during media availabilities for the NFL Honors show at the Fox Theatre. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"/></p> <p> Kansas City Chiefs</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>NFL notebook: Mahomes takes home MVP</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12099350.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Atlanta, GA, USA; Most Valuable Player winner Patrick Mahomes of the Kansa City Chiefs during media availabilities for the NFL Honors show at the Fox Theatre. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"></p><p> Kansas City Chiefs quarterback Patrick Mahomes was the overwhelming pick for NFL MVP while also winning Offensive Player of the Year in the end-of-year Associated Press awards, handed out Saturday night in Atlanta at the NFL Honors ceremony. </p> </p><p> Los Angeles Rams standout Aaron Donald repeated as AP Defensive Player of the Year. </p> </p><p> New York Giants running back Saquon Barkley won AP Offensive Rookie of the Year, and AP Defensive Rookie of the Year went to Indianapolis Colts linebacker Darius Leonard. </p> </p><p> Chicago Bears coach Matt Nagy won AP Coach of the Year, and Colts quarterback Andrew Luck received the AP Comeback Player of the Year honor. </p> </p><p> &#8211;Tight end Tony Gonzalez and safety Ed Reed highlight the eight-man class that earned induction into the Pro Football Hall of Fame. </p> </p><p> Reed was one of four defensive backs who will be inducted on Aug. 3 in Canton, Ohio. The others were cornerbacks Champ Bailey and Ty Law and safety Johnny Robinson. </p> </p><p> Also selected for enshrinement were center Kevin Mawae, Broncos owner Pat Bowlen and personnel executive Gil Brandt during a process held in Atlanta one day prior to the Super Bowl. </p> </p><p> &#8211;The Philadelphia Eagles reportedly will pick up quarterback Nick Foles&#8217; $20 million contract option for 2019. </p> </p><p> NFL Network&#8217;s Ian Rapoport reported there is no guarantee, however, that Foles remains with the team and laid out the possible options. ESPN&#8217;s Adam Schefter reported the franchise tag is expected for Foles and that other teams have contacted the Eagles about his potential availability. </p> </p><p> Foles, 30, led the Eagles to the playoffs two consecutive seasons after injuries to starter Carson Wentz. Philadelphia won its first-ever Super Bowl following the 2017 season and lost this year to New Orleans in the NFL divisional round. </p> </p><p> &#8211;NFL commissioner Roger Goodell is happy to see a drop in the number of diagnosed concussions this season and said he thinks the new rule against lowering the helmet to initiate contact was a big part of that. </p> </p><p> There was a 24 percent decline in concussions in the preseason and regular season, from 281 in 2017 to 214 this season. For the regular season only, there was a 29 percent decrease from 190 in 2017 to 135. </p> </p><p> Speaking at Georgia Tech ahead of the Super Bowl in Atlanta, Goodell credited the league&#8217;s approach for the reduction. &#8220;I think we&#8217;ve been effective. I give credit to the players and coaches for the way they&#8217;ve played the game,&#8221; he said, per ProFootballTalk. </p> </p><p> &#8211;Future Hall of Fame receiver Larry Fitzgerald said he doesn&#8217;t believe challenges and replays should apply to potential pass interference calls. </p> </p><p> &#8220;I personally don&#8217;t believe there should be review of plays like that. It&#8217;s a bang-bang play,&#8221; Fitzgerald told the audience at Georgia Tech, per ProFootballTalk. &#8220;It&#8217;s very subjective, it&#8217;s happening so fast. These officials are put in really tough positions. I just don&#8217;t think we should do that.&#8221; </p> </p><p> The NFL&#8217;s competition committee is expected to discuss the possibility of a rule change to allow coaches to challenge pass interference calls. The NFL has admitted missing the call in the NFC Championship Game, potentially costing the New Orleans Saints a chance to play in the Super Bowl. </p> </p><p> &#8211;Los Angeles Rams quarterbacks coach Zac Taylor is expected to be in Cincinnati on Monday to complete the process of becoming the head coach of the Bengals, according to NFL Network&#8217;s Tom Pelissero. </p> </p><p> The expectation the Bengals would hire Taylor, 35, has been known for weeks, but nothing could be made official until after the Super Bowl because of the Rams&#8217; participation. </p> </p><p> This will be the first head coaching job for Taylor and also the first change at the Bengals&#8217; helm since before the 2003 season, when Marvin Lewis took over. The Bengals fired Lewis in December following the team&#8217;s third straight sub-.500 season. </p> </p><p> &#8211;The morning after the Super Bowl, Brian Flores will fly to Miami and finalize terms to become the Dolphins&#8217; new head coach, according to multiple reports. </p> </p><p> Flores, 37, currently coaches linebackers for the New England Patriots, but that gig will end Sunday against the Los Angeles Rams in Super Bowl LIII. </p> </p><p> There also are multiple reports that former New England assistant Patrick Graham (2009-15) and current receivers coach Chad O&#8217;Shea will join Flores with the Dolphins. Graham reportedly will become defensive coordinator, and O&#8217;Shea will serve as offensive coordinator. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','NFL notebook: Mahomes takes home MVP');return false;"><span class="op-btn">Read More</span> <span class="count">650 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-notebook-mahomes-takes-home-mvp%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL notebook: Mahomes takes home MVP+http://nfp.news/11nr" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL notebook: Mahomes takes home MVP&#32;&#32;http://nfp.news/11nr" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11nr"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/report-eagles-likely-to-pick-up-foles-option/" rel="bookmark" title="Report: Eagles likely to pick up Foles&#8217; option">Report: Eagles likely to pick up Foles&#8217; option</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-eagles-likely-to-pick-up-foles-option/"/><meta itemprop="datePublished" content="2019-02-02"/><meta itemprop="dateModified" content="2019-02-02"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Report: Eagles likely to pick up Foles' option</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12036732.jpg" width="1100" height="686" alt="" title="Jan 13, 2019; New Orleans, LA, USA; Philadelphia Eagles quarterback Nick Foles (9) makes a throw during the third quarter of a NFC Divisional playoff football game against the New Orleans Saints at Mercedes-Benz Superdome. Mandatory Credit: Chuck Cook-USA TODAY Sports" data-portal-copyright="Chuck</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Report: Eagles likely to pick up Foles&#8217; option</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12036732.jpg" width="1100" height="686" alt="" title="Jan 13, 2019; New Orleans, LA, USA; Philadelphia Eagles quarterback Nick Foles (9) makes a throw during the third quarter of a NFC Divisional playoff football game against the New Orleans Saints at Mercedes-Benz Superdome. Mandatory Credit: Chuck Cook-USA TODAY Sports" data-portal-copyright="Chuck Cook-USA TODAY Sports"></p><p> The Philadelphia Eagles reportedly will pick up quarterback Nick Foles&#8217; $20 million contract option for 2019. </p> </p><p> NFL Network&#8217;s Ian Rapoport reported Saturday that there is no guarantee, however, that Foles remains with the team and laid out the possible options. </p> </p><p> Once the option is exercised, Foles could pay the Eagles $2 million to buy his way out of the contract to become a free agent. But, Rapoport said, Philadelphia at that point could put the franchise tag on Foles and search for a trade partner. </p> </p><p> ESPN&#8217;s Adam Schefter reported Saturday that the franchise tag is expected for Foles and that other teams have contacted the Eagles about his potential availability. </p> </p><p> If the Eagles, however, allow him to become a free agent, they would receive a compensatory draft pick, Rapoport said. </p> </p><p> &#8220;Either way, it&#8217;s a little bit of a game of chicken right now,&#8221; he said. &#8220;We do not know how the Eagles are going to proceed after Foles gives them $2 million back for his freedom.&#8221; </p> </p><p> Foles, 30, led the Eagles to the playoffs two consecutive seasons after injuries to starter Carson Wentz. Philadelphia won its first-ever Super Bowl following the 2017 season and lost this year to New Orleans in the NFL divisional round. </p> </p><p> After the 2018 season, Eagles coach Doug Pederson said Wentz would be the starting quarterback in 2019. </p> </p><p> Over the past two seasons, Foles has appeared in 12 games for the Eagles, starting eight, and has a 6-2 record. He has thrown for 1,950 yards, with 12 touchdowns and six interceptions in that span. </p> </p><p> He led the Eagles to a 41-33 win over the New England Patriots in Super Bowl LII and was named MVP after completing 28 of 43 passes for 373 yards with three touchdowns and an interception. He also caught a touchdown pass on a trick play. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Report: Eagles likely to pick up Foles&#8217; option');return false;"><span class="op-btn">Read More</span> <span class="count">241 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-eagles-likely-to-pick-up-foles-option%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Eagles likely to pick up Foles’ option+http://nfp.news/11nl" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Eagles likely to pick up Foles&#8217; option&#32;&#32;http://nfp.news/11nl" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11nl"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/patriots-pool-report-belichick-not-a-fan-of-super-bowl-pace/" rel="bookmark" title="Patriots pool report: Belichick not a fan of Super Bowl pace">Patriots pool report: Belichick not a fan of Super Bowl pace</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/patriots-pool-report-belichick-not-a-fan-of-super-bowl-pace/"/><meta itemprop="datePublished" content="2019-02-02"/><meta itemprop="dateModified" content="2019-02-02"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Patriots pool report: Belichick not a fan of Super Bowl pace</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12086236-1.jpg" width="1100" height="733" alt="" title="Jan 31, 2019; Atlanta, GA, USA; New England Patriots head coach Bill Belichick addresses the media at a press conference for Super Bowl LIII at Hyatt Regency Atlanta. Mandatory Credit: Brett Davis-USA TODAY Sports" data-portal-copyright="Brett Davis-USA TODAY Sports"/></p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Patriots pool report: Belichick not a fan of Super Bowl pace</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12086236-1.jpg" width="1100" height="733" alt="" title="Jan 31, 2019; Atlanta, GA, USA; New England Patriots head coach Bill Belichick addresses the media at a press conference for Super Bowl LIII at Hyatt Regency Atlanta. Mandatory Credit: Brett Davis-USA TODAY Sports" data-portal-copyright="Brett Davis-USA TODAY Sports"></p><p> ATLANTA &#8211; For a few minutes Saturday morning, Bill Belichick&#8217;s top concern was opening a bag of macadamia nuts for his 2-year-old granddaughter, Blakely. The Patriots coach has spent the past two weeks preparing for Super Bowl LIII, which included stashing some snack packs in his pants pocket in case of a hungry toddler. </p> </p><p> Blakely, the daughter of Belichick&#8217;s son, Steve, was born in October 2016, so this will be her third Super Bowl before she turns 3. </p> </p><p> &#8220;She&#8217;s starting off fast,&#8221; Belichick said. </p> </p><p> Blakely was one of more than 800 friends and family who joined the Patriots players, coaches, front office and staff at Mercedes-Benz Stadium on Saturday morning. After finishing a week of practice at Georgia Tech, the Patriots did not hold a walk-through or practice on Saturday, but instead came to the site of the game for team photos and a gathering with their guests. This is the same routine they have followed in previous Super Bowls. </p> </p><p> &#8220;This breaks up the day and lets them participate in it with their families,&#8221; Belichick said. &#8220;This is a dream for every player to play in this game, so to be able to share it with loved ones and family is special. We have tried to embrace it.&#8221; </p> </p><p> The entire 53-person active roster and 10-person practice squad were present, along with players on injured reserve, including running back Jeremy Hill and defensive back Eric Rowe. The Patriots have no players with an injury designation for the final game of the season. </p> </p><p> &#8220;Everybody is good,&#8221; Belichick said. </p> </p><p> The Patriots buses, escorted by police, pulled up to Mercedes-Benz Stadium at 10:40 a.m. ET and filed inside. Quarterback Tom Brady was in the middle of the pack, holding the hand of his 6-year-old daughter, Vivian, with his wife and two sons walking close by. Brady spotted former teammate and Hall of Fame nominee Richard Seymour, who rode in with the team, and wrapped him in a warm embrace. </p> </p><p> The players changed into the white jerseys and navy pants they&#8217;ll wear in the game and walked out onto the field for photos. Brady kneeled for the quarterbacks&#8217; picture, prompting a few staff members to playfully call out to him that he looked like he was posing for a Pop Warner photo. Belichick stood next to the team photographer, smiling as he watched each position group line up with their arms around each other. </p> </p><p> &#8220;It&#8217;s fun to see them having fun,&#8221; Belichick said. &#8220;They&#8217;ve earned it. You&#8217;ve gotta earn your way here; there is no other way to get here. So it&#8217;s very satisfying to see them having fun and enjoying each other and having the camaraderie that comes with getting to the game.&#8221; </p> </p><p> Brady and Belichick posed for a photo with team owner Robert Kraft and his son, Jonathan, the team president. Then, the entire team climbed onto a stack of risers for the customary team photo. As the </p><p> Patriots families and friends came down onto the field, they took a final team picture with several players and coaches holding their young children, who were carefully passed up the rows. For the next 40 minutes, they all mingled on the field. Brady met up with his parents and sisters, while Vivian did cartwheels nearby. The traveling party of Devin and Jason McCourty, the first twins to play together in the Super Bowl, sported shirts that read, &#8220;All we do is twin,&#8221; with &#8220;win&#8221; printed in contrasting red letters. </p> </p><p> During their visit, Belichick was taking mental notes about the stadium, which opened in 2017. The Patriots have not played here before. </p> </p><p> Belichick added that he did not think noise would be as big of a factor this week as in the conference championship game at Arrowhead Stadium. &#8220;The stadium is so big,&#8221; he said. &#8220;It&#8217;s going to be loud, but I don&#8217;t think it is going to be deafening loud, just because of the size of it and because the crowd is half and half, not all 80,000 against us.&#8221; </p> </p><p> Belichick said it usually takes him three days to get through all the reminders he gives his team before the game, covering topics such as the pacing of the game, which will have 11 commercials in each half and a 29-minute halftime. &#8220;There&#8217;s no momentum to it,&#8221; he said. &#8220;It&#8217;s like going to a traffic light, stop, traffic light, stop &#8212; that kind of thing. But that&#8217;s the game, so you&#8217;ve gotta play it that way.&#8221; </p> </p><p> He will gather the team for a team meeting Saturday night and another one Sunday morning, before heading to the stadium. Belichick said there will be no special guests at the meeting the night before the game. </p> </p><p> &#8220;Just us circling the wagons and playing for each other,&#8221; he said. &#8220;We are playing a good team, and we are going to have to play our best game of the year.&#8221; </p> </p><p> &#8211;By Jenny Vrentas, Pro Football Writers of America</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Patriots pool report: Belichick not a fan of Super Bowl pace');return false;"><span class="op-btn">Read More</span> <span class="count">762 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpatriots-pool-report-belichick-not-a-fan-of-super-bowl-pace%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Patriots pool report: Belichick not a fan of Super Bowl pace+http://nfp.news/11nm" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Patriots pool report: Belichick not a fan of Super Bowl pace&#32;&#32;http://nfp.news/11nm" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11nm"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/gonzalez-reed-head-8-person-hall-of-fame-class/" rel="bookmark" title="Gonzalez, Reed head 8-person Hall of Fame class">Gonzalez, Reed head 8-person Hall of Fame class</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/gonzalez-reed-head-8-person-hall-of-fame-class/"/><meta itemprop="datePublished" content="2019-02-02"/><meta itemprop="dateModified" content="2019-02-02"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Gonzalez, Reed head 8-person Hall of Fame class</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/9853953-1.jpg" width="1100" height="785" alt="" title="Feb 2, 2017; Houston, TX, USA; Kansas City Chiefs former tight end Tony Gonzalez is interviewed on radio row at the George R. Brown Convention Center in preparation for Super Bowl LI. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Gonzalez, Reed head 8-person Hall of Fame class</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/9853953-1.jpg" width="1100" height="785" alt="" title="Feb 2, 2017; Houston, TX, USA; Kansas City Chiefs former tight end Tony Gonzalez is interviewed on radio row at the George R. Brown Convention Center in preparation for Super Bowl LI. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"></p><p> Tight end Tony Gonzalez and safety Ed Reed highlight the eight-man class that earned induction into the Pro Football Hall of Fame on Saturday. </p> </p><p> Gonzalez is the all-time leader in receptions and yardage among tight ends with 1,325 catches and 15,127 yards. He played for the Kansas City Chiefs (1997-2008) and Atlanta Falcons (2009-13) during a 17-year playing career. </p> </p><p> Reed led the NFL in interceptions three times and had 64 career interceptions, while playing 11 of his 12 NFL seasons with the Baltimore Ravens from 2002-12. </p> </p><p> Reed was one of four defensive backs who will be inducted on Aug. 3 in Canton, Ohio. The others were cornerbacks Champ Bailey and Ty Law, and safety Johnny Robinson. </p> </p><p> Robinson was the seniors finalist. </p> </p><p> Also selected for enshrinement were center Kevin Mawae, Broncos owner Pat Bowlen and personnel executive Gil Brandt. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Gonzalez, Reed head 8-person Hall of Fame class');return false;"><span class="op-btn">Read More</span> <span class="count">83 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fgonzalez-reed-head-8-person-hall-of-fame-class%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Gonzalez, Reed head 8-person Hall of Fame class+http://nfp.news/11nn" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Gonzalez, Reed head 8-person Hall of Fame class&#32;&#32;http://nfp.news/11nn" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11nn"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/fowler-takes-command-in-phoenix-open/" rel="bookmark" title="Fowler takes command in Phoenix Open">Fowler takes command in Phoenix Open</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/fowler-takes-command-in-phoenix-open/"/><meta itemprop="datePublished" content="2019-02-02"/><meta itemprop="dateModified" content="2019-02-02"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Fowler takes command in Phoenix Open</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12098320.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Scottsdale, AZ, USA; Rickie Fowler plays his tee shot on the par 3 16th hole during the third round of the Waste Management Phoenix Open golf tournament at TPC Scottsdale. Mandatory Credit: Allan Henry-USA TODAY Sports" data-portal-copyright="Allan Henry-USA TODAY Sports"/></p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Fowler takes command in Phoenix Open</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12098320.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Scottsdale, AZ, USA; Rickie Fowler plays his tee shot on the par 3 16th hole during the third round of the Waste Management Phoenix Open golf tournament at TPC Scottsdale. Mandatory Credit: Allan Henry-USA TODAY Sports" data-portal-copyright="Allan Henry-USA TODAY Sports"></p><p> Rickie Fowler threatened to run away with the Waste Management Phoenix Open, shooting a 7-under-par 64 on Saturday in the third round at Scottsdale, Ariz. </p> </p><p> Fowler is at 20-under 193 for the tournament, four shots in front of second-place Matt Kuchar, going into Sunday&#8217;s final round. </p> </p><p> Thanks to birdies on four of his first six holes in the third round, Fowler matched his first-round score. </p> </p><p> Fowler had just one bogey in the round, giving him the best score turned in by any of the 73 golfers who made the cut. </p> </p><p> The 30-year-old California will be aiming for his fifth victory on the PGA Tour. </p> </p><p> Kuchar, who won last month&#8217;s Sony Open in Hawaii, notched birdies on each of the three par-5 holes. He carded a bogey-free round for his second consecutive round of 6 under par. </p> </p><p> Justin Thomas (3 under on Saturday) is at 15 under after failing to keep pace with Fowler. Thomas was a first-round co-leader. </p> </p><p> Thomas, who was a shot back entering the third round, was at 1 over for the day through 10 holes before rallying with four birdies the rest of the way. </p> </p><p> Fowler and Thomas are sharing a house during this tournament, and they will be in the same grouping again on the final day of the event. </p> </p><p> South Africa&#8217;s Branden Grace (3 under) and South Korea&#8217;s Byeong Hun An (6 under) are at 13 under overall. An re-emerged among the strong contenders with birdies on three of the last four holes. </p> </p><p> Defending champion Gary Woodland stayed on the leaderboard. He shot 5 under on Saturday to move to 12 under and into a tie for sixth place with Bubba Watson (3 under). </p> </p><p> Harold Varner III, who was a first-round co-leader, recovered with a round of 3 under after shooting even par on Friday. He&#8217;s one of four golfers tied for eighth place at 10 under. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Fowler takes command in Phoenix Open');return false;"><span class="op-btn">Read More</span> <span class="count">245 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Ffowler-takes-command-in-phoenix-open%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Fowler takes command in Phoenix Open+http://nfp.news/11no" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Fowler takes command in Phoenix Open&#32;&#32;http://nfp.news/11no" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11no"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/nfl-awards-mahomes-runaway-winner-as-mvp/" rel="bookmark" title="NFL awards: Mahomes runaway winner as MVP">NFL awards: Mahomes runaway winner as MVP</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-awards-mahomes-runaway-winner-as-mvp/"/><meta itemprop="datePublished" content="2019-02-02"/><meta itemprop="dateModified" content="2019-02-02"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>NFL awards: Mahomes runaway winner as MVP</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12098285-2.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Atlanta, GA, USA; Patrick Mahomes during red carpet arrivals for the NFL Honors show at the Fox Theatre. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"/></p> <p> Kansas City Chiefs quarterback Patrick Mahomes was selected the NFL's</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>NFL awards: Mahomes runaway winner as MVP</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12098285-2.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Atlanta, GA, USA; Patrick Mahomes during red carpet arrivals for the NFL Honors show at the Fox Theatre. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"></p><p> Kansas City Chiefs quarterback Patrick Mahomes was selected the NFL&#8217;s Most Valuable Player as the end-of-year Associated Press accolades were announced Saturday in Atlanta. </p> </p><p> Mahomes also took home AP Offensive Player of the Year honors, and Los Angeles Rams defensive tackle Aaron Donald captured his second consecutive AP Defensive Player of the Year award. </p> </p><p> New York Giants running back Saquon Barkley won AP Offensive Rookie of the Year, Chicago Bears coach Matt Nagy was selected AP Coach of the Year, and Indianapolis Colts quarterback Andrew Luck received the AP Comeback Player of the Year. </p> </p><p> Philadelphia Eagles defensive end Chris Long received the prestigious Walter Payton Man of the Year award, which honors players&#8217; community service. </p> </p><p> Mahomes threw for 50 touchdowns and 5,097 yards in his first season as the Chiefs&#8217; starting quarterback. The second-year player led Kansas City to the AFC Championship Game. </p> </p><p> He received 41 MVP votes. New Orleans Saints quarterback Drew Brees finished second with nine MVP votes. </p> </p><p> The same duo came in No. 1 and No. 2 in voting for Offensive Player of the Year, with Mahomes getting 30 votes and Brees capturing 16. </p> </p><p> Donald, who had a league-best 20.5 sacks in the regular season, helped lead the Rams to the Super Bowl. He received 45 votes for the top defensive performer, with Bears pass rusher Khalil Mack coming in second with five votes. </p> </p><p> Barkley, the second overall draft pick in the 2018 draft, lived up to his billing by rushing for 1,307 yards and 11 touchdowns in his first pro season. </p> </p><p> Nagy was the runaway winner for Coach of the Year after leading the Bears to a 12-4 record and the NFC North division title in his debut season. Nagy got 24 votes; Anthony Lynn of the Los Angeles Chargers came in a distant second with just 10. </p> </p><p> Luck, too, was a runaway winner for Comeback Player of the year. He finished second in the league in touchdown passes (39) after missing the entire 2017 season with a shoulder injury. Luck threw for 4,593 yards in leading the Colts to 10-6 record and a wild-card playoff berth. Luck got 44 votes, and Houston&#8217;s J.J. Watt was second with four votes. </p> </p><p> Nagy&#8217;s defensive coordinator, Vic Fangio, earned assistant coach of the year honors. Fangio accepted a head-coaching position with the Denver Broncos in the offseason. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','NFL awards: Mahomes runaway winner as MVP');return false;"><span class="op-btn">Read More</span> <span class="count">321 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-awards-mahomes-runaway-winner-as-mvp%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL awards: Mahomes runaway winner as MVP+http://nfp.news/11np" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL awards: Mahomes runaway winner as MVP&#32;&#32;http://nfp.news/11np" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11np"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/nfl-awards-mahomes-donald-earn-poy-honors/" rel="bookmark" title="NFL awards: Mahomes, Donald earn POY honors">NFL awards: Mahomes, Donald earn POY honors</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-awards-mahomes-donald-earn-poy-honors/"/><meta itemprop="datePublished" content="2019-02-02"/><meta itemprop="dateModified" content="2019-02-02"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>NFL awards: Mahomes, Donald earn POY honors</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12098285-1.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Atlanta, GA, USA; Patrick Mahomes during red carpet arrivals for the NFL Honors show at the Fox Theatre. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"/></p> <p> Kansas City Chiefs quarterback Patrick Mahomes took home Offensive Player</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>NFL awards: Mahomes, Donald earn POY honors</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12098285-1.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Atlanta, GA, USA; Patrick Mahomes during red carpet arrivals for the NFL Honors show at the Fox Theatre. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"></p><p> Kansas City Chiefs quarterback Patrick Mahomes took home Offensive Player of the Year honors and Los Angeles Rams defensive tackle Aaron Donald captured his second consecutive Defensive Player of the Year award on Saturday as the end-of-year Associated Press NFL accolades were announced. </p> </p><p> New York Giants running back Saquon Barkley won AP Offensive Rookie of the Year, Chicago Bears coach Matt Nagy was selected AP Coach of the Year, and Indianapolis Colts quarterback Andrew Luck received the AP Comeback Player of the Year. </p> </p><p> Mahomes threw for 50 touchdowns and 5,097 yards in his first season as the Chiefs&#8217; starting quarterback. The second-year player led Kansas City to the AFC Championship Game. </p> </p><p> Donald, who had a league-best 20.5 sacks in the regular season, helped lead the Rams to the Super Bowl. He received 45 votes for the top defensive performer, with Bears pass rusher Khalil Mack coming in second with five votes. </p> </p><p> Barkley, the second overall draft pick in the 2018 draft, lived up to his billing by rushing for 1,307 yards and 11 touchdowns in his first pro season. </p> </p><p> Nagy was the runaway winner for Coach of the Year after leading the Bears to a 12-4 record and the NFC North division title in his debut season. Nagy got 24 votes; Anthony Lynn of the Los Angeles Chargers came in a distant second with just 10. </p> </p><p> Luck, too, was a runaway winner for Comeback Player of the year. He finished second in the league in touchdown passes (39) after missing the entire 2017 season with a shoulder injury. Luck threw for 4,593 yards in leading the Colts to 10-6 record and a wild-card playoff berth. Luck got 44 votes, and Houston&#8217;s J.J. Watt was second with four votes. </p> </p><p> Nagy&#8217;s defensive coordinator, Vic Fangio, earned assistant coach of the year honors. Fangio accepted a head-coaching position with the Denver Broncos in the offseason. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','NFL awards: Mahomes, Donald earn POY honors');return false;"><span class="op-btn">Read More</span> <span class="count">250 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-awards-mahomes-donald-earn-poy-honors%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL awards: Mahomes, Donald earn POY honors+http://nfp.news/11nk" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL awards: Mahomes, Donald earn POY honors&#32;&#32;http://nfp.news/11nk" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11nk"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/nfl-awards-mahomes-takes-offensive-poy/" rel="bookmark" title="NFL awards: Mahomes takes offensive POY">NFL awards: Mahomes takes offensive POY</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-awards-mahomes-takes-offensive-poy/"/><meta itemprop="datePublished" content="2019-02-02"/><meta itemprop="dateModified" content="2019-02-02"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>NFL awards: Mahomes takes offensive POY</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12098285.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Atlanta, GA, USA; Patrick Mahomes during red carpet arrivals for the NFL Honors show at the Fox Theatre. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"/></p> <p> Kansas City Chiefs quarterback Patrick Mahomes took home Offensive Player of</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>NFL awards: Mahomes takes offensive POY</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12098285.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Atlanta, GA, USA; Patrick Mahomes during red carpet arrivals for the NFL Honors show at the Fox Theatre. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"></p><p> Kansas City Chiefs quarterback Patrick Mahomes took home Offensive Player of the Year honors and New York Giants running back Saquon Barkley Offensive Rookie of the Year in the end of year Associated Press awards. </p> </p><p> Chicago Bears coach Matt Nagy won AP Coach of the Year, and Indianapolis Colts quarterback Andrew Luck received the AP Comeback Player of the Year. </p> </p><p> Mahomes threw for 50 touchdowns and 5,097 yards in his first season as the Chiefs&#8217; starting quarterback. The second-year player led Kansas City to the AFC Championship Game. </p> </p><p> Barkley, the second overall draft pick in the 2018 draft, lived up to his billing by rushing for 1,307 yards and 11 touchdowns in his first pro season. </p> </p><p> Nagy was the runaway winner for Coach of the Year after leading the Bears to a 12-4 record and the NFC North division title in his debut season. Nagy got 24 votes; Anthony Lynn of the Los Angeles Chargers came in a distant second with just 10. </p> </p><p> Luck, too, was a runaway winner for Comeback Player of the year. He finished second in the league in touchdown passes (39) after missing the entire 2017 season with a shoulder injury. Luck threw for 4,593 yards in leading the Colts to 10-6 record and a wild-card playoff berth. Luck got 44 votes, and Houston&#8217;s J.J. Watt was second with four votes. </p> </p><p> Nagy&#8217;s defensive coordinator, Vic Fangio, earned assistant coach of the year honors. Fangio accepted a head-coaching position with the Denver Broncos in the offseason. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','NFL awards: Mahomes takes offensive POY');return false;"><span class="op-btn">Read More</span> <span class="count">188 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-awards-mahomes-takes-offensive-poy%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL awards: Mahomes takes offensive POY+http://nfp.news/11nq" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL awards: Mahomes takes offensive POY&#32;&#32;http://nfp.news/11nq" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11nq"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/bengals-expected-to-name-taylor-coach-on-monday/" rel="bookmark" title="Bengals expected to name Taylor coach on Monday">Bengals expected to name Taylor coach on Monday</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/bengals-expected-to-name-taylor-coach-on-monday/"/><meta itemprop="datePublished" content="2019-02-02"/><meta itemprop="dateModified" content="2019-02-02"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Bengals expected to name Taylor coach on Monday</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/10476065.jpg" width="1100" height="872" alt="" title="Dec 3, 2017; Glendale, AZ, USA; Los Angeles Rams assistant wide receivers coach Zac Taylor against the Arizona Cardinals at University of Phoenix Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports"/></p> <p> Los Angeles Rams quarterbacks</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Bengals expected to name Taylor coach on Monday</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/10476065.jpg" width="1100" height="872" alt="" title="Dec 3, 2017; Glendale, AZ, USA; Los Angeles Rams assistant wide receivers coach Zac Taylor against the Arizona Cardinals at University of Phoenix Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports"></p><p> Los Angeles Rams quarterbacks coach Zac Taylor is expected to be in Cincinnati on Monday to complete the process of becoming the head coach of the Bengals, according to NFL Network&#8217;s Tom Pelissero. </p> </p><p> The expectation the Bengals would hire Taylor, 35, has been known for weeks, but nothing could be made official until after the Super Bowl because of the Rams&#8217; participation. </p> </p><p> This will be the first head coaching job for Taylor and also the first change at the Bengals&#8217; helm since before the 2003 season, when Marvin Lewis took over. The Bengals fired Lewis in December following the team&#8217;s third straight sub-.500 season. </p> </p><p> Taylor was with the Rams for two seasons, the first as assistant wide receivers coach. He spent four seasons coaching quarterbacks with the Miami Dolphins (2012-15) and doubled as interim offensive coordinator in his final season there. In 2016, he was the offensive coordinator at the University of Cincinnati. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Bengals expected to name Taylor coach on Monday');return false;"><span class="op-btn">Read More</span> <span class="count">101 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fbengals-expected-to-name-taylor-coach-on-monday%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Bengals expected to name Taylor coach on Monday+http://nfp.news/11nh" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Bengals expected to name Taylor coach on Monday&#32;&#32;http://nfp.news/11nh" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11nh"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/report-flores-set-to-be-introduced-as-dolphins-coach-on-monday/" rel="bookmark" title="Report: Flores set to be introduced as Dolphins&#8217; coach on Monday">Report: Flores set to be introduced as Dolphins&#8217; coach on Monday</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-flores-set-to-be-introduced-as-dolphins-coach-on-monday/"/><meta itemprop="datePublished" content="2019-02-02"/><meta itemprop="dateModified" content="2019-02-02"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Report: Flores set to be introduced as Dolphins' coach on Monday</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12038396.jpg" width="1100" height="733" alt="" title="Jan 20, 2019; Kansas City, MO, USA; New England Patriots linebackers coach Brian Flores walks to the field before the AFC Championship game between the Kansas City Chiefs and the New England Patriots at Arrowhead Stadium. Mandatory Credit: Mark</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Report: Flores set to be introduced as Dolphins&#8217; coach on Monday</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12038396.jpg" width="1100" height="733" alt="" title="Jan 20, 2019; Kansas City, MO, USA; New England Patriots linebackers coach Brian Flores walks to the field before the AFC Championship game between the Kansas City Chiefs and the New England Patriots at Arrowhead Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports"></p><p> The morning after the Super Bowl, Brian Flores will fly to Miami and finalize terms to become the Dolphins&#8217; new head coach, according to multiple reports. </p> </p><p> Flores currently coaches linebackers for the New England Patriots, but that gig will end Sunday against the Los Angeles Rams in Super Bowl LIII. </p> </p><p> It is no secret that the 37-year-old Flores is set to become the Dolphins&#8217; coach and the organization plans to officially introduce him on Monday, according to the Miami Herald. </p> </p><p> There also are multiple reports that former New England assistant Patrick Graham (2009-15) and current receivers coach Chad O&#8217;Shea will join Flores with the Dolphins. Graham reportedly will become defensive coordinator and O&#8217;Shea will serve as offensive coordinator. </p> </p><p> Graham was linebackers coach of the Green Bay Packers in 2018. O&#8217;Shea is finishing his 10th season with New England. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Report: Flores set to be introduced as Dolphins&#8217; coach on Monday');return false;"><span class="op-btn">Read More</span> <span class="count">91 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-flores-set-to-be-introduced-as-dolphins-coach-on-monday%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Flores set to be introduced as Dolphins’ coach on Monday+http://nfp.news/11ni" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Flores set to be introduced as Dolphins&#8217; coach on Monday&#32;&#32;http://nfp.news/11ni" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11ni"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/pga-tour-rescinds-two-stroke-penalty-for-mccarthy/" rel="bookmark" title="PGA Tour rescinds two-stroke penalty for McCarthy">PGA Tour rescinds two-stroke penalty for McCarthy</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/pga-tour-rescinds-two-stroke-penalty-for-mccarthy/"/><meta itemprop="datePublished" content="2019-02-02"/><meta itemprop="dateModified" content="2019-02-02"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>PGA Tour rescinds two-stroke penalty for McCarthy</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12014393.jpg" width="1100" height="732" alt="" title="Jan 17, 2019; La Quinta, CA, USA; Denny McCarthy plays his shot from the ninth tee during the first round of the Desert Classic golf tournament at Nicklaus Tournament Course. Mandatory Credit: Orlando Ramirez-USA TODAY Sports" data-portal-copyright="Orlando Ramirez-USA TODAY Sports"/></p> <p> On</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>PGA Tour rescinds two-stroke penalty for McCarthy</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12014393.jpg" width="1100" height="732" alt="" title="Jan 17, 2019; La Quinta, CA, USA; Denny McCarthy plays his shot from the ninth tee during the first round of the Desert Classic golf tournament at Nicklaus Tournament Course. Mandatory Credit: Orlando Ramirez-USA TODAY Sports" data-portal-copyright="Orlando Ramirez-USA TODAY Sports"></p><p> On second thought, the PGA Tour decided Saturday against imposing a two-stroke penalty on Denny McCarthy after his caddie appeared to help him line up a shot during Friday&#8217;s second round of the Waste Management Phoenix Open. </p> </p><p> After hitting his second shot into the water at the par-15 15th hole at the TPC Scottsdale course, McCarthy lined up for his fourth shot with his caddie behind him. McCarthy then stepped back from the ball and lined up again on his own before hitting the shot. </p> </p><p> Rule 10.2b (4), put in play for the 2019 season, states that a caddie &#8220;cannot deliberately stand in location on or close to an extension of the line of play behind the ball for any reason.&#8221; A similar violation was in question for Justin Thomas. </p> </p><p> But after a day to think about the McCarthy violation, the PGA Tour, in an official statement, declined to penalize McCarthy and would not take action against Thomas. A similar violation was called against Haotong Li at last week&#8217;s Dubai Desert Classic. </p> </p><p> The PGA Tour reconsidered the latest violation by saying, &#8220;In each of these cases, when the caddie was standing behind the player, the player had not yet begun taking the stance for the stroke, nor could useful guidance on aiming be given because the player was still in the process of determining how to play the stroke.&#8221; </p> </p><p> The statement said the PGA Tour will work &#8220;in the coming days&#8221; to better interpret and apply the new rule. </p> </p><p> By giving McCarthy back the two strokes, he stood at 8 under par instead of 6 under after 36 holes. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','PGA Tour rescinds two-stroke penalty for McCarthy');return false;"><span class="op-btn">Read More</span> <span class="count">214 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpga-tour-rescinds-two-stroke-penalty-for-mccarthy%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=PGA Tour rescinds two-stroke penalty for McCarthy+http://nfp.news/11nj" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=PGA Tour rescinds two-stroke penalty for McCarthy&#32;&#32;http://nfp.news/11nj" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11nj"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/rams-pool-report-mcvay-likes-teams-balanced-approach/" rel="bookmark" title="Rams pool report: McVay likes team&#8217;s balanced approach">Rams pool report: McVay likes team&#8217;s balanced approach</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/rams-pool-report-mcvay-likes-teams-balanced-approach/"/><meta itemprop="datePublished" content="2019-02-02"/><meta itemprop="dateModified" content="2019-02-02"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Rams pool report: McVay likes team's balanced approach</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12084278.jpg" width="1100" height="733" alt="" title="Jan 31, 2019; Atlanta, GA, USA; Los Angeles Rams head coach Sean McVay answers questions from the media during press interviews at Marriott Atlanta Buckhead. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"/></p> <p> ATLANTA -- Following three days</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Rams pool report: McVay likes team&#8217;s balanced approach</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/02/12084278.jpg" width="1100" height="733" alt="" title="Jan 31, 2019; Atlanta, GA, USA; Los Angeles Rams head coach Sean McVay answers questions from the media during press interviews at Marriott Atlanta Buckhead. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"></p><p> ATLANTA &#8212; Following three days of practice at the Atlanta Falcons&#8217; training facility in Flowery Branch, the Los Angeles Rams began to put the final touches on their week of planning and spent some time enjoying the moment with friends and family. </p> </p><p> Saturday around 1 p.m. ET, after meetings and a walkthrough held at their hotel in Buckhead, the Rams slipped on their blue throwback jerseys and yellow pants for a team photo inside Mercedes-Benz Stadium. </p> </p><p> Coaches stood at the top and players on the bottom rungs of the bleachers placed at the 5-yard line, with general manager Les Snead, owner Stan Kroenke and coach Sean McVay planted front and center. </p> </p><p> Then they scattered for individual photos, positional group photos, selfies and time with family members, who were allowed down on the field. Offensive tackle Andrew Whitworth chased his kids around the field, running back C.J. Anderson&#8217;s mom chatted up McVay, cornerback Aqib Talib introduced defensive coordinator Wade Phillips to his youngest son, and for about 40 minutes all soaked in their journey to Super Bowl LIII. </p> </p><p> &#8220;It&#8217;s great,&#8221; McVay said. &#8220;This is something I&#8217;ve never really been a part of. It&#8217;s really special. We&#8217;ve got a few players and coaches that have been a part of Super Bowls in previous years, but for a lot of guys it&#8217;s their first time and I think it&#8217;s definitely something you want to cherish.&#8221; </p> </p><p> When family time ended around 2 p.m., players and coaches returned to the stadium locker room and prepared for an evening of additional meetings as the focus shifted back to football. </p> </p><p> &#8220;I feel really good,&#8221; McVay said. &#8220;I think they understand the time where they can enjoy themselves right now, but when we&#8217;re doing football-related things, locking into the game plan, they&#8217;ve done a great job. And I think that&#8217;s kind of been this team&#8217;s personality really this whole season. It&#8217;s a good balance; they enjoy themselves, but not at the expense of allowing it to affect our focus and concentration.&#8221; </p> </p><p> McVay said his team enters the game with a clean bill of health; both safety Blake Countess and kicker Greg Zuerlein, who were previously on the injury report with foot injuries, are good to go. Both practiced in full Friday. </p> </p><p> &#8220;They&#8217;re going to be playing in the game,&#8221; McVay said. &#8220;Unless something changes from now until then, we should be good.&#8221; </p> </p><p> Over the last week and a half, McVay placed an emphasis on maintaining a similar routine &#8212; as similar as possible, anyway &#8212; in preparing for the New England Patriots. The Rams installed the majority of their game plan last week in L.A., then used this week for final tweaks and adjustments. </p> </p><p> &#8220;It&#8217;s a good delicate balance of making sure that you don&#8217;t do too many things, having two weeks to get ready for an opponent,&#8221; McVay said. &#8220;But the main thing is the players having ownership on what we&#8217;re going to do and I think they feel good and confident.&#8221; </p> </p><p> Sunday, because of a later (6:30 p.m. ET) kickoff, the Rams will use the morning at their hotel to run through it all one last time. Players will have an &#8220;activation,&#8221; in which the strength and conditioning staff will get them loose and put them through a stretch. </p> </p><p> &#8220;Then we&#8217;ll have quick meetings, a walkthrough and pre-game meal and then come over and here we go,&#8221; McVay said while taking a look around the stadium. &#8220;&#8230; I think you realize the magnitude of this event really with the media coverage and things like this. I&#8217;ve kind of stayed at the hotel. My parents have come over and I&#8217;ve seen them a bit, then going to practice back and forth. I haven&#8217;t really gotten out much, but hopefully we&#8217;ll take care of business and be able to enjoy after tomorrow.&#8221; </p> </p><p> &#8211;By Nicki Jhabvala, Pro Football Writers of America</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Rams pool report: McVay likes team&#8217;s balanced approach');return false;"><span class="op-btn">Read More</span> <span class="count">590 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Frams-pool-report-mcvay-likes-teams-balanced-approach%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Rams pool report: McVay likes team’s balanced approach+http://nfp.news/11ng" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Rams pool report: McVay likes team&#8217;s balanced approach&#32;&#32;http://nfp.news/11ng" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11ng"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article></div></div></div></div></div></div><a href="#" id="fl-to-top"><i class="fa fa-chevron-up"></i></a><style>[class*="fa fa-"]{font-family:FontAwesome !important;}</style>
<noscript id="wpfc-google-fonts"><link rel='stylesheet' id='sab-font-css' href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,700,400italic,700italic&#038;subset=latin' type='text/css' media='all'/>
<link rel='stylesheet' id='fl-builder-google-fonts-a0dc0f37a2c19d739b7445c77d065820-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C700%7CRoboto+Condensed%3A700%7COpen+Sans+Condensed%3A700&#038;ver=4.9.9' type='text/css' media='all'/>
</noscript>
<link rel='stylesheet' id='font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=2.1.4.3' type='text/css' media='all'/>
<script>var posts_table_params={"ajax_url":"https:\/\/nationalfootballpost.com\/wp-admin\/admin-ajax.php","ajax_nonce":"7b8b7cb5cf","wrapper_class":"posts-table-wrapper bb-theme","language":{"info":"Showing _START_ to _END_ of _TOTAL_ entries","infoEmpty":"Showing 0 entries","infoFiltered":"(_MAX_ entries in total)","lengthMenu":"Show _MENU_ entries","emptyTable":"No data available in table.","zeroRecords":"No matching records found.","search":"Search:","paginate":{"first":"First","last":"Last","next":"Next","previous":"Previous"},"thousands":",","decimal":".","aria":{"sortAscending":": activate to sort column ascending","sortDescending":": activate to sort column descending"},"filterBy":"Filter:","resetButton":"Reset"}};</script>
<!--[if lt IE 9]><script src="//nationalfootballpost.com/wp-content/cache/wpfc-minified/8z16d3ot/7xcbf.js"></script><![endif]-->
<!--[if lt IE 9]><script src="//nationalfootballpost.com/wp-content/cache/wpfc-minified/lbeld6mi/7xcbf.js"></script><![endif]-->
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/nationalfootballpost.com\/","sameAs":["http:\/\/facebook.com\/nationalfootballpost","https:\/\/twitter.com\/footballpost"],"@id":"https:\/\/nationalfootballpost.com\/#organization","name":"National Football Post","logo":"http:\/\/footballpost.wpengine.com\/wp-content\/uploads\/2018\/05\/NFPlogo-400.png"}</script>
<script src='//nationalfootballpost.com/wp-content/cache/wpfc-minified/qlb18u0t/7xcbe.js' type="text/javascript"></script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-5166086-1"></script>
<script>window.dataLayer=window.dataLayer||[];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-5166086-1');</script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/clipboard.js/1.5.10/clipboard.min.js"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>
<script>jQuery(function($){
$('button').tooltip({
trigger: 'click',
placement: 'bottom'
});
function setTooltip(btn, message){
$(btn).tooltip('hide')
.attr('data-original-title', message)
.tooltip('show');
}
function hideTooltip(btn){
setTimeout(function(){
$(btn).tooltip('hide');
}, 1000);
}
var clipboard=new Clipboard('button');
clipboard.on('success', function(e){
setTooltip(e.trigger, 'Link copied to clipboard');
hideTooltip(e.trigger);
});
clipboard.on('error', function(e){
setTooltip(e.trigger, 'Failed!');
hideTooltip(e.trigger);
});
});</script>
<script defer src='//nationalfootballpost.com/wp-content/cache/wpfc-minified/6mqm6t2g/7xcbe.js' type="text/javascript"></script>
<script>document.addEventListener('DOMContentLoaded',function(){function wpfcgl(){var wgh=document.querySelector('noscript#wpfc-google-fonts').innerText, wgha=wgh.match(/<link[^\>]+>/gi);for(i=0;i<wgha.length;i++){var wrpr=document.createElement('div');wrpr.innerHTML=wgha[i];document.body.appendChild(wrpr.firstChild);}}wpfcgl();});</script>
<script >document.addEventListener('DOMContentLoaded',function(){
jQuery(document).ready(function($){
$(window).scroll(function(){
var footerPos=$('footer').last().position().top;
var pos=$(window).scrollTop();
if(pos+(screen.height*4) > footerPos){
if($(".centil-infinite-scroll").first().hasClass('working')){
return false;
}else{
$(".centil-infinite-scroll").first().addClass('working');
}
var centilNextPostId=$(".centil-infinite-scroll").first().text();
var data={
'action': 'centil_is',
'centilNextPostId': centilNextPostId
};
jQuery.post('https://nationalfootballpost.com/wp-admin/admin-ajax.php', data, function(response){
$(".centil-infinite-scroll").first().replaceWith(response);
}, 'html');
}
var currUrl=$(".centil-post-header").first().attr("url");
var currTitle=$(".centil-post-header").first().attr("title");
if($(".centil-post-header").length > 1&&history.pushState){
for (var i=0; i<$(".centil-post-header").length; i++){
if(pos+(screen.height/2) >=$(".centil-post-header").eq(i).next().position().top){
currUrl=$(".centil-post-header").eq(i).attr("url");
currTitle=$(".centil-post-header").eq(i).attr("title");
}}
}
if(location.href!=currUrl){
history.pushState({}, currTitle, currUrl);
}});
});});</script>
</body>
</html><!-- WP Fastest Cache file was created in 2.0447909832 seconds, on 03-02-19 23:40:33 -->