<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8"/>
<meta name='viewport' content='width=device-width, initial-scale=1.0'/>
<meta http-equiv='X-UA-Compatible' content='IE=edge'/>
<link rel="profile" href="https://gmpg.org/xfn/11"/>
<link rel="pingback" href="https://nationalfootballpost.com/xmlrpc.php"/>
<title>Report: Packers hire Mennenga to be special teams coach - National Football Post</title>
<link rel="canonical" href="https://nationalfootballpost.com/report-packers-hire-mennenga-to-be-special-teams-coach/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Report: Packers hire Mennenga to be special teams coach - National Football Post"/>
<meta property="og:description" content="Report: Packers hire Mennenga to be special teams coach The Green Bay Packers have hired Shawn Mennenga from the college ranks to be their new special teams coach, ESPN reported Thursday. Mennenga was the special teams coordinator for Vanderbilt last season after seven seasons as a special teams assistant on the Cleveland Browns&#8217; staff, including&hellip;"/>
<meta property="og:url" content="https://nationalfootballpost.com/report-packers-hire-mennenga-to-be-special-teams-coach/"/>
<meta property="og:site_name" content="National Football Post"/>
<meta property="article:publisher" content="http://facebook.com/nationalfootballpost"/>
<meta property="article:tag" content="FLM"/>
<meta property="article:section" content="NFL and College Football Articles"/>
<meta property="article:published_time" content="2019-01-31T21:38:52+00:00"/>
<meta property="article:modified_time" content="2019-01-31T21:38:53+00:00"/>
<meta property="og:updated_time" content="2019-01-31T21:38:53+00:00"/>
<meta property="og:image" content="https://nationalfootballpost.com/wp-content/uploads/2019/01/8920165.jpg"/>
<meta property="og:image:secure_url" content="https://nationalfootballpost.com/wp-content/uploads/2019/01/8920165.jpg"/>
<meta property="og:image:width" content="875"/>
<meta property="og:image:height" content="1100"/>
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="National Football Post &raquo; Feed" href="https://nationalfootballpost.com/feed/"/>
<link rel="stylesheet" type="text/css" href="//nationalfootballpost.com/wp-content/cache/wpfc-minified/2qvnzqgi/7xcbd.css" media="all"/>
<link rel='https://api.w.org/' href='https://nationalfootballpost.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nationalfootballpost.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nationalfootballpost.com/wp-includes/wlwmanifest.xml"/> 
<link rel='shortlink' href='https://nationalfootballpost.com/?p=102399'/>
<link rel="alternate" type="application/json+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Freport-packers-hire-mennenga-to-be-special-teams-coach%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Freport-packers-hire-mennenga-to-be-special-teams-coach%2F&#038;format=xml"/>
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','https://www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-5166086-1', 'auto'); ga('send', 'pageview');</script>
<meta name="generator" content="Feed to Post 3.7.5"/>
<link rel="canonical" href="https://footballpost.wpengine.com/newsml/fieldlevelmedia_str_20190131T191908_0800_000029480_1.xml"/><style>.saboxplugin-wrap .saboxplugin-gravatar img{-webkit-border-radius:50%;-moz-border-radius:50%;-ms-border-radius:50%;-o-border-radius:50%;border-radius:50%;}
.saboxplugin-wrap .saboxplugin-authorname a{color:#212121;}
.saboxplugin-wrap .saboxplugin-authorname{font-family:"Roboto Condensed";}
.saboxplugin-wrap .saboxplugin-desc{font-family:Roboto Condensed;}
.saboxplugin-wrap .saboxplugin-desc{font-style:italic;}
.saboxplugin-wrap{margin-top:20px;margin-bottom:10px;padding:5px 5px}
.saboxplugin-wrap .saboxplugin-authorname{font-size:20px;line-height:27px;}
.saboxplugin-wrap .saboxplugin-desc p, .saboxplugin-wrap .saboxplugin-desc{font-size:16px !important;line-height:23px !important;}
.saboxplugin-wrap .saboxplugin-web{font-size:14px;}
.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa:before{font-size:18px;}
.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa{width:36px;height:36px;line-height:36px;}</style><link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-32x32.jpg" sizes="32x32"/>
<link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-192x192.jpg" sizes="192x192"/>
<link rel="apple-touch-icon-precomposed" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-180x180.jpg"/>
<meta name="msapplication-TileImage" content="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-270x270.jpg"/>
<style id="wp-custom-css">.fl-post-cats-tags{padding:0px 0px 0px 0px;border-bottom:4px solid #e6e6e6}
.share-social{border-bottom:4px solid #e6e6e6}
.container{max-width:93%}
.fl-sidebar-left{padding-right:2%;padding-left:0px;}
.fl-post-cats-tags a, .share-social a{text-transform:uppercase;color:#000;font-size:18px;font-weight:600;font-style:normal;}
.fl-archive .fl-post{border-bottom:0px;}
div.share-social{letter-spacing:7px;float:right;padding-top:10px;}
.custom-html-widget li a{font-size:16px;color:#555;font-style:normal;display:block;padding-bottom:4px;font-weight:600;text-transform:uppercase;}
.custom-html-widget li{font-size:14px;color:#7b7b7b;font-style:italic;font-weight:500;text-transform:uppercase;padding-bottom:6px;border-bottom:2px solid #e6e6e6}
.fl-widget-title{border-style:solid;border-width:4px 0px 4px 0px;text-align:center;padding:5px}
.fl-post-title{margin-bottom:0px;}
.fl-post-author{text-transform:uppercase;font-style:italic;font-weight:600;font-size:18px;}
.tooltip-inner{letter-spacing:1px;}
.fl-post-meta-bottom{border-top:none;font-style:italic;margin-top:0;padding-top:10px;float:left;}
.btn-primary{border:none !important;background:0 0 !important;;color:#000 !important;;box-shadow:none !important;;padding:0 !important;;margin-bottom:5px !important;;}
.toptitle h1{font-size:22px;margin-top:5px;margin-bottom:5px;list-style:none;margin:0;padding:0;line-height:40px;width:50%;position:relative;left:25%;margin:0 px;padding:0 px;border:1px solid #AAA;color:white;background:#050505;border-bottom-left-radius:10px;border-bottom-right-radius:10px;font-style:italic;}
.fl-archive .fl-archive-title{display:none;}
.rp4wp-related-post-content{font-size:18px;color:#555;font-style:italic;display:block;font-weight:800;text-transform:uppercase;}</style>
<script data-wpfc-render="false">var Wpfcll={s:[],i:function(){Wpfcll.ss();window.addEventListener('load',function(){window.addEventListener("DOMSubtreeModified",function(e){Wpfcll.ss();Wpfcll.ls(false);},false);Wpfcll.ls(true);});window.addEventListener('scroll',function(){Wpfcll.ls(false);});window.addEventListener('resize',function(){Wpfcll.ls(false);});window.addEventListener('click',function(){Wpfcll.ls(false);});},c:function(e,pageload){var w=document.documentElement.clientHeight || body.clientHeight;var n=pageload ? 0:800;var er=e.getBoundingClientRect();var t=0;var p=e.parentNode;var pr=p.getBoundingClientRect();if(er.x==0 && er.y==0){for(var i=0;i < 10;i++){if(p){if(pr.x==0 && pr.y==0){p=p.parentNode;pr=p.getBoundingClientRect();}else{t=pr.top;break;}}};}else{t=er.top;}if(w - t+n > 0){return true;}return false;},r:function(e,pageload){var s=this;var oc,ot;try{if(s.c(e,pageload)){oc=e.getAttribute("data-wpfc-original-src");ot=e.getAttribute("data-wpfc-original-srcset");if(oc || ot){if(oc){e.setAttribute('src',oc);}if(ot){e.setAttribute('srcset',ot);}e.removeAttribute("data-wpfc-original-src");e.removeAttribute("onload");if(e.tagName=="IFRAME"){e.onload=function(){var s=e.getAttribute("src").match(/templates\/youtube\.html\#(.+)/);var y="https://www.youtube.com/embed/";if(s){try{var i=e.contentDocument || e.contentWindow;if(i.location.href=="about:blank"){e.setAttribute('src',y+s[1]);}}catch(err){e.setAttribute('src',y+s[1]);}}}}}}}catch(error){console.log(error);console.log("==>",e);}},ss:function(){var i=Array.prototype.slice.call(document.getElementsByTagName("img"));var f=Array.prototype.slice.call(document.getElementsByTagName("iframe"));this.s=i.concat(f);},ls:function(pageload){var s=this;[].forEach.call(s.s,function(e,index){s.r(e,pageload);});}};document.addEventListener('DOMContentLoaded',function(){wpfci();});function wpfci(){Wpfcll.i();}</script>
</head>
<body class="post-template-default single single-post postid-102399 single-format-standard fl-preset-default fl-fixed-width fl-scroll-to-top fl-search-active" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="fl-page"> <header class="fl-page-header fl-page-header-fixed fl-page-nav-right fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="fl-page-logo-wrap col-md-3 col-sm-12"> <div class="fl-page-header-logo"> <a href="https://nationalfootballpost.com/"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post"/><meta itemprop="name" content="National Football Post"/></a></div></div><div class="fl-page-fixed-nav-wrap col-md-9 col-sm-12"> <div class="fl-page-nav-wrap"> <nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span><i class="fa fa-bars"></i></span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-top-nav" class="nav navbar-nav navbar-right menu"><li id="menu-item-78448" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a> <ul class="sub-menu"> <li id="menu-item-94464" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li> <li id="menu-item-94463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li> </ul> </li> <li id="menu-item-80343" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a> <ul class="sub-menu"> <li id="menu-item-88321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li> <li id="menu-item-80344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li> <li id="menu-item-78452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li> </ul> </li> <li id="menu-item-78387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a> <ul class="sub-menu"> <li id="menu-item-84427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li> <li id="menu-item-84236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li> </ul> </li> <li id="menu-item-78499" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a> <ul class="sub-menu"> <li id="menu-item-78502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li> <li id="menu-item-78500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li> <li id="menu-item-80079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li> </ul> </li> </ul></div></nav></div></div></div></div></div></header>
<header class="fl-page-header fl-page-header-primary fl-page-nav-centered fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-12 fl-page-header-logo-col"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="https://schema.org/Organization"> <a href="https://nationalfootballpost.com/" itemprop="url"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post"/><meta itemprop="name" content="National Football Post"/></a></div></div></div></div></div><div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span><i class="fa fa-bars"></i></span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-top-nav-1" class="nav navbar-nav menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li> </ul> </li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li> </ul> </li> </ul><div class="fl-page-nav-search"> <a href="javascript:void(0);" class="fa fa-search"></a> <form method="get" role="search" action="https://nationalfootballpost.com/" title="Type and press Enter to search."> <input type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" /> </form></div></div></nav></div></div></header>
<div class="fl-page-content" itemprop="mainContentOfPage"> <div class="fl-archive container"> <div class="row"> <div class="fl-sidebar fl-sidebar-left fl-sidebar-display-desktop col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"> <aside id="custom_html-3" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">RECENT</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/mcvay-way-rams-credit-coach-for-super-bowl-run/" title="McVay Way: Rams credit coach for Super Bowl run">McVay Way: Rams credit coach for Super Bowl run</a> 1 hour ago </li><li ><a href="https://nationalfootballpost.com/augusta-national-lengthens-fifth-hole-in-time-for-masters/" title="Augusta National lengthens fifth hole in time for Masters">Augusta National lengthens fifth hole in time for Masters</a> 1 hour ago </li><li ><a href="https://nationalfootballpost.com/cowboys-owner-jones-backs-head-coach-garrett/" title="Cowboys owner Jones backs head coach Garrett">Cowboys owner Jones backs head coach Garrett</a> 1 hour ago </li><li ><a href="https://nationalfootballpost.com/take-5-masterminds-collide-in-super-bowl-liii/" title="Take 5: Masterminds collide in Super Bowl LIII">Take 5: Masterminds collide in Super Bowl LIII</a> 1 hour ago </li><li class="current"><a href="https://nationalfootballpost.com/report-packers-hire-mennenga-to-be-special-teams-coach/" title="Report: Packers hire Mennenga to be special teams coach">Report: Packers hire Mennenga to be special teams coach</a> 1 hour ago </li><li ><a href="https://nationalfootballpost.com/cowboys-officially-name-moore-oc-kitna-qbs-coach/" title="Cowboys officially name Moore OC, Kitna QBs coach">Cowboys officially name Moore OC, Kitna QBs coach</a> 1 hour ago </li><li ><a href="https://nationalfootballpost.com/mcvay-time-to-tighten-the-screws/" title="McVay: Time to &#8216;tighten the screws&#8217;">McVay: Time to &#8216;tighten the screws&#8217;</a> 5 hours ago </li><li ><a href="https://nationalfootballpost.com/gary-players-son-charged-with-fraud/" title="Gary Player&#8217;s son charged with fraud">Gary Player&#8217;s son charged with fraud</a> 18 hours ago </li><li ><a href="https://nationalfootballpost.com/rams-pool-report-pk-zuerlein-foot-limited/" title="Rams pool report: PK Zuerlein (foot) limited">Rams pool report: PK Zuerlein (foot) limited</a> 18 hours ago </li><li ><a href="https://nationalfootballpost.com/cardinals-db-peterson-im-here-to-stay-baby/" title="Cardinals DB Peterson: &#8216;I&#8217;m here to stay, baby&#8217;">Cardinals DB Peterson: &#8216;I&#8217;m here to stay, baby&#8217;</a> 18 hours ago </li></ul></div></aside><aside id="custom_html-7" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">FEATURES</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/report-brady-defiantly-denies-retirement-question/" title="Report: Brady defiantly denies retirement question">Report: Brady defiantly denies retirement question</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/rams-cooks-responds-to-pats-chung-dig-in-fan-rally/" title="Rams&#8217; Cooks responds to Pats&#8217; Chung dig in fan rally">Rams&#8217; Cooks responds to Pats&#8217; Chung dig in fan rally</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/huge-crowd-sends-patriots-off-to-super-bowl/" title="Huge crowd sends Patriots off to Super Bowl">Huge crowd sends Patriots off to Super Bowl</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/rams-k-zuerlein-optimistic-strained-foot-will-be-good-to-go/" title="Rams K Zuerlein optimistic strained foot will be ‘good to go’">Rams K Zuerlein optimistic strained foot will be ‘good to go’</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/bears-give-ot-massie-four-year-extension/" title="Bears give OT Massie four-year extension">Bears give OT Massie four-year extension</a> January 26, 2019 </li></ul></div></aside></div><div class="fl-content fl-content-right col-md-9" itemscope="itemscope" itemtype="https://schema.org/Blog"> <article class="fl-post post-102399 post type-post status-publish format-standard hentry category-news tag-flm" id="fl-post-102399" itemscope itemtype="https://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Report: Packers hire Mennenga to be special teams coach </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-packers-hire-mennenga-to-be-special-teams-coach/"/><meta itemprop="datePublished" content="1 hour ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" itemprop="text"> <h2><title>Report: Packers hire Mennenga to be special teams coach</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/8920165.jpg" width="875" height="1100" alt="" title="Nov 5, 2015; Cincinnati, OH, USA; Cleveland Browns assistant special teams coach Shawn Mennenga reacts against the Cincinnati Bengals in a NFL game at Paul Brown Stadium. The Bengals defeated the Browns 31-10 to improve to 8-0 for the first time in franchise history. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"></p><p> The Green Bay Packers have hired Shawn Mennenga from the college ranks to be their new special teams coach, ESPN reported Thursday. </p> </p><p> Mennenga was the special teams coordinator for Vanderbilt last season after seven seasons as a special teams assistant on the Cleveland Browns&#8217; staff, including time under then head coach Mike Pettine, now the Packers defensive coordinator. </p> </p><p> Mennenga would replace Ron Zook, let go by the Packers in the housecleaning that followed the termination of Mike McCarthy during the season. </p> </p><p> The Packers reportedly interviewed at least four other candidates for the position before landing on Mennenga to lead their woeful special teams, ranked last in 2018 in Dallas Morning News columnist Rick Gosselin&#8217;s annual special teams rankings. </p> </p><p> The Packers announced Wednesday that new head coach Matt LaFleur hired Alvis Whitted from Colorado State to be his new receivers coach. </p> </p><p> &#8211;Field Level Media</p></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-packers-hire-mennenga-to-be-special-teams-coach%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Packers hire Mennenga to be special teams coach+http://nfp.news/11lw" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Packers hire Mennenga to be special teams coach&#32;&#32;http://nfp.news/11lw" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11lw"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<div class="related-post"> <article style="overflow: hidden;margin-bottom: 30px;"> <header class="fl-post-header"> <h2 class="fl-post-title" itemprop="headline"> <a href="https://nationalfootballpost.com/mcvay-way-rams-credit-coach-for-super-bowl-run/" rel="bookmark" title="McVay Way: Rams credit coach for Super Bowl run">McVay Way: Rams credit coach for Super Bowl run</a> </h2> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/mcvay-way-rams-credit-coach-for-super-bowl-run/"/><meta itemprop="datePublished" content="1 hour ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>McVay Way: Rams credit coach for Super Bowl run</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12033604-1.jpg" width="1100" height="890" alt="" title="Jan 20, 2019; New Orleans, LA, USA; Los Angeles Rams head coach Sean McVay points while on the sidelines during the first quarter against the New Orleans Saints in the NFC Championship at Mercedes-Benz Superdome. Mandatory Credit: Matthew Emmons-USA TODAY Sports"</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>McVay Way: Rams credit coach for Super Bowl run</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12033604-1.jpg" width="1100" height="890" alt="" title="Jan 20, 2019; New Orleans, LA, USA; Los Angeles Rams head coach Sean McVay points while on the sidelines during the first quarter against the New Orleans Saints in the NFC Championship at Mercedes-Benz Superdome. Mandatory Credit: Matthew Emmons-USA TODAY Sports" data-portal-copyright="Matthew Emmons-USA TODAY Sports"></p><p> ATLANTA &#8211; Rams head coach Sean McVay credits his players for putting Los Angeles in Super Bowl LIII. </p> </p><p> NFL Defensive Player of the Year Aaron Donald made sure McVay told the entire story. </p> </p><p> &#8220;He was thanking the players,&#8221; Donald said. &#8220;I thanked him. I told him, &lsquo;Once you came, you changed this thing around. He changed the culture.&#8221; </p> </p><p> McVay&#8217;s innovative offense boasts two 1,200-yard receivers and a 4,000-yard passer, not to mention running back Todd Gurley, who put up 21 total touchdowns and more than 1,800 yards from scrimmage. </p> </p><p> &#8220;He&#8217;s crazy,&#8221; Gurley said Thursday. &#8220;I think he comes up with this stuff in his sleep. He tells you something he thought up one morning, and then does it the next morning, the next morning, the next morning. He doesn&#8217;t stop.&#8221; </p> </p><p> The 33-year-old McVay has deep NFL roots, but his approach to leading a team is anything but traditional. Wednesday&#8217;s practice was more of a sped-up walkthrough. McVay based the schedule on the &#8220;sports science and nutrition&#8221; side, deferring the heavy lather type of practices at the Atlanta Falcons team facility for Thursday and Friday. </p> </p><p> Player-first dynamics are part of what makes McVay a player&#8217;s coach. </p> </p><p> At 15-3 this season, including playoffs, McVay is tied for the best winning percentage in the NFL since he was hired to take over a 4-12 team. </p> </p><p> Gurley, essentially benched in the NFC Championship Game in favor of journeyman C.J. Anderson, said he appreciates McVay as a leader and competitor. </p> </p><p> &#8220;He makes it all about communication,&#8221; Gurley said. </p> </p><p> Rather than sulk as Anderson stepped into the spotlight, Gurley congratulated Anderson and said he would do the same on Sunday should Super Bowl LIII follow a similar script. Gurley said his &#8220;dream outcome&#8221; this week in Atlanta has nothing to do with statistics or individual accolades. </p> </p><p> &#8220;Honestly, just win,&#8221; Gurley said. </p> </p><p> The theme is nearly universal among Rams players who addressed personal bonds with McVay and the chemistry he brought to a locker room that could be too small for this many stars. </p> </p><p> McVay was on the phone with Donald before the opportunity arose to acquire Ndamukong Suh in free agency and general manager Les Snead reached out when Khalil Mack was being shopped by the Raiders. The franchise makes every effort to eliminate the common football refrain, &#8220;It&#8217;s a business.&#8221; </p> </p><p> For Snead and McVay, the goal is to present a different label, football as family. </p> </p><p> &#8220;He holds us accountable by being accountable,&#8221; third-year quarterback Jared Goff said. </p> </p><p> For wide receiver Brandin Cooks, set to play in back-to-back Super Bowls following an offseason trade from the Patriots, the contrast between McVay and Bill Belichick is stark. On his third team in three seasons &#8211; Cooks was acquired by the Patriots via trade from New Orleans &#8211; it took only a matter of days for the speedy receiver to know he&#8217;d finally found the perfect fit. </p> </p><p> And for that, he credits McVay. </p> </p><p> &#8220;He&#8217;s special,&#8221; Cooks said. &#8220;I enjoy being a fly on the wall just watching how he works.&#8221; </p> </p><p> McVay said he&#8217;s also smart enough to know what he doesn&#8217;t know. </p> </p><p> One of his first moves as a head coach was to go after former NFL head coach and longtime defensive coordinator Wade Phillips. </p> </p><p> &#8220;He&#8217;s got so many things he can draw on from all the success he&#8217;s had in this league, but it never feels like it&#8217;s pushed on you. When you go to him and ask him for advice he&#8217;s been so supportive to me,&#8221; McVay said. &#8220;With the inexperience I do have I feel so fortunate to be around Wade Phillips.&#8221; </p> </p><p> Phillips, 71, had eight years coaching in the NFL on his resume when McVay was born. But Phillips has seen natural born leaders in his day, and he puts McVay in that class. </p> </p><p> &#8220;He&#8217;s brilliant at what he does, not just coaching-wise, but leadership-wise,&#8221; Phillips said. &#8220;He has command of the team. The players know what he wants, how he wants it done. They&#8217;ve bought into what he says.&#8221; </p> </p><p> &#8211;By Jeff Reynolds, Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','McVay Way: Rams credit coach for Super Bowl run');return false;"><span class="op-btn">Read More</span> <span class="count">620 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fmcvay-way-rams-credit-coach-for-super-bowl-run%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=McVay Way: Rams credit coach for Super Bowl run+http://nfp.news/11lx" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=McVay Way: Rams credit coach for Super Bowl run&#32;&#32;http://nfp.news/11lx" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11lx"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/augusta-national-lengthens-fifth-hole-in-time-for-masters/" rel="bookmark" title="Augusta National lengthens fifth hole in time for Masters">Augusta National lengthens fifth hole in time for Masters</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/augusta-national-lengthens-fifth-hole-in-time-for-masters/"/><meta itemprop="datePublished" content="1 hour ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Augusta National lengthens fifth hole in time for Masters</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/10777085.jpg" width="1100" height="774" alt="" title="Apr 8, 2018; Augusta, GA, USA; Patrick Reed walks to the 18th green during the final round of the Masters golf tournament at Augusta National Golf Club. Mandatory Credit: Rob Schumacher-USA TODAY Sports" data-portal-copyright="Rob Schumacher-USA TODAY Sports"/></p> <p> Augusta National</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Augusta National lengthens fifth hole in time for Masters</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/10777085.jpg" width="1100" height="774" alt="" title="Apr 8, 2018; Augusta, GA, USA; Patrick Reed walks to the 18th green during the final round of the Masters golf tournament at Augusta National Golf Club. Mandatory Credit: Rob Schumacher-USA TODAY Sports" data-portal-copyright="Rob Schumacher-USA TODAY Sports"></p><p> Augusta National is getting tweaked again ahead of this year&#8217;s Masters Tournament. </p> </p><p> The par-4 fifth hole has been lengthened from 455 yards to 495, according to the just-released tournament media guide, and it denotes a 313-yard carry off the tee over bunkers down the left side of the fairway. </p> </p><p> The new fifth tee has been built across Old Berckmans Road, which has been closed to traffic since 2015. </p> </p><p> ESPN reported that in anticipation of future changes, Augusta National bought land from adjacent Augusta Country Club two years ago on the part of the course known as Amen Corner &#8212; the 11th green, 12th hole and 13th tee &#8211; which would allow the lengthening of the par-5 13th hole by moving the tee, but the 13th is still listed as the same 510 yards. </p> </p><p> Last year, the fifth hole played to an average of 4.16, making it the sixth-toughest hole during the tournament. Augusta National&#8217;s length now stands at 7,475 yards, 550 yards longer than in 1997 when Tiger Woods won the tournament for the first time. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Augusta National lengthens fifth hole in time for Masters');return false;"><span class="op-btn">Read More</span> <span class="count">120 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Faugusta-national-lengthens-fifth-hole-in-time-for-masters%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Augusta National lengthens fifth hole in time for Masters+http://nfp.news/11ly" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Augusta National lengthens fifth hole in time for Masters&#32;&#32;http://nfp.news/11ly" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11ly"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/cowboys-owner-jones-backs-head-coach-garrett/" rel="bookmark" title="Cowboys owner Jones backs head coach Garrett">Cowboys owner Jones backs head coach Garrett</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/cowboys-owner-jones-backs-head-coach-garrett/"/><meta itemprop="datePublished" content="1 hour ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Cowboys owner Jones backs head coach Garrett</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/11398494.jpg" width="1100" height="770" alt="" title="Oct 7, 2018; Houston, TX, USA; Dallas Cowboys head coach Jason Garrett (left) speaks with owner Jerry Jones (right) before the game against the Houston Texans at NRG Stadium. Mandatory Credit: Kevin Jairaj-USA TODAY Sports" data-portal-copyright="Kevin Jairaj-USA TODAY Sports"/></p> <p> Jerry Jones</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Cowboys owner Jones backs head coach Garrett</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/11398494.jpg" width="1100" height="770" alt="" title="Oct 7, 2018; Houston, TX, USA; Dallas Cowboys head coach Jason Garrett (left) speaks with owner Jerry Jones (right) before the game against the Houston Texans at NRG Stadium. Mandatory Credit: Kevin Jairaj-USA TODAY Sports" data-portal-copyright="Kevin Jairaj-USA TODAY Sports"></p><p> Jerry Jones called into a Dallas-area radio station Wednesday and said that delays in officially naming assistant coaches does not reflect any uncertainty about the future of Dallas Cowboys head coach Jason Garrett. </p> </p><p> On the unscheduled call to FM 105.3 The Fan, the Cowboys&#8217; owner and general manager stressed there were valid reasons for the delays in the expected naming of Kellen Moore as offensive coordinator and Jon Kitna as quarterbacks coach. </p> </p><p> &#8220;Within the staff we&#8217;ve made several commitments. But the reason that it&#8217;s not being talked about is not that Jason is on shaky ground,&#8221; Jones said. &#8220;It&#8217;s just that we&#8217;re putting together ideas and didn&#8217;t want to necessarily make that a featured topic around the Super Bowl. </p> </p><p> &#8220;Everything is as it should be.&#8221; </p> </p><p> Jones&#8217; surprise call to the &#8220;Ben and Skin&#8221; show had particular praise for Moore. </p> </p><p> &#8220;The facts are, we think a lot of Kellen. &#8230; The facts are, he&#8217;s really going to contribute his fresh ideas,&#8221; Jones said on the show. </p> </p><p> &#8220;I want their ideas,&#8221; he added about the new coaches. &#8220;I want their preference, I want them to lay in front of a train to get it implemented into what we&#8217;re doing offensively. </p> </p><p> &#8220;I&#8217;ll assure you it&#8217;ll be a collaborative effort and that&#8217;s how we&#8217;re going to handle it.&#8221; </p> </p><p> Speculation has been that Garrett will have offensive play-calling duties returned to his umbrella, particularly due to Moore&#8217;s lack of experience. </p> </p><p> &#8220;Jason&#8217;s going to be making an announcement here real quickly, but make no mistake about it, he&#8217;s going to be a key guy in what play is run on that football field,&#8221; Jones said. &#8220;By key, probably have the ultimate responsibility.&#8221; </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Cowboys owner Jones backs head coach Garrett');return false;"><span class="op-btn">Read More</span> <span class="count">224 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fcowboys-owner-jones-backs-head-coach-garrett%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Cowboys owner Jones backs head coach Garrett+http://nfp.news/11lz" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Cowboys owner Jones backs head coach Garrett&#32;&#32;http://nfp.news/11lz" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11lz"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/take-5-masterminds-collide-in-super-bowl-liii/" rel="bookmark" title="Take 5: Masterminds collide in Super Bowl LIII">Take 5: Masterminds collide in Super Bowl LIII</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/take-5-masterminds-collide-in-super-bowl-liii/"/><meta itemprop="datePublished" content="1 hour ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Take 5: Masterminds collide in Super Bowl LIII</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12071722.jpg" width="1100" height="833" alt="" title="Jan 28, 2019; Atlanta, GA, USA; Los Angeles Rams head coach Sean McVay (left) greets New England Patriots head coach Bill Belichick (right) during Opening Night for Super Bowl LIII at State Farm Arena. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Take 5: Masterminds collide in Super Bowl LIII</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12071722.jpg" width="1100" height="833" alt="" title="Jan 28, 2019; Atlanta, GA, USA; Los Angeles Rams head coach Sean McVay (left) greets New England Patriots head coach Bill Belichick (right) during Opening Night for Super Bowl LIII at State Farm Arena. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"></p><p> Sunday&#8217;s game features plenty of stars, but it also pits two of the NFL&#8217;s most touted football minds against one another. </p> </p><p> The specialties of Bill Belichick and Sean McVay clash on the most pivotal battleground as the New England Patriots and Los Angeles Rams fight for Super Bowl LIII. </p> </p><p> 1. How will Belichick combat McVay&#8217;s offense? </p> </p><p> The Patriots predominantly use man coverage &#8212; and did so almost exclusively in the AFC Championship Game &#8212; but Belichick famously caters his plan to his opponent. Given what troubled McVay&#8217;s offense the most this season, odds are New England will lean on zone coverage Sunday, especially Cover-4 (also called quarters). </p> </p><p> The Rams&#8217; worst offensive outings &#8212; Weeks 13-15, a stretch that began against former Patriots defensive coordinator Matt Patricia &#8212; came mostly against Cover-4, a matchup zone in which safeties play shallower and attack downhill. Those safeties provide double teams against vertical routes in McVay&#8217;s downfield designs, while also sitting low enough to drive on crossers. </p> </p><p> Cover-4 has weak points underneath, but it muddies the middle of the field. It also would prevent defenders from getting picked by intertwined releases out of stacks and bunches from condensed formations, a Rams staple. Though they&#8217;ve steadied this season, the Patriots have had issues in man against stacks and bunches since early 2017, including in Super Bowl LII. </p> </p><p> Belichick could also counter condensed formations with his famed &#8220;bullseye&#8221; tactic &#8212; first debuted in Super Bowl XXXVI against Marshall Faulk &#8212; by using Dont&#8217;a Hightower or Kyle Van Noy to disrupt a receiver&#8217;s release before pass rushing. A physical jam against a bunch or stack could disrupt multiple routes at once, a huge bonus. </p> </p><p> When New England does play man, expect extreme physicality, and not just at the line. Knowing nobody wants a flag fest, the Patriots always push the boundaries of illegal contact and holding in the postseason, and this year is no different. In Kansas City, a conservative eye saw six clear holding penalties on the Chiefs&#8217; 11 first-half dropbacks (only one was flagged). </p> </p><p> 2. Rams&#8217; O-line must exploit numbers advantages </p> </p><p> When the Patriots play Cover-4 (or any 2-high coverage), L.A. will have the numbers edge in the box, which McVay and Todd Gurley excel at exploiting. But New England&#8217;s defense is better equipped than most to stop the run with a light box, especially against zone schemes. </p> </p><p> Trey Flowers, Adrian Clayborn, Hightower (when playing outside) and John Simon are relentless, physical edge-setters who guide runs back inside. The Patriots also employ myriad fronts &#8212; often five on the line and one off-ball linebacker &#8212; and run blitzes to blur O-linemen&#8217;s responsibilities and prevent them from getting to linebackers. Likewise, Hightower, Van Noy and Elandon Roberts are outstanding at playing through blocks with physicality or slipping them in space. </p> </p><p> New England routinely stymied Kansas City&#8217;s run game with just five or six in the box. The Rams&#8217; run-blocking should fare better, but it had its own issues against the New Orleans Saints, who used a pair of 2-technique (head-up on each guard) defensive tackles to mess with angles and assignments. </p> </p><p> L.A. must run well enough to stay ahead of the chains. That unlocks more opportunities for play-action, which limits pass rush by moving the pocket and/or keeping extra blockers in. Too many obvious passing situations would let the Patriots dial up the stunts, twists and blitzes that hounded the Chiefs&#8217; protection two weeks ago. </p> </p><p> 3. More of the same from New England&#8217;s offense </p> </p><p> The Patriots reached Atlanta with a run-first, ball-control approach, and there&#8217;s no reason to stop now. </p> </p><p> Despite improvement in the playoffs, run defense was the Rams&#8217; soft underbelly in the regular season (5.1 yards per carry allowed, dead last), and New England&#8217;s scheme is suited to attack it. Spindly linebackers Cory Littleton and Mark Barron won&#8217;t have anywhere to hide against fullback James Develin, and Rob Gronkowski should have his way against L.A.&#8217;s edge defenders, especially Dante Fowler Jr. </p> </p><p> The Rams&#8217; interior has played excellent of late &#8212; especially Ndamukong Suh, reminding everyone what he can do with maximum effort &#8212; but the Patriots&#8217; volume of designs is a load to handle mentally. Likewise, their trap and wham schemes could turn Suh&#8217;s and Aaron Donald&#8217;s aggression against them. </p> </p><p> Perhaps more important to New England than actual yards gained on the ground would be potential effects elsewhere. </p> </p><p> More runs would limit the pass rush&#8217;s bite, with fewer pass rush opportunities and more coming against play-action. Eating clock could also wear out Donald & Co. while testing McVay&#8217;s patience to maintain his own run/pass balance. </p> </p><p> 4. How will Wade Phillips play Tom Brady? </p> </p><p> Even if the Rams can slow the run game, there&#8217;s a four-time Super Bowl MVP to deal with. </p> </p><p> Teams that have given Brady the most trouble this season used safe blitzes (five rushers or fewer) and zone exchanges (a second-level defender rushes while a lineman drops) to pressure him without leaving gaping holes in coverage. </p> </p><p> But that isn&#8217;t really Phillips&#8217; style. He prefers standard four- and five-man rushes, with man coverage or matchup zones (mostly Cover-3, Cover-4 and Cover-6). That worked perfectly with the Denver Broncos, whose edge rushers and cover corners stymied Brady a few times, but the Rams&#8217; personnel is entirely different. </p> </p><p> Donald and Suh provide more interior rush, but Fowler will be lucky to reach Brady before his release. Aqib Talib remains excellent, but Marcus Peters is wildly inconsistent, and Nickell Robey-Coleman is solid in the slot, but not exactly Chris Harris. Of course, the Patriots&#8217; best wideout, Julian Edelman, plays primarily inside. </p> </p><p> John Johnson has the coverage skills to hang with Gronkowski, but his small frame (6-foot, 209 pounds) will get boxed out at times. Elsewhere, Littleton and Barron must handle James White better than they did Alvin Kamara, who had a field day on option routes from the weak side, something New England loves to do with White. </p> </p><p> Expect plenty of lurk/robber coverage (a free defender to help against routes between the numbers) and selective double teams against Edelman, Gronkowski and even White at times. Phillips could also bet against Brady beating him downfield and have his safeties play extra aggressively downhill. </p> </p><p> 5. Watching for tendency breakers </p> </p><p> Great coaches excel at self-scouting, and with two weeks to prepare, both sides should cook up surprises counter to their own tendencies. </p> </p><p> Will the Rams run more from shotgun? After doing so almost never in the regular season, they&#8217;ve done it occasionally in the playoffs. A broader package might be worthwhile. </p> </p><p> Could McVay resurrect the running back screen game? He killed opponents with Gurley on screens throughout 2017 before mostly scrapping the tactic this season, for whatever reason. The Patriots struggled against the Chiefs&#8217; misdirection screens two weeks ago. </p> </p><p> Meanwhile, New England could throw a curveball by using Develin as a decoy. Diverse as its run game is, runs virtually always follow him when he&#8217;s on the field, giving the defense a reliable key to read the play. Josh McDaniels could exploit that tendency with split-flow runs, sending Develin one way to provide a false key as the run goes elsewhere. </p> </p><p> The Patriots could also throw more with Sony Michel &#8212; a capable receiver in college &#8212; or run more with White, counter to typical usage patterns. </p> </p><p> The team with better surprises could grab the upper hand early. Just as important will be how quickly each adjusts to their opponents&#8217; changeups. </p> </p><p> &#8211;David DeChant, Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Take 5: Masterminds collide in Super Bowl LIII');return false;"><span class="op-btn">Read More</span> <span class="count">1181 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Ftake-5-masterminds-collide-in-super-bowl-liii%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Take 5: Masterminds collide in Super Bowl LIII+http://nfp.news/11m0" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Take 5: Masterminds collide in Super Bowl LIII&#32;&#32;http://nfp.news/11m0" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11m0"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/cowboys-officially-name-moore-oc-kitna-qbs-coach/" rel="bookmark" title="Cowboys officially name Moore OC, Kitna QBs coach">Cowboys officially name Moore OC, Kitna QBs coach</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/cowboys-officially-name-moore-oc-kitna-qbs-coach/"/><meta itemprop="datePublished" content="1 hour ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Cowboys officially name Moore OC, Kitna QBs coach</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/11840484.jpg" width="1100" height="786" alt="" title="Dec 9, 2018; Arlington, TX, USA; Dallas Cowboys quarterback Dak Prescott (4) talks with quarterbacks coach Kellen Moore and head coach Jason Garrett during a timeout from the game against the Philadelphia Eagles at AT&amp;T Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports"</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Cowboys officially name Moore OC, Kitna QBs coach</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/11840484.jpg" width="1100" height="786" alt="" title="Dec 9, 2018; Arlington, TX, USA; Dallas Cowboys quarterback Dak Prescott (4) talks with quarterbacks coach Kellen Moore and head coach Jason Garrett during a timeout from the game against the Philadelphia Eagles at AT&T Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports" data-portal-copyright="Matthew Emmons-USA TODAY Sports"></p><p> The Dallas Cowboys officially promoted Kellen Moore to offensive coordinator and hired Jon Kitna to fill Moore&#8217;s old role as quarterbacks coach, the team announced Thursday. </p> </p><p> Both moves have been expected for over a week, but the lack of an announcement had some speculating about head coach Jason Garrett&#8217;s job status, compelling owner Jerry Jones to address the matter publicly on Wednesday. </p> </p><p> &#8220;Within the staff we&#8217;ve made several commitments,&#8221; Jones said on FM 105.3 The Fan after calling in unscheduled. &#8220;But the reason that it&#8217;s not being talked about is not that Jason is on shaky ground. It&#8217;s just that we&#8217;re putting together ideas and didn&#8217;t want to necessarily make that a featured topic around the Super Bowl.&#8221; </p> </p><p> If the Cowboys were waiting to make the announcement until after Sunday&#8217;s game, that plan apparently changed. It&#8217;s unclear exactly how the team&#8217;s playcalling structure will work, but Jones suggested Wednesday that the responsibility will fall more on Moore &#8212; who is replacing departed playcaller and coordinator Scott Linehan &#8212; than on Garrett. </p> </p><p> Moore, 29, spent 2018 as quarterbacks coach after playing for Dallas as a backup from 2015-17. He previously spent three years as a backup for the Detroit Lions (2012-14). </p> </p><p> Despite his inexperience, Moore was a coveted name in coaching searches this offseason. ESPN reports multiple teams asked the Cowboys for permission to interview Moore but were denied. </p> </p><p> Quarterback Dak Prescott offered glowing praise of Moore on 105.3 The Fan earlier Thursday. </p> </p><p> &#8220;He&#8217;s honestly one of these young genius phenoms in the game,&#8221; Prescott said. &#8220;&#8230; He&#8217;s special. He knows a lot about the game &#8212; just the way he sees the game, the way he&#8217;s ahead of the game. He can bring a lot to us, a lot of creativity &#8212; something that we need.&#8221; </p> </p><p> Kitna, 46, brings another former Cowboys quarterback to the staff, after he played for the Cowboys from 2009-11 and in 2013. The 14-year veteran has spent the last seven years coaching high school football and was set to be the offensive coordinator for the Alliance of American Football&#8217;s San Diego Fleet, before taking the Cowboys job instead. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Cowboys officially name Moore OC, Kitna QBs coach');return false;"><span class="op-btn">Read More</span> <span class="count">297 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fcowboys-officially-name-moore-oc-kitna-qbs-coach%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Cowboys officially name Moore OC, Kitna QBs coach+http://nfp.news/11m1" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Cowboys officially name Moore OC, Kitna QBs coach&#32;&#32;http://nfp.news/11m1" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11m1"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/mcvay-time-to-tighten-the-screws/" rel="bookmark" title="McVay: Time to &#8216;tighten the screws&#8217;">McVay: Time to &#8216;tighten the screws&#8217;</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/mcvay-time-to-tighten-the-screws/"/><meta itemprop="datePublished" content="5 hours ago"/><meta itemprop="dateModified" content="4 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>McVay: Time to 'tighten the screws'</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12079652.jpg" width="1100" height="764" alt="" title="Jan 30, 2019; Atlanta, GA, USA; Los Angeles Rams head coach Sean McVay speaks during a press conference at Marriott Atlanta Buckhead. Mandatory Credit: Jason Getz-USA TODAY Sports" data-portal-copyright="Jason Getz-USA TODAY Sports"/></p> <p> ATLANTA - It's time to "tighten the screws." </p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>McVay: Time to &#8216;tighten the screws&#8217;</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12079652.jpg" width="1100" height="764" alt="" title="Jan 30, 2019; Atlanta, GA, USA; Los Angeles Rams head coach Sean McVay speaks during a press conference at Marriott Atlanta Buckhead. Mandatory Credit: Jason Getz-USA TODAY Sports" data-portal-copyright="Jason Getz-USA TODAY Sports"></p><p> ATLANTA &#8211; It&#8217;s time to &#8220;tighten the screws.&#8221; </p> </p><p> That was the message from Los Angeles Rams coach Sean McVay in wrapping up his media obligations with his final press conference Thursday morning ahead of Super Bowl LIII. </p> </p><p> The Rams are practicing at the Atlanta Falcons&#8217; facility in Flowery Branch, and after some &#8220;above the head&#8221; and individual work on Wednesday, the focus will turn toward fine-tuning the game plan for Sunday. </p> </p><p> &#8220;It has been outstanding, we couldn&#8217;t have asked for much more,&#8221; McVay said of the Rams&#8217; experience this week. &#8220;You appreciate the magnitude of this game, it&#8217;s a blessing to be here. Our players and coaches have earned the right to be here.&#8221; </p> </p><p> McVay said his players have handled the Super Bowl stage very well, but now the focus really turns to football. The Rams scored 527 points during the regular season and are 8-0 against AFC teams under McVay. </p> </p><p> Still, it&#8217;s impossible not to wonder how the 33-year-old will handle the magnitude of being on the sideline for his first Super Bowl. Across the field will be a man twice his age with infinitely more experience on the game&#8217;s greatest stage, with Bill Belichick leading the New England Patriots to the Super Bowl for the ninth time. </p> </p><p> McVay grew up in a football family, the grandson of legendary 49ers general manager John McVay, and has coached under the likes of Super Bowl-winning Jon Gruden and Mike Shanahan in addition to growing up around Bill Walsh. He knows great teams don&#8217;t beat themselves, and even the Rams&#8217; best shot come Sunday might not be enough. </p> </p><p> &#8220;To play against the Patriots is a great challenge,&#8221; he said. &#8220;You look at the amount of appearances that they&#8217;ve had, the consistency at which they&#8217;ve performed, it&#8217;s not a surprise. </p> </p><p> &#8220;They&#8217;re a great challenge to prepare for because they do such an excellent job specific to each week. But one of the things that you consistently hear is good teams don&#8217;t beat themselves. And they&#8217;re a great team because they never beat themselves. You never see the Patriots beat themselves. </p> </p><p> &#8220;They handle situations, their big-time players make plays at the most opportune moments, and they handle adversity extremely well. I think that consistent belief and expectation that &lsquo;we&#8217;re going to find a way&#8217; is a really powerful thing.&#8221; </p> </p><p> McVay now gets to retreat from the media parade and spend the next few days focusing on how to dethrone arguably the greatest dynasty in NFL history in Super Bowl LIII. </p> </p><p> &#8220;These next two days really kind of finalize, tighten the screws, and have these players as confident as possible going into Sunday,&#8221; he said. &#8220;Can&#8217;t wait for kickoff.&#8221; </p> </p><p> &#8211;Derek Harper, Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','McVay: Time to &#8216;tighten the screws&#8217;');return false;"><span class="op-btn">Read More</span> <span class="count">395 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fmcvay-time-to-tighten-the-screws%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=McVay: Time to ‘tighten the screws’+http://nfp.news/11lo" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=McVay: Time to &#8216;tighten the screws&#8217;&#32;&#32;http://nfp.news/11lo" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11lo"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/gary-players-son-charged-with-fraud/" rel="bookmark" title="Gary Player&#8217;s son charged with fraud">Gary Player&#8217;s son charged with fraud</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/gary-players-son-charged-with-fraud/"/><meta itemprop="datePublished" content="18 hours ago"/><meta itemprop="dateModified" content="17 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Gary Player's son charged with fraud</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/10767427-1.jpg" width="1100" height="750" alt="" title="Apr 5, 2018; Augusta, GA, USA; Gary Player hits a ceremonial tee shot on the 1st hole during the first round of the Masters golf tournament at Augusta National GC. Mandatory Credit: Michael Madrid-USA TODAY Sports" data-portal-copyright="Michael Madrid-USA TODAY Sports"/></p> <p> Wayne Player,</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Gary Player&#8217;s son charged with fraud</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/10767427-1.jpg" width="1100" height="750" alt="" title="Apr 5, 2018; Augusta, GA, USA; Gary Player hits a ceremonial tee shot on the 1st hole during the first round of the Masters golf tournament at Augusta National GC. Mandatory Credit: Michael Madrid-USA TODAY Sports" data-portal-copyright="Michael Madrid-USA TODAY Sports"></p><p> Wayne Player, the son of nine-time golf major winner Gary Player, was arrested in South Carolina last week and charged with fraud in connection with last year&#8217;s Masters Tournament. </p> </p><p> According to the Augusta Chronicle, Wayne Player, 56, was charged with &#8220;deposit account fraud/bad check&#8221; after a check he wrote for two nights of a house rental at last year&#8217;s Masters was returned for insufficient funds. </p> </p><p> Subsequent attempts by the homeowner to reach Wayne Player were unsuccessful, until the son of the three-time Masters champion offered $1,000 to settle the debt. That payment never arrived, and the homeowner contacted police in July of last year. </p> </p><p> According to the Golf Channel, Wayne Player is also involved in a separate lawsuit for acting in &#8220;bad faith&#8221; over failing to deliver on a $6,850 Masters experience in 2018 that was said to include an open-bar dinner, tickets to the Par-3 Contest, tickets to the opening round of the Masters, and an audience with Gary Player. </p> </p><p> Gary Player won the Masters in 1961, 1974 and 1978. He won the U.S. Open in 1965, the British Open in 1959, 1968 and 1974, and the PGA Championship in 1962 and 1972. He is one of just five golfers to have completed the career grand slam. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Gary Player&#8217;s son charged with fraud');return false;"><span class="op-btn">Read More</span> <span class="count">146 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fgary-players-son-charged-with-fraud%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Gary Player’s son charged with fraud+http://nfp.news/11le" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Gary Player&#8217;s son charged with fraud&#32;&#32;http://nfp.news/11le" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11le"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/rams-pool-report-pk-zuerlein-foot-limited/" rel="bookmark" title="Rams pool report: PK Zuerlein (foot) limited">Rams pool report: PK Zuerlein (foot) limited</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/rams-pool-report-pk-zuerlein-foot-limited/"/><meta itemprop="datePublished" content="18 hours ago"/><meta itemprop="dateModified" content="17 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Rams pool report: PK Zuerlein (foot) limited</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12080054.jpg" width="1100" height="733" alt="" title="Jan 30, 2019; Atlanta, GA, USA; Los Angeles Rams kicker Greg Zuerlein speaks during a press conference at Marriott Atlanta Buckhead. Mandatory Credit: Jason Getz-USA TODAY Sports" data-portal-copyright="Jason Getz-USA TODAY Sports"/></p> <p> FLOWERY BRANCH, Georgia -- The Rams got back into their</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Rams pool report: PK Zuerlein (foot) limited</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12080054.jpg" width="1100" height="733" alt="" title="Jan 30, 2019; Atlanta, GA, USA; Los Angeles Rams kicker Greg Zuerlein speaks during a press conference at Marriott Atlanta Buckhead. Mandatory Credit: Jason Getz-USA TODAY Sports" data-portal-copyright="Jason Getz-USA TODAY Sports"></p><p> FLOWERY BRANCH, Georgia &#8212; The Rams got back into their routine Wednesday afternoon with a one-hour, 33-minute practice at the Falcons&#8217; team facility in Flowery Branch. </p> </p><p> &#8220;It was great,&#8221; Rams coach Sean McVay said, &#8220;and it was good really for players and coaches. You almost get away from it a couple of days. It&#8217;s good just to sharpen yourself up, making sure we&#8217;re tightening all the screws on the game plan. I thought the players did a nice job just getting a little bit of a lather. It was really a big emphasis on above the neck, and then tomorrow and Friday will be good to kind of finalize the week.&#8221; </p> </p><p> The Rams&#8217; routine is a walk-through on Wednesdays. They got back to work with no helmets &#8211; other than those with the coach-to-player communication system &#8211; and no hitting while going at half speed. </p> </p><p> Since Week 4, the Rams have held lighter practices on Wednesdays. </p> </p><p> &#8220;Really where I got it from was just learning from our training staff as far as a sports-science approach, just being smart with our players,&#8221; McVay said. &#8220;Earlier in the year, we end up practicing on Wednesdays and then depending upon where we are injury-wise or how our team is feeling, for us this year was after Week 4, we ended up tailoring our Wednesdays back. Guys have handled it really well. I think it&#8217;s been good from a performance standpoint. We&#8217;re able to get a lot of reps, but we don&#8217;t get as much physical work as you&#8217;d like, but that&#8217;s why the Thursdays and the Fridays are so important to us.&#8221; </p> </p><p> Even though it wasn&#8217;t full speed, the Rams were all business as the offense worked against the offense and the defense against the defense for two periods with a special teams period in between. </p> </p><p> &#8220;I think really it&#8217;s good for me to go back and kind of clean some things up and make sure the players feel as comfortable and as confident as possible going into tomorrow and most importantly Sunday,&#8221; McVay said. </p> </p><p> Safety Blake Countess (foot) remained out while kicker Greg Zuerlein (left foot) was limited. Those were the only two players listed on the team&#8217;s injury report. </p> </p><p> &#8220;Greg Zuerlein kicked a little bit, and he&#8217;s on track,&#8221; McVay said. &#8220;And I believe Blake will be good, but we want to be smart with him earlier this week.&#8221; </p> </p><p> Countess, who was listed as questionable on the team&#8217;s status report Friday, did some work with the trainer on the side at the start of practice. </p> </p><p> &#8220;Feel good, feel really good [injury-wise],&#8221; McVay said. &#8220;I think Blake will be OK with his foot and same thing with Greg. Really that&#8217;s all you can ask for this time of year to be as healthy as we are.&#8221; </p> </p><p> The Falcons have made the Rams feel as at home as possible with Rams&#8217; signage throughout the facility. </p> </p><p> &#8220;They&#8217;ve done a great job,&#8221; McVay said. &#8220;I really just think it&#8217;s been a first-class operation since we got here in Atlanta. They&#8217;ve made us feel very welcome. They&#8217;ve done an outstanding job of being great hosts. The facility was set up, and we really can&#8217;t ask for much more than that.&#8221; </p> </p><p> &#8211;Charean Williams, Pro Football Writers of America</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Rams pool report: PK Zuerlein (foot) limited');return false;"><span class="op-btn">Read More</span> <span class="count">486 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Frams-pool-report-pk-zuerlein-foot-limited%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Rams pool report: PK Zuerlein (foot) limited+http://nfp.news/11lf" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Rams pool report: PK Zuerlein (foot) limited&#32;&#32;http://nfp.news/11lf" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11lf"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/cardinals-db-peterson-im-here-to-stay-baby/" rel="bookmark" title="Cardinals DB Peterson: &#8216;I&#8217;m here to stay, baby&#8217;">Cardinals DB Peterson: &#8216;I&#8217;m here to stay, baby&#8217;</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/cardinals-db-peterson-im-here-to-stay-baby/"/><meta itemprop="datePublished" content="18 hours ago"/><meta itemprop="dateModified" content="17 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Cardinals DB Peterson: 'I'm here to stay, baby'</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/11834993.jpg" width="1100" height="733" alt="" title="Dec 9, 2018; Glendale, AZ, USA; Arizona Cardinals cornerback Patrick Peterson (21) reacts against the Detroit Lions at State Farm Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports"/></p> <p> Patrick Peterson used a day of golf</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Cardinals DB Peterson: &#8216;I&#8217;m here to stay, baby&#8217;</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/11834993.jpg" width="1100" height="733" alt="" title="Dec 9, 2018; Glendale, AZ, USA; Arizona Cardinals cornerback Patrick Peterson (21) reacts against the Detroit Lions at State Farm Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports"></p><p> Patrick Peterson used a day of golf Wednesday to confirm that he spoke too soon when requesting a midseason trade from the Arizona Cardinals. </p> </p><p> The cornerback took his tee shot at TPC Scottsdale&#8217;s famed par-3 16th hole during a pro-am round at the Waste Management Phoenix Open, then took to the microphone to address Arizona sports fans. </p> </p><p> &#8220;I just want to apologize to everybody for asking for that trade in the middle of the season,&#8221; Peterson said. &#8220;I&#8217;m here to stay, baby.&#8221; </p> </p><p> Peterson&#8217;s news follows the recent announcement from veteran wide receiver Larry Fitzgerald that he will be back for his 16th season in Arizona. The Cardinals also announced earlier this month that the pass-oriented Kliff Kingsbury will be their new head coach. </p> </p><p> Peterson&#8217;s initial trade request was first reported in October, but he immediately tried to distance himself from the story. His current contract with the Cardinals runs through the 2020 season, and he now seems committed to seeing out that deal. </p> </p><p> &#8220;I think we&#8217;re definitely moving in the right direction,&#8221; Peterson told azcardinals.com on Wednesday. &#8220;I&#8217;m happy with the decisions that ownership made this offseason.&#8221; </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Cardinals DB Peterson: &#8216;I&#8217;m here to stay, baby&#8217;');return false;"><span class="op-btn">Read More</span> <span class="count">138 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fcardinals-db-peterson-im-here-to-stay-baby%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Cardinals DB Peterson: ‘I’m here to stay, baby’+http://nfp.news/11lg" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Cardinals DB Peterson: &#8216;I&#8217;m here to stay, baby&#8217;&#32;&#32;http://nfp.news/11lg" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11lg"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/nfl-notebook-kraft-open-to-brady-extension/" rel="bookmark" title="NFL notebook: Kraft open to Brady extension">NFL notebook: Kraft open to Brady extension</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-notebook-kraft-open-to-brady-extension/"/><meta itemprop="datePublished" content="18 hours ago"/><meta itemprop="dateModified" content="17 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>NFL notebook: Kraft open to Brady extension</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12081539.jpg" width="1100" height="733" alt="" title="Jan 30, 2019; Atlanta, GA, USA; New England Patriots quarterback Tom Brady (12) addresses the media at a press conference for Super Bowl LIII at Hyatt Regency Atlanta. Mandatory Credit: Brett Davis-USA TODAY Sports" data-portal-copyright="Brett Davis-USA TODAY Sports"/></p> <p> New England Patriots</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>NFL notebook: Kraft open to Brady extension</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12081539.jpg" width="1100" height="733" alt="" title="Jan 30, 2019; Atlanta, GA, USA; New England Patriots quarterback Tom Brady (12) addresses the media at a press conference for Super Bowl LIII at Hyatt Regency Atlanta. Mandatory Credit: Brett Davis-USA TODAY Sports" data-portal-copyright="Brett Davis-USA TODAY Sports"></p><p> New England Patriots quarterback Tom Brady has said he wants to play until age 45, and team owner Robert Kraft said Wednesday he wouldn&#8217;t be opposed to that. </p> </p><p> Brady will be 42 as he enters the 2019 season, which is the final year of his contract. </p> </p><p> &#8220;Think about it: The last three years, we&#8217;ve been privileged to go to the Super Bowl with a quarterback in place. I would be quite surprised if he didn&#8217;t continue for quite a while as our quarterback,&#8221; Kraft said. </p> </p><p> A contract extension also would give the Patriots a chance to restructure Brady&#8217;s deal. Under the current pact, his contract will count as $27 million against the salary cap in 2019. </p> </p><p> &#8211;Ten days after the controversial end of the NFC championship game, NFL commissioner Roger Goodell said while he understands the frustration of the New Orleans Saints and their fans, it &#8220;was not a consideration&#8221; to overturn the result. </p> </p><p> The Saints lost 26-23 in overtime to the Los Angeles Rams after a pair of penalties were not called against Rams cornerback Nickell Robey-Coleman on a critical third down play late in regulation that would have let New Orleans run most of the time off the clock and almost certainly win with a short field goal. </p> </p><p> Goodell continues to explore with the league&#8217;s competition committee ways to improve the game, including a &#8220;sincere effort&#8221; to evaluate officiating. </p> </p><p> &#8211;Saints coach Sean Payton met the media for his season-ending news conference and said his team will recover from the heartbreaking and controversial loss to the Rams in the NFC championship game. </p> </p><p> &#8220;I would say honestly after the game for two to three days, much like normal people, I sat and probably didn&#8217;t come out of my room, ate Jeni&#8217;s ice cream and watched Netflix for three straight days,&#8221; Payton said. </p> </p><p> &#8211;The NFL is reviewing options to allow coaches to challenge judgment calls by officials, but their teams would be negatively impacted if a review shows officials got the call right, ESPN&#8217;s Adam Schefter reported. </p> </p><p> Schefter said that if a challenge is wrong, the team could be penalized or time could be run off the clock. He said that by adding such a disincentive, coaches will reserve the option for the most obvious of cases. </p> </p><p> A league source told Schefter that the NFL&#8217;s competition committee likely will pass a rule on judgment calls this offseason and this particular idea has some support. </p> </p><p> &#8211;Patrick Peterson used a day of golf to confirm that he spoke too soon when requesting a midseason trade from the Arizona Cardinals. </p> </p><p> &#8220;I just want to apologize to everybody for asking for that trade in the middle of the season,&#8221; Peterson said. &#8220;I&#8217;m here to stay, baby.&#8221; </p> </p><p> &#8211;New Baltimore Ravens general manager Eric DeCosta has been in his position just a few weeks, and already he&#8217;s facing tough decisions that will affect the future of the franchise. </p> </p><p> First among them is just how to cut ties with veteran quarterback Joe Flacco, and in a news conference, DeCosta said it still be a while before that question is answered. </p> </p><p> Flacco, 34, led the Ravens to a Super Bowl championship in 2013 and has been the starter since 2008. But when an injury in 2018 sent Flacco to the sidelines after Week 9, rookie Lamar Jackson took over and didn&#8217;t relinquish the role. </p> </p><p> &#8211;Carolina Panthers quarterback Cam Newton said his shoulder feels good, nearly a week after arthroscopic surgery. </p> </p><p> Newton, 29, missed the final two games of the 2018 season with a sore throwing shoulder. The team said last Thursday that the procedure was successfully performed in Charlotte, N.C., by team physician Dr. Pat Connor. </p> </p><p> &#8211;New York Giants running back Saquon Barkley said he is confident that if fellow NFL players had a vote for Offensive Rookie of the Year, they&#8217;d vote for him. </p> </p><p> &#8220;If you asked my peers that played against me or coaches that had to play against me, &#8216;Who is Rookie of the Year?&#8217; I think they would say me,&#8221; Barkley said on ESPN&#8217;s &#8220;Get Up.&#8221; </p> </p><p> &#8211;Rob Ryan is back in the NFL, having been hired as the inside linebackers coach for the Washington Redskins. The longtime assistant has been out of the league since being fired by the Buffalo Bills in December 2016. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','NFL notebook: Kraft open to Brady extension');return false;"><span class="op-btn">Read More</span> <span class="count">648 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-notebook-kraft-open-to-brady-extension%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL notebook: Kraft open to Brady extension+http://nfp.news/11lh" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL notebook: Kraft open to Brady extension&#32;&#32;http://nfp.news/11lh" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11lh"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/ravens-gm-flacco-decision-wont-come-before-march/" rel="bookmark" title="Ravens GM: Flacco decision won&#8217;t come before March">Ravens GM: Flacco decision won&#8217;t come before March</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/ravens-gm-flacco-decision-wont-come-before-march/"/><meta itemprop="datePublished" content="22 hours ago"/><meta itemprop="dateModified" content="21 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Ravens GM: Flacco decision won't come before March</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/11856168.jpg" width="1100" height="733" alt="" title="Dec 16, 2018; Baltimore, MD, USA; Baltimore Ravens quarterback Joe Flacco (5) looks on from the sideline against the Tampa Bay Buccaneers at M&amp;T Bank Stadium. Mandatory Credit: Mitch Stringer-USA TODAY Sports" data-portal-copyright="Mitch Stringer-USA TODAY Sports"/></p> <p> New Baltimore Ravens general</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Ravens GM: Flacco decision won&#8217;t come before March</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/11856168.jpg" width="1100" height="733" alt="" title="Dec 16, 2018; Baltimore, MD, USA; Baltimore Ravens quarterback Joe Flacco (5) looks on from the sideline against the Tampa Bay Buccaneers at M&T Bank Stadium. Mandatory Credit: Mitch Stringer-USA TODAY Sports" data-portal-copyright="Mitch Stringer-USA TODAY Sports"></p><p> New Baltimore Ravens general manager Eric DeCosta has been in his position just a few weeks, and already he&#8217;s facing tough decisions that will affect the future of the franchise. </p> </p><p> First among them is just how to cut ties with veteran quarterback Joe Flacco, and in a news conference Wednesday, DeCosta said it still be a while before that question is answered. </p> </p><p> &#8220;I think that&#8217;s an ongoing process,&#8221; DeCosta said. &#8220;The new league year starts in March. We&#8217;ll have a lot of new ideas, strategies, things that we&#8217;ll look at once March rolls around. </p> </p><p> &#8220;Right now, we&#8217;re really focused on the draft and our free agency meetings which will start to take place over the next few weeks. We have discussed Joe. We&#8217;ve discussed a lot of players on the team. I think when the time comes for us to make a decision one way or the other, we will have a plan in place.&#8221; </p> </p><p> One option to benefit the roster would be to trade Flacco and receive players or draft picks in return. </p> </p><p> Flacco, 34, led the Ravens to a Super Bowl championship in 2013 and has been the starter since 2008. But when an injury in 2018 sent Flacco to the sidelines after Week 9, rookie Lamar Jackson took over and didn&#8217;t relinquish the role. </p> </p><p> The Ravens were 4-5 when Flacco went out; Jackson led them to a 6-1 record and the AFC North title the rest of the way. </p> </p><p> In his Baltimore career, Flacco has completed 61.7 percent of his passes for 38,245 yards and 212 touchdowns. </p> </p><p> In March 2016, he signed a three-year, $66.4 million contract extension that runs through the 2021 season. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Ravens GM: Flacco decision won&#8217;t come before March');return false;"><span class="op-btn">Read More</span> <span class="count">217 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fravens-gm-flacco-decision-wont-come-before-march%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Ravens GM: Flacco decision won’t come before March+http://nfp.news/11l6" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Ravens GM: Flacco decision won&#8217;t come before March&#32;&#32;http://nfp.news/11l6" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11l6"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/son-of-gary-player-arrested-for-fraud/" rel="bookmark" title="Son of Gary Player arrested for fraud">Son of Gary Player arrested for fraud</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/son-of-gary-player-arrested-for-fraud/"/><meta itemprop="datePublished" content="22 hours ago"/><meta itemprop="dateModified" content="21 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Son of Gary Player arrested for fraud</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/10767427.jpg" width="1100" height="750" alt="" title="Apr 5, 2018; Augusta, GA, USA; Gary Player hits a ceremonial tee shot on the 1st hole during the first round of the Masters golf tournament at Augusta National GC. Mandatory Credit: Michael Madrid-USA TODAY Sports" data-portal-copyright="Michael Madrid-USA TODAY Sports"/></p> <p> Wayne</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Son of Gary Player arrested for fraud</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/10767427.jpg" width="1100" height="750" alt="" title="Apr 5, 2018; Augusta, GA, USA; Gary Player hits a ceremonial tee shot on the 1st hole during the first round of the Masters golf tournament at Augusta National GC. Mandatory Credit: Michael Madrid-USA TODAY Sports" data-portal-copyright="Michael Madrid-USA TODAY Sports"></p><p> Wayne Player, the son of nine-time golf major winner Gary Player, was arrested in South Carolina last week and charged with fraud in connection with last year&#8217;s Masters Tournament. </p> </p><p> According to the Augusta Chronicle, Wayne Player, 56, was charged with &#8220;deposit account fraud/bad check&#8221; after a check he wrote for two nights of a house rental at last year&#8217;s Masters was returned for insufficient funds. </p> </p><p> Subsequent attempts by the homeowner to reach Wayne Player were unsuccessful, until the son of the three-time Masters champion, offered $1,000 to settle the debt. That payment never arrived, and the homeowner contacted police in July of last year. </p> </p><p> According to the Golf Channel, Wayne Player is also involved in a separate lawsuit for acting in &#8220;bad faith&#8221; over failing to deliver on a $6,850 Masters experience in 2018 that was said to include an open-bar dinner, tickets to the Par-3 Contest, tickets to the opening round of the Masters, and an audience with Gary Player. </p> </p><p> Gary Player won the Masters in 1961, 1974 and 1978. He won the U.S. Open in 1965, the British Open in 1959, 1968 and 1974, and the PGA Championship in 1962 and 1972. He is one of just five golfers to have completed the career grand slam. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Son of Gary Player arrested for fraud');return false;"><span class="op-btn">Read More</span> <span class="count">147 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fson-of-gary-player-arrested-for-fraud%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Son of Gary Player arrested for fraud+http://nfp.news/11l5" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Son of Gary Player arrested for fraud&#32;&#32;http://nfp.news/11l5" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11l5"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/kraft-expects-brady-at-qb-for-quite-a-while/" rel="bookmark" title="Kraft expects Brady at QB &#8216;for quite a while&#8217;">Kraft expects Brady at QB &#8216;for quite a while&#8217;</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/kraft-expects-brady-at-qb-for-quite-a-while/"/><meta itemprop="datePublished" content="22 hours ago"/><meta itemprop="dateModified" content="21 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Kraft expects Brady at QB 'for quite a while'</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/9865844.jpg" width="1100" height="733" alt="" title="Feb 5, 2017; Houston, TX, USA; New England Patriots quarterback Tom Brady (12) with Patriots chairman Robert Kraft before Super Bowl LI at NRG Stadium. Mandatory Credit: Bob Donnan-USA TODAY Sports" data-portal-copyright="Bob Donnan-USA TODAY Sports"/></p> <p> New England Patriots quarterback</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Kraft expects Brady at QB &#8216;for quite a while&#8217;</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/9865844.jpg" width="1100" height="733" alt="" title="Feb 5, 2017; Houston, TX, USA; New England Patriots quarterback Tom Brady (12) with Patriots chairman Robert Kraft before Super Bowl LI at NRG Stadium. Mandatory Credit: Bob Donnan-USA TODAY Sports" data-portal-copyright="Bob Donnan-USA TODAY Sports"></p><p> New England Patriots quarterback Tom Brady has said he wants to play until age 45, and team owner Robert Kraft said Wednesday he wouldn&#8217;t be opposed to that. </p> </p><p> Brady will be 42 as he enters the 2019 season, which is the final year of his contract. </p> </p><p> &#8220;Think about it: The last three years, we&#8217;ve been privileged to go to the Super Bowl with a quarterback in place. I would be quite surprised if he didn&#8217;t continue for quite a while as our quarterback,&#8221; Kraft said following commissioner Roger Goodell&#8217;s news conference. </p> </p><p> Brady and head coach Bill Belichick will be in their ninth Super Bowl together Sunday in Atlanta. This will be their third in a row, defeating the Atlanta Falcons in 2017 and losing to the Philadelphia Eagles last year. </p> </p><p> A contract extension also would give the Patriots a chance to restructure Brady&#8217;s deal. Under the current pact, his contract will count as $27 million against the salary cap in 2019. </p> </p><p> It was clear Wednesday that Kraft isn&#8217;t ready to break up the magic of the team. </p> </p><p> &#8220;Having the head coach Bill Belichick we have and having Tom, there is a unique symmetry there, and chemistry,&#8221; he said. &#8220;It carries over to the whole organization. I think we&#8217;re very lucky.&#8221; </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Kraft expects Brady at QB &#8216;for quite a while&#8217;');return false;"><span class="op-btn">Read More</span> <span class="count">156 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fkraft-expects-brady-at-qb-for-quite-a-while%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Kraft expects Brady at QB ‘for quite a while’+http://nfp.news/11l7" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Kraft expects Brady at QB &#8216;for quite a while&#8217;&#32;&#32;http://nfp.news/11l7" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11l7"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/patriots-goodell-lament-path-of-wr-gordon/" rel="bookmark" title="Patriots, Goodell lament path of WR Gordon">Patriots, Goodell lament path of WR Gordon</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/patriots-goodell-lament-path-of-wr-gordon/"/><meta itemprop="datePublished" content="22 hours ago"/><meta itemprop="dateModified" content="21 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Patriots, Goodell lament path of WR Gordon</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/11872215-1.jpg" width="1100" height="733" alt="" title="Dec 2, 2018; Foxborough, MA, USA; New England Patriots wide receiver Josh Gordon (10) reacts during the second quarter against the Minnesota Vikings at Gillette Stadium. Mandatory Credit: Greg M. Cooper-USA TODAY Sports" data-portal-copyright="Greg M. Cooper-USA TODAY Sports"/></p> <p> ATLANTA -- New</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Patriots, Goodell lament path of WR Gordon</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/11872215-1.jpg" width="1100" height="733" alt="" title="Dec 2, 2018; Foxborough, MA, USA; New England Patriots wide receiver Josh Gordon (10) reacts during the second quarter against the Minnesota Vikings at Gillette Stadium. Mandatory Credit: Greg M. Cooper-USA TODAY Sports" data-portal-copyright="Greg M. Cooper-USA TODAY Sports"></p><p> ATLANTA &#8212; New England Patriots quarterback Tom Brady will take the field at Mercedes-Benz Stadium on Sunday without the benefit of his most naturally gifted receiver. </p> </p><p> Josh Gordon, acquired from the Cleveland Browns, caught 40 passes and scored three touchdowns in 11 total games with the team this season before another indefinite suspension for substance abuse violations. </p> </p><p> The 27-year-old had missed 43 of a possible 48 games in Cleveland&#8217;s previous three seasons prior to the start of the 2018 season. </p> </p><p> Commissioner Roger Goodell has delivered multiple bans to Gordon, but said Wednesday he remains close with the troubled star, propping the door open for reinstatement down the road. </p> </p><p> Goodell said he hasn&#8217;t directly spoken to Gordon because he&#8217;s in treatment, but plans to reach out. The Patriots, according to NESN, are paying for Gordon&#8217;s inpatient treatment. </p> </p><p> &#8220;He&#8217;s working at it. He understands what he has to do,&#8221; Goodell said. &#8220;This is well beyond football, this is his life. He understands the importance of getting this issue under control and being able to live a healthy and long life. If he can, we will evaluate that at the right time.&#8221; </p> </p><p> Gordon was suspended Dec. 20, a short time after he announced he was stepping away from the team to address his wellbeing. Gordon also took a self-imposed sabbatical from the Browns in August. </p> </p><p> Owner Robert Kraft and his son, Jonathan Kraft, both addressed Gordon&#8217;s situation this week. </p> </p><p> &#8220;He was a real good guy, and there was a connection,&#8221; Robert Kraft said in an interview with NBC Boston. &#8220;Unfortunately, people like that need mentoring at a young age, but when it becomes addiction, addiction is something that is way beyond our&#8230; We gave him tremendous support on a daily basis, and he was worthy. But I think we as a society have to try to help these young people not to get addicted in the first place. And that&#8217;s the sad part of this. He&#8217;s a good guy &#8212; a really good guy. It makes us sad.&#8221; </p> </p><p> Jonathan Kraft was sympathetic to Gordon&#8217;s situation but would not say if he&#8217;d get another chance in New England. </p> </p><p> &#8220;You get exposed to it in a whole different way when you come from where Josh Gordon came from. He is a very good kid,&#8221; he said. </p> </p><p> &#8211;By Jeff Reynolds, Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Patriots, Goodell lament path of WR Gordon');return false;"><span class="op-btn">Read More</span> <span class="count">328 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpatriots-goodell-lament-path-of-wr-gordon%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Patriots, Goodell lament path of WR Gordon+http://nfp.news/11l8" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Patriots, Goodell lament path of WR Gordon&#32;&#32;http://nfp.news/11l8" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11l8"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/players-coalition-announces-2m-in-new-grants/" rel="bookmark" title="Players Coalition announces $2M in new grants">Players Coalition announces $2M in new grants</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/players-coalition-announces-2m-in-new-grants/"/><meta itemprop="datePublished" content="22 hours ago"/><meta itemprop="dateModified" content="21 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Players Coalition announces $2M in new grants</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/9858176.jpg" width="1100" height="781" alt="" title="Feb 4, 2017; Houston, TX, USA; Detroit Lions wide receiver Anquan Boldin arrives on the red carpet prior to the 6th Annual NFL Honors at Wortham Theater. Mandatory Credit: Kevin Jairaj-USA TODAY Sports" data-portal-copyright="Kevin Jairaj-USA TODAY Sports"/></p> <p> ATLANTA -- The Players</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Players Coalition announces $2M in new grants</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/9858176.jpg" width="1100" height="781" alt="" title="Feb 4, 2017; Houston, TX, USA; Detroit Lions wide receiver Anquan Boldin arrives on the red carpet prior to the 6th Annual NFL Honors at Wortham Theater. Mandatory Credit: Kevin Jairaj-USA TODAY Sports" data-portal-copyright="Kevin Jairaj-USA TODAY Sports"></p><p> ATLANTA &#8212; The Players Coalition charitable foundation announced six grant recipients for 2019 on Wednesday. </p> </p><p> The grants total $2 million and are focused on nonprofit organizations that &#8220;impact racial and social inequality.&#8221; </p> </p><p> Co-founders Anquan Boldin and Malcolm Jenkins announced the six grantees along with Carolina Panthers wide receiver Torrey Smith: Year Up, Communities In Schools, Advancement Project, National Juvenile Defender Center, Center For Policing Equity and The Justice Collaborative. </p> </p><p> &#8220;Players have come together to work collaboratively because we saw there was an impact we could make as a collective unit,&#8221; said Jenkins. </p> </p><p> The Players Coalition focused in 2018 on &#8220;building awareness and support for national campaigns centered around cash bail reform, juvenile justice, the power of elected public officials, and the importance of voting.&#8221; The Coalition has received funding from the NFL, among other organizations, and worked on grassroots efforts in numerous states. </p> </p><p> The Coalition has worked toward bail reform in Georgia, Louisiana and Florida, raising the age limits for youth prosecution in Massachusetts and helping pass the Clean Slate Act in Pennsylvania, among other initiatives. </p> </p><p> &#8220;The Players Coalition will be around for years to come,&#8221; Boldin said. &#8220;Players have committed their own time, money and resources. </p> </p><p> &#8220;This day for us is a big day. We are grateful to be partnering with you guys. And the work you guys have been doing for so long, that we can work alongside you.&#8221; </p> </p><p> &#8211;Derek Harper, Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Players Coalition announces $2M in new grants');return false;"><span class="op-btn">Read More</span> <span class="count">180 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fplayers-coalition-announces-2m-in-new-grants%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Players Coalition announces $2M in new grants+http://nfp.news/11l9" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Players Coalition announces $2M in new grants&#32;&#32;http://nfp.news/11l9" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11l9"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/belichick-demands-patriots-ace-super-bowl-liii-preparation/" rel="bookmark" title="Belichick demands Patriots ace Super Bowl LIII preparation">Belichick demands Patriots ace Super Bowl LIII preparation</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/belichick-demands-patriots-ace-super-bowl-liii-preparation/"/><meta itemprop="datePublished" content="22 hours ago"/><meta itemprop="dateModified" content="21 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Belichick demands Patriots ace Super Bowl LIII preparation </title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12077015.jpg" width="1100" height="757" alt="" title="Jan 29, 2019; Atlanta, GA, USA; New England Patriots coach Bill Belichick addresses the media during a press conference at the Hyatt Regency Atlanta. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"/></p> <p> ATLANTA - Patriots head coach</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Belichick demands Patriots ace Super Bowl LIII preparation </title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12077015.jpg" width="1100" height="757" alt="" title="Jan 29, 2019; Atlanta, GA, USA; New England Patriots coach Bill Belichick addresses the media during a press conference at the Hyatt Regency Atlanta. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"></p><p> ATLANTA &#8211; Patriots head coach Bill Belichick has good reason to believe the Los Angeles Rams don&#8217;t know what&#8217;s coming Sunday night in Super Bowl LIII. </p> </p><p> Frankly, Belichick himself won&#8217;t know what is coming until he sees players execute it flawlessly on the field the next three days. </p> </p><p> Belichick said if players don&#8217;t exhibit flawless proficiency on the field when working on a certain play, scheme or design, he eliminates it from his game plan. The approach is underscored this week. </p> </p><p> &#8220;We don&#8217;t have a lot of plays left in our season,&#8221; Belichick said at the Hyatt Regency Atlanta on Wednesday afternoon. &#8220;Everybody wants to feel good about the plays we do call.&#8221; </p> </p><p> The Patriots pride themselves on restructuring their approach and &#8220;opponent-specific plans&#8221; for every game. </p> </p><p> &#8220;We see a lot of different things over the course of the year. It&#8217;s hard for us for one size to fit all,&#8221; Belichick said. &#8220;That&#8217;s just kind of the way I was brought up. I want to match up against our opponent as best we can. Sometimes that might mean doing something different than you&#8217;ve done the week before, or month before. </p> </p><p> &#8220;I hear the phrase a lot, &lsquo;once they have it, they have it&#8217; about players (retaining). That doesn&#8217;t work for us. A lot of our learning is reteaching every week. It takes a certain type of individual that can have the motivation and discipline to continue to do that. Throw away last week&#8217;s game plan &#8230; Rebuild the house each week. And at the end of the week move on and start a new one. We demand a lot.&#8221; </p> </p><p> Belichick reminisced Wednesday about sharing his love of football history and books &#8211; they owned more than 4,000 combined, mostly predating the 1950s &#8211; that feeds his meticulous attention to detail. How meticulous? Belichick requires a study of the opponent and circumstances of game day before deciding how to handle the coin flip. </p> </p><p> An element of preparation for Belichick this week was studying film of the Rams against the Detroit Lions. The Lions are coached by former Patriots defensive coordinator Matt Patricia. Not because effective concepts can be copied and pasted into the New England game plan binders for Super Bowl LIII, but to gauge what worked conceptually. </p> </p><p> &#8220;One of the benefits &#8211; a lot of it we&#8217;re familiar with,&#8221; safety Devin McCourty said. &#8220;You know, within this defense, having the ability to adjust to change the game plan within that week. We know there&#8217;s some crossover there.&#8221; </p> </p><p> As per usual, Belichick is leaving little to chance in preparation. Multiple players repeated key statistics coaches have emphasized &#8211; including the five non-offensive touchdowns for the Rams this season &#8211; as they brace for the game plan quizzes Belichick delivers. </p> </p><p> &#8220;We need to know every player that&#8217;s on the active roster. The ones that get eliminated on the inactive list before the game, you don&#8217;t worry about them,&#8221; Belichick said. &#8220;If a player has a tendency in one particular thing more than another, or the way a team utilizes a player differently, we need to know that too.&#8221; </p> </p><p> Why the written tests in support of on-field preparation? The Super Bowl is the ultimate pass-fail exercise. </p> </p><p> &#8220;There&#8217;s no play really to relax on these guys. Screw up one play, they&#8217;ll have it in the end zone,&#8221; Belichick said. </p> </p><p> &#8211;By Jeff Reynolds, Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Belichick demands Patriots ace Super Bowl LIII preparation');return false;"><span class="op-btn">Read More</span> <span class="count">508 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fbelichick-demands-patriots-ace-super-bowl-liii-preparation%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Belichick demands Patriots ace Super Bowl LIII preparation+http://nfp.news/11la" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Belichick demands Patriots ace Super Bowl LIII preparation&#32;&#32;http://nfp.news/11la" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11la"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/blanks-bowl-2-hot-dogs-and-southern-hospitality/" rel="bookmark" title="Blank&#8217;s Bowl: $2 hot dogs and Southern hospitality">Blank&#8217;s Bowl: $2 hot dogs and Southern hospitality</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/blanks-bowl-2-hot-dogs-and-southern-hospitality/"/><meta itemprop="datePublished" content="22 hours ago"/><meta itemprop="dateModified" content="21 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Blank's Bowl: $2 hot dogs and Southern hospitality</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12081281.jpg" width="1100" height="776" alt="" title="Jan 30, 2019; Atlanta, GA, USA; Atlanta Falcons owner Arthur Blank speaks at a press conference for Super Bowl LIII at Super Bowl Media Center. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"/></p> <p> ATLANTA -- Super Bowl LIII</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Blank&#8217;s Bowl: $2 hot dogs and Southern hospitality</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12081281.jpg" width="1100" height="776" alt="" title="Jan 30, 2019; Atlanta, GA, USA; Atlanta Falcons owner Arthur Blank speaks at a press conference for Super Bowl LIII at Super Bowl Media Center. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"></p><p> ATLANTA &#8212; Super Bowl LIII is still four days away and throngs of fans and celebrities have yet to arrive, but Falcons owner Arthur Blank is confident that Atlanta is already positioning itself to have the NFL&#8217;s biggest game return in the not-too-distant future. </p> </p><p> It has been 19 years since the Super Bowl was played in Atlanta, whose metropolitan area boasts a population of nearly six million. Blank was the driving force behind replacing the aging Georgia Dome with the $2 billion Mercedes-Benz Stadium, where fans will consume $2 hot dogs and $3 nachos en masse come Sunday. </p> </p><p> The fan experience has been at the forefront since Day 1 for Blank. </p> </p><p> &#8220;Everything we&#8217;ve done has been focused on the fans,&#8221; he said Wednesday. &#8220;It&#8217;s a showcase for Atlanta, I think, and Atlanta is going to do a great job in putting its best foot forward.&#8221; </p> </p><p> The stadium&#8217;s &#8220;responsive pricing&#8221; has been a buzz term leading up to the Super Bowl. Blank&#8217;s plan to slash the cost of food and beverage has been much debated, but the 76-year-old co-founder of Home Depot said the financial model has been proven successful. </p> </p><p> Blank has welcomed other stadium operators to review the books and understand the economic model behind responsive pricing. He said more than 50 institutions now follow the model, and that the NFL and Major League Soccer ranked Mercedes-Benz Stadium as the No. 1 fan experience when it opened in 2017. </p> </p><p> &#8220;Food and beverage is a big component of that,&#8221; said Blank. &#8220;Our hope is that (responsive pricing) becomes more of a sea change across America. I think all entertainment areas around the country need to acknowledge that if they can. </p> </p><p> &#8220;Our hope that when we did that was to not only do that right thing for Atlanta, but to plant a seed for other operators to be able to do the same thing. It&#8217;s working in terms of the economics, but we didn&#8217;t do it for the economics. We did it because it was the right thing to do for the people who are supporting us.&#8221; </p> </p><p> But Super Bowl LIII is about far more than cheap concession prices for Blank. A 41-year resident of Atlanta, his pride in the growth of the downtown area since the last time the big game was held here is abundantly clear. </p> </p><p> And he doesn&#8217;t want to wait another two decades to see it return. </p> </p><p> &#8220;It&#8217;s a very exciting week, a very rewarding week,&#8221; said Blank. &#8220;And to see the efforts that all of the citizens, local agencies and the communities that have gathered up and done a great job in welcoming everybody. </p> </p><p> &#8220;I&#8217;d like to earn the right to host another Super Bowl. We&#8217;re crossing every &#8216;T,&#8217; dotting every &#8216;I,&#8217; and we&#8217;ll see how the week plays out. </p> </p><p> &#8220;But I&#8217;m very confident that we&#8217;ll see another Super Bowl.&#8221; </p> </p><p> And if President Trump decides to drop in Sunday as he did when Atlanta hosted the College Football Playoff title game in 2018? </p> </p><p> &#8220;We&#8217;d love to have him,&#8221; Blank said with a smile. </p> </p><p> &#8211;Derek Harper, Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Blank&#8217;s Bowl: $2 hot dogs and Southern hospitality');return false;"><span class="op-btn">Read More</span> <span class="count">451 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fblanks-bowl-2-hot-dogs-and-southern-hospitality%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Blank’s Bowl: $2 hot dogs and Southern hospitality+http://nfp.news/11lb" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Blank&#8217;s Bowl: $2 hot dogs and Southern hospitality&#32;&#32;http://nfp.news/11lb" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11lb"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/buccaneers-wr-jackson-interested-in-joining-rams/" rel="bookmark" title="Buccaneers WR Jackson interested in joining Rams">Buccaneers WR Jackson interested in joining Rams</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/buccaneers-wr-jackson-interested-in-joining-rams/"/><meta itemprop="datePublished" content="22 hours ago"/><meta itemprop="dateModified" content="21 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Buccaneers WR Jackson interested in joining Rams</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/11950603-1.jpg" width="1100" height="732" alt="" title="Nov 25, 2018; Tampa, FL, USA; Tampa Bay Buccaneers wide receiver DeSean Jackson (11) runs with the ball during the first half at Raymond James Stadium. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports"/></p> <p> Tampa Bay Buccaneers wide receiver</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Buccaneers WR Jackson interested in joining Rams</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/11950603-1.jpg" width="1100" height="732" alt="" title="Nov 25, 2018; Tampa, FL, USA; Tampa Bay Buccaneers wide receiver DeSean Jackson (11) runs with the ball during the first half at Raymond James Stadium. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports"></p><p> Tampa Bay Buccaneers wide receiver DeSean Jackson does not care for the state taxes in California, but he concedes he might be willing to dip a little further in his pocket if a chance to join the Los Angeles Rams became available. </p> </p><p> There is just one problem: Jackson still has one more year remaining on his contract with the Buccaneers for a non-guaranteed $10 million. </p> </p><p> Jackson pondered the future while appearing on the Simms and Lefkoe Podcast on Tuesday. The podcast is the product of Bleacher Report&#8217;s Adam Lefkoe and former quarterback Chris Simms. </p> </p><p> Jackson started out by saying he would not care for joining the San Francisco 49ers, mentioning California taxes and not the state of the team that went 4-12 last season. He then moved on to a team a little further south. </p> </p><p> &#8220;I don&#8217;t know. &#8230; If anything, I would like to kind of end up in L.A., being a Ram,&#8221; Jackson said. &#8220;(Head coach) Sean McVay, you know, we got some connection from when I was in D.C., but we&#8217;ll see how it plays out, man. Right now, I got another year in Tampa. So we&#8217;ll see how it plays out, man.&#8221; </p> </p><p> Jackson was born in Los Angeles, attended Long Beach (Calif.) Poly High School and played at Cal in the northern part of the state. </p> </p><p> Jackson caught 41 passes for 774 yards and four touchdowns for the Buccaneers last season, missing time with thumb and Achilles injuries. </p> </p><p> He has 589 receptions over 11 seasons with the Philadelphia Eagles, Washington Redskins and Buccaneers, collecting 10,261 yards and 53 touchdowns. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Buccaneers WR Jackson interested in joining Rams');return false;"><span class="op-btn">Read More</span> <span class="count">207 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fbuccaneers-wr-jackson-interested-in-joining-rams%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Buccaneers WR Jackson interested in joining Rams+http://nfp.news/11lc" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Buccaneers WR Jackson interested in joining Rams&#32;&#32;http://nfp.news/11lc" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11lc"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/patriots-pool-report-brown-limited-brady-looks-sharp/" rel="bookmark" title="Patriots pool report: Brown limited, Brady looks sharp">Patriots pool report: Brown limited, Brady looks sharp</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/patriots-pool-report-brown-limited-brady-looks-sharp/"/><meta itemprop="datePublished" content="22 hours ago"/><meta itemprop="dateModified" content="21 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Patriots pool report: Brown limited, Brady looks sharp</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12077017.jpg" width="1100" height="749" alt="" title="Jan 29, 2019; Atlanta, GA, USA; New England Patriots quarterback Tom Brady addresses the media during a press conference at the Hyatt Regency Atlanta. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"/></p> <p> ATLANTA -- The New England Patriots</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Patriots pool report: Brown limited, Brady looks sharp</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12077017.jpg" width="1100" height="749" alt="" title="Jan 29, 2019; Atlanta, GA, USA; New England Patriots quarterback Tom Brady addresses the media during a press conference at the Hyatt Regency Atlanta. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"></p><p> ATLANTA &#8212; The New England Patriots held their first practice in Atlanta on Wednesday afternoon, wearing helmets and shells for an 88-minute session in Georgia Tech&#8217;s indoor practice facility, just over a mile from the team&#8217;s downtown hotel. </p> </p><p> There was one addition to the injury report: Defensive tackle Malcom Brown was limited with a calf injury, head coach Bill Belichick said. Brown was at practice wearing his helmet but spent most of the session on the sideline. Everyone else was a full participant, Belichick said. </p> </p><p> &#8220;He did some stuff early in practice today,&#8221; Belichick said of Brown. &#8220;Everybody else was good to go.&#8221; </p> </p><p> The Patriots began practice at 12:30 p.m., starting with some walk-through plays and a special teams period. The starting offense and defense then alternated driving the length of the 80-yard turf field, running 11-on-11 plays against the scout team mimicking the Los Angeles Rams personnel. </p> </p><p> Quarterback Tom Brady looked sharp, starting off with a few up-tempo plays as the team piped in Guns N&#8217; Roses&#8217; &#8220;Sweet Child O&#8217; Mine,&#8221; raising the music&#8217;s volume before the offense was preparing to snap the ball. </p> </p><p> Brady celebrated one successful play by raising his arms to make the touchdown signal. He continued encouraging his teammates through practice, at one point offering a thumbs-up and later patting his offensive linemen and receiver Phillip Dorsett on the helmet. </p> </p><p> Brady ended the final period of practice with two touchdown passes against the scout-team defense. Afterward, players did some extra individual work on the field, and Brady stayed with center David Andrews and a few offensive teammates to practice exchanges and handoffs. </p> </p><p> &#8220;We are way ahead of where we normally are on Wednesday, but we are trying to keep it as a Wednesday-Thursday-Friday and get into our normal routine, which has worked pretty well for us this year,&#8221; Belichick said. </p> </p><p> The Patriots held one padded practice in Foxborough, Mass., last week and opted to work in just upper shells Wednesday. </p> </p><p> &#8220;We were in pads last week,&#8221; Belichick said. &#8220;I think we will be ready to go.&#8221; </p> </p><p> Belichick seemed pleased with the Patriots&#8217; set-up in Atlanta, noting &#8220;there is not a lot of travel time&#8221; between their hotel and Georgia Tech&#8217;s campus. The Patriots practiced indoors all last week while they were still in Foxborough and will conduct all their work indoors this week as well. </p> </p><p> &#8220;There are 20-story skyscrapers surrounding the field,&#8221; Belichick said. &#8220;I don&#8217;t think we can have a public practice out there.&#8221; </p> </p><p> The CBS broadcast team that will be calling Super Bowl LIII, including play-by-play announcer Jim Nantz, color commentator Tony Romo and sideline reporter Tracy Wolfson, was in attendance. </p> </p><p> Before the Patriots headed to shower and make the approximately 10-minute bus ride back to the hotel, Belichick gathered his players at the middle of the field for a brief message with a few reminders. </p> </p><p> &#8220;What our schedule is, what we need to do between now and tomorrow in terms of preparation, physical and mental,&#8221; Belichick said. &#8220;We are getting there. We&#8217;ve still got four days, really. But we are getting there.&#8221; </p> </p><p> &#8211;By Jenny Vrentas, Pro Football Writers of America</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Patriots pool report: Brown limited, Brady looks sharp');return false;"><span class="op-btn">Read More</span> <span class="count">466 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpatriots-pool-report-brown-limited-brady-looks-sharp%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Patriots pool report: Brown limited, Brady looks sharp+http://nfp.news/11ld" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Patriots pool report: Brown limited, Brady looks sharp&#32;&#32;http://nfp.news/11ld" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11ld"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/netflix-ice-cream-helped-payton-cope-with-saints-loss/" rel="bookmark" title="Netflix, ice cream helped Payton cope with Saints&#8217; loss">Netflix, ice cream helped Payton cope with Saints&#8217; loss</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/netflix-ice-cream-helped-payton-cope-with-saints-loss/"/><meta itemprop="datePublished" content="2019-01-30"/><meta itemprop="dateModified" content="2019-01-30"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Netflix, ice cream helped Payton cope with Saints' loss</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12030041.jpg" width="1100" height="918" alt="" title="Jan 20, 2019; New Orleans, LA, USA; New Orleans Saints head coach Sean Payton during the first quarter in the NFC Championship game against the Los Angeles Rams at Mercedes-Benz Superdome. Mandatory Credit: John David Mercer-USA TODAY Sports" data-portal-copyright="John David Mercer-USA</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Netflix, ice cream helped Payton cope with Saints&#8217; loss</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/01/12030041.jpg" width="1100" height="918" alt="" title="Jan 20, 2019; New Orleans, LA, USA; New Orleans Saints head coach Sean Payton during the first quarter in the NFC Championship game against the Los Angeles Rams at Mercedes-Benz Superdome. Mandatory Credit: John David Mercer-USA TODAY Sports" data-portal-copyright="John David Mercer-USA TODAY Sports"></p><p> New Orleans Saints coach Sean Payton met the media Wednesday for his season-ending news conference and said his team will recover from the heartbreaking and controversial loss to the Los Angeles Rams in the NFC championship game. </p> </p><p> &#8220;This one, where it happened in the postseason, we&#8217;ve gotta be able to get past that. And we will,&#8221; Payton said. </p> </p><p> &#8220;We&#8217;ve got good leadership on this team. I don&#8217;t know that you ever really get over it but you do get past it. And there&#8217;s enough resolve that this time away is healthy. And when it starts back up again in the spring &#8230; you get back at it again.&#8221; </p> </p><p> Still, he acknowledged that the days following the Saints&#8217; 26-23 overtime loss to the Rams on Jan. 20 &#8212; marred by a no-call on a play that the league admitted should have been called pass interference or helmet-to-helmet contact &#8212; were tough. </p> </p><p> &#8220;What is it now, a week and a half? It feels like it&#8217;s been longer than that,&#8221; Payton said. </p> </p><p> &#8220;I would say honestly after the game for two to three days, much like normal people, I sat and probably didn&#8217;t come out of my room, ate Jeni&#8217;s ice cream and watched Netflix for three straight days.&#8221; </p> </p><p> He did have some phone conversations during that time, though. </p> </p><p> The NFL&#8217;s head of officials, Al Riveron, called him immediately after the game and was &#8220;fantastic&#8221; and &#8220;brutally honest&#8221; during their conversation, Payton said, about the missed calls on a pass intended for receiver Tommylee Lewis. </p> </p><p> He said he also talked to commissioner Roger Goodell and NFL executive vice president of football operations Troy Vincent. </p> </p><p> &#8220;My discussions briefly on Monday and Tuesday with the commissioner and Troy were relative to &#8212; not any type of reversal or anything like that &#8212; just the play and any statement,&#8221; Payton said. &#8220;But there&#8217;s tons of people that reach out to you, you get a ton of text messages and emails, and you&#8217;re appreciative of all that, then you just want to disappear into your cave for a little while.&#8221; </p> </p><p> Payton is a member of the NFL competition committee and said he is hopeful the committee will find a way for so-called &#8220;judgment calls&#8221; to be reviewed. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Netflix, ice cream helped Payton cope with Saints&#8217; loss');return false;"><span class="op-btn">Read More</span> <span class="count">320 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnetflix-ice-cream-helped-payton-cope-with-saints-loss%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Netflix, ice cream helped Payton cope with Saints’ loss+http://nfp.news/11kz" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Netflix, ice cream helped Payton cope with Saints&#8217; loss&#32;&#32;http://nfp.news/11kz" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/11kz"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article></div></div></div></div></div></div><a href="#" id="fl-to-top"><i class="fa fa-chevron-up"></i></a><style>[class*="fa fa-"]{font-family:FontAwesome !important;}</style>
<noscript id="wpfc-google-fonts"><link rel='stylesheet' id='sab-font-css' href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,700,400italic,700italic&#038;subset=latin' type='text/css' media='all'/>
<link rel='stylesheet' id='fl-builder-google-fonts-a0dc0f37a2c19d739b7445c77d065820-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C700%7CRoboto+Condensed%3A700%7COpen+Sans+Condensed%3A700&#038;ver=4.9.9' type='text/css' media='all'/>
</noscript>
<link rel='stylesheet' id='font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=2.1.4.3' type='text/css' media='all'/>
<script>var posts_table_params={"ajax_url":"https:\/\/nationalfootballpost.com\/wp-admin\/admin-ajax.php","ajax_nonce":"cd457abb26","wrapper_class":"posts-table-wrapper bb-theme","language":{"info":"Showing _START_ to _END_ of _TOTAL_ entries","infoEmpty":"Showing 0 entries","infoFiltered":"(_MAX_ entries in total)","lengthMenu":"Show _MENU_ entries","emptyTable":"No data available in table.","zeroRecords":"No matching records found.","search":"Search:","paginate":{"first":"First","last":"Last","next":"Next","previous":"Previous"},"thousands":",","decimal":".","aria":{"sortAscending":": activate to sort column ascending","sortDescending":": activate to sort column descending"},"filterBy":"Filter:","resetButton":"Reset"}};</script>
<!--[if lt IE 9]><script src="//nationalfootballpost.com/wp-content/cache/wpfc-minified/8z16d3ot/7xcbf.js"></script><![endif]-->
<!--[if lt IE 9]><script src="//nationalfootballpost.com/wp-content/cache/wpfc-minified/lbeld6mi/7xcbf.js"></script><![endif]-->
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/nationalfootballpost.com\/","sameAs":["http:\/\/facebook.com\/nationalfootballpost","https:\/\/twitter.com\/footballpost"],"@id":"https:\/\/nationalfootballpost.com\/#organization","name":"National Football Post","logo":"http:\/\/footballpost.wpengine.com\/wp-content\/uploads\/2018\/05\/NFPlogo-400.png"}</script>
<script src='//nationalfootballpost.com/wp-content/cache/wpfc-minified/qlb18u0t/7xcbe.js' type="text/javascript"></script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-5166086-1"></script>
<script>window.dataLayer=window.dataLayer||[];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-5166086-1');</script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/clipboard.js/1.5.10/clipboard.min.js"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>
<script>jQuery(function($){
$('button').tooltip({
trigger: 'click',
placement: 'bottom'
});
function setTooltip(btn, message){
$(btn).tooltip('hide')
.attr('data-original-title', message)
.tooltip('show');
}
function hideTooltip(btn){
setTimeout(function(){
$(btn).tooltip('hide');
}, 1000);
}
var clipboard=new Clipboard('button');
clipboard.on('success', function(e){
setTooltip(e.trigger, 'Link copied to clipboard');
hideTooltip(e.trigger);
});
clipboard.on('error', function(e){
setTooltip(e.trigger, 'Failed!');
hideTooltip(e.trigger);
});
});</script>
<script defer src='//nationalfootballpost.com/wp-content/cache/wpfc-minified/6mqm6t2g/7xcbe.js' type="text/javascript"></script>
<script>document.addEventListener('DOMContentLoaded',function(){function wpfcgl(){var wgh=document.querySelector('noscript#wpfc-google-fonts').innerText, wgha=wgh.match(/<link[^\>]+>/gi);for(i=0;i<wgha.length;i++){var wrpr=document.createElement('div');wrpr.innerHTML=wgha[i];document.body.appendChild(wrpr.firstChild);}}wpfcgl();});</script>
<script >document.addEventListener('DOMContentLoaded',function(){
jQuery(document).ready(function($){
$(window).scroll(function(){
var footerPos=$('footer').last().position().top;
var pos=$(window).scrollTop();
if(pos+(screen.height*4) > footerPos){
if($(".centil-infinite-scroll").first().hasClass('working')){
return false;
}else{
$(".centil-infinite-scroll").first().addClass('working');
}
var centilNextPostId=$(".centil-infinite-scroll").first().text();
var data={
'action': 'centil_is',
'centilNextPostId': centilNextPostId
};
jQuery.post('https://nationalfootballpost.com/wp-admin/admin-ajax.php', data, function(response){
$(".centil-infinite-scroll").first().replaceWith(response);
}, 'html');
}
var currUrl=$(".centil-post-header").first().attr("url");
var currTitle=$(".centil-post-header").first().attr("title");
if($(".centil-post-header").length > 1&&history.pushState){
for (var i=0; i<$(".centil-post-header").length; i++){
if(pos+(screen.height/2) >=$(".centil-post-header").eq(i).next().position().top){
currUrl=$(".centil-post-header").eq(i).attr("url");
currTitle=$(".centil-post-header").eq(i).attr("title");
}}
}
if(location.href!=currUrl){
history.pushState({}, currTitle, currUrl);
}});
});});</script>
</body>
</html><!-- WP Fastest Cache file was created in 5.60380196571 seconds, on 31-01-19 17:39:49 -->