<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8"/>
<meta name='viewport' content='width=device-width, initial-scale=1.0'/>
<meta http-equiv='X-UA-Compatible' content='IE=edge'/>
<link rel="profile" href="https://gmpg.org/xfn/11"/>
<link rel="pingback" href="https://nationalfootballpost.com/xmlrpc.php"/>
<title>Report: Incognito, Raiders agree to one-year deal - National Football Post</title>
<link rel="canonical" href="https://nationalfootballpost.com/report-incognito-raiders-agree-to-one-year-deal/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Report: Incognito, Raiders agree to one-year deal - National Football Post"/>
<meta property="og:description" content="Report: Incognito, Raiders agree to one-year deal Guard Richie Incognito will sign a one-year deal with the Oakland Raiders, NFL Network&#8217;s Ian Rapoport reported Tuesday. He visited the Raiders earlier this month. Incognito, who turns 36 in July, last played for the Buffalo Bills in the 2017 season. He announced his retirement in April 2018,&hellip;"/>
<meta property="og:url" content="https://nationalfootballpost.com/report-incognito-raiders-agree-to-one-year-deal/"/>
<meta property="og:site_name" content="National Football Post"/>
<meta property="article:publisher" content="http://facebook.com/nationalfootballpost"/>
<meta property="article:tag" content="FLM"/>
<meta property="article:section" content="NFL and College Football Articles"/>
<meta property="article:published_time" content="2019-05-28T16:42:03+00:00"/>
<meta property="article:modified_time" content="2019-05-28T16:42:06+00:00"/>
<meta property="og:updated_time" content="2019-05-28T16:42:06+00:00"/>
<meta property="og:image" content="https://nationalfootballpost.com/wp-content/uploads/2019/05/10547209-1.jpg"/>
<meta property="og:image:secure_url" content="https://nationalfootballpost.com/wp-content/uploads/2019/05/10547209-1.jpg"/>
<meta property="og:image:width" content="1100"/>
<meta property="og:image:height" content="760"/>
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="National Football Post &raquo; Feed" href="https://nationalfootballpost.com/feed/"/>
<link rel="stylesheet" type="text/css" href="//nationalfootballpost.com/wp-content/cache/wpfc-minified/2m79n2i1/80n70.css" media="all"/>
<link rel='https://api.w.org/' href='https://nationalfootballpost.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nationalfootballpost.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nationalfootballpost.com/wp-includes/wlwmanifest.xml"/> 
<link rel='shortlink' href='https://nfp.news/13k9'/>
<link rel="alternate" type="application/json+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Freport-incognito-raiders-agree-to-one-year-deal%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Freport-incognito-raiders-agree-to-one-year-deal%2F&#038;format=xml"/>
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','https://www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-5166086-1', 'auto'); ga('send', 'pageview');</script>
<meta name="generator" content="Feed to Post 3.7.5"/>
<link rel="canonical" href="https://footballpost.wpengine.com/newsml/fieldlevelmedia_str_20190528T143753_0800_000039667_1.xml"/><style>.saboxplugin-wrap .saboxplugin-gravatar img{-webkit-border-radius:50%;-moz-border-radius:50%;-ms-border-radius:50%;-o-border-radius:50%;border-radius:50%;}
.saboxplugin-wrap .saboxplugin-authorname a{color:#212121;}
.saboxplugin-wrap .saboxplugin-authorname{font-family:"Roboto Condensed";}
.saboxplugin-wrap .saboxplugin-desc{font-family:Roboto Condensed;}
.saboxplugin-wrap .saboxplugin-desc{font-style:italic;}
.saboxplugin-wrap{margin-top:20px;margin-bottom:10px;padding:5px 5px}
.saboxplugin-wrap .saboxplugin-authorname{font-size:20px;line-height:27px;}
.saboxplugin-wrap .saboxplugin-desc p, .saboxplugin-wrap .saboxplugin-desc{font-size:16px !important;line-height:23px !important;}
.saboxplugin-wrap .saboxplugin-web{font-size:14px;}
.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa:before{font-size:18px;}
.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa{width:36px;height:36px;line-height:36px;}</style><link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-32x32.jpg" sizes="32x32"/>
<link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-192x192.jpg" sizes="192x192"/>
<link rel="apple-touch-icon-precomposed" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-180x180.jpg"/>
<meta name="msapplication-TileImage" content="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-270x270.jpg"/>
<style id="wp-custom-css">.fl-post-cats-tags{padding:0px 0px 0px 0px;border-bottom:4px solid #e6e6e6}
.share-social{border-bottom:4px solid #e6e6e6}
.container{max-width:93%}
.fl-sidebar-left{padding-right:2%;padding-left:0px;}
.fl-post-cats-tags a, .share-social a{text-transform:uppercase;color:#000;font-size:18px;font-weight:600;font-style:normal;}
.fl-archive .fl-post{border-bottom:0px;}
div.share-social{letter-spacing:7px;float:right;padding-top:10px;}
.custom-html-widget li a{font-size:16px;color:#555;font-style:normal;display:block;padding-bottom:4px;font-weight:600;text-transform:uppercase;}
.custom-html-widget li{font-size:14px;color:#7b7b7b;font-style:italic;font-weight:500;text-transform:uppercase;padding-bottom:6px;border-bottom:2px solid #e6e6e6}
.fl-widget-title{border-style:solid;border-width:4px 0px 4px 0px;text-align:center;padding:5px}
.fl-post-title{margin-bottom:0px;}
.fl-post-author{text-transform:uppercase;font-style:italic;font-weight:600;font-size:18px;}
.tooltip-inner{letter-spacing:1px;}
.fl-post-meta-bottom{border-top:none;font-style:italic;margin-top:0;padding-top:10px;float:left;}
.btn-primary{border:none !important;background:0 0 !important;;color:#000 !important;;box-shadow:none !important;;padding:0 !important;;margin-bottom:5px !important;;}
.toptitle h1{font-size:22px;margin-top:5px;margin-bottom:5px;list-style:none;margin:0;padding:0;line-height:40px;width:50%;position:relative;left:25%;margin:0 px;padding:0 px;border:1px solid #AAA;color:white;background:#050505;border-bottom-left-radius:10px;border-bottom-right-radius:10px;font-style:italic;}
.fl-archive .fl-archive-title{display:none;}
.rp4wp-related-post-content{font-size:18px;color:#555;font-style:italic;display:block;font-weight:800;text-transform:uppercase;}</style>
<script data-wpfc-render="false">var Wpfcll={s:[],i:function(){Wpfcll.ss();window.addEventListener('load',function(){window.addEventListener("DOMSubtreeModified",function(e){Wpfcll.ss();Wpfcll.ls(false);},false);Wpfcll.ls(true);});window.addEventListener('scroll',function(){Wpfcll.ls(false);});window.addEventListener('resize',function(){Wpfcll.ls(false);});window.addEventListener('click',function(){Wpfcll.ls(false);});},c:function(e,pageload){var w=document.documentElement.clientHeight || body.clientHeight;var n=pageload ? 0:800;var er=e.getBoundingClientRect();var t=0;var p=e.parentNode;var pr=p.getBoundingClientRect();if(er.x==0 && er.y==0){for(var i=0;i < 10;i++){if(p){if(pr.x==0 && pr.y==0){p=p.parentNode;pr=p.getBoundingClientRect();}else{t=pr.top;break;}}};}else{t=er.top;}if(w - t+n > 0){return true;}return false;},r:function(e,pageload){var s=this;var oc,ot;try{if(s.c(e,pageload)){oc=e.getAttribute("data-wpfc-original-src");ot=e.getAttribute("data-wpfc-original-srcset");if(oc || ot){if(oc){e.setAttribute('src',oc);}if(ot){e.setAttribute('srcset',ot);}e.removeAttribute("data-wpfc-original-src");e.removeAttribute("onload");if(e.tagName=="IFRAME"){e.onload=function(){var s=e.getAttribute("src").match(/templates\/youtube\.html\#(.+)/);var y="https://www.youtube.com/embed/";if(s){try{var i=e.contentDocument || e.contentWindow;if(i.location.href=="about:blank"){e.setAttribute('src',y+s[1]);}}catch(err){e.setAttribute('src',y+s[1]);}}}}}}}catch(error){console.log(error);console.log("==>",e);}},ss:function(){var i=Array.prototype.slice.call(document.getElementsByTagName("img"));var f=Array.prototype.slice.call(document.getElementsByTagName("iframe"));this.s=i.concat(f);},ls:function(pageload){var s=this;[].forEach.call(s.s,function(e,index){s.r(e,pageload);});}};document.addEventListener('DOMContentLoaded',function(){wpfci();});function wpfci(){Wpfcll.i();}</script>
</head>
<body class="post-template-default single single-post postid-105312 single-format-standard fl-preset-default fl-fixed-width fl-scroll-to-top fl-search-active" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="fl-page"> <header class="fl-page-header fl-page-header-fixed fl-page-nav-right fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="fl-page-logo-wrap col-md-3 col-sm-12"> <div class="fl-page-header-logo"> <a href="https://nationalfootballpost.com/"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post"/><meta itemprop="name" content="National Football Post"/></a></div></div><div class="fl-page-fixed-nav-wrap col-md-9 col-sm-12"> <div class="fl-page-nav-wrap"> <nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span><i class="fa fa-bars"></i></span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-top-nav" class="nav navbar-nav navbar-right menu"><li id="menu-item-78448" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a> <ul class="sub-menu"> <li id="menu-item-94464" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li> <li id="menu-item-94463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li> </ul> </li> <li id="menu-item-80343" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a> <ul class="sub-menu"> <li id="menu-item-88321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li> <li id="menu-item-80344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li> <li id="menu-item-78452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li> </ul> </li> <li id="menu-item-78387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a> <ul class="sub-menu"> <li id="menu-item-84427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li> <li id="menu-item-84236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li> </ul> </li> <li id="menu-item-78499" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a> <ul class="sub-menu"> <li id="menu-item-78502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li> <li id="menu-item-78500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li> <li id="menu-item-80079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li> </ul> </li> </ul></div></nav></div></div></div></div></div></header>
<header class="fl-page-header fl-page-header-primary fl-page-nav-centered fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-12 fl-page-header-logo-col"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="https://schema.org/Organization"> <a href="https://nationalfootballpost.com/" itemprop="url"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post"/><meta itemprop="name" content="National Football Post"/></a></div></div></div></div></div><div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span><i class="fa fa-bars"></i></span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-top-nav-1" class="nav navbar-nav menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li> </ul> </li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li> </ul> </li> </ul><div class="fl-page-nav-search"> <a href="javascript:void(0);" class="fa fa-search"></a> <form method="get" role="search" action="https://nationalfootballpost.com/" title="Type and press Enter to search."> <input type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" /> </form></div></div></nav></div></div></header>
<div class="fl-page-content" itemprop="mainContentOfPage"> <div class="fl-archive container"> <div class="row"> <div class="fl-sidebar fl-sidebar-left fl-sidebar-display-desktop col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"> <aside id="custom_html-3" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">RECENT</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/agent-incognito-raiders-agree-to-one-year-deal/" title="Agent: Incognito, Raiders agree to one-year deal">Agent: Incognito, Raiders agree to one-year deal</a> 1 min ago </li><li ><a href="https://nationalfootballpost.com/report-incognito-raiders-agree-to-one-year-deal/" title="Report: Incognito, Raiders agree to one-year deal">Report: Incognito, Raiders agree to one-year deal</a> 1 min ago </li><li ><a href="https://nationalfootballpost.com/report-nfl-to-review-video-of-cowboys-elliott-altercation/" title="Report: NFL to review video of Cowboys&#8217; Elliott altercation">Report: NFL to review video of Cowboys&#8217; Elliott altercation</a> 15 hours ago </li><li ><a href="https://nationalfootballpost.com/na-gifts-caddie-1973-challenger-after-colonial-win/" title="Na gifts caddie 1973 Challenger after Colonial win">Na gifts caddie 1973 Challenger after Colonial win</a> May 27, 2019 </li><li ><a href="https://nationalfootballpost.com/patriots-te-watson-says-he-faces-4-game-ban-for-peds/" title="Patriots TE Watson says he faces 4-game ban for PEDs">Patriots TE Watson says he faces 4-game ban for PEDs</a> May 27, 2019 </li><li ><a href="https://nationalfootballpost.com/na-cruises-to-charles-schwab-victory-for-third-pga-title/" title="Na cruises to Charles Schwab victory for third PGA title">Na cruises to Charles Schwab victory for third PGA title</a> May 26, 2019 </li><li ><a href="https://nationalfootballpost.com/legendary-packers-qb-starr-dies-at-85/" title="Legendary Packers QB Starr dies at 85">Legendary Packers QB Starr dies at 85</a> May 26, 2019 </li><li ><a href="https://nationalfootballpost.com/na-takes-two-stroke-lead-at-charles-schwab/" title="Na takes two-stroke lead at Charles Schwab">Na takes two-stroke lead at Charles Schwab</a> May 25, 2019 </li><li ><a href="https://nationalfootballpost.com/report-winnipeg-to-host-packers-raiders-preseason-tilt/" title="Report: Winnipeg to host Packers-Raiders preseason tilt">Report: Winnipeg to host Packers-Raiders preseason tilt</a> May 25, 2019 </li><li ><a href="https://nationalfootballpost.com/na-charges-up-charles-schwab-leaderboard/" title="Na charges up Charles Schwab leaderboard">Na charges up Charles Schwab leaderboard</a> May 25, 2019 </li></ul></div></aside><aside id="custom_html-7" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">FEATURES</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/caputi-2019-nfl-mock-draft-final/" title="Caputi: 2019 NFL Mock Draft (Final)">Caputi: 2019 NFL Mock Draft (Final)</a> April 25, 2019 </li><li ><a href="https://nationalfootballpost.com/super-bowl-53-betting-preview/" title="Super Bowl 53 Betting Preview – Best Props Picks, Trends">Super Bowl 53 Betting Preview – Best Props Picks, Trends</a> February 3, 2019 </li><li ><a href="https://nationalfootballpost.com/report-brady-defiantly-denies-retirement-question/" title="Report: Brady defiantly denies retirement question">Report: Brady defiantly denies retirement question</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/rams-cooks-responds-to-pats-chung-dig-in-fan-rally/" title="Rams&#8217; Cooks responds to Pats&#8217; Chung dig in fan rally">Rams&#8217; Cooks responds to Pats&#8217; Chung dig in fan rally</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/huge-crowd-sends-patriots-off-to-super-bowl/" title="Huge crowd sends Patriots off to Super Bowl">Huge crowd sends Patriots off to Super Bowl</a> January 27, 2019 </li></ul></div></aside></div><div class="fl-content fl-content-right col-md-9" itemscope="itemscope" itemtype="https://schema.org/Blog"> <article class="fl-post post-105312 post type-post status-publish format-standard hentry category-news tag-flm" id="fl-post-105312" itemscope itemtype="https://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Report: Incognito, Raiders agree to one-year deal </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-incognito-raiders-agree-to-one-year-deal/"/><meta itemprop="datePublished" content="1 min ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" itemprop="text"> <h2><title>Report: Incognito, Raiders agree to one-year deal</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/10547209-1.jpg" width="1100" height="761" alt="" title="Jan 7, 2018; Jacksonville, FL, USA; Buffalo Bills offensive guard Richie Incognito (64) works out prior to the the AFC Wild Card playoff football game at EverBank Field. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports"></p><p> Guard Richie Incognito will sign a one-year deal with the Oakland Raiders, NFL Network&#8217;s Ian Rapoport reported Tuesday. </p> </p><p> He visited the Raiders earlier this month. </p> </p><p> Incognito, who turns 36 in July, last played for the Buffalo Bills in the 2017 season. He announced his retirement in April 2018, citing health reasons, but apparently has improved enough to play. </p> </p><p> &#8220;My liver and kidneys are shutting down,&#8221; Incognito told The Buffalo News at that time. &#8220;The stress is killing me. It&#8217;s just about doing what&#8217;s right. I just want to be in the Hall of Fame.&#8221; </p> </p><p> A four-time Pro Bowl selection, Incognito started 150 career games with the St. Louis Rams, Miami Dolphins and Bills. He was suspended by the Dolphins in 2013 after being accused of bullying teammate Jonathan Martin, and he sat out the 2014 season. </p> </p><p> &#8211;Field Level Media</p></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-incognito-raiders-agree-to-one-year-deal%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Incognito, Raiders agree to one-year deal+http://nfp.news/13k9" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Incognito, Raiders agree to one-year deal&#32;&#32;http://nfp.news/13k9" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13k9"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<div class="related-post"> <article style="overflow: hidden;margin-bottom: 30px;"> <header class="fl-post-header"> <h2 class="fl-post-title" itemprop="headline"> <a href="https://nationalfootballpost.com/agent-incognito-raiders-agree-to-one-year-deal/" rel="bookmark" title="Agent: Incognito, Raiders agree to one-year deal">Agent: Incognito, Raiders agree to one-year deal</a> </h2> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/agent-incognito-raiders-agree-to-one-year-deal/"/><meta itemprop="datePublished" content="1 min ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Agent: Incognito, Raiders agree to one-year deal</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/10547209-2.jpg" width="1100" height="761" alt="" title="Jan 7, 2018; Jacksonville, FL, USA; Buffalo Bills offensive guard Richie Incognito (64) works out prior to the the AFC Wild Card playoff football game at EverBank Field. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports"/></p> <p> Guard Richie Incognito</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Agent: Incognito, Raiders agree to one-year deal</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/10547209-2.jpg" width="1100" height="761" alt="" title="Jan 7, 2018; Jacksonville, FL, USA; Buffalo Bills offensive guard Richie Incognito (64) works out prior to the the AFC Wild Card playoff football game at EverBank Field. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports"></p><p> Guard Richie Incognito will sign a one-year deal with the Oakland Raiders, his agent said Tuesday. </p> </p><p> Incognito visited the Raiders earlier this month and Ken Sarnoff, who represents Incognito, announced the deal Tuesday. </p> </p><p> &#8220;Congrats to client @68INCOGNITO on signing with the @Raiders. #Youngmoneyfootball #JustWinBaby #RaiderNation,&#8221; Sarnoff posted via Twitter. </p> </p><p> Incognito, who turns 36 in July, last played for the Buffalo Bills in the 2017 season. He announced his retirement in April 2018, citing health reasons, but apparently has improved enough to play. </p> </p><p> &#8220;My liver and kidneys are shutting down,&#8221; Incognito told The Buffalo News at that time. &#8220;The stress is killing me. It&#8217;s just about doing what&#8217;s right. I just want to be in the Hall of Fame.&#8221; </p> </p><p> A four-time Pro Bowl selection, Incognito started 150 career games with the St. Louis Rams, Miami Dolphins and Bills. He was suspended by the Dolphins in 2013 after being accused of bullying teammate Jonathan Martin, and he sat out the 2014 season. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Agent: Incognito, Raiders agree to one-year deal');return false;"><span class="op-btn">Read More</span> <span class="count">104 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fagent-incognito-raiders-agree-to-one-year-deal%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Agent: Incognito, Raiders agree to one-year deal+http://nfp.news/13k8" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Agent: Incognito, Raiders agree to one-year deal&#32;&#32;http://nfp.news/13k8" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13k8"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/report-nfl-to-review-video-of-cowboys-elliott-altercation/" rel="bookmark" title="Report: NFL to review video of Cowboys&#8217; Elliott altercation">Report: NFL to review video of Cowboys&#8217; Elliott altercation</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-nfl-to-review-video-of-cowboys-elliott-altercation/"/><meta itemprop="datePublished" content="15 hours ago"/><meta itemprop="dateModified" content="15 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Report: NFL to review video of Cowboys' Elliott altercation</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12009891.jpg" width="1100" height="831" alt="" title="Sep 16, 2018; Arlington, TX, USA; Dallas Cowboys running back Ezekiel Elliott (21) on the bench against the New York Giants at AT&amp;T Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports" data-portal-copyright="Matthew Emmons-USA TODAY Sports"/></p> <p> The NFL likely will investigate</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Report: NFL to review video of Cowboys&#8217; Elliott altercation</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12009891.jpg" width="1100" height="831" alt="" title="Sep 16, 2018; Arlington, TX, USA; Dallas Cowboys running back Ezekiel Elliott (21) on the bench against the New York Giants at AT&T Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports" data-portal-copyright="Matthew Emmons-USA TODAY Sports"></p><p> The NFL likely will investigate an altercation between Dallas Cowboys running back Ezekiel Elliott and a security officer to determine whether Elliott violated any terms of a previous suspension agreement, Yahoo Sports reported Monday. </p> </p><p> Gossip website TMZ posted a video last Monday showing events that took place early May 18 at the Electric Daisy Carnival festival in Las Vegas. The video shows a man identified as Elliott pushing a security guard against a metal railing, and he falls. Elliott then is handcuffed but not arrested. </p> </p><p> An NFL source told Yahoo Sports that the video is reviewable under the league&#8217;s personal conduct policy, especially given Elliott&#8217;s previous six-game suspension after the NFL investigated allegations of abuse made by a former girlfriend. </p> </p><p> Last week, team owner Jerry Jones said he didn&#8217;t expect Elliott to face any discipline and downplayed the incident. </p> </p><p> &#8220;In terms of his status with us, (it) has not been impacted in any way. And frankly, I know how conscientious he has been in the offseason, and that&#8217;s good enough. No, I don&#8217;t see that having any consequences for us.&#8221; </p> </p><p> Cowboys executives have indicated a desire to extend Elliott&#8217;s contract past 2020, when it is due to expire. Elliott, 23, rushed for 1,434 yards and six touchdowns in 15 games last season. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Report: NFL to review video of Cowboys&#8217; Elliott altercation');return false;"><span class="op-btn">Read More</span> <span class="count">159 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-nfl-to-review-video-of-cowboys-elliott-altercation%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: NFL to review video of Cowboys’ Elliott altercation+http://nfp.news/13k5" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: NFL to review video of Cowboys&#8217; Elliott altercation&#32;&#32;http://nfp.news/13k5" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13k5"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/na-gifts-caddie-1973-challenger-after-colonial-win/" rel="bookmark" title="Na gifts caddie 1973 Challenger after Colonial win">Na gifts caddie 1973 Challenger after Colonial win</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/na-gifts-caddie-1973-challenger-after-colonial-win/"/><meta itemprop="datePublished" content="2019-05-27"/><meta itemprop="dateModified" content="2019-05-27"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Na gifts caddie 1973 Challenger after Colonial win</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12774873.jpg" width="1100" height="724" alt="" title="May 26, 2019; Fort Worth, TX, USA; Kevin Na low fives his caddie Kenny Harms after a shot from the fairway on the 18th hole during the final round the Charles Schwab Challenge golf tournament at Colonial Country Club. Mandatory Credit: Ray</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Na gifts caddie 1973 Challenger after Colonial win</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12774873.jpg" width="1100" height="724" alt="" title="May 26, 2019; Fort Worth, TX, USA; Kevin Na low fives his caddie Kenny Harms after a shot from the fairway on the 18th hole during the final round the Charles Schwab Challenge golf tournament at Colonial Country Club. Mandatory Credit: Ray Carlin-USA TODAY Sports" data-portal-copyright="Ray Carlin-USA TODAY Sports"></p><p> Kevin Na claimed nearly $1.3 million for his victory at the Charles Schwab Challenge in Fort Worth, Texas, on Sunday, but his caddie made out pretty well, too. </p> </p><p> Na gave the keys to a shiny blue 1973 Dodge Challenger, one of the prizes awarded to the winner at Colonial Country Club, to the man on his bag, Kenny Harms. </p> </p><p> Harms asked Na during a practice round earlier this week if he could have the car if Na won, and Na said yes. Harms posted photos of the car on Instagram before the tournament began, writing the caption, &#8220;After @kevinna915 wins this week #charlesschwabchallenge This beauty is mine!&#8221; </p> </p><p> Na opened Sunday with a two-shot lead and fired a 4-under 66 to win by four shots, claiming his third PGA Tour victory. After sinking a birdie at 18 to cap his round, Na pointed to the car and said, &#8220;That&#8217;s your car, baby,&#8221; while smiling and embracing Harms. </p> </p><p> &#8220;He knows I was thinking about it,&#8221; Na said afterward. &#8220;I mean, looks like a beautiful car, but little did I know how much that car was worth.&#8221; </p> </p><p> Depending on the condition, the classic model of car can be worth anywhere from around $30,000 to approaching six digits. </p> </p><p> &#8220;He&#8217;s a good salesman, I guess,&#8221; Na said. &#8220;He sold me into it. But I&#8217;m more than happy to give it to him. He deserves it.&#8221; </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Na gifts caddie 1973 Challenger after Colonial win');return false;"><span class="op-btn">Read More</span> <span class="count">175 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fna-gifts-caddie-1973-challenger-after-colonial-win%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Na gifts caddie 1973 Challenger after Colonial win+http://nfp.news/13k4" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Na gifts caddie 1973 Challenger after Colonial win&#32;&#32;http://nfp.news/13k4" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13k4"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/patriots-te-watson-says-he-faces-4-game-ban-for-peds/" rel="bookmark" title="Patriots TE Watson says he faces 4-game ban for PEDs">Patriots TE Watson says he faces 4-game ban for PEDs</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/patriots-te-watson-says-he-faces-4-game-ban-for-peds/"/><meta itemprop="datePublished" content="2019-05-27"/><meta itemprop="dateModified" content="2019-05-27"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Patriots TE Watson says he faces 4-game ban for PEDs</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11492917.jpg" width="1100" height="733" alt="" title="Oct 21, 2018; Baltimore, MD, USA; New Orleans Saints tight end Ben Watson (82) gains yards after the catch defended by Baltimore Ravens safety Tony Jefferson (23) at M&amp;T Bank Stadium. Mandatory Credit: Mitch Stringer-USA TODAY Sports" data-portal-copyright="Mitch Stringer-USA TODAY</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Patriots TE Watson says he faces 4-game ban for PEDs</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11492917.jpg" width="1100" height="733" alt="" title="Oct 21, 2018; Baltimore, MD, USA; New Orleans Saints tight end Ben Watson (82) gains yards after the catch defended by Baltimore Ravens safety Tony Jefferson (23) at M&T Bank Stadium. Mandatory Credit: Mitch Stringer-USA TODAY Sports" data-portal-copyright="Mitch Stringer-USA TODAY Sports"></p><p> New England Patriots tight end Ben Watson was suspended four games for violating the league&#8217;s performance-enhancing drugs policy, a punishment he knew was coming when he came out of retirement this offseason. </p> </p><p> In a statement posted on social media Sunday, Watson said his doctors prescribed him Bio Identical Testosterone Cypionate &#8212; a substance he knew to be banned in the NFL &#8212; in March after he&#8217;d made what he thought was a permanent decision to retire. Nine days after first taking it, Watson was tested by the league. That was about a month before he would change his mind and decide to keep playing. </p> </p><p> &#8220;I complied (with the test) out of habit, never thinking in that moment I&#8217;d want to come back,&#8221; he said in the statement. &#8220;&#8230;Considering myself previously retired, I had forgotten all about my test in March until I got a letter on May 3 saying my results were positive. I was devastated and for obvious reasons didn&#8217;t want to proceed.&#8221; </p> </p><p> Watson said he told interested teams about the test, and the Patriots agreed to sign him earlier this month despite the pending suspension. </p> </p><p> &#8220;This is not how I would want to enter a new locker room and attempt to earn my role on a new team,&#8221; the statement added. &#8220;However, I respect the regulations that have been collectively bargained to promote fairness on the field of play and accept the discipline associated with my infraction.&#8221; </p> </p><p> Watson, 38, hasn&#8217;t missed a game since 2013. He will sit out contests against Pittsburgh, at Miami, against the New York Jets and at Buffalo before being eligible to play in Week 5 at Washington on Oct. 6. </p> </p><p> When he does play, it will be his first appearance for the Patriots since 2009, after playing six seasons with the team that drafted him 32nd overall in 2004. Watson also spent three years in Cleveland and four of the last five in New Orleans. </p> </p><p> Last season, he caught 35 passes for 400 yards and two touchdowns in 16 games (four starts) with the Saints. </p> </p><p> Watson has 530 receptions for 5,885 yards and 44 touchdowns in 195 career games (135 starts). </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Patriots TE Watson says he faces 4-game ban for PEDs');return false;"><span class="op-btn">Read More</span> <span class="count">296 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpatriots-te-watson-says-he-faces-4-game-ban-for-peds%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Patriots TE Watson says he faces 4-game ban for PEDs+http://nfp.news/13k3" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Patriots TE Watson says he faces 4-game ban for PEDs&#32;&#32;http://nfp.news/13k3" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13k3"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/na-cruises-to-charles-schwab-victory-for-third-pga-title/" rel="bookmark" title="Na cruises to Charles Schwab victory for third PGA title">Na cruises to Charles Schwab victory for third PGA title</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/na-cruises-to-charles-schwab-victory-for-third-pga-title/"/><meta itemprop="datePublished" content="2019-05-26"/><meta itemprop="dateModified" content="2019-05-26"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Na cruises to Charles Schwab victory for third PGA title</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12773950.jpg" width="1100" height="752" alt="" title="May 26, 2019; Fort Worth, TX, USA; Kevin Na lines up a putt on the 11th green during the final round the Charles Schwab Challenge golf tournament at Colonial Country Club. Mandatory Credit: Ray Carlin-USA TODAY Sports" data-portal-copyright="Ray Carlin-USA TODAY</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Na cruises to Charles Schwab victory for third PGA title</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12773950.jpg" width="1100" height="752" alt="" title="May 26, 2019; Fort Worth, TX, USA; Kevin Na lines up a putt on the 11th green during the final round the Charles Schwab Challenge golf tournament at Colonial Country Club. Mandatory Credit: Ray Carlin-USA TODAY Sports" data-portal-copyright="Ray Carlin-USA TODAY Sports"></p><p> Kevin Na cruised to his third career PGA tour victory on Sunday, winning the Charles Schwab Challenge in Fort Worth, Texas, by four shots over Tony Finau. </p> </p><p> Na, who started the day with a two-shot lead, increased his cushion early with three birdies over his first six holes Colonial Country Club. </p> </p><p> He balanced bogeys at Nos. 7 and 10 with two more birdies at Nos. 8 and 14. He punctuated his win with a wedge shot on 18 from 148 yards out to within 10 feet and drained the putt for a final birdie and a 4-under round of 66 to finish 13-under 267. </p> </p><p> &#8220;Standing on the first tee, I looked at that wall, and in my head I engraved my name in it, and sure enough it&#8217;s going to be there,&#8221; Na told CBS Sports following his round regarding seeing his name on Colonial&#8217;s Wall of Champions. </p> </p><p> &#8220;Every year I come here, I knew I had a chance to win,&#8221; he continued, noting that the golf course set up to his strengths. &#8220;And I knew before my career was over that I was going to definitely win out here, if not multiple times. It&#8217;s nice to get one, but who knows, maybe I&#8217;ll win a couple more times here before my career is over.&#8221; </p> </p><p> It was the second win in less than a year for the 35-year-old Na, a Las Vegas resident who was born in South Korea but came to the States when he was just 8 years old. He last won at the 2018 Greenbrier event in July, and his best finish this season prior to Fort Worth was a T-5 at the WGC Match Play in March. </p> </p><p> With the win, Na moves up significantly in the FedEx Cup rankings from No. 98 to No. 27, and he also earned 1,000 valuable Presidents Cup points </p> </p><p> First-round leader Finau, who birdied 18 to grab a solo second-place finish, shot 68 to finish at 9 under for the tournament. </p> </p><p> &#8220;I learned a lot about the swing changes that I&#8217;ve made, and I made a nice run,&#8221; said Finau, who is still searching for his second PGA Tour win but now has three runner-up finishes this season. &#8220;I had some looks down the stretch that didn&#8217;t go my way, but made some strides in the golf swing, tried a new putter grip this week, and apparently it seemed to work.&#8221; </p> </p><p> Finau, 29 from Salt Lake City, is currently ranked No. 33 and last won at the Puerto Rico Open in March 2016. </p> </p><p> Finishing tied for third at 8 under were Andrew Putnam (66) and Taiwan&#8217;s C.T. Pan (69), while Sweden&#8217;s Jonas Blixt (68) rounded out the top five at 7 under. </p> </p><p> Jordan Spieth, still seeking his first win since the 2017 Open Championship, fired a final-round 2-over 72 to finish in a five-way tie for eighth place at 5 under. </p> </p><p> Defending champion Justin Rose of England finished T-58 after shooting 70 on Sunday. Scotsman Russell Knox, 33, posted the low round of the day with a bogey-free 65 and also finished T-8. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Na cruises to Charles Schwab victory for third PGA title');return false;"><span class="op-btn">Read More</span> <span class="count">435 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fna-cruises-to-charles-schwab-victory-for-third-pga-title%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Na cruises to Charles Schwab victory for third PGA title+http://nfp.news/13k0" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Na cruises to Charles Schwab victory for third PGA title&#32;&#32;http://nfp.news/13k0" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13k0"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/legendary-packers-qb-starr-dies-at-85/" rel="bookmark" title="Legendary Packers QB Starr dies at 85">Legendary Packers QB Starr dies at 85</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/legendary-packers-qb-starr-dies-at-85/"/><meta itemprop="datePublished" content="2019-05-26"/><meta itemprop="dateModified" content="2019-05-26"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Legendary Packers QB Starr dies at 85</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/10362440.jpg" width="1100" height="916" alt="" title="Oct 22, 2017; Green Bay, WI, USA; Former Green Bay Packers quarterback Bart Starr (C) is honored in the first quarter during the game against the New Orleans Saints at Lambeau Field. Mandatory Credit: Benny Sieu-USA TODAY Sports" data-portal-copyright="Benny Sieu-USA TODAY Sports"/></p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Legendary Packers QB Starr dies at 85</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/10362440.jpg" width="1100" height="916" alt="" title="Oct 22, 2017; Green Bay, WI, USA; Former Green Bay Packers quarterback Bart Starr (C) is honored in the first quarter during the game against the New Orleans Saints at Lambeau Field. Mandatory Credit: Benny Sieu-USA TODAY Sports" data-portal-copyright="Benny Sieu-USA TODAY Sports"></p><p> Iconic former Green Bay Packers quarterback Bart Starr died on Sunday in Birmingham, Ala. </p> </p><p> Starr, who was 85, suffered a major stroke in 2014 and his health had been failing in the years since. </p> </p><p> The family of Starr released a statement through the Packers. </p> </p><p> &#8220;We are saddened to note the passing of our husband, father, grandfather, and friend, Bart Starr,&#8221; it reads, in part. &#8220;He battled with courage and determination to transcend the serious stroke he suffered in September 2014, but his most recent illness was too much to overcome. </p> </p><p> &#8220;While he may always be best known for his success as the Packers quarterback for 16 years, his true legacy will always be the respectful manner in which he treated every person he met, his humble demeanor, and his generous spirit.&#8221; </p> </p><p> A Pro Football Hall of Fame member, Starr played for the Packers from 1956-71 and led the team to five championships, including the first two Super Bowls &#8212; in which he was named MVP. </p> </p><p> Starr led the league in passer rating five times in the 1960s and was named league MVP in 1966. He played in 196 games, starting 157 of them, and had a 94-57-6 record as a starter. </p> </p><p> After retiring from the NFL, Starr coached the Packers from 1975-83. The teams he coached never reached the heights of the teams he quarterbacked, finishing 52-76-3 in his tenure with just one playoff berth. </p> </p><p> Thirty years later, he told an audience in Milwaukee that coaching was &#8220;the greatest mistake I made in my life.&#8221; </p> </p><p> Starr last visited Lambeau Field in 2017 to take part in the festivities commemorating the 50-year anniversary of the team&#8217;s 1967 championship. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Legendary Packers QB Starr dies at 85');return false;"><span class="op-btn">Read More</span> <span class="count">219 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Flegendary-packers-qb-starr-dies-at-85%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Legendary Packers QB Starr dies at 85+http://nfp.news/13jz" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Legendary Packers QB Starr dies at 85&#32;&#32;http://nfp.news/13jz" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13jz"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/na-takes-two-stroke-lead-at-charles-schwab/" rel="bookmark" title="Na takes two-stroke lead at Charles Schwab">Na takes two-stroke lead at Charles Schwab</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/na-takes-two-stroke-lead-at-charles-schwab/"/><meta itemprop="datePublished" content="2019-05-25"/><meta itemprop="dateModified" content="2019-05-25"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Na takes two-stroke lead at Charles Schwab</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12769803.jpg" width="1100" height="733" alt="" title="May 25, 2019; Fort Worth, TX, USA; Kevin Na walks to the 18th green atop the leaderboard by two strokes going into Sundays final round of the Charles Schwab Challenge golf tournament at Colonial Country Club. Mandatory Credit: Ray Carlin-USA TODAY Sports" data-portal-copyright="Ray</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Na takes two-stroke lead at Charles Schwab</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12769803.jpg" width="1100" height="733" alt="" title="May 25, 2019; Fort Worth, TX, USA; Kevin Na walks to the 18th green atop the leaderboard by two strokes going into Sundays final round of the Charles Schwab Challenge golf tournament at Colonial Country Club. Mandatory Credit: Ray Carlin-USA TODAY Sports" data-portal-copyright="Ray Carlin-USA TODAY Sports"></p><p> Kevin Na cooled off a bit after shooting a scorching 62 on Friday, but he still shot 1-under 69 on Saturday to claim a two-stroke lead through three rounds of the Charles Schwab Challenge in Fort Worth, Texas. </p> </p><p> Na sits at 9-under 201 for the tournament at Colonial Country Club, ahead of a cluster of five players at 7 under. </p> </p><p> That group comprises first-round leader Tony Finau (who shot 71), local favorite Jordan Spieth (68), two-time runner-up Jim Furyk (68), Taiwan&#8217;s C.T. Pan (68) and Canada&#8217;s Mackenzie Hughes (65). </p> </p><p> Hughes&#8217; 65 tied for the second-best round of the day behind Charley Hoffman, who shot 63 to jump into a tie for seventh with Austin Cook at 6 under. Three more players are at 5 under, including second-round leader Jonas Blixt of Sweden, who stumbled to a 74. </p> </p><p> Na began his day Saturday as if his Friday round never ended, birdieing Nos. 1 and 2 after hitting both approach shots inside of six feet. But he cooled off from there, parring eight straight holes before double-bogeying the 633-yard par-5 11th with two misplayed sand shots, the first of which came as a fan&#8217;s cell phone went off during his swing. </p> </p><p> He responded by sinking an 18-foot birdie putt at the par-3 13th, then parred out his round. </p> </p><p> &#8220;Over the years, I&#8217;ve had some good rounds (at Colonial), and it&#8217;s a golf course you don&#8217;t have to overpower,&#8221; Na told Golfweek afterward. &#8220;You have to keep it in play. From fairway in, I&#8217;m a pretty good player, so I think it plays right into my game.&#8221; </p> </p><p> Na, who finished fourth at the Charles Schwab Challenge in 2018, last held a 54-hole lead at the same event in 2015, but he shot 2 over in the final round and finished tied for 10th. </p> </p><p> Finau had a quiet day, and his birdie at the second was his only one of the round. He bogeyed No. 5 and the 18th &#8212; after his drive found the water &#8212; missing a chance to hold second place alone. </p> </p><p> Spieth also had a late bogey, at No. 17, which spoiled a previously bogey-free round in which he continued his masterful putting. He drained putts of 29, 21 and 37 feet for his three birdies, all on the front nine. The Dallas native already has set a personal best for total distance of made putts (434 feet, four inches) in any PGA Tour appearance, with 18 holes still to play. </p> </p><p> Still seeking his first win since The Open Championship in July 2017, Spieth is focused on being a bit sharper off the tee in his final round. </p> </p><p> &#8220;I do need to find more [fairways], especially from 12 in,&#8221; he told the Golf Channel. &#8220;I didn&#8217;t hit a fairway from 12 in today, and so you&#8217;re just not going to have any birdie looks if that&#8217;s the case. Certainly, closing tomorrow, it&#8217;d be nice to be playing out of the short grass.&#8221; </p> </p><p> Furyk, who was runner-up to Tom Watson in 1998 and lost in a three-way playoff to Rory Sabbatini in 2007, was bogey-free with two birdies in his round. At 49, he has a chance to become the oldest winner of the tournament. </p> </p><p> Pan was bogey-free and 4 under on the day through 16 holes, but his drives at Nos. 17 and 18 found the rough, leading to back-to-back bogeys. </p> </p><p> Hughes had a terrific round, making five birdies &#8212; including one at the 18th &#8212; and no bogeys to earn a spot in the final pairing. </p> </p><p> Hoffman also went bogey-free, tallying four birdies on the front and three on the back, including one at 18. </p> </p><p> Defending champion Justin Rose of England shot 74 to fall into a tie for 66th at 5 over. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Na takes two-stroke lead at Charles Schwab');return false;"><span class="op-btn">Read More</span> <span class="count">536 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fna-takes-two-stroke-lead-at-charles-schwab%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Na takes two-stroke lead at Charles Schwab+http://nfp.news/13js" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Na takes two-stroke lead at Charles Schwab&#32;&#32;http://nfp.news/13js" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13js"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/report-winnipeg-to-host-packers-raiders-preseason-tilt/" rel="bookmark" title="Report: Winnipeg to host Packers-Raiders preseason tilt">Report: Winnipeg to host Packers-Raiders preseason tilt</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-winnipeg-to-host-packers-raiders-preseason-tilt/"/><meta itemprop="datePublished" content="2019-05-25"/><meta itemprop="dateModified" content="2019-05-25"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Report: Winnipeg to host Packers-Raiders preseason tilt</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/9008103.jpg" width="1100" height="733" alt="" title="Dec 20, 2015; Oakland, CA, USA; Green Bay Packers quarterback Aaron Rodgers (12) eludes pressure against the Oakland Raiders in the second quarter at O.co Coliseum. Mandatory Credit: Cary Edmondson-USA TODAY Sports" data-portal-copyright="Cary Edmondson-USA TODAY Sports"/></p> <p> Winnipeg is reportedly finalizing a</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Report: Winnipeg to host Packers-Raiders preseason tilt</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/9008103.jpg" width="1100" height="733" alt="" title="Dec 20, 2015; Oakland, CA, USA; Green Bay Packers quarterback Aaron Rodgers (12) eludes pressure against the Oakland Raiders in the second quarter at O.co Coliseum. Mandatory Credit: Cary Edmondson-USA TODAY Sports" data-portal-copyright="Cary Edmondson-USA TODAY Sports"></p><p> Winnipeg is reportedly finalizing a deal to host a preseason game between the Green Bay Packers and Oakland Raiders in August, the NFL&#8217;s first-ever appearance in the city and its first in Canada since 2013. </p> </p><p> The game at IG Field, home of the Canadian Football League&#8217;s Winnipeg Blue Bombers, would occur during the third week of the preseason (Aug. 22-26). The Bombers are on the road that week. </p> </p><p> &#8220;We&#8217;re optimistic that we can secure this game,&#8221; Darren Cameron, the team&#8217;s director of public and player relations, told the Winnipeg Free Press on Friday. &#8220;It&#8217;s looking good and we&#8217;re working towards that game, but at this point there&#8217;s nothing more we can comment on.&#8221; </p> </p><p> The newspaper said that representatives from both teams and NFL officials visited the stadium in April to check out the facilities. </p> </p><p> Winnipeg is about four hours by plane and 11 hours by car from Green Bay, Wis. </p> </p><p> The NFL last played a game north of the border when the Atlanta Falcons defeated the Buffalo Bills 34-31 in overtime on Dec. 1, 2013 at the Rogers Centre in Toronto. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Report: Winnipeg to host Packers-Raiders preseason tilt');return false;"><span class="op-btn">Read More</span> <span class="count">127 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-winnipeg-to-host-packers-raiders-preseason-tilt%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Winnipeg to host Packers-Raiders preseason tilt+http://nfp.news/13jr" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Winnipeg to host Packers-Raiders preseason tilt&#32;&#32;http://nfp.news/13jr" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13jr"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/na-charges-up-charles-schwab-leaderboard/" rel="bookmark" title="Na charges up Charles Schwab leaderboard">Na charges up Charles Schwab leaderboard</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/na-charges-up-charles-schwab-leaderboard/"/><meta itemprop="datePublished" content="2019-05-25"/><meta itemprop="dateModified" content="2019-05-25"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Na charges up Charles Schwab leaderboard</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12765613.jpg" width="1100" height="775" alt="" title="May 24, 2019; Fort Worth, TX, USA; Kevin Na plays his shot from the sixth tee during the second round the Charles Schwab Challenge golf tournament at Colonial Country Club. Mandatory Credit: Ray Carlin-USA TODAY Sports" data-portal-copyright="Ray Carlin-USA TODAY Sports"/></p> <p> Kevin Na</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Na charges up Charles Schwab leaderboard</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12765613.jpg" width="1100" height="775" alt="" title="May 24, 2019; Fort Worth, TX, USA; Kevin Na plays his shot from the sixth tee during the second round the Charles Schwab Challenge golf tournament at Colonial Country Club. Mandatory Credit: Ray Carlin-USA TODAY Sports" data-portal-copyright="Ray Carlin-USA TODAY Sports"></p><p> Kevin Na matched the tournament record with a 61 last year at Colonial Country Club, and he nearly did so again Friday in the second round of the Charles Schwab Challenge in Fort Worth, Texas. </p> </p><p> An 8-under-par 62 left Na at 8-under 132, one shot behind the Sweden&#8217;s Jonas Blixt, who carded a 64 on Friday. </p> </p><p> First-round co-leader Tony Finau is also tied for second after a second-round 68. </p> </p><p> Na opened his day perfectly, hitting his second shot on the par-5 first hole within 3 feet of the cup, then sinking the eagle putt. He added six birdies in a bogey-free round. </p> </p><p> &#8220;Last year when I shot 61, I felt like I made everything,&#8221; Na said. &#8220;Kind of almost had that feeling today. With a few holes to go, I felt like I had a chance to challenge my own course record.&#8221; </p> </p><p> Blixt&#8217;s own bogey-free round also included an eagle, when he chipped in from 132 yards at the par-4 17th hole. </p> </p><p> &#8220;I think I&#8217;ve played pretty good this year,&#8221; Blixt said. &#8220;Obviously not had the good finishes yet, but it&#8217;s been up there a bunch of times. If you slow down a little bit &#8230; people are going to pass you. That&#8217;s pretty much what I&#8217;ve been looking for &#8212; a good weekend. &#8230; </p> </p><p> &#8220;Feel like I&#8217;ve been trending for a while. Just need to have a good weekend.&#8221; </p> </p><p> Blixt is alone atop a PGA Tour event after 36 holes for the first time in his career. He owns three wins on the tour, most recently capturing the Zurich Classic of New Orleans team event with Australia&#8217;s Cameron Smith in 2017. </p> </p><p> Slovakia&#8217;s Rory Sabbatini shot a 66 on Friday to claim fourth place at 6 under. </p> </p><p> Five players, including local favorite Jordan Spieth, share fifth place at 5 under. Spieth shot even-par 70 on Friday, leaving him level with Jim Furyk (second-round 66), Taiwan&#8217;s C.T. Pan (67), Nick Watney (68) and Jason Dufner (68). </p> </p><p> Notables who missed the cut include Rickie Fowler (3 over through two rounds) and Spain&#8217;s Jon Rahm (6 over). </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Na charges up Charles Schwab leaderboard');return false;"><span class="op-btn">Read More</span> <span class="count">272 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fna-charges-up-charles-schwab-leaderboard%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Na charges up Charles Schwab leaderboard+http://nfp.news/13jp" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Na charges up Charles Schwab leaderboard&#32;&#32;http://nfp.news/13jp" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13jp"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/nfl-notebook-pacman-jones-retires/" rel="bookmark" title="NFL notebook: &#8216;Pacman&#8217; Jones retires">NFL notebook: &#8216;Pacman&#8217; Jones retires</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-notebook-pacman-jones-retires/"/><meta itemprop="datePublished" content="2019-05-25"/><meta itemprop="dateModified" content="2019-05-25"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>NFL notebook: 'Pacman' Jones retires</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11707302.jpg" width="1100" height="733" alt="" title="Nov 18, 2018; Carson, CA, USA; Denver Broncos defensive back Adam Jones (24) looks on before the game against the Los Angeles Chargers at StubHub Center. Mandatory Credit: Jake Roth-USA TODAY Sports" data-portal-copyright="Jake Roth-USA TODAY Sports"/></p> <p> Cornerback Adam "Pacman" Jones announced his retirement</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>NFL notebook: &#8216;Pacman&#8217; Jones retires</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11707302.jpg" width="1100" height="733" alt="" title="Nov 18, 2018; Carson, CA, USA; Denver Broncos defensive back Adam Jones (24) looks on before the game against the Los Angeles Chargers at StubHub Center. Mandatory Credit: Jake Roth-USA TODAY Sports" data-portal-copyright="Jake Roth-USA TODAY Sports"></p><p> Cornerback Adam &#8220;Pacman&#8221; Jones announced his retirement from the NFL after 12 seasons. </p> </p><p> &#8220;I stand tall and proud as I announce that this beautiful life-changing ride that I have been on in the National Football League has come to an end, I&#8217;m officially hanging my cleats up, with no regrets!&#8221; Jones wrote in a statement released Friday by his agent, Peter Schaffer. </p> </p><p> Jones, 35, has a history of arrests and was plagued by legal issues throughout his career. The NFL suspended him for the 2007 season following a shooting at a Las Vegas strip club that left a man paralyzed. A member of Jones&#8217; entourage was identified as the shooter. </p> </p><p> The Tennessee Titans selected Jones with the No. 6 overall pick of the 2005 NFL Draft, and he played in 30 games over his first two seasons. He also played for the Dallas Cowboys (2008), Cincinnati Bengals (2010-17) and Denver Broncos (2018). </p> </p><p> &#8211;Jacksonville Jaguars running back Leonard Fournette is happy to have a &#8220;clean start.&#8221; </p> </p><p> Fournette was a major disappointment in 2018 for a team that greatly underachieved with a 5-11 mark one season after reaching the AFC Championship Game. But he has had time to decipher his poor campaign and feels he is back on track. </p> </p><p> &#8220;I&#8217;m happy, especially the way I&#8217;m here working with my team right now,&#8221; Fournette told reporters Friday after Jacksonville&#8217;s third organized team activity. He rushed for just 439 yards and five touchdowns in eight games last season after having 1,040 yards and nine scores in 13 games as a rookie in 2017. </p> </p><p> &#8211;Kevin Dyson may have come up a yard short in one of the greatest finishes in Super Bowl history, but he never let up on his pursuit of education &#8212; his own and that of others. </p> </p><p> Nearly 20 years after nearly climbing to the top of the football world, Dyson is sitting atop the academic world at a middle school in Tennessee. As the principal. </p> </p><p> Interim Williamson County superintendent Jason Golden on Friday announced that Dyson, 43, is the new permanent principal at Grassland Middle School in Franklin. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','NFL notebook: &#8216;Pacman&#8217; Jones retires');return false;"><span class="op-btn">Read More</span> <span class="count">280 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-notebook-pacman-jones-retires%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL notebook: ‘Pacman’ Jones retires+http://nfp.news/13jq" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL notebook: &#8216;Pacman&#8217; Jones retires&#32;&#32;http://nfp.news/13jq" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13jq"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/jaguars-rb-fournette-pleased-to-have-clean-start/" rel="bookmark" title="Jaguars RB Fournette pleased to have &#8216;clean start&#8217;">Jaguars RB Fournette pleased to have &#8216;clean start&#8217;</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/jaguars-rb-fournette-pleased-to-have-clean-start/"/><meta itemprop="datePublished" content="2019-05-24"/><meta itemprop="dateModified" content="2019-05-24"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Jaguars RB Fournette pleased to have 'clean start'</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11893220.jpg" width="1100" height="708" alt="" title="Dec 23, 2018; Miami Gardens, FL, USA; Jacksonville Jaguars running back Leonard Fournette (27) runs down the field during the second half against the Miami Dolphins at Hard Rock Stadium. Mandatory Credit: Jasen Vinlove-USA TODAY Sports" data-portal-copyright="Jasen Vinlove-USA TODAY Sports"/></p> <p></p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Jaguars RB Fournette pleased to have &#8216;clean start&#8217;</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11893220.jpg" width="1100" height="708" alt="" title="Dec 23, 2018; Miami Gardens, FL, USA; Jacksonville Jaguars running back Leonard Fournette (27) runs down the field during the second half against the Miami Dolphins at Hard Rock Stadium. Mandatory Credit: Jasen Vinlove-USA TODAY Sports" data-portal-copyright="Jasen Vinlove-USA TODAY Sports"></p><p> Jacksonville Jaguars running back Leonard Fournette is happy to have a &#8220;clean start.&#8221; </p> </p><p> Fournette was a major disappointment in 2018 for a team that greatly underachieved with a 5-11 mark one season after reaching the AFC Championship Game. But he has had time to decipher his poor campaign and feels he is back on track. </p> </p><p> &#8220;I&#8217;m happy, especially the way I&#8217;m here working with my team right now,&#8221; Fournette told reporters Friday after Jacksonville&#8217;s third organized team activity. &#8220;It&#8217;s a new year. We have a new team. We&#8217;re focused, and we have new players. It&#8217;s a new year for us. So it&#8217;s a new everything. It&#8217;s a clean start for a lot of us guys. </p> </p><p> &#8220;We&#8217;re not focused on the past. The past&#8217;s the past. Some things I did, whether it was offseason and I admitted to, yeah, I was wrong. We moved on. We&#8217;re in a good place right now.&#8221; </p> </p><p> Fournette rushed for just 439 yards and five touchdowns in eight games last season after having 1,040 yards and nine scores in 13 games as a rookie in 2017. </p> </p><p> An early-season hamstring injury derailed Fournette and he ended up missing seven games because of ailments and another due to a suspension. </p> </p><p> The bad fortune continued into the offseason when Fournette was arrested and charged with speeding and driving with a suspended license. </p> </p><p> But in terms of offseason workouts, Fournette decided not to train in his hometown of New Orleans. He instead worked out at the University of Wyoming where Ben Iannacchione works as the director of sports performance. </p> </p><p> Iannacchione worked at LSU when Fournette was the Tigers&#8217; star tailback. </p> </p><p> &#8220;I kind of put a lot on myself this offseason, like getting my body right,&#8221; Fournette said. &#8220;Just mentally coming back ready to play football. No distractions. Leaving the outside stuff where it&#8217;s at. I think that&#8217;s one of the biggest things that us players have a problem with. </p> </p><p> &#8220;We face a lot of problems, you know what I mean? We have a lot of issues ourselves. And if we&#8217;re not right with ourselves and then we come out on this field, we&#8217;re not going to be right in the game.&#8221; </p> </p><p> That was certainly an issue for Fournette last season. His suspension was for leaving the bench and getting in a fight with Buffalo Bills defensive lineman Shaq Lawson. He also was caught on video yelling at a fan in the stands during a December loss to the Tennessee Titans. </p> </p><p> Jaguars vice president of football operations Tom Coughlin publicly ripped Fournette &#8212; and fellow running back T.J. Yeldon &#8212; for appearing disinterested during the season finale against the Houston Texans. Fournette was inactive due to a foot injury. </p> </p><p> Jacksonville is looking for a bounce-back season from Fournette and new offensive coordinator John DeFilippo is interested in making him the focal point of the attack. </p> </p><p> &#8220;I&#8217;m going to call it what it is: He&#8217;s going to be a major reason for where our offense goes,&#8221; DeFilippo told reporters. &#8220;I&#8217;m not going to sugarcoat that. Leonard Fournette needs to be a big part of this offense. The harder he works, which he is right now, I think that&#8217;s not only going to be good for our offense but good for our team.&#8221; </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Jaguars RB Fournette pleased to have &#8216;clean start&#8217;');return false;"><span class="op-btn">Read More</span> <span class="count">487 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fjaguars-rb-fournette-pleased-to-have-clean-start%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Jaguars RB Fournette pleased to have ‘clean start’+http://nfp.news/13j9" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Jaguars RB Fournette pleased to have &#8216;clean start&#8217;&#32;&#32;http://nfp.news/13j9" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13j9"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/former-titans-wr-dyson-graduates-to-middle-school-principal/" rel="bookmark" title="Former Titans WR Dyson graduates to middle school principal">Former Titans WR Dyson graduates to middle school principal</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/former-titans-wr-dyson-graduates-to-middle-school-principal/"/><meta itemprop="datePublished" content="2019-05-24"/><meta itemprop="dateModified" content="2019-05-24"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Former Titans WR Dyson graduates to middle school principal</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/10766018.jpg" width="1100" height="733" alt="" title="Apr 3, 2018; Nashville, TN, USA; Former Tennessee Titan Kevin Dyson greets fans before the Titans uniform reveal event held at Broadway and 1st Avenue. Mandatory Credit: Andrew Nelles / The Tennessean Appeal via USA TODAY NETWORK" data-portal-copyright="Andrew Nelles-USA TODAY Sports"</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Former Titans WR Dyson graduates to middle school principal</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/10766018.jpg" width="1100" height="733" alt="" title="Apr 3, 2018; Nashville, TN, USA; Former Tennessee Titan Kevin Dyson greets fans before the Titans uniform reveal event held at Broadway and 1st Avenue. Mandatory Credit: Andrew Nelles / The Tennessean Appeal via USA TODAY NETWORK" data-portal-copyright="Andrew Nelles-USA TODAY Sports"></p><p> Kevin Dyson may have come up a yard short in one of the greatest finishes in Super Bowl history, but he never let up on his pursuit of education &#8212; his own and that of others. </p> </p><p> Nearly 20 years after nearly climbing to the top of the football world, Dyson is sitting atop the academic world at a middle school in Tennessee. As the principal. </p> </p><p> Interim Williamson County superintendent Jason Golden on Friday announced that Dyson, 43, is the new permanent principal at Grassland Middle School in Franklin. </p> </p><p> &#8220;He has served the school well during his interim period, and I&#8217;ve been especially impressed with the positive relationships he&#8217;s built in such a short time,&#8221; Golden told school faculty, according to the school district&#8217;s web site. &#8220;Teaching and learning matter at Grassland, and we look forward to Dr. Dyson leading this great school.&#8221; </p> </p><p> It is quite a change compared to a playoff run in which Dyson took part in two of the most famous plays in recent football history. In Super Bowl 34 in Atlanta on Jan. 30, 2000, Dyson and the Tennessee Titans trailed the St. Louis Rams 23-16 with five seconds to play and the Titans with the ball on the Rams&#8217; 10-yard line. </p> </p><p> Titans quarterback Steve McNair completed a pass for a slanting Dyson, who appeared headed for the end zone and a potential game-tying (or winning) score. But Rams linebacker Mike Jones wrapped Dyson&#8217;s legs and tackled him a yard short of the end zone. The play would become known as &#8220;The Tackle.&#8221; </p> </p><p> Earlier that same postseason, Dyson took a lateral on a kickoff and raced 75 yards down the left sideline and into the end zone with no time left to beat the Buffalo Bills 22-16 in a wild-card game &#8212; &#8220;The Music City Miracle.&#8221; </p> </p><p> While Dyson&#8217;s playing career would be over by the end of 2003, his education had many years left. After earning master&#8217;s degrees in both leadership and teaching from Trevecca Nazarene University in Nashville, Dyson earned his doctorate in leadership and practical practice, also at Trevecca, last July. </p> </p><p> &#8220;A lot of people have looked at me crazy when I&#8217;ve said this, but to me this is a lot greater accomplishment than being drafted in the first round, than my football career,&#8221; Dyson, picked No. 16 overall by the then-Tennessee Oilers in 1998, told The Tennesseean last summer. &#8220;&#8230; I went to school so I could play sports. I had to be eligible. I didn&#8217;t take education nearly as seriously as I should have and as I do as an adult. So this was greater because I&#8217;ve never considered myself academic. &#8230; Until a few years ago, I never wanted to do anything like this. That&#8217;s why it&#8217;s my greatest personal accomplishment. It&#8217;s my Mount Everest.&#8221; </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Former Titans WR Dyson graduates to middle school principal');return false;"><span class="op-btn">Read More</span> <span class="count">404 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fformer-titans-wr-dyson-graduates-to-middle-school-principal%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Former Titans WR Dyson graduates to middle school principal+http://nfp.news/13ja" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Former Titans WR Dyson graduates to middle school principal&#32;&#32;http://nfp.news/13ja" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13ja"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/pacman-jones-retires-from-nfl-2/" rel="bookmark" title="&#8216;Pacman&#8217; Jones retires from NFL">&#8216;Pacman&#8217; Jones retires from NFL</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/pacman-jones-retires-from-nfl-2/"/><meta itemprop="datePublished" content="2019-05-24"/><meta itemprop="dateModified" content="2019-05-24"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>'Pacman' Jones retires from NFL</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11216914-1.jpg" width="1100" height="733" alt="" title="Sep 9, 2018; Denver, CO, USA; Denver Broncos cornerback Adam Jones (24) looks on before a game against the Seattle Seahawks at Broncos Stadium at Mile High. Mandatory Credit: Ron Chenoy-USA TODAY Sports" data-portal-copyright="Ron Chenoy-USA TODAY Sports"/></p> <p> Cornerback Adam "Pacman" Jones announced his</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>&#8216;Pacman&#8217; Jones retires from NFL</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11216914-1.jpg" width="1100" height="733" alt="" title="Sep 9, 2018; Denver, CO, USA; Denver Broncos cornerback Adam Jones (24) looks on before a game against the Seattle Seahawks at Broncos Stadium at Mile High. Mandatory Credit: Ron Chenoy-USA TODAY Sports" data-portal-copyright="Ron Chenoy-USA TODAY Sports"></p><p> Cornerback Adam &#8220;Pacman&#8221; Jones announced his retirement from the NFL after 12 seasons. </p> </p><p> &#8220;I stand tall and proud as I announce that this beautiful life-changing ride that I have been on in the National Football League has come to an end, I&#8217;m officially hanging my cleats up, with no regrets!&#8221; Jones wrote in a statement released Friday by his agent, Peter Schaffer. </p> </p><p> &#8220;How can I not be proud, 13 years in the game man, hell, I sometimes can&#8217;t believe it, but it&#8217;s real. I will forever be grateful for having the opportunity to do what I love for so many years. We climbed through the mud to get here, we broke barriers, we cried, we laughed, we broke cycles, we broke records, we fell, but got &#8230; back up. </p> </p><p> &#8220;&#8230; I appreciate and thank everyone who played a role in my career. Every organization and coach I was blessed to play for, I am forever grateful for the opportunities and memories.&#8221; </p> </p><p> The Tennessee Titans selected Jones with the No. 6 overall pick of the 2005 NFL Draft, and he played in 30 games over his first two seasons. He also played for the Dallas Cowboys (2008), Cincinnati Bengals (2010-17) and Denver Broncos (2018). </p> </p><p> The Broncos signed him before the season and released him after he played in seven games. </p> </p><p> Jones, 35, has a history of arrests and was plagued by legal issues throughout his career. The NFL suspended him for the 2007 season following a shooting at a Las Vegas strip club that left a man paralyzed. A member of Jones&#8217; entourage was identified as the shooter. </p> </p><p> He played the 2009 season in the Canadian Football League. </p> </p><p> Jones retires with 17 career interceptions and 522 tackles. He also returned 192 punts for 1,944 yards and five touchdowns, and gained 3,232 yards on 125 kickoff returns. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','&#8216;Pacman&#8217; Jones retires from NFL');return false;"><span class="op-btn">Read More</span> <span class="count">235 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpacman-jones-retires-from-nfl-2%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=‘Pacman’ Jones retires from NFL+http://nfp.news/13j7" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=&#8216;Pacman&#8217; Jones retires from NFL&#32;&#32;http://nfp.news/13j7" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13j7"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/pacman-jones-retires-from-nfl/" rel="bookmark" title="&#8216;Pacman&#8217; jones retires from NFL">&#8216;Pacman&#8217; jones retires from NFL</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/pacman-jones-retires-from-nfl/"/><meta itemprop="datePublished" content="2019-05-24"/><meta itemprop="dateModified" content="2019-05-24"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>'Pacman' jones retires from NFL</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11216914.jpg" width="1100" height="733" alt="" title="Sep 9, 2018; Denver, CO, USA; Denver Broncos cornerback Adam Jones (24) looks on before a game against the Seattle Seahawks at Broncos Stadium at Mile High. Mandatory Credit: Ron Chenoy-USA TODAY Sports" data-portal-copyright="Ron Chenoy-USA TODAY Sports"/></p> <p> Cornerback Adam "Pacman" Jones announced his</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>&#8216;Pacman&#8217; jones retires from NFL</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11216914.jpg" width="1100" height="733" alt="" title="Sep 9, 2018; Denver, CO, USA; Denver Broncos cornerback Adam Jones (24) looks on before a game against the Seattle Seahawks at Broncos Stadium at Mile High. Mandatory Credit: Ron Chenoy-USA TODAY Sports" data-portal-copyright="Ron Chenoy-USA TODAY Sports"></p><p> Cornerback Adam &#8220;Pacman&#8221; Jones announced his retirement from the NFL after 12 seasons. </p> </p><p> The Tennessee Titans selected Jones with the No. 6 overall pick of the 2005 NFL Draft, and he played in 30 games over his first two seasons. He also played for the Dallas Cowboys (2008), Cincinnati Bengals (2010-17) and Denver Broncos (2018). </p> </p><p> The Broncos signed him before the season and released him after he played in seven games. </p> </p><p> Jones, 35, has a history of arrests and was plagued by legal issues throughout his career. The NFL suspended him for the 2007 season following a shooting at a Las Vegas strip club that left a man paralyzed. A member of Jones&#8217; entourage was identified as the shooter. </p> </p><p> He played the 2009 season in the Canadian Football League. </p> </p><p> Jones retires with 17 career interceptions and 522 tackles. He also returned 192 punts for 1,944 yards and five touchdowns, and gained 3,232 yards on 125 kickoff returns. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','&#8216;Pacman&#8217; jones retires from NFL');return false;"><span class="op-btn">Read More</span> <span class="count">90 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpacman-jones-retires-from-nfl%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=‘Pacman’ jones retires from NFL+http://nfp.news/13j8" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=&#8216;Pacman&#8217; jones retires from NFL&#32;&#32;http://nfp.news/13j8" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13j8"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/cowboys-jones-touts-progress-in-talks-with-qb-prescott/" rel="bookmark" title="Cowboys&#8217; Jones touts progress in talks with QB Prescott">Cowboys&#8217; Jones touts progress in talks with QB Prescott</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/cowboys-jones-touts-progress-in-talks-with-qb-prescott/"/><meta itemprop="datePublished" content="2019-05-24"/><meta itemprop="dateModified" content="2019-05-24"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Cowboys' Jones touts progress in talks with QB Prescott</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11992850.jpg" width="733" height="1100" alt="" title="Jan 5, 2019; Arlington, TX, USA; Dallas Cowboys quarterback Dak Prescott (4) in action during an NFC Wild Card playoff football game between the Cowboys and the Seahawks at AT&amp;T Stadium. Mandatory Credit: Jerome Miron-USA TODAY Sports" data-portal-copyright="Jerome Miron-USA TODAY Sports"</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Cowboys&#8217; Jones touts progress in talks with QB Prescott</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11992850.jpg" width="733" height="1100" alt="" title="Jan 5, 2019; Arlington, TX, USA; Dallas Cowboys quarterback Dak Prescott (4) in action during an NFC Wild Card playoff football game between the Cowboys and the Seahawks at AT&T Stadium. Mandatory Credit: Jerome Miron-USA TODAY Sports" data-portal-copyright="Jerome Miron-USA TODAY Sports"></p><p> Dallas Cowboys owner Jerry Jones remains upbeat about signing quarterback Dak Prescott to a long-term deal after the sides exchanged contract proposals. </p> </p><p> Prescott said Thursday his representatives countered the original contract offer from the Cowboys. </p> </p><p> &#8220;We never really know where we are with anybody until we get one done,&#8221; Jones said. &#8220;But we&#8217;re moving along satisfactorily with all of our contract negotiations.&#8221; </p> </p><p> Jones told Cowboys Hall of Famer Michael Irvin on the Rich Eisen Show in early May that he was confident the deal with Prescott, entering his fourth NFL season, would get done. </p> </p><p> &#8220;We are sold on Dak,&#8221; Jones said. &#8220;We do want to have him for the long term. We think he is worthy of investing in for the long term. &#8230; </p> </p><p> &#8220;When you look at the snaps he has had, the situations he has been in and how he has got here and you see he has performed, we see real upside in Dak. You don&#8217;t have it all yet. We love the way he logically progresses through a game. You see when the going gets tough when he&#8217;s got to come from behind when he turns it loose a little bit. You see him make those plays. He emboldens me to make a deal with him that puts him here for the long term.&#8221; </p> </p><p> Dallas is installing a tweaked offensive system after Scott Linehan was replaced as coordinator by Kellen Moore. Prescott said he notices changes that are beyond subtle shifts. </p> </p><p> &#8220;You&#8217;ll definitely notice it because we&#8217;re presenting it different,&#8221; Prescott said. &#8220;I can&#8217;t tell you we&#8217;re gonna have whole new offensive plays and things like that, but they&#8217;ll definitely be presented in different ways. And that&#8217;ll be a big help for us.&#8221; </p> </p><p> The Cowboys selected Prescott, a Mississippi State product, in the fourth round of the 2016 NFL Draft. He has started every game in three seasons, leading the team to 32 wins and two NFC East titles. </p> </p><p> Prescott, who turns 26 in July, has completed 66.1 percent of his passes, throwing for 10,876 yards with 67 touchdowns and 25 interceptions. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Cowboys&#8217; Jones touts progress in talks with QB Prescott');return false;"><span class="op-btn">Read More</span> <span class="count">291 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fcowboys-jones-touts-progress-in-talks-with-qb-prescott%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Cowboys’ Jones touts progress in talks with QB Prescott+http://nfp.news/13j6" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Cowboys&#8217; Jones touts progress in talks with QB Prescott&#32;&#32;http://nfp.news/13j6" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13j6"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/dt-mccoy-to-visit-browns-friday-amid-heavy-interest/" rel="bookmark" title="DT McCoy to visit Browns Friday amid heavy interest">DT McCoy to visit Browns Friday amid heavy interest</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/dt-mccoy-to-visit-browns-friday-amid-heavy-interest/"/><meta itemprop="datePublished" content="2019-05-24"/><meta itemprop="dateModified" content="2019-05-24"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>DT McCoy to visit Browns Friday amid heavy interest</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12098076-1.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Atlanta, GA, USA; Gerald McCoy during red carpet arrivals for the NFL Honors show at the Fox Theatre. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"/></p> <p> Interest from the Cleveland Browns is being reciprocated</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>DT McCoy to visit Browns Friday amid heavy interest</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12098076-1.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Atlanta, GA, USA; Gerald McCoy during red carpet arrivals for the NFL Honors show at the Fox Theatre. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"></p><p> Interest from the Cleveland Browns is being reciprocated by free agent defensive tackle Gerald McCoy, who will be in Berea, Ohio, at team headquarters on Friday. </p> </p><p> McCoy will take his first-ever free agency visit with the Browns, and he informed other suitors of the pecking order on Thursday. </p> </p><p> McCoy, the third overall pick in the 2010 NFL Draft, was released by the Tampa Bay Buccaneers on Monday with three years left on his contract. The deal called for him to make $13 million in base pay this season. The original contract was for six years and $95.2 million. </p> </p><p> Cleveland general manager John Dorsey confirmed he&#8217;d host McCoy on Friday. Dorsey, speaking Thursday after organized team activities, said he will continue to &#8220;turn over every rock.&#8221; Of McCoy, Dorsey said he is &#8220;a good player the Browns want to get to know a little better.&#8221; </p> </p><p> The Tampa Bay Times reports McCoy has drawn offers from 10 teams with offers as high as $11 million annually. </p> </p><p> Among teams mentioned to be interested, per various reports, are the Cincinnati Bengals, New Orleans Saints, Carolina Panthers, Atlanta Falcons and Indianapolis Colts. </p> </p><p> Dorsey has been aggressive in stocking the Browns&#8217; roster, including trades that brought in wide receivers Odell Beckham Jr. and Jarvis Landry and defensive end Olivier Vernon. According to reports, the Browns have been interested in adding McCoy for months but didn&#8217;t offer a draft pick in exchange because they expected him to be released. </p> </p><p> &#8220;These decisions are very difficult, personally and professionally,&#8221; Buccaneers general manager Jason Licht said in a statement when the team released McCoy. &#8220;Over the past nine years, Gerald has been a cornerstone of this franchise and a leader in our community. Parting ways with a player and person such as Gerald is one of the toughest responsibilities of this job. We wish Gerald, along with his wife, Ebony, and the entire McCoy family continued success and thank them for everything they have meant to our organization and community.&#8221; </p> </p><p> After the Times originally reported McCoy was released, ESPN&#8217;s Adam Schefter noted that the Bucs tried for two months to find a trade partner, but when it was clear there was none, the two sides &#8220;mutually parted ways.&#8221; </p> </p><p> The 31-year-old McCoy has been a pillar on otherwise subpar defenses for most of his career in Tampa, earning six Pro Bowl selections and tallying 54.5 sacks. </p> </p><p> Earlier this month, McCoy voiced his displeasure with trade rumors while skipping voluntary workouts. </p> </p><p> &#8220;I will be playing football somewhere,&#8221; McCoy told a local reporter at the time. When asked where that would be, McCoy said, &#8220;I don&#8217;t know. We&#8217;ll see.&#8221; </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','DT McCoy to visit Browns Friday amid heavy interest');return false;"><span class="op-btn">Read More</span> <span class="count">382 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fdt-mccoy-to-visit-browns-friday-amid-heavy-interest%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=DT McCoy to visit Browns Friday amid heavy interest+http://nfp.news/13j3" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=DT McCoy to visit Browns Friday amid heavy interest&#32;&#32;http://nfp.news/13j3" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13j3"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/cowboys-owner-jones-expects-elliott-to-avoid-discipline/" rel="bookmark" title="Cowboys owner Jones expects Elliott to avoid discipline">Cowboys owner Jones expects Elliott to avoid discipline</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/cowboys-owner-jones-expects-elliott-to-avoid-discipline/"/><meta itemprop="datePublished" content="2019-05-24"/><meta itemprop="dateModified" content="2019-05-24"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Cowboys owner Jones expects Elliott to avoid discipline</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11993258.jpg" width="1100" height="733" alt="" title="Jan 5, 2019; Arlington, TX, USA; Dallas Cowboys running back Ezekiel Elliott (21) looks for an opening against the Seattle Seahawks in the second quarter in a NFC Wild Card playoff football game at AT&amp;T Stadium. Mandatory Credit: Shane Roper-USA TODAY Sports"</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Cowboys owner Jones expects Elliott to avoid discipline</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11993258.jpg" width="1100" height="733" alt="" title="Jan 5, 2019; Arlington, TX, USA; Dallas Cowboys running back Ezekiel Elliott (21) looks for an opening against the Seattle Seahawks in the second quarter in a NFC Wild Card playoff football game at AT&T Stadium. Mandatory Credit: Shane Roper-USA TODAY Sports" data-portal-copyright="Shane Roper-USA TODAY Sports"></p><p> Dallas Cowboys owner and general manager Jerry Jones expects star running back Ezekiel Elliott to avoid league discipline despite a recent incident involving security guards at a Las Vegas music festival. </p> </p><p> Elliott briefly was placed in handcuffs and detained by police, but he was not arrested. A video showing part of the incident was released by the gossip website TMZ. </p> </p><p> Jones downplayed the incident as he praised Elliott, who drew positive headlines earlier this offseason when he paid for the funeral of a teenage football player who was killed by a stray bullet in East St. Louis, Ill. Elliott grew up on the Missouri side of the river and maintains close ties to the St. Louis area. </p> </p><p> &#8220;I think that the main thing is that I don&#8217;t see anything that needs supporting,&#8221; Jones said Thursday. &#8220;In terms of his status with us, (it) has not been impacted in any way. And frankly, I know how conscientious he has been in the offseason, and that&#8217;s good enough. No, I don&#8217;t see that having any consequences for us.&#8221; </p> </p><p> Cowboys executives have indicated a desire to extend Elliott&#8217;s contract past 2020, when it is due to expire. Elliott, 23, rushed for 1,434 yards and six touchdowns in 15 games last season. </p> </p><p> &#8220;I think that he&#8217;s certainly has had a great offseason, had a great year last year, and I think that&#8217;ll speak for itself,&#8221; Jones said. &#8220;So I think that, yes, his overall career at this point is in a really positive place.&#8221; </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Cowboys owner Jones expects Elliott to avoid discipline');return false;"><span class="op-btn">Read More</span> <span class="count">197 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fcowboys-owner-jones-expects-elliott-to-avoid-discipline%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Cowboys owner Jones expects Elliott to avoid discipline+http://nfp.news/13iz" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Cowboys owner Jones expects Elliott to avoid discipline&#32;&#32;http://nfp.news/13iz" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13iz"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/nfl-notebook-gase-calls-bell-trade-talk-ridiculous/" rel="bookmark" title="NFL notebook: Gase calls Bell trade talk &#8216;ridiculous&#8217;">NFL notebook: Gase calls Bell trade talk &#8216;ridiculous&#8217;</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-notebook-gase-calls-bell-trade-talk-ridiculous/"/><meta itemprop="datePublished" content="2019-05-24"/><meta itemprop="dateModified" content="2019-05-24"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>NFL notebook: Gase calls Bell trade talk 'ridiculous'</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12246900-2.jpg" width="1100" height="732" alt="" title="Feb 27, 2019; Indianapolis, IN, USA; New York Jets head coach Adam Gase speaks to media during the 2019 NFL Combine at Indianapolis Convention Center. Mandatory Credit: Trevor Ruszkowski-USA TODAY Sports" data-portal-copyright="Trevor Ruszkowski-USA TODAY Sports"/></p> <p> New York Jets coach Adam</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>NFL notebook: Gase calls Bell trade talk &#8216;ridiculous&#8217;</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12246900-2.jpg" width="1100" height="732" alt="" title="Feb 27, 2019; Indianapolis, IN, USA; New York Jets head coach Adam Gase speaks to media during the 2019 NFL Combine at Indianapolis Convention Center. Mandatory Credit: Trevor Ruszkowski-USA TODAY Sports" data-portal-copyright="Trevor Ruszkowski-USA TODAY Sports"></p><p> New York Jets coach Adam Gase on Thursday dismissed speculation that All-Pro running back Le&#8217;Veon Bell was on the trading block, calling it &#8220;ridiculous.&#8221; </p> </p><p> After the Jets fired general manager Mike Maccagnan and named Gase the interim GM last week, there was talk that Gase had objected to Maccagnan&#8217;s March signing of Bell to a four-year, $52.5 million deal. </p> </p><p> &#8220;That&#8217;s ridiculous. That&#8217;s the first I&#8217;ve heard of that,&#8221; Gase said during his first news conference since the front-office makeover. Asked if he thought the Jets overpaid for Bell, Gase replied, &#8220;No.&#8221; </p> </p><p> &#8220;No, the contract was what it was,&#8221; he said. &#8220;Everybody can criticize contracts all you want, but he&#8217;s here. I&#8217;m excited he&#8217;s here. I think the players are excited he&#8217;s here. I think the coaches are.&#8221; </p> </p><p> &#8211;Dallas Cowboys owner and general manager Jerry Jones expects star running back Ezekiel Elliott to avoid league discipline despite a recent incident involving security guards at a Las Vegas music festival. </p> </p><p> Elliott briefly was placed in handcuffs and detained by police, but he was not arrested. A video showing part of the incident was released by the gossip website TMZ. </p> </p><p> &#8220;I think that the main thing is that I don&#8217;t see anything that needs supporting,&#8221; Jones said. &#8220;In terms of his status with us, (it) has not been impacted in any way.&#8221; </p> </p><p> &#8211;Free agent defensive tackle Gerald McCoy is reciprocating the Cleveland Browns&#8217; interest and will visit Berea, Ohio, at team headquarters on Friday. </p> </p><p> McCoy will take his first-ever free agency visit with the Browns after being released by the Tampa Bay Buccaneers earlier this week. Cleveland general manager John Dorsey called the defensive tackle &#8220;a good player the Browns want to get to know a little better.&#8221; </p> </p><p> Other teams with reported interest include the Cincinnati Bengals, Carolina Panthers, Atlanta Falcons, Indianapolis Colts and New Orleans Saints. </p> </p><p> &#8211;Ndamukong Suh officially signed a one-year deal with the Tampa Bay Buccaneers, two days after his reported agreement. </p> </p><p> Suh&#8217;s contract is worth $9.25 million and incentives could push it to $10 million, per multiple reports. </p> </p><p> The 32-year-old Suh, entering his 10th season, played with the Los Angeles Rams in 2018 and had 59 tackles, 4.5 sacks, 19 quarterback hits and four passes defensed. </p> </p><p> &#8211;San Francisco 49ers safety Jimmie Ward broke his collarbone diving for a ball during organized team activities and will miss eight to 12 weeks, the team announced. </p> </p><p> That would give Ward a chance to return early in training camp, which begins in mid July, and a good shot at being ready for the Sept. 8 regular-season opener. </p> </p><p> The team also announced top pick Nick Bosa will miss the rest of OTAs with a Grade 1 hamstring strain, but he&#8217;s expected to be ready for training camp. </p> </p><p> &#8211;The Jacksonville Jaguars signed first-round defensive end Josh Allen to his four-year rookie contract. Like all first-round deals, it comes with a fifth-year team option. </p> </p><p> Allen, chosen seventh overall, will make $22.7 million over four years, with the full figure guaranteed. </p> </p><p> Allen sat out Thursday after bruising his right knee during the team&#8217;s first practice of organized team activities. He will sit out Friday as well. </p> </p><p> &#8220;We&#8217;re just keeping him on the side, working,&#8221; head coach Doug Marrone told reporters before practice. &#8220;He&#8217;ll be fine. We&#8217;re not concerned about it.&#8221; </p> </p><p> &#8211;The Denver Broncos signed first-round tight end Noah Fant to his rookie contract. </p> </p><p> The deal is worth $12.6 million over four years, with $9.9 million fully guaranteed. Fant was chosen 20th overall last month after Denver traded down from No. 10. </p> </p><p> &#8211;The Miami Dolphins signed free agent defensive tackle Adolphus Washington. </p> </p><p> A third-round pick by the Buffalo Bills in 2016, the 24-year-old Washington was waived by Buffalo after one game last season and joined the Cincinnati Bengals for four games. He has 4.5 career sacks in 35 games (21 starts). </p> </p><p> &#8211;The New Orleans Saints worked out free agent running backs Rob Kelley, Javorius Allen and Fozzy Whittaker, the Times-Picayune reported. </p> </p><p> Kelley started 16 games from 2016-17 in Washington, including a 2016 campaign with 704 rushing yards and six touchdowns. </p> </p><p> Allen had 1,249 rushing yards and eight scores across four years in Baltimore. Whittaker played in 53 games for Carolina from 2014-17 before missing 2018 with a torn ACL sustained last May. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','NFL notebook: Gase calls Bell trade talk &#8216;ridiculous&#8217;');return false;"><span class="op-btn">Read More</span> <span class="count">631 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-notebook-gase-calls-bell-trade-talk-ridiculous%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL notebook: Gase calls Bell trade talk ‘ridiculous’+http://nfp.news/13j0" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL notebook: Gase calls Bell trade talk &#8216;ridiculous&#8217;&#32;&#32;http://nfp.news/13j0" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13j0"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/49ers-s-ward-breaks-collarbone-out-8-12-weeks/" rel="bookmark" title="49ers S Ward breaks collarbone, out 8-12 weeks">49ers S Ward breaks collarbone, out 8-12 weeks</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/49ers-s-ward-breaks-collarbone-out-8-12-weeks/"/><meta itemprop="datePublished" content="2019-05-23"/><meta itemprop="dateModified" content="2019-05-23"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>49ers S Ward breaks collarbone, out 8-12 weeks</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11655538-1.jpg" width="1100" height="775" alt="" title="Nov 12, 2018; Santa Clara, CA, USA; New York Giants running back Saquon Barkley (26) is defended by San Francisco 49ers cornerback Jimmie Ward (20)in the second quarterat Levi&#039;s Stadium. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"/></p> <p></p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>49ers S Ward breaks collarbone, out 8-12 weeks</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/11655538-1.jpg" width="1100" height="775" alt="" title="Nov 12, 2018; Santa Clara, CA, USA; New York Giants running back Saquon Barkley (26) is defended by San Francisco 49ers cornerback Jimmie Ward (20)in the second quarterat Levi's Stadium. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"></p><p> San Francisco 49ers safety Jimmie Ward broke his collarbone diving for a ball Thursday during organized team activities and will miss eight to 12 weeks, the team announced. </p> </p><p> That would give Ward a chance to return early in training camp, which begins in mid July, and a good shot at being ready for the Sept. 8 regular-season opener. </p> </p><p> A Northern Illinois product, Ward was the No. 30 overall pick of the 2014 NFL Draft by the 49ers. In both 2017 and 2018, his season ended in November because of a broken arm. The 49ers re-signed him to a one-year, $4.5 million deal in March after he played out the fifth-year option of his rookie contract. </p> </p><p> Ward has appeared in 51 games (31 starts) over five seasons and has 186 tackles, two interceptions and 21 passes defensed. </p> </p><p> Fellow defensive back Richard Sherman gave Ward high praise for his versatility and work ethic in a story posted on the team&#8217;s website just Wednesday. </p> </p><p> &#8220;He&#8217;s a great teammate, he&#8217;s a great player and he&#8217;s a great person,&#8221; Sherman said. &#8220;He&#8217;s a guy who doesn&#8217;t complain very often. If you said, &#8216;Hey, you&#8217;re playing D-line today,&#8217; he&#8217;d be like, &#8216;OK cool, where do I stand?&#8217; He&#8217;s a guy who goes to work, brings his hard hat every day and gets the job done. &#8230; He is a tremendous player.&#8221; </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','49ers S Ward breaks collarbone, out 8-12 weeks');return false;"><span class="op-btn">Read More</span> <span class="count">166 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2F49ers-s-ward-breaks-collarbone-out-8-12-weeks%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=49ers S Ward breaks collarbone, out 8-12 weeks+http://nfp.news/13ix" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=49ers S Ward breaks collarbone, out 8-12 weeks&#32;&#32;http://nfp.news/13ix" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13ix"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/finau-leads-spieth-one-back-at-charles-schwab/" rel="bookmark" title="Finau leads, Spieth one back at Charles Schwab">Finau leads, Spieth one back at Charles Schwab</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/finau-leads-spieth-one-back-at-charles-schwab/"/><meta itemprop="datePublished" content="2019-05-23"/><meta itemprop="dateModified" content="2019-05-23"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Finau leads, Spieth one back at Charles Schwab</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12763266.jpg" width="1100" height="763" alt="" title="May 23, 2019; Fort Worth, TX, USA; Tony Finau watches his shot from the 11th tee during the first round the Charles Schwab Challenge golf tournament at Colonial Country Club. Mandatory Credit: Ray Carlin-USA TODAY Sports" data-portal-copyright="Ray Carlin-USA TODAY Sports"/></p> <p></p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Finau leads, Spieth one back at Charles Schwab</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/05/12763266.jpg" width="1100" height="763" alt="" title="May 23, 2019; Fort Worth, TX, USA; Tony Finau watches his shot from the 11th tee during the first round the Charles Schwab Challenge golf tournament at Colonial Country Club. Mandatory Credit: Ray Carlin-USA TODAY Sports" data-portal-copyright="Ray Carlin-USA TODAY Sports"></p><p> Tony Finau produced a blistering 6-under-par 64 on Thursday to take the early lead at the Charles Schwab Challenge in Fort Worth, Texas, with local favorite Jordan Spieth lurking close behind. </p> </p><p> Spieth and Canada&#8217;s Roger Sloan share second place, one stroke back, after each shot 65 at Colonial Country Club. </p> </p><p> Tied for fourth is a cluster of nine players at 3 under, including Jason Dufner and Jimmy Walker. Mexico&#8217;s Abraham Ancer is among eight others at 2 under. </p> </p><p> Finau reached 2 under with birdies at Nos. 3 and 4, and after a hiccup bogey at the fifth, he tacked on two more birdies at Nos. 7 and 8. He then strung together three in a row beginning at No. 11, sinking putts of 24 and 27 feet at the 12th and 13th, respectively, to get to 6 under before parring the final five holes. </p> </p><p> The breakthrough for Finau &#8212; after he struggled to a final-round 79 at last week&#8217;s PGA Championship &#8212; coincided with a switch to a claw grip on his putter, something he said he&#8217;s considered for a while. </p> </p><p> &#8220;It&#8217;s something that I&#8217;ve kind of been thinking,&#8221; Finau told PGA.com afterward. &#8220;It&#8217;s an itch I wanted to scratch. &#8230; To me, it was just perfect time. &#8230; If I feel like something is better, I&#8217;m not afraid to change, no matter the results.&#8221; </p> </p><p> In addition to his long makes on the back nine, Finau holed birdie putts of 20 feet (No. 3) and 19 feet (No. 7) on the front nine, as well as a par putt of 20 feet at the 16th. </p> </p><p> &#8220;I wanted to try something different, and it felt great out there today,&#8221; he said. </p> </p><p> Like Finau, Spieth&#8217;s putter was red hot, as the Dallas native drained birdie putts of 30 and 46 feet and didn&#8217;t miss inside 15 feet all day. He sank a 73-foot chip shot for a birdie at No. 13. </p> </p><p> &#8220;It&#8217;s nice to see some results off what I believe is the progress I&#8217;ve been making,&#8221; Spieth said afterward, per the Dallas Morning News. &#8220;At the same time, it&#8217;s one round. I&#8217;ve got to keep my head down and keep working.&#8221; </p> </p><p> Spieth, the 2016 winner of the event, racked up eight birdies in the round, overcoming a double bogey at the par-4 18th when he found water with his approach shot. After he started on the back nine, the double bogey dropped him from 4 under to 2 under, but he birdied four more on the front, including No. 9 after a bogey at the eighth. </p> </p><p> Sloan notched three birdies on each side, with the only blemish a bogey at No. 9. </p> </p><p> Defending champion Justin Rose of England is tied for 95th among 121 players after shooting 74. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Finau leads, Spieth one back at Charles Schwab');return false;"><span class="op-btn">Read More</span> <span class="count">377 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Ffinau-leads-spieth-one-back-at-charles-schwab%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Finau leads, Spieth one back at Charles Schwab+http://nfp.news/13iy" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Finau leads, Spieth one back at Charles Schwab&#32;&#32;http://nfp.news/13iy" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13iy"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article></div></div></div></div></div></div><a href="#" id="fl-to-top"><i class="fa fa-chevron-up"></i></a><style>[class*="fa fa-"]{font-family:FontAwesome !important;}</style>
<noscript id="wpfc-google-fonts"><link rel='stylesheet' id='sab-font-css' href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,700,400italic,700italic&#038;subset=latin' type='text/css' media='all'/>
<link rel='stylesheet' id='fl-builder-google-fonts-a0dc0f37a2c19d739b7445c77d065820-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C700%7CRoboto+Condensed%3A700%7COpen+Sans+Condensed%3A700&#038;ver=5.1.1' type='text/css' media='all'/>
</noscript>
<link rel='stylesheet' id='font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=2.1.4.3' type='text/css' media='all'/>
<script>var posts_table_params={"ajax_url":"https:\/\/nationalfootballpost.com\/wp-admin\/admin-ajax.php","ajax_nonce":"054471f120","wrapper_class":"posts-table-wrapper bb-theme","language":{"info":"Showing _START_ to _END_ of _TOTAL_ entries","infoEmpty":"Showing 0 entries","infoFiltered":"(_MAX_ entries in total)","lengthMenu":"Show _MENU_ entries","emptyTable":"No data available in table.","zeroRecords":"No matching records found.","search":"Search:","paginate":{"first":"First","last":"Last","next":"Next","previous":"Previous"},"thousands":",","decimal":".","aria":{"sortAscending":": activate to sort column ascending","sortDescending":": activate to sort column descending"},"filterBy":"Filter:","resetButton":"Reset"}};</script>
<!--[if lt IE 9]><script src="//nationalfootballpost.com/wp-content/cache/wpfc-minified/8z16d3ot/80n71.js"></script><![endif]-->
<!--[if lt IE 9]><script src="//nationalfootballpost.com/wp-content/cache/wpfc-minified/lbeld6mi/80n71.js"></script><![endif]-->
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/nationalfootballpost.com\/","sameAs":["http:\/\/facebook.com\/nationalfootballpost","https:\/\/twitter.com\/footballpost"],"@id":"https:\/\/nationalfootballpost.com\/#organization","name":"National Football Post","logo":"http:\/\/footballpost.wpengine.com\/wp-content\/uploads\/2018\/05\/NFPlogo-400.png"}</script>
<script src='//nationalfootballpost.com/wp-content/cache/wpfc-minified/qlb18u0t/80n70.js' type="text/javascript"></script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-5166086-1"></script>
<script>window.dataLayer=window.dataLayer||[];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-5166086-1');</script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/clipboard.js/1.5.10/clipboard.min.js"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>
<script>jQuery(function($){
$('button').tooltip({
trigger: 'click',
placement: 'bottom'
});
function setTooltip(btn, message){
$(btn).tooltip('hide')
.attr('data-original-title', message)
.tooltip('show');
}
function hideTooltip(btn){
setTimeout(function(){
$(btn).tooltip('hide');
}, 1000);
}
var clipboard=new Clipboard('button');
clipboard.on('success', function(e){
setTooltip(e.trigger, 'Link copied to clipboard');
hideTooltip(e.trigger);
});
clipboard.on('error', function(e){
setTooltip(e.trigger, 'Failed!');
hideTooltip(e.trigger);
});
});</script>
<script defer src='//nationalfootballpost.com/wp-content/cache/wpfc-minified/6mqm6t2g/80n70.js' type="text/javascript"></script>
<script>document.addEventListener('DOMContentLoaded',function(){function wpfcgl(){var wgh=document.querySelector('noscript#wpfc-google-fonts').innerText, wgha=wgh.match(/<link[^\>]+>/gi);for(i=0;i<wgha.length;i++){var wrpr=document.createElement('div');wrpr.innerHTML=wgha[i];document.body.appendChild(wrpr.firstChild);}}wpfcgl();});</script>
<script >document.addEventListener('DOMContentLoaded',function(){
jQuery(document).ready(function($){
$(window).scroll(function(){
var footerPos=$('footer').last().position().top;
var pos=$(window).scrollTop();
if(pos+(screen.height*4) > footerPos){
if($(".centil-infinite-scroll").first().hasClass('working')){
return false;
}else{
$(".centil-infinite-scroll").first().addClass('working');
}
var centilNextPostId=$(".centil-infinite-scroll").first().text();
var data={
'action': 'centil_is',
'centilNextPostId': centilNextPostId
};
jQuery.post('https://nationalfootballpost.com/wp-admin/admin-ajax.php', data, function(response){
$(".centil-infinite-scroll").first().replaceWith(response);
}, 'html');
}
var currUrl=$(".centil-post-header").first().attr("url");
var currTitle=$(".centil-post-header").first().attr("title");
if($(".centil-post-header").length > 1&&history.pushState){
for (var i=0; i<$(".centil-post-header").length; i++){
if(pos+(screen.height/2) >=$(".centil-post-header").eq(i).next().position().top){
currUrl=$(".centil-post-header").eq(i).attr("url");
currTitle=$(".centil-post-header").eq(i).attr("title");
}}
}
if(location.href!=currUrl){
history.pushState({}, currTitle, currUrl);
}});
});});</script>
</body>
</html><!-- WP Fastest Cache file was created in 2.20794391632 seconds, on 28-05-19 12:42:55 -->