<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name='viewport' content='width=device-width, initial-scale=1.0' />
<meta http-equiv='X-UA-Compatible' content='IE=edge' />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://nationalfootballpost.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://nationalfootballpost.com/wp-content/themes/bb-theme/js/html5shiv.js"></script>
	<script src="https://nationalfootballpost.com/wp-content/themes/bb-theme/js/respond.min.js"></script>
<![endif]-->
<title>Raiders release WR Nelson, QB McCarron - National Football Post</title>

<!-- This site is optimized with the Yoast SEO plugin v11.4 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://nationalfootballpost.com/raiders-release-wr-nelson-qb-mccarron/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Raiders release WR Nelson, QB McCarron - National Football Post" />
<meta property="og:description" content="Raiders release WR Nelson, QB McCarron The Oakland Raiders released wide receiver Jordy Nelson on Thursday, less than three months after paying him a $3.6 million roster bonus for 2019. The Raiders gave Nelson &#8212; who joined the team on a two-year, $14.2 million deal last spring &#8212; his bonus on Dec. 28, which was&hellip;" />
<meta property="og:url" content="https://nationalfootballpost.com/raiders-release-wr-nelson-qb-mccarron/" />
<meta property="og:site_name" content="National Football Post" />
<meta property="article:publisher" content="http://facebook.com/nationalfootballpost" />
<meta property="article:tag" content="FLM" />
<meta property="article:section" content="NFL and College Football Articles" />
<meta property="article:published_time" content="2019-08-20T13:54:11+00:00" />
<meta property="article:modified_time" content="2019-08-20T13:54:13+00:00" />
<meta property="og:updated_time" content="2019-08-20T13:54:13+00:00" />
<meta property="og:image" content="https://nationalfootballpost.com/wp-content/uploads/2019/08/11950314-1.jpg" />
<meta property="og:image:secure_url" content="https://nationalfootballpost.com/wp-content/uploads/2019/08/11950314-1.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://nationalfootballpost.com/#organization","name":"National Football Post","url":"https://nationalfootballpost.com/","sameAs":["http://facebook.com/nationalfootballpost","https://twitter.com/footballpost"]},{"@type":"WebSite","@id":"https://nationalfootballpost.com/#website","url":"https://nationalfootballpost.com/","name":"National Football Post","publisher":{"@id":"https://nationalfootballpost.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://nationalfootballpost.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://nationalfootballpost.com/raiders-release-wr-nelson-qb-mccarron/#webpage","url":"https://nationalfootballpost.com/raiders-release-wr-nelson-qb-mccarron/","inLanguage":"en-US","name":"Raiders release WR Nelson, QB McCarron - National Football Post","isPartOf":{"@id":"https://nationalfootballpost.com/#website"},"image":{"@type":"ImageObject","@id":"https://nationalfootballpost.com/raiders-release-wr-nelson-qb-mccarron/#primaryimage","url":"https://nationalfootballpost.com/wp-content/uploads/2019/08/11950314-1.jpg","width":1100,"height":724},"primaryImageOfPage":{"@id":"https://nationalfootballpost.com/raiders-release-wr-nelson-qb-mccarron/#primaryimage"},"datePublished":"2019-08-20T13:54:11+00:00","dateModified":"2019-08-20T13:54:13+00:00"},{"@type":"Article","@id":"https://nationalfootballpost.com/raiders-release-wr-nelson-qb-mccarron/#article","isPartOf":{"@id":"https://nationalfootballpost.com/raiders-release-wr-nelson-qb-mccarron/#webpage"},"author":{"@id":"https://nationalfootballpost.com/author/national-football-post/#author"},"headline":"Raiders release WR Nelson, QB McCarron","datePublished":"2019-08-20T13:54:11+00:00","dateModified":"2019-08-20T13:54:13+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://nationalfootballpost.com/raiders-release-wr-nelson-qb-mccarron/#webpage"},"publisher":{"@id":"https://nationalfootballpost.com/#organization"},"keywords":"FLM","articleSection":"NFL and College Football Articles"},{"@type":["Person"],"@id":"https://nationalfootballpost.com/author/national-football-post/#author","name":"National Football Post","image":{"@type":"ImageObject","@id":"https://nationalfootballpost.com/#authorlogo","url":"https://nationalfootballpost.com/wp-content/uploads/2015/02/NFP-LOGO-400sq.jpg","caption":"National Football Post"},"sameAs":[]}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="National Football Post &raquo; Feed" href="https://nationalfootballpost.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="National Football Post &raquo; Comments Feed" href="https://nationalfootballpost.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="National Football Post &raquo; Raiders release WR Nelson, QB McCarron Comments Feed" href="https://nationalfootballpost.com/raiders-release-wr-nelson-qb-mccarron/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/nationalfootballpost.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<!-- managing ads with Advanced Ads – https://wpadvancedads.com/ --><script>
					advanced_ads_ready=function(){var fns=[],listener,doc=typeof document==="object"&&document,hack=doc&&doc.documentElement.doScroll,domContentLoaded="DOMContentLoaded",loaded=doc&&(hack?/^loaded|^c/:/^loaded|^i|^c/).test(doc.readyState);if(!loaded&&doc){listener=function(){doc.removeEventListener(domContentLoaded,listener);window.removeEventListener("load",listener);loaded=1;while(listener=fns.shift())listener()};doc.addEventListener(domContentLoaded,listener);window.addEventListener("load",listener)}return function(fn){loaded?setTimeout(fn,0):fns.push(fn)}}();
			</script><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='otw_sbm.css-css'  href='https://nationalfootballpost.com/wp-content/plugins/sidebar-manager-light/css/otw_sbm.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='fl-builder-google-fonts-6fd2b081dbaa3bb8686313de37b24bdf-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C700&#038;ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='fl-builder-google-fonts-4bd28ee77d135a4495776630bd4dfb32-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A700&#038;ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='fl-builder-google-fonts-8cbd1b8ff36d9bbc9ac97d58e2da881d-css'  href='https://fonts.googleapis.com/css?family=Open+Sans+Condensed%3A700&#038;ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://nationalfootballpost.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='ce_responsive-css'  href='https://nationalfootballpost.com/wp-content/plugins/simple-embed-code/css/video-container.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-data-tables-css'  href='https://nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/css/datatables/datatables.min.css?ver=1.10.16' type='text/css' media='all' />
<link rel='stylesheet' id='posts-table-pro-css'  href='https://nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/css/posts-table-pro.min.css?ver=2.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='sab-font-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,700,400italic,700italic&#038;subset=latin' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://nationalfootballpost.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://nationalfootballpost.com/wp-content/themes/bb-theme/css/font-awesome.min.css?ver=1.6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='mono-social-icons-css'  href='https://nationalfootballpost.com/wp-content/themes/bb-theme/css/mono-social-icons.css?ver=1.6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-magnificpopup-css'  href='https://nationalfootballpost.com/wp-content/themes/bb-theme/css/jquery.magnificpopup.css?ver=1.6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://nationalfootballpost.com/wp-content/themes/bb-theme/css/bootstrap.min.css?ver=1.6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='fl-automator-skin-css'  href='https://nationalfootballpost.com/wp-content/uploads/bb-theme/skin-5d593986d81e8.css?ver=1.6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='fl-child-theme-css'  href='https://nationalfootballpost.com/wp-content/themes/bb-theme-child/style.css?ver=5.2.2' type='text/css' media='all' />
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/plugins/wp-d3/js/d3.v35.min.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/plugins/wp-google-analytics-events/js/ga-scroll-events.js?ver=2.5.3'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme-child/js/custom.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme-child/js/infinite-scroll.min.js?ver=5.2.2'></script>
<link rel='https://api.w.org/' href='https://nationalfootballpost.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nationalfootballpost.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nationalfootballpost.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://nationalfootballpost.com/?p=110914' />
<link rel="alternate" type="application/json+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Fraiders-release-wr-nelson-qb-mccarron%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Fraiders-release-wr-nelson-qb-mccarron%2F&#038;format=xml" />
<!-- Google Analytics -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-5166086-1', 'auto');
ga('send', 'pageview');
</script>
<!-- End Google Analytics --><style type='text/css'>.rp4wp-related-posts ul{width:100%;padding:0;margin:0;float:left;}
.rp4wp-related-posts ul>li{list-style:none;padding:0;margin:0;padding-bottom:20px;clear:both;}
.rp4wp-related-posts ul>li>p{margin:0;padding:0;}
.rp4wp-related-post-image{width:35%;padding-right:25px;-moz-box-sizing:border-box;-webkit-box-sizing:border-box;box-sizing:border-box;float:left;}</style>
<script type="text/javascript" >
jQuery(document).ready(function($) {
                       
                       $(window).scroll(function() {
                                        var footerPos = $('footer').last().position().top;
                                        var pos = $(window).scrollTop();
                                        
                                        // Load next article
                                        if (pos+(screen.height*4) > footerPos) {
                                        if ($(".centil-infinite-scroll").first().hasClass('working')) {
                                        return false;
                                        } else {
                                        $(".centil-infinite-scroll").first().addClass('working');
                                        }
                                        
                                        var centilNextPostId = $(".centil-infinite-scroll").first().text();
                                        var data = {
                                        'action': 'centil_is',
                                        'centilNextPostId': centilNextPostId
                                        };
                                        
                                        // since 2.8 ajaxurl is always defined in the admin header and points to admin-ajax.php
                                        jQuery.post('https://nationalfootballpost.com/wp-admin/admin-ajax.php', data, function(response) {
                                                    $(".centil-infinite-scroll").first().replaceWith(response);
                                                    }, 'html');
                                        }
                                        
                                        // Update new URL
                                        var currUrl = $(".centil-post-header").first().attr("url");
                                        var currTitle = $(".centil-post-header").first().attr("title");
                                        
                                        if ($(".centil-post-header").length > 1 && history.pushState) {
                                        for (var i=0; i<$(".centil-post-header").length; i++) {
                                        if (pos+(screen.height/2) >= $(".centil-post-header").eq(i).next().position().top) {
                                        currUrl = $(".centil-post-header").eq(i).attr("url");
                                        currTitle = $(".centil-post-header").eq(i).attr("title");
                                        }
                                        }
                                        }
                                        if (location.href != currUrl) {
                                        history.pushState({}, currTitle, currUrl);
                                        }
                                        });
                       });
</script>

<meta name="generator" content="Feed to Post 3.7.5" />
<link rel="canonical" href="https://footballpost.wpengine.com/newsml/fieldlevelmedia_str_20190314T211922_0800_000033209_2.xml" /><link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-270x270.jpg" />
        <script>
                if (typeof ga === 'undefined') {
                  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
                  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
                  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
                  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

                  ga('create','', 'nationalfootballpost.com');                  ga('send', 'pageview');
                                }
            </script> 		<style type="text/css" id="wp-custom-css">
			.fl-post-cats-tags{
		    padding: 0px 0px 0px 0px;	
				border-bottom:4px solid #e6e6e6
}

.share-social{
	border-bottom:4px solid #e6e6e6
}


.container
{max-width: 93%}


.fl-sidebar-left
{
	padding-right: 2%;
	padding-left: 0px;
}

.fl-post-cats-tags a, .share-social a {
    text-transform: uppercase;
    color: #000;
		font-size: 18px;
		font-weight: 600;
    font-style: normal;
		
}
.fl-archive .fl-post
{
	border-bottom: 0px;
}


div.share-social {
    letter-spacing: 7px;
    float: right;
	padding-top: 10px;
}

.custom-html-widget li a{
	font-size: 16px;
  color: #555;
	font-style: normal;
  display: block;
	padding-bottom: 4px;
	font-weight: 600;
	text-transform: uppercase;	
}

.custom-html-widget li{
	font-size: 14px;
  color: #7b7b7b;
	font-style: italic;
	font-weight: 500;
	text-transform: uppercase;	
	padding-bottom: 6px;
	border-bottom: 2px solid #e6e6e6
	
}

.fl-widget-title {
	border-style: solid;
  border-width: 4px 0px 4px 0px; 
	text-align: center;
	padding: 5px
	
}


.fl-post-title{
     margin-bottom: 0px;}

.fl-post-author {
	text-transform: uppercase;
	font-style: italic;
	font-weight:600;
	font-size: 18px;
}
.tooltip-inner{letter-spacing: 1px;}
.fl-post-meta-bottom {
    border-top: none;
    font-style: italic;
    margin-top: 0;
    padding-top: 10px;
    float: left;
}
.btn-primary{
	    border: none !important;
    background: 0 0 !important;;
    color: #000 !important;;
    box-shadow: none !important;;
    padding: 0 !important;;
    margin-bottom: 5px !important;;
}

.toptitle h1{
	font-size:22px;
	margin-top: 5px;
	margin-bottom: 5px; 
  list-style: none;
  margin: 0;
  padding: 0;
  line-height:40px;
	width:50%;
	position: relative;
	left: 25%;
	margin: 0 px;
  padding: 0 px;
  border: 1px solid #AAA;
	color:white;
  background: #050505;
	 border-bottom-left-radius: 10px;
	border-bottom-right-radius: 10px;
	font-style: italic;

}


.fl-archive .fl-archive-title{display:none;}

.rp4wp-related-post-content{
	font-size: 18px;
  color: #555;
	font-style: italic;
  display: block;
	font-weight: 800;
	text-transform: uppercase;
}
		</style>
		<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-5166086-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-5166086-1');
</script>

</head>

<body class="post-template-default single single-post postid-110914 single-format-standard fl-preset-default fl-fixed-width fl-scroll-to-top fl-search-active" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="fl-page">
	<header class="fl-page-header fl-page-header-fixed fl-page-nav-right fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile">
	<div class="fl-page-header-wrap">
		<div class="fl-page-header-container container">
			<div class="fl-page-header-row row">
				<div class="fl-page-logo-wrap col-md-3 col-sm-12">
					<div class="fl-page-header-logo">
						<a href="https://nationalfootballpost.com/"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post" /><meta itemprop="name" content="National Football Post" /></a>
					</div>
				</div>
				<div class="fl-page-fixed-nav-wrap col-md-9 col-sm-12">
					<div class="fl-page-nav-wrap">
						<nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu">
							<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse">
								<span><i class="fa fa-bars"></i></span>
							</button>
							<div class="fl-page-nav-collapse collapse navbar-collapse">
								<ul id="menu-top-nav" class="nav navbar-nav navbar-right menu"><li id="menu-item-78448" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-94464" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li>
	<li id="menu-item-94463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li>
</ul>
</li>
<li id="menu-item-80343" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a>
<ul class="sub-menu">
	<li id="menu-item-88321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li>
	<li id="menu-item-80344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li>
	<li id="menu-item-78452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li>
</ul>
</li>
<li id="menu-item-78387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a>
<ul class="sub-menu">
	<li id="menu-item-84427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li>
	<li id="menu-item-84236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li>
</ul>
</li>
<li id="menu-item-78499" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a>
<ul class="sub-menu">
	<li id="menu-item-78502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li>
	<li id="menu-item-78500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li>
	<li id="menu-item-80079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li>
</ul>
</li>
</ul>							</div>
						</nav>
					</div>
				</div>
			</div>
		</div>
	</div>
</header><!-- .fl-page-header-fixed -->
<header class="fl-page-header fl-page-header-primary fl-page-nav-centered fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="fl-page-header-wrap">
		<div class="fl-page-header-container container">
			<div class="fl-page-header-row row">
				<div class="col-md-12 fl-page-header-logo-col">
					<div class="fl-page-header-logo" itemscope="itemscope" itemtype="https://schema.org/Organization">
						<a href="https://nationalfootballpost.com/" itemprop="url"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post" /><meta itemprop="name" content="National Football Post" /></a>
					</div>
				</div>
			</div>
		</div>
	</div>
	<div class="fl-page-nav-wrap">
		<div class="fl-page-nav-container container">
			<nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
				<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse">
					<span><i class="fa fa-bars"></i></span>
				</button>
				<div class="fl-page-nav-collapse collapse navbar-collapse">
					<ul id="menu-top-nav-1" class="nav navbar-nav menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li>
</ul>
</li>
</ul><div class="fl-page-nav-search">
	<a href="javascript:void(0);" class="fa fa-search"></a>
	<form method="get" role="search" action="https://nationalfootballpost.com/" title="Type and press Enter to search.">
		<input type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" />
	</form>
</div>
				</div>
			</nav>
		</div>
	</div>
</header><!-- .fl-page-header -->
	<div class="fl-page-content" itemprop="mainContentOfPage">

		
<div class="fl-archive container">
	<div class="row">
		
		<div class="fl-sidebar fl-sidebar-left fl-sidebar-display-desktop col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
		<aside id="custom_html-3" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">RECENT</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/bears-sign-ss-clinton-dix-to-one-year-deal/" title="Bears sign SS Clinton-Dix to one-year deal">Bears sign SS Clinton-Dix to one-year deal</a> 12 mins ago </li><li ><a href="https://nationalfootballpost.com/panthers-cut-ot-kalil/" title="Panthers cut OT Kalil">Panthers cut OT Kalil</a> 12 mins ago </li><li ><a href="https://nationalfootballpost.com/fleetwood-bradley-grab-early-lead-at-players-championship/" title="Fleetwood, Bradley grab early lead at Players Championship">Fleetwood, Bradley grab early lead at Players Championship</a> 13 mins ago </li><li ><a href="https://nationalfootballpost.com/reports-giants-add-wr-tate-de-golden/" title="Reports: Giants add WR Tate, DE Golden">Reports: Giants add WR Tate, DE Golden</a> 13 mins ago </li><li class="current"><a href="https://nationalfootballpost.com/raiders-release-wr-nelson-qb-mccarron/" title="Raiders release WR Nelson, QB McCarron">Raiders release WR Nelson, QB McCarron</a> 13 mins ago </li><li ><a href="https://nationalfootballpost.com/reports-raiders-release-wr-nelson/" title="Reports: Raiders release WR Nelson">Reports: Raiders release WR Nelson</a> 13 mins ago </li><li ><a href="https://nationalfootballpost.com/mickelson-family-not-part-of-college-admissions-scheme/" title="Mickelson: Family not part of college admissions scheme">Mickelson: Family not part of college admissions scheme</a> 13 mins ago </li><li ><a href="https://nationalfootballpost.com/vikings-retain-de-griffen-after-restructure/" title="Vikings retain DE Griffen after restructure">Vikings retain DE Griffen after restructure</a> 13 mins ago </li><li ><a href="https://nationalfootballpost.com/reports-chiefs-agree-to-deal-with-de-okafor/" title="Reports: Chiefs agree to deal with DE Okafor">Reports: Chiefs agree to deal with DE Okafor</a> 13 mins ago </li><li ><a href="https://nationalfootballpost.com/chiefs-agree-to-deal-with-de-okafor/" title="Chiefs agree to deal with DE Okafor">Chiefs agree to deal with DE Okafor</a> 13 mins ago </li><li ><a href="https://nationalfootballpost.com/giants-add-tate-for-reported-four-years-37-5m/" title="Giants add Tate for reported four years, $37.5M">Giants add Tate for reported four years, $37.5M</a> 13 mins ago </li><li ><a href="https://nationalfootballpost.com/cowboys-bring-back-wr-austin-sign-dl-covington/" title="Cowboys bring back WR Austin, sign DL Covington">Cowboys bring back WR Austin, sign DL Covington</a> 13 mins ago </li><li ><a href="https://nationalfootballpost.com/reports-cardinals-to-sign-ol-garcia-wr-white/" title="Reports: Cardinals to sign OL Garcia, WR White">Reports: Cardinals to sign OL Garcia, WR White</a> 13 mins ago </li><li ><a href="https://nationalfootballpost.com/saints-re-sign-bridgewater-add-dt-brown/" title="Saints re-sign Bridgewater, add DT Brown">Saints re-sign Bridgewater, add DT Brown</a> 13 mins ago </li><li ><a href="https://nationalfootballpost.com/patriots-sign-five-players-including-wr-ellington/" title="Patriots sign five players, including WR Ellington">Patriots sign five players, including WR Ellington</a> 13 mins ago </li></ul></div></aside>	</div>

		<div class="fl-content fl-content-right col-md-9" itemscope="itemscope" itemtype="https://schema.org/Blog">

			
									
<article class="fl-post post-110914 post type-post status-publish format-standard hentry category-news tag-flm" id="fl-post-110914" itemscope itemtype="https://schema.org/BlogPosting">

	
	<header class="fl-post-header">
		<h1 class="fl-post-title" itemprop="headline">
			Raiders release WR Nelson, QB McCarron					</h1>
		<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/raiders-release-wr-nelson-qb-mccarron/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>	</header><!-- .fl-post-header -->

	
	
	<div class="fl-post-content clearfix" itemprop="text">
		<h2><title>Raiders release WR Nelson, QB McCarron</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11950314-1.jpg" width="1100" height="724" alt="" title="Dec 30, 2018; Kansas City, MO, USA; Oakland Raiders wide receiver Jordy Nelson (82) gets into position before the snap against the Kansas City Chiefs at Arrowhead Stadium. Mandatory Credit: Jay Biggerstaff-USA TODAY Sports" data-portal-copyright="Jay Biggerstaff-USA TODAY Sports" /></p><p>
The Oakland Raiders released wide receiver Jordy Nelson on Thursday, less than three months after paying him a $3.6 million roster bonus for 2019.
</p>
</p><p>
The Raiders gave Nelson &#8212; who joined the team on a two-year, $14.2 million deal last spring &#8212; his bonus on Dec. 28, which was earlier than required, for cap purposes. Head coach Jon Gruden said at the time regarding Nelson, &#8220;Yeah, he&#8217;ll be back.&#8221;
</p>
</p><p>
Instead, Nelson has been released, after earning just under $11 million for one year. The team will save just over $3.5 million against the cap in 2019, with $1.8 million in dead money.
</p>
</p><p>
Oakland traded for star wideout Antonio Brown over the weekend, then signed former Los Angeles Chargers deep threat Tyrell Williams in free agency.
</p>
</p><p>
Nelson, who turns 34 in May, has now been released in consecutive offseasons, after the Green Bay Packers let him go last spring. He had 63 catches for 739 yards and three touchdowns in 15 games (14 starts) last season.
</p>
</p><p>
Nelson had 97 grabs for 1,257 yards and a league-high 14 scores in 2016 while coming off a torn ACL, but he posted just 53 catches for 482 yards in 2017, marking a career-low 9.1 yards per catch. In 10 career seasons, he has 613 catches for 8,587 yards and 72 touchdowns.
</p>
</p><p>
The Raiders also announced the release of quarterback AJ McCarron, six months after acquiring him from the Buffalo Bills for a fifth-round pick.
</p>
</p><p>
McCarron, 28, was set to count $5 million against the cap in 2019, all of which Oakland will save with his release.
</p>
</p><p>
A former fourth-round pick of the Cincinnati Bengals who went 2-1 as a fill-in starter in 2015, McCarron attempted three passes in two games last year, completing one for 8 yards. He is 87 of 136 for 928 yards, six touchdowns and two interceptions in his career.
</p>
</p><p>
Oakland also officially announced the re-signing of defensive tackle Johnathan Hankins and the addition of former Los Angeles Rams safety Lamarcus Joyner. Both deals were reported earlier this week.
</p>
</p><p>
&#8211;Field Level Media</p>
<div class='rp4wp-related-posts'>
<h3>Related Posts</h3>
<ul>
<li><div class='rp4wp-related-post-content'>
<a href='https://nationalfootballpost.com/reports-raiders-release-wr-nelson/'>Reports: Raiders release WR Nelson</a></div>
</li>
<li><div class='rp4wp-related-post-content'>
<a href='https://nationalfootballpost.com/reports-raiders-release-wr-roberts/'>Reports: Raiders release WR Roberts</a></div>
</li>
<li><div class='rp4wp-related-post-content'>
<a href='https://nationalfootballpost.com/bills-trade-qb-mccarron-to-raiders/'>Bills trade QB McCarron to Raiders</a></div>
</li>
</ul>
</div>
	</div><!-- .fl-post-content -->


    <div class="post-bot">
	    <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>        <div class="share-social">
		    <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fraiders-release-wr-nelson-qb-mccarron%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
		    <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Raiders release WR Nelson, QB McCarron+https://nationalfootballpost.com/?p=110914" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
		    <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Raiders release WR Nelson, QB McCarron&#32;&#32;https://nationalfootballpost.com/?p=110914" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
		    <button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110914"><i class="fa fa-link" aria-hidden="true"></i></button>
        </div>
    </div>
		
</article>

			    
			    <div class="related-post">
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/bears-sign-ss-clinton-dix-to-one-year-deal/" rel="bookmark" title="Bears sign SS Clinton-Dix to one-year deal">Bears sign SS Clinton-Dix to one-year deal</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/bears-sign-ss-clinton-dix-to-one-year-deal/" /><meta itemprop="datePublished" content="12 mins ago" /><meta itemprop="dateModified" content="12 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Bears sign SS Clinton-Dix to one-year deal</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11907081.jpg" width="1100" height="871" alt="" title="Dec 16, 2018; Jacksonville, FL, USA; Washington Redskins strong safety Ha Ha Clinton-Dix (20) reacts during the second quarter against the Jacksonville Jaguars at TIAA Bank Field. Mandatory Credit: Douglas DeFelice-USA TODAY Sports" data-portal-copyright="Douglas DeFelice-USA TODAY Sports" /></p> <p> Strong safety Ha Ha</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Bears sign SS Clinton-Dix to one-year deal</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11907081.jpg" width="1100" height="871" alt="" title="Dec 16, 2018; Jacksonville, FL, USA; Washington Redskins strong safety Ha Ha Clinton-Dix (20) reacts during the second quarter against the Jacksonville Jaguars at TIAA Bank Field. Mandatory Credit: Douglas DeFelice-USA TODAY Sports" data-portal-copyright="Douglas DeFelice-USA TODAY Sports" /></p><p>
Strong safety Ha Ha Clinton-Dix signed a one-year deal worth a reported $3.5 million with the Chicago Bears.
</p>
</p><p>
NFL Network reported Clinton-Dix turned down more money to play in Chicago with fellow Alabama safety Eddie Jackson, who made the Pro Bowl last season at free safety.
</p>
</p><p>
Clinton-Dix was traded to the Washington Redskins in October and spent his previous four-plus NFL seasons with the Bears&#8217; archrival, the Green Bay Packers. Bears safety Adrian Amos signed with the Packers on Wednesday and was introduced at Lambeau Field on Thursday.
</p>
</p><p>
Clinton-Dix didn&#8217;t miss a game while with the Packers, posting 390 tackles, 14 interceptions and 25 passes defensed.
</p>
</p><p>
The Redskins signed safety Landon Collins to a six-year, $84 million deal at the outset of free agency this week.
</p>
</p><p>
Clinton-Dix was a first-round pick of the Packers in 2014.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Bears sign SS Clinton-Dix to one-year deal');return false;"><span class="op-btn">Read More</span> <span class="count">80 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fbears-sign-ss-clinton-dix-to-one-year-deal%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Bears sign SS Clinton-Dix to one-year deal+https://nationalfootballpost.com/?p=110934" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Bears sign SS Clinton-Dix to one-year deal&#32;&#32;https://nationalfootballpost.com/?p=110934" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110934"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/panthers-cut-ot-kalil/" rel="bookmark" title="Panthers cut OT Kalil">Panthers cut OT Kalil</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/panthers-cut-ot-kalil/" /><meta itemprop="datePublished" content="12 mins ago" /><meta itemprop="dateModified" content="12 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Panthers cut OT Kalil</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/10504209.jpg" width="1100" height="732" alt="" title="Dec 24, 2017; Charlotte, NC, USA; Carolina Panthers offensive tackle Matt Kalil (75) is introduced before the game at Bank of America Stadium. Mandatory Credit: Bob Donnan-USA TODAY Sports" data-portal-copyright="Bob Donnan-USA TODAY Sports" /></p> <p> The Carolina Panthers released left tackle Matt Kalil on Thursday with</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Panthers cut OT Kalil</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/10504209.jpg" width="1100" height="732" alt="" title="Dec 24, 2017; Charlotte, NC, USA; Carolina Panthers offensive tackle Matt Kalil (75) is introduced before the game at Bank of America Stadium. Mandatory Credit: Bob Donnan-USA TODAY Sports" data-portal-copyright="Bob Donnan-USA TODAY Sports" /></p><p>
The Carolina Panthers released left tackle Matt Kalil on Thursday with a post-June 1 designation.
</p>
</p><p>
The Charlotte Observer first reported the move. Using the delayed designation saves the Panthers more than $7 million under the salary cap this year.
</p>
</p><p>
Taylor Moton is expected to start at left tackle in 2019.
</p>
</p><p>
Kalil had three years remaining on his contract.
</p>
</p><p>
Kalil missed the entire 2018 season with a right knee injury, landing on injured reserve before the season opener.
</p>
</p><p>
The 29-year-old was a first-round pick of the Minnesota Vikings (2012) before joining the Panthers, with since-retired brother Ryan Kalil at center, in 2017.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Panthers cut OT Kalil');return false;"><span class="op-btn">Read More</span> <span class="count">42 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpanthers-cut-ot-kalil%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Panthers cut OT Kalil+https://nationalfootballpost.com/?p=110929" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Panthers cut OT Kalil&#32;&#32;https://nationalfootballpost.com/?p=110929" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110929"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/fleetwood-bradley-grab-early-lead-at-players-championship/" rel="bookmark" title="Fleetwood, Bradley grab early lead at Players Championship">Fleetwood, Bradley grab early lead at Players Championship</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/fleetwood-bradley-grab-early-lead-at-players-championship/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="12 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Fleetwood, Bradley grab early lead at Players Championship</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/12342188.jpg" width="1100" height="733" alt="" title="Mar 14, 2019; Ponte Vedra Beach, FL, USA; Tommy Fleetwood plays his shot from the sixth tee during the first round of THE PLAYERS Championship golf tournament at TPC Sawgrass - Stadium Course. Mandatory Credit: Jasen Vinlove-USA TODAY Sports" data-portal-copyright="Jasen Vinlove-USA TODAY</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Fleetwood, Bradley grab early lead at Players Championship</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/12342188.jpg" width="1100" height="733" alt="" title="Mar 14, 2019; Ponte Vedra Beach, FL, USA; Tommy Fleetwood plays his shot from the sixth tee during the first round of THE PLAYERS Championship golf tournament at TPC Sawgrass - Stadium Course. Mandatory Credit: Jasen Vinlove-USA TODAY Sports" data-portal-copyright="Jasen Vinlove-USA TODAY Sports" /></p><p>
Keegan Bradley and England&#8217;s Tommy Fleetwood shot 7-under-par 65s on Thursday to share the lead after the first round of The Players Championship in Ponte Verde Beach, Fla.
</p>
</p><p>
While the scores were uncommonly low at TPC Sawgrass as the winds stayed fairly calm, Fleetwood turned in one of only six bogey-free rounds on the day. The majority of the low scores came during the morning wave.
</p>
</p><p>
&#8220;Very happy, I&#8217;ll take that and move on and go have my lunch,&#8221; Fleetwood said after the round. &#8220;I played really, really well. It was nice to just hit a lot of good golf shots. I was really good off the tee, and I put myself in good positions all throughout the day.&#8221;
</p>
</p><p>
Brian Harman and South Korea&#8217;s Byeong Hun An are tied for second at 6 under with Northern Ireland&#8217;s Rory McIlroy another shot back at 5 under along with Vaughn Taylor and Ryan Moore.
</p>
</p><p>
There are 10 players within three shots of the lead, with Slovakia&#8217;s Rory Sabbatini part of a group at 4 under that also includes Brendan Steele, J.T. Poston, Kyle Stanley and Kevin Kisner.
</p>
</p><p>
Fleetwood and Bradley both began their rounds on the back nine.
</p>
</p><p>
While Fleetwood did most of his damage with a 6-under 30 over his final nine holes on the front nine, Bradley shot out of the gates with birdies on two of his first three holes. He traded a bogey and a birdie before knocking his second shot on the par-5 16th hole to within 10 feet and converting the eagle putt.
</p>
</p><p>
Bradley birdied the 18th hole and then added two more birdies over his final nine holes. Perhaps the biggest shot of the day was his third on the par-5 second after shanking his approach into the trees. Bradley overcame a gnarly lie to punch his ball onto the green and went on to save par.
</p>
</p><p>
&#8220;It&#8217;s one of those rounds that just felt easy,&#8221; Bradley told the Golf Channel. &#8220;I rarely ever have rounds like that. It was just a fun day that everything went right.&#8221;
</p>
</p><p>
Fleetwood reeled off three consecutive birdies to close out his opening round, and said the putts simply started to fall in on his back nine.
</p>
</p><p>
&#8220;If you would have asked me this morning a 65, I would have quite happily sat in the locker room and not moved,&#8221; said Fleetwood.
</p>
</p><p>
Tiger Woods is five shots off the lead after battling his way to a 2-under 70. Woods struggled with misses both left and right off the tee throughout the round, but also rolled in six birdies against four bogeys.
</p>
</p><p>
Woods birdied the 16th and 17th holes to put himself in position for just his second opening round in the 60s at TPC Sawgrass, but pulled his 4-foot par put on the 18th hole left of the cup.
</p>
</p><p>
Woods played in the afternoon round, when players had to deal with bumpier greens and stronger winds.
</p>
</p><p>
&#8220;It was tricky out there today,&#8221; he told the Golf Channel. &#8220;I was hoping that we would get the brunt of the wind early and then it would die down. It died down a little bit, it wasn&#8217;t so bad, but the greens got a little bit on the bumpier side towards the end. Became a little more challenging to make the putts.&#8221;
</p>
</p><p>
Other notable names include top-ranked Dustin Johnson (3 under), No. 2 in the world Justin Rose (2 over), Nos. 3 and 4 Brooks Koepka and Justin Thomas (1 under) and Phil Mickelson (2 over.)
</p>
</p><p>
Woods said he came out of the round feeling good after skipping last week&#8217;s Arnold Palmer Invitational due to a neck injury.
</p>
</p><p>
&#8220;Neck&#8217;s fine &#8230; yeah, neck&#8217;s good,&#8221; he said. &#8220;Just wish that putt would have gone in on the last hole.&#8221;
</p>
</p><p>
Notes: Moore hit only the ninth hole-in-one on the famed par-3 17th hole in the history of The Players. It came just minutes after Argentina&#8217;s Emiliano Grillo hit the flagstick with his tee shot and nearly rolled back into the water before going on to make par. Moore&#8217;s ace came from 121 yards. None of the previous players to hit a hole-in-one on the 17th hole have gone on to win The Players. &#8230; Harris English made just the second albatross in the history of the event on the par-5 11th when he holed out from 236 yards. &#8230; Wyndham Clark was the last player in the field after Pat Perez withdrew due to an Achilles injury.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Fleetwood, Bradley grab early lead at Players Championship');return false;"><span class="op-btn">Read More</span> <span class="count">675 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Ffleetwood-bradley-grab-early-lead-at-players-championship%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Fleetwood, Bradley grab early lead at Players Championship+https://nationalfootballpost.com/?p=110924" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Fleetwood, Bradley grab early lead at Players Championship&#32;&#32;https://nationalfootballpost.com/?p=110924" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110924"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/reports-giants-add-wr-tate-de-golden/" rel="bookmark" title="Reports: Giants add WR Tate, DE Golden">Reports: Giants add WR Tate, DE Golden</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/reports-giants-add-wr-tate-de-golden/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Reports: Giants add WR Tate, DE Golden</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11858646-1.jpg" width="1100" height="788" alt="" title="Dec 16, 2018; Los Angeles, CA, USA; Los Angeles Rams defensive back Nickell Robey-Coleman (23) tries to tackle Philadelphia Eagles wide receiver Golden Tate (19) during the first half at Los Angeles Memorial Coliseum. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Reports: Giants add WR Tate, DE Golden</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11858646-1.jpg" width="1100" height="788" alt="" title="Dec 16, 2018; Los Angeles, CA, USA; Los Angeles Rams defensive back Nickell Robey-Coleman (23) tries to tackle Philadelphia Eagles wide receiver Golden Tate (19) during the first half at Los Angeles Memorial Coliseum. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports" /></p><p>
The New York Giants found some wide receiver help Thursday when they agreed to a four-year, $37.5 million deal with Golden Tate, $23 million of which is fully guaranteed, according to multiple reports.
</p>
</p><p>
Tate acknowledged the signing on Twitter, tweeting an image of the &#8220;I love New York&#8221; logo and making it his new profile picture.
</p>
</p><p>
Tate will pick up at least some of the slack after wide receiver Odell Beckham Jr. was traded to the Cleveland Browns this week. A nine-year veteran, Tate, 30, caught 74 passes for 795 yards and four touchdowns for the Detroit Lions and Philadelphia Eagles last season.
</p>
</p><p>
Tate was traded from Detroit to Philadelphia before the trade deadline in October for a third-round pick in the upcoming draft.
</p>
</p><p>
The former second-round pick in 2010 by the Seattle Seahawks has caught 611 passes for 7,214 yards and 38 touchdowns for the Seahawks, Lions and Eagles. He was selected to the Pro Bowl after the 2014 season, his first with the Lions, when he caught a career-best 99 passes for 1,331 yards and four TDs.
</p>
</p><p>
Tate told reporters after the season that if he didn&#8217;t stay with Philadelphia, he hoped to latch on with a contender.
</p>
</p><p>
&#8220;My years are limited,&#8221; Tate said at the time. &#8220;I don&#8217;t have time to go someone who&#8217;s trying to rebuild. I need to go somewhere where they believe they can win now.&#8221;
</p>
</p><p>
Meanwhile, the Giants also added outside linebacker Markus Golden on a one-year deal, according to multiple reports.
</p>
</p><p>
Golden&#8217;s agent, Joseph Clayborne, told ESPN&#8217;s Josina Anderson his client wanted a one-year deal in a good situation to prove his value.
</p>
</p><p>
&#8220;We are going to reunite with his former D Coordinator and get back to where we should be as one of the top pass rushers in the league,&#8221; Clayborne told Anderson.
</p>
</p><p>
Golden, who turned 28 on Wednesday, played three seasons under Giants defensive coordinator James Bettcher, who held the same position with the Arizona Cardinals from 2015-17.
</p>
</p><p>
A second-round pick in 2015, Golden had just 2.5 sacks and six quarterback hits last season in 11 games while returning from a torn ACL, but he racked up 12.5 sacks and 22 QB hits in 16 games in 2016.
</p>
</p><p>
The Giants are also expected to re-sign defensive backs Tony Lippett and Antonio Hamilton, according to multiple reports on Thursday. </p>
</p><p>
Both players were primarily special team performers in 2018.
</p>
</p><p>
-Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Reports: Giants add WR Tate, DE Golden');return false;"><span class="op-btn">Read More</span> <span class="count">326 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freports-giants-add-wr-tate-de-golden%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Reports: Giants add WR Tate, DE Golden+https://nationalfootballpost.com/?p=110919" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Reports: Giants add WR Tate, DE Golden&#32;&#32;https://nationalfootballpost.com/?p=110919" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110919"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/reports-raiders-release-wr-nelson/" rel="bookmark" title="Reports: Raiders release WR Nelson">Reports: Raiders release WR Nelson</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/reports-raiders-release-wr-nelson/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Reports: Raiders release WR Nelson</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11950314.jpg" width="1100" height="724" alt="" title="Dec 30, 2018; Kansas City, MO, USA; Oakland Raiders wide receiver Jordy Nelson (82) gets into position before the snap against the Kansas City Chiefs at Arrowhead Stadium. Mandatory Credit: Jay Biggerstaff-USA TODAY Sports" data-portal-copyright="Jay Biggerstaff-USA TODAY Sports" /></p> <p> The Oakland Raiders released wide</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Reports: Raiders release WR Nelson</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11950314.jpg" width="1100" height="724" alt="" title="Dec 30, 2018; Kansas City, MO, USA; Oakland Raiders wide receiver Jordy Nelson (82) gets into position before the snap against the Kansas City Chiefs at Arrowhead Stadium. Mandatory Credit: Jay Biggerstaff-USA TODAY Sports" data-portal-copyright="Jay Biggerstaff-USA TODAY Sports" /></p><p>
The Oakland Raiders released wide receiver Jordy Nelson on Thursday, according to multiple reports, less than three months after paying him a $3.6 million roster bonus for 2019.
</p>
</p><p>
The Raiders gave Nelson &#8212; who joined the team on a two-year, $14.2 million deal last spring &#8212; his bonus on Dec. 28, which was earlier than required, for cap purposes. Head coach Jon Gruden said at the time regarding Nelson, &#8220;Yeah, he&#8217;ll be back.&#8221;
</p>
</p><p>
Instead, Nelson has been released, after earning just under $11 million for one year. The team will save just over $3.5 million against the cap in 2019, with $1.8 million in dead money.
</p>
</p><p>
Oakland traded for star wideout Antonio Brown over the weekend, then signed former Los Angeles Chargers deep threat Tyrell Williams in free agency.
</p>
</p><p>
Nelson, who turns 34 in May, has now been released in consecutive offseasons, after the Green Bay Packers let him go last spring. He had 63 catches for 739 yards and three touchdowns in 15 games (14 starts) last season.
</p>
</p><p>
Nelson had 97 grabs for 1,257 yards and a league-high 14 scores in 2016 while coming off a torn ACL, but he posted just 53 catches for 482 yards in 2017, marking a career-low 9.1 yards per catch. In 10 career seasons, he has 613 catches for 8,587 yards and 72 touchdowns.
</p>
</p><p>
The Raiders also officially announced the re-signing of defensive tackle Johnathan Hankins and the addition of former Los Angeles Rams safety Lamarcus Joyner. Both deals were reported earlier this week.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Reports: Raiders release WR Nelson');return false;"><span class="op-btn">Read More</span> <span class="count">174 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freports-raiders-release-wr-nelson%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Reports: Raiders release WR Nelson+https://nationalfootballpost.com/?p=110909" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Reports: Raiders release WR Nelson&#32;&#32;https://nationalfootballpost.com/?p=110909" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110909"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/mickelson-family-not-part-of-college-admissions-scheme/" rel="bookmark" title="Mickelson: Family not part of college admissions scheme">Mickelson: Family not part of college admissions scheme</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/mickelson-family-not-part-of-college-admissions-scheme/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Mickelson: Family not part of college admissions scheme</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11342778.jpg" width="1100" height="733" alt="" title="Sep 29, 2018; Paris, FRA; United States golfer Phil Mickelson and Amy Mickelson watch on the 15th hole during the Ryder Cup Saturday afternoon matches at Le Golf National. Mandatory Credit: Brian Spurlock-USA TODAY Sports" data-portal-copyright="Brian Spurlock-USA TODAY Sports" /></p> <p> Golfer</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Mickelson: Family not part of college admissions scheme</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11342778.jpg" width="1100" height="733" alt="" title="Sep 29, 2018; Paris, FRA; United States golfer Phil Mickelson and Amy Mickelson watch on the 15th hole during the Ryder Cup Saturday afternoon matches at Le Golf National. Mandatory Credit: Brian Spurlock-USA TODAY Sports" data-portal-copyright="Brian Spurlock-USA TODAY Sports" /></p><p>
Golfer Phil Mickelson said he paid the ringleader of a college admissions bribery scheme for college preparation for his children but nothing more.
</p>
</p><p>
Speaking Thursday after the opening round of The Players Championship in Ponte Vedra, Fla., Mickelson said he and his wife, Amy, hired William Singer&#8217;s for-profit tutoring company. But, he added, he never made a financial donation to Singer&#8217;s nonprofit group, Key World Foundation, in expectation of Singer&#8217;s help of getting his children into a college they weren&#8217;t qualified to attend.
</p>
</p><p>
Singer admitted to using the foundation to illegally funnel bribes received from parents.
</p>
</p><p>
&#8220;We, along with thousands of other families, hired he and his company to help guide us through the college application process,&#8221; Mickelson told reporters. &#8220;We&#8217;re as shocked as everyone the last few days.&#8221;
</p>
</p><p>
The Mickelsons have three children. Their 19-year-old daughter, Amanda, attends Brown University. Their younger daughter and son are in high school.
</p>
</p><p>
On Tuesday, Singer pleaded guilty to numerous charges that had to do with his work in helping the children of well-to-do parents gain admission to top universities either by arranging to fix their scores on tests such as the SAT, or by building a profile of the students as recruited athletes and connecting them with coaches. Members of athletic staffs at several Division I universities, recruited by Singer, have been indicted in connection with the case.
</p>
</p><p>
Singer published a testimonial letter from the Mickelsons on his company&#8217;s website, which the golfer said his wife wrote as a thank you for assistance in the college-prep efforts for the children.
</p>
</p><p>
&#8220;We&#8217;re not a part of this,&#8221; Mickelson said of the scheme. &#8220;Most every family that hired his company was not a part of it. I think that&#8217;s why we&#8217;re all so surprised.&#8221;
</p>
</p><p>
He said his children have both the academic and athletic prowess to be considered by leading colleges on their own.
</p>
</p><p>
Amanda Mickelson was the captain of the lacrosse and tennis teams at Pacific Ridge School in Carlsbad, Calif. She also was on the basketball team.
</p>
</p><p>
&#8220;Our kids, schools are like fighting to get them,&#8221; Mickelson said. &#8220;I say that as a proud dad. Their grades and outside activities and worldly beliefs are things that have colleges recruiting them. [Singer and his company] helped us through the whole process because it can be confusing.&#8221;
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Mickelson: Family not part of college admissions scheme');return false;"><span class="op-btn">Read More</span> <span class="count">334 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fmickelson-family-not-part-of-college-admissions-scheme%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Mickelson: Family not part of college admissions scheme+https://nationalfootballpost.com/?p=110904" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Mickelson: Family not part of college admissions scheme&#32;&#32;https://nationalfootballpost.com/?p=110904" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110904"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/vikings-retain-de-griffen-after-restructure/" rel="bookmark" title="Vikings retain DE Griffen after restructure">Vikings retain DE Griffen after restructure</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/vikings-retain-de-griffen-after-restructure/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Vikings retain DE Griffen after restructure</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11942942.jpg" width="1100" height="733" alt="" title="Dec 30, 2018; Minneapolis, MN, USA; Minnesota Vikings defensive end Everson Griffen (97) during a game between the Minnesota Vikings and Chicago Bears at U.S. Bank Stadium. Mandatory Credit: Brace Hemmelgarn-USA TODAY Sports" data-portal-copyright="Brace Hemmelgarn-USA TODAY Sports" /></p> <p> The Minnesota Vikings agreed to</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Vikings retain DE Griffen after restructure</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11942942.jpg" width="1100" height="733" alt="" title="Dec 30, 2018; Minneapolis, MN, USA; Minnesota Vikings defensive end Everson Griffen (97) during a game between the Minnesota Vikings and Chicago Bears at U.S. Bank Stadium. Mandatory Credit: Brace Hemmelgarn-USA TODAY Sports" data-portal-copyright="Brace Hemmelgarn-USA TODAY Sports" /></p><p>
The Minnesota Vikings agreed to a restructured contract with defensive end Everson Griffen, general manager Rick Spielman confirmed Thursday, hours before his $10.9 million salary for 2019 would have become guaranteed
</p>
</p><p>
According to NFL Network, Griffen will instead make $8 million in 2019, with the potential to opt out of his deal if he hits certain performance marks.
</p>
</p><p>
Griffen had signed a four-year, $58 million extension in July of 2017 that ran through 2022. The Vikings could have released him outright before his salary became guaranteed on Thursday, which would have saved $10.5 million off the cap with just $1.2 million in dead money.
</p>
</p><p>
The 31-year-old finished with 5.5 sacks and 13 quarterback hits last season in 11 games (10 starts), missing five games due to mental health issues. Griffen was involved in a series of incidents in September that concerned teammates, team personnel and family members, and he left the team for a month before returning in late October.
</p>
</p><p>
Griffen totaled 43.5 sacks and 101 QB hits from 2014-2017 while missing just two games, earning three Pro Bowl nods from 2015-17. A fourth-round pick in 2010, he has 66.5 sacks and 152 QB hits in 132 career games (73 starts) across nine seasons with the Vikings.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Vikings retain DE Griffen after restructure');return false;"><span class="op-btn">Read More</span> <span class="count">136 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fvikings-retain-de-griffen-after-restructure%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Vikings retain DE Griffen after restructure+https://nationalfootballpost.com/?p=110899" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Vikings retain DE Griffen after restructure&#32;&#32;https://nationalfootballpost.com/?p=110899" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110899"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/reports-chiefs-agree-to-deal-with-de-okafor/" rel="bookmark" title="Reports: Chiefs agree to deal with DE Okafor">Reports: Chiefs agree to deal with DE Okafor</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/reports-chiefs-agree-to-deal-with-de-okafor/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Reports: Chiefs agree to deal with DE Okafor</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11198427-1.jpg" width="1100" height="628" alt="" title="Aug 30, 2018; New Orleans, LA, USA; New Orleans Saints defensive end Alex Okafor (57) in the second half of their game against the Los Angeles Rams at Mercedes-Benz Superdome. The Saints won, 28-0. Mandatory Credit: Chuck Cook-USA TODAY Sports" data-portal-copyright="Chuck Cook-USA</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Reports: Chiefs agree to deal with DE Okafor</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11198427-1.jpg" width="1100" height="628" alt="" title="Aug 30, 2018; New Orleans, LA, USA; New Orleans Saints defensive end Alex Okafor (57) in the second half of their game against the Los Angeles Rams at Mercedes-Benz Superdome. The Saints won, 28-0. Mandatory Credit: Chuck Cook-USA TODAY Sports" data-portal-copyright="Chuck Cook-USA TODAY Sports" /></p><p>
The Kansas City Chiefs continued to rework their defense as they agreed Thursday to a three-year, $24 million deal with defensive end Alex Okafor, according to multiple reports.
</p>
</p><p>
A six-year veteran who played the last two seasons in New Orleans, Okafor arrives on the heels of the Chiefs also adding safety Tyrann Mathieu, whose deal was officially signed Thursday.
</p>
</p><p>
Kansas City opened up cap space recently with the release of linebacker Justin Houston and defensive back Eric Berry. The Chiefs also traded franchise-tagged pass rusher Dee Ford to the San Francisco 49ers, citing a poor fit in new coordinator Steve Spagnuolo&#8217;s 4-3 defense.
</p>
</p><p>
Okafor, 28, had four sacks, nine QB hits and 36 tackles last season for the Saints, who advanced to the NFC Championship Game. He started all 16 games in 2018, the first time in his career he has played a full season.
</p>
</p><p>
In 68 career NFL games with the Arizona Cardinals and Saints, the former 2013 fourth-round pick out of Texas has 22 sacks, 48 QB hits, 156 tackles and nine passes defensed. He had career highs of eight sacks and 13 QB hits in 2014 with the Arizona Cardinals.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Reports: Chiefs agree to deal with DE Okafor');return false;"><span class="op-btn">Read More</span> <span class="count">132 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freports-chiefs-agree-to-deal-with-de-okafor%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Reports: Chiefs agree to deal with DE Okafor+https://nationalfootballpost.com/?p=110894" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Reports: Chiefs agree to deal with DE Okafor&#32;&#32;https://nationalfootballpost.com/?p=110894" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110894"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/chiefs-agree-to-deal-with-de-okafor/" rel="bookmark" title="Chiefs agree to deal with DE Okafor">Chiefs agree to deal with DE Okafor</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/chiefs-agree-to-deal-with-de-okafor/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Chiefs agree to deal with DE Okafor</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11198427.jpg" width="1100" height="628" alt="" title="Aug 30, 2018; New Orleans, LA, USA; New Orleans Saints defensive end Alex Okafor (57) in the second half of their game against the Los Angeles Rams at Mercedes-Benz Superdome. The Saints won, 28-0. Mandatory Credit: Chuck Cook-USA TODAY Sports" data-portal-copyright="Chuck Cook-USA TODAY</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Chiefs agree to deal with DE Okafor</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11198427.jpg" width="1100" height="628" alt="" title="Aug 30, 2018; New Orleans, LA, USA; New Orleans Saints defensive end Alex Okafor (57) in the second half of their game against the Los Angeles Rams at Mercedes-Benz Superdome. The Saints won, 28-0. Mandatory Credit: Chuck Cook-USA TODAY Sports" data-portal-copyright="Chuck Cook-USA TODAY Sports" /></p><p>
The Kansas City Chiefs continued to rework their defense as they signed defensive end Alex Okafor, the team announced on Thursday.
</p>
</p><p>
Contract terms were not disclosed, but multiple reports said the deal was for three years and $24 million.
</p>
</p><p>
A six-year veteran who played the last two seasons in New Orleans, Okafor arrives on the heels of the Chiefs also adding safety Tyrann Mathieu, whose deal was officially signed Thursday.
</p>
</p><p>
Kansas City opened up cap space recently with the release of linebacker Justin Houston and defensive back Eric Berry. The Chiefs also traded franchise-tagged pass rusher Dee Ford to the San Francisco 49ers, citing a poor fit in new coordinator Steve Spagnuolo&#8217;s 4-3 defense.
</p>
</p><p>
Okafor, 28, had four sacks, nine QB hits and 36 tackles last season for the Saints, who advanced to the NFC championship game. He started all 16 games in 2018, the first time in his career he has played a full season.
</p>
</p><p>
In 68 career NFL games with the Arizona Cardinals and Saints, the former 2013 fourth-round pick out of Texas has 22 sacks, 48 QB hits, 156 tackles and nine passes defensed. He had career highs of eight sacks and 13 QB hits in 2014 with the Arizona Cardinals.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Chiefs agree to deal with DE Okafor');return false;"><span class="op-btn">Read More</span> <span class="count">142 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fchiefs-agree-to-deal-with-de-okafor%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Chiefs agree to deal with DE Okafor+https://nationalfootballpost.com/?p=110889" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Chiefs agree to deal with DE Okafor&#32;&#32;https://nationalfootballpost.com/?p=110889" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110889"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/giants-add-tate-for-reported-four-years-37-5m/" rel="bookmark" title="Giants add Tate for reported four years, $37.5M">Giants add Tate for reported four years, $37.5M</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/giants-add-tate-for-reported-four-years-37-5m/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Giants add Tate for reported four years, $37.5M</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11858646.jpg" width="1100" height="788" alt="" title="Dec 16, 2018; Los Angeles, CA, USA; Los Angeles Rams defensive back Nickell Robey-Coleman (23) tries to tackle Philadelphia Eagles wide receiver Golden Tate (19) during the first half at Los Angeles Memorial Coliseum. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Giants add Tate for reported four years, $37.5M</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11858646.jpg" width="1100" height="788" alt="" title="Dec 16, 2018; Los Angeles, CA, USA; Los Angeles Rams defensive back Nickell Robey-Coleman (23) tries to tackle Philadelphia Eagles wide receiver Golden Tate (19) during the first half at Los Angeles Memorial Coliseum. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports" /></p><p>
The New York Giants found some wide receiver help Thursday when they agreed to a four-year, $37.5 million deal with Golden Tate, $23 million of which is fully guaranteed, according to multiple reports.
</p>
</p><p>
Tate acknowledged the signing on Twitter, tweeting an image of the &#8220;I love New York&#8221; logo and making it his new profile picture.
</p>
</p><p>
Tate will pick up at least some of the slack after wide receiver Odell Beckham Jr. was traded to the Cleveland Brown this week. A nine-year veteran, Tate, 30, caught 74 passes for 795 yards and four touchdowns for the Detroit Lions and Philadelphia Eagles last season.
</p>
</p><p>
Tate was traded from Detroit to Philadelphia before the trade deadline in October for a third-round draft pick in the upcoming draft.
</p>
</p><p>
The former second-round pick in 2010 by the Seattle Seahawks has caught 611 passes for 7,214 yards and 38 touchdowns for the Seahawks, Lions and Eagles. He was selected to the Pro Bowl after the 2014 season, his first with the Lions, when he caught a career-best 99 passes for 1,331 yards and four TDs.
</p>
</p><p>
Tate told reporters after the season that if he didn&#8217;t stay with Philadelphia, he hoped to latch on with a contender.
</p>
</p><p>
&#8220;My years are limited,&#8221; Tate said at the time. &#8220;I don&#8217;t have time to go someone who&#8217;s trying to rebuild. I need to go somewhere where they believe they can win now.&#8221;
</p>
</p><p>
-Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Giants add Tate for reported four years, $37.5M');return false;"><span class="op-btn">Read More</span> <span class="count">172 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fgiants-add-tate-for-reported-four-years-37-5m%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Giants add Tate for reported four years, $37.5M+https://nationalfootballpost.com/?p=110884" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Giants add Tate for reported four years, $37.5M&#32;&#32;https://nationalfootballpost.com/?p=110884" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110884"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/cowboys-bring-back-wr-austin-sign-dl-covington/" rel="bookmark" title="Cowboys bring back WR Austin, sign DL Covington">Cowboys bring back WR Austin, sign DL Covington</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/cowboys-bring-back-wr-austin-sign-dl-covington/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Cowboys bring back WR Austin, sign DL Covington</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/12011069-1.jpg" width="1100" height="865" alt="" title="Sep 16, 2018; Arlington, TX, USA; Dallas Cowboys receiver Tavon Austin (10) runs after a reception for a touchdown against the New York Giants at AT&amp;T Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports" data-portal-copyright="Matthew Emmons-USA TODAY Sports" /></p> <p> The Cowboys and</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Cowboys bring back WR Austin, sign DL Covington</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/12011069-1.jpg" width="1100" height="865" alt="" title="Sep 16, 2018; Arlington, TX, USA; Dallas Cowboys receiver Tavon Austin (10) runs after a reception for a touchdown against the New York Giants at AT&T Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports" data-portal-copyright="Matthew Emmons-USA TODAY Sports" /></p><p>
The Cowboys and Tavon Austin agreed on a one-year deal to keep the speedy wide receiver in Dallas, the team announced Thursday.
</p>
</p><p>
Austin played in just seven games due to injury last season, catching eight passes for 140 yards and two touchdowns. He could be in line for more targets now that Cole Beasley left the Cowboys for Buffalo.
</p>
</p><p>
Austin also ran the ball six times for 55 yards.
</p>
</p><p>
Austin has 14 career touchdowns in six NFL seasons, the first five of which came with the Rams.
</p>
</p><p>
The Cowboys also signed free agent defensive lineman Christian Covington to a one-year deal to bolster a line that will be without Randy Gregory and David Irving next season. Covington posted 7.5 sacks in 50 games with the Houston Texans over the past four seasons.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Cowboys bring back WR Austin, sign DL Covington');return false;"><span class="op-btn">Read More</span> <span class="count">78 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fcowboys-bring-back-wr-austin-sign-dl-covington%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Cowboys bring back WR Austin, sign DL Covington+https://nationalfootballpost.com/?p=110879" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Cowboys bring back WR Austin, sign DL Covington&#32;&#32;https://nationalfootballpost.com/?p=110879" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110879"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/reports-cardinals-to-sign-ol-garcia-wr-white/" rel="bookmark" title="Reports: Cardinals to sign OL Garcia, WR White">Reports: Cardinals to sign OL Garcia, WR White</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/reports-cardinals-to-sign-ol-garcia-wr-white/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Reports: Cardinals to sign OL Garcia, WR White</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/10487529-1.jpg" width="1100" height="733" alt="" title="Dec 10, 2017; Denver, CO, USA; Denver Broncos offensive guard Max Garcia (76) during the first half against the New York Jets at Sports Authority Field at Mile High. Mandatory Credit: Ron Chenoy-USA TODAY Sports" data-portal-copyright="Ron Chenoy-USA TODAY Sports" /></p> <p> The</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Reports: Cardinals to sign OL Garcia, WR White</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/10487529-1.jpg" width="1100" height="733" alt="" title="Dec 10, 2017; Denver, CO, USA; Denver Broncos offensive guard Max Garcia (76) during the first half against the New York Jets at Sports Authority Field at Mile High. Mandatory Credit: Ron Chenoy-USA TODAY Sports" data-portal-copyright="Ron Chenoy-USA TODAY Sports" /></p><p>
The Arizona Cardinals continue to revamp their offensive line, coming to terms with free agent offensive lineman Max Garcia, according to multiple media reports.
</p>
</p><p>
Arizona is also expected to sign former Chicago Bears first-round wideout Kevin White, according to NFL Network.
</p>
</p><p>
Garcia was drafted by the Denver Broncos in the fourth round of the 2015 draft and played in 57 games for the team, starting 41. Garcia is primarily a left guard but has played some on the right side. He is coming off an ACL tear suffered in mid-November.
</p>
</p><p>
The Cardinals, beset with injuries and poor play in the trenches last year, have already traded for former Pittsburgh Steelers offensive tackle Marcus Gilbert and come to terms with former Seattle Seahawks guard J.R. Sweezy.
</p>
</p><p>
White, 26, was drafted seventh overall in 2015 but has played in just 14 games (five starts) through four seasons due to a variety of injuries. After surgery to repair a stress fracture in his left leg wiped out his rookie season, he broke the fibula in the same leg in 2016 and then fractured his left shoulder blade in 2017, finishing all three years on injured reserve.
</p>
</p><p>
Last year, White had four catches for 92 yards in nine games (no starts), including a 54-yarder on a Hail Mary attempt that came up just short of the goal line. He was a healthy scratch in several games during the final few weeks of the season.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Reports: Cardinals to sign OL Garcia, WR White');return false;"><span class="op-btn">Read More</span> <span class="count">183 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freports-cardinals-to-sign-ol-garcia-wr-white%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Reports: Cardinals to sign OL Garcia, WR White+https://nationalfootballpost.com/?p=110874" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Reports: Cardinals to sign OL Garcia, WR White&#32;&#32;https://nationalfootballpost.com/?p=110874" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110874"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/saints-re-sign-bridgewater-add-dt-brown/" rel="bookmark" title="Saints re-sign Bridgewater, add DT Brown">Saints re-sign Bridgewater, add DT Brown</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/saints-re-sign-bridgewater-add-dt-brown/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Saints re-sign Bridgewater, add DT Brown</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11919833.jpg" width="1100" height="769" alt="" title="Dec 30, 2018; New Orleans, LA, USA; New Orleans Saints quarterback Teddy Bridgewater (5) looks to pass against the Carolina Panthers during the second quarter at the Mercedes-Benz Superdome. Mandatory Credit: Derick E. Hingle-USA TODAY Sports" data-portal-copyright="Derick E. Hingle-USA TODAY Sports" /></p> <p> Quarterback</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Saints re-sign Bridgewater, add DT Brown</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11919833.jpg" width="1100" height="769" alt="" title="Dec 30, 2018; New Orleans, LA, USA; New Orleans Saints quarterback Teddy Bridgewater (5) looks to pass against the Carolina Panthers during the second quarter at the Mercedes-Benz Superdome. Mandatory Credit: Derick E. Hingle-USA TODAY Sports" data-portal-copyright="Derick E. Hingle-USA TODAY Sports" /></p><p>
Quarterback Teddy Bridgewater has agreed to re-sign with the New Orleans Saints rather than join the Miami Dolphins, according to multiple reports on Thursday.
</p>
</p><p>
Bridgewater acknowledged the decision on Twitter, posting a photo of himself in his Saints uniform with the caption, &#8220;Run it back Turbo.&#8221;
</p>
</p><p>
According to multiple reports, Bridgewater will sign a one-year deal worth $7.25 million, with incentives that can push the value as high as $12.5 million.
</p>
</p><p>
Bridgewater, 26, visited with the Dolphins on Wednesday evening but did not come away with a contract.
</p>
</p><p>
NFL Network reported after Monday&#8217;s free agent negotiating window opened that Bridgewater would return to New Orleans, but multiple reports on Wednesday said the decision was not final, and that the Miami native could opt for his hometown Dolphins if they offered more money. The Fort Worth Star-Telegram reported Wednesday that speculation linking Saints head coach Sean Payton to the Dallas Cowboys&#8217; job in 2020 was factoring into Bridgewater&#8217;s decision.
</p>
</p><p>
After flirting with Miami, Bridgewater will remain the Saints&#8217; backup and potential heir apparent to 40-year-old Drew Brees, whose contract was restructured Thursday to create more cap room. Brees is under contract through 2019, though he has said he would like to play further into his 40s.
</p>
</p><p>
Bridgewater went 14 for 23 for 118 yards, a touchdown and an interception in limited action last season, but he impressed in the preseason for the New York Jets, prompting the Saints to trade a third-round pick for him in August. The former first-round pick has started just one game since suffering a devastating knee injury just before the 2016 season opener.
</p>
</p><p>
The Saints also signed former New England Patriots defensive tackle Malcom Brown to a three-year contract on Thursday.
</p>
</p><p>
According to multiple reports, the deal is worth $5 million annually.
</p>
</p><p>
Brown, 25, was the Patriots&#8217; first-round pick in 2015 and started 51 of 60 games over four seasons while shining in run defense, but his fifth-year option was declined. He had no sacks and just one QB hit last year while making a career-low 39 tackles, but he has 8.5 sacks, 16 QB hits and 186 tackles in his career.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Saints re-sign Bridgewater, add DT Brown');return false;"><span class="op-btn">Read More</span> <span class="count">287 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fsaints-re-sign-bridgewater-add-dt-brown%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Saints re-sign Bridgewater, add DT Brown+https://nationalfootballpost.com/?p=110869" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Saints re-sign Bridgewater, add DT Brown&#32;&#32;https://nationalfootballpost.com/?p=110869" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110869"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/patriots-sign-five-players-including-wr-ellington/" rel="bookmark" title="Patriots sign five players, including WR Ellington">Patriots sign five players, including WR Ellington</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/patriots-sign-five-players-including-wr-ellington/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Patriots sign five players, including WR Ellington</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11819806.jpg" width="1100" height="758" alt="" title="Dec 9, 2018; Glendale, AZ, USA; Detroit Lions wide receiver Bruce Ellington flips his dreadlocks hair back prior to putting on his helmet against the Arizona Cardinals at State Farm Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports"</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Patriots sign five players, including WR Ellington</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11819806.jpg" width="1100" height="758" alt="" title="Dec 9, 2018; Glendale, AZ, USA; Detroit Lions wide receiver Bruce Ellington flips his dreadlocks hair back prior to putting on his helmet against the Arizona Cardinals at State Farm Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports" /></p><p>
The New England Patriots added pieces to their roster on Thursday, signing five players.
</p>
</p><p>
Defensive tackle Mike Pennel signed a two-year deal, his agent confirmed. Tight end Matt LaCosse, who visited the Patriots on Thursday, also signed a two-year contract, this one worth as much as $4.8 million, ESPN&#8217;s Mike Reiss said.
</p>
</p><p>
Wide receivers Bruce Ellington and Maurice Harris also are joining the team, according to multiple outlets. Ellington&#8217;s deal is for one year, and no terms were reported or announced for either receiver.
</p>
</p><p>
Safety Terrence Brooks, also a special teams standout, is moving to New England from the New York Jets on a two-year deal, ESPN&#8217;s Adam Schefter reported.
</p>
</p><p>
Pennel, 27, is a five-year NFL veteran who spent the past two seasons with the Jets, before they declined his 2019 option in February. In 32 games (10 starts) in that span, he made 62 tackles and had three quarterback hits. He can help to fill the vacancy created when Malcom Brown departed for New Orleans.
</p>
</p><p>
The 26-year-old LaCosse is entering his fourth season. With Denver last year, he played in 15 games, making 24 catches for 250 yards and a touchdown. The Broncos declined to tender LaCosse, who was a restricted free agent, earlier this week.
</p>
</p><p>
Ellington split time last season between the Houston Texans and Detroit Lions. In seven games (three starts), the 27-year-old had 31 receptions for 224 yards and a touchdown.
</p>
</p><p>
Harris, 26, played for the Washington Redskins for three seasons before they declined his restricted free agent tender this week. In that time, he appeared in 28 games (seven starts), catching 40 passes for 432 yards and a touchdown. He also filled in as a punt returner in 2018.
</p>
</p><p>
Brooks, 27, has played for the Baltimore Ravens, Philadelphia Eagles and the Jets during his five-year career. In 65 total games, he has 43 tackles, three interceptions, eight pass breakups and two forced fumbles.
</p>
</p><p>
Meanwhile, the Patriots officially announced the re-signing of cornerback Jason McCourty and addition of running back Brandon Bolden, which were both reported on Wednesday.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Patriots sign five players, including WR Ellington');return false;"><span class="op-btn">Read More</span> <span class="count">273 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpatriots-sign-five-players-including-wr-ellington%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Patriots sign five players, including WR Ellington+https://nationalfootballpost.com/?p=110864" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Patriots sign five players, including WR Ellington&#32;&#32;https://nationalfootballpost.com/?p=110864" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110864"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/qb-mayfield-its-an-exciting-time-in-cleveland/" rel="bookmark" title="QB Mayfield: &#8216;It&#8217;s an exciting time in Cleveland&#8217;">QB Mayfield: &#8216;It&#8217;s an exciting time in Cleveland&#8217;</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/qb-mayfield-its-an-exciting-time-in-cleveland/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>QB Mayfield: 'It's an exciting time in Cleveland'</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11992881.jpg" width="1100" height="732" alt="" title="Dec 23, 2018; Cleveland, OH, USA; Cleveland Browns quarterback Baker Mayfield (6) at FirstEnergy Stadium. Mandatory Credit: Ken Blaze-USA TODAY Sports" data-portal-copyright="Ken Blaze-USA TODAY Sports" /></p> <p> Cleveland Browns quarterback Baker Mayfield said Friday he can't wait to show the fans what</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>QB Mayfield: &#8216;It&#8217;s an exciting time in Cleveland&#8217;</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11992881.jpg" width="1100" height="732" alt="" title="Dec 23, 2018; Cleveland, OH, USA; Cleveland Browns quarterback Baker Mayfield (6) at FirstEnergy Stadium. Mandatory Credit: Ken Blaze-USA TODAY Sports" data-portal-copyright="Ken Blaze-USA TODAY Sports" /></p><p>
Cleveland Browns quarterback Baker Mayfield said Friday he can&#8217;t wait to show the fans what the team can do in 2019.
</p>
</p><p>
&#8220;It&#8217;s an exciting time in Cleveland, absolutely,&#8221; Mayfield said. &#8220;The fans there, after having a decent year, nothing that we were too happy about (7-8-1), were unbelievably satisfied. But now, I can&#8217;t even imagine.
</p>
</p><p>
Mayfield made his first public comments since the Browns acquired Pro Bowl wide receiver Odell Beckham Jr. from the New York Giants on Tuesday. He spoke to the media from the Milwaukee Brewers spring training locker room in Phoenix, where he spent the day as a guest of his close friend, Brewers outfielder Christian Yelich.
</p>
</p><p>
The Browns have spent the offseason surrounding the second-year quarterback with offensive weapons, most notably Beckham and running back Kareem Hunt, who must serve an eight-game NFL suspension before he can take the field. Beckham is reunited in Cleveland with wide receiver Jarvis Landry, his teammate at LSU and training partner in the NFL.
</p>
</p><p>
He called the offense &#8220;a thing where you pick your poison.&#8221;
</p>
</p><p>
When a reporter asked Mayfield about the oversized personalities of Landry and Beckham, he said he has no intention of trying to change anything about the receivers.
</p>
</p><p>
&#8220;You could say the same thing about me; you don&#8217;t want to tame it,&#8221; Mayfield said. &#8220;You just let them be themselves and make plays. That&#8217;s who they are, and when it comes down to it, the guys in that locker room, you&#8217;re going to love playing with them.&#8221;
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'QB Mayfield: &#8216;It&#8217;s an exciting time in Cleveland&#8217;');return false;"><span class="op-btn">Read More</span> <span class="count">202 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fqb-mayfield-its-an-exciting-time-in-cleveland%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=QB Mayfield: ‘It’s an exciting time in Cleveland’+https://nationalfootballpost.com/?p=110859" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=QB Mayfield: &#8216;It&#8217;s an exciting time in Cleveland&#8217;&#32;&#32;https://nationalfootballpost.com/?p=110859" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110859"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/nfl-transactions-bridgewater-re-signs-with-saints/" rel="bookmark" title="NFL transactions: Bridgewater re-signs with Saints">NFL transactions: Bridgewater re-signs with Saints</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-transactions-bridgewater-re-signs-with-saints/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>NFL transactions: Bridgewater re-signs with Saints</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11919711-2.jpg" width="1100" height="690" alt="" title="Dec 30, 2018; New Orleans, LA, USA; New Orleans Saints quarterback Teddy Bridgewater (5) looks to throw in the second half against the Carolina Panthers at the Mercedes-Benz Superdome. Mandatory Credit: Chuck Cook-USA TODAY Sports" data-portal-copyright="Chuck Cook-USA TODAY Sports" /></p> <p> Quarterback Teddy Bridgewater</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>NFL transactions: Bridgewater re-signs with Saints</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11919711-2.jpg" width="1100" height="690" alt="" title="Dec 30, 2018; New Orleans, LA, USA; New Orleans Saints quarterback Teddy Bridgewater (5) looks to throw in the second half against the Carolina Panthers at the Mercedes-Benz Superdome. Mandatory Credit: Chuck Cook-USA TODAY Sports" data-portal-copyright="Chuck Cook-USA TODAY Sports" /></p><p>
Quarterback Teddy Bridgewater agreed to re-sign with the New Orleans Saints rather than join the Miami Dolphins, according to multiple reports on Thursday.
</p>
</p><p>
Bridgewater, who acknowledged the decision on Twitter, reportedly will receive a one-year deal worth $7.25 million, with incentives that can push the value as high as $12.5 million. He visited the Dolphins on Wednesday.
</p>
</p><p>
The Saints also restructured Drew Brees&#8217; contract to free up $10.8 million in cap space and signed former New England Patriots defensive tackle Malcom Brown. According to multiple reports, Brown&#8217;s deal is worth $5 million annually.
</p>
</p><p>
&#8211;The New York Giants agreed to a four-year, $37.5 million deal, $23 million of which is fully guaranteed, with wideout Golden Tate, according to multiple reports.
</p>
</p><p>
Tate, who acknowledged the signing on Twitter, will pick up at least some of the slack after wide receiver Odell Beckham Jr. was traded to the Cleveland Browns this week. Tate, 30, caught 74 passes for 795 yards and four touchdowns for the Detroit Lions and Philadelphia Eagles last season.
</p>
</p><p>
The Giants also added outside linebacker Markus Golden on a one-year deal, according to multiple reports, reuniting him with former coordinator James Bettcher. Golden had 12.5 sacks under Bettcher with the Arizona Cardinals in 2016.
</p>
</p><p>
&#8211;Trey Flowers put pen to paper to join the Detroit Lions on a $90 million contract, officially becoming the fifth-highest-paid defensive player in the NFL.
</p>
</p><p>
The former Patriots defensive end, who aligned at six different positions for at least 15 snaps last season in New England, was a coveted chess piece for Matt Patricia&#8217;s defense in Detroit. Patricia used to coach Flowers in New England. Flowers racked up 21 sacks and 59 QB hits over the past three seasons. He received a $28 million signing bonus.
</p>
</p><p>
The Lions also signed safety Andrew Adams to a one-year deal after the Bucs declined to tender a contract to the restricted free agent.
</p>
</p><p>
&#8211;The Seattle Seahawks re-signed linebacker K.J. Wright and guard D.J. Fluker while adding guard Mike Iupati.
</p>
</p><p>
Wright&#8217;s deal is for two years and $15.5 million, according to NFL Network. Fluker&#8217;s deal is for two years and $9 million per NFL.com, while Iupati&#8217;s deal is for one year.
</p>
</p><p>
&#8211;The Oakland Raiders released wide receiver Jordy Nelson and quarterback AJ McCarron.
</p>
</p><p>
The Raiders gave Nelson a $3.6 million bonus on Dec. 28, which was earlier than required, for cap purposes. Head coach Jon Gruden said at the time regarding Nelson, &#8220;Yeah, he&#8217;ll be back.&#8221;
</p>
</p><p>
Nelson earned just under $11 million for one year, with the team saving $3.5 million with his release. The Raiders will save $5 million by releasing McCarron, who was acquired for a fifth-round pick from Buffalo in September.
</p>
</p><p>
&#8211;The Minnesota Vikings agreed to a restructured contract with defensive end Everson Griffen, general manager Rick Spielman confirmed, hours before his $10.9 million salary for 2019 would have become guaranteed.
</p>
</p><p>
According to NFL Network, Griffen instead will make $8 million in 2019, with the potential to opt out of his deal if he hits certain performance marks.
</p>
</p><p>
&#8211;The Kansas City Chiefs signed former Saints defensive end Alex Okafor.
</p>
</p><p>
Contract terms were not disclosed, but multiple reports said the deal was for three years and $24 million.
</p>
</p><p>
&#8211;Safety Ha Ha Clinton-Dix signed a one-year deal worth a reported $3.5 million with the Chicago Bears.
</p>
</p><p>
NFL Network reported Clinton-Dix turned down more money to play in Chicago with fellow Alabama safety Eddie Jackson.
</p>
</p><p>
&#8211;The Carolina Panthers released left tackle Matt Kalil with a post-June 1 designation.
</p>
</p><p>
The Charlotte Observer first reported the move. Using the delayed designation saves the Panthers more than $7 million under the salary cap this year.
</p>
</p><p>
&#8211;The San Francisco 49ers signed former Pro Bowl cornerback Jason Verrett to a one-year contract. Multiple outlets report the deal is worth $3.6 million.
</p>
</p><p>
Verrett, 27, has played in just five games over the past three seasons and just 25 through five years, but he reached the Pro Bowl in 2015 with the then-San Diego Chargers.
</p>
</p><p>
The 49ers also signed former Eagles wideout Jordan Matthews (one-year deal) and former Panthers linebacker David Mayo (two years) and released linebacker Brock Coyle, who announced his retirement due to a compression fracture in his back sustained last season. The team will also re-sign safety Antone Exum on a one-year deal worth $895,000, per multiple reports.
</p>
</p><p>
&#8211;The Jets officially signed and introduced running back Le&#8217;Veon Bell, a few hours after releasing incumbent starter Isaiah Crowell. They also re-signed nose tackle Steve McLendon and officially confirmed the re-signings of offensive lineman Jonotthan Harrison and cornerback Darryl Roberts.
</p>
</p><p>
The New York Daily News reported McLendon&#8217;s deal is for one year and $2.5 million, with an additional $1 million in incentives.
</p>
</p><p>
The Jets also signed cornerback Brian Poole to a one-year, $3.5 million deal, per multiple reports. The Atlanta Falcons surprisingly did not tender the restricted free agent after he broke up 20 passes in 47 games (21 starts) over the past three seasons.
</p>
</p><p>
&#8211;The Patriots signed defensive tackle Mike Pennel (two-year deal), tight end Matt LaCosse (two years, $4.8 million), wide receivers Bruce Ellington (one year) and Maurice Harris (not reported) and safety Terrence Brooks (two years), according to several reports.
</p>
</p><p>
Pennel and Brooks are former Jets.
</p>
</p><p>
&#8211;The Cincinnati Bengals signed former Giants cornerback B.W. Webb to a three-year contract. The deal reportedly is worth $13 million.
</p>
</p><p>
&#8211;The Pittsburgh Steelers signed former Jaguars wide receiver Donte Moncrief to a two-year deal and re-signed wideout Eli Rogers and defensive tackle Dan McCullers.
</p>
</p><p>
&#8211;The Dallas Cowboys re-signed wideout Tavon Austin and added former Texans defensive lineman Christian Covington, both on one-year deals.
</p>
</p><p>
&#8211;The Falcons signed tight end Luke Stocker on a two-year contract and running back Kenjon Barner on a one-year deal.
</p>
</p><p>
&#8211;The Arizona Cardinals are expected to sign former Bears first-round wideout Kevin White, per NFL Network, and former Denver Broncos guard Max Garcia, per his agent.
</p>
</p><p>
&#8211;The Cleveland Browns signed former Bears offensive lineman Eric Kush, who started seven games last season.
</p>
</p><p>
&#8211;The Philadelphia Eagles signed former Steelers linebacker L.J. Fort to a three-year deal worth a reported, $5.6 million.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'NFL transactions: Bridgewater re-signs with Saints');return false;"><span class="op-btn">Read More</span> <span class="count">915 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-transactions-bridgewater-re-signs-with-saints%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL transactions: Bridgewater re-signs with Saints+https://nationalfootballpost.com/?p=110854" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL transactions: Bridgewater re-signs with Saints&#32;&#32;https://nationalfootballpost.com/?p=110854" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110854"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/browns-rb-hunt-suspended-eight-games/" rel="bookmark" title="Browns RB Hunt suspended eight games">Browns RB Hunt suspended eight games</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/browns-rb-hunt-suspended-eight-games/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Browns RB Hunt suspended eight games</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11700781.jpg" width="1100" height="733" alt="" title="Nov 19, 2018; Los Angeles, CA: Kansas City Chiefs running back Kareem Hunt (27) celebrates scoring in the second quarter against the Los Angeles Rams at the Los Angeles Memorial Coliseum. Mandatory Credit: Robert Hanashiro-USA TODAY Sports" data-portal-copyright="Robert Hanashiro-USA TODAY Sports" /></p> <p> Cleveland</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Browns RB Hunt suspended eight games</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11700781.jpg" width="1100" height="733" alt="" title="Nov 19, 2018; Los Angeles, CA: Kansas City Chiefs running back Kareem Hunt (27) celebrates scoring in the second quarter against the Los Angeles Rams at the Los Angeles Memorial Coliseum. Mandatory Credit: Robert Hanashiro-USA TODAY Sports" data-portal-copyright="Robert Hanashiro-USA TODAY Sports" /></p><p>
Cleveland Browns running back Kareem Hunt was suspended for the first eight games of the 2018 season.
</p>
</p><p>
Hunt was on the commissioner&#8217;s exempt list since Nov. 30 during the NFL&#8217;s investigation into a physical altercation captured by an Ohio hotel surveillance system in which Hunt shoved to the ground and kicked a woman.
</p>
</p><p>
Hunt&#8217;s agent, Dan Saffron, said there will be no appeal in a released statement in response to the announcement of the discipline.
</p>
</p><p>
&#8220;PFS Agency stands behind our client, Kareem Hunt, in his decision to accept the suspension handed down by the NFL today,&#8221; Saffron said.
</p>
</p><p>
The NFL said in a statement Hunt&#8217;s ban is the result of two separate incidents.
</p>
</p><p>
&#8220;Kareem Hunt of the Cleveland Browns was notified today that he has been suspended without pay for the Browns&#8217; first eight regular season games for violations of the NFL Personal Conduct Policy in connection with physical altercations at his residence in Cleveland last February and at a resort in Ohio last June. Hunt was placed on the Commissioner Exempt list on November 30 and was released by his former club, the Kansas City Chiefs, that same day. The findings followed a detailed investigation by the NFL, which included reviewing available law enforcement records, video and electronic communications, interviews with numerous witnesses, and multiple interviews with Hunt.
</p>
</p><p>
&#8220;Hunt has advised the league office that he accepts responsibility for his conduct and the discipline that has been imposed. He has committed to take advantage of available resources to help him grow personally and as a member of the Cleveland community, and to live up to his obligations as an NFL player. The eight-game suspension will take effect as of the final roster reduction on August 31. Hunt will be eligible to play in the Browns&#8217; ninth regular season game.&#8221;
</p>
</p><p>
When the video surfaced, Hunt was released by the Chiefs. The Browns signed Hunt to a one-year contract in February after general manager John Dorsey &#8212; who drafted Hunt as GM of the Chiefs &#8212; and owner Jimmy Haslam reviewed the situation and discussed appropriate steps toward contrition with Hunt.
</p>
</p><p>
&#8220;We had done our research,&#8221; Dorsey said at the NFL Scouting Combine. &#8220;We thought at the appropriate time with all the information we did have, how truly remorseful he was and &#8230; knowing when he comes here there are no guarantees, he&#8217;s going to earn your respect with his actions. Right now, I feel very comfortable with the signing.
</p>
</p><p>
&#8220;Deep down, if you really sit down and engage with him, he has a really good heart. The act he did last year &#8212; it was egregious. We all know that. &#8230; He&#8217;s showing through his actions, not his words, how remorseful he is.&#8221;
</p>
</p><p>
Hunt is not permitted to be with the Browns during the suspension, but can participate in training camp and preseason games.
</p>
</p><p>
ESPN reported Hunt will forfeit $303,529 of his $645,000 base salary. He is scheduled to be a restricted free agent in March 2019.
</p>
</p><p>
&#8220;He&#8217;s got a lot of work to do,&#8221; Browns coach Freddie Kitchens said in Indianapolis, &#8220;between now and when that second chance comes. Right now, our job is to support Kareem and help him grow as a person.&#8221;
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Browns RB Hunt suspended eight games');return false;"><span class="op-btn">Read More</span> <span class="count">475 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fbrowns-rb-hunt-suspended-eight-games%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Browns RB Hunt suspended eight games+https://nationalfootballpost.com/?p=110849" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Browns RB Hunt suspended eight games&#32;&#32;https://nationalfootballpost.com/?p=110849" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110849"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/titans-releasing-veteran-g-kline/" rel="bookmark" title="Titans releasing veteran G Kline">Titans releasing veteran G Kline</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/titans-releasing-veteran-g-kline/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Titans releasing veteran G Kline</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/10488048.jpg" width="1100" height="868" alt="" title="Dec 10, 2017; Glendale, AZ, USA; Tennessee Titans guard Josh Kline (64) against the Arizona Cardinals at University of Phoenix Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports" /></p> <p> The Tennessee Titans are releasing right guard Josh Kline, one</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Titans releasing veteran G Kline</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/10488048.jpg" width="1100" height="868" alt="" title="Dec 10, 2017; Glendale, AZ, USA; Tennessee Titans guard Josh Kline (64) against the Arizona Cardinals at University of Phoenix Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports" /></p><p>
The Tennessee Titans are releasing right guard Josh Kline, one year after signing him to a four-year, $26 million contract extension.
</p>
</p><p>
NFL Network&#8217;s Ian Rapoport said the 29-year-old veteran declined to take a pay cut. Releasing him leaves a $3.5 million dead cap hit this season.
</p>
</p><p>
Kline started all 16 games last season and 46 of the Titans&#8217; 48 games from 2016-18. He spent his first three seasons with the New England Patriots.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Titans releasing veteran G Kline');return false;"><span class="op-btn">Read More</span> <span class="count">16 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Ftitans-releasing-veteran-g-kline%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Titans releasing veteran G Kline+https://nationalfootballpost.com/?p=110844" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Titans releasing veteran G Kline&#32;&#32;https://nationalfootballpost.com/?p=110844" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110844"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/pats-to-release-de-clayborn-clear-4m-in-cap-space/" rel="bookmark" title="Pats to release DE Clayborn, clear $4M in cap space">Pats to release DE Clayborn, clear $4M in cap space</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/pats-to-release-de-clayborn-clear-4m-in-cap-space/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Pats to release DE Clayborn, clear $4M in cap space</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/12104933.jpg" width="1100" height="733" alt="" title="Feb 3, 2019; Atlanta, GA, USA; Los Angeles Rams quarterback Jared Goff (16) prepares to pass as New England Patriots defensive end Adrian Clayborn (94) closes in during the first quarter in Super Bowl LIII at Mercedes-Benz Stadium. Mandatory Credit:</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Pats to release DE Clayborn, clear $4M in cap space</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/12104933.jpg" width="1100" height="733" alt="" title="Feb 3, 2019; Atlanta, GA, USA; Los Angeles Rams quarterback Jared Goff (16) prepares to pass as New England Patriots defensive end Adrian Clayborn (94) closes in during the first quarter in Super Bowl LIII at Mercedes-Benz Stadium. Mandatory Credit: Robert Deutsch-USA TODAY Sports" data-portal-copyright="Robert Deutsch-USA TODAY Sports" /></p><p>
New England is releasing defensive end Adrian Clayborn, a move that clears about $4 million in cap space for the defending champion Patriots.
</p>
</p><p>
Clayborn, 30, broke the news Friday morning on Twitter and thanked the Patriots for granting his release.
</p>
</p><p>
&#8220;I&#8217;m ready for this next chapter,&#8221; he said.
</p>
</p>
</p><p>
Clayborn was due to count $5.94 million against the cap and New England will have $2 million in dead money with this move.
</p>
</p><p>
Clayborn, who signed a two-year, $12 million deal with the Patriots last March, tallied 11 tackles, 2.5 sacks and a forced fumble in 14 games in 2018.
</p>
</p><p>
Tampa Bay&#8217;s first-round pick in 2011, Clayborn played four seasons with the Buccaneers and three with the Atlanta Falcons before joining New England.
</p>
</p><p>
In 95 career games, he has 32.5 sacks, 178 tackles and eight forced fumbles.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Pats to release DE Clayborn, clear $4M in cap space');return false;"><span class="op-btn">Read More</span> <span class="count">75 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpats-to-release-de-clayborn-clear-4m-in-cap-space%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Pats to release DE Clayborn, clear $4M in cap space+https://nationalfootballpost.com/?p=110839" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Pats to release DE Clayborn, clear $4M in cap space&#32;&#32;https://nationalfootballpost.com/?p=110839" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110839"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/reports-bengals-signing-g-miller-for-3-years-16-5m/" rel="bookmark" title="Reports: Bengals signing G Miller for 3 years, $16.5M">Reports: Bengals signing G Miller for 3 years, $16.5M</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/reports-bengals-signing-g-miller-for-3-years-16-5m/" /><meta itemprop="datePublished" content="13 mins ago" /><meta itemprop="dateModified" content="13 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/" /><meta itemprop="name" content="National Football Post" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Reports: Bengals signing G Miller for 3 years, $16.5M</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11917617.jpg" width="1100" height="789" alt="" title="Dec 16, 2018; Orchard Park, NY, USA; Buffalo Bills offensive guard John Miller (76) warms up prior to a game against the Detroit Lions at New Era Field. Mandatory Credit: Mark Konezny-USA TODAY Sports" data-portal-copyright="Mark Konezny-USA TODAY Sports" /></p> <p> The</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Reports: Bengals signing G Miller for 3 years, $16.5M</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/08/11917617.jpg" width="1100" height="789" alt="" title="Dec 16, 2018; Orchard Park, NY, USA; Buffalo Bills offensive guard John Miller (76) warms up prior to a game against the Detroit Lions at New Era Field. Mandatory Credit: Mark Konezny-USA TODAY Sports" data-portal-copyright="Mark Konezny-USA TODAY Sports" /></p><p>
The Cincinnati Bengals are signing free agent guard John Miller to a three-year, $16.5 million contract, according to multiple reports Friday.
</p>
</p><p>
Miller, 25, was Buffalo&#8217;s third-round pick in 2015 and started 47 games at right guard for the Bills over the past four seasons.
</p>
</p><p>
Miller ranked fourth on the Bills with 883 offensive snaps in 15 starts last season.
</p>
</p><p>
Miller visited Thursday with the Bengals. He will be reunited on the offensive line with former Buffalo teammate Cordy Glenn, a tackle who joined Cincinnati in a trade last March.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Reports: Bengals signing G Miller for 3 years, $16.5M');return false;"><span class="op-btn">Read More</span> <span class="count">34 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freports-bengals-signing-g-miller-for-3-years-16-5m%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Reports: Bengals signing G Miller for 3 years, $16.5M+https://nationalfootballpost.com/?p=110834" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Reports: Bengals signing G Miller for 3 years, $16.5M&#32;&#32;https://nationalfootballpost.com/?p=110834" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=110834"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				</div>
			    

				<div class="fl-comments">

	
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/raiders-release-wr-nelson-qb-mccarron/#respond" style="display:none;">Cancel Reply</a></small></h3>			<form action="https://nationalfootballpost.com/wp-comments-post.php?wpe-comment-post=footballpost" method="post" id="fl-comment-form" class="fl-comment-form">
				<label for="comment">Comment</label>
									<textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea><br /><label for="author">Name</label>
									<input type="text" name="author" class="form-control" value="" tabindex="1" /><br />
<label for="email">Email (will not be published)</label>
									<input type="text" name="email" class="form-control" value="" tabindex="2" /><br />
<label for="url">Website</label>
									<input type="text" name="url" class="form-control" value="" tabindex="3" /><br />
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="fl-comment-form-submit" class="btn btn-primary" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='110914' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="f26b10f870" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="222"/></p>			</form>
			</div><!-- #respond -->
		</div>

				<!-- .fl-post -->
								<!-- .fl-post -->
				<script src="https://cdnjs.cloudflare.com/ajax/libs/clipboard.js/1.5.10/clipboard.min.js"></script>
				<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>
				<script>
				// Tooltip
				jQuery(function($){
				   $('button').tooltip({
                   trigger: 'click',
                   placement: 'bottom'
                   });
				   
				   function setTooltip(btn, message) {
				   $(btn).tooltip('hide')
				   .attr('data-original-title', message)
				   .tooltip('show');
				   }
				   
				   function hideTooltip(btn) {
				   setTimeout(function() {
		              $(btn).tooltip('hide');
		              }, 1000);
				   }
				   
				   // Clipboard
				   
				   var clipboard = new Clipboard('button');
				   
				   clipboard.on('success', function(e) {
	                setTooltip(e.trigger, 'Link copied to clipboard');
	                hideTooltip(e.trigger);
	                });
				   
				   clipboard.on('error', function(e) {
	                setTooltip(e.trigger, 'Failed!');
	                hideTooltip(e.trigger);
	                });
				   });
				</script>


			  
			
					</div>
		
				
	</div>
</div>


	</div><!-- .fl-page-content -->
		</div><!-- .fl-page -->
<a href="#" id="fl-to-top"><i class="fa fa-chevron-up"></i></a><style type="text/css">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</style><script type='text/javascript' src='https://nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/js/datatables/datatables.min.js?ver=1.10.16'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var posts_table_params = {"ajax_url":"https:\/\/nationalfootballpost.com\/wp-admin\/admin-ajax.php","ajax_nonce":"aa9be0b23b","wrapper_class":"posts-table-wrapper bb-theme","language":{"info":"Showing _START_ to _END_ of _TOTAL_ entries","infoEmpty":"Showing 0 entries","infoFiltered":"(_MAX_ entries in total)","lengthMenu":"Show _MENU_ entries","emptyTable":"No data available in table.","zeroRecords":"No matching records found.","search":"Search:","paginate":{"first":"First","last":"Last","next":"Next","previous":"Previous"},"thousands":",","decimal":".","aria":{"sortAscending":": activate to sort column ascending","sortDescending":": activate to sort column descending"},"filterBy":"Filter:","resetButton":"Reset"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/js/posts-table-pro.min.js?ver=2.0.3'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme/js/jquery.throttle.min.js?ver=1.6.5.1'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme/js/jquery.magnificpopup.min.js?ver=1.6.5.1'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme/js/jquery.fitvids.js?ver=1.6.5.1'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme/js/bootstrap.min.js?ver=1.6.5.1'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme/js/theme.min.js?ver=1.6.5.1'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script>
<script async="async" type='text/javascript' src='https://nationalfootballpost.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>

    <!-- BEGIN: wpflow ga events array -->
    <script>

                jQuery(document).ready(function() {
                    if(typeof scroll_events == 'undefined') {
                        return;
                    }
                    scroll_events.bind_events( {
                        universal: 1,
                        gtm:0,
                        gst:0,

                        scroll_elements: [],
                        click_elements: [],
                    });
                });

    </script>
    <!-- END: wpflow ga events array --></body>
</html>
