<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8"/>
<meta name='viewport' content='width=device-width, initial-scale=1.0'/>
<meta http-equiv='X-UA-Compatible' content='IE=edge'/>
<link rel="profile" href="https://gmpg.org/xfn/11"/>
<link rel="pingback" href="https://nationalfootballpost.com/xmlrpc.php"/>
<title>NFL notebook: QB Murray, 22 others to attend draft - National Football Post</title>
<link rel="canonical" href="https://nationalfootballpost.com/nfl-notebook-qb-murray-22-others-to-attend-draft/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="NFL notebook: QB Murray, 22 others to attend draft - National Football Post"/>
<meta property="og:description" content="NFL notebook: QB Murray, 22 others to attend draft Oklahoma quarterback Kyler Murray will be in Nashville on April 25 for the first round of the NFL draft. Where he goes from there remains to be seen. Murray is one of 23 prospects who plan to attend the draft later this month, the NFL announced&hellip;"/>
<meta property="og:url" content="https://nationalfootballpost.com/nfl-notebook-qb-murray-22-others-to-attend-draft/"/>
<meta property="og:site_name" content="National Football Post"/>
<meta property="article:publisher" content="http://facebook.com/nationalfootballpost"/>
<meta property="article:tag" content="FLM"/>
<meta property="article:section" content="NFL and College Football Articles"/>
<meta property="article:published_time" content="2019-04-10T03:38:33+00:00"/>
<meta property="article:modified_time" content="2019-04-10T03:38:35+00:00"/>
<meta property="og:updated_time" content="2019-04-10T03:38:35+00:00"/>
<meta property="og:image" content="https://nationalfootballpost.com/wp-content/uploads/2019/04/12268222-1.jpg"/>
<meta property="og:image:secure_url" content="https://nationalfootballpost.com/wp-content/uploads/2019/04/12268222-1.jpg"/>
<meta property="og:image:width" content="1100"/>
<meta property="og:image:height" content="733"/>
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="National Football Post &raquo; Feed" href="https://nationalfootballpost.com/feed/"/>
<link rel="stylesheet" type="text/css" href="//nationalfootballpost.com/wp-content/cache/wpfc-minified/2m79n2i1/8e5lw.css" media="all"/>
<link rel='https://api.w.org/' href='https://nationalfootballpost.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nationalfootballpost.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nationalfootballpost.com/wp-includes/wlwmanifest.xml"/> 
<link rel='shortlink' href='https://nfp.news/12ro'/>
<link rel="alternate" type="application/json+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-notebook-qb-murray-22-others-to-attend-draft%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-notebook-qb-murray-22-others-to-attend-draft%2F&#038;format=xml"/>
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','https://www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-5166086-1', 'auto'); ga('send', 'pageview');</script>
<meta name="generator" content="Feed to Post 3.7.5"/>
<link rel="canonical" href="https://footballpost.wpengine.com/newsml/fieldlevelmedia_str_20190410T013756_0800_000035805_1.xml"/><style>.saboxplugin-wrap .saboxplugin-gravatar img{-webkit-border-radius:50%;-moz-border-radius:50%;-ms-border-radius:50%;-o-border-radius:50%;border-radius:50%;}
.saboxplugin-wrap .saboxplugin-authorname a{color:#212121;}
.saboxplugin-wrap .saboxplugin-authorname{font-family:"Roboto Condensed";}
.saboxplugin-wrap .saboxplugin-desc{font-family:Roboto Condensed;}
.saboxplugin-wrap .saboxplugin-desc{font-style:italic;}
.saboxplugin-wrap{margin-top:20px;margin-bottom:10px;padding:5px 5px}
.saboxplugin-wrap .saboxplugin-authorname{font-size:20px;line-height:27px;}
.saboxplugin-wrap .saboxplugin-desc p, .saboxplugin-wrap .saboxplugin-desc{font-size:16px !important;line-height:23px !important;}
.saboxplugin-wrap .saboxplugin-web{font-size:14px;}
.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa:before{font-size:18px;}
.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa{width:36px;height:36px;line-height:36px;}</style><link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-32x32.jpg" sizes="32x32"/>
<link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-192x192.jpg" sizes="192x192"/>
<link rel="apple-touch-icon-precomposed" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-180x180.jpg"/>
<meta name="msapplication-TileImage" content="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-270x270.jpg"/>
<style id="wp-custom-css">.fl-post-cats-tags{padding:0px 0px 0px 0px;border-bottom:4px solid #e6e6e6}
.share-social{border-bottom:4px solid #e6e6e6}
.container{max-width:93%}
.fl-sidebar-left{padding-right:2%;padding-left:0px;}
.fl-post-cats-tags a, .share-social a{text-transform:uppercase;color:#000;font-size:18px;font-weight:600;font-style:normal;}
.fl-archive .fl-post{border-bottom:0px;}
div.share-social{letter-spacing:7px;float:right;padding-top:10px;}
.custom-html-widget li a{font-size:16px;color:#555;font-style:normal;display:block;padding-bottom:4px;font-weight:600;text-transform:uppercase;}
.custom-html-widget li{font-size:14px;color:#7b7b7b;font-style:italic;font-weight:500;text-transform:uppercase;padding-bottom:6px;border-bottom:2px solid #e6e6e6}
.fl-widget-title{border-style:solid;border-width:4px 0px 4px 0px;text-align:center;padding:5px}
.fl-post-title{margin-bottom:0px;}
.fl-post-author{text-transform:uppercase;font-style:italic;font-weight:600;font-size:18px;}
.tooltip-inner{letter-spacing:1px;}
.fl-post-meta-bottom{border-top:none;font-style:italic;margin-top:0;padding-top:10px;float:left;}
.btn-primary{border:none !important;background:0 0 !important;;color:#000 !important;;box-shadow:none !important;;padding:0 !important;;margin-bottom:5px !important;;}
.toptitle h1{font-size:22px;margin-top:5px;margin-bottom:5px;list-style:none;margin:0;padding:0;line-height:40px;width:50%;position:relative;left:25%;margin:0 px;padding:0 px;border:1px solid #AAA;color:white;background:#050505;border-bottom-left-radius:10px;border-bottom-right-radius:10px;font-style:italic;}
.fl-archive .fl-archive-title{display:none;}
.rp4wp-related-post-content{font-size:18px;color:#555;font-style:italic;display:block;font-weight:800;text-transform:uppercase;}</style>
<script data-wpfc-render="false">var Wpfcll={s:[],i:function(){Wpfcll.ss();window.addEventListener('load',function(){window.addEventListener("DOMSubtreeModified",function(e){Wpfcll.ss();Wpfcll.ls(false);},false);Wpfcll.ls(true);});window.addEventListener('scroll',function(){Wpfcll.ls(false);});window.addEventListener('resize',function(){Wpfcll.ls(false);});window.addEventListener('click',function(){Wpfcll.ls(false);});},c:function(e,pageload){var w=document.documentElement.clientHeight || body.clientHeight;var n=pageload ? 0:800;var er=e.getBoundingClientRect();var t=0;var p=e.parentNode;var pr=p.getBoundingClientRect();if(er.x==0 && er.y==0){for(var i=0;i < 10;i++){if(p){if(pr.x==0 && pr.y==0){p=p.parentNode;pr=p.getBoundingClientRect();}else{t=pr.top;break;}}};}else{t=er.top;}if(w - t+n > 0){return true;}return false;},r:function(e,pageload){var s=this;var oc,ot;try{if(s.c(e,pageload)){oc=e.getAttribute("data-wpfc-original-src");ot=e.getAttribute("data-wpfc-original-srcset");if(oc || ot){if(oc){e.setAttribute('src',oc);}if(ot){e.setAttribute('srcset',ot);}e.removeAttribute("data-wpfc-original-src");e.removeAttribute("onload");if(e.tagName=="IFRAME"){e.onload=function(){var s=e.getAttribute("src").match(/templates\/youtube\.html\#(.+)/);var y="https://www.youtube.com/embed/";if(s){try{var i=e.contentDocument || e.contentWindow;if(i.location.href=="about:blank"){e.setAttribute('src',y+s[1]);}}catch(err){e.setAttribute('src',y+s[1]);}}}}}}}catch(error){console.log(error);console.log("==>",e);}},ss:function(){var i=Array.prototype.slice.call(document.getElementsByTagName("img"));var f=Array.prototype.slice.call(document.getElementsByTagName("iframe"));this.s=i.concat(f);},ls:function(pageload){var s=this;[].forEach.call(s.s,function(e,index){s.r(e,pageload);});}};document.addEventListener('DOMContentLoaded',function(){wpfci();});function wpfci(){Wpfcll.i();}</script>
</head>
<body class="post-template-default single single-post postid-103906 single-format-standard fl-preset-default fl-fixed-width fl-scroll-to-top fl-search-active" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="fl-page"> <header class="fl-page-header fl-page-header-fixed fl-page-nav-right fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="fl-page-logo-wrap col-md-3 col-sm-12"> <div class="fl-page-header-logo"> <a href="https://nationalfootballpost.com/"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post"/><meta itemprop="name" content="National Football Post"/></a></div></div><div class="fl-page-fixed-nav-wrap col-md-9 col-sm-12"> <div class="fl-page-nav-wrap"> <nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span><i class="fa fa-bars"></i></span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-top-nav" class="nav navbar-nav navbar-right menu"><li id="menu-item-78448" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a> <ul class="sub-menu"> <li id="menu-item-94464" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li> <li id="menu-item-94463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li> </ul> </li> <li id="menu-item-80343" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a> <ul class="sub-menu"> <li id="menu-item-88321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li> <li id="menu-item-80344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li> <li id="menu-item-78452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li> </ul> </li> <li id="menu-item-78387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a> <ul class="sub-menu"> <li id="menu-item-84427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li> <li id="menu-item-84236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li> </ul> </li> <li id="menu-item-78499" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a> <ul class="sub-menu"> <li id="menu-item-78502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li> <li id="menu-item-78500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li> <li id="menu-item-80079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li> </ul> </li> </ul></div></nav></div></div></div></div></div></header>
<header class="fl-page-header fl-page-header-primary fl-page-nav-centered fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-12 fl-page-header-logo-col"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="https://schema.org/Organization"> <a href="https://nationalfootballpost.com/" itemprop="url"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post"/><meta itemprop="name" content="National Football Post"/></a></div></div></div></div></div><div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span><i class="fa fa-bars"></i></span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-top-nav-1" class="nav navbar-nav menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li> </ul> </li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li> </ul> </li> </ul><div class="fl-page-nav-search"> <a href="javascript:void(0);" class="fa fa-search"></a> <form method="get" role="search" action="https://nationalfootballpost.com/" title="Type and press Enter to search."> <input type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" /> </form></div></div></nav></div></div></header>
<div class="fl-page-content" itemprop="mainContentOfPage"> <div class="fl-archive container"> <div class="row"> <div class="fl-sidebar fl-sidebar-left fl-sidebar-display-desktop col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"> <aside id="custom_html-3" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">RECENT</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/oklahoma-qb-murray-plans-to-attend-draft/" title="Oklahoma QB Murray plans to attend draft">Oklahoma QB Murray plans to attend draft</a> 1 min ago </li><li ><a href="https://nationalfootballpost.com/nfl-nflpa-commit-to-regular-meetings-on-new-cba/" title="NFL, NFLPA commit to regular meetings on new CBA">NFL, NFLPA commit to regular meetings on new CBA</a> 1 min ago </li><li ><a href="https://nationalfootballpost.com/nfl-notebook-qb-murray-22-others-to-attend-draft/" title="NFL notebook: QB Murray, 22 others to attend draft">NFL notebook: QB Murray, 22 others to attend draft</a> 1 min ago </li><li ><a href="https://nationalfootballpost.com/report-patriots-agree-to-two-year-deal-with-gostkowski/" title="Report: Patriots agree to two-year deal with Gostkowski">Report: Patriots agree to two-year deal with Gostkowski</a> 4 hours ago </li><li ><a href="https://nationalfootballpost.com/falcons-bring-back-veteran-de-clayborn/" title="Falcons bring back veteran DE Clayborn">Falcons bring back veteran DE Clayborn</a> 7 hours ago </li><li ><a href="https://nationalfootballpost.com/aaron-rodgers-i-lost-vision-after-week-17-concussion/" title="Aaron Rodgers: ‘I lost vision’ after Week 17 concussion">Aaron Rodgers: ‘I lost vision’ after Week 17 concussion</a> 7 hours ago </li><li ><a href="https://nationalfootballpost.com/2019-masters-rating-the-rookies/" title="2019 Masters: Rating the Rookies">2019 Masters: Rating the Rookies</a> 7 hours ago </li><li ><a href="https://nationalfootballpost.com/nfl-releases-2019-preseason-schedule/" title="NFL releases 2019 preseason schedule">NFL releases 2019 preseason schedule</a> 7 hours ago </li><li ><a href="https://nationalfootballpost.com/report-murray-meeting-again-with-cardinals/" title="Report: Murray meeting again with Cardinals">Report: Murray meeting again with Cardinals</a> 10 hours ago </li><li ><a href="https://nationalfootballpost.com/eagles-sign-three-ex-aaf-players-to-1-year-contracts/" title="Eagles sign three ex-AAF players to 1-year contracts">Eagles sign three ex-AAF players to 1-year contracts</a> 10 hours ago </li></ul></div></aside><aside id="custom_html-7" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">FEATURES</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/super-bowl-53-betting-preview/" title="Super Bowl 53 Betting Preview – Best Props Picks, Trends">Super Bowl 53 Betting Preview – Best Props Picks, Trends</a> February 3, 2019 </li><li ><a href="https://nationalfootballpost.com/report-brady-defiantly-denies-retirement-question/" title="Report: Brady defiantly denies retirement question">Report: Brady defiantly denies retirement question</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/rams-cooks-responds-to-pats-chung-dig-in-fan-rally/" title="Rams&#8217; Cooks responds to Pats&#8217; Chung dig in fan rally">Rams&#8217; Cooks responds to Pats&#8217; Chung dig in fan rally</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/huge-crowd-sends-patriots-off-to-super-bowl/" title="Huge crowd sends Patriots off to Super Bowl">Huge crowd sends Patriots off to Super Bowl</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/rams-k-zuerlein-optimistic-strained-foot-will-be-good-to-go/" title="Rams K Zuerlein optimistic strained foot will be ‘good to go’">Rams K Zuerlein optimistic strained foot will be ‘good to go’</a> January 27, 2019 </li></ul></div></aside></div><div class="fl-content fl-content-right col-md-9" itemscope="itemscope" itemtype="https://schema.org/Blog"> <article class="fl-post post-103906 post type-post status-publish format-standard hentry category-news tag-flm" id="fl-post-103906" itemscope itemtype="https://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> NFL notebook: QB Murray, 22 others to attend draft </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-notebook-qb-murray-22-others-to-attend-draft/"/><meta itemprop="datePublished" content="1 min ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" itemprop="text"> <h2><title>NFL notebook: QB Murray, 22 others to attend draft</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12268222-1.jpg" width="1100" height="733" alt="" title="Mar 2, 2019; Indianapolis, IN, USA; Oklahoma quarterback Kyler Murray (QB11) who did not participate in workout drills watches from the sidelines during the 2019 NFL Combine at Lucas Oil Stadium. Mandatory Credit: Brian Spurlock-USA TODAY Sports" data-portal-copyright="Brian Spurlock-USA TODAY Sports"></p><p> Oklahoma quarterback Kyler Murray will be in Nashville on April 25 for the first round of the NFL draft. Where he goes from there remains to be seen. </p> </p><p> Murray is one of 23 prospects who plan to attend the draft later this month, the NFL announced Tuesday. He stands a chance to be one of the top picks, if not the No. 1 overall selection, after passing for 4,361 yards, 42 touchdowns and seven interceptions in 2018. </p> </p><p> Quarterbacks Daniel Jones of Duke and Drew Lock of Missouri also plan to be at the draft, while another top quarterback, Dwayne Haskins of Ohio State, will not be there. The other 20 players include six defensive linemen, four offensive linemen, three linebackers, two defensive backs, two wide receivers, two tight ends and a running back. </p> </p><p> Murray reportedly headed to Phoenix on Tuesday for another meeting with the Arizona Cardinals, who hold the No. 1 overall draft pick. </p> </p><p> &#8211;The NFL and NFL Players Association announced they will take part in regularly scheduled meetings to discuss a new collective bargaining agreement. </p> </p><p> The NFL and NFLPA issued the following statement: &#8220;Today, the members of the NFL&#8217;s Management Council and the NFLPA&#8217;s Executive Committee met to discuss negotiations for a new collective bargaining agreement. The League and the Union have committed to meet regularly in the coming months, which will involve staff, NFL leadership, members of the NFLPA Executive Committee and Player Representation.&#8221; </p> </p><p> The league and its players most recently agreed upon a collective bargaining agreement in 2011. The deal, which was reached after a player lockout, runs through the end of the 2020 season. Both sides hope that starting negotiations early may help to avoid a work stoppage after the end of next season. </p> </p><p> &#8211;The New England Patriots and kicker Stephen Gostkowski agreed to a two-year contract, ESPN reported. </p> </p><p> Gostkowski, 35, has been the club&#8217;s kicker since 2006. He replaced Adam Vinatieri, who had departed to the Indianapolis Colts as a free agent. </p> </p><p> Gostkowski, a four-time Pro Bowl selection, has made 367 of 420 field-goal attempts during 13 seasons with New England. He was 27 of 32 last season. </p> </p><p> &#8211;The NFL released the 65-game 2019 preseason schedule, kicking off with the Hall of Fame game between the Denver Broncos and Atlanta Falcons on Aug. 1 in Canton, Ohio. </p> </p><p> Other highlights include the Dallas Cowboys facing the Los Angeles Rams in Honolulu on Aug. 17, the NFL&#8217;s first preseason contest at Aloha Stadium since 1976. </p> </p><p> The Super Bowl LIII champion New England Patriots will square off against the New York Giants in the preseason finale for the 15th straight season. </p> </p><p> &#8211;The Atlanta Falcons signed veteran defensive end Adrian Clayborn to a one-year deal, the team announced. Official terms were not disclosed, but multiple outlets reported that he could earn up to $4 million with incentives. </p> </p><p> Clayborn, who played for the Falcons from 2015-17, appeared in 14 games for the Super Bowl champion New England Patriots last season and tallied 2.5 sacks. </p> </p><p> Clayborn, 30, has registered 32.5 career sacks and 90 quarterback hits in 95 games (51 starts) with the Tampa Bay Buccaneers, Falcons and Patriots. </p> </p><p> &#8211;Green Bay Packers quarterback Aaron Rodgers said in an interview with ESPN Milwaukee that he &#8220;lost vision&#8221; after sustaining a concussion in the final game of last season. </p> </p><p> Rodgers also went into detail about the knee injury he sustained in Week 1 and then aggravated in Week 5. Rodgers left the Week 1 game against the Chicago Bears but returned to engineer the 20-point comeback victory. </p> </p><p> &#8220;I had a tibial plateau fracture and obviously an MCL sprain,&#8221; Rodgers told ESPN, &#8220;so that was very painful. If you watch the hit back, just my two bones here that come together on the outside just kind of made an indent fracture. Very painful.&#8221; </p> </p><p> &#8211;The Philadelphia Eagles announced the signing of three former Alliance of American Football players to one-year contracts. </p> </p><p> Quarterback Luis Perez and wide receivers Charles Johnson and Greg Ward became available when the AAF ceased operations last week, just eight weeks into its inaugural season. </p> </p><p> &#8211;Field Level Media</p></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-notebook-qb-murray-22-others-to-attend-draft%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL notebook: QB Murray, 22 others to attend draft+http://nfp.news/12ro" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL notebook: QB Murray, 22 others to attend draft&#32;&#32;http://nfp.news/12ro" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12ro"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<div class="related-post"> <article style="overflow: hidden;margin-bottom: 30px;"> <header class="fl-post-header"> <h2 class="fl-post-title" itemprop="headline"> <a href="https://nationalfootballpost.com/oklahoma-qb-murray-plans-to-attend-draft/" rel="bookmark" title="Oklahoma QB Murray plans to attend draft">Oklahoma QB Murray plans to attend draft</a> </h2> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/oklahoma-qb-murray-plans-to-attend-draft/"/><meta itemprop="datePublished" content="1 min ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Oklahoma QB Murray plans to attend draft</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12338271.jpg" width="1100" height="733" alt="" title="Mar 13, 2019; Norman, OK, USA; Oklahoma quarterback Kyler Murray participates in positional workouts during pro day at the Everest Indoor Training Center at the University of Oklahoma. Mandatory Credit: Jerome Miron-USA TODAY Sports" data-portal-copyright="Jerome Miron-USA TODAY Sports"/></p> <p> Oklahoma quarterback Kyler</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Oklahoma QB Murray plans to attend draft</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12338271.jpg" width="1100" height="733" alt="" title="Mar 13, 2019; Norman, OK, USA; Oklahoma quarterback Kyler Murray participates in positional workouts during pro day at the Everest Indoor Training Center at the University of Oklahoma. Mandatory Credit: Jerome Miron-USA TODAY Sports" data-portal-copyright="Jerome Miron-USA TODAY Sports"></p><p> Oklahoma quarterback Kyler Murray knows he will be in Nashville on April 25 for the first round of the NFL draft. </p> </p><p> As for where Murray will go from there, he still can&#8217;t say for sure. </p> </p><p> Murray is one of 23 prospects who plan to be in attendance for the draft later this month, the NFL announced Tuesday. He stands a chance to be one of the top picks, if not the No. 1 overall selection, after passing for 4,361 yards, 42 touchdowns and seven interceptions in 2018. </p> </p><p> Quarterbacks Daniel Jones of Duke and Drew Lock of Missouri also plan to be at the draft. The other 20 players include six defensive linemen, four offensive linemen, three linebackers, two defensive backs, two wide receivers, two tight ends and a running back. </p> </p><p> Another top quarterback &#8212; Ohio State&#8217;s Dwayne Haskins &#8212; is not scheduled to attend. </p> </p><p> Here is the alphabetical list of participants, according to NFL.com: </p> </p><p> 1. Josh Allen, DE, Kentucky </p><p> 2. Deandre Baker, DB, Georgia </p><p> 3. Nick Bosa, DE, Ohio State </p><p> 4. Marquise Brown, WR, Oklahoma </p><p> 5. Brian Burns, DE, Florida State </p><p> 6. Devin Bush, LB, Michigan </p><p> 7. Andre Dillard, OT, Washington State </p><p> 8. Noah Fant, TE, Iowa </p><p> 9. Cody Ford, OT, Oklahoma </p><p> 10. T.J. Hockenson, TE, Iowa </p><p> 11. Josh Jacobs, RB, Alabama </p><p> 12. Daniel Jones, QB, Duke </p><p> 13. Drew Lock, QB, Missouri </p><p> 14. D.K. Metcalf, WR, Ole Miss </p><p> 15. Kyler Murray, QB, Oklahoma </p><p> 16. Ed Oliver, DT, Houston </p><p> 17. Montez Sweat, DE, Mississippi State </p><p> 18. Jawaan Taylor, OT, Florida </p><p> 19. Devin White, LB, LSU </p><p> 20. Christian Wilkins, DT, Clemson </p><p> 21. Greedy Williams, DB, LSU </p><p> 22. Jonah Williams, OT, Alabama </p><p> 23. Quinnen Williams, DT, Alabama </p> </p><p> The Arizona Cardinals have the top pick in this year&#8217;s draft. The San Francisco 49ers will select second and New York Jets third. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Oklahoma QB Murray plans to attend draft');return false;"><span class="op-btn">Read More</span> <span class="count">220 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Foklahoma-qb-murray-plans-to-attend-draft%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Oklahoma QB Murray plans to attend draft+http://nfp.news/12rm" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Oklahoma QB Murray plans to attend draft&#32;&#32;http://nfp.news/12rm" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12rm"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/nfl-nflpa-commit-to-regular-meetings-on-new-cba/" rel="bookmark" title="NFL, NFLPA commit to regular meetings on new CBA">NFL, NFLPA commit to regular meetings on new CBA</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-nflpa-commit-to-regular-meetings-on-new-cba/"/><meta itemprop="datePublished" content="1 min ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>NFL, NFLPA commit to regular meetings on new CBA</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12085676.jpg" width="1100" height="732" alt="" title="Jan 31, 2019; Atlanta, GA, USA; NFLPA executive director DeMaurice Smith speaks during the NFLPA press conference in advance of the Super Bowl LIII where the New England Patriots will play the Los Angeles Rams on Feb. 3, 2019 at Mercedes_Benz</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>NFL, NFLPA commit to regular meetings on new CBA</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12085676.jpg" width="1100" height="732" alt="" title="Jan 31, 2019; Atlanta, GA, USA; NFLPA executive director DeMaurice Smith speaks during the NFLPA press conference in advance of the Super Bowl LIII where the New England Patriots will play the Los Angeles Rams on Feb. 3, 2019 at Mercedes_Benz Stadium. Mandatory Credit: John David Mercer-USA TODAY Sports" data-portal-copyright="John David Mercer-USA TODAY Sports"></p><p> The NFL and NFL Players Association announced Tuesday that they will take part in regularly scheduled meetings to discuss a new collective bargaining agreement. </p> </p><p> The NFL and NFLPA issued the following statement: &#8220;Today, the members of the NFL&#8217;s Management Council and the NFLPA&#8217;s Executive Committee met to discuss negotiations for a new collective bargaining agreement. The League and the Union have committed to meet regularly in the coming months, which will involve staff, NFL leadership, members of the NFLPA Executive Committee and Player Representation.&#8221; </p> </p><p> The league and its players most recently agreed upon a collective bargaining agreement in 2011. The deal, which was reached after a player lockout, runs through the end of the 2020 season. </p> </p><p> Both sides hope that starting negotiations early may help to avoid a work stoppage after the end of next season. </p> </p><p> Dallas Cowboys owner Jerry Jones was among those in attendance for Tuesday&#8217;s meeting, according to NFL.com. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','NFL, NFLPA commit to regular meetings on new CBA');return false;"><span class="op-btn">Read More</span> <span class="count">103 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-nflpa-commit-to-regular-meetings-on-new-cba%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL, NFLPA commit to regular meetings on new CBA+http://nfp.news/12rn" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL, NFLPA commit to regular meetings on new CBA&#32;&#32;http://nfp.news/12rn" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12rn"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/report-patriots-agree-to-two-year-deal-with-gostkowski/" rel="bookmark" title="Report: Patriots agree to two-year deal with Gostkowski">Report: Patriots agree to two-year deal with Gostkowski</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-patriots-agree-to-two-year-deal-with-gostkowski/"/><meta itemprop="datePublished" content="4 hours ago"/><meta itemprop="dateModified" content="4 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Report: Patriots agree to two-year deal with Gostkowski</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12182681.jpg" width="1100" height="729" alt="" title="Feb 3, 2019; Atlanta, GA, USA; New England Patriots kicker Stephen Gostkowski (3) kicks during the game against the Los Angeles Rams in Super Bowl LIII at Mercedes-Benz Stadium. Mandatory Credit: Kevin Jairaj-USA TODAY Sports" data-portal-copyright="Kevin Jairaj-USA TODAY Sports"/></p> <p> The</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Report: Patriots agree to two-year deal with Gostkowski</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12182681.jpg" width="1100" height="729" alt="" title="Feb 3, 2019; Atlanta, GA, USA; New England Patriots kicker Stephen Gostkowski (3) kicks during the game against the Los Angeles Rams in Super Bowl LIII at Mercedes-Benz Stadium. Mandatory Credit: Kevin Jairaj-USA TODAY Sports" data-portal-copyright="Kevin Jairaj-USA TODAY Sports"></p><p> The New England Patriots and kicker Stephen Gostkowski have agreed to a two-year contract, ESPN reported Tuesday. </p> </p><p> The 35-year-old Gostkowski has been the club&#8217;s kicker since 2006. He replaced Adam Vinatieri, who had departed to the Indianapolis Colts as a free agent. </p> </p><p> Gostkowski, a four-time Pro Bowl selectio, has made 367 of 420 field-goal attempts during 13 seasons with New England. He was 27 of 32 last season. </p> </p><p> Gostkowski has 1,743 career points, and has led the NFL in scoring on five occasions. He has topped 140 points in a season seven times. </p> </p><p> He is 39 of 44 on field goals in 28 postseason appearances. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Report: Patriots agree to two-year deal with Gostkowski');return false;"><span class="op-btn">Read More</span> <span class="count">45 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-patriots-agree-to-two-year-deal-with-gostkowski%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Patriots agree to two-year deal with Gostkowski+http://nfp.news/12ra" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Patriots agree to two-year deal with Gostkowski&#32;&#32;http://nfp.news/12ra" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12ra"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/falcons-bring-back-veteran-de-clayborn/" rel="bookmark" title="Falcons bring back veteran DE Clayborn">Falcons bring back veteran DE Clayborn</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/falcons-bring-back-veteran-de-clayborn/"/><meta itemprop="datePublished" content="7 hours ago"/><meta itemprop="dateModified" content="7 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Falcons bring back veteran DE Clayborn</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/10465531-1.jpg" width="1100" height="733" alt="" title="Dec 7, 2017; Atlanta, GA, USA; Atlanta Falcons defensive end Adrian Clayborn (99) reacts after a sack against the New Orleans Saints in the fourth quarter at Mercedes-Benz Stadium. Mandatory Credit: Brett Davis-USA TODAY Sports" data-portal-copyright="Brett Davis-USA TODAY Sports"/></p> <p> The Atlanta Falcons</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Falcons bring back veteran DE Clayborn</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/10465531-1.jpg" width="1100" height="733" alt="" title="Dec 7, 2017; Atlanta, GA, USA; Atlanta Falcons defensive end Adrian Clayborn (99) reacts after a sack against the New Orleans Saints in the fourth quarter at Mercedes-Benz Stadium. Mandatory Credit: Brett Davis-USA TODAY Sports" data-portal-copyright="Brett Davis-USA TODAY Sports"></p><p> The Atlanta Falcons have signed veteran defensive end Adrian Clayborn to a one-year deal, the team announced Tuesday. </p> </p><p> Official terms were not disclosed, but multiple outlets reported that he could earn up to $4 million with incentives. </p> </p><p> Clayborn, who played for the Falcons from 2015-17, appeared in 14 games for the Super Bowl champion New England Patriots last season and tallied 2.5 sacks. </p> </p><p> &#8220;I&#8217;m excited to be back and help this defense and team anyway I can,&#8221; he told NFL Network. &#8220;It&#8217;s familiar here and I know I fit into the defense well. At this point that&#8217;s what&#8217;s most important.&#8221; </p> </p><p> Clayborn, 30, has registered 32.5 career sacks and 90 quarterback hits in 95 games (51 starts) with the Tampa Bay Buccaneers, Falcons and Patriots. </p> </p><p> On Nov. 12, 2017, the former first-round pick (20th overall in 2011) set a Falcons record with six sacks in a 27-7 victory against the Dallas Cowboys. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Falcons bring back veteran DE Clayborn');return false;"><span class="op-btn">Read More</span> <span class="count">89 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Ffalcons-bring-back-veteran-de-clayborn%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Falcons bring back veteran DE Clayborn+http://nfp.news/12r6" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Falcons bring back veteran DE Clayborn&#32;&#32;http://nfp.news/12r6" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12r6"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/aaron-rodgers-i-lost-vision-after-week-17-concussion/" rel="bookmark" title="Aaron Rodgers: ‘I lost vision’ after Week 17 concussion">Aaron Rodgers: ‘I lost vision’ after Week 17 concussion</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/aaron-rodgers-i-lost-vision-after-week-17-concussion/"/><meta itemprop="datePublished" content="7 hours ago"/><meta itemprop="dateModified" content="7 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Aaron Rodgers: &lsquo;I lost vision&rsquo; after Week 17 concussion</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/11920503.jpg" width="1100" height="760" alt="" title="Dec 30, 2018; Green Bay, WI, USA; Detroit Lions defensive end Romeo Okwara and Jarrad Davis sack Green Bay Packers quarterback Aaron Rodgers in the first quarter at Lambeau Field. Mandatory Credit: William Glasheen/Appleton Post Crescent via USA TODAY NETWORK" data-portal-copyright="Appleton</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Aaron Rodgers: &lsquo;I lost vision&rsquo; after Week 17 concussion</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/11920503.jpg" width="1100" height="760" alt="" title="Dec 30, 2018; Green Bay, WI, USA; Detroit Lions defensive end Romeo Okwara and Jarrad Davis sack Green Bay Packers quarterback Aaron Rodgers in the first quarter at Lambeau Field. Mandatory Credit: William Glasheen/Appleton Post Crescent via USA TODAY NETWORK" data-portal-copyright="Appleton Post Crescent-USA TODAY NETWORK"></p><p> Green Bay Packers quarterback Aaron Rodgers said Tuesday that he &#8220;lost vision&#8221; after suffering a concussion in the final game of last season. </p> </p><p> In an interview with ESPN Milwaukee radio, Rodgers said it was the first time he&#8217;s ever removed himself from a game. </p> </p><p> &#8220;It&#8217;s disappointing how it ended, getting that concussion was disappointing and also a little scary, honestly. I couldn&#8217;t see. I lost vision, definitely peripheral,&#8221; Rodgers told ESPN about the injury he incurred after a sack against the Detroit Lions. </p> </p><p> Rodgers also went into detail about the knee injury he suffered in Week 1 and then reinjured in Week 5. Rodgers left the game against the Chicago Bears but returned to engineer the 20-point comeback victory. </p> </p><p> Rodgers called it an &#8220;indent fracture.&#8221; </p> </p><p> &#8220;I had a tibial plateau fracture and obviously an MCL sprain,&#8221; Rodgers told ESPN. &#8220;So that was very painful. If you watch the hit back, just my two bones here that come together on the outside just kind of made an indent fracture. Very painful.&#8221; </p> </p><p> Rodgers did not require surgery and said he returned from a vacation in New Zealand feeling &#8220;incredible.&#8221; </p> </p><p> Rodgers said he&#8217;s &#8220;excited about working&#8221; with new coach Matt LaFleur. </p> </p><p> &#8220;I think any great quarterback-to-play-caller relationship is a good partnership. We both know who the boss is and it&#8217;s him. But it works better when it&#8217;s a partnership,&#8221; Rodgers told ESPN. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Aaron Rodgers: ‘I lost vision’ after Week 17 concussion');return false;"><span class="op-btn">Read More</span> <span class="count">180 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Faaron-rodgers-i-lost-vision-after-week-17-concussion%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Aaron Rodgers: ‘I lost vision’ after Week 17 concussion+http://nfp.news/12r7" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Aaron Rodgers: ‘I lost vision’ after Week 17 concussion&#32;&#32;http://nfp.news/12r7" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12r7"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/2019-masters-rating-the-rookies/" rel="bookmark" title="2019 Masters: Rating the Rookies">2019 Masters: Rating the Rookies</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/2019-masters-rating-the-rookies/"/><meta itemprop="datePublished" content="7 hours ago"/><meta itemprop="dateModified" content="7 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>2019 Masters: Rating the Rookies</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/10116575.jpg" width="1100" height="792" alt="" title="Jun 17, 2017; Erin, WI, USA; Eddie Pepperell plays his shot from the fourth tee during the third round of the U.S. Open golf tournament at Erin Hills. Mandatory Credit: Geoff Burke-USA TODAY Sports" data-portal-copyright="Geoff Burke-USA TODAY Sports"/></p> <p> The gravity of the event</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>2019 Masters: Rating the Rookies</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/10116575.jpg" width="1100" height="792" alt="" title="Jun 17, 2017; Erin, WI, USA; Eddie Pepperell plays his shot from the fourth tee during the third round of the U.S. Open golf tournament at Erin Hills. Mandatory Credit: Geoff Burke-USA TODAY Sports" data-portal-copyright="Geoff Burke-USA TODAY Sports"></p><p> The gravity of the event and the nuances of Augusta National are the driving factors behind only three rookies winning the green jacket in the 82 Masters contested since 1934. </p> </p><p> Ten professionals among the 87-player field will be making their Masters debuts this week. </p> </p><p> There are few household names, but plenty of talent that could make some noise this week. Rating the rookies in this year&#8217;s field: </p> </p><p> Eddie Pepperell, England (World Golf Rank: 40): Pepperell first popped onto the worldwide scene by posting the low round on Sunday at last year&#8217;s Open Championship. He made another final-round run at The Players last month, again showing that he can handle the biggest stages. We like the 28-year-old&#8217;s game &#8212; and mental makeup &#8212; to be hovering around the first page of the leaderboard come Sunday. </p> </p><p> Matt Wallace, England (36): Some will recall Wallace&#8217;s hole-in-one at last year&#8217;s PGA Championship. But the Englishman is well known on the European Tour after posting three victories in 2018. His form hasn&#8217;t been stellar since a solo second at the Dubai Desert Classic in January &#8212; a T6 at Bay Hill being his only other top-10 this year. But Wallace&#8217;s game garners a lot of respect from fellow players. </p> </p><p> Lucas Bjerregaard, Denmark (43): Other pros had hinted at the Dane&#8217;s all-around game before he slayed Tiger Woods en route to a semifinal showing at the WGC-Match Play event last month. He missed the cut last week and fatigue has to be a concern after a busy stretch in the U.S. for the European Tour star. </p> </p><p> Keith Mitchell, United States (60): It&#8217;s understandable that Mitchell&#8217;s results have tailed off since winning his first PGA Tour event at The Honda Classic and then posting a T6 the next week at Bay Hill. He went T47 at The Players before failing to advance out of the group stage at Match Play. Mitchell has a lot of game and, more important at Augusta National, length to spare. </p> </p><p> Corey Conners, Canada (84): Talk about a whirlwind turn of events. Conners had to Monday qualify just to be in last week&#8217;s field at the Valero Texas Open. He then went on to win the event and secure the final spot in this year&#8217;s Masters &#8212; along with a slew of other perks. He&#8217;s an unlikely contender but should at least be playing with nothing to lose. </p> </p><p> Aaron Wise, United States (67): In the field courtesy of his victory at the AT&T Byron Nelson last year, there is little to suggest that Wise is prepared to make a run this week. He has four missed cuts in his past seven starts and only one top-20 result. His swing is highly inconsistent at the moment, which was on full display during his Match Play loss to Woods. </p> </p><p> Andrew Landry, United States (128): Landry admitted losing some focus after winning his first PGA Tour event at last year&#8217;s Valero Texas Open. He didn&#8217;t make the cut in his title defense, which has been fairly standard of late. He has five MCs in nine events in 2019 and hasn&#8217;t posted a top-20 result since last July. </p> </p><p> Adam Long, United States (108): Another first-time winner this season at the Desert Classic, Long promptly missed his next five cuts. On the Web.com Tour this time last year, Long will no doubt enjoy the pageantry and the azaleas, but sticking around for the weekend would be considered a significant accomplishment. </p> </p><p> Kevin Tway, United States (98): It has been going steadily downhill for Tway since beginning the 2018-19 season with a victory at the Safeway Open. That includes six consecutive missed cuts dating back to February. </p> </p><p> Michael Kim, United States (330): How does the world&#8217;s 330th-ranked player make his way into the Masters field? By winning last year&#8217;s John Deere. Since then, Kim has missed 13 of 18 cuts, including all eight in 2019. He tied for last in the limited-field Tournament of Champions and missed two more cuts prior to that. </p> </p><p> &#8211;Derek Harper, Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','2019 Masters: Rating the Rookies');return false;"><span class="op-btn">Read More</span> <span class="count">599 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2F2019-masters-rating-the-rookies%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=2019 Masters: Rating the Rookies+http://nfp.news/12r8" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=2019 Masters: Rating the Rookies&#32;&#32;http://nfp.news/12r8" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12r8"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/nfl-releases-2019-preseason-schedule/" rel="bookmark" title="NFL releases 2019 preseason schedule">NFL releases 2019 preseason schedule</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-releases-2019-preseason-schedule/"/><meta itemprop="datePublished" content="7 hours ago"/><meta itemprop="dateModified" content="7 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>NFL releases 2019 preseason schedule</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/10195826.jpg" width="1100" height="733" alt="" title="Aug 3, 2017; Canton, OH, USA; General view of the logo at mid-field prior to the Dallas Cowboys hosting the Arizona Cardinals in the 2017 Hall of Fame football game at the newly renovated Tom Benson Hall of Fame Stadium. Mandatory Credit: Charles LeClaire-USA TODAY</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>NFL releases 2019 preseason schedule</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/10195826.jpg" width="1100" height="733" alt="" title="Aug 3, 2017; Canton, OH, USA; General view of the logo at mid-field prior to the Dallas Cowboys hosting the Arizona Cardinals in the 2017 Hall of Fame football game at the newly renovated Tom Benson Hall of Fame Stadium. Mandatory Credit: Charles LeClaire-USA TODAY Sports" data-portal-copyright="Charles LeClaire-USA TODAY Sports"></p><p> The NFL released the 65-game 2019 preseason schedule Tuesday, kicking off with the Hall of Fame game between the Denver Broncos and Atlanta Falcons on Aug. 1 in Canton, Ohio. </p> </p><p> After the Broncos-Falcons clash (NBC, 8 p.m. ET), there are four nationally televised games scheduled for Week 2 of the preseason and three more for Week 3. </p> </p><p> The Week 2 slate includes the Oakland Raiders at Arizona Cardinals (ESPN, 8 p.m.) on Thursday, Aug. 15, and the New Orleans Saints at Los Angeles Chargers (CBS, 4 p.m.) on Sunday, Aug. 18. </p> </p><p> Week 3 action includes the Jacksonville Jaguars at Miami Dolphins (FOX, 8 p.m.) on Thursday, Aug. 22, and the Pittsburgh Steelers at Tennessee Titans (NBC, 8 pm.) on Sunday, Aug. 25. </p> </p><p> The Dallas Cowboys will face the Los Angeles Rams in Honolulu on Aug. 17, the NFL&#8217;s first preseason contest at Aloha Stadium since 1976. </p> </p><p> The Super Bowl LIII champion New England Patriots will square off against the New York Giants in the preseason finale for the 15th straight season. </p> </p><p> Specific dates and times for the remaining games will be released later this offseason. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','NFL releases 2019 preseason schedule');return false;"><span class="op-btn">Read More</span> <span class="count">119 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-releases-2019-preseason-schedule%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL releases 2019 preseason schedule+http://nfp.news/12r9" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL releases 2019 preseason schedule&#32;&#32;http://nfp.news/12r9" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12r9"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/report-murray-meeting-again-with-cardinals/" rel="bookmark" title="Report: Murray meeting again with Cardinals">Report: Murray meeting again with Cardinals</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-murray-meeting-again-with-cardinals/"/><meta itemprop="datePublished" content="10 hours ago"/><meta itemprop="dateModified" content="10 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Report: Murray meeting again with Cardinals</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12268222.jpg" width="1100" height="733" alt="" title="Mar 2, 2019; Indianapolis, IN, USA; Oklahoma quarterback Kyler Murray (QB11) who did not participate in workout drills watches from the sidelines during the 2019 NFL Combine at Lucas Oil Stadium. Mandatory Credit: Brian Spurlock-USA TODAY Sports" data-portal-copyright="Brian Spurlock-USA TODAY Sports"/></p> <p> Heisman</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Report: Murray meeting again with Cardinals</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12268222.jpg" width="1100" height="733" alt="" title="Mar 2, 2019; Indianapolis, IN, USA; Oklahoma quarterback Kyler Murray (QB11) who did not participate in workout drills watches from the sidelines during the 2019 NFL Combine at Lucas Oil Stadium. Mandatory Credit: Brian Spurlock-USA TODAY Sports" data-portal-copyright="Brian Spurlock-USA TODAY Sports"></p><p> Heisman Trophy winner Kyler Murray reportedly headed to Phoenix on Tuesday for another meeting with the Arizona Cardinals, who hold the No. 1 pick in this month&#8217;s draft. </p> </p><p> The NFL Network reported that the former Oklahoma quarterback and his agent are visiting the team on Wednesday. Murray previously met with the Cardinals at the NFL Combine and again last month at his campus workout in Norman, Okla. </p> </p><p> Murray&#8217;s agent, Erik Burkhardt, also represents Cardinals head coach Kliff Kingsbury. </p> </p><p> Arizona has met with other potential top picks, including Ohio State defensive end Nick Bosa and Alabama defensive tackle Quinnen Williams. </p> </p><p> Murray passed for 4,361 yards and 42 touchdowns and rushed for 1,001 yards and 12 touchdowns in 14 games last season for the Sooners. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Report: Murray meeting again with Cardinals');return false;"><span class="op-btn">Read More</span> <span class="count">66 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-murray-meeting-again-with-cardinals%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Murray meeting again with Cardinals+http://nfp.news/12r4" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Murray meeting again with Cardinals&#32;&#32;http://nfp.news/12r4" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12r4"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/eagles-sign-three-ex-aaf-players-to-1-year-contracts/" rel="bookmark" title="Eagles sign three ex-AAF players to 1-year contracts">Eagles sign three ex-AAF players to 1-year contracts</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/eagles-sign-three-ex-aaf-players-to-1-year-contracts/"/><meta itemprop="datePublished" content="10 hours ago"/><meta itemprop="dateModified" content="10 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Eagles sign three ex-AAF players to 1-year contracts</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12180649.jpg" width="1100" height="733" alt="" title="Feb 17, 2019; San Antonio, TX, USA; Orlando Apollos wide receiver Charles Johnson (right) catches the ball as San Antonio Commanders corner back De&#039;Vante Bausby (41) defends during the first half at The Alamodome. Mandatory Credit: Soobum Im-USA TODAY Sports" data-portal-copyright="Soobum Im-USA</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Eagles sign three ex-AAF players to 1-year contracts</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12180649.jpg" width="1100" height="733" alt="" title="Feb 17, 2019; San Antonio, TX, USA; Orlando Apollos wide receiver Charles Johnson (right) catches the ball as San Antonio Commanders corner back De'Vante Bausby (41) defends during the first half at The Alamodome. Mandatory Credit: Soobum Im-USA TODAY Sports" data-portal-copyright="Soobum Im-USA TODAY Sports"></p><p> The Philadelphia Eagles announced the signings Tuesday of three former Alliance of American Football players to one-year contracts. </p> </p><p> Quarterback Luis Perez and wide receivers Charles Johnson and Greg Ward became available when the AAF ceased operations last week, just eight weeks into its inaugural season. </p> </p><p> Perez, 24, passed for 1,461 yards (third in the AAF) with five touchdowns and six interceptions in eight games with the Birmingham Iron. </p> </p><p> Johnson, 30, led the league in receptions (45) and receiving yards (687) and caught five touchdowns in eight games with the Orlando Apollos. </p> </p><p> Ward, 23, caught 22 passes for 214 yards with the San Antonio Commanders. </p> </p><p> Ward and Perez have never appeared in an NFL game, while Johnson had 60 catches for 834 yards and two touchdowns in 39 games with the Minnesota Vikings from 2014-16. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Eagles sign three ex-AAF players to 1-year contracts');return false;"><span class="op-btn">Read More</span> <span class="count">74 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Feagles-sign-three-ex-aaf-players-to-1-year-contracts%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Eagles sign three ex-AAF players to 1-year contracts+http://nfp.news/12r5" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Eagles sign three ex-AAF players to 1-year contracts&#32;&#32;http://nfp.news/12r5" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12r5"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/reports-falcons-bring-back-veteran-de-clayborn/" rel="bookmark" title="Reports: Falcons bring back veteran DE Clayborn">Reports: Falcons bring back veteran DE Clayborn</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/reports-falcons-bring-back-veteran-de-clayborn/"/><meta itemprop="datePublished" content="10 hours ago"/><meta itemprop="dateModified" content="10 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Reports: Falcons bring back veteran DE Clayborn</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/10465531.jpg" width="1100" height="733" alt="" title="Dec 7, 2017; Atlanta, GA, USA; Atlanta Falcons defensive end Adrian Clayborn (99) reacts after a sack against the New Orleans Saints in the fourth quarter at Mercedes-Benz Stadium. Mandatory Credit: Brett Davis-USA TODAY Sports" data-portal-copyright="Brett Davis-USA TODAY Sports"/></p> <p> The Atlanta</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Reports: Falcons bring back veteran DE Clayborn</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/10465531.jpg" width="1100" height="733" alt="" title="Dec 7, 2017; Atlanta, GA, USA; Atlanta Falcons defensive end Adrian Clayborn (99) reacts after a sack against the New Orleans Saints in the fourth quarter at Mercedes-Benz Stadium. Mandatory Credit: Brett Davis-USA TODAY Sports" data-portal-copyright="Brett Davis-USA TODAY Sports"></p><p> The Atlanta Falcons are signing defensive end Adrian Clayborn to a one-year deal worth up to $4 million, multiple outlets reported Tuesday. </p> </p><p> Clayborn, who played for the Falcons from 2015-17, appeared in 14 games for the Super Bowl champion New England Patriots last season and tallied 2.5 sacks. </p> </p><p> Clayborn, 30, has registered 32.5 career sacks and 90 quarterback hits in 95 games with the Tampa Bay Buccaneers, Falcons and Patriots. </p> </p><p> On Nov. 12, 2017, the former first-round pick (20th overall in 2011) set a Falcons record with six sacks in a 27-7 victory against the Dallas Cowboys. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Reports: Falcons bring back veteran DE Clayborn');return false;"><span class="op-btn">Read More</span> <span class="count">37 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freports-falcons-bring-back-veteran-de-clayborn%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Reports: Falcons bring back veteran DE Clayborn+http://nfp.news/12r3" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Reports: Falcons bring back veteran DE Clayborn&#32;&#32;http://nfp.news/12r3" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12r3"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/cowboys-de-lawrence-to-miss-preseason-after-surgery/" rel="bookmark" title="Cowboys DE Lawrence to miss preseason after surgery">Cowboys DE Lawrence to miss preseason after surgery</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/cowboys-de-lawrence-to-miss-preseason-after-surgery/"/><meta itemprop="datePublished" content="2019-04-08"/><meta itemprop="dateModified" content="2019-04-08"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Cowboys DE Lawrence to miss preseason after surgery</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12009845-2.jpg" width="1100" height="817" alt="" title="Sep 16, 2018; Arlington, TX, USA; Dallas Cowboys defensive end DeMarcus Lawrence (90) in action against the New York Giants at AT&amp;T Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports" data-portal-copyright="Matthew Emmons-USA TODAY Sports"/></p> <p> A day after reports that he will</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Cowboys DE Lawrence to miss preseason after surgery</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12009845-2.jpg" width="1100" height="817" alt="" title="Sep 16, 2018; Arlington, TX, USA; Dallas Cowboys defensive end DeMarcus Lawrence (90) in action against the New York Giants at AT&T Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports" data-portal-copyright="Matthew Emmons-USA TODAY Sports"></p><p> A day after reports that he will have shoulder surgery to fix a torn labrum, Dallas Cowboys defensive end DeMarcus Lawrence confirmed Monday he expects to miss the preseason while recovering in hopes of playing in Week 1. </p> </p><p> Fresh off reaching a five-year deal to remain in Dallas, Lawrence said on The Rich Eisen Show that he will undergo surgery on Wednesday after putting off the procedure while he sorted out his contract, reportedly worth $105 million. </p> </p><p> Lawrence, 26, played through the injury in the 2018 season and led the Cowboys with 10.5 sacks. The two-time Pro Bowler has 25 sacks over the past two season, with no other Cowboy recording double digits over the same span. </p> </p><p> Cowboys vice president Stephen Jones told a Dallas radio station Monday that the team is &#8220;hopeful&#8221; that Lawrence will be back sooner rather than later. </p> </p><p> &#8220;Yes, you are always hopeful for the shorter time barring some complication,&#8221; Jones told 103.3 FM on Monday morning, per the Star-Telegram. &#8220;It was certainly a concern. He played with it last year. We felt like it was in his best interest long-term. DeMarcus felt that way. We needed to get surgery. It turns out it got done in a timely fashion. We couldn&#8217;t do a contract that wasn&#8217;t good for DeMarcus and the Cowboys.&#8221; </p> </p><p> The Cowboys tagged Lawrence in March for the second year in a row, giving them until July 15 to sign him to a long-term extension. Lawrence played the 2018 season on his $17.1 million tender, and he could have made $20.5 million on the tag in 2019, but reports had indicated he was unlikely to participate in training camp if he didn&#8217;t receive a long-term extension. </p> </p><p> In five seasons in Dallas, Lawrence has a combined 34 sacks and 200 tackles in 64 games (47 starts). The Cowboys selected the Boise State product in the second round of the 2014 NFL Draft. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Cowboys DE Lawrence to miss preseason after surgery');return false;"><span class="op-btn">Read More</span> <span class="count">252 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fcowboys-de-lawrence-to-miss-preseason-after-surgery%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Cowboys DE Lawrence to miss preseason after surgery+http://nfp.news/12qt" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Cowboys DE Lawrence to miss preseason after surgery&#32;&#32;http://nfp.news/12qt" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12qt"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/chiefs-agree-to-deal-with-lb-attaochu/" rel="bookmark" title="Chiefs agree to deal with LB Attaochu">Chiefs agree to deal with LB Attaochu</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/chiefs-agree-to-deal-with-lb-attaochu/"/><meta itemprop="datePublished" content="2019-04-08"/><meta itemprop="dateModified" content="2019-04-08"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Chiefs agree to deal with LB Attaochu</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/11288784.jpg" width="1100" height="733" alt="" title="Sep 20, 2018; Cleveland, OH, USA; Cleveland Browns quarterback Baker Mayfield (6) and New York Jets linebacker Jeremiah Attaochu (55) go for a fumbled ball during a two-point conversion attempt during the second half at FirstEnergy Stadium. Mandatory Credit: Ken Blaze-USA TODAY Sports"</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Chiefs agree to deal with LB Attaochu</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/11288784.jpg" width="1100" height="733" alt="" title="Sep 20, 2018; Cleveland, OH, USA; Cleveland Browns quarterback Baker Mayfield (6) and New York Jets linebacker Jeremiah Attaochu (55) go for a fumbled ball during a two-point conversion attempt during the second half at FirstEnergy Stadium. Mandatory Credit: Ken Blaze-USA TODAY Sports" data-portal-copyright="Ken Blaze-USA TODAY Sports"></p><p> The Kansas City Chiefs have reached agreement with linebacker Jeremiah Attaochu, according to the sports agency that represents the 26-year-old. </p> </p><p> SportsTrust tweeted out a photo of Attaochu while announcing he has joined the Chiefs. </p> </p><p> &#8220;@JAttaochu45 -&gt; @Chiefs. Back to the AFC West. Congrats, Jerry!&#8221; </p> </p> </p><p> Attaochu played his first four NFL seasons (2014-17) with the Chargers &#8212; three in San Diego, one in Los Angeles &#8212; so he is mighty familiar with the AFC West. He had 10 sacks in 38 games (13 starts) with the Chargers. Attaochu was originally picked in the second round of the 2014 NFL Draft by the Chargers. </p> </p><p> He signed with the San Francisco 49ers as a free agent in March 2018 but didn&#8217;t make the team and was released. The New York Jets picked up Attaochu two days later and he had two sacks in 11 games. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Chiefs agree to deal with LB Attaochu');return false;"><span class="op-btn">Read More</span> <span class="count">87 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fchiefs-agree-to-deal-with-lb-attaochu%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Chiefs agree to deal with LB Attaochu+http://nfp.news/12qu" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Chiefs agree to deal with LB Attaochu&#32;&#32;http://nfp.news/12qu" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12qu"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/nfl-notebook-cowboys-de-lawrence-to-miss-preseason/" rel="bookmark" title="NFL notebook: Cowboys DE Lawrence to miss preseason">NFL notebook: Cowboys DE Lawrence to miss preseason</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-notebook-cowboys-de-lawrence-to-miss-preseason/"/><meta itemprop="datePublished" content="2019-04-08"/><meta itemprop="dateModified" content="2019-04-08"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>NFL notebook: Cowboys DE Lawrence to miss preseason</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12009845-1.jpg" width="1100" height="817" alt="" title="Sep 16, 2018; Arlington, TX, USA; Dallas Cowboys defensive end DeMarcus Lawrence (90) in action against the New York Giants at AT&amp;T Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports" data-portal-copyright="Matthew Emmons-USA TODAY Sports"/></p> <p> A day after reports that he will</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>NFL notebook: Cowboys DE Lawrence to miss preseason</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12009845-1.jpg" width="1100" height="817" alt="" title="Sep 16, 2018; Arlington, TX, USA; Dallas Cowboys defensive end DeMarcus Lawrence (90) in action against the New York Giants at AT&T Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports" data-portal-copyright="Matthew Emmons-USA TODAY Sports"></p><p> A day after reports that he will have shoulder surgery to fix a torn labrum, Dallas Cowboys defensive end DeMarcus Lawrence confirmed Monday he expects to miss the preseason while recovering in hopes of playing in Week 1. </p> </p><p> Fresh off reaching a five-year deal to remain in Dallas, Lawrence said on The Rich Eisen Show that he will undergo surgery on Wednesday after putting off the procedure while he sorted out his contract, reportedly worth $105 million. </p> </p><p> Lawrence, 26, played through the injury in the 2018 season and led the Cowboys with 10.5 sacks. The two-time Pro Bowler has 25 sacks over the past two seasons, with no other Cowboy recording double digits over the same span. </p> </p><p> In five seasons in Dallas, Lawrence has a combined 34 sacks and 200 tackles in 64 games (47 starts). The Cowboys selected the Boise State product in the second round of the 2014 NFL Draft. </p> </p><p> &#8211;The Kansas City Chiefs have reached agreement with linebacker Jeremiah Attaochu, according to the sports agency SportsTrust that represents the 26-year-old. </p> </p><p> Attaochu played his first four NFL seasons (2014-17) with the Chargers &#8212; three in San Diego, one in Los Angeles &#8212; so he is mighty familiar with the AFC West. He had 10 sacks in 38 games (13 starts) with the Chargers. Attaochu was originally picked in the second round of the 2014 NFL Draft by the Chargers. </p> </p><p> He signed with the San Francisco 49ers as a free agent in March 2018 but didn&#8217;t make the team and was released. The New York Jets picked up Attaochu two days later and he had two sacks in 11 games. </p> </p><p> &#8211;The Arizona Cardinals re-signed defensive tackle Rodney Gunter to a one-year contract, the team announced. </p> </p><p> Gunter reportedly made a free-agent visit to the Green Bay Packers last week. The 27-year-old Gunter established career highs of 44 tackles and 4.5 sacks last year in his fourth season with the Cardinals. He has 95 tackles and eight sacks in 64 career games (25 starts). </p> </p><p> The Cardinals also announced that they signed two offensive linemen who played for the recently disbanded Alliance of American Football: Andrew Lauderdale (Arizona Hotshots) and Jeremiah Poutasi (Salt Lake City Stallions). </p> </p><p> &#8211;The Carolina Panthers announced the signing of five players, highlighted by former Philadelphia Eagles defensive tackle Destiny Vaeao and four others with experience in the now-suspended Alliance of American Football. </p> </p><p> Vaeao, 25, has played parts of three seasons with the Eagles since signing as an undrafted free agent out of Washington State in 2016. He was cut by the Eagles last October and was signed to the New York Jets practice squad the following month, but never saw regular-season action. </p> </p><p> In addition, the Panthers added four others who played in the AAF. The group includes Rashad Ross, 29, who caught 36 passes for 583 yards (16.2 yards per catch) and a league-best seven touchdowns for the Arizona Hotshots. His signing initially was reported on Thursday. </p> </p><p> &#8211;The Miami Dolphins have reached a one-year deal with former Cleveland Browns wide receiver Ricardo Louis, according to multiple reports. </p> </p><p> A fourth-round pick by the Browns in 2016, the 6-foot-2, 215-pound Louis missed all of last season with a neck injury that he had surgically repaired before training camp. </p> </p><p> The two seasons prior, Louis appeared in all 32 games with 12 starts, catching 45 passes for 562 yards. He also averaged 18.2 yards on nine kickoff returns as a rookie after running a 4.43-second 40-yard dash at the Combine. </p> </p><p> &#8211;Former rugby player Christian Wade has been allocated to the Buffalo Bills as part of the NFL&#8217;s International Player Pathway Program, the team announced. </p> </p><p> The 5-foot-8, 190-pound Wade was a highly decorated rugby star in the United Kingdom, having played for the national team at the U16, U18 and U20 levels, as well as making the British and Irish Lions squad. He retired from the rugby union last year to pursue playing in the NFL. </p> </p><p> Wade&#8217;s 82 tries (touchdowns) in Premiership Rugby, mostly as a ballcarrier, is third all-time and he has been designated as a running back with the Bills. </p> </p><p> Wade, 27, is one of seven international athletes from five countries who have been training in Florida with the goal of landing one of four placements among AFC East teams this offseason. He participated in a pro day last week, where he was timed at 4.53 seconds in the 40-yard dash. </p> </p><p> The four clubs will be allowed to carry an extra player (91 total) during training camp and, should the player not make the final roster, will also receive an extra practice squad spot for the allotted player. However, those placed on the practice squad with the international player exemption will be ineligible to be activated during the season. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','NFL notebook: Cowboys DE Lawrence to miss preseason');return false;"><span class="op-btn">Read More</span> <span class="count">701 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-notebook-cowboys-de-lawrence-to-miss-preseason%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL notebook: Cowboys DE Lawrence to miss preseason+http://nfp.news/12qv" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL notebook: Cowboys DE Lawrence to miss preseason&#32;&#32;http://nfp.news/12qv" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12qv"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/take-5-good-bets-to-win-the-masters/" rel="bookmark" title="Take 5: Good bets to win the Masters">Take 5: Good bets to win the Masters</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/take-5-good-bets-to-win-the-masters/"/><meta itemprop="datePublished" content="2019-04-08"/><meta itemprop="dateModified" content="2019-04-08"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Take 5: Good bets to win the Masters</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12497295.jpg" width="1100" height="772" alt="" title="Apr 8, 2019; Augusta, GA, USA; Rory McIlroy hits his tee shot on the fourth hole during a practice round for the Masters golf tournament at Augusta National Golf Club. Mandatory Credit: Rob Schumacher-USA TODAY Sports" data-portal-copyright="Rob Schumacher-USA TODAY Sports"/></p> <p></p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Take 5: Good bets to win the Masters</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12497295.jpg" width="1100" height="772" alt="" title="Apr 8, 2019; Augusta, GA, USA; Rory McIlroy hits his tee shot on the fourth hole during a practice round for the Masters golf tournament at Augusta National Golf Club. Mandatory Credit: Rob Schumacher-USA TODAY Sports" data-portal-copyright="Rob Schumacher-USA TODAY Sports"></p><p> Masters week is here, and one of the many intriguing elements is the small field at Augusta National. Only 87 players qualified for this year&#8217;s event, making it even more likely that one of the world&#8217;s best players will earn a green jacket come Sunday. </p> </p><p> Defending champion Patrick Reed offers good odds at 60-1 by Sportsbook.ag, but he hasn&#8217;t shown the form of late that instills confidence that he can threaten a repeat. The same would be true for the likes of former champs Jordan Spieth (18-1 despite zero top-10s since last year&#8217;s Open Championship) and Phil Mickelson (45-1, two missed cuts in past three events and eliminated in group stage of Match Play). </p> </p><p> Five good bets to win the 2019 Masters. </p> </p><p> 5. Tiger Woods, United States (14-1): Never count Tiger out at Augusta National. It&#8217;s the tournament he covets the most and builds his entire schedule around. But he&#8217;s also 43 years old and the most recent of his 14 major titles came 11 years ago. He hasn&#8217;t donned the green jacket since 2005. Woods has only five events under his belt in 2019 and hasn&#8217;t shown the form of late to make him one of the true favorites this week. But, hey, he also has four green jackets to his name and few players understand the nuances of Augusta National better than Tiger. </p> </p><p> 4. Francesco Molinari, Italy (18-1): Those are pretty favorable odds for one of the world&#8217;s most consistent players. Since tying for 20th at last year&#8217;s Masters, Molinari has posted four worldwide wins, including last month&#8217;s Arnold Palmer Invitational. His ball-striking is typically impeccable and he has the steely nerves to handle the pressure of the back nine on Sunday. </p> </p><p> 3. Eddie Pepperell, England (150-1): If you&#8217;re looking for a longshot, Pepperell is worth a strong look at 150-1. He&#8217;s ranked 40th in the world and has shown the ability to compete on golf&#8217;s biggest stages. Pepperell posted a 67 on Sunday of last year&#8217;s Open Championship &#8211; the lowest score in the final round &#8211; to tie for sixth. He also made a Sunday charge with a 66 at The Players last month before ultimately tying for third. Pepperell primarily plays on the European Tour and this will be the 28-year-old&#8217;s first time in the Masters. Only three Masters rookies have won since the tournament began in 1934, hence the long odds. Pepperell is one of 10 professionals making their Masters debuts this week. </p> </p><p> 2. Dustin Johnson, United States (10-1): Justin Rose snuck past him for the No. 1 spot in the world rankings entering this week, but Johnson&#8217;s numbers across the board in 2019 are as well-rounded as any player in the field. He has the length to tame Augusta National and his short iron play has improved markedly. The lone question is the putter, as some painful misses in the 5- to 10-foot range have crept into Johnson&#8217;s game the past few events. </p> </p><p> 1. Rory McIlroy, Northern Ireland (8-1): The betting favorite, McIlroy is unquestionably the hottest player on the planet. He has seven consecutive top-10s to begin 2019, highlighted by his win at The Players, and all facets of his game have come together. If he can get the putter even reasonably hot this week, McIlroy has perhaps his best opportunity yet to complete the career grand slam come Sunday. </p> </p><p> &#8211;Derek Harper, Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Take 5: Good bets to win the Masters');return false;"><span class="op-btn">Read More</span> <span class="count">494 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Ftake-5-good-bets-to-win-the-masters%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Take 5: Good bets to win the Masters+http://nfp.news/12qp" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Take 5: Good bets to win the Masters&#32;&#32;http://nfp.news/12qp" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12qp"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/panthers-sign-five-including-four-aaf-players/" rel="bookmark" title="Panthers sign five, including four AAF players">Panthers sign five, including four AAF players</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/panthers-sign-five-including-four-aaf-players/"/><meta itemprop="datePublished" content="2019-04-08"/><meta itemprop="dateModified" content="2019-04-08"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Panthers sign five, including four AAF players</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12283940.jpg" width="1100" height="791" alt="" title="Mar 3, 2019; Tempe, AZ, USA; Arizona Hotshots wide receiver Rashad Ross (15) reacts against the Atlanta Legends during an AAF football game at Sun Devil Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports"/></p> <p> The Carolina</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Panthers sign five, including four AAF players</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12283940.jpg" width="1100" height="791" alt="" title="Mar 3, 2019; Tempe, AZ, USA; Arizona Hotshots wide receiver Rashad Ross (15) reacts against the Atlanta Legends during an AAF football game at Sun Devil Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports"></p><p> The Carolina Panthers announced the signing of five players on Monday, highlighted by former Philadelphia Eagles defensive tackle Destiny Vaeao and four others with experience in the now-suspended Alliance of American Football. </p> </p><p> Vaeao, 25, has played parts of three seasons with the Eagles since signing as an undrafted free agent out of Washington State in 2016. He was cut by the Eagles last October and was signed to the New York Jets practice squad the following month, but never saw regular-season action. </p> </p><p> With the Eagles, Vaeao played in 33 career games (three starts) and recorded 27 tackles and three sacks. </p> </p><p> In addition, the Panthers added four others who played in the AAF. Rashad Ross, 29, caught 36 passes for 583 yards (16.2 yards per catch) and a league-best seven touchdowns for the Arizona Hotshots. His signing initially was reported on Thursday. </p> </p><p> Also joining Carolina&#8217;s 90-man roster are defensive tackle T.J. Barnes, who also played in parts of three NFL seasons with the Jets, Buffalo Bills and Kansas City Chiefs from 2014-16. He has six career tackles in 21 games (one start). </p> </p><p> The other ex-AAF players to sign Monday are tight end Thomas Duarte and offensive tackle Brandon Greene. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Panthers sign five, including four AAF players');return false;"><span class="op-btn">Read More</span> <span class="count">140 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpanthers-sign-five-including-four-aaf-players%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Panthers sign five, including four AAF players+http://nfp.news/12qq" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Panthers sign five, including four AAF players&#32;&#32;http://nfp.news/12qq" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12qq"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/cardinals-re-sign-dt-gunter/" rel="bookmark" title="Cardinals re-sign DT Gunter">Cardinals re-sign DT Gunter</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/cardinals-re-sign-dt-gunter/"/><meta itemprop="datePublished" content="2019-04-08"/><meta itemprop="dateModified" content="2019-04-08"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Cardinals re-sign DT Gunter</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/11971924.jpg" width="1100" height="803" alt="" title="Dec 23, 2018; Glendale, AZ, USA; Arizona Cardinals defensive tackle Rodney Gunter (95) against the Los Angeles Rams at State Farm Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports"/></p> <p> The Arizona Cardinals re-signed defensive tackle Rodney Gunter to a</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Cardinals re-sign DT Gunter</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/11971924.jpg" width="1100" height="803" alt="" title="Dec 23, 2018; Glendale, AZ, USA; Arizona Cardinals defensive tackle Rodney Gunter (95) against the Los Angeles Rams at State Farm Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports"></p><p> The Arizona Cardinals re-signed defensive tackle Rodney Gunter to a one-year contract, the team announced on Monday. </p> </p><p> Gunter reportedly made a free-agent visit to the Green Bay Packers last week. </p> </p><p> The 27-year-old Gunter established career highs of 44 tackles and 4.5 sacks last year in his fourth season with the Cardinals. He has 95 tackles and eight sacks in 64 career games (25 starts). </p> </p><p> The Cardinals also announced that they signed two offensive linemen who played for the recently disbanded Alliance of American Football: Andrew Lauderdale (Arizona Hotshots) and Jeremiah Poutasi (Salt Lake City Stallions). </p> </p><p> Poutasi has played in 12 NFL games (eight starts) with the Tennessee Titans (2015) and Jacksonville Jaguars (2016). </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Cardinals re-sign DT Gunter');return false;"><span class="op-btn">Read More</span> <span class="count">52 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fcardinals-re-sign-dt-gunter%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Cardinals re-sign DT Gunter+http://nfp.news/12qr" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Cardinals re-sign DT Gunter&#32;&#32;http://nfp.news/12qr" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12qr"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/bills-allocated-british-rugby-player-christian-wade/" rel="bookmark" title="Bills allocated British rugby player Christian Wade">Bills allocated British rugby player Christian Wade</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/bills-allocated-british-rugby-player-christian-wade/"/><meta itemprop="datePublished" content="2019-04-08"/><meta itemprop="dateModified" content="2019-04-08"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Bills allocated British rugby player Christian Wade</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/10340222.jpg" width="1100" height="733" alt="" title="Oct 8, 2017; Cincinnati, OH, USA; A view of the Bills logo on a game helmet during the game of the Buffalo Bills against the Cincinnati Bengals at Paul Brown Stadium. Mandatory Credit: Aaron Doster-USA TODAY Sports" data-portal-copyright="Aaron Doster-USA TODAY Sports"/></p> <p></p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Bills allocated British rugby player Christian Wade</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/10340222.jpg" width="1100" height="733" alt="" title="Oct 8, 2017; Cincinnati, OH, USA; A view of the Bills logo on a game helmet during the game of the Buffalo Bills against the Cincinnati Bengals at Paul Brown Stadium. Mandatory Credit: Aaron Doster-USA TODAY Sports" data-portal-copyright="Aaron Doster-USA TODAY Sports"></p><p> Former rugby player Christian Wade has been allocated to the Buffalo Bills as part of the NFL&#8217;s International Player Pathway Program, the team announced on Monday. </p> </p><p> The 5-foot-8, 190-pound Wade was a highly decorated rugby star in the United Kingdom, having played for the national team at the U16, U18 and U20 levels, as well as making the British and Irish Lions squad. He retired from the rugby union last year to pursue playing in the NFL. </p> </p><p> Wade&#8217;s 82 tries (touchdowns) in Premiership Rugby, mostly as a ballcarrier, is third all-time and he has been designated as a running back with the Bills. </p> </p><p> Wade, 27, is one of seven international athletes from five countries who have been training in Florida with the goal of landing one of four placements among AFC East teams this offseason. He participated in a pro day last week, where he was timed at 4.53 seconds in the 40-yard dash. </p> </p><p> The four clubs will be allowed to carry an extra player (91 total) during training camp and, should the player not make the final roster, will also receive an extra practice squad spot for the allotted player. However, those placed on the practice squad with the international player exemption will be ineligible to be activated during the season. </p> </p><p> The International Player Pathway Program began in 2017 and rotates through divisions each year. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Bills allocated British rugby player Christian Wade');return false;"><span class="op-btn">Read More</span> <span class="count">171 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fbills-allocated-british-rugby-player-christian-wade%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Bills allocated British rugby player Christian Wade+http://nfp.news/12qm" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Bills allocated British rugby player Christian Wade&#32;&#32;http://nfp.news/12qm" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12qm"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/reports-dolphins-agree-to-deal-with-wr-louis/" rel="bookmark" title="Reports: Dolphins agree to deal with WR Louis">Reports: Dolphins agree to deal with WR Louis</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/reports-dolphins-agree-to-deal-with-wr-louis/"/><meta itemprop="datePublished" content="2019-04-08"/><meta itemprop="dateModified" content="2019-04-08"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Reports: Dolphins agree to deal with WR Louis</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/10372022.jpg" width="1100" height="733" alt="" title="Oct 27, 2017; Bagshot, United Kingdom; Cleveland Browns wide receiver Ricardo Louis (80) reacts during practice at the Pennyhill Park Hotel &amp; Spa. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"/></p> <p> The Miami Dolphins have reached a one-year</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Reports: Dolphins agree to deal with WR Louis</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/10372022.jpg" width="1100" height="733" alt="" title="Oct 27, 2017; Bagshot, United Kingdom; Cleveland Browns wide receiver Ricardo Louis (80) reacts during practice at the Pennyhill Park Hotel & Spa. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"></p><p> The Miami Dolphins have reached a one-year deal with former Cleveland Browns wide receiver Ricardo Louis, according to multiple reports. </p> </p><p> A fourth-round pick by the Browns in 2016, the 6-foot-2, 215-pound Louis missed all of last season with a neck injury that he had surgically repaired before training camp. </p> </p><p> The two seasons prior, Louis appeared in all 32 games with 12 starts, catching 45 passes for 562 yards. He also averaged 18.2 yards on nine kickoff returns as a rookie after running a 4.43-second 40-yard dash at the Combine. </p> </p><p> The Browns waived Louis, 25, on April 1. </p> </p><p> Louis starred at Miami Beach High before moving on to play for the Auburn Tigers. He now joins a Dolphins receiving crew that includes Kenny Stills, Albert Wilson, DeVante Parker and Jakeem Grant. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Reports: Dolphins agree to deal with WR Louis');return false;"><span class="op-btn">Read More</span> <span class="count">73 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freports-dolphins-agree-to-deal-with-wr-louis%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Reports: Dolphins agree to deal with WR Louis+http://nfp.news/12qn" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Reports: Dolphins agree to deal with WR Louis&#32;&#32;http://nfp.news/12qn" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12qn"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/2019-nfl-draft-top-250-prospects/" rel="bookmark" title="2019 NFL Draft: Top 250 prospects">2019 NFL Draft: Top 250 prospects</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/2019-nfl-draft-top-250-prospects/"/><meta itemprop="datePublished" content="2019-04-08"/><meta itemprop="dateModified" content="2019-04-08"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>2019 NFL Draft: Top 250 prospects</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12278825.jpg" width="1100" height="733" alt="" title="Mar 3, 2019; Indianapolis, IN, USA; Ohio State defensive lineman Nick Bosa (DL25) goes through workout drills during the 2019 NFL Combine at Lucas Oil Stadium. Mandatory Credit: Brian Spurlock-USA TODAY Sports" data-portal-copyright="Brian Spurlock-USA TODAY Sports"/></p> <p> Field Level Media's Top 250 prospects</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>2019 NFL Draft: Top 250 prospects</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12278825.jpg" width="1100" height="733" alt="" title="Mar 3, 2019; Indianapolis, IN, USA; Ohio State defensive lineman Nick Bosa (DL25) goes through workout drills during the 2019 NFL Combine at Lucas Oil Stadium. Mandatory Credit: Brian Spurlock-USA TODAY Sports" data-portal-copyright="Brian Spurlock-USA TODAY Sports"></p><p> Field Level Media&#8217;s Top 250 prospects for the 2019 NFL Draft, ranked overall by position. </p> </p><p> Rank (Position Rank), Player (*=underclassman) Pos, Ht., Wt., 40, Proj., School </p><p> 1. (1) Nick Bosa, DE, 6-3 3/4, 266, 4.79, 1, Ohio State </p><p> 2. (1) Quinnen Williams, DT, 6-3, 303, 4.83, 1, Alabama </p><p> 3. (1) Ed Oliver, DT, 6-1 7/8, 287, N/A, 1, Houston </p><p> 4. (1) Josh Allen, OLB, 6-4 7/8, 262, 4.63, 1, Kentucky </p><p> 5. (1) Devin White, ILB, 6-0, 237, 4.42, 1, LSU </p><p> 6. (2) Rashan Gary, DE, 6-4 3/8, 277, 4.58, 1, Michigan </p><p> 7. (3) Montez Sweat, DE, 6-5 3/4, 260, 4.41, 1, Mississippi State </p><p> 8. (4) Clelin Ferrell, DE, 6-4 3/8, 264, N/A, 1, Clemson </p><p> 9. (1) Jonah Williams, OT, 6-4 1/2, 302, 5.12, 1, Alabama </p><p> 10. (1) Dwayne Haskins, QB, 6-3 3/8, 231, 5.04, 1, Ohio State </p><p> 11. (1) Andraez &#8220;Greedy&#8221; Williams, CB, 6-1 7/8, 185, 4.37, 1, LSU </p><p> 12. (1) T.J. Hockenson, TE, 6-4 3/4, 251, 4.7, 1, Iowa </p><p> 13. (2) Brian Burns, OLB, 6-4 3/4, 249, 4.53, 1, Florida State </p><p> 13. (2) Kyler Murray, QB, 5-10 1/8, 207, N/A, 1, Oklahoma </p><p> 14. (1) D.K. Metcalf, WR, 6-3 3/8, 228, 4.33, 1, Mississippi </p><p> 15. (2) Byron Murphy, CB, 5-10 3/4, 190, 4.55, 1, Washington </p><p> 16. (3) Christian Wilkins, DT, 6-3 1/4, 315, 5.04, 1, Clemson </p><p> 17. (1) Nasir Adderley, S, 5-11 3/4, 206, N/A, 1, Delaware </p><p> 18. (2) N&#8217;Keal Harry, WR, 6-2 3/8, 228, 4.53, 1, Arizona State </p><p> 19. (2) Jawaan Taylor, OT, 6-5, 312, N/A, 1, Florida </p><p> 20. (4) Dexter Lawrence , DT, 6-4 1/2, 342, 5.05, 1, Clemson </p><p> 21. (2) Devin Bush, ILB, 5-11, 234, 4.43, 1-2, Michigan </p><p> 22. (2) Noah Fant, TE, 6-4 1/8, 249, 4.5, 1-2, Iowa </p><p> 23. (5) Jerry Tillery, DT, 6-6 1/2, 295, 4.93, 1-2, Notre Dame </p><p> 24. (2) Johnathan Abram, S, 5-11 3/8, 205, 4.45, 1-2, Mississippi State </p><p> 25. (3) Deionte Thompson, S, 6-1, 195, N/A, 1-2, Alabama </p><p> 26. (3) Andre Dillard, OT, 6-5, 315, 4.96, 1-2, Washington State </p><p> 27. (3) Deandre Baker, CB, 5-11, 193, 4.52, 1-2, Georgia </p><p> 28. (1) Cody Ford, OG, 6-3 3/4, 329, 5.21, 1-2, Oklahoma </p><p> 29. (1) Josh Jacobs, RB, 5-10 , 220, N/A, 1-2, Alabama </p><p> 30. (3) Drew Lock, QB, 6-3 3/4, 228, 4.69, 1-2, Missouri </p><p> 31. (3) Marquise Brown, WR, 5-9 3/8, 166, N/A, 1-2, Oklahoma </p><p> 32. (4) Dalton Risner, OT, 6-4 3/4, 312, 5.3, 1-2, Kansas State </p><p> 33. (4) Amani Hooker, S, 5-11 3/8, 210, 4.48, 1-2, Iowa </p><p> 34. (5) Anthony Nelson, DE, 6-7, 271, 4.82, 1-2, Iowa </p><p> 35. (4) A.J. Brown, WR, 6-0 1/2, 226, 4.49, 1-2, Mississippi </p><p> 36. (4) Daniel Jones, QB, 6-5 1/8, 221, 4.81, 1-2, Duke </p><p> 37. (1) Garrett Bradbury, C, 6-2 7/8, 306, 4.92, 2, North Carolina State </p><p> 38. (5) Kaleb McGary, OT, 6-7 1/8, 317, 5.05, 2, Washington </p><p> 38. (7) Jeffery Simmons, DT, 6-3, 305, N/A, 2, Mississippi State </p><p> 39. (4) Lonnie Johnson, CB, 6-1 7/8, 213, 4.52, 2, Kentucky </p><p> 40. (5) Taylor Rapp, S, 5-11 3/4, 208, N/A, 2, Washington </p><p> 41. (6) Trysten Hill, DT, 6-2 3/4, 308, 5.04, 2, Central Florida </p><p> 42. (5) Deebo Samuel, WR, 5-11 1/4, 214, 4.48, 2, South Carolina </p><p> 43. (6) Chauncey Gardner-Johnson, S, 5-10 7/8, 210, 4.48, 2, Florida </p><p> 44. (6) Joe Jackson, DE, 6-4 1/4, 275, N/A, 2, Miami </p><p> 45. (2) Chris Lindstrom, OG, 6-3 3/4, 308, 4.91, 2, Boston College </p><p> 46. (6) Greg Little, OT, 6-5 1/4, 310, 5.33, 2, Mississippi </p><p> 47. (5) Kendall Sheffield, CB, 5-11 3/8, 193, N/A, 2, Ohio State </p><p> 48. (3) Mack Wilson, ILB, 6-1 1/8 , 240, N/A, 2, Alabama </p><p> 49. (7) Jachai Polite, DE, 6-2 5/8, 258, 4.84, 2, Florida </p><p> 50. (6) Hakeem Butler, WR, 6-5 3/8, 227, 4.48, 2, Iowa State </p><p> 51. (6) Amani Oruwariye, CB, 6-1 5/8, 205, 4.47, 2, Penn State </p><p> 52. (7) Darnell Savage, S, 5-10 3/4, 198, 4.36, 2, Maryland </p><p> 53. (7) Parris Campbell, WR, 5-11 7/8, 205, 4.31, 2, Ohio State </p><p> 53. (8) Zach Allen, DE, 6-4 1/8, 281, 5.0, 2, Boston College </p><p> 54. (8) JJ Arcega-Whiteside, WR, 6-2, 225, N/A, 2, Stanford </p><p> 55. (3) Chase Winovich, OLB, 6-2 3/4, 256, 4.59, 2, Michigan </p><p> 56. (2) Elgton Jenkins, C, 6-4 1/2, 310, N/A, 2-3, Mississippi State </p><p> 57. (4) Vosean Joseph, ILB, 6-1 1/2, 230, N/A, 2-3, Florida </p><p> 58. (7) Michael Jackson, CB, 6-0 5/8, 210, 4.45, 2-3, Miami </p><p> 59. (9) Charles Omenihu, DE, 6-5 3/8, 280, 4.92, 2-3, Texas </p><p> 60. (3) Dru Samia, OG, 6-5 3/4, 305, 5.29, 2-3, Oklahoma </p><p> 61. (5) Jarrett Stidham, QB, 6-2 3/8, 218, 4.81, 2-3, Auburn </p><p> 62. (8) Justin Layne, CB, 6-1 3/4, 192, 4.50, 2-3, Michigan State </p><p> 63. (2) Trayveon Williams, RB, 5-8 1/8, 206, 4.51, 2-3, Texas A&M </p><p> 64. (10) L.J. Collier, DE, 6-2 1/4, 283, 4.91, 2-3, TCU </p><p> 65. (3) Foster Moreau, TE, 6-4 1/8, 253, 4.66, 2-3, LSU </p><p> 66. (3) Erik McCoy, C, 6-3 7/8, 303, 4.89, 2-3, Texas A&M </p><p> 67. (8) Khalen Saunders, DT, 6-0 3/8, 324, 5.01, 2-3, Western Illinois </p><p> 68. (7) Mitch Hyatt, OT, 6-5 3/8, 303, N/A, 2-3, Clemson </p><p> 69. (4) Dawson Knox, TE, 6-4 3/8, 254, N/A, 2-3, Mississippi </p><p> 70. (3) Darrell Henderson, RB, 5-8 3/8, 208, 4.49, 2-3, Memphis </p><p> 71. (4) Connor McGovern, OG, 6-5 3/8, 308, N/A, 2-3, Penn State </p><p> 72. (8) Martez Ivey, OT, 6-5, 315, N/A, 2-3, Florida </p><p> 73. (8) Juan Thornhill, S, 6-0 1/4, 205, 4.42, 2-3, Virginia </p><p> 74. (4) Mike Weber, RB, 5-9 5/8, 211, 4.47, 3, Ohio State </p><p> 75. (10) Joejuan Williams, CB, 6-3 5/8, 211, 4.64, 3, Vanderbilt </p><p> 76. (9) Terry Beckner, Jr. , DT, 6-3 5/8, 296, 5.19, 3, Missouri </p><p> 77. (5) Kahale Warring, TE, 6-5 1/8, 252, 4.67, 3, San Diego State </p><p> 78. (5) David Montgomery, RB, 5-10 1/8, 222, 4.63, 3, Iowa State </p><p> 79. (5) Nate Davis, OG, 6-3 1/4, 316, 5.23, 3, Charlotte </p><p> 80. (5) Ben Banogu, OLB, 6-3 1/2, 250, 4.62, 3, TCU </p><p> 81. (9) Rock Ya-Sin, CB, 5-11 3/4, 192, 4.51, 3, Temple </p><p> 82. (11) Kris Boyd, CB, 5-11 1/2, 201, 4.45, 3, Texas </p><p> 82. (10) Isaiah Buggs, DT, 6-3 1/8, 306, 5.15, 3, Alabama </p><p> 83. (5) Bobby Okereke, ILB, 6-1 3/8, 239, 4.58, 3, Stanford </p><p> 84. (6) Drue Tranquill, OLB, 6-2, 234, 4.57, 3, Notre Dame </p><p> 85. (6) Josh Oliver, TE, 6-4 5/8, 249, 4.63, 3, San Jose State </p><p> 86. (12) Trayvon Mullen, CB, 6-1 1/2, 199, 4.46, 3, Clemson </p><p> 87. (6) Damien Harris, RB, 5-10 1/8, 216, 4.57, 3, Alabama </p><p> 88. (6) Michael Deiter, OG, 6-5 1/8, 309, 5.23, 3, Wisconsin </p><p> 89. (7) Miles Sanders, RB, 5-10 5/8, 211, 4.49, 3, Penn State </p><p> 90. (11) Dre&#8217;Mont Jones, DT, 6-2 3/4, 281, 5.12, 3, Ohio State </p><p> 90. (9) Yodny Cajuste, OT, 6-4 7/8, 312, N/A, 3, West Virginia </p><p> 91. (7) Justin Hollins, OLB, 6-5 1/4, 248, 4.50, 3, Oregon </p><p> 92. (13) Sean Bunting, CB, 6-0 3/8, 195, 4.42, 3, Central Michigan </p><p> 93. (6) Tyree Jackson, QB, 6-7, 249, 4.59, 3, Buffalo </p><p> 94. (9) David Sills V, WR, 6-3 1/3, 211, 4.57, 3, West Virginia </p><p> 95. (11) Maxx Crosby, DE, 6-4 7/8, 255, 4.66, 3, Eastern Michigan </p><p> 96. (10) Kelvin Harmon, WR, 6-2 1/2, 221, 4.6, 3, North Carolina State </p><p> 97. (9) Will Harris, S, 6-1, 207, 4.41, 3, Boston College </p><p> 98. (11) Andy Isabella, WR, 5-8 3/4, 188, 4.31, 3, Massachusetts-Amherst </p><p> 99. (10) Marvell Tell III, S, 6-2, 198, N/A, 3, Southern California </p><p> 100. (12) Austin Bryant, DE, 6-3 7/8, 271, N/A, 3, Clemson </p><p> 101. (4) Blake Cashman, OLB, 6-1 1/8, 237, 4.50, 3, Minnesota </p><p> 102. (14) Isaiah Johnson, CB, 6-2 1/8, 208, 4.40, 3-4, Houston </p><p> 103. (8) Devin Singletary, RB, 5-7 1/2, 203, 4.66, 3-4, Florida Atlantic </p><p> 104. (13) Dontavius Russell, DT, 6-2 3/4, 319, 5.15, 3-4, Auburn </p><p> 105. (8) Sione Takitaki, OLB, 6-1 1/8, 238, 4.63, 3-4, BYU </p><p> 106. (13) Riley Ridley, WR, 6-1 1/4, 199, 4.58, 3-4, Georgia </p><p> 107. (15) Julian Love, CB, 5-10 3/4, 195, 4.54, 3-4, Notre Dame </p><p> 108. (12) Max Scharping, OT, 6-5 7/8, 327, N/A, 3-4, Northern Illinois </p><p> 109. (14) Terry McLaurin, WR, 6-0 1/8, 208, 4.35, 3-4, Ohio State </p><p> 110. (9) Oshane Ximines, OLB, 6-3 1/2, 253, 4.78, 3-4, Old Dominion </p><p> 111. (10) Tytus Howard, OT, 6-5, 322, 5.05, 3-4, Alabama State </p><p> 112. (16) Jamel Dean, CB, 6-1, 206, 4.30, 3-4, Auburn </p><p> 113. (10) Jordan Brailford, OLB, 6-2 5/8, 252, 4.65, 3-4, Oklahoma State </p><p> 114. (12) Mecole Hardman, WR, 5-10 1/4, 187, 4.33, 3-4, Georgia </p><p> 114. (7) Iosua Opeta , OG, 6-4 1/4, 301, 5.02, 4, Weber State </p><p> 115. (11) Isaiah Prince, OT, 6-6 1/2, 305, 5.09, 4, Ohio State </p><p> 115. (13) Jaylon Ferguson, DE, 6-4 6/8, 271, 4.82, 4, Louisiana Tech </p><p> 116. (13) Oli Udoh, OT, 6-5 1/2, 323, 5.05, 4, Elon </p><p> 117. (8) Phil Haynes, OG, 6-3 5/8, 322, 5.20, 4, Wake Forest </p><p> 118. (6) Cody Barton, ILB, 6-2 1/2, 237, 4.64, 4, Utah </p><p> 119. (9) Myles Gaskin, RB, 5-9 1/4, 205, 4.58, 4, Washington </p><p> 119. (11) Darius West, S, 5-10 7/8, 208, 4.39, 4, Kentucky </p><p> 120. (9) Beau Benzschawel, OG, 6-6 1/4, 309, 5.24, 4, Wisconsin </p><p> 120. (15) Keelan Doss, WR, 6-2 1/8, 211, N/A, 4, UC-Davis </p><p> 121. (14) John Cominsky, DE, 6-5 1/4, 286, 4.69, 4, Charleston </p><p> 122. (14) David Edwards, OT, 6-6 1/4, 308, 5.28, 4, Wisconsin </p><p> 123. (16) Ryan Davis, WR, 5-9 7/8, 189, N/A, 4, Auburn </p><p> 124. (7) Cameron Smith, ILB, 6-2, 238, 4.69, 4, Southern California </p><p> 125. (17) Saivion Smith, CB, 6-0 7/8, 199, 4.65, 4, Alabama </p><p> 125. (12) Albert Huggins, DT, 6-2 7/8, 305, 5.12, 4, Clemson </p><p> 126. (7) Ryan Finley, QB, 6-4, 213, 4.73, 4, North Carolina State </p><p> 127. (12) Khari Willis, S, 5-10 7/8, 213, 4.52, 4, Michigan State </p><p> 128. (17) Gary Jennings, Jr. , WR, 6-1, 214, 4.42, 4, West Virginia </p><p> 129. (10) Justice Hill, RB, 5-9 5/8, 198, 4.4, 4, Oklahoma State </p><p> 130. (14) Daylon Mack, DT, 6-1, 336, 5.10, 4, Texas A&M </p><p> 131. (11) Kaden Elliss, OLB, 6-2 1/4, 238, 4.62, 4, Idaho </p><p> 132. (4) Lamont Gaillard, C, 6-2 5/8, 305, N/A, 4-5, Georgia </p><p> 133. (11) Benny Snell, RB, 5-10 3/8, 224, 4.66, 4-5, Kentucky </p><p> 134. (8) Clayton Thorson, QB, 6-4, 222, N/A, 4-5, Northwestern </p><p> 135. (7) Jace Sternberger, TE, 6-4, 251, 4.75, 4-5, Texas A&M </p><p> 136. (15) Chuma Edoga, OT, 6-3 1/2, 308, 5.19, 4-5, Southern California </p><p> 137. (12) Terrill Hanks, OLB, 6-2, 242, 4.98, 4-5, New Mexico State </p><p> 138. (16) Michael Jordan, OT, 6-5 7/8, 312, 5.27, 4-5, Ohio State </p><p> 139. (8) Drew Sample, TE, 6-4 3/4, 255, 4.71, 4-5, Washington </p><p> 140. (13) Malik Gant, S, 5-11 5/8, 209, 4.63, 4-5, Marshall </p><p> 141. (19) Myles Boykin, WR, 6-3 3/4, 220, 4.42, 4-5, Notre Dame </p><p> 142. (19) DaMarkus Lodge, WR, 6-1 7/8, 202, 4.55, 4-5, Mississippi </p><p> 143. (13) Christian Miller, OLB, 6-3 3/8, 247, N/A, 4-5, Alabama </p><p> 144. (14) Marquise Blair, S, 6-1 1/4, 195, 4.48, 4-5, Utah </p><p> 145. (18) Jazz Ferguson, WR, 6-4 5/8, 227, 4.45, 4-5, Northwestern State (La.) </p><p> 145. (12) Jordan Scarlett, RB, 5-10 5/8, 208, 4.47, 4-5, Florida </p><p> 146. (15) Renell Wren, DT, 6-4 7/8, 318, 5.01, 4-5, Arizona State </p><p> 147. (8) Germaine Pratt, ILB, 6-2 1/2, 240, 4.57, 4-5, North Carolina State </p><p> 148. (18) Corey Ballentine, CB, 5-11, 196, 4.47, 4-5, Washburn </p><p> 149. (13) Rodney Anderson, RB, 6-0 3/8, 224, N/A, 5, Oklahoma </p><p> 150. (9) Will Grier, QB, 6-2 1/2, 217, 4.84, 5, West Virginia </p><p> 151. (14) Chase Hansen, OLB, 6-2 7/8, 222, N/A, 5, Utah </p><p> 152. (9) Irv Smith, Jr. , TE, 6-2 3/8, 242, 4.63, 5, Alabama </p><p> 153. (14) Dexter Williams, RB, 5-11, 212, 4.57, 5, Notre Dame </p><p> 154. (16) Porter Gustin, OLB, 6-4 1/2, 255, 4.69, 5, Southern California </p><p> 155. (10) Alize Mack, TE, 6-4, 249, 4.7, 5, Notre Dame </p><p> 156. (15) Ryquell Armstead, RB, 5-11 1/4, 220, 4.45, 5, Temple </p><p> 157. (1) Mitch Wishnowsky, P, 6-2 1/8, 218, 4.63, 5, Utah </p><p> 158. (9) Otaro Alaka, ILB, 6-3, 239, 4.82, 5, Texas A&M </p><p> 159. (19) Iman Lewis-Marshall, CB, 6-0 5/8, 207, 4.53, 5, Southern California </p><p> 160. (10) Hjalte Froholdt, OG, 6-4 5/8, 306, 5.20, 5, Arkansas </p><p> 161. (16) Bryce Love, RB, 5-8 7/8, 200, N/A, 5, Stanford </p><p> 162. (10) Ty Summers, ILB, 6-1 3/8, 241, 4.51, 5, TCU </p><p> 163. (20) Dillon Mitchell, WR, 6-1 1/4, 197, 4.46, 5, Oregon </p><p> 164. (11) Caleb Wilson, TE, 6-4 1/4, 240, 4.56, 5, UCLA </p><p> 165. (15) Gerri Green, OLB, 6-4, 252, 4.63, 5, Mississippi State </p><p> 166. (15) Sheldrick Redwine, S, 6-0, 196, 4.44, 5, Miami </p><p> 167. (18) Tyler Roemer, OT, 6-6 3/8, 312, 5.21, 5, San Diego State </p><p> 168. (15) Jonathan Ledbetter, DE, 6-3 3/4, 280, 5.14, 5, Georgia </p><p> 169. (20) Jordan Brown, CB, 6-0 3/8, 201, 4.51, 5, South Dakota State </p><p> 170. (16) Greg Gaines, DT, 6-1, 312, 5.16, 5, Washington </p><p> 172. (21) Jamal Peters, CB, 6-1 3/4, 218, 4.63, 5, Mississippi State </p><p> 173. (11) Derwin Gray, OG, 6-4 1/2, 320, 5.26, 5, Maryland </p><p> 174. (21) Darius Slayton, WR, 6-1, 190, 4.39, 5, Auburn </p><p> 175. (17) Bobby Evans, OT, 6-4 3/8, 312, 5.2, 5, Oklahoma </p><p> 176. (16) Shareef Miller, DE, 6-4 1/2, 254, 4.69, 5, Penn State </p><p> 177. (22) Tyre Brady, WR, 6-2 7/8, 211, N/A, 5, Marshall </p><p> 178. (17) Jalen Jelks, DE, 6-5 3/8, 256, N/A, 5, Oregon </p><p> 179. (23) Lil&#8217;Jordan Humphrey, WR, 6-3 5/8, 210, 4.75, 5, Texas </p><p> 180. (24) Travis Fulgham, WR, 6-2 1/2, 215, 4.58, 5, Old Dominion </p><p> 181. (25) Emanuel Hall, WR, 6-1 7/8, 201, 4.39, 5, Missouri </p><p> 182. (26) Johnnie Dixon, WR, 5-10 3/8, 201, 4.41, 5, Ohio State </p><p> 183. (27) Jalen Hurd, WR, 6-4 3/4, 226, N/A, 5, Baylor </p><p> 184. (5) Ross Pierschbacher, C, 6-3 5/8, 307, 5.20, 5-6, Alabama </p><p> 185. (12) Nate Herbig, OG, 6-3 1/2, 335, 5.41, 5-6, Stanford </p><p> 186. (19) William Sweet, OT, 6-6, 313, 5.27, 5-6, North Carolina </p><p> 187. (17) Ugo Amadi, S, 5-9 3/8, 199, 4.51, 5-6, Oregon </p><p> 188. (12) Dax Raymond, TE, 6-4 3/4, 255, 4.73, 5-6, Utah State </p><p> 189. (1) Alec Ingold, FB, 6-0 3/4, 242, 4.89, 5-6, Wisconsin </p><p> 190. (11) Jahlani Tavai, ILB, 6-2 3/8, 250, N/A, 5-6, Hawaii </p><p> 191. (17) Byron Cowart, DT, 6-3, 298, 5.16, 5-6, Maryland </p><p> 192. (18) Gerald Willis, DT, 6-1 3/4, 302, N/A, 5-6, Miami </p><p> 193. (17) D&#8217;Andre Walker, OLB, 6-2 3/8, 251, N/A, 5-6, Georgia </p><p> 194. (22) Derrick Baity, CB, 6-2 1/8, 197, N/A, 5-6, Kentucky </p><p> 195. (16) Andrew Wingard, S, 6-0 1/8, 209, 4.56, 5-6, Wyoming </p><p> 196. (28) Hunter Renfrow, WR, 5-10 1/4, 184, 4.59, 6, Clemson </p><p> 197. (17) Travis Homer, RB, 5-10 3/8, 201, 4.48, 6, Miami </p><p> 198. (18) David Long, Jr. , OLB, 5-11 1/4, 227, 4.45, 6, West Virginia </p><p> 199. (18) Mike Edwards, S, 5-10 1/2, 205, N/A, 6, Kentucky </p><p> 200. (13) Ben Powers, OG, 6-4 , 307, N/A, 6, Oklahoma </p><p> 201. (13) Kaden Smith, TE, 6-5, 255, 4.92, 6, Stanford </p><p> 202. (18) Alex Barnes, RB, 6-0 3/8, 226, 4.59, 6, Kansas State </p><p> 203. (19) Kingsley Keke, DT, 6-2 5/8, 288, 4.95, 6, Texas A&M </p><p> 204. (23) Jordan Miller, CB, 6-0 5/8, 186, 4.49, 6, Washington </p><p> 205. (29) Stanley Morgan Jr. , WR, 6-0, 202, 4.53, 6, Nebraska </p><p> 206. (14) Fred Johnson, OG, 6-7 1/8, 326, N/A, 6, Florida </p><p> 207. (19) Lukas Denis, S, 5-11 1/4, 190, 4.64, 6, Boston College </p><p> 208. (31) Terry Godwin, WR, 5-11 3/8, 184, 4.55, 6, Georgia </p><p> 209. (12) Te&#8217;Von Coney, ILB, 6-0 7/8, 234, N/A, 6, Notre Dame </p><p> 210. (1) Matt Gay, K, 6-0 , 232, N/A, 6, Utah </p><p> 210. (20) Yosh Nijman, OT, 6-6 7/8, 324, N/A, 6, Virginia Tech </p><p> 211. (13) Tre Lamar, ILB, 6-3 3/8, 253, 4.95, 6, Clemson </p><p> 212. (18) Darryl Johnson, DE, 6-6, 253, N/A, 6, North Carolina A&T </p><p> 213. (30) KeeSean Johnson, WR, 6-1 1/8, 201, 4.6, 6, Fresno State </p><p> 214. (24) David Long, CB, 5-10 5/8, 196, 4.45, 6, Michigan </p><p> 215. (32) Jakobi Myers, WR, 6-1 5/8, 203, 4.63, 6, North Carolina State </p><p> 216. (10) Gardner Minshew II, QB, 6-0 7/8, 225, 4.97, 6, Washington State </p><p> 217. (20) Jaquan Johnson, S, 5-10 1/8, 191, 4.69, 6-7, Miami </p><p> 218. (11) Trace McSorley, QB, 6-0 1/8, 202, 4.57, 6-7, Penn State </p><p> 219. (25) Mark Fields, CB, 5-9 7/8, 192, 4.37, 6-7, Clemson </p><p> 220. (15) Ethan Greenidge, OG, 6-4 3/8, 327, N/A, 6-7, Villanova </p><p> 221. (12) Jake Browning, QB, 6-1 7/8, 211, 4.74, 6-7, Washington </p><p> 222. (19) Jalin Moore, RB, 5-10, 212, N/A, 6-7, Appalachian State </p><p> 223. (19) Sutton Smith, OLB, 6-0 3/8, 233, 4.69, 6-7, Northern Illinois </p><p> 224. (21) Devon Johnson, OT, 6-7 1/4, 338, 5.16, 6-7, Ferris State </p><p> 225. (20) Karan Higdon, RB, 5-9 1/8, 206, 4.49, 6-7, Michigan </p><p> 226. (33) Felton Davis III, WR, 6-3 1/2, 211, N/A, 6-7, Michigan State </p><p> 227. (20) Demarcus Christmas, DT, 6-3 3/8, 294, 5.08, 7, Florida State </p><p> 228. (14) T.J. Edwards, ILB, 6-0 230, , N/A, 7, Wisconsin </p><p> 229. (21) Tony Pollard, RB, 5-11 5/8, 210, 4.52, 7, Memphis </p><p> 229. (2) Austin Seibert, K, 5-9 1/4, 213, N/A, 7, Oklahoma </p><p> 230. (21) Ben Burr-Kirven, OLB, 6-0, 230, 4.56, 7, Washington </p><p> 230. (22) Dre Greenlaw, OLB, 5-11 1/2, 237, N/A, 7, Arkansas </p><p> 231. (22) Ryan Pope, OT, 6-7, 320, N/A, 7, San Diego State </p><p> 232. (24) Emeke Egbule, OLB, 6-2, 245, 4.65, 7, Houston </p><p> 232. (24) LJ Scott, RB, 6-0 3/8, 227, N/A, 7, Michigan State </p><p> 233. (22) Qadree Ollison, RB, 6-0 5/8, 228, 4.58, 7, Pittsburgh </p><p> 234. (23) James Williams, RB, 5-9 1/2, 197, 4.58, 7, Washington State </p><p> 235. (14) Keenen Brown, TE, 6-2 1/2, 250, 4.75, 7, Texas State </p><p> 236. (13) Brett Rypien, QB, 6-1 5/8, 210, 4.91, 7, Boise State </p><p> 236. (34) Antoine Wesley, WR, 6-4 1/8, 206, N/A, 7, Texas Tech </p><p> 237. (26) Xavier Crawford, CB, 5-10 7/8, 187, 4.48, 7, Central Michigan </p><p> 237. (27) Hamp Cheevers, CB, 5-9 3/8, 169, 4.52, 7, Boston College </p><p> 237. (20) Carl Granderson, OLB, 6-4 3/4, 254, 4.79, 7, Wyoming </p><p> 238. (15) Deshaun Davis, ILB, 5-11 3/8, 234, N/A, 7, Auburn </p><p> 239. (3) Cole Tracy, K, 5-10 3/8, 184, N/A, 7, LSU </p><p> 240. (16) Javon Patterson, OG, 6-2 78, 307, 5.13, 7, Mississippi </p><p> 241. (19) Wyatt Ray, DE, 6-3 1/4, 257, 4.83, 7, Boston College </p><p> 242. (23) Gary Johnson, OLB, 5-11 7/8, 226, 4.43, 7, Texas </p><p> 243. (14) Nick Fitzgerald, QB, 6-4 5/8, 226, 4.64, 7, Mississippi State </p><p> 244. (35) Greg Dortch, WR, 5-7 1/8, 173, N/A, 7, Wake Forest </p><p> 245. (22) Mike Bell, S, 6-2 3/4, 210, 4.83, 7, Fresno State </p><p> 246. (15) Jordan Ta&#8217;amu, QB, 6-2 5/8, 221, 4.77, 7, Mississippi </p><p> 247. (21) Zedrick Woods, S, 5-11, 205, 4.29, 7, Mississippi </p><p> 248. (2) Jack Fox, P, 6-2 1/2, 213, 4.73, 7, Rice </p><p> 249. (36) Anthony Johnson, WR, 6-1 7/8, 209, N/A, 7, Buffalo </p><p> 250. (25) Alexander Mattison, RB, 5-11, 221, 4.67, 7, Boise State </p><p> 251. (17) Easton Stick, QB, 6-1 1/4, 224, 4.62, 7, North Dakota State </p><p> 252. (16) Kyle Shurmur, QB, 6-4, 230, 4.91, 7, Vanderbilt </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','2019 NFL Draft: Top 250 prospects');return false;"><span class="op-btn">Read More</span> <span class="count">1672 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2F2019-nfl-draft-top-250-prospects%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=2019 NFL Draft: Top 250 prospects+http://nfp.news/12qo" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=2019 NFL Draft: Top 250 prospects&#32;&#32;http://nfp.news/12qo" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12qo"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/steelers-smith-schuster-slams-ex-teammate-brown/" rel="bookmark" title="Steelers&#8217; Smith-Schuster slams ex-teammate Brown">Steelers&#8217; Smith-Schuster slams ex-teammate Brown</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/steelers-smith-schuster-slams-ex-teammate-brown/"/><meta itemprop="datePublished" content="2019-04-08"/><meta itemprop="dateModified" content="2019-04-08"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Steelers' Smith-Schuster slams ex-teammate Brown</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12045403.jpg" width="1100" height="807" alt="" title="Jan 23, 2019; Kissimmee, FL, USA; Pittsburgh Steelers receiver JuJu Smith-Schuster (19) acknowledges the crowd during the Pro Bowl Skills Challenge at ESPN Wide World of Sports Complex. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"/></p> <p> The Pittsburgh Steelers' former franchise</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Steelers&#8217; Smith-Schuster slams ex-teammate Brown</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/04/12045403.jpg" width="1100" height="807" alt="" title="Jan 23, 2019; Kissimmee, FL, USA; Pittsburgh Steelers receiver JuJu Smith-Schuster (19) acknowledges the crowd during the Pro Bowl Skills Challenge at ESPN Wide World of Sports Complex. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports"></p><p> The Pittsburgh Steelers&#8217; former franchise receiver took a Twitter swipe at the team&#8217;s new franchise receiver on Sunday. </p> </p><p> The Steelers&#8217; newest top wideout is not pleased, and not staying quiet. </p> </p><p> Nearly a month after the Steelers traded seven-time Pro Bowl wideout Antonio Brown to the Oakland Raiders after a contentious few months, including his absence from the team&#8217;s season finale, Brown sparked a Twitter spat with ex-teammate Juju Smith-Schuster when commenting on a fan post on social media. </p> </p><p> Brown had been tagged on a posted image with the header touting the 22-year-old Smith-Schuster as the Steelers&#8217; 2018 team MVP. Brown&#8217;s Twitter response blamed Smith-Schuster for his crucial fumble late in a Week 16 loss at New Orleans, saying he &#8220;fumbled the whole post season in the biggest game of year.&#8221; </p> </p> </p><p> Smith-Schuster caught wind of the post and tweeted, &#8220;Keep your emotions off the internet,&#8221; followed by a series of tweets referencing Brown. </p> </p> </p><p> &#8220;All I ever did was show that man love and respect from the moment I got to the league,&#8221; Smith-Schuster tweeted. &#8220;I was genuinely happy for him too when he got traded to Oakland w/ a big contract, and now he takes shots at me on social media?&#8221; </p> </p><p> Smith-Schuster continued, tweeting, &#8220;Crazy how big that ego got to be to take shots at people who show you love!&#8221; </p> </p> </p><p> Smith-Schuster then posted a quote from famous author Mark Twain that read, &#8220;Never argue with a fool. Onlookers may not be able to tell the difference.&#8221; </p> </p><p> Brown, 30, and Smith-Schuster were Pittsburgh teammates for the younger wideout&#8217;s first two NFL seasons in 2017-18. Publicly, Smith-Schuster has supported Brown, but he has also voiced strong support for Brown&#8217;s former quarterback, Ben Roethlisberger. Brown and Roethlisberger reportedly had a practice dispute heading into the Steelers&#8217; Week 17 game against Cincinnati. </p> </p><p> That apparent argument devolved into Brown missing the Steelers&#8217; final game, despite their playoff fates being on the line. </p> </p><p> Surrounding his trade to Oakland in March, Brown has often referenced his problems with Roethlisberger&#8217;s leadership style. Last month, Smith-Schuster publicly backed his quarterback amid the controversy, saying, &#8220;I was so blessed to enter the league and play with a Hall of Fame QB as a 20-year old. Ben has taught me so much, he&#8217;s a true Leader and I can&#8217;t wait to rock with my guy this season.&#8221; </p> </p> </p><p> Brown tweeted the next day, &#8220;Do not listen to any NFL player who haven&#8217;t got paid yet! They will do and say anything to make sure they going to get paid even if it&#8217;s compromising integrity or anything ! sad but true.&#8221; </p> </p><p> In late January, Smith-Schuster appeared on ESPN&#8217;s First Take and said the Steelers needed to limit off-field drama and distractions, comparing the team to a family of reality TV stars. </p> </p><p> &#8220;I think everyone just needs to stop being divas,&#8221; Smith-Schuster said. &#8220;I think we need to stop being the Kardashians and just play ball.&#8221; </p> </p><p> While the wideout wouldn&#8217;t offer names at the time when asked about which teammates he might be referring to, he said only, &#8220;I&#8217;ve learned a lot in that locker room, and I know that I would never want to be a problem to any franchise.&#8221; </p> </p><p> &#8220;For me, personally, let&#8217;s focus on the main goal: win a Super Bowl,&#8221; Smith-Schuster said. </p> </p><p> In his second season, Smith-Schuster finished with 111 catches for 1,426 yards and seven touchdowns, reaching his first Pro Bowl. Brown caught an NFL-high 15 touchdown passes while catching 104 passes for 1,297 yards. Brown caught 100-plus passes for an NFL-record sixth consecutive season. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Steelers&#8217; Smith-Schuster slams ex-teammate Brown');return false;"><span class="op-btn">Read More</span> <span class="count">524 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fsteelers-smith-schuster-slams-ex-teammate-brown%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Steelers’ Smith-Schuster slams ex-teammate Brown+http://nfp.news/12ql" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Steelers&#8217; Smith-Schuster slams ex-teammate Brown&#32;&#32;http://nfp.news/12ql" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/12ql"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article></div></div></div></div></div></div><a href="#" id="fl-to-top"><i class="fa fa-chevron-up"></i></a><style>[class*="fa fa-"]{font-family:FontAwesome !important;}</style>
<noscript id="wpfc-google-fonts"><link rel='stylesheet' id='sab-font-css' href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,700,400italic,700italic&#038;subset=latin' type='text/css' media='all'/>
<link rel='stylesheet' id='fl-builder-google-fonts-a0dc0f37a2c19d739b7445c77d065820-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C700%7CRoboto+Condensed%3A700%7COpen+Sans+Condensed%3A700&#038;ver=5.1.1' type='text/css' media='all'/>
</noscript>
<link rel='stylesheet' id='font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=2.1.4.3' type='text/css' media='all'/>
<script>var posts_table_params={"ajax_url":"https:\/\/nationalfootballpost.com\/wp-admin\/admin-ajax.php","ajax_nonce":"55e6ff52fe","wrapper_class":"posts-table-wrapper bb-theme","language":{"info":"Showing _START_ to _END_ of _TOTAL_ entries","infoEmpty":"Showing 0 entries","infoFiltered":"(_MAX_ entries in total)","lengthMenu":"Show _MENU_ entries","emptyTable":"No data available in table.","zeroRecords":"No matching records found.","search":"Search:","paginate":{"first":"First","last":"Last","next":"Next","previous":"Previous"},"thousands":",","decimal":".","aria":{"sortAscending":": activate to sort column ascending","sortDescending":": activate to sort column descending"},"filterBy":"Filter:","resetButton":"Reset"}};</script>
<!--[if lt IE 9]><script src="//nationalfootballpost.com/wp-content/cache/wpfc-minified/8z16d3ot/8e5lx.js"></script><![endif]-->
<!--[if lt IE 9]><script src="//nationalfootballpost.com/wp-content/cache/wpfc-minified/lbeld6mi/8e5lx.js"></script><![endif]-->
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/nationalfootballpost.com\/","sameAs":["http:\/\/facebook.com\/nationalfootballpost","https:\/\/twitter.com\/footballpost"],"@id":"https:\/\/nationalfootballpost.com\/#organization","name":"National Football Post","logo":"http:\/\/footballpost.wpengine.com\/wp-content\/uploads\/2018\/05\/NFPlogo-400.png"}</script>
<script src='//nationalfootballpost.com/wp-content/cache/wpfc-minified/qlb18u0t/8e5lw.js' type="text/javascript"></script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-5166086-1"></script>
<script>window.dataLayer=window.dataLayer||[];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-5166086-1');</script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/clipboard.js/1.5.10/clipboard.min.js"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>
<script>jQuery(function($){
$('button').tooltip({
trigger: 'click',
placement: 'bottom'
});
function setTooltip(btn, message){
$(btn).tooltip('hide')
.attr('data-original-title', message)
.tooltip('show');
}
function hideTooltip(btn){
setTimeout(function(){
$(btn).tooltip('hide');
}, 1000);
}
var clipboard=new Clipboard('button');
clipboard.on('success', function(e){
setTooltip(e.trigger, 'Link copied to clipboard');
hideTooltip(e.trigger);
});
clipboard.on('error', function(e){
setTooltip(e.trigger, 'Failed!');
hideTooltip(e.trigger);
});
});</script>
<script defer src='//nationalfootballpost.com/wp-content/cache/wpfc-minified/6mqm6t2g/8e5lw.js' type="text/javascript"></script>
<script>document.addEventListener('DOMContentLoaded',function(){function wpfcgl(){var wgh=document.querySelector('noscript#wpfc-google-fonts').innerText, wgha=wgh.match(/<link[^\>]+>/gi);for(i=0;i<wgha.length;i++){var wrpr=document.createElement('div');wrpr.innerHTML=wgha[i];document.body.appendChild(wrpr.firstChild);}}wpfcgl();});</script>
<script >document.addEventListener('DOMContentLoaded',function(){
jQuery(document).ready(function($){
$(window).scroll(function(){
var footerPos=$('footer').last().position().top;
var pos=$(window).scrollTop();
if(pos+(screen.height*4) > footerPos){
if($(".centil-infinite-scroll").first().hasClass('working')){
return false;
}else{
$(".centil-infinite-scroll").first().addClass('working');
}
var centilNextPostId=$(".centil-infinite-scroll").first().text();
var data={
'action': 'centil_is',
'centilNextPostId': centilNextPostId
};
jQuery.post('https://nationalfootballpost.com/wp-admin/admin-ajax.php', data, function(response){
$(".centil-infinite-scroll").first().replaceWith(response);
}, 'html');
}
var currUrl=$(".centil-post-header").first().attr("url");
var currTitle=$(".centil-post-header").first().attr("title");
if($(".centil-post-header").length > 1&&history.pushState){
for (var i=0; i<$(".centil-post-header").length; i++){
if(pos+(screen.height/2) >=$(".centil-post-header").eq(i).next().position().top){
currUrl=$(".centil-post-header").eq(i).attr("url");
currTitle=$(".centil-post-header").eq(i).attr("title");
}}
}
if(location.href!=currUrl){
history.pushState({}, currTitle, currUrl);
}});
});});</script>
</body>
</html><!-- WP Fastest Cache file was created in 2.75657010078 seconds, on 09-04-19 23:39:32 -->