<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8"/>
<meta name='viewport' content='width=device-width, initial-scale=1.0'/>
<meta http-equiv='X-UA-Compatible' content='IE=edge'/>
<link rel="profile" href="https://gmpg.org/xfn/11"/>
<link rel="pingback" href="https://nationalfootballpost.com/xmlrpc.php"/>
<title>NFL notebook: Bell works out at Jets&#039; minicamp - National Football Post</title>
<link rel="canonical" href="https://nationalfootballpost.com/nfl-notebook-bell-works-out-at-jets-minicamp/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="NFL notebook: Bell works out at Jets&#039; minicamp - National Football Post"/>
<meta property="og:description" content="NFL notebook: Bell works out at Jets&#8217; minicamp Running back Le&#8217;Veon Bell took part in on-field workouts at the New York Jets&#8217; mandatory minicamp Tuesday after skipping most of the team&#8217;s spring voluntary workouts. He worked with the first-team offense in 11-on-11 drills in what was his first competitive football since January 2018, when he&hellip;"/>
<meta property="og:url" content="https://nationalfootballpost.com/nfl-notebook-bell-works-out-at-jets-minicamp/"/>
<meta property="og:site_name" content="National Football Post"/>
<meta property="article:publisher" content="http://facebook.com/nationalfootballpost"/>
<meta property="article:tag" content="FLM"/>
<meta property="article:section" content="NFL and College Football Articles"/>
<meta property="article:published_time" content="2019-06-05T03:39:41+00:00"/>
<meta property="article:modified_time" content="2019-06-05T03:39:43+00:00"/>
<meta property="og:updated_time" content="2019-06-05T03:39:43+00:00"/>
<meta property="og:image" content="https://nationalfootballpost.com/wp-content/uploads/2019/06/10586477.jpg"/>
<meta property="og:image:secure_url" content="https://nationalfootballpost.com/wp-content/uploads/2019/06/10586477.jpg"/>
<meta property="og:image:width" content="1100"/>
<meta property="og:image:height" content="733"/>
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="National Football Post &raquo; Feed" href="https://nationalfootballpost.com/feed/"/>
<link rel="stylesheet" type="text/css" href="//nationalfootballpost.com/wp-content/cache/wpfc-minified/2m79n2i1/80n70.css" media="all"/>
<link rel='https://api.w.org/' href='https://nationalfootballpost.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nationalfootballpost.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nationalfootballpost.com/wp-includes/wlwmanifest.xml"/> 
<link rel='shortlink' href='https://nationalfootballpost.com/?p=105436'/>
<link rel="alternate" type="application/json+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-notebook-bell-works-out-at-jets-minicamp%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-notebook-bell-works-out-at-jets-minicamp%2F&#038;format=xml"/>
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','https://www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-5166086-1', 'auto'); ga('send', 'pageview');</script>
<meta name="generator" content="Feed to Post 3.7.5"/>
<link rel="canonical" href="https://footballpost.wpengine.com/newsml/fieldlevelmedia_str_20190605T012208_0800_000040203_1.xml"/><style>.saboxplugin-wrap .saboxplugin-gravatar img{-webkit-border-radius:50%;-moz-border-radius:50%;-ms-border-radius:50%;-o-border-radius:50%;border-radius:50%;}
.saboxplugin-wrap .saboxplugin-authorname a{color:#212121;}
.saboxplugin-wrap .saboxplugin-authorname{font-family:"Roboto Condensed";}
.saboxplugin-wrap .saboxplugin-desc{font-family:Roboto Condensed;}
.saboxplugin-wrap .saboxplugin-desc{font-style:italic;}
.saboxplugin-wrap{margin-top:20px;margin-bottom:10px;padding:5px 5px}
.saboxplugin-wrap .saboxplugin-authorname{font-size:20px;line-height:27px;}
.saboxplugin-wrap .saboxplugin-desc p, .saboxplugin-wrap .saboxplugin-desc{font-size:16px !important;line-height:23px !important;}
.saboxplugin-wrap .saboxplugin-web{font-size:14px;}
.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa:before{font-size:18px;}
.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa{width:36px;height:36px;line-height:36px;}</style><link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-32x32.jpg" sizes="32x32"/>
<link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-192x192.jpg" sizes="192x192"/>
<link rel="apple-touch-icon-precomposed" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-180x180.jpg"/>
<meta name="msapplication-TileImage" content="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-270x270.jpg"/>
<style id="wp-custom-css">.fl-post-cats-tags{padding:0px 0px 0px 0px;border-bottom:4px solid #e6e6e6}
.share-social{border-bottom:4px solid #e6e6e6}
.container{max-width:93%}
.fl-sidebar-left{padding-right:2%;padding-left:0px;}
.fl-post-cats-tags a, .share-social a{text-transform:uppercase;color:#000;font-size:18px;font-weight:600;font-style:normal;}
.fl-archive .fl-post{border-bottom:0px;}
div.share-social{letter-spacing:7px;float:right;padding-top:10px;}
.custom-html-widget li a{font-size:16px;color:#555;font-style:normal;display:block;padding-bottom:4px;font-weight:600;text-transform:uppercase;}
.custom-html-widget li{font-size:14px;color:#7b7b7b;font-style:italic;font-weight:500;text-transform:uppercase;padding-bottom:6px;border-bottom:2px solid #e6e6e6}
.fl-widget-title{border-style:solid;border-width:4px 0px 4px 0px;text-align:center;padding:5px}
.fl-post-title{margin-bottom:0px;}
.fl-post-author{text-transform:uppercase;font-style:italic;font-weight:600;font-size:18px;}
.tooltip-inner{letter-spacing:1px;}
.fl-post-meta-bottom{border-top:none;font-style:italic;margin-top:0;padding-top:10px;float:left;}
.btn-primary{border:none !important;background:0 0 !important;;color:#000 !important;;box-shadow:none !important;;padding:0 !important;;margin-bottom:5px !important;;}
.toptitle h1{font-size:22px;margin-top:5px;margin-bottom:5px;list-style:none;margin:0;padding:0;line-height:40px;width:50%;position:relative;left:25%;margin:0 px;padding:0 px;border:1px solid #AAA;color:white;background:#050505;border-bottom-left-radius:10px;border-bottom-right-radius:10px;font-style:italic;}
.fl-archive .fl-archive-title{display:none;}
.rp4wp-related-post-content{font-size:18px;color:#555;font-style:italic;display:block;font-weight:800;text-transform:uppercase;}</style>
<script data-wpfc-render="false">var Wpfcll={s:[],i:function(){Wpfcll.ss();window.addEventListener('load',function(){window.addEventListener("DOMSubtreeModified",function(e){Wpfcll.ss();Wpfcll.ls(false);},false);Wpfcll.ls(true);});window.addEventListener('scroll',function(){Wpfcll.ls(false);});window.addEventListener('resize',function(){Wpfcll.ls(false);});window.addEventListener('click',function(){Wpfcll.ls(false);});},c:function(e,pageload){var w=document.documentElement.clientHeight || body.clientHeight;var n=pageload ? 0:800;var er=e.getBoundingClientRect();var t=0;var p=e.parentNode;var pr=p.getBoundingClientRect();if(er.x==0 && er.y==0){for(var i=0;i < 10;i++){if(p){if(pr.x==0 && pr.y==0){p=p.parentNode;pr=p.getBoundingClientRect();}else{t=pr.top;break;}}};}else{t=er.top;}if(w - t+n > 0){return true;}return false;},r:function(e,pageload){var s=this;var oc,ot;try{if(s.c(e,pageload)){oc=e.getAttribute("data-wpfc-original-src");ot=e.getAttribute("data-wpfc-original-srcset");if(oc || ot){if(oc){e.setAttribute('src',oc);}if(ot){e.setAttribute('srcset',ot);}e.removeAttribute("data-wpfc-original-src");e.removeAttribute("onload");if(e.tagName=="IFRAME"){e.onload=function(){var s=e.getAttribute("src").match(/templates\/youtube\.html\#(.+)/);var y="https://www.youtube.com/embed/";if(s){try{var i=e.contentDocument || e.contentWindow;if(i.location.href=="about:blank"){e.setAttribute('src',y+s[1]);}}catch(err){e.setAttribute('src',y+s[1]);}}}}}}}catch(error){console.log(error);console.log("==>",e);}},ss:function(){var i=Array.prototype.slice.call(document.getElementsByTagName("img"));var f=Array.prototype.slice.call(document.getElementsByTagName("iframe"));this.s=i.concat(f);},ls:function(pageload){var s=this;[].forEach.call(s.s,function(e,index){s.r(e,pageload);});}};document.addEventListener('DOMContentLoaded',function(){wpfci();});function wpfci(){Wpfcll.i();}</script>
</head>
<body class="post-template-default single single-post postid-105436 single-format-standard fl-preset-default fl-fixed-width fl-scroll-to-top fl-search-active" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="fl-page"> <header class="fl-page-header fl-page-header-fixed fl-page-nav-right fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="fl-page-logo-wrap col-md-3 col-sm-12"> <div class="fl-page-header-logo"> <a href="https://nationalfootballpost.com/"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post"/><meta itemprop="name" content="National Football Post"/></a></div></div><div class="fl-page-fixed-nav-wrap col-md-9 col-sm-12"> <div class="fl-page-nav-wrap"> <nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span><i class="fa fa-bars"></i></span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-top-nav" class="nav navbar-nav navbar-right menu"><li id="menu-item-78448" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a> <ul class="sub-menu"> <li id="menu-item-94464" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li> <li id="menu-item-94463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li> </ul> </li> <li id="menu-item-80343" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a> <ul class="sub-menu"> <li id="menu-item-88321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li> <li id="menu-item-80344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li> <li id="menu-item-78452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li> </ul> </li> <li id="menu-item-78387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a> <ul class="sub-menu"> <li id="menu-item-84427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li> <li id="menu-item-84236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li> </ul> </li> <li id="menu-item-78499" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a> <ul class="sub-menu"> <li id="menu-item-78502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li> <li id="menu-item-78500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li> <li id="menu-item-80079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li> </ul> </li> </ul></div></nav></div></div></div></div></div></header>
<header class="fl-page-header fl-page-header-primary fl-page-nav-centered fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-12 fl-page-header-logo-col"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="https://schema.org/Organization"> <a href="https://nationalfootballpost.com/" itemprop="url"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post"/><meta itemprop="name" content="National Football Post"/></a></div></div></div></div></div><div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span><i class="fa fa-bars"></i></span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-top-nav-1" class="nav navbar-nav menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li> </ul> </li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li> </ul> </li> </ul><div class="fl-page-nav-search"> <a href="javascript:void(0);" class="fa fa-search"></a> <form method="get" role="search" action="https://nationalfootballpost.com/" title="Type and press Enter to search."> <input type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" /> </form></div></div></nav></div></div></header>
<div class="fl-page-content" itemprop="mainContentOfPage"> <div class="fl-archive container"> <div class="row"> <div class="fl-sidebar fl-sidebar-left fl-sidebar-display-desktop col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"> <aside id="custom_html-3" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">RECENT</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/mets-to-qb-brady-theres-only-one-tom-terrific/" title="Mets to QB Brady: There’s only one ‘Tom Terrific’">Mets to QB Brady: There’s only one ‘Tom Terrific’</a> 1 min ago </li><li class="current"><a href="https://nationalfootballpost.com/nfl-notebook-bell-works-out-at-jets-minicamp/" title="NFL notebook: Bell works out at Jets&#8217; minicamp">NFL notebook: Bell works out at Jets&#8217; minicamp</a> 1 min ago </li><li ><a href="https://nationalfootballpost.com/patriots-release-te-seferian-jenkins/" title="Patriots release TE Seferian-Jenkins">Patriots release TE Seferian-Jenkins</a> 4 hours ago </li><li ><a href="https://nationalfootballpost.com/pga-tour-adds-bermuda-to-2019-20-schedule/" title="PGA Tour adds Bermuda to 2019-20 schedule">PGA Tour adds Bermuda to 2019-20 schedule</a> 4 hours ago </li><li ><a href="https://nationalfootballpost.com/redskins-lt-williams-wants-new-deal/" title="Redskins LT Williams wants new deal">Redskins LT Williams wants new deal</a> 4 hours ago </li><li ><a href="https://nationalfootballpost.com/report-patriots-releasing-te-seferian-jenkins/" title="Report: Patriots releasing TE Seferian-Jenkins">Report: Patriots releasing TE Seferian-Jenkins</a> 4 hours ago </li><li ><a href="https://nationalfootballpost.com/all-pro-lb-bowman-retires-at-31/" title="All-Pro LB Bowman retires at 31">All-Pro LB Bowman retires at 31</a> 4 hours ago </li><li ><a href="https://nationalfootballpost.com/browns-rb-johnson-still-wants-to-be-traded/" title="Browns RB Johnson still wants to be traded">Browns RB Johnson still wants to be traded</a> 8 hours ago </li><li ><a href="https://nationalfootballpost.com/bell-takes-part-in-jets-camp-gm-decision-pending/" title="Bell takes part in Jets&#8217; camp; GM decision pending">Bell takes part in Jets&#8217; camp; GM decision pending</a> 8 hours ago </li><li ><a href="https://nationalfootballpost.com/report-lt-williams-wants-new-deal/" title="Report: LT Williams wants new deal">Report: LT Williams wants new deal</a> 8 hours ago </li></ul></div></aside><aside id="custom_html-7" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">FEATURES</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/caputi-2019-nfl-mock-draft-final/" title="Caputi: 2019 NFL Mock Draft (Final)">Caputi: 2019 NFL Mock Draft (Final)</a> April 25, 2019 </li><li ><a href="https://nationalfootballpost.com/super-bowl-53-betting-preview/" title="Super Bowl 53 Betting Preview – Best Props Picks, Trends">Super Bowl 53 Betting Preview – Best Props Picks, Trends</a> February 3, 2019 </li><li ><a href="https://nationalfootballpost.com/report-brady-defiantly-denies-retirement-question/" title="Report: Brady defiantly denies retirement question">Report: Brady defiantly denies retirement question</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/rams-cooks-responds-to-pats-chung-dig-in-fan-rally/" title="Rams&#8217; Cooks responds to Pats&#8217; Chung dig in fan rally">Rams&#8217; Cooks responds to Pats&#8217; Chung dig in fan rally</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/huge-crowd-sends-patriots-off-to-super-bowl/" title="Huge crowd sends Patriots off to Super Bowl">Huge crowd sends Patriots off to Super Bowl</a> January 27, 2019 </li></ul></div></aside></div><div class="fl-content fl-content-right col-md-9" itemscope="itemscope" itemtype="https://schema.org/Blog"> <article class="fl-post post-105436 post type-post status-publish format-standard hentry category-news tag-flm" id="fl-post-105436" itemscope itemtype="https://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> NFL notebook: Bell works out at Jets&#8217; minicamp </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-notebook-bell-works-out-at-jets-minicamp/"/><meta itemprop="datePublished" content="1 min ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" itemprop="text"> <h2><title>NFL notebook: Bell works out at Jets&#8217; minicamp</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/10586477.jpg" width="1100" height="733" alt="" title="Jan 28, 2018; Orlando, FL, USA; Pittsburgh Steelers running back Le'Veon Bell (26) against the NFC in the 2018 NFL Pro Bowl at Camping World Stadium. Mandatory Credit: Aaron Doster-USA TODAY Sports" data-portal-copyright="Aaron Doster-USA TODAY Sports"></p><p> Running back Le&#8217;Veon Bell took part in on-field workouts at the New York Jets&#8217; mandatory minicamp Tuesday after skipping most of the team&#8217;s spring voluntary workouts. </p> </p><p> He worked with the first-team offense in 11-on-11 drills in what was his first competitive football since January 2018, when he last played for the Pittsburgh Steelers. </p> </p><p> Bell sat out last season in a contract dispute and signed a four-year, $52.5 million contract with the Jets. </p> </p><p> &#8211;All-Pro Todd Gurley likely won&#8217;t be the workhorse out of the backfield for the Los Angeles Rams this season. </p> </p><p> NFL Network&#8217;s Ian Rapoport reported that the Rams are going to incorporate a number of running backs into the game in 2019, including Darrell Henderson, their third-round draft pick in April. </p> </p><p> &#8220;The days of Todd Gurley just being the straight-up, every-down bell cow are probably over, just based on his knee, his age, the position, the amount of carries he&#8217;s had.&#8221; Rapoport said. &#8220;This is a team that is clearly ready to spread the ball around.&#8221; </p> </p><p> &#8211;All-Pro linebacker NaVorro Bowman retired in San Francisco at age 31. </p> </p><p> Bowman earned four All-Pro selections and three Pro Bowl invitations during seven-plus seasons with the 49ers. Released during the 2017 season, he joined the Oakland Raiders and made 10 starts. He did not play in 2018. </p> </p><p> &#8211;Seven-time Pro Bowl left tackle Trent Williams skipped the start of mandatory minicamp as he seeks a new contract with the Washington Redskins. </p> </p><p> Williams has two years left on his existing contract worth $24 million, which includes base salaries of $11 million in 2019 and $12.5 million in 2020. </p> </p><p> Williams, who turns 31 before the start of training camp, underwent knee surgery last year and in April had an operation to remove a tumor from his head. </p> </p><p> &#8211;Cleveland Browns running back Duke Johnson showed up for the start of mandatory minicamp and restated his desire to be traded. </p> </p><p> Johnson was a no-show for the Browns&#8217; voluntary offseason program last month after reportedly telling the team he wanted to move on. </p> </p><p> General manager John Dorsey has said that second-year back Nick Chubb will be the starter in 2019 for the Browns, who also signed former Kansas City Chiefs running back Kareem Hunt in February. </p> </p><p> &#8211;Indianapolis Colts rookie center Javon Patterson tore his ACL during organized team activities and will miss the 2019 season. </p> </p><p> Coach Frank Reich confirmed the injury to Patterson, a seventh-round pick from Ole Miss. The Colts were expecting him to compete for a backup job on the interior of their offensive line. </p> </p><p> &#8211;The New England Patriots released tight end Austin Seferian-Jenkins, who signed a one-year deal in April and was expected to compete for a role after the offseason retirement of star Rob Gronkowski. </p> </p><p> Rapoport reported that Seferian-Jenkins is dealing with personal issues that will take him at least a month to resolve. </p> </p><p> &#8211;New England Patriots quarterback Tom Brady&#8217;s request to trademark the nickname &#8220;Tom Terrific&#8221; is getting slammed, particularly by two former New York Mets who were teammates of Hall of Fame pitcher Tom Seaver, Ed Kranepool and Art Shamsky. </p> </p><p> Seaver, who is now battling dementia, never filed for a trademark of the nickname that first was popularized by the &#8220;Tom Terrific&#8221; cartoon. According to a USA Today report, Brady&#8217;s company, TEB Capital, has filed for two &#8220;Tom Terrific&#8221; trademarks, one for trading cards, posters and signed photographs, and another for clothing. </p> </p><p> &#8211;Field Level Media</p></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-notebook-bell-works-out-at-jets-minicamp%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL notebook: Bell works out at Jets’ minicamp+https://nationalfootballpost.com/?p=105436" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL notebook: Bell works out at Jets&#8217; minicamp&#32;&#32;http://nfp.news/13nf" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13nf"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<div class="related-post"> <article style="overflow: hidden;margin-bottom: 30px;"> <header class="fl-post-header"> <h2 class="fl-post-title" itemprop="headline"> <a href="https://nationalfootballpost.com/mets-to-qb-brady-theres-only-one-tom-terrific/" rel="bookmark" title="Mets to QB Brady: There’s only one ‘Tom Terrific’">Mets to QB Brady: There’s only one ‘Tom Terrific’</a> </h2> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/mets-to-qb-brady-theres-only-one-tom-terrific/"/><meta itemprop="datePublished" content="1 min ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Mets to QB Brady: There&rsquo;s only one &lsquo;Tom Terrific&rsquo;</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12111114.jpg" width="1100" height="733" alt="" title="Feb 5, 2019; Boston, MA, USA; New England Patriots quarterback Tom Brady (12) holds up the Vince Lombardi Trophy during the Super Bowl LIII championship parade through downtown Boston. Mandatory Credit: Greg M. Cooper-USA TODAY Sports" data-portal-copyright="Greg M. Cooper-USA TODAY Sports"</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Mets to QB Brady: There&rsquo;s only one &lsquo;Tom Terrific&rsquo;</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12111114.jpg" width="1100" height="733" alt="" title="Feb 5, 2019; Boston, MA, USA; New England Patriots quarterback Tom Brady (12) holds up the Vince Lombardi Trophy during the Super Bowl LIII championship parade through downtown Boston. Mandatory Credit: Greg M. Cooper-USA TODAY Sports" data-portal-copyright="Greg M. Cooper-USA TODAY Sports"></p><p> New England Patriots quarterback Tom Brady&#8217;s request to trademark the nickname &#8220;Tom Terrific&#8221; is getting slammed, particularly by two former New York Mets who were teammates of Hall of Fame pitcher Tom Seaver. </p> </p><p> &#8220;Maybe it&#8217;s the new athlete,&#8221; former Mets first baseman Ed Kranepool said Tuesday in a USA Today story. &#8220;Maybe it&#8217;s the &lsquo;I&#8217; generation, who can only think about himself. He&#8217;s the greatest quarterback who ever lived and I supported him over the years, and any time I&#8217;m rooting in football, I&#8217;m rooting for Tom Brady. But when you ask me about Tom Terrific and having played behind a guy like (Seaver), there&#8217;s only one guy who can be called Tom Terrific and that&#8217;s him. But when you&#8217;re first in line, I think there should only be one of any kind. (Brady) is the second model.&#8221; </p> </p><p> Seaver, though, never filed for a trademark of the nickname that first was popularized by the &#8220;Tom Terrific&#8221; cartoon. Seaver is now battling dementia. </p> </p><p> According to the USA Today report, Brady&#8217;s company, TEB Capital, has filed for two &#8220;Tom Terrific&#8221; trademarks, one for trading cards, posters, and signed photographs, and another for clothing. </p> </p><p> On Monday, the Mets tweeted to the United States Patent and Trademark Office, making their point with a photo of the right-handed Seaver during his heyday with the Mets. </p> </p><p> &#8220;Hey @uspto, with all due respect to @TomBrady&#8230;There&#8217;s only one #TomTerrific to us. #LGM #Mets,&#8221; the tweet read. </p> </p> </p><p> A planned protest Tuesday at an Upper East Side restaurant in New York never gained momentum as, along with Kranepool and former Mets outfielder Art Shamsky, only a few fans showed up. But some reportedly grabbed Brady No. 12 jerseys and threw beans at them, then tossed them in a trash can. </p> </p><p> Shamsky, who played with the Miracle Mets team that included Kranepool and Seaver and won the 1969 World Series, interviewed Seaver in 2017 for a book he was writing about the aftermath of that team. </p> </p><p> &#8220;Tom Seaver will always be known as &#8216;Tom Terrific,'&#8221; Shamsky said Tuesday. &#8220;He will always be the face of the Mets, and one of the greatest pitchers who ever pitched in the major leagues.&#8221; </p> </p><p> Seaver won 311 games in a 20-year career. He was inducted into the National Baseball Hall of Fame with a then-record of appearing on 98.84 percent of voters&#8217; ballots. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Mets to QB Brady: There’s only one ‘Tom Terrific’');return false;"><span class="op-btn">Read More</span> <span class="count">342 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fmets-to-qb-brady-theres-only-one-tom-terrific%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Mets to QB Brady: There’s only one ‘Tom Terrific’+http://nfp.news/13nd" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Mets to QB Brady: There’s only one ‘Tom Terrific’&#32;&#32;http://nfp.news/13nd" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13nd"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/patriots-release-te-seferian-jenkins/" rel="bookmark" title="Patriots release TE Seferian-Jenkins">Patriots release TE Seferian-Jenkins</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/patriots-release-te-seferian-jenkins/"/><meta itemprop="datePublished" content="4 hours ago"/><meta itemprop="dateModified" content="4 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Patriots release TE Seferian-Jenkins</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/10466547-1.jpg" width="1100" height="733" alt="" title="Nov 12, 2017; Tampa, FL, USA; New York Jets tight end Austin Seferian-Jenkins (88) works out prior to the game at Raymond James Stadium. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports"/></p> <p> The New England Patriots released tight end Austin Seferian-Jenkins on</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Patriots release TE Seferian-Jenkins</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/10466547-1.jpg" width="1100" height="733" alt="" title="Nov 12, 2017; Tampa, FL, USA; New York Jets tight end Austin Seferian-Jenkins (88) works out prior to the game at Raymond James Stadium. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports"></p><p> The New England Patriots released tight end Austin Seferian-Jenkins on Tuesday. </p> </p><p> Seferian-Jenkins signed a one-year deal in April and was expected to compete for a role after the offseason retirement of star Rob Gronkowski. </p> </p><p> NFL Network&#8217;s Ian Rapoport reported that Seferian-Jenkins is dealing with personal issues that will take him at least a month to resolve. </p> </p><p> It is possible that New England will consider bringing him back in July prior to training camp. </p> </p><p> Seferian-Jenkins, 26, has caught 116 passes for 1,160 yards and 11 touchdowns in 43 games over five NFL seasons with the Tampa Bay Buccaneers (2014-16), New York Jets (2016-17) and Jacksonville Jaguars (2018). He was the Bucs&#8217; second-round pick in 2014. </p> </p><p> His best season came with the Jets in 2017 when he had career bests of 50 receptions and 357 yards. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Patriots release TE Seferian-Jenkins');return false;"><span class="op-btn">Read More</span> <span class="count">71 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpatriots-release-te-seferian-jenkins%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Patriots release TE Seferian-Jenkins+http://nfp.news/13n8" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Patriots release TE Seferian-Jenkins&#32;&#32;http://nfp.news/13n8" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13n8"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/pga-tour-adds-bermuda-to-2019-20-schedule/" rel="bookmark" title="PGA Tour adds Bermuda to 2019-20 schedule">PGA Tour adds Bermuda to 2019-20 schedule</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/pga-tour-adds-bermuda-to-2019-20-schedule/"/><meta itemprop="datePublished" content="4 hours ago"/><meta itemprop="dateModified" content="4 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>PGA Tour adds Bermuda to 2019-20 schedule</title></h2> <p></p> <p> The PGA Tour added the island of Bermuda to the 2019-20 schedule, with the Bermuda Championship making its debut from Oct. 31-Nov. 3, 2019. </p> <p> On Tuesday, the tour announced a five-year agreement through 2023 with the Bermuda Tourism Authority as the title sponsor</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>PGA Tour adds Bermuda to 2019-20 schedule</title></h2><p></p><p> The PGA Tour added the island of Bermuda to the 2019-20 schedule, with the Bermuda Championship making its debut from Oct. 31-Nov. 3, 2019. </p> </p><p> On Tuesday, the tour announced a five-year agreement through 2023 with the Bermuda Tourism Authority as the title sponsor of the tour&#8217;s first annual event on the Caribbean island. </p> </p><p> The tournament held at the Port Royal Golf Course will feature an anticipated field of 120 players and a $3 million purse, with 300 FedExCup points awarded to the champion. </p> </p><p> &#8220;We are excited to add the Bermuda Championship to the PGA Tour beginning next season,&#8221; executive vice president Ty Votaw said in a statement. &#8220;Bermuda is an appealing year-round destination, and the players will love visiting in the fall, plus we will be hosted by an outstanding golf course. It promises to be a wonderful opportunity to showcase Bermuda &#8212; a beautiful island destination that embodies genuine hospitality &#8212; to the world.&#8221; </p> </p><p> The Bermuda Championship will be played the same week as the World Golf Championships-HSBC Champions in Shanghai, China. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','PGA Tour adds Bermuda to 2019-20 schedule');return false;"><span class="op-btn">Read More</span> <span class="count">117 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpga-tour-adds-bermuda-to-2019-20-schedule%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=PGA Tour adds Bermuda to 2019-20 schedule+http://nfp.news/13n9" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=PGA Tour adds Bermuda to 2019-20 schedule&#32;&#32;http://nfp.news/13n9" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13n9"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/redskins-lt-williams-wants-new-deal/" rel="bookmark" title="Redskins LT Williams wants new deal">Redskins LT Williams wants new deal</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/redskins-lt-williams-wants-new-deal/"/><meta itemprop="datePublished" content="4 hours ago"/><meta itemprop="dateModified" content="4 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Redskins LT Williams wants new deal</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11921064-1.jpg" width="1100" height="733" alt="" title="Dec 30, 2018; Landover, MD, USA; Washington Redskins offensive tackle Trent Williams (71) and Redskins defensive end Jonathan Allen (93) run onto the field prior to the Redskins&#039; game against the Philadelphia Eagles at FedEx Field. The Eagles won 24-0. Mandatory Credit: Geoff Burke-USA</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Redskins LT Williams wants new deal</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11921064-1.jpg" width="1100" height="733" alt="" title="Dec 30, 2018; Landover, MD, USA; Washington Redskins offensive tackle Trent Williams (71) and Redskins defensive end Jonathan Allen (93) run onto the field prior to the Redskins' game against the Philadelphia Eagles at FedEx Field. The Eagles won 24-0. Mandatory Credit: Geoff Burke-USA TODAY Sports" data-portal-copyright="Geoff Burke-USA TODAY Sports"></p><p> Seven-time Pro Bowl left tackle Trent Williams skipped the start of mandatory minicamp Tuesday as he seeks a new contract with the Washington Redskins. </p> </p><p> Williams has two years left on his existing contract worth $24 million, which includes base salaries of $11 million in 2019 and $12.5 million in 2020. </p> </p><p> Redskins coach Jay Gruden confirmed Williams&#8217; absence. </p> </p><p> &#8220;We have been talking to Trent a little bit here and there. He is not here, you are right,&#8221; Gruden said. &#8220;As far as holding out for whatever reasons, that is between Trent and (senior vice president of football operations) Eric (Schaffer) and (team president) Bruce (Allen). Hopefully, we&#8217;ll get it all situated soon and get him back here.&#8221; </p> </p><p> Williams, who turns 31 before the start of training camp, underwent knee surgery last year and in April had an operation to remove a tumor from his head. </p> </p><p> Williams played a full 16-game regular-season schedule only twice in his first nine seasons. </p> </p><p> Gruden said the veteran lineman will be missed this week. </p> </p><p> &#8220;Well he is the best tackle in pro football,&#8221; Gruden said. &#8220;He&#8217;s a great player for us, a great leader. We would love to have him here without a doubt. I know his teammates support him and we support him without a doubt, but hopefully we get it situated where he comes back.&#8221; </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Redskins LT Williams wants new deal');return false;"><span class="op-btn">Read More</span> <span class="count">164 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fredskins-lt-williams-wants-new-deal%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Redskins LT Williams wants new deal+http://nfp.news/13na" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Redskins LT Williams wants new deal&#32;&#32;http://nfp.news/13na" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13na"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/report-patriots-releasing-te-seferian-jenkins/" rel="bookmark" title="Report: Patriots releasing TE Seferian-Jenkins">Report: Patriots releasing TE Seferian-Jenkins</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-patriots-releasing-te-seferian-jenkins/"/><meta itemprop="datePublished" content="4 hours ago"/><meta itemprop="dateModified" content="4 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Report: Patriots releasing TE Seferian-Jenkins</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/10466547.jpg" width="1100" height="733" alt="" title="Nov 12, 2017; Tampa, FL, USA; New York Jets tight end Austin Seferian-Jenkins (88) works out prior to the game at Raymond James Stadium. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports"/></p> <p> The New England Patriots are releasing tight end Austin</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Report: Patriots releasing TE Seferian-Jenkins</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/10466547.jpg" width="1100" height="733" alt="" title="Nov 12, 2017; Tampa, FL, USA; New York Jets tight end Austin Seferian-Jenkins (88) works out prior to the game at Raymond James Stadium. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports"></p><p> The New England Patriots are releasing tight end Austin Seferian-Jenkins, ESPN&#8217;s Field Yates reported Tuesday. </p> </p><p> Seferian-Jenkins signed a one-year deal in April and was expected to compete for a role after the offseason retirement of star Rob Gronkowski. </p> </p><p> NFL Network&#8217;s Ian Rapoport reported that Seferian-Jenkins is dealing with personal issues that will take him at least a month to resolve. </p> </p><p> Seferian-Jenkins wasn&#8217;t at the Patriots&#8217; mandatory minicamp on Tuesday, not so surprising after coach Bill Belichick said all the players required to show were in attendance. </p> </p><p> It is possible that New England will consider bringing him back in July prior to training camp. </p> </p><p> Seferian-Jenkins, 26, has caught 116 passes for 1,160 yards and 11 touchdowns in 43 games over five NFL seasons with the Tampa Bay Buccaneers (2014-16), New York Jets (2016-17) and Jacksonville Jaguars (2018). He was the Bucs&#8217; second-round pick in 2014. </p> </p><p> His best season came with the Jets in 2017 when he had career bests of 50 receptions and 357 yards. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Report: Patriots releasing TE Seferian-Jenkins');return false;"><span class="op-btn">Read More</span> <span class="count">102 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-patriots-releasing-te-seferian-jenkins%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Patriots releasing TE Seferian-Jenkins+http://nfp.news/13nb" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Patriots releasing TE Seferian-Jenkins&#32;&#32;http://nfp.news/13nb" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13nb"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/all-pro-lb-bowman-retires-at-31/" rel="bookmark" title="All-Pro LB Bowman retires at 31">All-Pro LB Bowman retires at 31</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/all-pro-lb-bowman-retires-at-31/"/><meta itemprop="datePublished" content="4 hours ago"/><meta itemprop="dateModified" content="4 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>All-Pro LB Bowman retires at 31</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/10251546.jpg" width="1100" height="733" alt="" title="Aug 31, 2017; Santa Clara, CA, USA; San Francisco 49ers inside linebacker NaVorro Bowman walks on the field before the start of the third quarter against the Los Angeles Chargers at Levi&#039;s Stadium. Mandatory Credit: Cary Edmondson-USA TODAY Sports" data-portal-copyright="Cary Edmondson-USA TODAY Sports"/></p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>All-Pro LB Bowman retires at 31</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/10251546.jpg" width="1100" height="733" alt="" title="Aug 31, 2017; Santa Clara, CA, USA; San Francisco 49ers inside linebacker NaVorro Bowman walks on the field before the start of the third quarter against the Los Angeles Chargers at Levi's Stadium. Mandatory Credit: Cary Edmondson-USA TODAY Sports" data-portal-copyright="Cary Edmondson-USA TODAY Sports"></p><p> All-Pro linebacker NaVorro Bowman retired Tuesday in San Francisco at age 31. </p> </p><p> Bowman earned four All-Pro selections and three Pro Bowl invitations during seven-plus seasons with the 49ers. Released during the 2017 season, he joined the Oakland Raiders and made 10 starts. He did not play in 2018. </p> </p><p> &#8220;NaVorro gave his heart and soul to this team for the last eight years, and for that we are all extremely grateful,&#8221; 49ers general manager John Lynch said in a team press release. &#8220;During that time, NaVorro was a key component of one of the best teams in the league, and his passion for the game allowed him to quickly become a favorite of our faithful fans.&#8221; </p> </p><p> San Francisco&#8217;s third-round pick in 2010 out of Penn State, Bowman registered more than 100 tackles in five of his eight seasons. </p> </p><p> After missing the 2014 season with a knee injury, Bowman returned to lead the NFL with 154 tackles in 2015. </p> </p><p> Bowman&#8217;s final numbers included 798 tackles, 14 sacks, five interceptions and six fumble recoveries in 99 games. </p> </p><p> He announced his retirement at San Francisco&#8217;s team headquarters. The 49ers said they were unable to sign Bowman to a ceremonial one-day contract because their roster is currently at capacity and it would have required a transaction. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','All-Pro LB Bowman retires at 31');return false;"><span class="op-btn">Read More</span> <span class="count">147 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fall-pro-lb-bowman-retires-at-31%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=All-Pro LB Bowman retires at 31+http://nfp.news/13nc" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=All-Pro LB Bowman retires at 31&#32;&#32;http://nfp.news/13nc" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13nc"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/browns-rb-johnson-still-wants-to-be-traded/" rel="bookmark" title="Browns RB Johnson still wants to be traded">Browns RB Johnson still wants to be traded</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/browns-rb-johnson-still-wants-to-be-traded/"/><meta itemprop="datePublished" content="8 hours ago"/><meta itemprop="dateModified" content="8 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Browns RB Johnson still wants to be traded</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11892286.jpg" width="1100" height="743" alt="" title="Dec 23, 2018; Cleveland, OH, USA; Cleveland Browns running back Duke Johnson (29) runs the ball against the Cincinnati Bengals during the first quarter at FirstEnergy Stadium. Mandatory Credit: Scott R. Galvin-USA TODAY Sports" data-portal-copyright="Scott R. Galvin-USA TODAY Sports"/></p> <p> Cleveland</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Browns RB Johnson still wants to be traded</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11892286.jpg" width="1100" height="743" alt="" title="Dec 23, 2018; Cleveland, OH, USA; Cleveland Browns running back Duke Johnson (29) runs the ball against the Cincinnati Bengals during the first quarter at FirstEnergy Stadium. Mandatory Credit: Scott R. Galvin-USA TODAY Sports" data-portal-copyright="Scott R. Galvin-USA TODAY Sports"></p><p> Cleveland Browns running back Duke Johnson showed up for the start of mandatory minicamp Tuesday and restated his desire to be traded. </p> </p><p> Johnson was a no-show for the Browns&#8217; voluntary offseason program last month after reportedly telling the team he wanted to move on. </p> </p><p> General manager John Dorsey has said that second-year back Nick Chubb will be the starter in 2019 for the Browns, who also signed former Kansas City Chiefs running back Kareem Hunt in February. </p> </p><p> &#8220;I understand the nature of the business. I understand John Dorsey&#8217;s job is to do what&#8217;s best for the team and the organization. If that&#8217;s getting rid of me for a bigger piece and a better piece, then I&#8217;m OK with it,&#8221; Johnson told reporters Tuesday. &#8220;Like I said before, my trade request was to meet them at a middle ground.&#8221; </p> </p><p> The New York Jets, Houston Texans and Philadelphia Eagles reportedly have expressed interest in the 25-year-old Johnson, Cleveland&#8217;s third-round pick in 2015. </p> </p><p> Johnson signed a three-year, $15.6 million contract ($7.8 million guaranteed) extension last summer that runs through the 2021 season. </p> </p><p> He has played in all 64 games since entering the league, rushing for 1,286 yards and five touchdowns and catching 235 passes for 2,170 yards and eight scores. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Browns RB Johnson still wants to be traded');return false;"><span class="op-btn">Read More</span> <span class="count">149 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fbrowns-rb-johnson-still-wants-to-be-traded%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Browns RB Johnson still wants to be traded+http://nfp.news/13n3" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Browns RB Johnson still wants to be traded&#32;&#32;http://nfp.news/13n3" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13n3"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/bell-takes-part-in-jets-camp-gm-decision-pending/" rel="bookmark" title="Bell takes part in Jets&#8217; camp; GM decision pending">Bell takes part in Jets&#8217; camp; GM decision pending</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/bell-takes-part-in-jets-camp-gm-decision-pending/"/><meta itemprop="datePublished" content="8 hours ago"/><meta itemprop="dateModified" content="8 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Bell takes part in Jets' camp; GM decision pending</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12246900.jpg" width="1100" height="732" alt="" title="Feb 27, 2019; Indianapolis, IN, USA; New York Jets head coach Adam Gase speaks to media during the 2019 NFL Combine at Indianapolis Convention Center. Mandatory Credit: Trevor Ruszkowski-USA TODAY Sports" data-portal-copyright="Trevor Ruszkowski-USA TODAY Sports"/></p> <p> Running back Le'Veon Bell</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Bell takes part in Jets&#8217; camp; GM decision pending</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12246900.jpg" width="1100" height="732" alt="" title="Feb 27, 2019; Indianapolis, IN, USA; New York Jets head coach Adam Gase speaks to media during the 2019 NFL Combine at Indianapolis Convention Center. Mandatory Credit: Trevor Ruszkowski-USA TODAY Sports" data-portal-copyright="Trevor Ruszkowski-USA TODAY Sports"></p><p> Running back Le&#8217;Veon Bell took part in on-field workouts Tuesday at the New York Jets&#8217; mandatory minicamp after skipping most of the team&#8217;s spring voluntary workouts. </p> </p><p> He worked with the first-team offense in 11-on-11 drills in what was his first competitive football since January 2018, when he last played for the Pittsburgh Steelers. </p> </p><p> Bell sat out last season in a contract dispute and signed a four-year, $52.5 million contract with the Jets. </p> </p><p> Head coach Adam Gase said Bell wouldn&#8217;t have a full workload because of the long layoff from team drills. </p> </p><p> Before practice Tuesday, Gase updated reporters about the search for the team&#8217;s general manager. </p> </p><p> The Jets have interviewed Joe Douglas, Philadelphia Eagles vice president of player personnel; Scott Fitterer, the Seattle Seahawks&#8217; co-director of player personnel; Terry Fontenot, the New Orleans Saints&#8217; director of pro scouting; and Champ Kelly, the Chicago Bears&#8217; assistant director of player personnel. </p> </p><p> New York is seeking a replacement for Mike Maccagnan, who was fired on May 15 after four seasons in the role. Gase was among the staff members who joined CEO Christopher Johnson in interviews. </p> </p><p> &#8220;We went through some interviews this weekend,&#8221; Gase said. &#8220;Those guys did a great job. It was a great process that we&#8217;ve gone through so far. We&#8217;ll just keep huddling up and figuring out where we&#8217;re at with that until Christopher is ready to make a decision. Then once that happens, you guys will obviously know about that quickly.&#8221; </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Bell takes part in Jets&#8217; camp; GM decision pending');return false;"><span class="op-btn">Read More</span> <span class="count">190 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fbell-takes-part-in-jets-camp-gm-decision-pending%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Bell takes part in Jets’ camp; GM decision pending+http://nfp.news/13n2" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Bell takes part in Jets&#8217; camp; GM decision pending&#32;&#32;http://nfp.news/13n2" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13n2"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/report-lt-williams-wants-new-deal/" rel="bookmark" title="Report: LT Williams wants new deal">Report: LT Williams wants new deal</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-lt-williams-wants-new-deal/"/><meta itemprop="datePublished" content="8 hours ago"/><meta itemprop="dateModified" content="8 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Report: LT Williams wants new deal</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11921064.jpg" width="1100" height="733" alt="" title="Dec 30, 2018; Landover, MD, USA; Washington Redskins offensive tackle Trent Williams (71) and Redskins defensive end Jonathan Allen (93) run onto the field prior to the Redskins&#039; game against the Philadelphia Eagles at FedEx Field. The Eagles won 24-0. Mandatory Credit: Geoff Burke-USA</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Report: LT Williams wants new deal</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11921064.jpg" width="1100" height="733" alt="" title="Dec 30, 2018; Landover, MD, USA; Washington Redskins offensive tackle Trent Williams (71) and Redskins defensive end Jonathan Allen (93) run onto the field prior to the Redskins' game against the Philadelphia Eagles at FedEx Field. The Eagles won 24-0. Mandatory Credit: Geoff Burke-USA TODAY Sports" data-portal-copyright="Geoff Burke-USA TODAY Sports"></p><p> Washington Redskins left tackle Trent Williams is not participating in mandatory minicamp to make a statement about his contract, NFL Network reported Tuesday. </p> </p><p> Williams has two years left on his existing contract worth $24 million, which includes base salaries of $11 million in 2019 and $12.5 million in 2020. </p> </p><p> Williams turns 31 before the start of training camp. </p> </p><p> He underwent knee surgery last year and in April had an operation to remove a tumor from his head. </p> </p><p> Williams has played a full 16-game regular-season schedule only twice in his career. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Report: LT Williams wants new deal');return false;"><span class="op-btn">Read More</span> <span class="count">33 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-lt-williams-wants-new-deal%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: LT Williams wants new deal+http://nfp.news/13n4" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: LT Williams wants new deal&#32;&#32;http://nfp.news/13n4" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13n4"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/nt-harrison-cb-slay-to-stay-away-from-lions/" rel="bookmark" title="NT Harrison, CB Slay to stay away from Lions">NT Harrison, CB Slay to stay away from Lions</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nt-harrison-cb-slay-to-stay-away-from-lions/"/><meta itemprop="datePublished" content="8 hours ago"/><meta itemprop="dateModified" content="8 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>NT Harrison, CB Slay to stay away from Lions</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12052813.jpg" width="1100" height="733" alt="" title="Sep 23, 2018; Detroit, MI, USA; Detroit Lions defensive back Darius Slay (23) looks up before the game against the New England Patriots at Ford Field. Mandatory Credit: Raj Mehta-USA TODAY Sports" data-portal-copyright="Raj Mehta-USA TODAY Sports"/></p> <p> Contract squabbles with</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>NT Harrison, CB Slay to stay away from Lions</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12052813.jpg" width="1100" height="733" alt="" title="Sep 23, 2018; Detroit, MI, USA; Detroit Lions defensive back Darius Slay (23) looks up before the game against the New England Patriots at Ford Field. Mandatory Credit: Raj Mehta-USA TODAY Sports" data-portal-copyright="Raj Mehta-USA TODAY Sports"></p><p> Contract squabbles with the Detroit Lions will keep two star defenders away from mandatory summer minicamp. </p> </p><p> Cornerback Darius Slay posted to Twitter that he&#8217;ll be a bystander despite having two years remaining on his contract. Slay did not participate in volunteer workouts and clapped back at a social media critic who said he should honor his existing deal. </p> </p> </p><p> Named a first-team All-Pro in 2017, Slay signed a four-year extension in 2016 and is scheduled to make $12.55 million in base salary in 2019. He is due $10 million next season. </p> </p><p> Harrison was acquired from the New York Giants last season and has two years left on his contract. His base salary in 2019 is $6.75 million and he&#8217;s owed $9 million for 2020. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','NT Harrison, CB Slay to stay away from Lions');return false;"><span class="op-btn">Read More</span> <span class="count">66 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnt-harrison-cb-slay-to-stay-away-from-lions%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NT Harrison, CB Slay to stay away from Lions+http://nfp.news/13n5" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NT Harrison, CB Slay to stay away from Lions&#32;&#32;http://nfp.news/13n5" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13n5"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/colts-rookie-c-patterson-tears-acl-in-practice/" rel="bookmark" title="Colts rookie C Patterson tears ACL in practice">Colts rookie C Patterson tears ACL in practice</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/colts-rookie-c-patterson-tears-acl-in-practice/"/><meta itemprop="datePublished" content="8 hours ago"/><meta itemprop="dateModified" content="8 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Colts rookie C Patterson tears ACL in practice</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12255362.jpg" width="1100" height="733" alt="" title="Feb 28, 2019; Indianapolis, IN, USA; Mississippi offensive lineman Javon Patterson (OL43) speaks to the media during the 2019 NFL Combine at the Indianapolis Convention Center. Mandatory Credit: Brian Spurlock-USA TODAY Sports" data-portal-copyright="Brian Spurlock-USA TODAY Sports"/></p> <p> Indianapolis Colts rookie center</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Colts rookie C Patterson tears ACL in practice</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12255362.jpg" width="1100" height="733" alt="" title="Feb 28, 2019; Indianapolis, IN, USA; Mississippi offensive lineman Javon Patterson (OL43) speaks to the media during the 2019 NFL Combine at the Indianapolis Convention Center. Mandatory Credit: Brian Spurlock-USA TODAY Sports" data-portal-copyright="Brian Spurlock-USA TODAY Sports"></p><p> Indianapolis Colts rookie center Javon Patterson tore his ACL during organized team activities Tuesday and will miss the 2019 season. </p> </p><p> Head coach Frank Reich confirmed the injury to Patterson, a seventh-round pick from Ole Miss. </p> </p><p> Patterson, 21, started all 36 games in his last three seasons with the Rebels. The 6-foot-3, 307-pound lineman saw action at left guard, right guard and center. </p> </p><p> The Colts were expecting Patterson to compete for a backup job on the interior of their offensive line this season. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Colts rookie C Patterson tears ACL in practice');return false;"><span class="op-btn">Read More</span> <span class="count">30 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fcolts-rookie-c-patterson-tears-acl-in-practice%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Colts rookie C Patterson tears ACL in practice+http://nfp.news/13n6" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Colts rookie C Patterson tears ACL in practice&#32;&#32;http://nfp.news/13n6" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13n6"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/report-rams-reducing-gurleys-role-in-2019/" rel="bookmark" title="Report: Rams reducing Gurley&#8217;s role in 2019">Report: Rams reducing Gurley&#8217;s role in 2019</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-rams-reducing-gurleys-role-in-2019/"/><meta itemprop="datePublished" content="12 hours ago"/><meta itemprop="dateModified" content="12 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Report: Rams reducing Gurley's role in 2019</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12143996.jpg" width="1100" height="821" alt="" title="Feb 3, 2019; Atlanta, GA, USA; Los Angeles Rams running back Todd Gurley (30) runs against New England Patriots strong safety Patrick Chung (23) in the third quarter in Super Bowl LIII at Mercedes-Benz Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Report: Rams reducing Gurley&#8217;s role in 2019</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12143996.jpg" width="1100" height="821" alt="" title="Feb 3, 2019; Atlanta, GA, USA; Los Angeles Rams running back Todd Gurley (30) runs against New England Patriots strong safety Patrick Chung (23) in the third quarter in Super Bowl LIII at Mercedes-Benz Stadium. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports"></p><p> All-Pro Todd Gurley likely won&#8217;t be the workhorse out of the backfield for the Los Angeles Rams this season. </p> </p><p> NFL Network&#8217;s Ian Rapoport reported that the Rams are going to incorporate a number of running backs into the game in 2019, including Darrell Henderson, their third-round draft pick in April. </p> </p><p> &#8220;The days of Todd Gurley just being the straight-up, every-down bell cow are probably over, just based on his knee, his age, the position, the amount of carries he&#8217;s had.&#8221; Rapoport said. &#8220;&#8230;This is a team that is clearly ready to spread the ball around.&#8221; </p> </p><p> Gurley, entering his fifth season, has carried the ball an average of 260.5 times in each of his first four seasons. In 2018, he missed the final two games of the regular season but still ran 256 times &#8211; good for fourth in the NFL. He turns 25 in August. </p> </p><p> The running back saw limited action in the NFC championship game and in Super Bowl LIII, carrying the ball just 15 times combined. He hasn&#8217;t participated in on-field workouts during offseason practices. </p> </p><p> &#8220;Of course, Gurley&#8217;s knee, the wear and tear on that knee, the surgically repaired knee, is something that everyone knows has been concerning to the team for some time,&#8221; Rapoport said. &#8220;All they really want is for Gurley to come back when the season begins when it&#8217;s really time to go to be 100 percent. What they don&#8217;t want is to have all those questions they had leading up the Super Bowl repeat before Week 1.&#8221; </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Report: Rams reducing Gurley&#8217;s role in 2019');return false;"><span class="op-btn">Read More</span> <span class="count">194 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-rams-reducing-gurleys-role-in-2019%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Rams reducing Gurley’s role in 2019+http://nfp.news/13mz" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Rams reducing Gurley&#8217;s role in 2019&#32;&#32;http://nfp.news/13mz" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13mz"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/nfl-notebook-panthers-reportedly-land-dt-mccoy/" rel="bookmark" title="NFL notebook: Panthers reportedly land DT McCoy">NFL notebook: Panthers reportedly land DT McCoy</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-notebook-panthers-reportedly-land-dt-mccoy/"/><meta itemprop="datePublished" content="23 hours ago"/><meta itemprop="dateModified" content="23 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>NFL notebook: Panthers reportedly land DT McCoy</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12098076.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Atlanta, GA, USA; Gerald McCoy during red carpet arrivals for the NFL Honors show at the Fox Theatre. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"/></p> <p> Free agent defensive tackle Gerald McCoy and the Carolina Panthers</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>NFL notebook: Panthers reportedly land DT McCoy</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12098076.jpg" width="1100" height="733" alt="" title="Feb 2, 2019; Atlanta, GA, USA; Gerald McCoy during red carpet arrivals for the NFL Honors show at the Fox Theatre. Mandatory Credit: Dale Zanine-USA TODAY Sports" data-portal-copyright="Dale Zanine-USA TODAY Sports"></p><p> Free agent defensive tackle Gerald McCoy and the Carolina Panthers agreed to a one-year deal on Monday, multiple media outlets reported. </p> </p><p> The contract will pay as much as $10.25 million and includes a $4 million signing bonus, according to ESPN&#8217;s Adam Schefter. The Charlotte Observer cited sources indicating that the deal is worth a minimum of $8.5 million. </p> </p><p> McCoy, a six-time Pro Bowl selection, had visited the Panthers, Cleveland Browns and Baltimore Ravens. Schefter said quarterback Cam Newton helped to sway him toward the Panthers, adding the chance to play his former team &#8212; the Tampa Bay Buccaneers &#8212; twice a year could have been an incentive. </p> </p><p> McCoy, the third overall pick in the 2010 NFL Draft, was released by the Buccaneers on May 20 with three years left on his contract. The deal called for him to make $13 million in base pay this season. The original contract was for six years and $95.2 million. </p> </p><p> &#8211;NFL commissioner Roger Goodell restated his support for a new stadium in Buffalo. </p> </p><p> &#8220;I want to make sure this franchise remains competitive and stable,&#8221; Goodell said, per The Athletic. The Bills play at New Era Field (capacity 71,608), formerly known as Rich Stadium and Ralph Wilson Stadium, which opened in 1973 in Orchard Park, N.Y., and underwent renovations in 1998 and 2013. </p> </p><p> Goodell made the comment while attending the Jim Kelly Celebrity Classic golf tournament in Batavia, N.Y. He expressed a similar sentiment three years ago at the same charity event hosted by the Hall of Fame quarterback. </p> </p><p> &#8211;The Jacksonville Jaguars added veteran Terrelle Pryor to their inexperienced receivers group Monday. </p> </p><p> Pryor, who turns 30 later this month, has caught 115 passes for 1,563 yards and seven touchdowns since originally entering the league as an Oakland Raiders quarterback in 2011. </p> </p><p> Most of that production came with the Cleveland Browns in 2016, when the former Ohio State star tallied 77 receptions for 1,007 yards and four touchdowns. In the two seasons after that breakout year, Pryor caught only 36 balls for 492 yards and three TDs in 17 games with the Washington Redskins, New York Jets and Buffalo. </p> </p><p> &#8211;Wide receiver Adam Humphries signed a four-year, $36 million with the Tennessee Titans in March, passing up the chance to play for the New England Patriots. In doing so, he chose to catch passes from 25-year-old Marcus Mariota, entering his fifth season, instead of six-time Super Bowl champion Tom Brady. </p> </p><p> &#8220;Obviously, he&#8217;s the G.O.A.T. That&#8217;s that simple,&#8221; Humphries told The Athletic about Brady. &#8220;But there&#8217;s so much that factors into a decision. It was a four-year deal. Who knows how many (years) he&#8217;s got left? There&#8217;s a lot that goes into it.&#8221; </p> </p><p> Brady, who turns 42 is August, is entering his 20th season in New England. He has said he hopes to play until age 45. </p> </p><p> &#8211;Seattle Seahawks quarterback Russell Wilson has played seven seasons in the NFL, but in an interview with Michael Silver of NFL.com, he said he can see himself playing 15 more seasons, or until age 45. </p> </p><p> &#8220;I&#8217;m just getting started. And I believe this team is just getting started. So, I think that we can do anything that we set our minds out to do,&#8221; Wilson said. </p> </p><p> Wilson signed a four-year, $140 million contract extension with the Seahawks in April, making him the highest-paid player in the NFL at $35 million per year. The deal included a $65 million signing bonus. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','NFL notebook: Panthers reportedly land DT McCoy');return false;"><span class="op-btn">Read More</span> <span class="count">496 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-notebook-panthers-reportedly-land-dt-mccoy%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL notebook: Panthers reportedly land DT McCoy+http://nfp.news/13mv" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL notebook: Panthers reportedly land DT McCoy&#32;&#32;http://nfp.news/13mv" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13mv"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/wr-humphries-says-bradys-age-part-of-passing-on-pats/" rel="bookmark" title="WR Humphries says Brady&#8217;s age part of passing on Pats">WR Humphries says Brady&#8217;s age part of passing on Pats</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/wr-humphries-says-bradys-age-part-of-passing-on-pats/"/><meta itemprop="datePublished" content="2019-06-03"/><meta itemprop="dateModified" content="2019-06-03"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>WR Humphries says Brady's age part of passing on Pats</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11992995.jpg" width="1100" height="703" alt="" title="Dec 30, 2018; Tampa, FL, USA; Tampa Bay Buccaneers wide receiver Adam Humphries (10) during the second quarter at Raymond James Stadium. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports"/></p> <p> Wide receiver Adam Humphries signed a</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>WR Humphries says Brady&#8217;s age part of passing on Pats</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11992995.jpg" width="1100" height="703" alt="" title="Dec 30, 2018; Tampa, FL, USA; Tampa Bay Buccaneers wide receiver Adam Humphries (10) during the second quarter at Raymond James Stadium. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports"></p><p> Wide receiver Adam Humphries signed a four-year, $36 million with the Tennessee Titans in March, passing up the chance to play for the New England Patriots. </p> </p><p> In doing so, he chose to catch passes from 25-year-old Marcus Mariota, entering his fifth season, instead of six-time Super Bowl champion Tom Brady. </p> </p><p> &#8220;Obviously, he&#8217;s the G.O.A.T. That&#8217;s that simple,&#8221; Humphries told The Athletic about Brady. &#8220;But there&#8217;s so much that factors into a decision. It was a four-year deal. Who knows how many (years) he&#8217;s got left? There&#8217;s a lot that goes into it.&#8221; </p> </p><p> Brady, who turns 42 is August, is entering his 20th season in New England. He has said he hopes to play until age 45. </p> </p><p> &#8220;Obviously the chance to play with him would have been awesome, but a lot of things factor into that decision,&#8221; Humphries said. &#8220;Ultimately, I thought this was coming here to a team that was on the rise and with young talent on the offense and a really good defense. They&#8217;d had a taste of the playoffs. I felt like my need at the slot position was great. I felt like I could really contribute and start something new here.&#8221; </p> </p><p> Humphries, said other factors influenced his decision. </p> </p><p> &#8220;There were a ton of pros and not a lot of cons,&#8221; Humphries said. &#8220;You have to look at both situations and a quality of life and where you&#8217;re living, state taxes. A lot of things go into it when you&#8217;re talking with your agents and families and stuff about it. At the end of the day, my heart wanted to be in Tennessee.&#8221; </p> </p><p> Humphries, who turns 26 this month, signed with the Tampa Bay Buccaneers in 2015 as an undrafted free agent from Clemson. In four years with the team, he appeared in 60 games (17 starts), catching 219 passes for 2,329 years and nine touchdowns. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','WR Humphries says Brady&#8217;s age part of passing on Pats');return false;"><span class="op-btn">Read More</span> <span class="count">256 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fwr-humphries-says-bradys-age-part-of-passing-on-pats%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=WR Humphries says Brady’s age part of passing on Pats+http://nfp.news/13mt" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=WR Humphries says Brady&#8217;s age part of passing on Pats&#32;&#32;http://nfp.news/13mt" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13mt"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/reports-panthers-sign-dt-mccoy/" rel="bookmark" title="Reports: Panthers sign DT McCoy">Reports: Panthers sign DT McCoy</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/reports-panthers-sign-dt-mccoy/"/><meta itemprop="datePublished" content="2019-06-03"/><meta itemprop="dateModified" content="2019-06-03"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Reports: Panthers sign DT McCoy</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11313209.jpg" width="1100" height="733" alt="" title="Sep 24, 2018; Tampa, FL, USA; Tampa Bay Buccaneers defensive tackle Gerald McCoy (93) reacts during the first half against the Pittsburgh Steelers at Raymond James Stadium. Mandatory Credit: Douglas DeFelice-USA TODAY Sports" data-portal-copyright="Douglas DeFelice-USA TODAY Sports"/></p> <p> Free agent defensive tackle Gerald McCoy</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Reports: Panthers sign DT McCoy</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11313209.jpg" width="1100" height="733" alt="" title="Sep 24, 2018; Tampa, FL, USA; Tampa Bay Buccaneers defensive tackle Gerald McCoy (93) reacts during the first half against the Pittsburgh Steelers at Raymond James Stadium. Mandatory Credit: Douglas DeFelice-USA TODAY Sports" data-portal-copyright="Douglas DeFelice-USA TODAY Sports"></p><p> Free agent defensive tackle Gerald McCoy and the Carolina Panthers agreed to a one-year deal on Monday, multiple media outlets reported. </p> </p><p> The contract will pay as much as $10.25 million and includes a $4 million signing bonus, according to ESPN&#8217;s Adam Schefter. The Charlotte Observer cited sources indicating that the deal is worth a minimum of $8.5 million. </p> </p><p> McCoy, a six-time Pro Bowl selection, had visited the Panthers, Cleveland Browns and Baltimore Ravens. Schefter said quarterback Cam Newton helped to sway him toward the Panthers, adding the chance to play his former team &#8212; the Tampa Bay Buccaneers &#8212; twice a year could have been an incentive. </p> </p><p> McCoy, the third overall pick in the 2010 NFL Draft, was released by the Buccaneers on May 20 with three years left on his contract. The deal called for him to make $13 million in base pay this season. The original contract was for six years and $95.2 million. </p> </p><p> The Tampa Bay Times reported McCoy, 31, drew bids from 10 teams with offers as high as $11 million annually. </p> </p><p> Carolina freed up $9 million in salary-cap space in the past week by releasing offensive tackle Matt Kalil and restructuring the contract of wide receiver Torrey Smith, Schefter reported. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Reports: Panthers sign DT McCoy');return false;"><span class="op-btn">Read More</span> <span class="count">142 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freports-panthers-sign-dt-mccoy%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Reports: Panthers sign DT McCoy+http://nfp.news/13mu" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Reports: Panthers sign DT McCoy&#32;&#32;http://nfp.news/13mu" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13mu"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/cantlay-now-among-u-s-open-betting-favorites/" rel="bookmark" title="Cantlay now among U.S. Open betting favorites">Cantlay now among U.S. Open betting favorites</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/cantlay-now-among-u-s-open-betting-favorites/"/><meta itemprop="datePublished" content="2019-06-03"/><meta itemprop="dateModified" content="2019-06-03"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Cantlay now among U.S. Open betting favorites</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12820438.jpg" width="1100" height="823" alt="" title="Jun 2, 2019; Dublin, OH, USA; Jack Nicklaus presents the trophy to Patrick Cantlay after winning the 2019 Memorial golf tournament at Muirfield Village Golf Club. Mandatory Credit: Joe Maiorana-USA TODAY Sports" data-portal-copyright="Joe Maiorana-USA TODAY Sports"/></p> <p> Patrick Cantlay realized several tangible</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Cantlay now among U.S. Open betting favorites</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12820438.jpg" width="1100" height="823" alt="" title="Jun 2, 2019; Dublin, OH, USA; Jack Nicklaus presents the trophy to Patrick Cantlay after winning the 2019 Memorial golf tournament at Muirfield Village Golf Club. Mandatory Credit: Joe Maiorana-USA TODAY Sports" data-portal-copyright="Joe Maiorana-USA TODAY Sports"></p><p> Patrick Cantlay realized several tangible benefits from his second career PGA Tour victory at the Memorial Tournament on Sunday. </p> </p><p> Along with a cool $1.638 million winner&#8217;s check and guaranteed entries into all the marquee events over the next year, Cantlay also vaulted six spots to No. 8 in the official world golf rankings &#8212; a career high for the 27-year-old. </p> </p><p> With that success on a big stage against a tough field comes respect from oddsmakers. </p> </p><p> Cantlay entered the Memorial in good form, having tied for ninth at the Masters and then tying for third at the RBC Heritage and the PGA Championship in his past four tournaments. </p> </p><p> He arrived in Dublin, Ohio, last week listed at 25/1 by Sportsbetting.ag and 28/1 by Sportsbook.ag to win the 2019 U.S. Open later this month. After setting a Sunday scoring record in claiming the Memorial title, Cantlay is now listed at 18/1 by Sportsbetting.ag and 20/1 by Sportsbook.ag and Bovada.lv. </p> </p><p> Four-time major champion Brooks Koepka remains the betting favorite at 6/1 by Sportsbetting.ag and 11/2 by Sportsbook.ag, while Dustin Johnson (7.5/1 and 7/1) is close behind. Tiger Woods entered Sunday&#8217;s round at 10/1 by both sportsbooks and remained there following his closing 67 to charge into the top 10. </p> </p><p> Martin Kaymer, the overnight Memorial leader who stumbled to a third-place finish with a 72 on Sunday, still improved from 100/1 to 66/1 by Sportsbook.ag. The German, who finished tied for 51st at the Masters and missed the cut at the PGA Championship, also vaulted 89 spots to No. 97 in the world golf rankings. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Cantlay now among U.S. Open betting favorites');return false;"><span class="op-btn">Read More</span> <span class="count">202 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fcantlay-now-among-u-s-open-betting-favorites%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Cantlay now among U.S. Open betting favorites+http://nfp.news/13mr" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Cantlay now among U.S. Open betting favorites&#32;&#32;http://nfp.news/13mr" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13mr"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/goal-for-seahawks-qb-wilson-play-15-more-years/" rel="bookmark" title="Goal for Seahawks QB Wilson: Play 15 more years">Goal for Seahawks QB Wilson: Play 15 more years</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/goal-for-seahawks-qb-wilson-play-15-more-years/"/><meta itemprop="datePublished" content="2019-06-03"/><meta itemprop="dateModified" content="2019-06-03"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Goal for Seahawks QB Wilson: Play 15 more years</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11919861.jpg" width="1100" height="733" alt="" title="Dec 30, 2018; Seattle, WA, USA; Seattle Seahawks quarterback Russell Wilson (3) throws a lateral pass against the Arizona Cardinals during the first quarter at CenturyLink Field. Mandatory Credit: Joe Nicholson-USA TODAY Sports" data-portal-copyright="Joe Nicholson-USA TODAY Sports"/></p> <p> Seattle Seahawks</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Goal for Seahawks QB Wilson: Play 15 more years</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11919861.jpg" width="1100" height="733" alt="" title="Dec 30, 2018; Seattle, WA, USA; Seattle Seahawks quarterback Russell Wilson (3) throws a lateral pass against the Arizona Cardinals during the first quarter at CenturyLink Field. Mandatory Credit: Joe Nicholson-USA TODAY Sports" data-portal-copyright="Joe Nicholson-USA TODAY Sports"></p><p> Seattle Seahawks quarterback Russell Wilson has played seven seasons in the NFL and figures he&#8217;s only not quite one-third of the way through his career. </p> </p><p> &#8220;I feel like I&#8217;m just getting started,&#8221; Wilson said in an interview with Michael Silver of NFL.com. </p> </p><p> &#8220;That&#8217;s the scary part. That&#8217;s the most exciting part. That&#8217;s really where I believe that I am right now: I&#8217;m just getting started. And I believe this team is just getting started. So, I think that we can do anything that we set our minds out to do.&#8221; </p> </p><p> Wilson, 30, said later in the interview that he has his eye on potentially playing as many as 15 more seasons, when he will be 45. </p> </p><p> &#8220;Yeah, yeah,&#8221; he said. &#8220;That&#8217;s the goal. I&#8217;m just fired up for it.&#8221; </p> </p><p> Wilson signed a four-year, $140 million contract extension with the Seahawks in April, making him the highest-paid player in the NFL at $35 million per year. The deal included a $65 million signing bonus. </p> </p><p> Wilson hopes to keep playing long after that contract expires after the 2023 season. </p> </p><p> &#8220;Seven years has gone by so fast,&#8221; Wilson said. </p> </p><p> &#8220;You think about just turning 30 years old and what I have for the rest of my career &#8212; for the next 10-15 years &#8212; I&#8217;m just fired up about it. You think about some of the best quarterbacks of all time, guys like Drew (Brees), guys like Tom (Brady), who (are playing into their 40s). I really look up to those guys. There&#8217;s so much more to do.&#8221; </p> </p><p> Wilson is a five-time Pro Bowl selection who posted career highs in passing touchdowns (35) and passer rating (110.9) in 2018. He has thrown for 25,624 yards and 196 touchdowns in his seven-year career. He has started all 112 games he has played for the Seahawks. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Goal for Seahawks QB Wilson: Play 15 more years');return false;"><span class="op-btn">Read More</span> <span class="count">239 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fgoal-for-seahawks-qb-wilson-play-15-more-years%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Goal for Seahawks QB Wilson: Play 15 more years+http://nfp.news/13ms" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Goal for Seahawks QB Wilson: Play 15 more years&#32;&#32;http://nfp.news/13ms" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13ms"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/jaguars-sign-veteran-wr-pryor/" rel="bookmark" title="Jaguars sign veteran WR Pryor">Jaguars sign veteran WR Pryor</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/jaguars-sign-veteran-wr-pryor/"/><meta itemprop="datePublished" content="2019-06-03"/><meta itemprop="dateModified" content="2019-06-03"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Jaguars sign veteran WR Pryor</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11124441.jpg" width="1100" height="733" alt="" title="Aug 24, 2018; East Rutherford, NJ, USA; New York Jets wide receiver Terrelle Pryor (1) scores a touchdown against the New York Giants during first half at MetLife Stadium. Mandatory Credit: Noah K. Murray-USA TODAY Sports" data-portal-copyright="Noah K. Murray-USA TODAY Sports"/></p> <p> The Jacksonville</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Jaguars sign veteran WR Pryor</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/11124441.jpg" width="1100" height="733" alt="" title="Aug 24, 2018; East Rutherford, NJ, USA; New York Jets wide receiver Terrelle Pryor (1) scores a touchdown against the New York Giants during first half at MetLife Stadium. Mandatory Credit: Noah K. Murray-USA TODAY Sports" data-portal-copyright="Noah K. Murray-USA TODAY Sports"></p><p> The Jacksonville Jaguars added veteran Terrelle Pryor to their inexperienced receivers group Monday. </p> </p><p> Pryor, who turns 30 later this month, has caught 115 passes for 1,563 yards and seven touchdowns since originally entering the league as an Oakland Raiders quarterback in 2011. </p> </p><p> Most of that production came with the Cleveland Browns in 2016, when the former Ohio State star tallied 77 receptions for 1,007 yards and four touchdowns. </p> </p><p> In the two seasons after that breakout year, Pryor caught only 36 balls for 492 yards and three TDs in 17 games with the Washington Redskins, New York Jets and Buffalo Bills. </p> </p><p> Pryor&#8217;s numbers, although modest, make him one of Jacksonville&#8217;s most experienced receivers. The only wideout on the 2019 roster with more career catches is Marqise Lee &#8212; who missed all of 2018 with a knee injury &#8212; with 171 since 2014. </p> </p><p> Terms of Pryor&#8217;s deal were not disclosed. In a corresponding move, the Jaguars released second-year defensive lineman Lyndon Johnson. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Jaguars sign veteran WR Pryor');return false;"><span class="op-btn">Read More</span> <span class="count">94 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fjaguars-sign-veteran-wr-pryor%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Jaguars sign veteran WR Pryor+http://nfp.news/13mp" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Jaguars sign veteran WR Pryor&#32;&#32;http://nfp.news/13mp" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13mp"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/goodell-restates-support-for-new-buffalo-stadium/" rel="bookmark" title="Goodell restates support for new Buffalo stadium">Goodell restates support for new Buffalo stadium</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/goodell-restates-support-for-new-buffalo-stadium/"/><meta itemprop="datePublished" content="2019-06-03"/><meta itemprop="dateModified" content="2019-06-03"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>Goodell restates support for new Buffalo stadium</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/9540983.jpg" width="1100" height="815" alt="" title="Sep 15, 2016; Orchard Park, NY, USA; Buffalo Bills fans tailgating in the parking lot before the game against the New York Jets at New Era Field. Mandatory Credit: Kevin Hoffman-USA TODAY Sports" data-portal-copyright="Kevin Hoffman-USA TODAY Sports"/></p> <p> NFL commissioner Roger Goodell</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>Goodell restates support for new Buffalo stadium</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/9540983.jpg" width="1100" height="815" alt="" title="Sep 15, 2016; Orchard Park, NY, USA; Buffalo Bills fans tailgating in the parking lot before the game against the New York Jets at New Era Field. Mandatory Credit: Kevin Hoffman-USA TODAY Sports" data-portal-copyright="Kevin Hoffman-USA TODAY Sports"></p><p> NFL commissioner Roger Goodell restated his support for a new stadium in Buffalo on Monday. </p> </p><p> &#8220;I want to make sure this franchise remains competitive and stable,&#8221; Goodell said, per The Athletic. </p> </p><p> Goodell made the comment while attending the Jim Kelly Celebrity Classic golf tournament in Batavia, N.Y. </p> </p><p> He expressed a similar sentiment three years ago at the same charity event hosted by the Hall of Fame quarterback. </p> </p><p> &#8220;Stadiums are important, just to making sure the team here can continue to compete not only throughout the NFL but also to compete in this environment because we&#8217;ve got great facilities here now,&#8221; Goodell said in 2016. &#8220;The Bills have to stay up with that.&#8221; </p> </p><p> The Bills play at New Era Field (capacity 71,608), formerly known as Rich Stadium and Ralph Wilson Stadium, which opened in 1973 in Orchard Park, N.Y., and underwent renovations in 1998 and 2013. </p> </p><p> Erie County officials have expressed their support for further upgrades to the current facility over building a new home for the Bills. </p> </p><p> &#8220;You have to make the determination of do you build a new stadium or do you renovate the existing stadium and get the best bang for the buck,&#8221; Erie County executive Mark Poloncarz told the Buffalo News in April. &#8220;We know if we can extend the lifespan of that stadium for another 25 years, and if it worked for our market, why would we not do that?&#8221; </p> </p><p> Bills ownership has discussed building a new stadium that would be a &#8220;scaled-down version&#8221; of the &#8220;palaces&#8221; that are being built around the league. </p> </p><p> &#8220;The thing (Los Angeles Rams owner) Stan (Kroenke) is building in L.A. is amazing, Jerry Jones&#8217; facility in Dallas. So we need to do something that&#8217;s Buffalo style,&#8221; co-owner Terry Pegula said to reporters last month. </p> </p><p> The Bills&#8217; current lease at New Era Field runs through the 2022 season, but the team can opt out in 2020. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Goodell restates support for new Buffalo stadium');return false;"><span class="op-btn">Read More</span> <span class="count">260 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fgoodell-restates-support-for-new-buffalo-stadium%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Goodell restates support for new Buffalo stadium+http://nfp.news/13mo" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Goodell restates support for new Buffalo stadium&#32;&#32;http://nfp.news/13mo" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13mo"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/nfl-notebook-gronk-says-hes-staying-retired/" rel="bookmark" title="NFL notebook: Gronk says he&#8217;s staying retired">NFL notebook: Gronk says he&#8217;s staying retired</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-notebook-gronk-says-hes-staying-retired/"/><meta itemprop="datePublished" content="2019-06-03"/><meta itemprop="dateModified" content="2019-06-03"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="http://footballpost.wpengine.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/"/><meta itemprop="name" content=""/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><h2><title>NFL notebook: Gronk says he's staying retired</title></h2> <p><img onload="Wpfcll.r(this,true);" src="https://nationalfootballpost.com/wp-content/plugins/wp-fastest-cache-premium/pro/images/blank.gif" data-wpfc-original-src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12503661.jpg" width="1100" height="733" alt="" title="Apr 9, 2019; Boston, MA, USA; Retired New England Patriots player Rob Gronkowski throws a ceremonial first pitch before a game between the Boston Red Sox and the Toronto Blue Jays at Fenway Park. Mandatory Credit: Brian Fluharty-USA TODAY Sports" data-portal-copyright="Brian Fluharty-USA TODAY</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><h2><title>NFL notebook: Gronk says he&#8217;s staying retired</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/06/12503661.jpg" width="1100" height="733" alt="" title="Apr 9, 2019; Boston, MA, USA; Retired New England Patriots player Rob Gronkowski throws a ceremonial first pitch before a game between the Boston Red Sox and the Toronto Blue Jays at Fenway Park. Mandatory Credit: Brian Fluharty-USA TODAY Sports" data-portal-copyright="Brian Fluharty-USA TODAY Sports"></p><p> Rob Gronkowski said Sunday that he remains a former New England Patriots tight end. </p> </p><p> Ever since he announced his retirement in March, there have been rumors that the three-time Super Bowl champion might change his mind. </p> </p><p> &#8220;Whatever I say it doesn&#8217;t matter. It&#8217;ll always be crazy out there. You can put &#8217;em to rest,&#8221; he told reporters Sunday. &#8220;I&#8217;m feeling good. (I&#8217;m in) a good place.&#8221; </p> </p><p> Gronkowski, 30, made the comments at Gillette Stadium, where he was participating in a charity event for children with cancer. The five-time Pro Bowl selection played nine seasons for the Patriots (2010-18), catching 521 passes for 7,861 yards and 79 touchdowns in 115 games. </p> </p><p> &#8211;Members of the New England Patriots 2018 championship team will receive their Super Bowl rings on Thursday night in a private ceremony hosted by team owner Robert Kraft. </p> </p><p> Those attending the ceremony will include some players and staff members who have moved on from New England. Defensive end Trey Flowers, who since signed with the Detroit Lions, and defensive coordinator Brian Flores, now the head coach of the Miami Dolphins, are expected to attend. </p> </p><p> The Patriots beat the Los Angeles Rams 13-3 on Feb. 3 in Super Bowl LIII for their sixth title, all since the 2001 season. </p> </p><p> &#8211;The New York Jets interviewed Philadelphia Eagles vice president of player personnel Joe Douglas for their general manager opening. </p> </p><p> Douglas joined the Eagles in May 2016 and helped to build the roster that defeated the New England Patriots in Super Bowl LII on Feb. 4, 2018. </p> </p><p> Douglas previously worked with new Jets head coach Adam Gase in Chicago during the 2015 season, with Gase serving as the Bears&#8217; offensive coordinator and Douglas as director of college scouting. The Jets are interviewing candidates to replace Mike Maccagnan, who was fired on May 15 after four seasons in the role. </p> </p><p> &#8211;Former Detroit Lions wide receiver Calvin Johnson is open to mending fences with his former team, but only if the team pays him back the portion of the signing bonus he was forced to return when he retired. </p> </p><p> &#8220;The only way they&#8217;re going to get me back is they put that money back in my pocket,&#8221; Johnson told the Detroit Free Press on Saturday. &#8220;Nah, you don&#8217;t do that. I don&#8217;t care what they say. They can put it back, then they can have me back. That&#8217;s the bottom line.&#8221; </p> </p><p> Johnson announced his retirement from the league following the 2015 season. The then-30-year-old was still dominant in his final campaign, hauling in 88 passes for 1,214 yards and nine touchdowns and being named to the Pro Bowl for the sixth time. But he was forced to pay back at least $1 million of his signing bonus to the team. </p> </p><p> In his career, Johnson totaled 11,619 receiving yards and 83 touchdowns. He played in all 16 of the Lions&#8217; games in 2015 despite battling an ankle injury. </p> </p><p> &#8211;Field Level Media</p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','NFL notebook: Gronk says he&#8217;s staying retired');return false;"><span class="op-btn">Read More</span> <span class="count">412 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-notebook-gronk-says-hes-staying-retired%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL notebook: Gronk says he’s staying retired+http://nfp.news/13mk" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL notebook: Gronk says he&#8217;s staying retired&#32;&#32;http://nfp.news/13mk" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/13mk"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article></div></div></div></div></div></div><a href="#" id="fl-to-top"><i class="fa fa-chevron-up"></i></a><style>[class*="fa fa-"]{font-family:FontAwesome !important;}</style>
<noscript id="wpfc-google-fonts"><link rel='stylesheet' id='sab-font-css' href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,700,400italic,700italic&#038;subset=latin' type='text/css' media='all'/>
<link rel='stylesheet' id='fl-builder-google-fonts-a0dc0f37a2c19d739b7445c77d065820-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C700%7CRoboto+Condensed%3A700%7COpen+Sans+Condensed%3A700&#038;ver=5.1.1' type='text/css' media='all'/>
</noscript>
<link rel='stylesheet' id='font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=2.1.4.3' type='text/css' media='all'/>
<script>var posts_table_params={"ajax_url":"https:\/\/nationalfootballpost.com\/wp-admin\/admin-ajax.php","ajax_nonce":"dc7090533b","wrapper_class":"posts-table-wrapper bb-theme","language":{"info":"Showing _START_ to _END_ of _TOTAL_ entries","infoEmpty":"Showing 0 entries","infoFiltered":"(_MAX_ entries in total)","lengthMenu":"Show _MENU_ entries","emptyTable":"No data available in table.","zeroRecords":"No matching records found.","search":"Search:","paginate":{"first":"First","last":"Last","next":"Next","previous":"Previous"},"thousands":",","decimal":".","aria":{"sortAscending":": activate to sort column ascending","sortDescending":": activate to sort column descending"},"filterBy":"Filter:","resetButton":"Reset"}};</script>
<!--[if lt IE 9]><script src="//nationalfootballpost.com/wp-content/cache/wpfc-minified/8z16d3ot/80n71.js"></script><![endif]-->
<!--[if lt IE 9]><script src="//nationalfootballpost.com/wp-content/cache/wpfc-minified/lbeld6mi/80n71.js"></script><![endif]-->
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/nationalfootballpost.com\/","sameAs":["http:\/\/facebook.com\/nationalfootballpost","https:\/\/twitter.com\/footballpost"],"@id":"https:\/\/nationalfootballpost.com\/#organization","name":"National Football Post","logo":"http:\/\/footballpost.wpengine.com\/wp-content\/uploads\/2018\/05\/NFPlogo-400.png"}</script>
<script src='//nationalfootballpost.com/wp-content/cache/wpfc-minified/qlb18u0t/80n70.js' type="text/javascript"></script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-5166086-1"></script>
<script>window.dataLayer=window.dataLayer||[];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-5166086-1');</script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/clipboard.js/1.5.10/clipboard.min.js"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>
<script>jQuery(function($){
$('button').tooltip({
trigger: 'click',
placement: 'bottom'
});
function setTooltip(btn, message){
$(btn).tooltip('hide')
.attr('data-original-title', message)
.tooltip('show');
}
function hideTooltip(btn){
setTimeout(function(){
$(btn).tooltip('hide');
}, 1000);
}
var clipboard=new Clipboard('button');
clipboard.on('success', function(e){
setTooltip(e.trigger, 'Link copied to clipboard');
hideTooltip(e.trigger);
});
clipboard.on('error', function(e){
setTooltip(e.trigger, 'Failed!');
hideTooltip(e.trigger);
});
});</script>
<script defer src='//nationalfootballpost.com/wp-content/cache/wpfc-minified/6mqm6t2g/80n70.js' type="text/javascript"></script>
<script>document.addEventListener('DOMContentLoaded',function(){function wpfcgl(){var wgh=document.querySelector('noscript#wpfc-google-fonts').innerText, wgha=wgh.match(/<link[^\>]+>/gi);for(i=0;i<wgha.length;i++){var wrpr=document.createElement('div');wrpr.innerHTML=wgha[i];document.body.appendChild(wrpr.firstChild);}}wpfcgl();});</script>
<script >document.addEventListener('DOMContentLoaded',function(){
jQuery(document).ready(function($){
$(window).scroll(function(){
var footerPos=$('footer').last().position().top;
var pos=$(window).scrollTop();
if(pos+(screen.height*4) > footerPos){
if($(".centil-infinite-scroll").first().hasClass('working')){
return false;
}else{
$(".centil-infinite-scroll").first().addClass('working');
}
var centilNextPostId=$(".centil-infinite-scroll").first().text();
var data={
'action': 'centil_is',
'centilNextPostId': centilNextPostId
};
jQuery.post('https://nationalfootballpost.com/wp-admin/admin-ajax.php', data, function(response){
$(".centil-infinite-scroll").first().replaceWith(response);
}, 'html');
}
var currUrl=$(".centil-post-header").first().attr("url");
var currTitle=$(".centil-post-header").first().attr("title");
if($(".centil-post-header").length > 1&&history.pushState){
for (var i=0; i<$(".centil-post-header").length; i++){
if(pos+(screen.height/2) >=$(".centil-post-header").eq(i).next().position().top){
currUrl=$(".centil-post-header").eq(i).attr("url");
currTitle=$(".centil-post-header").eq(i).attr("title");
}}
}
if(location.href!=currUrl){
history.pushState({}, currTitle, currUrl);
}});
});});</script>
</body>
</html><!-- WP Fastest Cache file was created in 5.0109641552 seconds, on 04-06-19 23:40:09 -->