<!DOCTYPE html>
<html lang="en-US">
<head>
<meta charset="UTF-8" />
<meta name='viewport' content='width=device-width, initial-scale=1.0' />
<meta http-equiv='X-UA-Compatible' content='IE=edge' />
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="pingback" href="https://nationalfootballpost.com/xmlrpc.php" />
<!--[if lt IE 9]>
	<script src="https://nationalfootballpost.com/wp-content/themes/bb-theme/js/html5shiv.js"></script>
	<script src="https://nationalfootballpost.com/wp-content/themes/bb-theme/js/respond.min.js"></script>
<![endif]-->
<title>Los Angeles Rams training camp primer - National Football Post</title>

<!-- This site is optimized with the Yoast SEO plugin v11.4 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://nationalfootballpost.com/los-angeles-rams-training-camp-primer/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Los Angeles Rams training camp primer - National Football Post" />
<meta property="og:description" content="Los Angeles Rams training camp primer New faces: S Eric Weddle, OLB Clay Matthews, S Taylor Rapp, QB Blake Bortles, RB Darrell Henderson, CB David Long They&#8217;re gone: DT Ndamukong Suh, G Rodger Saffold, C John Sullivan, S LaMarcus Joyner, LB Mark Barron, RB C.J. Anderson, LB Ramik Wilson 2019 snapshot: After assembling a &#8220;Dream&hellip;" />
<meta property="og:url" content="https://nationalfootballpost.com/los-angeles-rams-training-camp-primer/" />
<meta property="og:site_name" content="National Football Post" />
<meta property="article:publisher" content="http://facebook.com/nationalfootballpost" />
<meta property="article:tag" content="FLM" />
<meta property="article:section" content="NFL and College Football Articles" />
<meta property="article:published_time" content="2019-07-24T00:48:22+00:00" />
<meta property="article:modified_time" content="2019-07-24T00:48:24+00:00" />
<meta property="og:updated_time" content="2019-07-24T00:48:24+00:00" />
<meta property="og:image" content="https://nationalfootballpost.com/wp-content/uploads/2019/07/12780786.jpg" />
<meta property="og:image:secure_url" content="https://nationalfootballpost.com/wp-content/uploads/2019/07/12780786.jpg" />
<script type='application/ld+json' class='yoast-schema-graph yoast-schema-graph--main'>{"@context":"https://schema.org","@graph":[{"@type":"Organization","@id":"https://nationalfootballpost.com/#organization","name":"National Football Post","url":"https://nationalfootballpost.com/","sameAs":["http://facebook.com/nationalfootballpost","https://twitter.com/footballpost"]},{"@type":"WebSite","@id":"https://nationalfootballpost.com/#website","url":"https://nationalfootballpost.com/","name":"National Football Post","publisher":{"@id":"https://nationalfootballpost.com/#organization"},"potentialAction":{"@type":"SearchAction","target":"https://nationalfootballpost.com/?s={search_term_string}","query-input":"required name=search_term_string"}},{"@type":"WebPage","@id":"https://nationalfootballpost.com/los-angeles-rams-training-camp-primer/#webpage","url":"https://nationalfootballpost.com/los-angeles-rams-training-camp-primer/","inLanguage":"en-US","name":"Los Angeles Rams training camp primer - National Football Post","isPartOf":{"@id":"https://nationalfootballpost.com/#website"},"image":{"@type":"ImageObject","@id":"https://nationalfootballpost.com/los-angeles-rams-training-camp-primer/#primaryimage","url":"https://nationalfootballpost.com/wp-content/uploads/2019/07/12780786.jpg","width":1100,"height":727},"primaryImageOfPage":{"@id":"https://nationalfootballpost.com/los-angeles-rams-training-camp-primer/#primaryimage"},"datePublished":"2019-07-24T00:48:22+00:00","dateModified":"2019-07-24T00:48:24+00:00"},{"@type":"Article","@id":"https://nationalfootballpost.com/los-angeles-rams-training-camp-primer/#article","isPartOf":{"@id":"https://nationalfootballpost.com/los-angeles-rams-training-camp-primer/#webpage"},"author":{"@id":"https://nationalfootballpost.com/author/#author"},"headline":"Los Angeles Rams training camp primer","datePublished":"2019-07-24T00:48:22+00:00","dateModified":"2019-07-24T00:48:24+00:00","commentCount":0,"mainEntityOfPage":{"@id":"https://nationalfootballpost.com/los-angeles-rams-training-camp-primer/#webpage"},"publisher":{"@id":"https://nationalfootballpost.com/#organization"},"keywords":"FLM","articleSection":"NFL and College Football Articles"}]}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="National Football Post &raquo; Feed" href="https://nationalfootballpost.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="National Football Post &raquo; Comments Feed" href="https://nationalfootballpost.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="National Football Post &raquo; Los Angeles Rams training camp primer Comments Feed" href="https://nationalfootballpost.com/los-angeles-rams-training-camp-primer/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/nationalfootballpost.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.2.2"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='otw_sbm.css-css'  href='https://nationalfootballpost.com/wp-content/plugins/sidebar-manager-light/css/otw_sbm.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='fl-builder-google-fonts-6fd2b081dbaa3bb8686313de37b24bdf-css'  href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C700&#038;ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='fl-builder-google-fonts-4bd28ee77d135a4495776630bd4dfb32-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed%3A700&#038;ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='fl-builder-google-fonts-8cbd1b8ff36d9bbc9ac97d58e2da881d-css'  href='https://fonts.googleapis.com/css?family=Open+Sans+Condensed%3A700&#038;ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://nationalfootballpost.com/wp-includes/css/dist/block-library/style.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='ce_responsive-css'  href='https://nationalfootballpost.com/wp-content/plugins/simple-embed-code/css/video-container.min.css?ver=5.2.2' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-data-tables-css'  href='https://nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/css/datatables/datatables.min.css?ver=1.10.16' type='text/css' media='all' />
<link rel='stylesheet' id='posts-table-pro-css'  href='https://nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/css/posts-table-pro.min.css?ver=2.0.3' type='text/css' media='all' />
<link rel='stylesheet' id='sab-font-css'  href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,700,400italic,700italic&#038;subset=latin' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://nationalfootballpost.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9.2' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://nationalfootballpost.com/wp-content/themes/bb-theme/css/font-awesome.min.css?ver=1.6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='mono-social-icons-css'  href='https://nationalfootballpost.com/wp-content/themes/bb-theme/css/mono-social-icons.css?ver=1.6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='jquery-magnificpopup-css'  href='https://nationalfootballpost.com/wp-content/themes/bb-theme/css/jquery.magnificpopup.css?ver=1.6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='bootstrap-css'  href='https://nationalfootballpost.com/wp-content/themes/bb-theme/css/bootstrap.min.css?ver=1.6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='fl-automator-skin-css'  href='https://nationalfootballpost.com/wp-content/uploads/bb-theme/skin-5bb55ecb9f95d.css?ver=1.6.5.1' type='text/css' media='all' />
<link rel='stylesheet' id='fl-child-theme-css'  href='https://nationalfootballpost.com/wp-content/themes/bb-theme-child/style.css?ver=5.2.2' type='text/css' media='all' />
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/plugins/wp-d3/js/d3.v35.min.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/plugins/wp-google-analytics-events/js/ga-scroll-events.js?ver=2.5.3'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme-child/js/custom.js?ver=5.2.2'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme-child/js/infinite-scroll.min.js?ver=5.2.2'></script>
<link rel='https://api.w.org/' href='https://nationalfootballpost.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nationalfootballpost.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nationalfootballpost.com/wp-includes/wlwmanifest.xml" /> 
<link rel='shortlink' href='https://nationalfootballpost.com/?p=106792' />
<link rel="alternate" type="application/json+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Flos-angeles-rams-training-camp-primer%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Flos-angeles-rams-training-camp-primer%2F&#038;format=xml" />
<!-- Google Analytics -->
<script>
(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

ga('create', 'UA-5166086-1', 'auto');
ga('send', 'pageview');
</script>
<!-- End Google Analytics --><style type='text/css'>.rp4wp-related-posts ul{width:100%;padding:0;margin:0;float:left;}
.rp4wp-related-posts ul>li{list-style:none;padding:0;margin:0;padding-bottom:20px;clear:both;}
.rp4wp-related-posts ul>li>p{margin:0;padding:0;}
.rp4wp-related-post-image{width:35%;padding-right:25px;-moz-box-sizing:border-box;-webkit-box-sizing:border-box;box-sizing:border-box;float:left;}</style>
<script type="text/javascript" >
jQuery(document).ready(function($) {
                       
                       $(window).scroll(function() {
                                        var footerPos = $('footer').last().position().top;
                                        var pos = $(window).scrollTop();
                                        
                                        // Load next article
                                        if (pos+(screen.height*4) > footerPos) {
                                        if ($(".centil-infinite-scroll").first().hasClass('working')) {
                                        return false;
                                        } else {
                                        $(".centil-infinite-scroll").first().addClass('working');
                                        }
                                        
                                        var centilNextPostId = $(".centil-infinite-scroll").first().text();
                                        var data = {
                                        'action': 'centil_is',
                                        'centilNextPostId': centilNextPostId
                                        };
                                        
                                        // since 2.8 ajaxurl is always defined in the admin header and points to admin-ajax.php
                                        jQuery.post('https://nationalfootballpost.com/wp-admin/admin-ajax.php', data, function(response) {
                                                    $(".centil-infinite-scroll").first().replaceWith(response);
                                                    }, 'html');
                                        }
                                        
                                        // Update new URL
                                        var currUrl = $(".centil-post-header").first().attr("url");
                                        var currTitle = $(".centil-post-header").first().attr("title");
                                        
                                        if ($(".centil-post-header").length > 1 && history.pushState) {
                                        for (var i=0; i<$(".centil-post-header").length; i++) {
                                        if (pos+(screen.height/2) >= $(".centil-post-header").eq(i).next().position().top) {
                                        currUrl = $(".centil-post-header").eq(i).attr("url");
                                        currTitle = $(".centil-post-header").eq(i).attr("title");
                                        }
                                        }
                                        }
                                        if (location.href != currUrl) {
                                        history.pushState({}, currTitle, currUrl);
                                        }
                                        });
                       });
</script>

<meta name="generator" content="Feed to Post 3.7.5" />
<link rel="canonical" href="https://footballpost.wpengine.com/newsml/fieldlevelmedia_str_20190723T202706_0800_000043793_1.xml" /><link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-270x270.jpg" />
        <script>
                if (typeof ga === 'undefined') {
                  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
                  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
                  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
                  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');

                  ga('create','', 'nationalfootballpost.com');                  ga('send', 'pageview');
                                }
            </script> 		<style type="text/css" id="wp-custom-css">
			.fl-post-cats-tags{
		    padding: 0px 0px 0px 0px;	
				border-bottom:4px solid #e6e6e6
}

.share-social{
	border-bottom:4px solid #e6e6e6
}


.container
{max-width: 93%}


.fl-sidebar-left
{
	padding-right: 2%;
	padding-left: 0px;
}

.fl-post-cats-tags a, .share-social a {
    text-transform: uppercase;
    color: #000;
		font-size: 18px;
		font-weight: 600;
    font-style: normal;
		
}
.fl-archive .fl-post
{
	border-bottom: 0px;
}


div.share-social {
    letter-spacing: 7px;
    float: right;
	padding-top: 10px;
}

.custom-html-widget li a{
	font-size: 16px;
  color: #555;
	font-style: normal;
  display: block;
	padding-bottom: 4px;
	font-weight: 600;
	text-transform: uppercase;	
}

.custom-html-widget li{
	font-size: 14px;
  color: #7b7b7b;
	font-style: italic;
	font-weight: 500;
	text-transform: uppercase;	
	padding-bottom: 6px;
	border-bottom: 2px solid #e6e6e6
	
}

.fl-widget-title {
	border-style: solid;
  border-width: 4px 0px 4px 0px; 
	text-align: center;
	padding: 5px
	
}


.fl-post-title{
     margin-bottom: 0px;}

.fl-post-author {
	text-transform: uppercase;
	font-style: italic;
	font-weight:600;
	font-size: 18px;
}
.tooltip-inner{letter-spacing: 1px;}
.fl-post-meta-bottom {
    border-top: none;
    font-style: italic;
    margin-top: 0;
    padding-top: 10px;
    float: left;
}
.btn-primary{
	    border: none !important;
    background: 0 0 !important;;
    color: #000 !important;;
    box-shadow: none !important;;
    padding: 0 !important;;
    margin-bottom: 5px !important;;
}

.toptitle h1{
	font-size:22px;
	margin-top: 5px;
	margin-bottom: 5px; 
  list-style: none;
  margin: 0;
  padding: 0;
  line-height:40px;
	width:50%;
	position: relative;
	left: 25%;
	margin: 0 px;
  padding: 0 px;
  border: 1px solid #AAA;
	color:white;
  background: #050505;
	 border-bottom-left-radius: 10px;
	border-bottom-right-radius: 10px;
	font-style: italic;

}


.fl-archive .fl-archive-title{display:none;}

.rp4wp-related-post-content{
	font-size: 18px;
  color: #555;
	font-style: italic;
  display: block;
	font-weight: 800;
	text-transform: uppercase;
}
		</style>
		<!-- Global site tag (gtag.js) - Google Analytics -->
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-5166086-1"></script>
<script>
  window.dataLayer = window.dataLayer || [];
  function gtag(){dataLayer.push(arguments);}
  gtag('js', new Date());

  gtag('config', 'UA-5166086-1');
</script>

</head>

<body class="post-template-default single single-post postid-106792 single-format-standard fl-preset-default fl-fixed-width fl-scroll-to-top fl-search-active" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="fl-page">
	<header class="fl-page-header fl-page-header-fixed fl-page-nav-right fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile">
	<div class="fl-page-header-wrap">
		<div class="fl-page-header-container container">
			<div class="fl-page-header-row row">
				<div class="fl-page-logo-wrap col-md-3 col-sm-12">
					<div class="fl-page-header-logo">
						<a href="https://nationalfootballpost.com/"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post" /><meta itemprop="name" content="National Football Post" /></a>
					</div>
				</div>
				<div class="fl-page-fixed-nav-wrap col-md-9 col-sm-12">
					<div class="fl-page-nav-wrap">
						<nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu">
							<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse">
								<span><i class="fa fa-bars"></i></span>
							</button>
							<div class="fl-page-nav-collapse collapse navbar-collapse">
								<ul id="menu-top-nav" class="nav navbar-nav navbar-right menu"><li id="menu-item-78448" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a>
<ul class="sub-menu">
	<li id="menu-item-94464" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li>
	<li id="menu-item-94463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li>
</ul>
</li>
<li id="menu-item-80343" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a>
<ul class="sub-menu">
	<li id="menu-item-88321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li>
	<li id="menu-item-80344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li>
	<li id="menu-item-78452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li>
</ul>
</li>
<li id="menu-item-78387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a>
<ul class="sub-menu">
	<li id="menu-item-84427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li>
	<li id="menu-item-84236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li>
</ul>
</li>
<li id="menu-item-78499" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a>
<ul class="sub-menu">
	<li id="menu-item-78502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li>
	<li id="menu-item-78500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li>
	<li id="menu-item-80079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li>
</ul>
</li>
</ul>							</div>
						</nav>
					</div>
				</div>
			</div>
		</div>
	</div>
</header><!-- .fl-page-header-fixed -->
<header class="fl-page-header fl-page-header-primary fl-page-nav-centered fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
	<div class="fl-page-header-wrap">
		<div class="fl-page-header-container container">
			<div class="fl-page-header-row row">
				<div class="col-md-12 fl-page-header-logo-col">
					<div class="fl-page-header-logo" itemscope="itemscope" itemtype="https://schema.org/Organization">
						<a href="https://nationalfootballpost.com/" itemprop="url"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post" /><meta itemprop="name" content="National Football Post" /></a>
					</div>
				</div>
			</div>
		</div>
	</div>
	<div class="fl-page-nav-wrap">
		<div class="fl-page-nav-container container">
			<nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement">
				<button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse">
					<span><i class="fa fa-bars"></i></span>
				</button>
				<div class="fl-page-nav-collapse collapse navbar-collapse">
					<ul id="menu-top-nav-1" class="nav navbar-nav menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li>
</ul>
</li>
</ul><div class="fl-page-nav-search">
	<a href="javascript:void(0);" class="fa fa-search"></a>
	<form method="get" role="search" action="https://nationalfootballpost.com/" title="Type and press Enter to search.">
		<input type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" />
	</form>
</div>
				</div>
			</nav>
		</div>
	</div>
</header><!-- .fl-page-header -->
	<div class="fl-page-content" itemprop="mainContentOfPage">

		
<div class="fl-archive container">
	<div class="row">
		
		<div class="fl-sidebar fl-sidebar-left fl-sidebar-display-desktop col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar">
		<aside id="custom_html-3" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">RECENT</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/seattle-seahawks-training-camp-primer/" title="Seattle Seahawks training camp primer">Seattle Seahawks training camp primer</a> 10 mins ago </li><li ><a href="https://nationalfootballpost.com/san-francisco-49ers-training-camp-primer/" title="San Francisco 49ers training camp primer">San Francisco 49ers training camp primer</a> 10 mins ago </li><li ><a href="https://nationalfootballpost.com/nfl-suspends-vikings-cb-hill-for-4-more-games/" title="NFL suspends Vikings CB Hill for 4 more games">NFL suspends Vikings CB Hill for 4 more games</a> 10 mins ago </li><li class="current"><a href="https://nationalfootballpost.com/los-angeles-rams-training-camp-primer/" title="Los Angeles Rams training camp primer">Los Angeles Rams training camp primer</a> 10 mins ago </li><li ><a href="https://nationalfootballpost.com/arizona-cardinals-training-camp-primer/" title="Arizona Cardinals training camp primer">Arizona Cardinals training camp primer</a> 10 mins ago </li><li ><a href="https://nationalfootballpost.com/washington-redskins-training-camp-primer/" title="Washington Redskins training camp primer">Washington Redskins training camp primer</a> 10 mins ago </li><li ><a href="https://nationalfootballpost.com/dallas-cowboys-training-camp-primer/" title="Dallas Cowboys training camp primer">Dallas Cowboys training camp primer</a> 10 mins ago </li><li ><a href="https://nationalfootballpost.com/packers-agree-to-extension-with-de-lowry/" title="Packers agree to extension with DE Lowry">Packers agree to extension with DE Lowry</a> 10 mins ago </li><li ><a href="https://nationalfootballpost.com/report-financial-issues-mount-for-redskins-rb-peterson/" title="Report: Financial issues mount for Redskins RB Peterson">Report: Financial issues mount for Redskins RB Peterson</a> 10 mins ago </li><li ><a href="https://nationalfootballpost.com/golf-glance-loaded-wgc-field-takes-aim-following-major/" title="Golf Glance: Loaded WGC field takes aim following major">Golf Glance: Loaded WGC field takes aim following major</a> 4 hours ago </li></ul></div></aside><aside id="custom_html-7" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">FEATURES</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/caputi-2019-nfl-mock-draft-final/" title="Caputi: 2019 NFL Mock Draft (Final)">Caputi: 2019 NFL Mock Draft (Final)</a> April 25, 2019 </li><li ><a href="https://nationalfootballpost.com/super-bowl-53-betting-preview/" title="Super Bowl 53 Betting Preview – Best Props Picks, Trends">Super Bowl 53 Betting Preview – Best Props Picks, Trends</a> February 3, 2019 </li><li ><a href="https://nationalfootballpost.com/report-brady-defiantly-denies-retirement-question/" title="Report: Brady defiantly denies retirement question">Report: Brady defiantly denies retirement question</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/rams-cooks-responds-to-pats-chung-dig-in-fan-rally/" title="Rams&#8217; Cooks responds to Pats&#8217; Chung dig in fan rally">Rams&#8217; Cooks responds to Pats&#8217; Chung dig in fan rally</a> January 27, 2019 </li><li ><a href="https://nationalfootballpost.com/huge-crowd-sends-patriots-off-to-super-bowl/" title="Huge crowd sends Patriots off to Super Bowl">Huge crowd sends Patriots off to Super Bowl</a> January 27, 2019 </li></ul></div></aside>	</div>

		<div class="fl-content fl-content-right col-md-9" itemscope="itemscope" itemtype="https://schema.org/Blog">

			
									
<article class="fl-post post-106792 post type-post status-publish format-standard hentry category-news tag-flm" id="fl-post-106792" itemscope itemtype="https://schema.org/BlogPosting">

	
	<header class="fl-post-header">
		<h1 class="fl-post-title" itemprop="headline">
			Los Angeles Rams training camp primer					</h1>
		<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/los-angeles-rams-training-camp-primer/" /><meta itemprop="datePublished" content="10 mins ago" /><meta itemprop="dateModified" content="10 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>	</header><!-- .fl-post-header -->

	
	
	<div class="fl-post-content clearfix" itemprop="text">
		<h2><title>Los Angeles Rams training camp primer</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12780786.jpg" width="1100" height="727" alt="" title="May 20, 2019; Thousand Oaks,  CA, USA; Los Angeles Rams safety Eric Weddle (32) during organized team activities at Cal Lutheran University. Mandatory Credit: Kirby Lee-USA TODAY Sports" data-portal-copyright="Kirby Lee-USA TODAY Sports" /></p><p>
New faces: S Eric Weddle, OLB Clay Matthews, S Taylor Rapp, QB Blake Bortles, RB Darrell Henderson, CB David Long
</p>
</p><p>
They&#8217;re gone: DT Ndamukong Suh, G Rodger Saffold, C John Sullivan, S LaMarcus Joyner, LB Mark Barron, RB C.J. Anderson, LB Ramik Wilson
</p>
</p><p>
2019 snapshot: After assembling a &#8220;Dream Team&#8221; of sorts last spring, the Rams quieted considerably this offseason, limited by a lack of cap space despite a number of players hitting free agency. Suh, Saffold, Joyner and Barron all seemed like obvious candidates to walk, and Sullivan&#8217;s retirement wasn&#8217;t a shock.
</p>
</p><p>
What was surprising is that L.A. did essentially nothing to replace either Saffold or Sullivan, trusting that 2018 draft picks Joseph Noteboom and Brian Allen can step in to start at left guard and center, respectfully.
</p>
</p><p>
The defense took an interesting turn, with Weddle and Matthews arriving to provide veteran savvy, and potentially a more schematically diverse approach from coordinator Wade Phillips. Both have declined physically, but if the normally straightforward Phillips wants to get more creative, he certainly can. Dante Fowler was retained, but his contract (one year, $12 million with $2 million in incentives) doesn&#8217;t offer much surplus value.
</p>
</p><p>
For the second consecutive year, a series of trades in the draft brought a deep class, led by Rapp and Henderson. Rapp, who has been compared to Weddle for his instinctive play, should contribute early as a dime linebacker, and Henderson could bring another dimension to the offense as a big-play threat and spread receiving option. Long provides some insurance behind contract-year CBs Aqib Talib and Marcus Peters.
</p>
</p><p>
Worth the investment?
</p>
</p><p>
&#8211;Coming off a 13-win season and a Super Bowl appearance, the Rams should at least push on their over/under total of 10 wins. But there are a few key holes, making the over less than a slam dunk.
</p>
</p><p>
&#8211;The Rams have three players with less-than-astronomical MVP odds, with Jared Goff and Aaron Donald at +4000 and Todd Gurley at +5000. Goff is the most realistic candidate, but we&#8217;d still pass given how much of his success is credited to McVay.
</p>
</p><p>
Bottom line: The Rams should be able to overcome most of their losses, but the lack of additions along the O-line is mildly concerning. Health and development from Noteboom and Allen will be critical.
</p>
</p><p>
&#8211;Field Level Media</p>
<div class='rp4wp-related-posts'>
<h3>Related Posts</h3>
<ul>
<li><div class='rp4wp-related-post-content'>
<a href='https://nationalfootballpost.com/los-angeles-chargers-training-camp-primer/'>Los Angeles Chargers training camp primer</a></div>
</li>
<li><div class='rp4wp-related-post-content'>
<a href='https://nationalfootballpost.com/los-angeles-rams-draft-review/'>Los Angeles Rams draft review</a></div>
</li>
<li><div class='rp4wp-related-post-content'>
<a href='https://nationalfootballpost.com/rams-to-stay-at-home-for-training-camp/'>Rams to stay at home for training camp</a></div>
</li>
</ul>
</div>
	</div><!-- .fl-post-content -->


    <div class="post-bot">
	    <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>        <div class="share-social">
		    <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Flos-angeles-rams-training-camp-primer%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
		    <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Los Angeles Rams training camp primer+https://nationalfootballpost.com/?p=106792" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
		    <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Los Angeles Rams training camp primer&#32;&#32;https://nationalfootballpost.com/?p=106792" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
		    <button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106792"><i class="fa fa-link" aria-hidden="true"></i></button>
        </div>
    </div>
		
</article>

			    
			    <div class="related-post">
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/seattle-seahawks-training-camp-primer/" rel="bookmark" title="Seattle Seahawks training camp primer">Seattle Seahawks training camp primer</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/seattle-seahawks-training-camp-primer/" /><meta itemprop="datePublished" content="10 mins ago" /><meta itemprop="dateModified" content="9 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Seattle Seahawks training camp primer</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12879128.jpg" width="1100" height="733" alt="" title="Jun 11, 2019; Renton, WA, USA; Seattle Seahawks quarterback Russell Wilson (3) talks with general manager John Schneider following a minicamp practice at the Virginia Mason Athletic Center. Mandatory Credit: Joe Nicholson-USA TODAY Sports" data-portal-copyright="Joe Nicholson-USA TODAY Sports" /></p> <p> New faces: DE Ezekiel Ansah,</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Seattle Seahawks training camp primer</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12879128.jpg" width="1100" height="733" alt="" title="Jun 11, 2019; Renton, WA, USA; Seattle Seahawks quarterback Russell Wilson (3) talks with general manager  John Schneider following a minicamp practice at the Virginia Mason Athletic Center. Mandatory Credit: Joe Nicholson-USA TODAY Sports" data-portal-copyright="Joe Nicholson-USA TODAY Sports" /></p><p>
New faces: DE Ezekiel Ansah, G Mike Iupati, DT Al Woods, DE L.J. Collier, DE Cassius Marsh, FB Nick Bellore, K Jason Myers, WR D.K. Metcalf, S Marquise Blair, QB Geno Smith, WR Gary Jennings
</p>
</p><p>
They&#8217;re gone: S Earl Thomas, DE Frank Clark, WR Doug Baldwin, CB Justin Coleman, G J.R. Sweezy, RB Mike Davis, QB Brett Hundley, DT Shamar Stephen, DT Malik McDowell, K Sebastian Janikowski
</p>
</p><p>
2019 snapshot: Taken as a whole, the departures of Thomas, Clark, Baldwin and Coleman were rather jarring, especially after Richard Sherman, Michael Bennett, Cliff Avril and Kam Chancellor all departed just a year earlier. But as the Seahawks showed last year, they excel at weathering storms.
</p>
</p><p>
Thomas (who missed most of last season) and Coleman were never expected back. Clark (franchise-tagged) was, but things pivoted when his price tag skyrocketed, and Seattle got first- and second-round picks in return for him.
</p>
</p><p>
The first-rounder turned into Collier, a crafty type who should replicate some of Bennett&#8217;s inside-outside versatility. Ansah&#8217;s arrival will also make Clark&#8217;s departure easier to stomach, assuming he can return to form following a shoulder injury.
</p>
</p><p>
The team might not have a like-for-like replacement for Baldwin, but Metcalf impressed in the offseason, and Jennings could compete for snaps. Meanwhile, Seattle kept K.J. Wright (two years, $14 million) and D.J. Fluker for cheap (two years, $6 million), while adding Iupati and Myers to shore up a few holes.
</p>
</p><p>
Of course, the Seahawks also handled Russell Wilson&#8217;s contract extension, a necessary move that was completed before it could become a distraction. Now they must turn to an extension for Bobby Wagner, for which the price tag jumped considerably after two massive linebacker contracts were signed in free agency (Kwon Alexander and C.J. Mosely) and another (Deion Jones) followed last week.
</p>
</p><p>
Worth the investment?
</p>
</p><p>
&#8211;In the last four seasons, Seattle has three 10-win campaigns and one with nine victories. We&#8217;re tempted to lean toward the under on their 9-win total this season, but it might be best to just stay away.
</p>
</p><p>
&#8211;Wilson has never won MVP, coming closest with a scorching finish to the 2015 campaign. He&#8217;s not a bad bet at +2000, but he&#8217;ll need more volume than Seattle&#8217;s run-heavy attack offered him last year.
</p>
</p><p>
Bottom line: It was another bumpy spring in Seattle, but the Seahawks again landed on their feet. As usual, they&#8217;ll go as far as Wilson can take them.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Seattle Seahawks training camp primer');return false;"><span class="op-btn">Read More</span> <span class="count">348 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fseattle-seahawks-training-camp-primer%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Seattle Seahawks training camp primer+https://nationalfootballpost.com/?p=106807" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Seattle Seahawks training camp primer&#32;&#32;https://nationalfootballpost.com/?p=106807" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106807"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/san-francisco-49ers-training-camp-primer/" rel="bookmark" title="San Francisco 49ers training camp primer">San Francisco 49ers training camp primer</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/san-francisco-49ers-training-camp-primer/" /><meta itemprop="datePublished" content="10 mins ago" /><meta itemprop="dateModified" content="10 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>San Francisco 49ers training camp primer</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12877874.jpg" width="1100" height="733" alt="" title="Jun 11, 2019; Santa Clara, CA, USA; San Francisco 49ers defensive end Nick Bosa (97) during minicamp at the SAP Performance Facility. Mandatory Credit: Stan Szeto-USA TODAY Sports" data-portal-copyright="Stan Szeto-USA TODAY Sports" /></p> <p> New faces: DE Dee Ford, LB Kwon Alexander, DE Nick</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>San Francisco 49ers training camp primer</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12877874.jpg" width="1100" height="733" alt="" title="Jun 11, 2019; Santa Clara, CA, USA; San Francisco 49ers defensive end Nick Bosa (97) during minicamp at the SAP Performance Facility. Mandatory Credit: Stan Szeto-USA TODAY Sports" data-portal-copyright="Stan Szeto-USA TODAY Sports" /></p><p>
New faces: DE Dee Ford, LB Kwon Alexander, DE Nick Bosa, RB Tevin Coleman, CB Jason Verrett, WR Deebo Samuel, LB David Mayo, WR Jordan Matthews, WR/TE Jalen Hurd, TE Kaden Smith, P Mitch Wishnowsky
</p>
</p><p>
They&#8217;re gone: WR Pierre Garcon, DT Earl Mitchell, DE Cassius Marsh, P Bradley Pinion, RB Alfred Morris, LB Dekoda Watson
</p>
</p><p>
2019 snapshot: Hyped as a team set to make the leap last year, the 49ers stacked up another strong offseason and could finally be primed for a breakthrough.
</p>
</p><p>
No other NFL team improved as much on defense as San Francisco, which suddenly has two potential star edge rushers in Ford (acquired via trade from Kansas City) and Bosa (drafted second overall). Alexander&#8217;s price tag was absurd (four years, $54 million), but the structure doesn&#8217;t carry long-term risk, and he adds speed for D-coordinator Robert Saleh. This could certainly become a top-10 unit, especially if Verrett stays healthy.
</p>
</p><p>
On offense, Coleman was one of the offseason&#8217;s biggest bargains (two years, $8.5 million), giving coach Kyle Shanahan yet another multi-dimensional back to employ as a runner and receiver. Samuel and especially Hurd will probably need time to develop, but both bring unique skillsets to the offense, and Smith could contribute early in a scheme that caters perfectly to tight ends.
</p>
</p><p>
Meanwhile, the 49ers lost very few players of consequence, extended LT Joe Staley and will get QB Jimmy Garoppolo and RB Jerick McKinnon back from injuries after both missed nearly all of 2018. Taking a punter (Wishnowsky) in the fourth round was absurd, but if that&#8217;s the biggest quibble of the offseason, it seems things have gone quite well for the Niners.
</p>
</p><p>
Worth the investment?
</p>
</p><p>
&#8211;Last year&#8217;s preseason optimism has cooled somewhat, bringing the 49ers&#8217; over/under win total into a friendly range at eight. Even in a tough division, that&#8217;s a bargain.
</p>
</p><p>
&#8211;If the 49ers take the leap many forecast in 2018, Jimmy Garoppolo (+3300) could be a sneaky MVP longshot. Kyle Shanahan coaxed an MVP campaign out of Matt Ryan just three years ago.
</p>
</p><p>
Bottom line: The health of Garoppolo will likely tell the story, but San Francisco did just about everything it could to thrust itself into playoff contention.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'San Francisco 49ers training camp primer');return false;"><span class="op-btn">Read More</span> <span class="count">309 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fsan-francisco-49ers-training-camp-primer%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=San Francisco 49ers training camp primer+https://nationalfootballpost.com/?p=106802" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=San Francisco 49ers training camp primer&#32;&#32;https://nationalfootballpost.com/?p=106802" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106802"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/nfl-suspends-vikings-cb-hill-for-4-more-games/" rel="bookmark" title="NFL suspends Vikings CB Hill for 4 more games">NFL suspends Vikings CB Hill for 4 more games</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/nfl-suspends-vikings-cb-hill-for-4-more-games/" /><meta itemprop="datePublished" content="10 mins ago" /><meta itemprop="dateModified" content="10 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>NFL suspends Vikings CB Hill for 4 more games</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/11920134.jpg" width="1100" height="733" alt="" title="Dec 30, 2018; Minneapolis, MN, USA; Chicago Bears wide receiver Taylor Gabriel (18) catches a pass over Minnesota Vikings cornerback Holton Hill (24) during the second quarter at U.S. Bank Stadium. Mandatory Credit: Brace Hemmelgarn-USA TODAY Sports" data-portal-copyright="Brace Hemmelgarn-USA TODAY Sports"</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>NFL suspends Vikings CB Hill for 4 more games</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/11920134.jpg" width="1100" height="733" alt="" title="Dec 30, 2018; Minneapolis, MN, USA; Chicago Bears wide receiver Taylor Gabriel (18) catches a pass over Minnesota Vikings cornerback Holton Hill (24) during the second quarter at U.S. Bank Stadium. Mandatory Credit: Brace Hemmelgarn-USA TODAY Sports" data-portal-copyright="Brace Hemmelgarn-USA TODAY Sports" /></p><p>
Minnesota Vikings cornerback Holton Hill has been suspended without pay for an additional four games for violating the NFL&#8217;s policy and program on substance abuse, the league announced Tuesday.
</p>
</p><p>
The league in April suspended Hill for the first four games of the season for violating the NFL policy on performance-enhancing drugs.
</p>
</p><p>
Hill will be allowed to participate in all preseason practices and games. He can return to the active roster Oct. 25 &#8212; the day following the Vikings&#8217; eighth game &#8212; and is eligible to play in a Nov. 3 game at the Kansas City Chiefs.
</p>
</p><p>
Hill, 22, had 36 tackles and one interception in 16 games (three starts) last season as an undrafted rookie.
</p>
</p><p>
He reportedly failed a drug test at the 2018 NFL Combine and also reportedly failed at least one drug test as a college player at Texas.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'NFL suspends Vikings CB Hill for 4 more games');return false;"><span class="op-btn">Read More</span> <span class="count">86 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fnfl-suspends-vikings-cb-hill-for-4-more-games%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=NFL suspends Vikings CB Hill for 4 more games+https://nationalfootballpost.com/?p=106797" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=NFL suspends Vikings CB Hill for 4 more games&#32;&#32;https://nationalfootballpost.com/?p=106797" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106797"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/arizona-cardinals-training-camp-primer/" rel="bookmark" title="Arizona Cardinals training camp primer">Arizona Cardinals training camp primer</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/arizona-cardinals-training-camp-primer/" /><meta itemprop="datePublished" content="10 mins ago" /><meta itemprop="dateModified" content="10 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Arizona Cardinals training camp primer</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12879803.jpg" width="1100" height="746" alt="" title="Jun 11, 2019; Tempe, AZ, USA; Arizona Cardinals quarterback Kyler Murray during minicamp at the teams Tempe training facility. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports" /></p> <p> New faces: QB Kyler Murray, LB Jordan Hicks, OLB Terrell Suggs, OT</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Arizona Cardinals training camp primer</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12879803.jpg" width="1100" height="746" alt="" title="Jun 11, 2019; Tempe, AZ, USA; Arizona Cardinals quarterback Kyler Murray during minicamp at the teams Tempe training facility. Mandatory Credit: Mark J. Rebilas-USA TODAY Sports" data-portal-copyright="Mark J. Rebilas-USA TODAY Sports" /></p><p>
New faces: QB Kyler Murray, LB Jordan Hicks, OLB Terrell Suggs, OT Marcus Gilbert, CB Robert Alford, CB Byron Murphy, G J.R. Sweezy, DT Darius Philon, G Max Garcia, LB Brooks Reed, TE Charles Clay, DT Terrell McClain, WR Kevin White, DE Zach Allen, WR Andy Isabella, WR Hakeem Butler, QB Brett Hundley
</p>
</p><p>
They&#8217;re gone: QB Josh Rosen, OLB Markus Golden, LB Deone Buccannon, S Antoine Bethea, G Mike Iupati, QB Mike Glennon, DT Olsen Pierre, TE Germaine Gresham, LB Josh Bynes, S Tre Boston
</p>
</p><p>
2019 snapshot: When you have a season as disastrous as Arizona&#8217;s 2018 campaign, blowing everything up and starting over is understandable. Even so, it&#8217;s hard to argue head coach Steve Wilks or Rosen deserved to be sent packing after just one year. Of course, Wilks&#8217; replacement &#8212; Kliff Kingsbury &#8212; had everything to do with why Rosen was shipped to Miami, as Kingsbury wanted Murray to run his Air Raid offense.
</p>
</p><p>
Many might prefer Murray to Rosen, but Rosen was widely viewed as the better prospect coming out of college, and a horrible supporting cast did him no favors in 2018. More importantly, the Cardinals could have had Rosen and Nick Bosa (or Quinnen Williams), but instead wound up with Murray and Isabella (the 62nd pick in return for Rosen). It&#8217;s difficult to agree with that tradeoff.
</p>
</p><p>
Arizona also churned the roster elsewhere, adding three players (Alford, Reed, Clay) before free agency even began, reinforcing the offensive line with Gilbert (via trade) and Sweezy (free agency) and adding Hicks and Suggs to a defense that slipped last season. The draft brought all sorts of potential contributors, with Murphy, Allen, Isabella and Butler all having a chance to grab a role early, and Murray very likely to start.
</p>
</p><p>
Worth the investment?
</p>
</p><p>
&#8211;If you believe in the coach-QB combo, go right ahead with the over on Arizona&#8217;s 5.5-win total. The defense and offensive line should be at least marginally improved, and Murray could win a game or two on his own.
</p>
</p><p>
&#8211;Would you rather take Murray or David Johnson (both at +6600) as a longshot to win MVP? Given Johnson got zero votes after a transcendent 2016 campaign, we&#8217;d lean heavily toward Murray.
</p>
</p><p>
Bottom line: Kingsbury and Murray must hit for Steve Keim&#8217;s risky offseason to be a success, which is far from a certainty. The Cardinals should be fascinating but most likely not major factors in 2019.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Arizona Cardinals training camp primer');return false;"><span class="op-btn">Read More</span> <span class="count">344 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Farizona-cardinals-training-camp-primer%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Arizona Cardinals training camp primer+https://nationalfootballpost.com/?p=106787" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Arizona Cardinals training camp primer&#32;&#32;https://nationalfootballpost.com/?p=106787" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106787"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/washington-redskins-training-camp-primer/" rel="bookmark" title="Washington Redskins training camp primer">Washington Redskins training camp primer</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/washington-redskins-training-camp-primer/" /><meta itemprop="datePublished" content="10 mins ago" /><meta itemprop="dateModified" content="10 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Washington Redskins training camp primer</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12832469.jpg" width="1100" height="733" alt="" title="Jun 4, 2019; Richmond, VA, USA; Washington Redskins quarterback Dwayne Haskins (7) throws the ball during minicamp at Redskins Park. Mandatory Credit: Scott Taetsch-USA TODAY Sports" data-portal-copyright="Scott Taetsch-USA TODAY Sports" /></p> <p> New faces: S Landon Collins, QB Dwayne Haskins, OLB Montez Sweat, QB Case</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Washington Redskins training camp primer</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12832469.jpg" width="1100" height="733" alt="" title="Jun 4, 2019; Richmond, VA, USA; Washington Redskins quarterback Dwayne Haskins (7) throws the ball during minicamp at Redskins Park. Mandatory Credit: Scott Taetsch-USA TODAY Sports" data-portal-copyright="Scott Taetsch-USA TODAY Sports" /></p><p>
New faces: S Landon Collins, QB Dwayne Haskins, OLB Montez Sweat, QB Case Keenum, LB Jon Bostick, OT Ereck Flowers, WR Terry McLaurin, RB Bryce Love
</p>
</p><p>
They&#8217;re gone: WR Jamison Crowder, OLB Preston Smith, LB Zach Brown, S Ha Ha Clinton-Dix, LB Mason Foster, OT Ty Nsekhe, OLB Pernell McPhee, WR Maurice Harris
</p>
</p><p>
2019 snapshot: Normally a very active team, Washington focused more on quality than quantity this offseason, resulting in a number of moves that could be categorized as boom or bust.
</p>
</p><p>
Collins might become the linchpin of a strong defense, or he might struggle in coverage and become an albatross of a contract (six years, $84 million, $44.5 million guaranteed). The deal has no out until at least 2022, and even then would carry $6 million in dead money to escape, making it one of the riskiest handed out this spring. Whether by design or not, the Redskins also let important contributors in Smith, Nsekhe, Clinton-Dix, Brown and Foster depart without many ideal replacements.
</p>
</p><p>
The draft also brought two swings for the fences, even if they were great value. Haskins has the tools to be a franchise quarterback, but he&#8217;ll need protection &#8212; LT Trent Williams&#8217; holdout doesn&#8217;t appear close to an end &#8212; and weapons early on to ease the transition. Sweat could become the star that Smith never was opposite Ryan Kerrigan, but he cost a 2020 second-round pick and was pulled from some teams&#8217; boards due to a heart condition. Both picks seemed like worthwhile gambles, but they are gambles nonetheless.
</p>
</p><p>
The offense could use another weapon, and Williams&#8217; holdout could leave the unit as a disaster. But the defense looks solid, and underrated DL Matt Ioannidis was extended at a nice price (three years, $21.8 million).
</p>
</p><p>
Worth the investment?
</p>
</p><p>
&#8211;Despite lacking a high ceiling, the Redskins have won at least seven games in four straight seasons, which makes the over on their 6.5-win total tempting. With their improving defense and possible upside at quarterback, that figure seems reasonable.
</p>
</p><p>
&#8211;Only four teams &#8212; the Dolphins, Cardinals, Bengals and Bucs &#8212; have longer odds to reach the postseason than Washington (+500). There might be some value there, given the possibility that Haskins pops.
</p>
</p><p>
Bottom line: It could all go south, but it&#8217;s hard to argue with the upside of Haskins, Sweat and Collins. Whether they pay dividends in 2019 remains to be seen.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Washington Redskins training camp primer');return false;"><span class="op-btn">Read More</span> <span class="count">336 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fwashington-redskins-training-camp-primer%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Washington Redskins training camp primer+https://nationalfootballpost.com/?p=106782" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Washington Redskins training camp primer&#32;&#32;https://nationalfootballpost.com/?p=106782" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106782"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/dallas-cowboys-training-camp-primer/" rel="bookmark" title="Dallas Cowboys training camp primer">Dallas Cowboys training camp primer</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/dallas-cowboys-training-camp-primer/" /><meta itemprop="datePublished" content="10 mins ago" /><meta itemprop="dateModified" content="10 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Dallas Cowboys training camp primer</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12877297.jpg" width="1100" height="761" alt="" title="Jun 11, 2019; Frisco, TX, USA; Dallas Cowboys quarterback Dak Prescott (4) goes through a drill during practice at the Ford Center at the Star in Frisco. Mandatory Credit: Tim Heitman-USA TODAY Sports" data-portal-copyright="Tim Heitman-USA TODAY Sports" /></p> <p> New faces: WR Randall Cobb, TE</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Dallas Cowboys training camp primer</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12877297.jpg" width="1100" height="761" alt="" title="Jun 11, 2019; Frisco, TX, USA; Dallas Cowboys quarterback Dak Prescott (4) goes through a drill during practice at the Ford Center at the Star in Frisco. Mandatory Credit: Tim Heitman-USA TODAY Sports" data-portal-copyright="Tim Heitman-USA TODAY Sports" /></p><p>
New faces: WR Randall Cobb, TE Jason Witten, DT Trysten Hill, DT Christian Covington, DT Kerry Hyder, S George Iloka, G Connor McGovern
</p>
</p><p>
They&#8217;re gone: WR Cole Beasley, WR Allen Hurns, DT David Irving, TE Geoff Swaim, LB Damien Wilson
</p>
</p><p>
2019 snapshot: No team answered fewer questions this offseason than the Cowboys, whose long list of players needing contract extensions produced just one deal: five years, $105 million for DE DeMarcus Lawrence.
</p>
</p><p>
Next in line are contract-year players QB Dak Prescott, WR Amari Cooper, CB Byron Jones, LB Jaylon Smith (restricted), OT La&#8217;el Collins, DT Maliek Collins and even head coach Jason Garrett. RB Ezekiel Elliott might also merit an extension &#8212; or choose to hold out if he doesn&#8217;t get one &#8212; though he has a fifth-year option for 2020.
</p>
</p><p>
Prescott is obviously the top priority, but it&#8217;s unclear what his deal will look like. Carson Wentz&#8217;s extension likely raised Prescott&#8217;s price tag, and the QB&#8217;s leverage will only grow, so a deal must come soon if Dallas hopes to use its franchise tag elsewhere next spring. Then again, the Cowboys have just $19.4 million in cap space, so the structure will have to be creative. They would also be wise to extend Cooper &#8212; who cost this year&#8217;s first-round pick &#8212; or Jones before the season, which would provide more options with the tag.
</p>
</p><p>
With limited cap space and draft capital, Dallas made only modest additions, replacing Beasley with Cobb and betting on Rod Marinelli to coach up Hill. McGovern could compete to start, but the draft class otherwise lacked punch. Witten&#8217;s return can&#8217;t hurt, but the 37-year-old is hardly a long-term answer at tight end. Getting Travis Frederick back from missing 2018 due to Guillain-Barre syndrome is extremely welcome.
</p>
</p><p>
Worth the investment?
</p>
</p><p>
&#8211;Dallas hit 10 wins last season and must do so again to top its over/under total (nine). While this team should still be good, the over seems risky if Carson Wentz is fully healthy in Philadelphia.
</p>
</p><p>
&#8211;The Cowboys have a pair of MVP candidates with +5000 odds in Prescott and Elliott. Given how difficult it is for running backs to win the award, we&#8217;d lean toward Prescott with hopes of him blossoming in Kellen Moore&#8217;s system.
</p>
</p><p>
Bottom line: The Cowboys mostly maintained the status quo and now must reproduce last year&#8217;s performance with several high-leverage contract situations simmering. Their fortunes could go in any number of directions.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Dallas Cowboys training camp primer');return false;"><span class="op-btn">Read More</span> <span class="count">344 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fdallas-cowboys-training-camp-primer%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Dallas Cowboys training camp primer+https://nationalfootballpost.com/?p=106777" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Dallas Cowboys training camp primer&#32;&#32;https://nationalfootballpost.com/?p=106777" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106777"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/packers-agree-to-extension-with-de-lowry/" rel="bookmark" title="Packers agree to extension with DE Lowry">Packers agree to extension with DE Lowry</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/packers-agree-to-extension-with-de-lowry/" /><meta itemprop="datePublished" content="10 mins ago" /><meta itemprop="dateModified" content="10 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Packers agree to extension with DE Lowry</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/10458223.jpg" width="1100" height="842" alt="" title="Dec 3, 2017; Green Bay, WI, USA; Green Bay Packers defensive end Dean Lowry (94) reacts after a sack in the third quarter during the game against the Tampa Bay Buccaneers at Lambeau Field. Mandatory Credit: Benny Sieu-USA TODAY Sports" data-portal-copyright="Benny Sieu-USA TODAY</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Packers agree to extension with DE Lowry</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/10458223.jpg" width="1100" height="842" alt="" title="Dec 3, 2017; Green Bay, WI, USA;  Green Bay Packers defensive end Dean Lowry (94) reacts after a sack in the third quarter during the game against the Tampa Bay Buccaneers at Lambeau Field. Mandatory Credit: Benny Sieu-USA TODAY Sports" data-portal-copyright="Benny Sieu-USA TODAY Sports" /></p><p>
The Green Bay Packers agreed on a contract extension with defensive end Dean Lowry, the team announced Tuesday.
</p>
</p><p>
The NFL Network reported Lowry&#8217;s deal is worth $20.325 million over three years.
</p>
</p><p>
The 25-year-old Lowry is slated to make $2.025 this season in the final year of his rookie contract.
</p>
</p><p>
After Green Bay drafted the former Northwestern product in the fourth round of the 2016 NFL Draft, Lowry worked himself into a steady role on the defensive line, playing all but one game since entering the league.
</p>
</p><p>
Last season Lowry posted a career-high 44 tackles, three sacks and three passed defensed in 16 games (eight starts). In three seasons, Lowry owns 84 tackles and seven sacks in 47 games (19 starts).
</p>
</p><p>
This offseason the Packers also added former Ravens D-lineman Za&#8217;Darius Smith via free agency to a defense that recorded 44 sacks last season, ranking tied for eighth-best in the NFL.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Packers agree to extension with DE Lowry');return false;"><span class="op-btn">Read More</span> <span class="count">91 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fpackers-agree-to-extension-with-de-lowry%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Packers agree to extension with DE Lowry+https://nationalfootballpost.com/?p=106772" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Packers agree to extension with DE Lowry&#32;&#32;https://nationalfootballpost.com/?p=106772" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106772"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/report-financial-issues-mount-for-redskins-rb-peterson/" rel="bookmark" title="Report: Financial issues mount for Redskins RB Peterson">Report: Financial issues mount for Redskins RB Peterson</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-financial-issues-mount-for-redskins-rb-peterson/" /><meta itemprop="datePublished" content="10 mins ago" /><meta itemprop="dateModified" content="10 mins ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Report: Financial issues mount for Redskins RB Peterson</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12833282.jpg" width="1100" height="733" alt="" title="Jun 4, 2019; Richmond, VA, USA; Washington Redskins running back Adrian Peterson (26) speaks with the media during minicamp at Redskins Park. Mandatory Credit: Scott Taetsch-USA TODAY Sports" data-portal-copyright="Scott Taetsch-USA TODAY Sports" /></p> <p> Financial problems continue to mount for Washington Redskins</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Report: Financial issues mount for Redskins RB Peterson</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12833282.jpg" width="1100" height="733" alt="" title="Jun 4, 2019; Richmond, VA, USA; Washington Redskins running back Adrian Peterson (26) speaks with the media during minicamp at Redskins Park. Mandatory Credit: Scott Taetsch-USA TODAY Sports" data-portal-copyright="Scott Taetsch-USA TODAY Sports" /></p><p>
Financial problems continue to mount for Washington Redskins running back Adrian Peterson, who is being sued for failure to repay a $5.2 million loan, according to a report Tuesday in The Athletic.
</p>
</p><p>
Now involved in three lawsuits, Peterson owes $6.6 million (which included interest and legal fees) to DeAngelo Vehicle Sales, the company that filed the latest lawsuit in New York, according to The Athletic. He also owes a combined $3 million to two other creditors.
</p>
</p><p>
Chase Carlson, the lawyer for the 34-year-old Peterson, believes his client&#8217;s problems involve a matter of trusting the wrong people.
</p>
</p><p>
&#8220;The truth behind Adrian Peterson&#8217;s current financial situation is more than is being reported at this time,&#8221; Carlson said in a statement. &#8220;Because of ongoing legal matters, I am unable to go into detail, but I will say this is yet another situation of an athlete trusting the wrong people and being taken advantage of by those he trusted. Adrian and his family look forward to sharing further details when appropriate.&#8221;
</p>
</p><p>
Peterson reportedly has earned $99.22 million in his 12-year career, according to Spotrac.com, during which the seven-time Pro Bowler moved up to rank eighth in NFL history with 13,318 rushing yards.
</p>
</p><p>
Peterson, who agreed in March to a two-year deal with Washington worth up to $5 million that also includes annual incentives of $1.5 million, enters training camp on Wednesday in competition with Derrius Guice for the starting job.
</p>
</p><p>
Peterson rushed for 1,042 yards and seven touchdowns in 16 games for the Redskins last season after signing late in training camp following Guice&#8217;s torn ACL.
</p>
</p><p>
The 1,000-yard campaign was the eighth of Peterson&#8217;s career, topped by his memorable 2,097-yard season with the Minnesota Vikings in 2012, when he fell 8 yards shy of Eric Dickerson&#8217;s all-time mark set in 1984. With another 1,000-yard season, Peterson would pass three more players &#8212; Jerome Bettis (13,662), LaDainian Tomlinson (13,684) and Curtis Martin (14,101) on the career rushing list.
</p>
</p><p>
Peterson is tied with Jim Brown for fifth all-time with 106 career rushing scores. He needs five more to pass Walter Payton for fourth.
</p>
</p><p>
Peterson also has 272 receptions for 2,223 yards and six touchdowns during his 149-game career.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Report: Financial issues mount for Redskins RB Peterson');return false;"><span class="op-btn">Read More</span> <span class="count">296 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-financial-issues-mount-for-redskins-rb-peterson%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Financial issues mount for Redskins RB Peterson+https://nationalfootballpost.com/?p=106767" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Financial issues mount for Redskins RB Peterson&#32;&#32;https://nationalfootballpost.com/?p=106767" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106767"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/golf-glance-loaded-wgc-field-takes-aim-following-major/" rel="bookmark" title="Golf Glance: Loaded WGC field takes aim following major">Golf Glance: Loaded WGC field takes aim following major</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/golf-glance-loaded-wgc-field-takes-aim-following-major/" /><meta itemprop="datePublished" content="4 hours ago" /><meta itemprop="dateModified" content="4 hours ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Golf Glance: Loaded WGC field takes aim following major</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/10886588.jpg" width="1100" height="748" alt="" title="Jun 10, 2018; Memphis, TN, USA; Dustin Johnson hits his tee shot on the 9th hole during the final round of the FedEx St. Jude Classic golf tournament at TPC Southwind. Mandatory Credit: Christopher Hanewinckel-USA TODAY Sports" data-portal-copyright="Christopher Hanewinckel-USA TODAY Sports"</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Golf Glance: Loaded WGC field takes aim following major</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/10886588.jpg" width="1100" height="748" alt="" title="Jun 10, 2018; Memphis, TN, USA; Dustin Johnson hits his tee shot on the 9th hole during the final round of the FedEx St. Jude Classic golf tournament at TPC Southwind. Mandatory Credit: Christopher Hanewinckel-USA TODAY Sports" data-portal-copyright="Christopher Hanewinckel-USA TODAY Sports" /></p><p>
Field Level Media&#8217;s Golf Glance provides weekly news and storylines from each of the major North American golf tours.
</p>
</p><p>
PGA TOUR
</p><p>
LAST TOURNAMENT: The Open Championship (Shane Lowry)
</p><p>
THIS WEEK: WGC-FedEx St. Jude, July 25-28
</p><p>
TPC Southwind, Memphis, Tenn. (Par 70, 7,238 yards)
</p><p>
Purse: $10.25 million (Winner: $1.742 million)
</p><p>
Defending champion: Justin Thomas
</p><p>
FedEx Cup leader: Brooks Koepka
</p><p>
Television: Thursday-Friday, 2-7 p.m. ET (Golf Channel). Saturday-Sunday, noon-1:45 p.m. (GC), 2-6 p.m. (CBS).
</p><p>
NOTES: The event moves to TPC Southwind from Akron&#8217;s Firestone Country Club. &#8230; Tiger Woods holds the 72-hole event scoring record of 259 set in 2000 at Firestone. He is not in the field this week. &#8230; Dustin Johnson&#8217;s six WGC victories are second only to Woods. He is a two-time winner at TPC Southwind, including last year&#8217;s finale of a 30-year run as a regular PGA Tour stop&#8230;. Lowry withdrew on Tuesday. &#8230; Woods and Italy&#8217;s sixth-ranked Francesco Molinari are the top players skipping this week&#8217;s event. &#8230; Recent winners Nate Lashley and Matthew Wolff will compete in their first career WGC events.
</p><p>
BEST BETS: Koepka (10/1 by PointsBet) owns a scoring average of 68.70 at TPC Southwind, if he can regain focus for a non-major. &#8230; Johnson (9/1) hasn&#8217;t been in top form this summer, but he does own a career scoring average of 67.75 in 20 rounds at TPC Southwind. &#8230; Justin Rose (20/1) will get his first look at the course in competition, but it&#8217;s a scorable track that should suit his tee-to-green game. &#8230; Danny Willett (70/1) is a solid under-the-radar pick who has T15s in three of his past four events, including the past two majors.
</p>
</p><p>
THIS WEEK: Barracuda Championship, July 25-28
</p><p>
Montreux Golf & Country Club, Reno, Nev. (Par 72, 7,472 yards)
</p><p>
Purse: $3.5 million (Winner: $612,000 &#8211; based on 2018)
</p><p>
Defending champion: Andrew Putnam
</p><p>
Television: Thursday-Friday, 7-9:30 p.m. ET (Golf Channel). Saturday-Sunday, 5-8 p.m. (GC).
</p><p>
NOTES: The opposite-field event is the only one on the PGA Tour to use the Modified Stableford scoring format, which awards eight points for a double eagle, five points for an eagle and two points for a birdie. No points are awarded for par, with a bogey costing a player one point and a double bogey or worse earning a minus-3 score. &#8230; The Montreux G&CC is a Jack Nicklaus design that sits approximately 5,500 feet above sea level between Lake Tahoe and Reno. &#8230; Putnam is not competing after qualifying for the WGC-FedEx St. Jude. &#8230; Korean pro Ho Sung Choi, who is known for his &#8220;fisherman&#8221; swing, will make his third PGA Tour start of the year.
</p><p>
NEXT WEEK: The Northern Trust, Jersey City, N.J.
</p>
</p><p>
LPGA TOUR
</p><p>
LAST TOURNAMENT: Dow Great Lakes Bay Invitational (Jasmine Suwannapura, Cydney Clanton)
</p><p>
THIS WEEK: The Evian Championship, July 25-28
</p><p>
Evian Resort Golf Club, Evian-les-Bains, France (Par 71, 6,527 yards)
</p><p>
Purse: $4.1 million (Winner: $615,000)
</p><p>
Defending champion: Angela Stanford
</p><p>
CME Race to the Globe leader: Jin Young Ko
</p><p>
Television: Thursday-Friday: 5-7 a.m., 9:30-11:30 a.m. (Golf Channel); Saturday-Sunday: 6-9 a.m. (GC), 9-11:30 a.m. (CNBC)
</p><p>
NOTES: This is the seventh year of the event being a major on the LPGA Tour. &#8230; Thirty-seven of the top 40 players in the Rolex Rankings &#8211; including each of the top 10 &#8211; are in the 120-player field. &#8230;  This is the first of two consecutive weeks of women&#8217;s majors. &#8230; Stanford earned her first career major at last year&#8217;s Evian in her 436th career LPGA start when Amy Olson double-bogeyed the 72nd hole. &#8230; Top-ranked Sung Hyun Park missed the cut last year. &#8230; The par-4 18th hole has been changed to a drivable par-5. &#8230; After being plagued by poor weather each of the past five years, The Evian was moved to July from mid-September. &#8230;
</p><p>
NEXT TOURNAMENT: AIG Women&#8217;s British Open, Milton Keynes, England
</p>
</p><p>
CHAMPIONS TOUR
</p><p>
LAST TOURNAMENT: Senior Players Championship (Retief Goosen)
</p><p>
THIS WEEK: The Senior Open Championship, July 25-28
</p><p>
Royal Lytham & St. Annes, Lytham, United Kingdom (Par 70, 6,948 yards)
</p><p>
Purse: $2 million (Winner: $314,330)
</p><p>
Defending champion: Miguel Angel Jimenez
</p><p>
Charles Schwab Cup leader: Scott McCarron
</p><p>
Television: Thursday-Friday: 7-9:30 a.m., 11:30 a.m.-2 p.m. ET (Golf Channel); Saturday-Sunday: 9:30 a.m.-12 p.m. (GC), 12 p.m.-2 p.m. (NBC)
</p><p>
NOTES: This is the fifth and final Champions major of the year. &#8230; Royal Lytham & St. Annes will play host to its fifth Senior Open and first since 1994. The five past Open Championship winners in the field include Darren Clarke and Paul Lawrie, who will make their Senior Open debuts. &#8230; Jimenez became the first Spaniard to win the Senior Open when he edged Bernhard Langer at St. Andrews for his first career Seniors major. &#8230; Gary Nicklaus and Golf Channel analyst Brandel Chamblee are among the 49 players who qualified on Monday. Esteban Toledo is the top-ranked player among the group at No. 50.
</p><p>
NEXT TOURNAMENT: DICK&#8217;S Sporting Goods Open, Endicott, N.Y., Aug. 16-18.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Golf Glance: Loaded WGC field takes aim following major');return false;"><span class="op-btn">Read More</span> <span class="count">736 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fgolf-glance-loaded-wgc-field-takes-aim-following-major%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Golf Glance: Loaded WGC field takes aim following major+https://nationalfootballpost.com/?p=106762" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Golf Glance: Loaded WGC field takes aim following major&#32;&#32;https://nationalfootballpost.com/?p=106762" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106762"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/report-cowboys-releasing-wr-hurns/" rel="bookmark" title="Report: Cowboys releasing WR Hurns">Report: Cowboys releasing WR Hurns</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-cowboys-releasing-wr-hurns/" /><meta itemprop="datePublished" content="4 hours ago" /><meta itemprop="dateModified" content="4 hours ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Report: Cowboys releasing WR Hurns</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/11993047.jpg" width="1100" height="733" alt="" title="Jan 5, 2019; Arlington, TX, USA; Dallas Cowboys wide receiver Allen Hurns (17) warms up before the NFC Wild Card playoff football game against the Seattle Seahawks at AT&amp;T Stadium. Mandatory Credit: Shane Roper-USA TODAY Sports" data-portal-copyright="Shane Roper-USA TODAY Sports" /></p> <p> The Dallas Cowboys</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Report: Cowboys releasing WR Hurns</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/11993047.jpg" width="1100" height="733" alt="" title="Jan 5, 2019; Arlington, TX, USA; Dallas Cowboys wide receiver Allen Hurns (17) warms up before the NFC Wild Card playoff football game against the Seattle Seahawks at AT&T Stadium. Mandatory Credit: Shane Roper-USA TODAY Sports" data-portal-copyright="Shane Roper-USA TODAY Sports" /></p><p>
The Dallas Cowboys are releasing veteran wide receiver Allen Hurns, multiple outlets reported Tuesday.
</p>
</p><p>
Hurns, 27, caught 20 passes for 295 yards and two touchdowns in 16 games during his first season in Dallas in 2018.
</p>
</p><p>
His season ended in horrific fashion, however, as he suffered a dislocated left ankle and broken fibula in the NFC wild-card game against Seattle on Jan. 5.
</p>
</p><p>
Hurns was due to be paid $4 million in base salary in 2019 with a salary cap hit of $6.25 million.
</p>
</p><p>
&#8220;The Cowboys wanted (him) back at a lower price, but he wanted to test the market. So Hurns gets his wish,&#8221; ESPN&#8217;s Adam Schefter tweeted.
</p>
</p><p>
Last month, Hurns estimated that he was about 90 percent recovered from the injuries.
</p>
</p><p>
&#8220;My main thing is to get healthy, put together a great training camp and go from there,&#8221; he said.
</p>
</p><p>
Hurns played his first four seasons in Jacksonville (2014-17). His best season with the Jaguars came in 2015 with 64 catches for 1,031 yards and 10 touchdowns, all career bests.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Report: Cowboys releasing WR Hurns');return false;"><span class="op-btn">Read More</span> <span class="count">106 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-cowboys-releasing-wr-hurns%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Cowboys releasing WR Hurns+https://nationalfootballpost.com/?p=106757" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Cowboys releasing WR Hurns&#32;&#32;https://nationalfootballpost.com/?p=106757" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106757"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/reports-redskins-to-part-ways-with-lb-mason-foster/" rel="bookmark" title="Reports: Redskins to part ways with LB Mason Foster">Reports: Redskins to part ways with LB Mason Foster</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/reports-redskins-to-part-ways-with-lb-mason-foster/" /><meta itemprop="datePublished" content="4 hours ago" /><meta itemprop="dateModified" content="4 hours ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Reports: Redskins to part ways with LB Mason Foster</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12832518.jpg" width="1100" height="733" alt="" title="Jun 4, 2019; Richmond, VA, USA; Washington Redskins inside linebacker Mason Foster (54) runs with the ball during minicamp at Redskins Park. Mandatory Credit: Scott Taetsch-USA TODAY Sports" data-portal-copyright="Scott Taetsch-USA TODAY Sports" /></p> <p> The Washington Redskins are releasing veteran linebacker</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Reports: Redskins to part ways with LB Mason Foster</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12832518.jpg" width="1100" height="733" alt="" title="Jun 4, 2019; Richmond, VA, USA; Washington Redskins inside linebacker Mason Foster (54) runs with the ball during minicamp at Redskins Park. Mandatory Credit: Scott Taetsch-USA TODAY Sports" data-portal-copyright="Scott Taetsch-USA TODAY Sports" /></p><p>
The Washington Redskins are releasing veteran linebacker Mason Foster ahead of training camp, according to multiple reports Tuesday.
</p>
</p><p>
Foster, 30, is coming off a season in which he made a career-high 131 tackles and intercepted two passes while starting all 16 games.
</p>
</p><p>
Foster seemed to be in line for a starting role again, especially after the Redskins lost Reuben Foster to a torn ACL in spring camp, but the release signals that the team is comfortable with second-year pro Shaun Dion Hamilton and Jon Bostic (signed after Reuben Foster&#8217;s injury) as the starting inside linebackers.
</p>
</p><p>
The Redskins will save $4 million in salary cap space, according to reports, by releasing Mason Foster.
</p>
</p><p>
Foster, Tampa Bay&#8217;s third-round pick in the 2011 NFL Draft, spent his first four seasons with the Buccaneers before signing with the Redskins in late September 2015. He has 661 career tackles, with 41 for loss and 8.5 sacks, in 107 games (92 starts).
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Reports: Redskins to part ways with LB Mason Foster');return false;"><span class="op-btn">Read More</span> <span class="count">97 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freports-redskins-to-part-ways-with-lb-mason-foster%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Reports: Redskins to part ways with LB Mason Foster+https://nationalfootballpost.com/?p=106752" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Reports: Redskins to part ways with LB Mason Foster&#32;&#32;https://nationalfootballpost.com/?p=106752" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106752"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/reports-wr-boyd-agrees-to-43m-extension-with-bengals/" rel="bookmark" title="Reports: WR Boyd agrees to $43M extension with Bengals">Reports: WR Boyd agrees to $43M extension with Bengals</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/reports-wr-boyd-agrees-to-43m-extension-with-bengals/" /><meta itemprop="datePublished" content="4 hours ago" /><meta itemprop="dateModified" content="4 hours ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Reports: WR Boyd agrees to $43M extension with Bengals</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/11693835.jpg" width="1100" height="733" alt="" title="Nov 18, 2018; Baltimore, MD, USA; Cincinnati Bengals wide receiver Tyler Boyd (83) lands after a fourth quarter reception against the Baltimore Ravens at M&amp;T Bank Stadium. Mandatory Credit: Tommy Gilligan-USA TODAY Sports" data-portal-copyright="Tommy Gilligan-USA TODAY Sports" /></p> <p> Cincinnati wide</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Reports: WR Boyd agrees to $43M extension with Bengals</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/11693835.jpg" width="1100" height="733" alt="" title="Nov 18, 2018; Baltimore, MD, USA;  Cincinnati Bengals wide receiver Tyler Boyd (83)  lands after a fourth quarter reception  against the Baltimore Ravens  at M&T Bank Stadium. Mandatory Credit: Tommy Gilligan-USA TODAY Sports" data-portal-copyright="Tommy Gilligan-USA TODAY Sports" /></p><p>
Cincinnati wide receiver Tyler Boyd, coming off a breakout season, agreed to a four-year, $43 million extension Tuesday that keeps him under contract through the 2023 season, according to multiple reports.
</p>
</p><p>
Boyd, 24, is entering the final year of his rookie contract and due to make about $1.03 million. The 2016 second-round pick out of Pittsburgh will make $11.3 million in the first year of his new contract, according to Tom Pelissero of the NFL Network.
</p>
</p><p>
Boyd caught 76 passes for 1,028 yards and seven touchdowns in 14 games (all starts) last season. The slot receiver had a combined 76 receptions for 828 yards and three scores in his first two seasons in Cincinnati.
</p>
</p><p>
&#8220;He doesn&#8217;t scare,&#8221; Bengals owner Mike Brown said of Boyd, according to the team&#8217;s official website. &#8220;He&#8217;s a difference-maker.&#8221;
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Reports: WR Boyd agrees to $43M extension with Bengals');return false;"><span class="op-btn">Read More</span> <span class="count">74 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freports-wr-boyd-agrees-to-43m-extension-with-bengals%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Reports: WR Boyd agrees to $43M extension with Bengals+https://nationalfootballpost.com/?p=106747" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Reports: WR Boyd agrees to $43M extension with Bengals&#32;&#32;https://nationalfootballpost.com/?p=106747" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106747"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/gaine-returns-to-bills-as-senior-personnel-adviser/" rel="bookmark" title="Gaine returns to Bills as senior personnel adviser">Gaine returns to Bills as senior personnel adviser</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/gaine-returns-to-bills-as-senior-personnel-adviser/" /><meta itemprop="datePublished" content="4 hours ago" /><meta itemprop="dateModified" content="4 hours ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Gaine returns to Bills as senior personnel adviser</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/11945823.jpg" width="1100" height="740" alt="" title="Jan 5, 2019; Houston, TX, USA; Houston Texans general manager Brian Gaine before a AFC Wild Card playoff football game against the Indianapolis Colts at NRG Stadium. Mandatory Credit: Troy Taormina-USA TODAY Sports" data-portal-copyright="Troy Taormina-USA TODAY Sports" /></p> <p> Former Houston Texans</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Gaine returns to Bills as senior personnel adviser</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/11945823.jpg" width="1100" height="740" alt="" title="Jan 5, 2019; Houston, TX, USA; Houston Texans general manager Brian Gaine before a AFC Wild Card playoff football game against the Indianapolis Colts at NRG Stadium. Mandatory Credit: Troy Taormina-USA TODAY Sports" data-portal-copyright="Troy Taormina-USA TODAY Sports" /></p><p>
Former Houston Texans general manager Brian Gaine is back in Buffalo after being named the Bills&#8217; senior personnel adviser on Tuesday.
</p>
</p><p>
Gaine will work in college and pro scouting under Bills&#8217; GM Brandon Beane, according to a team statement.
</p>
</p><p>
The Texans abruptly fired Gaine last month after just one season, even though Houston finished 11-5 and won the AFC South title before losing to the Indianapolis Colts in the wild-card round.
</p>
</p><p>
He had signed a five-year contract in January 2018.
</p>
</p><p>
&#8220;While the timing may be unusual, this decision was made in the best interest of our organization in our quest to build a championship team for the City of Houston,&#8221; Texans chairman and CEO Cal McNair said in a statement at that time.
</p>
</p><p>
Gaine spent three seasons with the Texans as director of player personnel from 2014-16, before joining the Bills as vice president of player personnel in 2017. He was hired as the Texans&#8217; GM after Rick Smith took a leave of absence from the position to care for his wife as she battled cancer.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Gaine returns to Bills as senior personnel adviser');return false;"><span class="op-btn">Read More</span> <span class="count">125 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fgaine-returns-to-bills-as-senior-personnel-adviser%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Gaine returns to Bills as senior personnel adviser+https://nationalfootballpost.com/?p=106742" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Gaine returns to Bills as senior personnel adviser&#32;&#32;https://nationalfootballpost.com/?p=106742" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106742"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/lowry-bows-out-of-wgc-fedex-st-jude-invitational/" rel="bookmark" title="Lowry bows out of WGC-FedEx St. Jude Invitational">Lowry bows out of WGC-FedEx St. Jude Invitational</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/lowry-bows-out-of-wgc-fedex-st-jude-invitational/" /><meta itemprop="datePublished" content="4 hours ago" /><meta itemprop="dateModified" content="4 hours ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Lowry bows out of WGC-FedEx St. Jude Invitational</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/13078817.jpg" width="1100" height="733" alt="" title="Jul 21, 2019; Portrush, IRL; Shane Lowry celebrates with the Claret Jug after winning The Open Championship golf tournament during the final round at Royal Portrush Golf Club - Dunluce Course. Mandatory Credit: Steve Flynn-USA TODAY Sports" data-portal-copyright="Steve Flynn-USA TODAY Sports" /></p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Lowry bows out of WGC-FedEx St. Jude Invitational</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/13078817.jpg" width="1100" height="733" alt="" title="Jul 21, 2019; Portrush, IRL; Shane Lowry celebrates with the Claret Jug  after winning The Open Championship golf tournament during the final round at Royal Portrush Golf Club -  Dunluce Course. Mandatory Credit: Steve Flynn-USA TODAY Sports" data-portal-copyright="Steve Flynn-USA TODAY Sports" /></p><p>
Shane Lowry, coming off his first major victory at the Open Championship, withdrew Tuesday from this week&#8217;s World Golf Championships-FedEx St. Jude Invitational in Memphis.
</p>
</p><p>
Lowry, who began 2019 ranked No. 75 in the official world golf rankings, jumped 16 spots to No. 17 after last week&#8217;s triumph at Royal Portrush in Northern Ireland. The Irishman was in his hometown of Clara on Tuesday for an event at his country club to celebrate his six-stroke victory.
</p>
</p><p>
The WGC-FedEx St. Jude Invitational begins Thursday at TPC Southwind with a strong field that includes world No. 1 Brooks Koepka, Irishman Rory McIlroy (coming off his missed cut at the Open Championship), Dustin Johnson, Xander Schauffele, Justin Rose and defending champion Justin Thomas.
</p>
</p><p>
Tiger Woods, Rickie Fowler and Francesco Molinari are among those not competing this week.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Lowry bows out of WGC-FedEx St. Jude Invitational');return false;"><span class="op-btn">Read More</span> <span class="count">80 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Flowry-bows-out-of-wgc-fedex-st-jude-invitational%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Lowry bows out of WGC-FedEx St. Jude Invitational+https://nationalfootballpost.com/?p=106737" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Lowry bows out of WGC-FedEx St. Jude Invitational&#32;&#32;https://nationalfootballpost.com/?p=106737" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106737"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/report-cowboys-c-frederick-ready-for-camp/" rel="bookmark" title="Report: Cowboys C Frederick ready for camp">Report: Cowboys C Frederick ready for camp</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-cowboys-c-frederick-ready-for-camp/" /><meta itemprop="datePublished" content="4 hours ago" /><meta itemprop="dateModified" content="4 hours ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Report: Cowboys C Frederick ready for camp</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/11455994.jpg" width="1100" height="806" alt="" title="Oct 14, 2018; Arlington, TX, USA; Dallas Cowboys injured center Travis Frederick sits on the bench during the game against the Jacksonville Jaguars at AT&amp;T Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports" data-portal-copyright="Matthew Emmons-USA TODAY Sports" /></p> <p> Dallas Cowboys center Travis Frederick,</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Report: Cowboys C Frederick ready for camp</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/11455994.jpg" width="1100" height="806" alt="" title="Oct 14, 2018; Arlington, TX, USA; Dallas Cowboys injured center Travis Frederick sits on the bench during the game against the Jacksonville Jaguars at AT&T Stadium. Mandatory Credit: Matthew Emmons-USA TODAY Sports" data-portal-copyright="Matthew Emmons-USA TODAY Sports" /></p><p>
Dallas Cowboys center Travis Frederick, who missed last season as he recovered from Guillain-Barre syndrome, is expected to be active for the start of training camp on Saturday, the NFL Network&#8217;s Ian Rapoport reported Tuesday.
</p>
</p><p>
Frederick, 28, was diagnosed with the rare auto-immune disorder during training camp last year. He has been with the Cowboys since they drafted him in the first round out of Wisconsin in 2013. He started all 80 regular-season games and three playoff games in his first five seasons, earning four Pro Bowl selections and a first-team All-Pro nod in 2016.
</p>
</p><p>
&#8220;This is very good news for this Cowboys&#8217; offensive line, still the strength of their team,&#8221; Rapoport said on the NFL Network. &#8220;He has, in fact, returned to full form.&#8221;
</p>
</p><p>
Frederick participated in individual drills in offseason workouts, when he also was recovering from hernia and shoulder surgeries.
</p>
</p><p>
He told reporters in April that he had never heard of Guillain-Barre syndrome &#8212; in which the body&#8217;s immune system attacks nerves &#8212; before he was diagnosed. He said it also took doctors awhile to figure out the cause of his symptoms, which included stingers and numbness in his toes or hands.
</p>
</p><p>
Frederick said the thought crossed his mind that he might never play again.
</p>
</p><p>
&#8220;But once the improvement started, and it happened at such an impressive rate, it makes you think, &#8216;OK, maybe there is a chance here,'&#8221; he said. &#8220;And if it continues at this rate, I don&#8217;t see any reason why I can&#8217;t be back to 100 percent.&#8221;
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Report: Cowboys C Frederick ready for camp');return false;"><span class="op-btn">Read More</span> <span class="count">200 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-cowboys-c-frederick-ready-for-camp%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Cowboys C Frederick ready for camp+https://nationalfootballpost.com/?p=106732" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Cowboys C Frederick ready for camp&#32;&#32;https://nationalfootballpost.com/?p=106732" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106732"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/broncos-add-punter-waive-kicker/" rel="bookmark" title="Broncos add punter, waive kicker">Broncos add punter, waive kicker</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/broncos-add-punter-waive-kicker/" /><meta itemprop="datePublished" content="4 hours ago" /><meta itemprop="dateModified" content="4 hours ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Broncos add punter, waive kicker</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/10378175.jpg" width="1100" height="794" alt="" title="Oct 22, 2017; Green Bay, WI, USA; Green Bay Packers punter Justin Vogel (8) during the game against the New Orleans Saints at Lambeau Field. Mandatory Credit: Jeff Hanisch-USA TODAY Sports" data-portal-copyright="Jeff Hanisch-USA TODAY Sports" /></p> <p> The Denver Broncos signed punter Justin Vogel and</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Broncos add punter, waive kicker</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/10378175.jpg" width="1100" height="794" alt="" title="Oct 22, 2017; Green Bay, WI, USA; Green Bay Packers punter Justin Vogel (8) during the game against the New Orleans Saints at Lambeau Field. Mandatory Credit: Jeff Hanisch-USA TODAY Sports" data-portal-copyright="Jeff Hanisch-USA TODAY Sports" /></p><p>
The Denver Broncos signed punter Justin Vogel and waived kicker Taylor Bertolet on Tuesday.
</p>
</p><p>
Vogel, 25, averaged 44.4 yards on 71 punts for the Green Bay Packers in 2017 but was released when the team drafted JK Scott out of Alabama. Vogel was with the Cleveland Browns in 2018 training camp and also spent time with the San Francisco 49ers this past offseason.
</p>
</p><p>
Vogel is expected to compete with Colby Wadman, who averaged 44.7 yards in 12 games last season.
</p>
</p><p>
Bertolet&#8217;s release leaves Brandon McManus as the only kicker on the camp roster. He hit 20 of 25 field goal attempts last season, with a long of 53.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Broncos add punter, waive kicker');return false;"><span class="op-btn">Read More</span> <span class="count">46 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fbroncos-add-punter-waive-kicker%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Broncos add punter, waive kicker+https://nationalfootballpost.com/?p=106727" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Broncos add punter, waive kicker&#32;&#32;https://nationalfootballpost.com/?p=106727" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106727"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/report-lions-cb-slay-will-report-to-camp/" rel="bookmark" title="Report: Lions CB Slay will report to camp">Report: Lions CB Slay will report to camp</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-lions-cb-slay-will-report-to-camp/" /><meta itemprop="datePublished" content="8 hours ago" /><meta itemprop="dateModified" content="8 hours ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Report: Lions CB Slay will report to camp</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/10482080.jpg" width="1100" height="733" alt="" title="Dec 16, 2017; Detroit, MI, USA; Detroit Lions cornerback Darius Slay (23) smiles after getting an interception during the second half against the Chicago Bears at Ford Field. Mandatory Credit: Raj Mehta-USA TODAY Sports" data-portal-copyright="Raj Mehta-USA TODAY Sports" /></p> <p> Detroit Lions</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Report: Lions CB Slay will report to camp</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/10482080.jpg" width="1100" height="733" alt="" title="Dec 16, 2017; Detroit, MI, USA; Detroit Lions cornerback Darius Slay (23) smiles after getting an interception during the second half against the Chicago Bears at Ford Field. Mandatory Credit: Raj Mehta-USA TODAY Sports" data-portal-copyright="Raj Mehta-USA TODAY Sports" /></p><p>
Detroit Lions cornerback Darius Slay will attend training camp Wednesday despite his contract dispute, multiple outlets reported Tuesday.
</p>
</p><p>
The two-time Pro Bowl selection skipped a mandatory minicamp in June and missed voluntary workouts this spring, but sources told the Detroit Free Press and ESPN that Slay will not hold out.
</p>
</p><p>
Slay, 28, has tallied 17 interceptions and has broken up a league-high 91 passes since entering the NFL as a second-round pick in 2013.
</p>
</p><p>
Slay has two years remaining on a contract that will pay him $12.55 million in 2019 and $10 million in 2020.
</p>
</p><p>
Defensive tackle Damon Harrison, who like Slay is represented by agent Drew Rosenhaus, said Monday that he would also report to camp on time. Rosenhaus was reportedly scheduled to meet with Detroit officials this week.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Report: Lions CB Slay will report to camp');return false;"><span class="op-btn">Read More</span> <span class="count">73 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-lions-cb-slay-will-report-to-camp%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: Lions CB Slay will report to camp+https://nationalfootballpost.com/?p=106722" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: Lions CB Slay will report to camp&#32;&#32;https://nationalfootballpost.com/?p=106722" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106722"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/report-qb-sanchez-retiring-to-join-abc/" rel="bookmark" title="Report: QB Sanchez retiring to join ABC">Report: QB Sanchez retiring to join ABC</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/report-qb-sanchez-retiring-to-join-abc/" /><meta itemprop="datePublished" content="8 hours ago" /><meta itemprop="dateModified" content="8 hours ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Report: QB Sanchez retiring to join ABC</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/11855802.jpg" width="1100" height="733" alt="" title="Dec 16, 2018; Jacksonville, FL, USA; Washington Redskins quarterback Mark Sanchez (6) look on prior to the game at TIAA Bank Field. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports" /></p> <p> Quarterback Mark Sanchez is retiring after 10 years in</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Report: QB Sanchez retiring to join ABC</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/11855802.jpg" width="1100" height="733" alt="" title="Dec 16, 2018; Jacksonville, FL, USA; Washington Redskins quarterback Mark Sanchez (6) look on prior to the game at TIAA Bank Field. Mandatory Credit: Kim Klement-USA TODAY Sports" data-portal-copyright="Kim Klement-USA TODAY Sports" /></p><p>
Quarterback Mark Sanchez is retiring after 10 years in the NFL to join ABC&#8217;s college football coverage, the New York Post reported Tuesday.
</p>
</p><p>
Sanchez, 32, led the New York Jets to back-to-back AFC Championship Game appearances in the 2009 and 2010 seasons and later played for the Philadelphia Eagles, Dallas Cowboys and most recently the Washington Redskins in 2018.
</p>
</p><p>
According to the Post, he will replace Mack Brown in the ABC studio. Brown left to coach at North Carolina.
</p>
</p><p>
Sanchez compiled a 37-36 career record, completing 56.6 percent of his passes for 15,357 yards with 86 touchdowns and 89 interceptions.
</p>
</p><p>
His best years came with the Jets, who made &#8220;The Sanchize&#8221; the No. 5 overall pick in the 2009 NFL Draft out of Southern California.
</p>
</p><p>
Sanchez set career highs in his third season with New York in 2011, throwing for 3,474 yards and 26 TDs.
</p>
</p><p>
He appeared in two games (one start) with Washington last season, completing 19 of 35 passes for 138 yards with three interceptions.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Report: QB Sanchez retiring to join ABC');return false;"><span class="op-btn">Read More</span> <span class="count">100 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Freport-qb-sanchez-retiring-to-join-abc%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Report: QB Sanchez retiring to join ABC+https://nationalfootballpost.com/?p=106717" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Report: QB Sanchez retiring to join ABC&#32;&#32;https://nationalfootballpost.com/?p=106717" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106717"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/odds-favor-pats-as-camps-spring-into-action/" rel="bookmark" title="Odds favor Pats as camps spring into action">Odds favor Pats as camps spring into action</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/odds-favor-pats-as-camps-spring-into-action/" /><meta itemprop="datePublished" content="8 hours ago" /><meta itemprop="dateModified" content="8 hours ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Odds favor Pats as camps spring into action</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12839511.jpg" width="1100" height="732" alt="" title="Jun 5, 2019; Foxborough, MA, USA; New England Patriots quarterback Tom Brady (12) makes a pass during mandatory minicamp at the Gillette Stadium practice field. Mandatory Credit: Greg M. Cooper-USA TODAY Sports" data-portal-copyright="Greg M. Cooper-USA TODAY Sports" /></p> <p> All 32 NFL</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Odds favor Pats as camps spring into action</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/12839511.jpg" width="1100" height="732" alt="" title="Jun 5, 2019; Foxborough, MA, USA; New England Patriots quarterback Tom Brady (12) makes a pass during mandatory minicamp at the Gillette Stadium practice field. Mandatory Credit: Greg M. Cooper-USA TODAY Sports" data-portal-copyright="Greg M. Cooper-USA TODAY Sports" /></p><p>
All 32 NFL training camps will be open by the end of the week, with hope springing eternal for most every franchise before the live bullets start flying in September.
</p>
</p><p>
The New England Patriots may have lost future Hall of Fame tight end Rob Gronkowski to retirement during another offseason that brought a bevy of changes to the two-deep. But with Tom Brady still calling the shots behind center and some deft moves to reload during free agency and the NFL Draft, the reigning champs open their training camp on Wednesday as the early favorites to take home another title in Super Bowl 54.
</p>
</p><p>
FanDuel lists the Patriots as 7/1 favorites, while PointsBet (6 1/2-1) and William Hill (5 1/2-1) have even more bullish odds. With big-play threat Tyreek Hill learning he will not be suspended to begin the season, the Kansas City Chiefs are the second betting favorite by all three books: 6-1 by William Hill and 8-1 by both FanDuel and PointsBet.
</p>
</p><p>
Where the differences start to come in is beyond the two AFC powers.
</p>
</p><p>
PointsBet has the New Orleans Saints at 9-1, with the next closest being the Indianapolis Colts and Los Angeles Rams at 11-1. FanDuel has the same three teams from Nos. 3-5, with the Saints at 9-1, followed by the Rams (10/1) and the Colts, who are 14-1 along with the Philadelphia Eagles.
</p>
</p><p>
William Hill gives a nod at No. 3 to the Rams at 8 1/2-1, followed by the Saints (10-1) and then the Chicago Bears (11-1). The Colts are sixth at 12-1, followed by the Eagles (13-1)
</p>
</p><p>
The Cleveland Browns are the chic pick by many following an exciting close to 2018 and a slew of offseason changes highlighted by the addition of Odell Beckham Jr. They open camp at 14-1 by PointsBet and William Hill and 16-1 by FanDuel.
</p>
</p><p>
Looking for a longshot? William Hill is offering the Miami Dolphins at 200-1, while PointsBet and FanDuel list them at 150-1. You can also get 150 on the Cincinnati Bengals from PointsBet and William Hill. FanDuel is slightly more bullish on the Bengals&#8217; prospects at 120-1.
</p>
</p><p>
NFL Super Bowl Winner Odds (PointsBet)
</p><p>
New England Patriots: +650
</p><p>
Kansas City Chiefs: +800
</p><p>
New Orleans Saints: +900
</p><p>
Indianapolis Colts: +1100
</p><p>
Los Angeles Rams: +1100
</p><p>
Cleveland Browns: +1400
</p><p>
Los Angeles Chargers: +1400
</p><p>
Chicago Bears: +1500
</p><p>
Philadelphia Eagles: +1500
</p><p>
Green Bay Packers: +1800
</p><p>
Pittsburgh Steelers: +2200
</p><p>
Dallas Cowboys: +2500
</p><p>
Minnesota Vikings: +2500
</p><p>
Seattle Seahawks: +2800
</p><p>
Atlanta Falcons: +3300
</p><p>
Houston Texans: +3500
</p><p>
Baltimore Ravens: +4000
</p><p>
Carolina Panthers: +4000
</p><p>
San Francisco 49ers: +4000
</p><p>
Jacksonville Jaguars: +4500
</p><p>
New York Jets: +5500
</p><p>
Tennessee Titans: +6000
</p><p>
Tampa Bay Buccaneers: +8000
</p><p>
Denver Broncos: +9000
</p><p>
Arizona Cardinals: +10000
</p><p>
Buffalo Bills: +10000
</p><p>
Detroit Lions: +10000
</p><p>
New York Giants: +10000
</p><p>
Oakland Raiders: +10000
</p><p>
Washington Redskins: +10000
</p><p>
Cincinnati Bengals: +15000
</p><p>
Miami Dolphins: +15000
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Odds favor Pats as camps spring into action');return false;"><span class="op-btn">Read More</span> <span class="count">375 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fodds-favor-pats-as-camps-spring-into-action%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Odds favor Pats as camps spring into action+https://nationalfootballpost.com/?p=106712" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Odds favor Pats as camps spring into action&#32;&#32;https://nationalfootballpost.com/?p=106712" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106712"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				
				<article style="overflow: hidden;margin-bottom: 30px;">
					<header class="fl-post-header">
						<h2 class="fl-post-title" itemprop="headline">
							<a href="https://nationalfootballpost.com/jets-release-rb-henderson/" rel="bookmark" title="Jets release RB Henderson">Jets release RB Henderson</a>
						</h2>
						<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/"><span></span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/jets-release-rb-henderson/" /><meta itemprop="datePublished" content="8 hours ago" /><meta itemprop="dateModified" content="8 hours ago" /><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/" /><meta itemprop="name" content="" /></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction" /><meta itemprop="userInteractionCount" content="0" /></div>					</header><!-- .fl-post-header -->
															<div class="fl-post-content clearfix" id="content-outter" itemprop="text">

											  	<div id="content-less"><h2><title>Jets release RB Henderson</title></h2> <p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/10510825.jpg" width="1100" height="734" alt="" title="Dec 31, 2017; Denver, CO, USA; Denver Broncos running back De&#039;Angelo Henderson (33) runs throughout the tackle of Kansas City Chiefs linebacker Ramik Wilson (53) for a touchdown in the second quarter at Sports Authority Field at Mile High. Mandatory Credit: Isaiah J. Downing-USA TODAY Sports"</p></div>		
						<div class="clearfix" style="clear:both"></div>
						<div id="complete-single"><h2><title>Jets release RB Henderson</title></h2><p><img src="https://nationalfootballpost.com/wp-content/uploads/2019/07/10510825.jpg" width="1100" height="734" alt="" title="Dec 31, 2017; Denver, CO, USA; Denver Broncos running back De&#039;Angelo Henderson (33) runs throughout the tackle of Kansas City Chiefs linebacker Ramik Wilson (53) for a touchdown in the second quarter at Sports Authority Field at Mile High. Mandatory Credit: Isaiah J. Downing-USA TODAY Sports" data-portal-copyright="Isaiah J. Downing-USA TODAY Sports" /></p><p>
The New York Jets released running back De&#8217;Angelo Henderson on Tuesday.
</p>
</p><p>
The team needed to clear space on the 90-man training camp roster after signing tight end Ryan Griffin on Monday.
</p>
</p><p>
Henderson, 26, was Denver&#8217;s sixth-round pick in 2017. He rushed seven times for 13 yards and caught two passes for 36 yards and a touchdown with the Broncos in five games as a rookie.
</p>
</p><p>
He joined the Jets&#8217; practice squad last September and was activated for three games, logging two carries for 19 yards.
</p>
</p><p>
&#8211;Field Level Media</p>
</div>
						<a href="#" id="btn-more" onclick="ga('send', 'event', 'Posts', 'click', 'Jets release RB Henderson');return false;"><span class="op-btn">Read More</span> <span class="count">27 Words</span></span></a>

					</div><!-- .fl-post-content -->
					
					<div class="post-bot">
						<div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div>						<div class="share-social">
							<a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fjets-release-rb-henderson%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a>
							<a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Jets release RB Henderson+https://nationalfootballpost.com/?p=106707" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a>
							<a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Jets release RB Henderson&#32;&#32;https://nationalfootballpost.com/?p=106707" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a>
							<button class="btn btn-primary" data-clipboard-text="https://nationalfootballpost.com/?p=106707"><i class="fa fa-link" aria-hidden="true"></i></button>
						</div>
					</div>
					
									</article>
				</div>
			    

				<div class="fl-comments">

	
			<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Comment <small><a rel="nofollow" id="cancel-comment-reply-link" href="/los-angeles-rams-training-camp-primer/#respond" style="display:none;">Cancel Reply</a></small></h3>			<form action="https://nationalfootballpost.com/wp-comments-post.php?wpe-comment-post=footballpost" method="post" id="fl-comment-form" class="fl-comment-form">
				<label for="comment">Comment</label>
									<textarea name="comment" class="form-control" cols="60" rows="8" tabindex="4"></textarea><br /><label for="author">Name</label>
									<input type="text" name="author" class="form-control" value="" tabindex="1" /><br />
<label for="email">Email (will not be published)</label>
									<input type="text" name="email" class="form-control" value="" tabindex="2" /><br />
<label for="url">Website</label>
									<input type="text" name="url" class="form-control" value="" tabindex="3" /><br />
<p class="comment-form-cookies-consent"><input id="wp-comment-cookies-consent" name="wp-comment-cookies-consent" type="checkbox" value="yes" /><label for="wp-comment-cookies-consent">Save my name, email, and website in this browser for the next time I comment.</label></p>
<p class="form-submit"><input name="submit" type="submit" id="fl-comment-form-submit" class="btn btn-primary" value="Submit Comment" /> <input type='hidden' name='comment_post_ID' value='106792' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="899f779ba0" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="192"/></p>			</form>
			</div><!-- #respond -->
		</div>

				<!-- .fl-post -->
								<!-- .fl-post -->
				<script src="https://cdnjs.cloudflare.com/ajax/libs/clipboard.js/1.5.10/clipboard.min.js"></script>
				<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>
				<script>
				// Tooltip
				jQuery(function($){
				   $('button').tooltip({
                   trigger: 'click',
                   placement: 'bottom'
                   });
				   
				   function setTooltip(btn, message) {
				   $(btn).tooltip('hide')
				   .attr('data-original-title', message)
				   .tooltip('show');
				   }
				   
				   function hideTooltip(btn) {
				   setTimeout(function() {
		              $(btn).tooltip('hide');
		              }, 1000);
				   }
				   
				   // Clipboard
				   
				   var clipboard = new Clipboard('button');
				   
				   clipboard.on('success', function(e) {
	                setTooltip(e.trigger, 'Link copied to clipboard');
	                hideTooltip(e.trigger);
	                });
				   
				   clipboard.on('error', function(e) {
	                setTooltip(e.trigger, 'Failed!');
	                hideTooltip(e.trigger);
	                });
				   });
				</script>


			  
			
					</div>
		
				
	</div>
</div>


	</div><!-- .fl-page-content -->
		</div><!-- .fl-page -->
<a href="#" id="fl-to-top"><i class="fa fa-chevron-up"></i></a><style type="text/css">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</style><script type='text/javascript' src='https://nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/js/datatables/datatables.min.js?ver=1.10.16'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/js/jquery-blockui/jquery.blockUI.min.js?ver=2.70.0'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var posts_table_params = {"ajax_url":"https:\/\/nationalfootballpost.com\/wp-admin\/admin-ajax.php","ajax_nonce":"20599b166b","wrapper_class":"posts-table-wrapper bb-theme","language":{"info":"Showing _START_ to _END_ of _TOTAL_ entries","infoEmpty":"Showing 0 entries","infoFiltered":"(_MAX_ entries in total)","lengthMenu":"Show _MENU_ entries","emptyTable":"No data available in table.","zeroRecords":"No matching records found.","search":"Search:","paginate":{"first":"First","last":"Last","next":"Next","previous":"Previous"},"thousands":",","decimal":".","aria":{"sortAscending":": activate to sort column ascending","sortDescending":": activate to sort column descending"},"filterBy":"Filter:","resetButton":"Reset"}};
/* ]]> */
</script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/plugins/posts-table-pro/assets/js/posts-table-pro.min.js?ver=2.0.3'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme/js/jquery.throttle.min.js?ver=1.6.5.1'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme/js/jquery.magnificpopup.min.js?ver=1.6.5.1'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme/js/jquery.fitvids.js?ver=1.6.5.1'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme/js/bootstrap.min.js?ver=1.6.5.1'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-content/themes/bb-theme/js/theme.min.js?ver=1.6.5.1'></script>
<script type='text/javascript' src='https://nationalfootballpost.com/wp-includes/js/wp-embed.min.js?ver=5.2.2'></script>
<script async="async" type='text/javascript' src='https://nationalfootballpost.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.2'></script>

    <!-- BEGIN: wpflow ga events array -->
    <script>

                jQuery(document).ready(function() {
                    if(typeof scroll_events == 'undefined') {
                        return;
                    }
                    scroll_events.bind_events( {
                        universal: 1,
                        gtm:0,
                        gst:0,

                        scroll_elements: [],
                        click_elements: [],
                    });
                });

    </script>
    <!-- END: wpflow ga events array --></body>
</html>
