<!DOCTYPE html>
<html lang="en-US" prefix="og: http://ogp.me/ns#">
<head>
<meta charset="UTF-8"/>
<meta name='viewport' content='width=device-width, initial-scale=1.0'/>
<meta http-equiv='X-UA-Compatible' content='IE=edge'/>
<link rel="profile" href="https://gmpg.org/xfn/11"/>
<link rel="pingback" href="https://nationalfootballpost.com/xmlrpc.php"/>
<title>Dolphins-Packers Stats - National Football Post</title>
<link rel="canonical" href="https://nationalfootballpost.com/dolphins-packers-stats/"/>
<meta property="og:locale" content="en_US"/>
<meta property="og:type" content="article"/>
<meta property="og:title" content="Dolphins-Packers Stats - National Football Post"/>
<meta property="og:description" content="Dolphins-Packers Stats"/>
<meta property="og:url" content="https://nationalfootballpost.com/dolphins-packers-stats/"/>
<meta property="og:site_name" content="National Football Post"/>
<meta property="article:publisher" content="http://facebook.com/nationalfootballpost"/>
<meta property="article:section" content="NFL and College Football Articles"/>
<meta property="article:published_time" content="2018-11-12T00:41:10+00:00"/>
<link rel='dns-prefetch' href='//fonts.googleapis.com'/>
<link rel='dns-prefetch' href='//maxcdn.bootstrapcdn.com'/>
<link rel='dns-prefetch' href='//s.w.org'/>
<link rel="alternate" type="application/rss+xml" title="National Football Post &raquo; Feed" href="https://nationalfootballpost.com/feed/"/>
<link rel="stylesheet" type="text/css" href="//nationalfootballpost.com/wp-content/cache/wpfc-minified/2qvnzqgi/bny8x.css" media="all"/>
<link rel='https://api.w.org/' href='https://nationalfootballpost.com/wp-json/'/>
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://nationalfootballpost.com/xmlrpc.php?rsd"/>
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://nationalfootballpost.com/wp-includes/wlwmanifest.xml"/> 
<link rel='shortlink' href='https://nfp.news/yot'/>
<link rel="alternate" type="application/json+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Fdolphins-packers-stats%2F"/>
<link rel="alternate" type="text/xml+oembed" href="https://nationalfootballpost.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fnationalfootballpost.com%2Fdolphins-packers-stats%2F&#038;format=xml"/>
<script>(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){ (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o), m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m) })(window,document,'script','https://www.google-analytics.com/analytics.js','ga'); ga('create', 'UA-5166086-1', 'auto'); ga('send', 'pageview');</script>
<style>.saboxplugin-wrap .saboxplugin-gravatar img{-webkit-border-radius:50%;-moz-border-radius:50%;-ms-border-radius:50%;-o-border-radius:50%;border-radius:50%;}
.saboxplugin-wrap .saboxplugin-authorname a{color:#212121;}
.saboxplugin-wrap .saboxplugin-authorname{font-family:"Roboto Condensed";}
.saboxplugin-wrap .saboxplugin-desc{font-family:Roboto Condensed;}
.saboxplugin-wrap .saboxplugin-desc{font-style:italic;}
.saboxplugin-wrap{margin-top:20px;margin-bottom:10px;padding:5px 5px}
.saboxplugin-wrap .saboxplugin-authorname{font-size:20px;line-height:27px;}
.saboxplugin-wrap .saboxplugin-desc p, .saboxplugin-wrap .saboxplugin-desc{font-size:16px !important;line-height:23px !important;}
.saboxplugin-wrap .saboxplugin-web{font-size:14px;}
.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa:before{font-size:18px;}
.saboxplugin-wrap .saboxplugin-socials .saboxplugin-icon-color.fa{width:36px;height:36px;line-height:36px;}</style><link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-32x32.jpg" sizes="32x32"/>
<link rel="icon" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-192x192.jpg" sizes="192x192"/>
<link rel="apple-touch-icon-precomposed" href="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-180x180.jpg"/>
<meta name="msapplication-TileImage" content="https://nationalfootballpost.com/wp-content/uploads/2018/06/cropped-NFP-ICO-270x270.jpg"/>
<style id="wp-custom-css">.fl-post-cats-tags{padding:0px 0px 0px 0px;border-bottom:4px solid #e6e6e6}
.share-social{border-bottom:4px solid #e6e6e6}
.container{max-width:93%}
.fl-sidebar-left{padding-right:2%;padding-left:0px;}
.fl-post-cats-tags a, .share-social a{text-transform:uppercase;color:#000;font-size:18px;font-weight:600;font-style:normal;}
.fl-archive .fl-post{border-bottom:0px;}
div.share-social{letter-spacing:7px;float:right;padding-top:10px;}
.custom-html-widget li a{font-size:16px;color:#555;font-style:normal;display:block;padding-bottom:4px;font-weight:600;text-transform:uppercase;}
.custom-html-widget li{font-size:14px;color:#7b7b7b;font-style:italic;font-weight:500;text-transform:uppercase;padding-bottom:6px;border-bottom:2px solid #e6e6e6}
.fl-widget-title{border-style:solid;border-width:4px 0px 4px 0px;text-align:center;padding:5px}
.fl-post-title{margin-bottom:0px;}
.fl-post-author{text-transform:uppercase;font-style:italic;font-weight:600;font-size:18px;}
.tooltip-inner{letter-spacing:1px;}
.fl-post-meta-bottom{border-top:none;font-style:italic;margin-top:0;padding-top:10px;float:left;}
.btn-primary{border:none !important;background:0 0 !important;;color:#000 !important;;box-shadow:none !important;;padding:0 !important;;margin-bottom:5px !important;;}
.toptitle h1{font-size:22px;margin-top:5px;margin-bottom:5px;list-style:none;margin:0;padding:0;line-height:40px;width:50%;position:relative;left:25%;margin:0 px;padding:0 px;border:1px solid #AAA;color:white;background:#050505;border-bottom-left-radius:10px;border-bottom-right-radius:10px;font-style:italic;}
.fl-archive .fl-archive-title{display:none;}
.rp4wp-related-post-content{font-size:18px;color:#555;font-style:italic;display:block;font-weight:800;text-transform:uppercase;}</style>
<script data-wpfc-render="false">var Wpfcll={s:[],i:function(){Wpfcll.ss();window.addEventListener('load',function(){window.addEventListener("DOMSubtreeModified",function(e){Wpfcll.ss();Wpfcll.ls(false);},false);Wpfcll.ls(true);});window.addEventListener('scroll',function(){Wpfcll.ls(false);});window.addEventListener('resize',function(){Wpfcll.ls(false);});window.addEventListener('click',function(){Wpfcll.ls(false);});},c:function(e,pageload){var w=document.documentElement.clientHeight || body.clientHeight;var n=pageload ? 0:800;var er=e.getBoundingClientRect();var t=0;var p=e.parentNode;var pr=p.getBoundingClientRect();if(er.x==0 && er.y==0){for(var i=0;i < 10;i++){if(p){if(pr.x==0 && pr.y==0){p=p.parentNode;pr=p.getBoundingClientRect();}else{t=pr.top;break;}}};}else{t=er.top;}if(w - t+n > 0){return true;}return false;},r:function(e,pageload){var s=this;var oc,ot;try{if(s.c(e,pageload)){oc=e.getAttribute("data-wpfc-original-src");ot=e.getAttribute("data-wpfc-original-srcset");if(oc || ot){if(oc){e.setAttribute('src',oc);}if(ot){e.setAttribute('srcset',ot);}e.removeAttribute("data-wpfc-original-src");e.removeAttribute("onload");if(e.tagName=="IFRAME"){e.onload=function(){var s=e.getAttribute("src").match(/templates\/youtube\.html\#(.+)/);var y="https://www.youtube.com/embed/";if(s){try{var i=e.contentDocument || e.contentWindow;if(i.location.href=="about:blank"){e.setAttribute('src',y+s[1]);}}catch(err){e.setAttribute('src',y+s[1]);}}}}}}}catch(error){console.log(error);console.log("==>",e);}},ss:function(){var i=Array.prototype.slice.call(document.getElementsByTagName("img"));var f=Array.prototype.slice.call(document.getElementsByTagName("iframe"));this.s=i.concat(f);},ls:function(pageload){var s=this;[].forEach.call(s.s,function(e,index){s.r(e,pageload);});}};document.addEventListener('DOMContentLoaded',function(){wpfci();});function wpfci(){Wpfcll.i();}</script>
</head>
<body class="post-template-default single single-post postid-98605 single-format-standard fl-preset-default fl-fixed-width fl-scroll-to-top fl-search-active" itemscope="itemscope" itemtype="https://schema.org/WebPage">
<div class="fl-page"> <header class="fl-page-header fl-page-header-fixed fl-page-nav-right fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile"> <div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="fl-page-logo-wrap col-md-3 col-sm-12"> <div class="fl-page-header-logo"> <a href="https://nationalfootballpost.com/"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post"/><meta itemprop="name" content="National Football Post"/></a></div></div><div class="fl-page-fixed-nav-wrap col-md-9 col-sm-12"> <div class="fl-page-nav-wrap"> <nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span><i class="fa fa-bars"></i></span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-top-nav" class="nav navbar-nav navbar-right menu"><li id="menu-item-78448" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a> <ul class="sub-menu"> <li id="menu-item-94464" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li> <li id="menu-item-94463" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li> </ul> </li> <li id="menu-item-80343" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a> <ul class="sub-menu"> <li id="menu-item-88321" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li> <li id="menu-item-80344" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li> <li id="menu-item-78452" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li> </ul> </li> <li id="menu-item-78387" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a> <ul class="sub-menu"> <li id="menu-item-84427" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li> <li id="menu-item-84236" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li> <li id="menu-item-91584" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91584"><a href="https://nationalfootballpost.com/betting-resources/nfl-odds/">NFL Odds</a></li> </ul> </li> <li id="menu-item-78499" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a> <ul class="sub-menu"> <li id="menu-item-78502" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li> <li id="menu-item-78500" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li> <li id="menu-item-80079" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li> </ul> </li> </ul></div></nav></div></div></div></div></div></header>
<header class="fl-page-header fl-page-header-primary fl-page-nav-centered fl-page-nav-toggle-icon fl-page-nav-toggle-visible-mobile" itemscope="itemscope" itemtype="https://schema.org/WPHeader">
<div class="fl-page-header-wrap"> <div class="fl-page-header-container container"> <div class="fl-page-header-row row"> <div class="col-md-12 fl-page-header-logo-col"> <div class="fl-page-header-logo" itemscope="itemscope" itemtype="https://schema.org/Organization"> <a href="https://nationalfootballpost.com/" itemprop="url"><img class="fl-logo-img" itemscope itemtype="https://schema.org/ImageObject" src="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png" data-retina="" alt="National Football Post"/><meta itemprop="name" content="National Football Post"/></a></div></div></div></div></div><div class="fl-page-nav-wrap"> <div class="fl-page-nav-container container"> <nav class="fl-page-nav fl-nav navbar navbar-default" role="navigation" aria-label="Header Menu" itemscope="itemscope" itemtype="https://schema.org/SiteNavigationElement"> <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".fl-page-nav-collapse"> <span><i class="fa fa-bars"></i></span> </button> <div class="fl-page-nav-collapse collapse navbar-collapse"> <ul id="menu-top-nav-1" class="nav navbar-nav menu"><li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-78448"><a href="https://nationalfootballpost.com/category/news/">News</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-94464"><a href="https://nationalfootballpost.com/category/news/">NFL</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-94463"><a href="https://nationalfootballpost.com/category/news/ncaa-college-football-articles/">NCAA</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-80343"><a href="#">Columns</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-88321"><a href="https://nationalfootballpost.com/category/columns/injury-wire/">Injury Wire</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-80344"><a href="https://nationalfootballpost.com/category/columns/esports/">eSports</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78452"><a href="https://nationalfootballpost.com/archive/">Archive</a></li> </ul> </li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-78387"><a href="https://nationalfootballpost.com/category/columns/betting/">Betting</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84427"><a href="https://nationalfootballpost.com/category/columns/betting/">Articles</a></li> <li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-84236"><a href="https://nationalfootballpost.com/category/columns/betting/props/">Props</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-91584"><a href="https://nationalfootballpost.com/betting-resources/nfl-odds/">NFL Odds</a></li> </ul> </li> <li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-78499"><a href="#">About</a> <ul class="sub-menu"> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78502"><a href="https://nationalfootballpost.com/contact-nfp/">Contact NFP</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-78500"><a href="https://nationalfootballpost.com/privacy/">Privacy Policy</a></li> <li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-80079"><a href="https://nationalfootballpost.com/terms/">Terms</a></li> </ul> </li> </ul><div class="fl-page-nav-search"> <a href="javascript:void(0);" class="fa fa-search"></a> <form method="get" role="search" action="https://nationalfootballpost.com/" title="Type and press Enter to search."> <input type="search" class="fl-search-input form-control" name="s" placeholder="Search" value="" /> </form></div></div></nav></div></div></header>
<div class="fl-page-content" itemprop="mainContentOfPage"> <div class="fl-archive container"> <div class="row"> <div class="fl-sidebar fl-sidebar-left fl-sidebar-display-desktop col-md-3" itemscope="itemscope" itemtype="https://schema.org/WPSideBar"> <aside id="custom_html-3" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">RECENT</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/buccaneers-lose-again-koetter-mum-on-possible-qb-change/" title="Buccaneers lose again, Koetter mum on possible QB change">Buccaneers lose again, Koetter mum on possible QB change</a> 1 min ago </li><li ><a href="https://nationalfootballpost.com/dolphins-packers-stats/" title="Dolphins-Packers Stats">Dolphins-Packers Stats</a> 1 min ago </li><li ><a href="https://nationalfootballpost.com/mistake-prone-jags-seeking-solutions-after-5th-straight-loss/" title="Mistake-prone Jags seeking solutions after 5th straight loss">Mistake-prone Jags seeking solutions after 5th straight loss</a> 1 min ago </li><li ><a href="https://nationalfootballpost.com/the-latest-fowler-strip-sack-helps-rams-up-lead-on-seattle/" title="The Latest: Fowler strip sack helps Rams up lead on Seattle">The Latest: Fowler strip sack helps Rams up lead on Seattle</a> 15 mins ago </li><li ><a href="https://nationalfootballpost.com/chargers-raiders-stats/" title="Chargers-Raiders Stats">Chargers-Raiders Stats</a> 15 mins ago </li><li ><a href="https://nationalfootballpost.com/eagles-right-tackle-lane-johnson-out-with-knee-injury/" title="Eagles right tackle Lane Johnson out with knee injury">Eagles right tackle Lane Johnson out with knee injury</a> 15 mins ago </li><li ><a href="https://nationalfootballpost.com/falcons-flop-lose-momentum-after-ugly-28-16-loss-to-browns/" title="Falcons flop, lose momentum after ugly 28-16 loss to Browns">Falcons flop, lose momentum after ugly 28-16 loss to Browns</a> 15 mins ago </li><li ><a href="https://nationalfootballpost.com/the-latest-packers-pulling-away-on-sputtering-dolphins/" title="The Latest: Packers pulling away on sputtering Dolphins">The Latest: Packers pulling away on sputtering Dolphins</a> 31 mins ago </li><li ><a href="https://nationalfootballpost.com/rivers-leads-chargers-to-6th-straight-win-20-6-over-raiders/" title="Rivers leads Chargers to 6th straight win, 20-6 over Raiders">Rivers leads Chargers to 6th straight win, 20-6 over Raiders</a> 31 mins ago </li><li ><a href="https://nationalfootballpost.com/edelman-2-others-hurt-for-patriots-in-loss-to-titans/" title="Edelman, 2 others hurt for Patriots in loss to Titans">Edelman, 2 others hurt for Patriots in loss to Titans</a> 31 mins ago </li></ul></div></aside><aside id="custom_html-9" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">NJ RESIDENTS &#8211; BET NOW!</h4><div class="textwidget custom-html-widget"></div></aside><aside id="custom_html-7" class="widget_text fl-widget widget_custom_html"><h4 class="fl-widget-title">FEATURES</h4><div class="textwidget custom-html-widget"><ul class="lcp_catlist" id="lcp_instance_0"><li ><a href="https://nationalfootballpost.com/bills-rb-mccoy-breaks-silence-by-saying-hes-frustrated/" title="Bills RB McCoy breaks silence by saying he&#8217;s frustrated">Bills RB McCoy breaks silence by saying he&#8217;s frustrated</a> November 9, 2018 </li><li ><a href="https://nationalfootballpost.com/say-his-name-rookie-wr-valdes-scantling-on-rise-for-packers/" title="Say his name: Rookie WR Valdes-Scantling on rise for Packers">Say his name: Rookie WR Valdes-Scantling on rise for Packers</a> November 9, 2018 </li><li ><a href="https://nationalfootballpost.com/beckham-jr-hopeful-giants-can-run-the-table/" title="Beckham Jr. hopeful Giants can run the table">Beckham Jr. hopeful Giants can run the table</a> November 9, 2018 </li><li ><a href="https://nationalfootballpost.com/nfl-fines-titans-safety-for-celebrating-on-cowboys-logo/" title="NFL fines Titans safety for celebrating on Cowboys&#8217; logo">NFL fines Titans safety for celebrating on Cowboys&#8217; logo</a> November 9, 2018 </li><li ><a href="https://nationalfootballpost.com/bills-qb-matt-barkley-in-the-mix-to-start-against-jets/" title="Bills QB Matt Barkley in the mix to start against Jets">Bills QB Matt Barkley in the mix to start against Jets</a> November 9, 2018 </li></ul></div></aside></div><div class="fl-content fl-content-right col-md-9" itemscope="itemscope" itemtype="https://schema.org/Blog"> <article class="fl-post post-98605 post type-post status-publish format-standard hentry category-news" id="fl-post-98605" itemscope itemtype="https://schema.org/BlogPosting"> <header class="fl-post-header"> <h1 class="fl-post-title" itemprop="headline"> Dolphins-Packers Stats </h1> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/dolphins-packers-stats/"/><meta itemprop="datePublished" content="1 min ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" itemprop="text"> <p><block id="Main"></p> <table> <tr> <th>Miami</th> <th>3</th> <th>6</th> <th>3</th> <th>0&mdash;12</th> </tr> <tr> <th>Green Bay</th> <th>7</th> <th>7</th> <th>14</th> <th>3&mdash;31</th> </tr> <tr> <th>First Quarter</th> </tr> </table><p>GB_D.Adams 7 pass from Rodgers (Crosby kick), 6:07.</p><p>Mia_FG Sanders 37, 1:18.</p> <table> <tr> <th>Second Quarter</th> </tr> </table><p>GB_A.Jones 2 run (Crosby kick), 14:53.</p><p>Mia_FG Sanders 25, 10:29.</p><p>Mia_FG Sanders 47, 2:49.</p> <table> <tr> <th>Third Quarter</th> </tr> </table><p>Mia_FG Sanders 40, 11:43.</p><p>GB_A.Jones 10 run (Crosby kick), 9:33.</p><p>GB_D.Adams 25 pass from Rodgers (Crosby kick), 7:25.</p> <table> <tr> <th>Fourth Quarter</th> </tr> </table><p>GB_FG Crosby 38, 8:53.</p><p>A_78,076.</p><p>___</p> <table> <tr> <th>Mia</th> <th>GB</th> <td></td> </tr> <tr> <td>First downs</td> <td>19</td> <td>21</td> </tr> <tr> <td>Total Net Yards</td> <td>294</td> <td>377</td> </tr> <tr> <td>Rushes-yards</td> <td>23-131</td> <td>25-195</td> </tr> <tr> <td>Passing</td> <td>163</td> <td>182</td> </tr> <tr> <td>Punt Returns</td> <td>0-0</td> <td>1-19</td> </tr> <tr> <td>Kickoff Returns</td> <td>5-97</td> <td>2-34</td> </tr> <tr> <td>Interceptions Ret.</td> <td>0-0</td> <td>1-26</td> </tr> <tr> <td>Comp-Att-Int</td> <td>23-37-1</td> <td>19-28-0</td> </tr> <tr> <td>Sacked-Yards Lost</td> <td>6-50</td> <td>2-17</td> </tr> <tr> <td>Punts</td> <td>2-38.5</td> <td>2-18.5</td> </tr> <tr> <td>Fumbles-Lost</td> <td>1-1</td> <td>1-1</td> </tr> <tr> <td>Penalties-Yards</td> <td>3-10</td> <td>6-45</td> </tr> <tr> <td>Time of Possession</td> <td>32:03</td> <td>27:57</td> </tr> </table><p>___</p> <table> <tr> <th>INDIVIDUAL STATISTICS</th> </tr> </table><p>RUSHING_Miami, Gore 13-90, Drake 8-27, Carroo 1-14, Osweiler 1-0. Green Bay, A.Jones 15-145, Greene 1-26, Rodgers 6-21, J.Williams 3-3.</p><p>PASSING_Miami, Osweiler 23-37-1-213. Green Bay, Rodgers 19-28-0-199.</p><p>RECEIVING_Miami, Amendola 7-72, Parker 5-43, Stills 2-26, Gore 2-12, Drake 2-11, Carroo 1-20, Derby 1-13, Ballage 1-6, Gesicki 1-5, O&#8217;Leary 1-5. Green Bay, Valdes-Scantling 6-44, D.Adams 4-57, A.Jones 3-27, Kendricks 2-24, St. Brown 2-3, Lewis 1-30, Graham 1-14.</p><p>MISSED FIELD GOALS_None.</p><p> </block></p></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fdolphins-packers-stats%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Dolphins-Packers Stats+http://nfp.news/yot" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Dolphins-Packers Stats&#32;&#32;http://nfp.news/yot" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yot"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<div class="related-post"> <article style="overflow: hidden;margin-bottom: 30px;"> <header class="fl-post-header"> <h2 class="fl-post-title" itemprop="headline"> <a href="https://nationalfootballpost.com/buccaneers-lose-again-koetter-mum-on-possible-qb-change/" rel="bookmark" title="Buccaneers lose again, Koetter mum on possible QB change">Buccaneers lose again, Koetter mum on possible QB change</a> </h2> <div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/buccaneers-lose-again-koetter-mum-on-possible-qb-change/"/><meta itemprop="datePublished" content="1 min ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>TAMPA, Fla. (AP) — Ryan Fitzpatrick has been down this road far more times than the veteran quarterback cares to remember.</p> <p>The Tampa Bay Buccaneers lost for the third straight time Sunday, failing to score a touchdown in a 16-3 loss to the Washington Redskins despite gaining 501 yards total offense and only</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>TAMPA, Fla. (AP) &mdash; Ryan Fitzpatrick has been down this road far more times than the veteran quarterback cares to remember.</p><p>The Tampa Bay Buccaneers lost for the third straight time Sunday, failing to score a touchdown in a 16-3 loss to the Washington Redskins despite gaining 501 yards total offense and only punting once.</p><p>Fitzpatrick topped 400 yards passing for the fourth time this season, yet he may be headed back to the bench after the team&#8217;s sixth loss in seven games following a 2-0 start.</p><p>That means Jameis Winston, benched after throwing four interceptions in a loss at Cincinnati three weeks ago, may be on the verge of getting another chance.</p><p>&#8220;We&#8217;ll talk about all personnel issues (Monday),&#8221; said coach Dirk Koetter, who also may consider changing kickers after Chandler Catanzaro missed two more field goals Sunday, one of them a 30-yarder.</p><p>One change Koetter&#8217;s already made is resuming his role as offensive play caller.</p><p>Offensive coordinator Todd Monken handled the responsibility for the first eight games, and the Bucs have the NFL&#8217;s No. 1 passing attack and rank second in total offense.</p><p>So, why switch up before Sunday&#8217;s game?</p><p>&#8220;Just my own reasons,&#8221; Koetter said.</p><p>The Bucs (3-6) have missed the playoffs 10 consecutive seasons, the second-longest drought in the NFL behind the Cleveland Browns, who haven&#8217;t earned a berth since 2002.</p><p>Fitzpatrick expects the team to stick together and eventually pull out of the tailspin.</p><p>&#8220;Unfortunately for me, I&#8217;ve been in this situation 13 straight years in terms of a team that isn&#8217;t quite playing up to their potential and having some struggles,&#8221; said Fitzpatrick, who&#8217;s been with seven teams during a 14-year career.</p><p>&#8220;The only way I know how to get out of it is to just keep coming to work every day being a professional,&#8221; Fitzpatrick added. &#8220;Keep grinding, making sure you&#8217;re putting in the work. &#8230; I think we have a lot of professionals in that locker room, so that&#8217;s not something I&#8217;m worried about.&#8221;</p><p>Moving the ball wasn&#8217;t a problem Sunday. The Bucs outgained the Redskins 501 yards to 286 and got inside the Washington 20 five times.</p><p>An interception and two fumbles foiled scoring opportunities. A fourth turnover led to the last three field goals Dustin Hopkins kicked for the Redskins.</p><p>&#8220;We weren&#8217;t good enough as a team, and that starts with me,&#8221; Koetter said. &#8220;To move the ball like that and come up with three points, you&#8217;re just not going to win that way.&#8221;</p><p>Fitzpatrick, 2-4 as a starter this season, shrugged off a question about whether he played well enough to retain the starting job.</p><p>&#8220;I love playing football. That&#8217;s not something I concern myself with,&#8221; Fitzpatrick said. &#8220;If I get a chance to go out there, I try and do my best and play as hard as I can.&#8221;</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Buccaneers lose again, Koetter mum on possible QB change');return false;"><span class="op-btn">Read More</span> <span class="count">413 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fbuccaneers-lose-again-koetter-mum-on-possible-qb-change%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Buccaneers lose again, Koetter mum on possible QB change+http://nfp.news/you" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Buccaneers lose again, Koetter mum on possible QB change&#32;&#32;http://nfp.news/you" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/you"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/mistake-prone-jags-seeking-solutions-after-5th-straight-loss/" rel="bookmark" title="Mistake-prone Jags seeking solutions after 5th straight loss">Mistake-prone Jags seeking solutions after 5th straight loss</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/mistake-prone-jags-seeking-solutions-after-5th-straight-loss/"/><meta itemprop="datePublished" content="1 min ago"/><meta itemprop="dateModified" content="1 min ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>INDIANAPOLIS (AP) — Jacksonville cornerback Jalen Ramsey had plenty to say this summer.</p> <p>Now that the temperatures are cooling, Ramsey seems to be toning down the rhetoric.</p> <p>He may not have many more chances this season to get the league's attention. After a late fumble sealed the Jaguars' fifth straight loss, 29-26 at</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>INDIANAPOLIS (AP) &mdash; Jacksonville cornerback Jalen Ramsey had plenty to say this summer.</p><p>Now that the temperatures are cooling, Ramsey seems to be toning down the rhetoric.</p><p>He may not have many more chances this season to get the league&#8217;s attention. After a late fumble sealed the Jaguars&#8217; fifth straight loss, 29-26 at Indianapolis on Sunday, the Jaguars (3-6) find themselves sitting alone in the AFC South basement with their playoff hopes fading fast and the search for answers becoming increasingly more urgent.</p><p>Nobody sounds more frustrated than Ramsey.</p><p>&#8220;Things happen,&#8221; he said. &#8220;You have to try to bounce back from it. But we dug ourselves too big of a hole today.&#8221;</p><p>Ramsey didn&#8217;t stick around long following the game &mdash; and he didn&#8217;t say much.</p><p>But it doesn&#8217;t require too much thought to understand why last year&#8217;s AFC runner-ups have made a mess of this season.</p><p>Andrew Luck threw three touchdown passes and took the Colts (4-5) on four scoring marches before halftime to give Indy a 29-13 lead. The three-time Pro Bowl quarterback produced only two first downs in the second half but still finished 21 of 29 with 285 yards and one interception &mdash; playing far better than Ramsey suggested when he said of Luck in August, &#8220;I don&#8217;t really think he&#8217;s that good.&#8221;</p><p>What Luck did was expose the Jags&#8217; mismatches by repeatedly going to his tight ends. Eric Ebron , Jack Doyle and Mo Alie-Cox combined for eight catches, 133 yards and three TD receptions &mdash; all in the first two quarters.</p><p>And with Ramsey&#8217;s tag-teaming cornerback A.J. Bouye out because of an injured calf, Luck didn&#8217;t really have to throw at Ramsey much.</p><p>Perhaps the most remarkable difference between this game and last year&#8217;s was that the Jags couldn&#8217;t put much pressure on Luck. After recording 14 sacks against the Colts last year, Luck didn&#8217;t go down a single time Sunday. He hasn&#8217;t been sacked in four games, the longest stretch of his pro career.</p><p>&#8220;It&#8217;s always tough on an offensive line when you get to third-and-long and you&#8217;ve got to hold the ball a little bit longer and give yourself a chance,&#8221; Jaguars coach Doug Marrone said. &#8220;But when guys were open early on, they were wide open. It&#8217;s tough to get to the quarterback. I think we might have hit him two or three times, but they were all on deeper third down plays.&#8221;</p><p>One of those hits drew an unnecessary roughness call against Malik Jackson &mdash; after Jacksonville had called timeout. The penalty converted a third-and-3 into a first down, which helped the Colts score their final touchdown.</p><p>There was plenty of blame to go around, though.</p><p>Two plays after Jackson&#8217;s 15-yard penalty, linebacker Myles Jack was called for unnecessary roughness. And when the Jags jumped offside on the ensuing extra point, Marlon Mack made the decision to go for 2 a wise choice by plunging in from 1 yard out to make it 29-13.</p><p>Not enough?</p><p>Ebron scored on a 53-yard pass seven plays into the game and again on a 12-yard TD in the second quarter. In between those two, he scored on a 2-yard run.</p><p>While the defense improved in the second half, the mistakes continued.</p><p>Josh Lambo, who had an extra point blocked in the first half, missed a 52-yard field goal wide left before making a 55-yarder with 4:03 left to get the Jags within 29-26.</p><p>After a defensive stop, Blake Bortles quickly got Jacksonville into field goal range and appeared to have them in perfect position when the officials ruled Rashad Green Sr. went down at the Colts&#8217; 23-yard line before the ball squirted free. But just before the next snap, the replay official stopped the play, overturned the call and assured Jacksonville of another inexplicable loss.</p><p>Ramsey said the Jaguars were playing with a sense of desperation.</p><p>&#8220;That&#8217;s how we were feeling before the game,&#8221; he said. &#8220;I mean we really wanted to win out, we wanted to win every game from here on out.&#8221;</p><p>___</p><p>More AP NFL: https://apnews.com/tag/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Mistake-prone Jags seeking solutions after 5th straight loss');return false;"><span class="op-btn">Read More</span> <span class="count">612 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fmistake-prone-jags-seeking-solutions-after-5th-straight-loss%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Mistake-prone Jags seeking solutions after 5th straight loss+http://nfp.news/yos" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Mistake-prone Jags seeking solutions after 5th straight loss&#32;&#32;http://nfp.news/yos" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yos"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/the-latest-fowler-strip-sack-helps-rams-up-lead-on-seattle/" rel="bookmark" title="The Latest: Fowler strip sack helps Rams up lead on Seattle">The Latest: Fowler strip sack helps Rams up lead on Seattle</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/the-latest-fowler-strip-sack-helps-rams-up-lead-on-seattle/"/><meta itemprop="datePublished" content="15 mins ago"/><meta itemprop="dateModified" content="15 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>The Latest on Week 10 in the NFL (all times EST):</p> <p>7:10 p.m.</p> <p>Newly acquired Rams defensive end Dante Fowler Jr. has bounced back from a pair of penalties to force a turnover in helping Los Angeles build a 36-24 lead over NFC West rival Seattle.</p> <p>Fowler forced a fumble while sacking Russell</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>The Latest on Week 10 in the NFL (all times EST):</p><p>7:10 p.m.</p><p>Newly acquired Rams defensive end Dante Fowler Jr. has bounced back from a pair of penalties to force a turnover in helping Los Angeles build a 36-24 lead over NFC West rival Seattle.</p><p>Fowler forced a fumble while sacking Russell Wilson and then recovered it at Seattle&#8217;s 9. Brandin Cooks scored on the next play. The Rams have sacked Wilson four times, led by Aaron Donald&#8217;s 2 1/2.</p><p>The Rams acquired Fowler at the NFL trading deadline on Oct. 30 from Jacksonville for two draft picks, including a 2019 third-round selection.</p><p>___</p><p>6:50 p.m.</p><p>The Green Bay Packers are pulling away from the Miami Dolphins.</p><p>Davante Adams and Aaron Jones have accounted for two touchdowns each. Green Bay broke it open in the third quarter. After Jones scored on a 10-yard run, Green Bay&#8217;s Bashaud Breeland picked off Brock Osweiler deep in Miami territory.</p><p>Three plays later Aaron Rodgers hit Adams for a 25-yard touchdown pass for a 28-12 lead with 7:24 left. That was the score going into the fourth quarter.</p><p>The Dolphins have settled for kicker Jason Sanders hitting four field goals on five drives inside Green Bay&#8217;s 30.</p><p>___</p><p>6:40 p.m.</p><p>Los Angeles Chargers quarterback Philip Rivers is closing in on extending his streak to nine games with at least two touchdown passes and a passer rating of 95 or higher.</p><p>Rivers is already just the third player to do that in eight straight games to start a season. Only Green Bay&#8217;s Aaron Rodgers, who did it in 13 straight to open the 2011 season, and Tom Brady, 10 straight in 2007, have longer streaks.</p><p>Rivers is currently 17 of 25 for 219 yards passing with two TDs and an interception and a 105.2 passer rating with the Chargers up 20-6 on the Oakland Raiders with four minutes remaining.</p><p>___</p><p>6:05 p.m.</p><p>Green Bay running back Aaron Jones has 101 yards and a touchdown on eight carries at halftime with the Packers leading the Miami Dolphins 14-9.</p><p>It&#8217;s the first time that a Green Bay running back has gone over the 100-yard mark this season. Aaron Rodgers also has a touchdown pass to Davante Adams.</p><p>The Dolphins have been moving the ball in spite of missing three starting offensive linemen. But they turned the ball over a bad shotgun snap on their first series, and have been held to three field goals.</p><p>___</p><p>5:50 p.m.</p><p>Los Angeles Rams running back Todd Gurley has become the fourth NFL player to score a touchdown in each of his team&#8217;s first 10 games of a season.</p><p>Gurley scored on a 17-yard run to put the Ram up 17-14 with under three minutes left in the second quarter against Seattle. His 10-game streak matches former Rams player Elroy &#8216;Crazylegs&#8217; Hirsch, who did it in 1951.</p><p>Baltimore&#8217;s Lenny Moore, in 1951, and Buffalo&#8217;s O.J. Simpson, in 1975, share the record in having scored in each of their teams&#8217; first 14 games of the season.</p><p>The touchdown was Gurley&#8217;s league-leading 17th of the season. And he&#8217;s scored in 13 consecutive regular-season games since being held out of the end zone in a 32-16 win at Arizona last Dec. 3.</p><p>___</p><p>5:35 p.m.</p><p>Los Angeles Rams defensive end Aaron Donald set a career-high with his 12th sack of the season and second of the game against Seattle&#8217;s Russell Wilson.</p><p>Donald entered the day second on the NFL list with 10 sacks this season, 11 1/2 behind Minnesota&#8217;s Danielle Hunter.</p><p>The fifth-year player passed his previous high of 11 sacks set in both 2015 and last season, and increased his career total to 61.</p><p>___</p><p>5:15 p.m.</p><p>Miami Dolphins running back Frank Gore has topped 500 yards rushing for a 14th consecutive season to set an NFL record.</p><p>Gore entered the game against Green Bay tied with Hall of Famers Emmitt Smith and Walter Payton, who had topped 500 yards in 13 straight seasons. Gore topped the milestone with a 9-yard run with about 3 1/2 minutes left in the first quarter.</p><p>The 14-year veteran ranks fourth and leads active players with 14,464 yards rushing.</p><p>Green Bay leads Miami 14-6 early in the second quarter. For the Packers, running back Aaron Jones has 96 yards on four carries, including a career-long 67-yarder.</p><p>___</p><p>5 p.m.</p><p>Arizona Cardinals receiver Larry Fitzgerald has passed Hall of Famer Terrell Owens to move into second place on the career yards-receiving list.</p><p>The 15th-year player had six catches for 50 yards to up his total to 15,952 &mdash; moving 18 ahead of Owens &mdash; in a 26-14 loss at Kansas City.</p><p>Jerry Rice holds the record with 22,895 yards.</p><p>___</p><p>4:50 p.m.</p><p>The Los Angeles Rams held a moment of silence before their game against Seattle for the 12 victims of the mass shooting in Thousand Oaks last week.</p><p>The Rams&#8217; training complex in less than five miles from the Borderline Bar and Grill. The team is donating proceeds from its stadium raffle and a jersey auction to a relief effort, and left tackle Andrew Whitworth has pledged his game check.</p><p>___</p><p>4:45 p.m.</p><p>The Green Bay Packers have cashed in on a turnover on the Miami Dolphins&#8217; game-opening drive.</p><p>Aaron Rodgers hit Davante Adams for a 7-yard touchdown pass with 6:07 left in the first quarter to give Green Bay a 7-0 lead. Running back Aaron Jones accounted for 54 total yards on the drive. The Packers capitalized after Dolphins&#8217; quarterback Brock Osweiler mishandled a shotgun snap that was recovered by Reggie Gilbert at the Green Bay 30.</p><p>___</p><p>4:20 p.m.</p><p>The Tampa Bay Buccaneers had very little to show for gaining 501 yards offense in a 16-3 loss to Washington.</p><p>The Buccaneers became just the second team since 1940 to top 400 yards and score 3 or fewer points, according to Pro Football Reference. They join the then-St. Louis Rams, who had 424 yards offense in a 24-3 loss to Green Bay in 2011.</p><p>Four turnovers, including two interceptions thrown by Ryan Fitzpatrick, didn&#8217;t help. Neither did kicker Chandler Catanzaro missing field-goal attempts from 30 and 48 yards, both wide right.</p><p>___</p><p>3:50 p.m.</p><p>The New England Patriots have pulled quarterback Tom Brady while trailing the Titans 34-10 in the fourth quarter.</p><p>The Titans sacked Brady a season-high three times, and former New England cornerback Logan Ryan broke up a Brady pass to Julian Edelman on fourth down with 10:48 left to end a Patriots&#8217; scoring threat.</p><p>Edelman went to the locker room after that pass was broken up. He is questionable to return with an injured ankle.</p><p>Brian Hoyer replaced Brady after Derrick Henry&#8217;s 10-yard run out of the wildcat put the Titans up 34-10 with 7:13 left.</p><p>The Patriots also were playing without left tackle Trent Brown, who left in the third quarter with an injured back. Tight end Dwayne Allen is questionable to return with an injured knee.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>3:10 p.m.</p><p>Buffalo Bills running back LeSean McCoy has plenty to talk about now while enjoying his best game of the season.</p><p>Three quarters into Buffalo&#8217;s game at the New York Jets, McCoy has already topped 100 yards rushing for the first time since gaining 156 on a snow-covered field in a 13-7 overtime win over Indianapolis on Dec. 10.</p><p>He has also scored two touchdowns rushing for the first time since scoring twice in a 30-27 win over Tampa Bay on Oct. 22, 2017.</p><p>The touchdowns were the first of the season for McCoy. And the come two days after the 10th-year player broke nearly two weeks of silence by telling reporters he was frustrated with his lack of production.</p><p>McCoy entered the game with 267 yards rushing this season, and had 103 midway through the third quarter.</p><p>McCoy also surpassed 500 career points, and vaulted into 26th place on the career yards rushing list by moving ahead of Marshawn Lynch (10,379), Eddie George (10,441) and Tiki Barber (10,449).</p><p>___</p><p>2:50 p.m.</p><p>Cleveland Browns rookie Nick Chubb broke a club record and maybe Atlanta&#8217;s back with a 92-yard TD run.</p><p>The running back took a handoff at Cleveland&#8217;s 8, cut right and avoided a few tacklers before streaking to the end zone to give Cleveland a 28-10 lead midway through the third quarter.</p><p>Chubb&#8217;s 92-yard run is the longest in team history, topping the 90-yard run by Bobby Mitchell in 1959 against Washington.</p><p>It was Chubb&#8217;s second touchdown of the game. He also caught a 13-yard pass from Baker Mayfield in the second quarter.</p><p>___</p><p>2:45 p.m.</p><p>The Tennessee Titans are following up their big win in Dallas with a strong first half against the Patriots.</p><p>Tennessee scored a season-high 28 points to beat the Cowboys on Monday night, and they now lead New England 24-10 at halftime.</p><p>The Titans scored a season-high 17 points in the first quarter with touchdown passes by Marcus Mariota on each of their first two possessions. Mariota is 11 of 16 for 152 yards.</p><p>The Titans have been getting plenty of pressure on Tom Brady. Former Patriots cornerback Logan Ryan sacked Brady on the final play of the first half, the Titans&#8217; second sack of the first half.</p><p>James Develin has run for a TD, and Stephen Gostkowski connected on one of his two 52-yard field goal attempt for New England.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>___</p><p>2:40 p.m.</p><p>Rams left tackle Andrew Whitworth is donating a game check to the families of the victims of the mass shooting in Thousand Oaks.</p><p>Whitworth will give his check from Los Angeles&#8217; game against Seattle to the Ventura County Community Foundation&#8217;s Conejo Valley Victims Fund. The fund was set up to help the families of the 12 people killed by a gunman in Thousand Oaks, the home of the Rams&#8217; training complex.</p><p>Whitworth is in the second season of a three-year, $36 million deal with the Rams. He has played a major role in the Rams&#8217; transformation into an elite NFC team under Sean McVay.</p><p>Whitworth, Todd Gurley, Jared Goff, Michael Brockers and other players are also auctioning off their game jerseys to benefit the victims&#8217; fund and American Red Cross Southern California Wildfire Relief.</p><p>Two wildfires are also burning in the same general area of the western Los Angeles suburbs.</p><p>2:30 p.m.</p><p>New Orleans Saints quarterback Drew Brees has moved ahead of Brett Favre for second place on the career regular-season touchdown list with a sensational first half at Cincinnati.</p><p>He&#8217;s thrown three TD passes as the Saints have raced ahead 35-7, reaching the end zone on all five possessions. Brees has 509 career TD passes, one more than Favre.</p><p>Peyton Manning holds the record with 539.</p><p>The Saints have piled up 311 yards, and they have 21 first downs on 40 plays. Brees is 18 of 20 for 214 yards.</p><p>___</p><p>2:15 p.m.</p><p>Baker Mayfield enjoyed a perfect half.</p><p>Cleveland&#8217;s rookie quarterback completed 12 of 12 passes for 165 yards and two touchdowns in the first half against Atlanta. Mayfield connected on a 28-yard TD with Rashard Higgins and threw a 13-yard scoring pass to Nick Chubb.</p><p>Mayfield finished the half with a 158.3 quarterback rating, the highest possible score. The Browns did have one interception in the half, but it was thrown by running back Dontrell Hilliard, who attempted to hit a well-covered Mayfield on a trick play.</p><p>___</p><p>2:10 p.m.</p><p>Patrick Mahomes has broken the Kansas City Chiefs record for touchdown passes in a season.</p><p>The first-year starter threw his 31st of the season &mdash; and second of the game to Tyreek Hill &mdash; to pass Len Dawson. The Hall of Famer threw 30 in 1964.</p><p>The record-setter came on third-and-goal from the Arizona 14. Hill celebrated by leaping into the stands, just as he did on his first TD catch, then playing with the TV cameras.</p><p>That last bit earned Hill an unsportsmanlike conduct penalty.</p><p>&mdash; Dave Skretta reporting from Kansas City</p><p>___</p><p>2 p.m.</p><p>Atlanta receiver Julio Jones has reached 10,000 yards receiving faster than any player in NFL history.</p><p>Jones reached the plateau in his 104th career game, catching a 30-yard pass in the second quarter from Matt Ryan. Calvin Johnson held the previous mark, getting to 10,000 yards in his 115th game. Torry Holt and Antonio Brown got there in 116 games.</p><p>Jones caught a short pass over the middle and broke a couple tackles on his first reception of the game. He came in with 933 yards receiving this season.</p><p>Moments later, Jones caught a 1-yard TD pass from Ryan to give the Falcons a 10-7 lead.</p><p>___</p><p>1:50 p.m.</p><p>The Buffalo Bills have scored twice in the first quarter against the New York Jets to match their combined total from their previous four games.</p><p>LeSean McCoy opened the scoring with a 28-yard run, 5 more than he totaled in his previous two games. And then tight end Jason Croom recovered teammate Zay Jones&#8217; fumble in the end zone to put the Bills ahead 14-0.</p><p>Buffalo&#8217;s 14 points are the most they&#8217;ve scored in seven games, since a 27-6 victory at Minnesota on Sept. 23. And the Bills are doing this with Matt Barkley making his debut at quarterback less than two weeks after signing with Buffalo.</p><p>___</p><p>1:40 p.m.</p><p>New Orleans quarterback Drew Brees has thrown two touchdown passes against Cincinnati to up his regular-season total to 508 and match Brett Favre for second on the NFL career list.</p><p>Brees first TD was a 7-yarder to Michael Thomas midway through the first quarter. Mark Ingram II then turned a screen pass into a 28-yard touchdown</p><p>Peyton Manning holds the record with 539.</p><p>___</p><p>1:25 p.m.</p><p>Six teams reached the end zone on the opening possession of their games Sunday to get Week 10 off to a high-scoring start.</p><p>Kansas City, which lost the coin toss for the first time all season, went 75 yards in 56 seconds. Three plays were needed, with Patrick Mahomes connecting with Tyreek Hill for 38 yards, then for a 37-yard touchdown.</p><p>Tennessee&#8217;s Darius Jennings returned the opening kickoff 58 yards, then the Titans needed seven plays to go 40 yards, capped by Marcus Mariota 4-yard TD pass to Jonnu Smith against New England.</p><p>Chicago&#8217;s Tarik Cohen had a 3-yard TD run to cap an eight-play, 75-yard drive vs. Detroit. But Cody Parkey missed the extra point.</p><p>Indianapolis covered 75 yards in seven plays and Andrew Luck found Eric Ebron for a 53-yard scoring pass against Jacksonville.</p><p>Buffalo used a mere two plays against the Jets, with newcomer Matt Barkley throwing 47 yards to Robert Foster before LeSean McCoy broke from a lengthy slump for his first touchdown this season, on a 28-yard run.</p><p>And Drew Brees threw his 507th career touchdown pass, leaving him one behind Brett Favre for second place on the career list, capping a 15-play, 75-yard drive that consumed 8 minutes, 30 seconds. It ended with Michael Thomas&#8217; diving 7-yard catch.</p><p>___</p><p>1:15 p.m.</p><p>Chiefs quarterback Patrick Mahomes needed only 56 seconds to throw his first touchdown pass against Arizona, moving him into a tie with Hall of Famer Len Dawson for the single-season franchise record.</p><p>Mahomes hit Tyreek Hill down the sideline for 38 yards on the game&#8217;s first play. Then, after an incompletion, Mahomes found Hill again for a 37-yard touchdown reception.</p><p>It was the 30th thrown by Mahomes this season. Dawson threw 30 during the 1964 season.</p><p>&mdash; Dave Skretta reporting from Kansas City.</p><p>___</p><p>1:10 p.m.</p><p>The Indianapolis Colts honored kicker Adam Vinatieri, the NFL&#8217;s new career scoring leader, with a brief highlight show during pregame introduction before their game against Jacksonville.</p><p>Vinatieri received a roaring ovation from the Lucas Oil Stadium crowd when he was announced as the final starter. The 45-year-old waved to the crowd and slapped hands with a group of fans gathered around the American flag on the field.</p><p>Vinatieri broke Morten Andersen&#8217;s record two weeks ago at Oakland, but the Colts had a bye last week and Sunday marked the first time Indy could celebrate the record-breaking moment on its home turf.</p><p>___</p><p>1 p.m.</p><p>Three-time Pro Bowl defensive lineman Jurrell Casey was the last of the Titans defense introduced before kickoff for Tennessee&#8217;s game against New England.</p><p>Casey took the field carrying an American flag, and first shaking hands with a soldier as part of the NFL&#8217;s Salute to Service being held on Veteran&#8217;s Day. A soldier accompanied each Titans starter onto the field for a few steps.</p><p>Country artist Little Big Town performed the national anthem, which featured a flyover by military helicopters.</p><p>___</p><p>11:30 a.m.</p><p>Drew Brees and Tom Brady enter Week 10 of the NFL&#8217;s schedule neck and neck in closing in on matching Brett Favre for second place on the career regular-season list.</p><p>Brees has 506 touchdowns passing, two behind Favre, as the New Orleans Saints play at Cincinnati. And Brady has 505 with his New England Patriots playing at Tennessee. Both are a little more than 30 behind Peyton Manning&#8217;s record of 539.</p><p>Brady does have chance to pass Manning on the career touchdowns passing list, including playoffs. Manning has 579, only three more than Brady.</p><p>On the other end of the quarterback matchup spectrum Sunday, the Buffalo Bills and New York Jets will feature a battle of the backups rather than far more intriguing AFC East showdown of two rookie first-round picks.</p><p>Matt Barkley is starting in place of Buffalo&#8217;s Josh Allen, who will miss his fourth straight game with a sprained throwing elbow. For New York, Josh McCown is starting in place Sam Darnold, who is sidelined by a strained right foot. Darnold was drafted third overall, four spots ahead of Allen.</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','The Latest: Fowler strip sack helps Rams up lead on Seattle');return false;"><span class="op-btn">Read More</span> <span class="count">2761 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fthe-latest-fowler-strip-sack-helps-rams-up-lead-on-seattle%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=The Latest: Fowler strip sack helps Rams up lead on Seattle+http://nfp.news/yoq" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=The Latest: Fowler strip sack helps Rams up lead on Seattle&#32;&#32;http://nfp.news/yoq" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yoq"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/chargers-raiders-stats/" rel="bookmark" title="Chargers-Raiders Stats">Chargers-Raiders Stats</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/chargers-raiders-stats/"/><meta itemprop="datePublished" content="15 mins ago"/><meta itemprop="dateModified" content="15 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <table> <tr> <th>L.A. Chargers</th> <th>0</th> <th>10</th> <th>7</th> <th>3—20</th> </tr> <tr> <th>Oakland</th> <th>3</th> <th>0</th> <th>0</th> <th>3—</th> <th>6</th> </tr> <tr> <th>First Quarter</th> </tr> </table> <p>Oak_FG Carlson 46, 2:51.</p> <table> <tr> <th>Second Quarter</th> </tr> </table> <p>LAC_FG Badgley 27, 5:47.</p> <p>LAC_Allen 11 pass from Rivers (Badgley kick), :24.</p> <table> <tr> <th>Third Quarter</th> </tr> </table> <p>LAC_Gordon 66 pass</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p> <table> <tr> <th>L.A. Chargers</th> <th>0</th> <th>10</th> <th>7</th> <th>3&mdash;20</th> </tr> <tr> <th>Oakland</th> <th>3</th> <th>0</th> <th>0</th> <th>3&mdash;</th> <th>6</th> </tr> <tr> <th>First Quarter</th> </tr> </table><p>Oak_FG Carlson 46, 2:51.</p> <table> <tr> <th>Second Quarter</th> </tr> </table><p>LAC_FG Badgley 27, 5:47.</p><p>LAC_Allen 11 pass from Rivers (Badgley kick), :24.</p> <table> <tr> <th>Third Quarter</th> </tr> </table><p>LAC_Gordon 66 pass from Rivers (Badgley kick), 12:32.</p> <table> <tr> <th>Fourth Quarter</th> </tr> </table><p>Oak_FG Carlson 30, 14:49.</p><p>LAC_FG Badgley 41, 7:12.</p><p>A_54,750.</p><p>___</p> <table> <tr> <th>LAC</th> <th>Oak</th> <td></td> </tr> <tr> <td>First downs</td> <td>16</td> <td>16</td> </tr> <tr> <td>Total Net Yards</td> <td>335</td> <td>317</td> </tr> <tr> <td>Rushes-yards</td> <td>26-113</td> <td>22-114</td> </tr> <tr> <td>Passing</td> <td>222</td> <td>203</td> </tr> <tr> <td>Punt Returns</td> <td>2-15</td> <td>3-8</td> </tr> <tr> <td>Kickoff Returns</td> <td>2-41</td> <td>5-96</td> </tr> <tr> <td>Interceptions Ret.</td> <td>0-0</td> <td>1-0</td> </tr> <tr> <td>Comp-Att-Int</td> <td>18-26-1</td> <td>24-37-0</td> </tr> <tr> <td>Sacked-Yards Lost</td> <td>1-1</td> <td>4-40</td> </tr> <tr> <td>Punts</td> <td>4-42.8</td> <td>3-54.0</td> </tr> <tr> <td>Fumbles-Lost</td> <td>0-0</td> <td>1-1</td> </tr> <tr> <td>Penalties-Yards</td> <td>6-70</td> <td>6-55</td> </tr> <tr> <td>Time of Possession</td> <td>28:50</td> <td>31:10</td> </tr> </table><p>___</p> <table> <tr> <th>INDIVIDUAL STATISTICS</th> </tr> </table><p>RUSHING_Los Angeles, Gordon 18-93, Ekeler 3-19, Watt 2-2, Rivers 1-1, M.Williams 1-0, Benjamin 1-(minus 2). Oakland, Martin 15-61, Townsend 1-42, Richard 3-7, Bryant 1-2, Carr 2-2.</p><p>PASSING_Los Angeles, Rivers 18-26-1-223. Oakland, Carr 24-37-0-243.</p><p>RECEIVING_Los Angeles, Allen 6-57, Gordon 5-72, Ty.Williams 4-46, Green 2-30, Gates 1-18. Oakland, Richard 5-52, Cook 4-52, LaFell 4-47, Roberts 3-39, Martin 3-31, Bryant 3-17, Carrier 1-5, D.Harris 1-0.</p><p>MISSED FIELD GOALS_None.</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Chargers-Raiders Stats');return false;"><span class="op-btn">Read More</span> <span class="count">99 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fchargers-raiders-stats%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Chargers-Raiders Stats+http://nfp.news/yoo" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Chargers-Raiders Stats&#32;&#32;http://nfp.news/yoo" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yoo"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/eagles-right-tackle-lane-johnson-out-with-knee-injury/" rel="bookmark" title="Eagles right tackle Lane Johnson out with knee injury">Eagles right tackle Lane Johnson out with knee injury</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/eagles-right-tackle-lane-johnson-out-with-knee-injury/"/><meta itemprop="datePublished" content="15 mins ago"/><meta itemprop="dateModified" content="15 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>PHILADELPHIA (AP) — Right tackle Lane Johnson is inactive for the Eagles against Dallas on Sunday night.</p> <p>Johnson, an All-Pro last season, has a strained medial collateral ligament in his left knee. Halapoulivaati Vaitai will take his place in the lineup.</p> <p>Starting cornerback Jalen Mills has a foot injury and was already ruled</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>PHILADELPHIA (AP) &mdash; Right tackle Lane Johnson is inactive for the Eagles against Dallas on Sunday night.</p><p>Johnson, an All-Pro last season, has a strained medial collateral ligament in his left knee. Halapoulivaati Vaitai will take his place in the lineup.</p><p>Starting cornerback Jalen Mills has a foot injury and was already ruled out.</p><p>Linebacker Sean Lee is among several injured players sitting out for the Cowboys. Lee has a hamstring injury and is expected to miss several games.</p><p>The full list of inactive players:</p><p>DALLAS-PHILADELPHIA</p><p>Cowboys: Lee, QR Mike White, WR Tavon Austin, LB Joe Thomas, G Connor Williams, DL David Irving, DE Taco Charlton</p><p>Eagles: Johnson, Mills, QB Nate Sudfeld, RB Darren Sproles, CB Sidney Jones, S Deiondre&#8217; Hall, OL Matt Pryor</p><p>___</p><p>More AP NFL coverage: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Eagles right tackle Lane Johnson out with knee injury');return false;"><span class="op-btn">Read More</span> <span class="count">77 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Feagles-right-tackle-lane-johnson-out-with-knee-injury%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Eagles right tackle Lane Johnson out with knee injury+http://nfp.news/yop" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Eagles right tackle Lane Johnson out with knee injury&#32;&#32;http://nfp.news/yop" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yop"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/falcons-flop-lose-momentum-after-ugly-28-16-loss-to-browns/" rel="bookmark" title="Falcons flop, lose momentum after ugly 28-16 loss to Browns">Falcons flop, lose momentum after ugly 28-16 loss to Browns</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/falcons-flop-lose-momentum-after-ugly-28-16-loss-to-browns/"/><meta itemprop="datePublished" content="15 mins ago"/><meta itemprop="dateModified" content="15 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>CLEVELAND (AP) — Quarterback Matt Ryan packed his belongings, left Atlanta's subdued locker room and slowly walked down the corridor toward the team bus, pulling his wheeled luggage.</p> <p>He and the Falcons may have left their playoff hopes behind.</p> <p>Their three-game winning streak came to a screeching halt Sunday with a 28-16 loss</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>CLEVELAND (AP) &mdash; Quarterback Matt Ryan packed his belongings, left Atlanta&#8217;s subdued locker room and slowly walked down the corridor toward the team bus, pulling his wheeled luggage.</p><p>He and the Falcons may have left their playoff hopes behind.</p><p>Their three-game winning streak came to a screeching halt Sunday with a 28-16 loss to the Cleveland Browns, who put together one of their best all-around games in years against an Atlanta team that had seemingly turned its season around following a 1-4 start.</p><p>But the Falcons (4-5) committed a costly turnover in the second half, gave up a Cleveland-record-breaking 92-yard touchdown run to Georgia native Nick Chubb, and failed to execute on a critical trip to the red zone when the game was still winnable.</p><p>Afterward, Atlanta coach Dan Quinn was at a loss to explain his team&#8217;s puzzling performance.</p><p>&#8220;I thought we had made some improvement and some progress, so it&#8217;s a setback,&#8221; Quinn said. &#8220;I like the fight of our guys. I know we&#8217;ll come back to fight. When you miss an opportunity, whether it&#8217;s a team that people on the outside say you should win or one people think the other way, I go into it and think you can get them all. When you don&#8217;t get that done, for sure it stinks.&#8221;</p><p>It was shocking considering the Falcons were coming off a well-balanced win over Washington last week and had fought their way back into contention in the NFC South.</p><p>&#8220;It was disappointing,&#8221; said Ryan, whose solid stats (38 of 52 for 330 yards and two touchdowns) obscured other offensive issues. &#8220;Obviously, you have to give credit to Cleveland. I thought they played really well and made a lot of good plays. We fell short and did not make enough plays when we needed to. We didn&#8217;t play up to the standard that we are capable to playing.</p><p>&#8220;We need to do that as we move forward and get ready for next week. We have got to play better.&#8221;</p><p>Despite their problems, the Falcons were only down 14-10 at halftime, and with their high-powered offense, a comeback seemed inevitable against the Browns (3-6-1), who had dropped four in a row.</p><p>Atlanta got the ball to start the third quarter and got a 23-yard completion from Ryan to Julio Jones on the first play. After an 8-yard loss, Ryan connected on a 4-yard pass to wide receiver Mohamed Sanu, who fumbled after a hit by Browns cornerback T.J. Carrie.</p><p>Cleveland recovered at Atlanta&#8217;s 41 and quickly drove for a touchdown as rookie QB Baker Mayfield hit Duke Johnson for an 11-yard score to give the Browns a 21-10 lead.</p><p>Sanu&#8217;s fumble had given the momentum right back to the Browns, but while they were shaky, the Falcons still seemed OK when they pinned Cleveland at its 8 after a punt.</p><p>The worst was yet to come.</p><p>On second down, Chubb found a crease on Atlanta&#8217;s right side, cut toward the sideline and outran several Falcons to the end zone on the longest rushing play in Cleveland history &mdash; and the longest by any rookie since 1949.</p><p>As Chubb raced by, Quinn, Ryan and everyone else dressed in black and red on the Atlanta sideline could only watch helplessly as any thoughts of a comeback completely vanished.</p><p>Quinn didn&#8217;t want to speculate on what went wrong on the play. Suffice to say, little went right.</p><p>Still, the Falcons were hanging around in the fourth quarter when a series of head-scratching plays perhaps best sized up their day.</p><p>Atlanta drove to Cleveland&#8217;s 6 before a short pass was followed by two runs up the middle that were stopped by the Browns short of the end zone. Then, on fourth down and inches from a TD, Ryan was inexplicably in the shotgun before he threw a pass toward third-string tight end Eric Saubert, who had no chance of making a catch.</p><p>Ryan&#8217;s choice of targets was peculiar given his other options: Jones, Sanu and tight end Alex Hooper, who caught 10 passes. Even a running play made more sense.</p><p>The hard-to-understand performance and loss overshadowed a personal milestone for Jones, who reached 10,000 career yards receiving faster than any player in NFL history.</p><p>&#8220;It&#8217;s always tough when you lose,&#8221; said Jones, who had seven catches for 107 yards and one TD. &#8220;We can make up stuff here and there, but at the end of the day it&#8217;s on us. I&#8217;m going to keep saying that we can play better and we can do better, but with opportunities and things like that, we have to do better. That&#8217;s it. That&#8217;s the bottom line. We just have to get back to work.&#8221;</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Falcons flop, lose momentum after ugly 28-16 loss to Browns');return false;"><span class="op-btn">Read More</span> <span class="count">723 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Ffalcons-flop-lose-momentum-after-ugly-28-16-loss-to-browns%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Falcons flop, lose momentum after ugly 28-16 loss to Browns+http://nfp.news/yor" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Falcons flop, lose momentum after ugly 28-16 loss to Browns&#32;&#32;http://nfp.news/yor" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yor"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/the-latest-packers-pulling-away-on-sputtering-dolphins/" rel="bookmark" title="The Latest: Packers pulling away on sputtering Dolphins">The Latest: Packers pulling away on sputtering Dolphins</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/the-latest-packers-pulling-away-on-sputtering-dolphins/"/><meta itemprop="datePublished" content="31 mins ago"/><meta itemprop="dateModified" content="31 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>The Latest on Week 10 in the NFL (all times EST):</p> <p>6:50 p.m.</p> <p>The Green Bay Packers are pulling away from the Miami Dolphins.</p> <p>Davante Adams and Aaron Jones have accounted for two touchdowns each. Green Bay broke it open in the third quarter. After Jones scored on a 10-yard run, Green Bay's</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>The Latest on Week 10 in the NFL (all times EST):</p><p>6:50 p.m.</p><p>The Green Bay Packers are pulling away from the Miami Dolphins.</p><p>Davante Adams and Aaron Jones have accounted for two touchdowns each. Green Bay broke it open in the third quarter. After Jones scored on a 10-yard run, Green Bay&#8217;s Bashaud Breeland picked off Brock Osweiler deep in Miami territory.</p><p>Three plays later Aaron Rodgers hit Adams for a 25-yard touchdown pass for a 28-12 lead with 7:24 left. That was the score going into the fourth quarter.</p><p>The Dolphins have settled for kicker Jason Sanders hitting four field goals on five drives inside Green Bay&#8217;s 30.</p><p>___</p><p>6:40 p.m.</p><p>Los Angeles Chargers quarterback Philip Rivers is closing in on extending his streak to nine games with at least two touchdown passes and a passer rating of 95 or higher.</p><p>Rivers is already just the third player to do that in eight straight games to start a season. Only Green Bay&#8217;s Aaron Rodgers, who did it in 13 straight to open the 2011 season, and Tom Brady, 10 straight in 2007, have longer streaks.</p><p>Rivers is currently 17 of 25 for 219 yards passing with two TDs and an interception and a 105.2 passer rating with the Chargers up 20-6 on the Oakland Raiders with four minutes remaining.</p><p>___</p><p>6:05 p.m.</p><p>Green Bay running back Aaron Jones has 101 yards and a touchdown on eight carries at halftime with the Packers leading the Miami Dolphins 14-9.</p><p>It&#8217;s the first time that a Green Bay running back has gone over the 100-yard mark this season. Aaron Rodgers also has a touchdown pass to Davante Adams.</p><p>The Dolphins have been moving the ball in spite of missing three starting offensive linemen. But they turned the ball over a bad shotgun snap on their first series, and have been held to three field goals.</p><p>___</p><p>5:50 p.m.</p><p>Los Angeles Rams running back Todd Gurley has become the fourth NFL player to score a touchdown in each of his team&#8217;s first 10 games of a season.</p><p>Gurley scored on a 17-yard run to put the Ram up 17-14 with under three minutes left in the second quarter against Seattle. His 10-game streak matches former Rams player Elroy &#8216;Crazylegs&#8217; Hirsch, who did it in 1951.</p><p>Baltimore&#8217;s Lenny Moore, in 1951, and Buffalo&#8217;s O.J. Simpson, in 1975, share the record in having scored in each of their teams&#8217; first 14 games of the season.</p><p>The touchdown was Gurley&#8217;s league-leading 17th of the season. And he&#8217;s scored in 13 consecutive regular-season games since being held out of the end zone in a 32-16 win at Arizona last Dec. 3.</p><p>___</p><p>5:35 p.m.</p><p>Los Angeles Rams defensive end Aaron Donald set a career-high with his 12th sack of the season and second of the game against Seattle&#8217;s Russell Wilson.</p><p>Donald entered the day second on the NFL list with 10 sacks this season, 11 1/2 behind Minnesota&#8217;s Danielle Hunter.</p><p>The fifth-year player passed his previous high of 11 sacks set in both 2015 and last season, and increased his career total to 61.</p><p>___</p><p>5:15 p.m.</p><p>Miami Dolphins running back Frank Gore has topped 500 yards rushing for a 14th consecutive season to set an NFL record.</p><p>Gore entered the game against Green Bay tied with Hall of Famers Emmitt Smith and Walter Payton, who had topped 500 yards in 13 straight seasons. Gore topped the milestone with a 9-yard run with about 3 1/2 minutes left in the first quarter.</p><p>The 14-year veteran ranks fourth and leads active players with 14,464 yards rushing.</p><p>Green Bay leads Miami 14-6 early in the second quarter. For the Packers, running back Aaron Jones has 96 yards on four carries, including a career-long 67-yarder.</p><p>___</p><p>5 p.m.</p><p>Arizona Cardinals receiver Larry Fitzgerald has passed Hall of Famer Terrell Owens to move into second place on the career yards-receiving list.</p><p>The 15th-year player had six catches for 50 yards to up his total to 15,952 &mdash; moving 18 ahead of Owens &mdash; in a 26-14 loss at Kansas City.</p><p>Jerry Rice holds the record with 22,895 yards.</p><p>___</p><p>4:50 p.m.</p><p>The Los Angeles Rams held a moment of silence before their game against Seattle for the 12 victims of the mass shooting in Thousand Oaks last week.</p><p>The Rams&#8217; training complex in less than five miles from the Borderline Bar and Grill. The team is donating proceeds from its stadium raffle and a jersey auction to a relief effort, and left tackle Andrew Whitworth has pledged his game check.</p><p>___</p><p>4:45 p.m.</p><p>The Green Bay Packers have cashed in on a turnover on the Miami Dolphins&#8217; game-opening drive.</p><p>Aaron Rodgers hit Davante Adams for a 7-yard touchdown pass with 6:07 left in the first quarter to give Green Bay a 7-0 lead. Running back Aaron Jones accounted for 54 total yards on the drive. The Packers capitalized after Dolphins&#8217; quarterback Brock Osweiler mishandled a shotgun snap that was recovered by Reggie Gilbert at the Green Bay 30.</p><p>___</p><p>4:20 p.m.</p><p>The Tampa Bay Buccaneers had very little to show for gaining 501 yards offense in a 16-3 loss to Washington.</p><p>The Buccaneers became just the second team since 1940 to top 400 yards and score 3 or fewer points, according to Pro Football Reference. They join the then-St. Louis Rams, who had 424 yards offense in a 24-3 loss to Green Bay in 2011.</p><p>Four turnovers, including two interceptions thrown by Ryan Fitzpatrick, didn&#8217;t help. Neither did kicker Chandler Catanzaro missing field-goal attempts from 30 and 48 yards, both wide right.</p><p>___</p><p>3:50 p.m.</p><p>The New England Patriots have pulled quarterback Tom Brady while trailing the Titans 34-10 in the fourth quarter.</p><p>The Titans sacked Brady a season-high three times, and former New England cornerback Logan Ryan broke up a Brady pass to Julian Edelman on fourth down with 10:48 left to end a Patriots&#8217; scoring threat.</p><p>Edelman went to the locker room after that pass was broken up. He is questionable to return with an injured ankle.</p><p>Brian Hoyer replaced Brady after Derrick Henry&#8217;s 10-yard run out of the wildcat put the Titans up 34-10 with 7:13 left.</p><p>The Patriots also were playing without left tackle Trent Brown, who left in the third quarter with an injured back. Tight end Dwayne Allen is questionable to return with an injured knee.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>3:10 p.m.</p><p>Buffalo Bills running back LeSean McCoy has plenty to talk about now while enjoying his best game of the season.</p><p>Three quarters into Buffalo&#8217;s game at the New York Jets, McCoy has already topped 100 yards rushing for the first time since gaining 156 on a snow-covered field in a 13-7 overtime win over Indianapolis on Dec. 10.</p><p>He has also scored two touchdowns rushing for the first time since scoring twice in a 30-27 win over Tampa Bay on Oct. 22, 2017.</p><p>The touchdowns were the first of the season for McCoy. And the come two days after the 10th-year player broke nearly two weeks of silence by telling reporters he was frustrated with his lack of production.</p><p>McCoy entered the game with 267 yards rushing this season, and had 103 midway through the third quarter.</p><p>McCoy also surpassed 500 career points, and vaulted into 26th place on the career yards rushing list by moving ahead of Marshawn Lynch (10,379), Eddie George (10,441) and Tiki Barber (10,449).</p><p>___</p><p>2:50 p.m.</p><p>Cleveland Browns rookie Nick Chubb broke a club record and maybe Atlanta&#8217;s back with a 92-yard TD run.</p><p>The running back took a handoff at Cleveland&#8217;s 8, cut right and avoided a few tacklers before streaking to the end zone to give Cleveland a 28-10 lead midway through the third quarter.</p><p>Chubb&#8217;s 92-yard run is the longest in team history, topping the 90-yard run by Bobby Mitchell in 1959 against Washington.</p><p>It was Chubb&#8217;s second touchdown of the game. He also caught a 13-yard pass from Baker Mayfield in the second quarter.</p><p>___</p><p>2:45 p.m.</p><p>The Tennessee Titans are following up their big win in Dallas with a strong first half against the Patriots.</p><p>Tennessee scored a season-high 28 points to beat the Cowboys on Monday night, and they now lead New England 24-10 at halftime.</p><p>The Titans scored a season-high 17 points in the first quarter with touchdown passes by Marcus Mariota on each of their first two possessions. Mariota is 11 of 16 for 152 yards.</p><p>The Titans have been getting plenty of pressure on Tom Brady. Former Patriots cornerback Logan Ryan sacked Brady on the final play of the first half, the Titans&#8217; second sack of the first half.</p><p>James Develin has run for a TD, and Stephen Gostkowski connected on one of his two 52-yard field goal attempt for New England.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>___</p><p>2:40 p.m.</p><p>Rams left tackle Andrew Whitworth is donating a game check to the families of the victims of the mass shooting in Thousand Oaks.</p><p>Whitworth will give his check from Los Angeles&#8217; game against Seattle to the Ventura County Community Foundation&#8217;s Conejo Valley Victims Fund. The fund was set up to help the families of the 12 people killed by a gunman in Thousand Oaks, the home of the Rams&#8217; training complex.</p><p>Whitworth is in the second season of a three-year, $36 million deal with the Rams. He has played a major role in the Rams&#8217; transformation into an elite NFC team under Sean McVay.</p><p>Whitworth, Todd Gurley, Jared Goff, Michael Brockers and other players are also auctioning off their game jerseys to benefit the victims&#8217; fund and American Red Cross Southern California Wildfire Relief.</p><p>Two wildfires are also burning in the same general area of the western Los Angeles suburbs.</p><p>2:30 p.m.</p><p>New Orleans Saints quarterback Drew Brees has moved ahead of Brett Favre for second place on the career regular-season touchdown list with a sensational first half at Cincinnati.</p><p>He&#8217;s thrown three TD passes as the Saints have raced ahead 35-7, reaching the end zone on all five possessions. Brees has 509 career TD passes, one more than Favre.</p><p>Peyton Manning holds the record with 539.</p><p>The Saints have piled up 311 yards, and they have 21 first downs on 40 plays. Brees is 18 of 20 for 214 yards.</p><p>___</p><p>2:15 p.m.</p><p>Baker Mayfield enjoyed a perfect half.</p><p>Cleveland&#8217;s rookie quarterback completed 12 of 12 passes for 165 yards and two touchdowns in the first half against Atlanta. Mayfield connected on a 28-yard TD with Rashard Higgins and threw a 13-yard scoring pass to Nick Chubb.</p><p>Mayfield finished the half with a 158.3 quarterback rating, the highest possible score. The Browns did have one interception in the half, but it was thrown by running back Dontrell Hilliard, who attempted to hit a well-covered Mayfield on a trick play.</p><p>___</p><p>2:10 p.m.</p><p>Patrick Mahomes has broken the Kansas City Chiefs record for touchdown passes in a season.</p><p>The first-year starter threw his 31st of the season &mdash; and second of the game to Tyreek Hill &mdash; to pass Len Dawson. The Hall of Famer threw 30 in 1964.</p><p>The record-setter came on third-and-goal from the Arizona 14. Hill celebrated by leaping into the stands, just as he did on his first TD catch, then playing with the TV cameras.</p><p>That last bit earned Hill an unsportsmanlike conduct penalty.</p><p>&mdash; Dave Skretta reporting from Kansas City</p><p>___</p><p>2 p.m.</p><p>Atlanta receiver Julio Jones has reached 10,000 yards receiving faster than any player in NFL history.</p><p>Jones reached the plateau in his 104th career game, catching a 30-yard pass in the second quarter from Matt Ryan. Calvin Johnson held the previous mark, getting to 10,000 yards in his 115th game. Torry Holt and Antonio Brown got there in 116 games.</p><p>Jones caught a short pass over the middle and broke a couple tackles on his first reception of the game. He came in with 933 yards receiving this season.</p><p>Moments later, Jones caught a 1-yard TD pass from Ryan to give the Falcons a 10-7 lead.</p><p>___</p><p>1:50 p.m.</p><p>The Buffalo Bills have scored twice in the first quarter against the New York Jets to match their combined total from their previous four games.</p><p>LeSean McCoy opened the scoring with a 28-yard run, 5 more than he totaled in his previous two games. And then tight end Jason Croom recovered teammate Zay Jones&#8217; fumble in the end zone to put the Bills ahead 14-0.</p><p>Buffalo&#8217;s 14 points are the most they&#8217;ve scored in seven games, since a 27-6 victory at Minnesota on Sept. 23. And the Bills are doing this with Matt Barkley making his debut at quarterback less than two weeks after signing with Buffalo.</p><p>___</p><p>1:40 p.m.</p><p>New Orleans quarterback Drew Brees has thrown two touchdown passes against Cincinnati to up his regular-season total to 508 and match Brett Favre for second on the NFL career list.</p><p>Brees first TD was a 7-yarder to Michael Thomas midway through the first quarter. Mark Ingram II then turned a screen pass into a 28-yard touchdown</p><p>Peyton Manning holds the record with 539.</p><p>___</p><p>1:25 p.m.</p><p>Six teams reached the end zone on the opening possession of their games Sunday to get Week 10 off to a high-scoring start.</p><p>Kansas City, which lost the coin toss for the first time all season, went 75 yards in 56 seconds. Three plays were needed, with Patrick Mahomes connecting with Tyreek Hill for 38 yards, then for a 37-yard touchdown.</p><p>Tennessee&#8217;s Darius Jennings returned the opening kickoff 58 yards, then the Titans needed seven plays to go 40 yards, capped by Marcus Mariota 4-yard TD pass to Jonnu Smith against New England.</p><p>Chicago&#8217;s Tarik Cohen had a 3-yard TD run to cap an eight-play, 75-yard drive vs. Detroit. But Cody Parkey missed the extra point.</p><p>Indianapolis covered 75 yards in seven plays and Andrew Luck found Eric Ebron for a 53-yard scoring pass against Jacksonville.</p><p>Buffalo used a mere two plays against the Jets, with newcomer Matt Barkley throwing 47 yards to Robert Foster before LeSean McCoy broke from a lengthy slump for his first touchdown this season, on a 28-yard run.</p><p>And Drew Brees threw his 507th career touchdown pass, leaving him one behind Brett Favre for second place on the career list, capping a 15-play, 75-yard drive that consumed 8 minutes, 30 seconds. It ended with Michael Thomas&#8217; diving 7-yard catch.</p><p>___</p><p>1:15 p.m.</p><p>Chiefs quarterback Patrick Mahomes needed only 56 seconds to throw his first touchdown pass against Arizona, moving him into a tie with Hall of Famer Len Dawson for the single-season franchise record.</p><p>Mahomes hit Tyreek Hill down the sideline for 38 yards on the game&#8217;s first play. Then, after an incompletion, Mahomes found Hill again for a 37-yard touchdown reception.</p><p>It was the 30th thrown by Mahomes this season. Dawson threw 30 during the 1964 season.</p><p>&mdash; Dave Skretta reporting from Kansas City.</p><p>___</p><p>1:10 p.m.</p><p>The Indianapolis Colts honored kicker Adam Vinatieri, the NFL&#8217;s new career scoring leader, with a brief highlight show during pregame introduction before their game against Jacksonville.</p><p>Vinatieri received a roaring ovation from the Lucas Oil Stadium crowd when he was announced as the final starter. The 45-year-old waved to the crowd and slapped hands with a group of fans gathered around the American flag on the field.</p><p>Vinatieri broke Morten Andersen&#8217;s record two weeks ago at Oakland, but the Colts had a bye last week and Sunday marked the first time Indy could celebrate the record-breaking moment on its home turf.</p><p>___</p><p>1 p.m.</p><p>Three-time Pro Bowl defensive lineman Jurrell Casey was the last of the Titans defense introduced before kickoff for Tennessee&#8217;s game against New England.</p><p>Casey took the field carrying an American flag, and first shaking hands with a soldier as part of the NFL&#8217;s Salute to Service being held on Veteran&#8217;s Day. A soldier accompanied each Titans starter onto the field for a few steps.</p><p>Country artist Little Big Town performed the national anthem, which featured a flyover by military helicopters.</p><p>___</p><p>11:30 a.m.</p><p>Drew Brees and Tom Brady enter Week 10 of the NFL&#8217;s schedule neck and neck in closing in on matching Brett Favre for second place on the career regular-season list.</p><p>Brees has 506 touchdowns passing, two behind Favre, as the New Orleans Saints play at Cincinnati. And Brady has 505 with his New England Patriots playing at Tennessee. Both are a little more than 30 behind Peyton Manning&#8217;s record of 539.</p><p>Brady does have chance to pass Manning on the career touchdowns passing list, including playoffs. Manning has 579, only three more than Brady.</p><p>On the other end of the quarterback matchup spectrum Sunday, the Buffalo Bills and New York Jets will feature a battle of the backups rather than far more intriguing AFC East showdown of two rookie first-round picks.</p><p>Matt Barkley is starting in place of Buffalo&#8217;s Josh Allen, who will miss his fourth straight game with a sprained throwing elbow. For New York, Josh McCown is starting in place Sam Darnold, who is sidelined by a strained right foot. Darnold was drafted third overall, four spots ahead of Allen.</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','The Latest: Packers pulling away on sputtering Dolphins');return false;"><span class="op-btn">Read More</span> <span class="count">2673 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fthe-latest-packers-pulling-away-on-sputtering-dolphins%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=The Latest: Packers pulling away on sputtering Dolphins+http://nfp.news/yol" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=The Latest: Packers pulling away on sputtering Dolphins&#32;&#32;http://nfp.news/yol" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yol"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/rivers-leads-chargers-to-6th-straight-win-20-6-over-raiders/" rel="bookmark" title="Rivers leads Chargers to 6th straight win, 20-6 over Raiders">Rivers leads Chargers to 6th straight win, 20-6 over Raiders</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/rivers-leads-chargers-to-6th-straight-win-20-6-over-raiders/"/><meta itemprop="datePublished" content="31 mins ago"/><meta itemprop="dateModified" content="31 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>OAKLAND, Calif. (AP) — Philip Rivers threw two touchdown passes, Melvin Gordon gained 165 yards and the Los Angeles Chargers won their sixth straight game, 20-6 over the struggling Oakland Raiders on Sunday.</p> <p>Rivers bounced back from a first quarter with no completions to throw an 11-yard TD pass to Keenan Allen in</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>OAKLAND, Calif. (AP) &mdash; Philip Rivers threw two touchdown passes, Melvin Gordon gained 165 yards and the Los Angeles Chargers won their sixth straight game, 20-6 over the struggling Oakland Raiders on Sunday.</p><p>Rivers bounced back from a first quarter with no completions to throw an 11-yard TD pass to Keenan Allen in the second quarter to give the Chargers (7-2) the lead for good and a 66-yarder to Gordon on the opening drive of the second half.</p><p>Los Angeles coasted from there against the Raiders (1-8), who have lost five straight games by at least 14 points under coach Jon Gruden and have been outscored 75-9 in the past nine quarters in what has quickly become a lost season.</p><p>Oakland started quickly by controlling the ball for 23 of 29 plays in the first quarter and outgaining the Chargers by 129 yards. But Los Angeles allowed little after Melvin Ingram forced a fumble on a sack of Derek Carr early in the second quarter with the Raiders looking to add to a 3-0 lead.</p><p>Rivers found his stride after that, leading the Chargers to a field goal and then engineering a 91-yard drive at the end of the half that was capped by the throw to Allen in the front corner of the end zone.</p><p>Gordon, who had 93 yards rushing and 72 yards receiving, then put the game away when he caught a short pass from Rivers, broke a tackle by Gareon Conley, juked Reggie Nelson and raced in for the long score.</p><p>LOPSIDED START</p><p>The Raiders missed opportunities to take a bigger lead while outgaining the Chargers 135-6 in the first quarter. Dwayne Harris was stopped by Derwin James on a shovel pass on fourth-and-goal from the 1 to deny the best chance for Oakland. Los Angeles then scored 10 points in the second quarter with a strip sack by Ingram denying Oakland a shot at a field goal and setting up one for the Chargers. Rivers hit Allen for the TD with 24 seconds left in the half.</p><p>FAKING IT</p><p>Raiders rookie punter Johnny Townsend pulled off a fake punt on the opening drive for a 42-yard run. That was longer than his average punt of 41.9 yards coming into the game. Townsend then added his longest kick of the season with a 57-yarder in the second quarter. Townsend is the third player since the 1970 merger with a run of at least 40 yards and a punt of at least 50 in the same game, joining Cleveland&#8217;s Reggie Hodges, who did it for Cleveland in 2010, and Jeff Hayes for Washington in 1983.</p><p>SMOKY GAME</p><p>The air quality for the game was at an unhealthy level because of wildfires in Butte County, about 150 miles to the north. The Air Quality Index was at 159 at kickoff, which is in the unhealthy zone, and smoke could be smelled throughout the stadium. The NFL had monitored the situation but the AQI never got near 200, the level where the game would have needed to be moved.</p><p>INJURIES</p><p>Chargers LB Denzel Perryman left the game with a knee injury on the opening drive. &#8230; Raiders WR Martavis Bryant (knee) left the game in the third quarter.</p><p>UP NEXT</p><p>Colts: Host the Broncos on Sunday.</p><p>Raiders: Visit the Cardinals on Sunday.</p><p>___</p><p>More AP NFL: https://apnews.com/tag/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Rivers leads Chargers to 6th straight win, 20-6 over Raiders');return false;"><span class="op-btn">Read More</span> <span class="count">486 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Frivers-leads-chargers-to-6th-straight-win-20-6-over-raiders%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Rivers leads Chargers to 6th straight win, 20-6 over Raiders+http://nfp.news/yom" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Rivers leads Chargers to 6th straight win, 20-6 over Raiders&#32;&#32;http://nfp.news/yom" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yom"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/edelman-2-others-hurt-for-patriots-in-loss-to-titans/" rel="bookmark" title="Edelman, 2 others hurt for Patriots in loss to Titans">Edelman, 2 others hurt for Patriots in loss to Titans</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/edelman-2-others-hurt-for-patriots-in-loss-to-titans/"/><meta itemprop="datePublished" content="31 mins ago"/><meta itemprop="dateModified" content="31 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>The New England Patriots returned to their usual efficient selves after an iffy start to the season in part because they got receiver Julian Edelman back from a four-game suspension. On Sunday, Tom Brady again was down one of his favorite targets.</p> <p>Edelman left the Patriots' 34-10 loss to the Tennessee Titans with</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>The New England Patriots returned to their usual efficient selves after an iffy start to the season in part because they got receiver Julian Edelman back from a four-game suspension. On Sunday, Tom Brady again was down one of his favorite targets.</p><p>Edelman left the Patriots&#8217; 34-10 loss to the Tennessee Titans with an ankle injury and did not return on a rough day for the New England offense. It also ended with Brady on the bench &mdash; because the game was out of reach.</p><p>Left tackle Trent Brown was hurt twice during the game, leaving for good when he injured his back in the third quarter. Tight end Dwayne Allen also hurt a knee in the third quarter.</p><p>For the Titans, running back David Fluellen went down untouched with a knee injury.</p><p>New England&#8217;s opponent in last season&#8217;s AFC championship game also got banged-up on offense. Jaguars center Brandon Linder and tackle Ereck Flowers both left Jacksonville&#8217;s loss to Indianapolis with knee injuries.</p><p>The Colts lost defensive end Carroll Phillips to an injured groin and defensive tackle Grover Stewart to an ankle injury.</p><p>The Bills, with Matt Barkley filling in at quarterback for the injured Josh Allen and Derek Anderson, had two defensive players hurt in their win over the Jets. Cornerback Taron Johnson hurt a shoulder and Matt Milano, who had an interception earlier in the game, left in the fourth quarter to be evaluated for a head injury.</p><p>Cincinnati&#8217;s historically bad defense suffered another setback when cornerback Dre Kirkpatrick exited the Bengals&#8217; blowout loss to the Saints with a concussion.</p><p>For the Detroit Lions, tight end Michael Roberts suffered a shoulder injury and wide receiver Marvin Jones Jr. hurt a knee.</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Edelman, 2 others hurt for Patriots in loss to Titans');return false;"><span class="op-btn">Read More</span> <span class="count">236 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fedelman-2-others-hurt-for-patriots-in-loss-to-titans%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Edelman, 2 others hurt for Patriots in loss to Titans+http://nfp.news/yok" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Edelman, 2 others hurt for Patriots in loss to Titans&#32;&#32;http://nfp.news/yok" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yok"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/the-latest-rivers-extends-season-long-roll-against-raiders/" rel="bookmark" title="The Latest: Rivers extends season-long roll against Raiders">The Latest: Rivers extends season-long roll against Raiders</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/the-latest-rivers-extends-season-long-roll-against-raiders/"/><meta itemprop="datePublished" content="46 mins ago"/><meta itemprop="dateModified" content="46 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>The Latest on Week 10 in the NFL (all times EST):</p> <p>6:40 p.m.</p> <p>Los Angeles Chargers quarterback Philip Rivers is closing in on extending his streak to nine games with at least two touchdown passes and a passer rating of 95 or higher.</p> <p>Rivers is already just the third player to do that</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>The Latest on Week 10 in the NFL (all times EST):</p><p>6:40 p.m.</p><p>Los Angeles Chargers quarterback Philip Rivers is closing in on extending his streak to nine games with at least two touchdown passes and a passer rating of 95 or higher.</p><p>Rivers is already just the third player to do that in eight straight games to start a season. Only Green Bay&#8217;s Aaron Rodgers, who did it in 13 straight to open the 2011 season, and Tom Brady, 10 straight in 2007, have longer streaks.</p><p>Rivers is currently 17 of 25 for 219 yards passing with two TDs and an interception and a 105.2 passer rating with the Chargers up 20-6 on the Oakland Raiders with four minutes remaining.</p><p>___</p><p>6:05 p.m.</p><p>Green Bay running back Aaron Jones has 101 yards and a touchdown on eight carries at halftime with the Packers leading the Miami Dolphins 14-9.</p><p>It&#8217;s the first time that a Green Bay running back has gone over the 100-yard mark this season. Aaron Rodgers also has a touchdown pass to Davante Adams.</p><p>The Dolphins have been moving the ball in spite of missing three starting offensive linemen. But they turned the ball over a bad shotgun snap on their first series, and have been held to three field goals.</p><p>___</p><p>5:50 p.m.</p><p>Los Angeles Rams running back Todd Gurley has become the fourth NFL player to score a touchdown in each of his team&#8217;s first 10 games of a season.</p><p>Gurley scored on a 17-yard run to put the Ram up 17-14 with under three minutes left in the second quarter against Seattle. His 10-game streak matches former Rams player Elroy &#8216;Crazylegs&#8217; Hirsch, who did it in 1951.</p><p>Baltimore&#8217;s Lenny Moore, in 1951, and Buffalo&#8217;s O.J. Simpson, in 1975, share the record in having scored in each of their teams&#8217; first 14 games of the season.</p><p>The touchdown was Gurley&#8217;s league-leading 17th of the season. And he&#8217;s scored in 13 consecutive regular-season games since being held out of the end zone in a 32-16 win at Arizona last Dec. 3.</p><p>___</p><p>5:35 p.m.</p><p>Los Angeles Rams defensive end Aaron Donald set a career-high with his 12th sack of the season and second of the game against Seattle&#8217;s Russell Wilson.</p><p>Donald entered the day second on the NFL list with 10 sacks this season, 11 1/2 behind Minnesota&#8217;s Danielle Hunter.</p><p>The fifth-year player passed his previous high of 11 sacks set in both 2015 and last season, and increased his career total to 61.</p><p>___</p><p>5:15 p.m.</p><p>Miami Dolphins running back Frank Gore has topped 500 yards rushing for a 14th consecutive season to set an NFL record.</p><p>Gore entered the game against Green Bay tied with Hall of Famers Emmitt Smith and Walter Payton, who had topped 500 yards in 13 straight seasons. Gore topped the milestone with a 9-yard run with about 3 1/2 minutes left in the first quarter.</p><p>The 14-year veteran ranks fourth and leads active players with 14,464 yards rushing.</p><p>Green Bay leads Miami 14-6 early in the second quarter. For the Packers, running back Aaron Jones has 96 yards on four carries, including a career-long 67-yarder.</p><p>___</p><p>5 p.m.</p><p>Arizona Cardinals receiver Larry Fitzgerald has passed Hall of Famer Terrell Owens to move into second place on the career yards-receiving list.</p><p>The 15th-year player had six catches for 50 yards to up his total to 15,952 &mdash; moving 18 ahead of Owens &mdash; in a 26-14 loss at Kansas City.</p><p>Jerry Rice holds the record with 22,895 yards.</p><p>___</p><p>4:50 p.m.</p><p>The Los Angeles Rams held a moment of silence before their game against Seattle for the 12 victims of the mass shooting in Thousand Oaks last week.</p><p>The Rams&#8217; training complex in less than five miles from the Borderline Bar and Grill. The team is donating proceeds from its stadium raffle and a jersey auction to a relief effort, and left tackle Andrew Whitworth has pledged his game check.</p><p>___</p><p>4:45 p.m.</p><p>The Green Bay Packers have cashed in on a turnover on the Miami Dolphins&#8217; game-opening drive.</p><p>Aaron Rodgers hit Davante Adams for a 7-yard touchdown pass with 6:07 left in the first quarter to give Green Bay a 7-0 lead. Running back Aaron Jones accounted for 54 total yards on the drive. The Packers capitalized after Dolphins&#8217; quarterback Brock Osweiler mishandled a shotgun snap that was recovered by Reggie Gilbert at the Green Bay 30.</p><p>___</p><p>4:20 p.m.</p><p>The Tampa Bay Buccaneers had very little to show for gaining 501 yards offense in a 16-3 loss to Washington.</p><p>The Buccaneers became just the second team since 1940 to top 400 yards and score 3 or fewer points, according to Pro Football Reference. They join the then-St. Louis Rams, who had 424 yards offense in a 24-3 loss to Green Bay in 2011.</p><p>Four turnovers, including two interceptions thrown by Ryan Fitzpatrick, didn&#8217;t help. Neither did kicker Chandler Catanzaro missing field-goal attempts from 30 and 48 yards, both wide right.</p><p>___</p><p>3:50 p.m.</p><p>The New England Patriots have pulled quarterback Tom Brady while trailing the Titans 34-10 in the fourth quarter.</p><p>The Titans sacked Brady a season-high three times, and former New England cornerback Logan Ryan broke up a Brady pass to Julian Edelman on fourth down with 10:48 left to end a Patriots&#8217; scoring threat.</p><p>Edelman went to the locker room after that pass was broken up. He is questionable to return with an injured ankle.</p><p>Brian Hoyer replaced Brady after Derrick Henry&#8217;s 10-yard run out of the wildcat put the Titans up 34-10 with 7:13 left.</p><p>The Patriots also were playing without left tackle Trent Brown, who left in the third quarter with an injured back. Tight end Dwayne Allen is questionable to return with an injured knee.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>3:10 p.m.</p><p>Buffalo Bills running back LeSean McCoy has plenty to talk about now while enjoying his best game of the season.</p><p>Three quarters into Buffalo&#8217;s game at the New York Jets, McCoy has already topped 100 yards rushing for the first time since gaining 156 on a snow-covered field in a 13-7 overtime win over Indianapolis on Dec. 10.</p><p>He has also scored two touchdowns rushing for the first time since scoring twice in a 30-27 win over Tampa Bay on Oct. 22, 2017.</p><p>The touchdowns were the first of the season for McCoy. And the come two days after the 10th-year player broke nearly two weeks of silence by telling reporters he was frustrated with his lack of production.</p><p>McCoy entered the game with 267 yards rushing this season, and had 103 midway through the third quarter.</p><p>McCoy also surpassed 500 career points, and vaulted into 26th place on the career yards rushing list by moving ahead of Marshawn Lynch (10,379), Eddie George (10,441) and Tiki Barber (10,449).</p><p>___</p><p>2:50 p.m.</p><p>Cleveland Browns rookie Nick Chubb broke a club record and maybe Atlanta&#8217;s back with a 92-yard TD run.</p><p>The running back took a handoff at Cleveland&#8217;s 8, cut right and avoided a few tacklers before streaking to the end zone to give Cleveland a 28-10 lead midway through the third quarter.</p><p>Chubb&#8217;s 92-yard run is the longest in team history, topping the 90-yard run by Bobby Mitchell in 1959 against Washington.</p><p>It was Chubb&#8217;s second touchdown of the game. He also caught a 13-yard pass from Baker Mayfield in the second quarter.</p><p>___</p><p>2:45 p.m.</p><p>The Tennessee Titans are following up their big win in Dallas with a strong first half against the Patriots.</p><p>Tennessee scored a season-high 28 points to beat the Cowboys on Monday night, and they now lead New England 24-10 at halftime.</p><p>The Titans scored a season-high 17 points in the first quarter with touchdown passes by Marcus Mariota on each of their first two possessions. Mariota is 11 of 16 for 152 yards.</p><p>The Titans have been getting plenty of pressure on Tom Brady. Former Patriots cornerback Logan Ryan sacked Brady on the final play of the first half, the Titans&#8217; second sack of the first half.</p><p>James Develin has run for a TD, and Stephen Gostkowski connected on one of his two 52-yard field goal attempt for New England.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>___</p><p>2:40 p.m.</p><p>Rams left tackle Andrew Whitworth is donating a game check to the families of the victims of the mass shooting in Thousand Oaks.</p><p>Whitworth will give his check from Los Angeles&#8217; game against Seattle to the Ventura County Community Foundation&#8217;s Conejo Valley Victims Fund. The fund was set up to help the families of the 12 people killed by a gunman in Thousand Oaks, the home of the Rams&#8217; training complex.</p><p>Whitworth is in the second season of a three-year, $36 million deal with the Rams. He has played a major role in the Rams&#8217; transformation into an elite NFC team under Sean McVay.</p><p>Whitworth, Todd Gurley, Jared Goff, Michael Brockers and other players are also auctioning off their game jerseys to benefit the victims&#8217; fund and American Red Cross Southern California Wildfire Relief.</p><p>Two wildfires are also burning in the same general area of the western Los Angeles suburbs.</p><p>2:30 p.m.</p><p>New Orleans Saints quarterback Drew Brees has moved ahead of Brett Favre for second place on the career regular-season touchdown list with a sensational first half at Cincinnati.</p><p>He&#8217;s thrown three TD passes as the Saints have raced ahead 35-7, reaching the end zone on all five possessions. Brees has 509 career TD passes, one more than Favre.</p><p>Peyton Manning holds the record with 539.</p><p>The Saints have piled up 311 yards, and they have 21 first downs on 40 plays. Brees is 18 of 20 for 214 yards.</p><p>___</p><p>2:15 p.m.</p><p>Baker Mayfield enjoyed a perfect half.</p><p>Cleveland&#8217;s rookie quarterback completed 12 of 12 passes for 165 yards and two touchdowns in the first half against Atlanta. Mayfield connected on a 28-yard TD with Rashard Higgins and threw a 13-yard scoring pass to Nick Chubb.</p><p>Mayfield finished the half with a 158.3 quarterback rating, the highest possible score. The Browns did have one interception in the half, but it was thrown by running back Dontrell Hilliard, who attempted to hit a well-covered Mayfield on a trick play.</p><p>___</p><p>2:10 p.m.</p><p>Patrick Mahomes has broken the Kansas City Chiefs record for touchdown passes in a season.</p><p>The first-year starter threw his 31st of the season &mdash; and second of the game to Tyreek Hill &mdash; to pass Len Dawson. The Hall of Famer threw 30 in 1964.</p><p>The record-setter came on third-and-goal from the Arizona 14. Hill celebrated by leaping into the stands, just as he did on his first TD catch, then playing with the TV cameras.</p><p>That last bit earned Hill an unsportsmanlike conduct penalty.</p><p>&mdash; Dave Skretta reporting from Kansas City</p><p>___</p><p>2 p.m.</p><p>Atlanta receiver Julio Jones has reached 10,000 yards receiving faster than any player in NFL history.</p><p>Jones reached the plateau in his 104th career game, catching a 30-yard pass in the second quarter from Matt Ryan. Calvin Johnson held the previous mark, getting to 10,000 yards in his 115th game. Torry Holt and Antonio Brown got there in 116 games.</p><p>Jones caught a short pass over the middle and broke a couple tackles on his first reception of the game. He came in with 933 yards receiving this season.</p><p>Moments later, Jones caught a 1-yard TD pass from Ryan to give the Falcons a 10-7 lead.</p><p>___</p><p>1:50 p.m.</p><p>The Buffalo Bills have scored twice in the first quarter against the New York Jets to match their combined total from their previous four games.</p><p>LeSean McCoy opened the scoring with a 28-yard run, 5 more than he totaled in his previous two games. And then tight end Jason Croom recovered teammate Zay Jones&#8217; fumble in the end zone to put the Bills ahead 14-0.</p><p>Buffalo&#8217;s 14 points are the most they&#8217;ve scored in seven games, since a 27-6 victory at Minnesota on Sept. 23. And the Bills are doing this with Matt Barkley making his debut at quarterback less than two weeks after signing with Buffalo.</p><p>___</p><p>1:40 p.m.</p><p>New Orleans quarterback Drew Brees has thrown two touchdown passes against Cincinnati to up his regular-season total to 508 and match Brett Favre for second on the NFL career list.</p><p>Brees first TD was a 7-yarder to Michael Thomas midway through the first quarter. Mark Ingram II then turned a screen pass into a 28-yard touchdown</p><p>Peyton Manning holds the record with 539.</p><p>___</p><p>1:25 p.m.</p><p>Six teams reached the end zone on the opening possession of their games Sunday to get Week 10 off to a high-scoring start.</p><p>Kansas City, which lost the coin toss for the first time all season, went 75 yards in 56 seconds. Three plays were needed, with Patrick Mahomes connecting with Tyreek Hill for 38 yards, then for a 37-yard touchdown.</p><p>Tennessee&#8217;s Darius Jennings returned the opening kickoff 58 yards, then the Titans needed seven plays to go 40 yards, capped by Marcus Mariota 4-yard TD pass to Jonnu Smith against New England.</p><p>Chicago&#8217;s Tarik Cohen had a 3-yard TD run to cap an eight-play, 75-yard drive vs. Detroit. But Cody Parkey missed the extra point.</p><p>Indianapolis covered 75 yards in seven plays and Andrew Luck found Eric Ebron for a 53-yard scoring pass against Jacksonville.</p><p>Buffalo used a mere two plays against the Jets, with newcomer Matt Barkley throwing 47 yards to Robert Foster before LeSean McCoy broke from a lengthy slump for his first touchdown this season, on a 28-yard run.</p><p>And Drew Brees threw his 507th career touchdown pass, leaving him one behind Brett Favre for second place on the career list, capping a 15-play, 75-yard drive that consumed 8 minutes, 30 seconds. It ended with Michael Thomas&#8217; diving 7-yard catch.</p><p>___</p><p>1:15 p.m.</p><p>Chiefs quarterback Patrick Mahomes needed only 56 seconds to throw his first touchdown pass against Arizona, moving him into a tie with Hall of Famer Len Dawson for the single-season franchise record.</p><p>Mahomes hit Tyreek Hill down the sideline for 38 yards on the game&#8217;s first play. Then, after an incompletion, Mahomes found Hill again for a 37-yard touchdown reception.</p><p>It was the 30th thrown by Mahomes this season. Dawson threw 30 during the 1964 season.</p><p>&mdash; Dave Skretta reporting from Kansas City.</p><p>___</p><p>1:10 p.m.</p><p>The Indianapolis Colts honored kicker Adam Vinatieri, the NFL&#8217;s new career scoring leader, with a brief highlight show during pregame introduction before their game against Jacksonville.</p><p>Vinatieri received a roaring ovation from the Lucas Oil Stadium crowd when he was announced as the final starter. The 45-year-old waved to the crowd and slapped hands with a group of fans gathered around the American flag on the field.</p><p>Vinatieri broke Morten Andersen&#8217;s record two weeks ago at Oakland, but the Colts had a bye last week and Sunday marked the first time Indy could celebrate the record-breaking moment on its home turf.</p><p>___</p><p>1 p.m.</p><p>Three-time Pro Bowl defensive lineman Jurrell Casey was the last of the Titans defense introduced before kickoff for Tennessee&#8217;s game against New England.</p><p>Casey took the field carrying an American flag, and first shaking hands with a soldier as part of the NFL&#8217;s Salute to Service being held on Veteran&#8217;s Day. A soldier accompanied each Titans starter onto the field for a few steps.</p><p>Country artist Little Big Town performed the national anthem, which featured a flyover by military helicopters.</p><p>___</p><p>11:30 a.m.</p><p>Drew Brees and Tom Brady enter Week 10 of the NFL&#8217;s schedule neck and neck in closing in on matching Brett Favre for second place on the career regular-season list.</p><p>Brees has 506 touchdowns passing, two behind Favre, as the New Orleans Saints play at Cincinnati. And Brady has 505 with his New England Patriots playing at Tennessee. Both are a little more than 30 behind Peyton Manning&#8217;s record of 539.</p><p>Brady does have chance to pass Manning on the career touchdowns passing list, including playoffs. Manning has 579, only three more than Brady.</p><p>On the other end of the quarterback matchup spectrum Sunday, the Buffalo Bills and New York Jets will feature a battle of the backups rather than far more intriguing AFC East showdown of two rookie first-round picks.</p><p>Matt Barkley is starting in place of Buffalo&#8217;s Josh Allen, who will miss his fourth straight game with a sprained throwing elbow. For New York, Josh McCown is starting in place Sam Darnold, who is sidelined by a strained right foot. Darnold was drafted third overall, four spots ahead of Allen.</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','The Latest: Rivers extends season-long roll against Raiders');return false;"><span class="op-btn">Read More</span> <span class="count">2576 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fthe-latest-rivers-extends-season-long-roll-against-raiders%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=The Latest: Rivers extends season-long roll against Raiders+http://nfp.news/yoj" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=The Latest: Rivers extends season-long roll against Raiders&#32;&#32;http://nfp.news/yoj" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yoj"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/bowles-sinking-jets-bottom-out-with-41-10-loss-to-bills/" rel="bookmark" title="Bowles&#8217; sinking Jets bottom out with 41-10 loss to Bills">Bowles&#8217; sinking Jets bottom out with 41-10 loss to Bills</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/bowles-sinking-jets-bottom-out-with-41-10-loss-to-bills/"/><meta itemprop="datePublished" content="46 mins ago"/><meta itemprop="dateModified" content="46 mins ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>EAST RUTHERFORD, N.J. (AP) — The locker room was eerily quiet as New York Jets players got dressed, packed their bags and headed for the exits.</p> <p>Their 41-10 loss to the Buffalo Bills on Sunday was as ugly as it gets. And it further cast doubts on the future of coach Todd Bowles.</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>EAST RUTHERFORD, N.J. (AP) &mdash; The locker room was eerily quiet as New York Jets players got dressed, packed their bags and headed for the exits.</p><p>Their 41-10 loss to the Buffalo Bills on Sunday was as ugly as it gets. And it further cast doubts on the future of coach Todd Bowles.</p><p>&#8220;Everything that could&#8217;ve gone wrong,&#8221; Bowles said, &#8220;went wrong.&#8221;</p><p>The hot seat under Bowles reached a boiling point as the Jets (3-7) got completely manhandled by a Bills team that was led by Matt Barkley , who hadn&#8217;t started in nearly two years, and entered with a league-low 96 points and had two touchdowns in its previous four games.</p><p>New York has now lost four in a row heading into its bye-week break. Whether Bowles will still be in charge when the Jets play again on Nov. 25 against New England seems immediately uncertain. But the coach spoke like a man approaching things like business as usual.</p><p>&#8220;We&#8217;re going to take a long, hard look at everything this week, coaches and players,&#8221; Bowles said. &#8220;We&#8217;re going to try like hell to win our last six games.&#8221;</p><p>This loss, and the way it went down, could give owner Christopher Johnson pause when evaluating the future. It has seemed like a forgone conclusion to many that Bowles would not be back after the season. This latest loss, though, had many wondering if the coach will be back after Sunday.</p><p>Johnson declined comment to reporters after the game when asked if he was considering a change.</p><p>Many of the players insisted that the struggles can be attributed to lots of people, not just Bowles.</p><p>&#8220;T-Bowles is not the problem,&#8221; safety Jamal Adams said. &#8220;I&#8217;m going to ride with T-Bowles until the end. I don&#8217;t care what the fans say. It&#8217;s T-Bowles. I&#8217;m going to support my coach through thick and thin.&#8221;</p><p>Well, consider this the thinnest of thin.</p><p>New York started 39-year-old Josh McCown in place of injured rookie Sam Darnold, but he couldn&#8217;t prevent a brutal loss in front of a frustrated fan base that booed lustily throughout.</p><p>McCown was 17 of 34 for 135 yards with two interceptions, and the Jets finished with just 199 total yards.</p><p>&#8220;That&#8217;s the first time I felt like somebody really smacked us,&#8221; cornerback Morris Claiborne said, &#8220;and we didn&#8217;t do nothing about it.&#8221;</p><p>Barkley sparked Buffalo&#8217;s bumbling offense with two touchdown passes, including one to offensive tackle Dion Dawkins, LeSean McCoy broke out of a season-long slump with 113 yards rushing and a pair of TD runs, and the Bills (3-7) were in control before many fans had settled into their seats.</p><p>On Barkley&#8217;s first play, he launched a 47-yard pass to Robert Foster. On the next play, Barkley handed off to LeSean McCoy, who scored his first touchdown of the season with a 28-yard run that gave Buffalo a 7-0 lead 49 seconds in.</p><p>&#8220;Honestly, we didn&#8217;t expect to come out there like that,&#8221; Adams said. &#8220;We didn&#8217;t expect this game to go like that. We didn&#8217;t come out there and execute.&#8221;</p><p>Barkley and the Bills took a 14-0 lead midway through the opening quarter on a fluky play. On third-and-7 from the 11, Zay Jones caught a pass and took it 10 yards before fumbling as he reached for the goal line. Tight end Jason Croom recovered in the end zone for a touchdown that was upheld by video review.</p><p>The 14-play, 73-play drive was prolonged by a fake punt on fourth-and-6 from the Bills 47 when the ball was snapped directly to tight end Logan Thomas, a quarterback at Virginia Tech. Thomas then completed a 19-yard pass to Foster for the first down.</p><p>&#8220;I don&#8217;t feel like anybody quit,&#8221; Claiborne said. &#8220;I just feel like the way the game went, it was their day coaching and their day playing.&#8221;</p><p>Perhaps the biggest sign of that came midway through the second quarter when Dawkins lined up as an eligible receiver on first-and-goal from the 7. Barkley, of course, found the 6-foot-5, 320-pound lineman wide open for a touchdown.</p><p>&#8220;We got our (butts) kicked,&#8221; Adams said. &#8220;It&#8217;s as simple as that.&#8221;</p><p>The boos from the frustrated fans at MetLife Stadium got louder at that point, and eventually turned into chants of &#8220;Bye Bye Todd!&#8221;</p><p>Claiborne said he didn&#8217;t hear those, but insisted he is standing by his coach.</p><p>&#8220;I have Todd&#8217;s back, 100 percent,&#8221; Claiborne said. &#8220;He&#8217;s a guy who definitely knows football, knows what he&#8217;s talking about and knows how to coach his players. &#8230; I have nothing but love for him. Where we&#8217;re at is where we&#8217;re at right now. We&#8217;re trying to win with who we&#8217;ve got right now, period, point blank.&#8221;</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Bowles&#8217; sinking Jets bottom out with 41-10 loss to Bills');return false;"><span class="op-btn">Read More</span> <span class="count">722 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fbowles-sinking-jets-bottom-out-with-41-10-loss-to-bills%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Bowles’ sinking Jets bottom out with 41-10 loss to Bills+http://nfp.news/yoi" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Bowles&#8217; sinking Jets bottom out with 41-10 loss to Bills&#32;&#32;http://nfp.news/yoi" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yoi"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/lions-secondary-unable-to-stop-trubisky-in-loss-to-bears/" rel="bookmark" title="Lions&#8217; secondary unable to stop Trubisky in loss to Bears">Lions&#8217; secondary unable to stop Trubisky in loss to Bears</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/lions-secondary-unable-to-stop-trubisky-in-loss-to-bears/"/><meta itemprop="datePublished" content="1 hour ago"/><meta itemprop="dateModified" content="1 hour ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>CHICAGO (AP) — Glover Quin had a chance to stop Anthony Miller. He ended up on the ground on the sideline, watching as Miller sped toward the end zone.</p> <p>It was that kind of day for Detroit's secondary.</p> <p>Playing without injured cornerback Darius Slay, the Lions were picked apart by Mitchell Trubisky in</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>CHICAGO (AP) &mdash; Glover Quin had a chance to stop Anthony Miller. He ended up on the ground on the sideline, watching as Miller sped toward the end zone.</p><p>It was that kind of day for Detroit&#8217;s secondary.</p><p>Playing without injured cornerback Darius Slay, the Lions were picked apart by Mitchell Trubisky in a 34-22 loss to the Chicago Bears on Sunday. Quin, DeShawn Shead and Nevin Lawson each had costly missed tackles, and coverage issues created large swatches of open green grass for Allen Robinson and the rest of Chicago&#8217;s receivers.</p><p>&#8220;It is on us,&#8221; Quin said. &#8220;We have to turn it around. At the end of the day, we&#8217;re the ones out there playing. We have to get it fixed.&#8221;</p><p>Detroit (3-6) had played well against the pass in its first year under coach Matt Patricia, who was New England&#8217;s defensive coordinator for six seasons before taking over the Lions in February. But the secondary issues for the Lions in their third consecutive loss looked more like their old teams than anything from Patricia&#8217;s time with the Patriots.</p><p>&#8220;Ran into each other on one particular big play. We had a communication thing on another one,&#8221; Patricia said. &#8220;But look, in the end, I just got to do a better job coaching it up and getting them in the right positions and we got to go out and execute.&#8221;</p><p>The trouble began on the first drive of the game. Shead was unable to bring down Robinson on a slant, and he ran all the way down to the Detroit 3 for a 35-yard play. Tarik Cohen carried the ball in for the Bears (6-3) on the next play.</p><p>Shead got the start in place of Slay, who was sidelined for the first time this season because of a knee injury.</p><p>&#8220;Look, we&#8217;re going to play with whoever&#8217;s healthy and whoever&#8217;s ready to go,&#8221; Patricia said. &#8220;So, for us, if you&#8217;re out on the field you got to perform. You got to go out and execute. So obviously we didn&#8217;t do a good job early on with our execution in the back end.&#8221;</p><p>The 29-year-old Shead had more trouble in the final minute of the first quarter. Chicago was facing third-and-15 at the Detroit 36 when Shead was beaten by Robinson at the line. He caught up, but couldn&#8217;t find the ball as Robinson adjusted to make the catch in the end zone.</p><p>It was more of the same in the second quarter. Miller was wide open on a reception on the right side of the field. Quin came over and tried to bring him down near the 20, but Miller ran through his tackle attempt for a 45-yard touchdown that made it 19-0 with 11:24 left in the first half.</p><p>&#8220;We just have to execute better,&#8221; Shead said. &#8220;Just go in, look at the tape and just see, I mean the little things, the little mistakes. I know &#8230; one play was miscommunication on my part on the back end. Just being on the same page and just jelling together and executing.&#8221;</p><p>Chicago led 26-7 at halftime. Trubisky was 14 for 16 for 209 yards at the break with a perfect passer rating of 158.3.</p><p>The Lions&#8217; chances for a comeback took a hit when Robinson ran out of Lawson&#8217;s tackle attempt for a 26-yard TD reception in the third quarter.</p><p>Detroit began the weekend ranked fourth in the NFL with just 214.6 yards passing allowed per game. But Trubisky finished with a career-high 355 yards through the air, and Robinson and Miller each went over 100 yards receiving.</p><p>&#8220;There&#8217;s a combination of a lot of fundamentals right now that need to be better across the board,&#8221; Patricia said. &#8220;Tackling is one of them, but there&#8217;s certainly, obviously, a bunch of things we need to work on.&#8221;</p><p>___</p><p>Jay Cohen can be reached at https://twitter.com/jcohenap</p><p>___</p><p>More AP NFL: https://apnews.com/tag/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Lions&#8217; secondary unable to stop Trubisky in loss to Bears');return false;"><span class="op-btn">Read More</span> <span class="count">589 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Flions-secondary-unable-to-stop-trubisky-in-loss-to-bears%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Lions’ secondary unable to stop Trubisky in loss to Bears+http://nfp.news/yoh" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Lions&#8217; secondary unable to stop Trubisky in loss to Bears&#32;&#32;http://nfp.news/yoh" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yoh"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/bengals-give-up-500-yards-again-get-crushed-by-saints-51-14/" rel="bookmark" title="Bengals give up 500 yards again, get crushed by Saints 51-14">Bengals give up 500 yards again, get crushed by Saints 51-14</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/bengals-give-up-500-yards-again-get-crushed-by-saints-51-14/"/><meta itemprop="datePublished" content="1 hour ago"/><meta itemprop="dateModified" content="1 hour ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>CINCINNATI (AP) — Broken coverage by broken coverage, missed tackle by missed tackle, yard by yard, the Bengals made history for horrific defense. Cincinnati keeps giving up big numbers, and now the losses are mounting, too.</p> <p>Drew Brees threw for three touchdowns, and the New Orleans Saints scored on every possession except the</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>CINCINNATI (AP) &mdash; Broken coverage by broken coverage, missed tackle by missed tackle, yard by yard, the Bengals made history for horrific defense. Cincinnati keeps giving up big numbers, and now the losses are mounting, too.</p><p>Drew Brees threw for three touchdowns, and the New Orleans Saints scored on every possession except the last one &mdash; when they took a knee &mdash; during a 51-14 victory on Sunday that left Cincinnati in disarray.</p><p>The Bengals (5-4) have given up 500 yards in three straight games &mdash; a first in the Super Bowl era &mdash; and are on pace to give up an NFL record for yards in a season. Of all the bad showings on defense, this was the worst.</p><p>The Saints (8-1) moved the ball even when they were trying to run out the clock. What little was left of the crowd of 52,492 booed loudly when it ended with New Orleans taking a knee three consecutive plays &mdash; technically, Cincinnati&#8217;s only defensive stop of the day.</p><p>&#8220;I haven&#8217;t seen anything like it,&#8221; linebacker Preston Brown said. &#8220;Every week we&#8217;re giving up too many yards.&#8221;</p><p>The Bengals knew they&#8217;d be in for some growing pains when they decided to field the youngest team in coach Marvin Lewis&#8217; 16 seasons, with most of the inexperience on defense. They also brought in coordinator Teryl Austin, who changed some of their schemes.</p><p>It&#8217;s not working, and the Bengals seem to have run out of ideas for what to do next.</p><p>&#8220;Obviously, your confidence gets shaken,&#8221; Lewis said. &#8220;I just addressed that with them. They have to focus and get determined. It&#8217;s their job to do it right.&#8221;</p><p>Shaken, and deeply disturbed.</p><p>&#8220;I&#8217;m kind of in shock after a loss like that,&#8221; linebacker Jordan Evans said.</p><p>In the last four games, the Bengals have given up 481, 551, 576 and 509 yards. They&#8217;re allowing an average of 454 yards per game, worst in the league.</p><p>They&#8217;re on pace to allow 7,272 yards, which would be an NFL record. The 2012 Saints are the only team to give up 7,000 in a season, 7,042 in 2012.</p><p>The Bengals opened the season 4-1 despite giving up a lot of yards. Four defensive touchdowns played major roles in the fast start, and the offense managed to keep up and pull out two wins at the end. With A.J. Green out indefinitely because of a toe injury, the offense is limited.</p><p>&#8220;We always want to score, but at the end of the day, our defense has got to get some stops,&#8221; receiver Tyler Boyd said. &#8220;You can&#8217;t let the other team score on every drive.&#8221;</p><p>That&#8217;s what the Saints did.</p><p>Brees led the Saints to touchdowns on all five first-half possessions with a nearly perfect performance &mdash; only two incompletions. His 17-yard TD to Michael Thomas with 2 seconds left in the half gave him 509 career touchdown passes, one more than Brett Favre for second on the career list. Peyton Manning holds the record with 539.</p><p>Brees had his way with the Bengals&#8217; historically bad defense , even diving over the pile to score a 1-yard touchdown.</p><p>The Bengals matched the most lopsided defeat in franchise history and gave up the second-most points in club history. In the first half alone, the Saints piled up 311 yards and had 21 first downs on 40 plays. The 28 points allowed in the second quarter matched the club record.</p><p>Even more shocking: Cincinnati was coming out of a bye and had two weeks to prepare for the Saints. The Bengals thought they&#8217;d get some of their issues resolved.</p><p>&#8220;It didn&#8217;t look like it,&#8221; Brown said. &#8220;We gave up 500 yards.&#8221;</p><p>___</p><p>More AP NFL: https://apnews.com/tag/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Bengals give up 500 yards again, get crushed by Saints 51-14');return false;"><span class="op-btn">Read More</span> <span class="count">538 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fbengals-give-up-500-yards-again-get-crushed-by-saints-51-14%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Bengals give up 500 yards again, get crushed by Saints 51-14+http://nfp.news/yog" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Bengals give up 500 yards again, get crushed by Saints 51-14&#32;&#32;http://nfp.news/yog" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yog"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/the-latest-packers-rb-jones-tops-100-yards-in-1st-half/" rel="bookmark" title="The Latest: Packers&#8217; RB Jones tops 100 yards in 1st half">The Latest: Packers&#8217; RB Jones tops 100 yards in 1st half</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/the-latest-packers-rb-jones-tops-100-yards-in-1st-half/"/><meta itemprop="datePublished" content="2 hours ago"/><meta itemprop="dateModified" content="2 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>The Latest on Week 10 in the NFL (all times EST):</p> <p>6:05 p.m.</p> <p>Green Bay running back Aaron Jones has 101 yards and a touchdown on eight carries at halftime with the Packers leading the Miami Dolphins 14-9.</p> <p>It's the first time that a Green Bay running back has gone over the 100-yard</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>The Latest on Week 10 in the NFL (all times EST):</p><p>6:05 p.m.</p><p>Green Bay running back Aaron Jones has 101 yards and a touchdown on eight carries at halftime with the Packers leading the Miami Dolphins 14-9.</p><p>It&#8217;s the first time that a Green Bay running back has gone over the 100-yard mark this season. Aaron Rodgers also has a touchdown pass to Davante Adams.</p><p>The Dolphins have been moving the ball in spite of missing three starting offensive linemen. But they turned the ball over a bad shotgun snap on their first series, and have been held to three field goals.</p><p>___</p><p>5:50 p.m.</p><p>Los Angeles Rams running back Todd Gurley has become the fourth NFL player to score a touchdown in each of his team&#8217;s first 10 games of a season.</p><p>Gurley scored on a 17-yard run to put the Ram up 17-14 with under three minutes left in the second quarter against Seattle. His 10-game streak matches former Rams player Elroy &#8216;Crazylegs&#8217; Hirsch, who did it in 1951.</p><p>Baltimore&#8217;s Lenny Moore, in 1951, and Buffalo&#8217;s O.J. Simpson, in 1975, share the record in having scored in each of their teams&#8217; first 14 games of the season.</p><p>The touchdown was Gurley&#8217;s league-leading 17th of the season. And he&#8217;s scored in 13 consecutive regular-season games since being held out of the end zone in a 32-16 win at Arizona last Dec. 3.</p><p>___</p><p>5:35 p.m.</p><p>Los Angeles Rams defensive end Aaron Donald set a career-high with his 12th sack of the season and second of the game against Seattle&#8217;s Russell Wilson.</p><p>Donald entered the day second on the NFL list with 10 sacks this season, 11 1/2 behind Minnesota&#8217;s Danielle Hunter.</p><p>The fifth-year player passed his previous high of 11 sacks set in both 2015 and last season, and increased his career total to 61.</p><p>___</p><p>5:15 p.m.</p><p>Miami Dolphins running back Frank Gore has topped 500 yards rushing for a 14th consecutive season to set an NFL record.</p><p>Gore entered the game against Green Bay tied with Hall of Famers Emmitt Smith and Walter Payton, who had topped 500 yards in 13 straight seasons. Gore topped the milestone with a 9-yard run with about 3 1/2 minutes left in the first quarter.</p><p>The 14-year veteran ranks fourth and leads active players with 14,464 yards rushing.</p><p>Green Bay leads Miami 14-6 early in the second quarter. For the Packers, running back Aaron Jones has 96 yards on four carries, including a career-long 67-yarder.</p><p>___</p><p>5 p.m.</p><p>Arizona Cardinals receiver Larry Fitzgerald has passed Hall of Famer Terrell Owens to move into second place on the career yards-receiving list.</p><p>The 15th-year player had six catches for 50 yards to up his total to 15,952 &mdash; moving 18 ahead of Owens &mdash; in a 26-14 loss at Kansas City.</p><p>Jerry Rice holds the record with 22,895 yards.</p><p>___</p><p>4:50 p.m.</p><p>The Los Angeles Rams held a moment of silence before their game against Seattle for the 12 victims of the mass shooting in Thousand Oaks last week.</p><p>The Rams&#8217; training complex in less than five miles from the Borderline Bar and Grill. The team is donating proceeds from its stadium raffle and a jersey auction to a relief effort, and left tackle Andrew Whitworth has pledged his game check.</p><p>___</p><p>4:45 p.m.</p><p>The Green Bay Packers have cashed in on a turnover on the Miami Dolphins&#8217; game-opening drive.</p><p>Aaron Rodgers hit Davante Adams for a 7-yard touchdown pass with 6:07 left in the first quarter to give Green Bay a 7-0 lead. Running back Aaron Jones accounted for 54 total yards on the drive. The Packers capitalized after Dolphins&#8217; quarterback Brock Osweiler mishandled a shotgun snap that was recovered by Reggie Gilbert at the Green Bay 30.</p><p>___</p><p>4:20 p.m.</p><p>The Tampa Bay Buccaneers had very little to show for gaining 501 yards offense in a 16-3 loss to Washington.</p><p>The Buccaneers became just the second team since 1940 to top 400 yards and score 3 or fewer points, according to Pro Football Reference. They join the then-St. Louis Rams, who had 424 yards offense in a 24-3 loss to Green Bay in 2011.</p><p>Four turnovers, including two interceptions thrown by Ryan Fitzpatrick, didn&#8217;t help. Neither did kicker Chandler Catanzaro missing field-goal attempts from 30 and 48 yards, both wide right.</p><p>___</p><p>3:50 p.m.</p><p>The New England Patriots have pulled quarterback Tom Brady while trailing the Titans 34-10 in the fourth quarter.</p><p>The Titans sacked Brady a season-high three times, and former New England cornerback Logan Ryan broke up a Brady pass to Julian Edelman on fourth down with 10:48 left to end a Patriots&#8217; scoring threat.</p><p>Edelman went to the locker room after that pass was broken up. He is questionable to return with an injured ankle.</p><p>Brian Hoyer replaced Brady after Derrick Henry&#8217;s 10-yard run out of the wildcat put the Titans up 34-10 with 7:13 left.</p><p>The Patriots also were playing without left tackle Trent Brown, who left in the third quarter with an injured back. Tight end Dwayne Allen is questionable to return with an injured knee.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>3:10 p.m.</p><p>Buffalo Bills running back LeSean McCoy has plenty to talk about now while enjoying his best game of the season.</p><p>Three quarters into Buffalo&#8217;s game at the New York Jets, McCoy has already topped 100 yards rushing for the first time since gaining 156 on a snow-covered field in a 13-7 overtime win over Indianapolis on Dec. 10.</p><p>He has also scored two touchdowns rushing for the first time since scoring twice in a 30-27 win over Tampa Bay on Oct. 22, 2017.</p><p>The touchdowns were the first of the season for McCoy. And the come two days after the 10th-year player broke nearly two weeks of silence by telling reporters he was frustrated with his lack of production.</p><p>McCoy entered the game with 267 yards rushing this season, and had 103 midway through the third quarter.</p><p>McCoy also surpassed 500 career points, and vaulted into 26th place on the career yards rushing list by moving ahead of Marshawn Lynch (10,379), Eddie George (10,441) and Tiki Barber (10,449).</p><p>___</p><p>2:50 p.m.</p><p>Cleveland Browns rookie Nick Chubb broke a club record and maybe Atlanta&#8217;s back with a 92-yard TD run.</p><p>The running back took a handoff at Cleveland&#8217;s 8, cut right and avoided a few tacklers before streaking to the end zone to give Cleveland a 28-10 lead midway through the third quarter.</p><p>Chubb&#8217;s 92-yard run is the longest in team history, topping the 90-yard run by Bobby Mitchell in 1959 against Washington.</p><p>It was Chubb&#8217;s second touchdown of the game. He also caught a 13-yard pass from Baker Mayfield in the second quarter.</p><p>___</p><p>2:45 p.m.</p><p>The Tennessee Titans are following up their big win in Dallas with a strong first half against the Patriots.</p><p>Tennessee scored a season-high 28 points to beat the Cowboys on Monday night, and they now lead New England 24-10 at halftime.</p><p>The Titans scored a season-high 17 points in the first quarter with touchdown passes by Marcus Mariota on each of their first two possessions. Mariota is 11 of 16 for 152 yards.</p><p>The Titans have been getting plenty of pressure on Tom Brady. Former Patriots cornerback Logan Ryan sacked Brady on the final play of the first half, the Titans&#8217; second sack of the first half.</p><p>James Develin has run for a TD, and Stephen Gostkowski connected on one of his two 52-yard field goal attempt for New England.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>___</p><p>2:40 p.m.</p><p>Rams left tackle Andrew Whitworth is donating a game check to the families of the victims of the mass shooting in Thousand Oaks.</p><p>Whitworth will give his check from Los Angeles&#8217; game against Seattle to the Ventura County Community Foundation&#8217;s Conejo Valley Victims Fund. The fund was set up to help the families of the 12 people killed by a gunman in Thousand Oaks, the home of the Rams&#8217; training complex.</p><p>Whitworth is in the second season of a three-year, $36 million deal with the Rams. He has played a major role in the Rams&#8217; transformation into an elite NFC team under Sean McVay.</p><p>Whitworth, Todd Gurley, Jared Goff, Michael Brockers and other players are also auctioning off their game jerseys to benefit the victims&#8217; fund and American Red Cross Southern California Wildfire Relief.</p><p>Two wildfires are also burning in the same general area of the western Los Angeles suburbs.</p><p>2:30 p.m.</p><p>New Orleans Saints quarterback Drew Brees has moved ahead of Brett Favre for second place on the career regular-season touchdown list with a sensational first half at Cincinnati.</p><p>He&#8217;s thrown three TD passes as the Saints have raced ahead 35-7, reaching the end zone on all five possessions. Brees has 509 career TD passes, one more than Favre.</p><p>Peyton Manning holds the record with 539.</p><p>The Saints have piled up 311 yards, and they have 21 first downs on 40 plays. Brees is 18 of 20 for 214 yards.</p><p>___</p><p>2:15 p.m.</p><p>Baker Mayfield enjoyed a perfect half.</p><p>Cleveland&#8217;s rookie quarterback completed 12 of 12 passes for 165 yards and two touchdowns in the first half against Atlanta. Mayfield connected on a 28-yard TD with Rashard Higgins and threw a 13-yard scoring pass to Nick Chubb.</p><p>Mayfield finished the half with a 158.3 quarterback rating, the highest possible score. The Browns did have one interception in the half, but it was thrown by running back Dontrell Hilliard, who attempted to hit a well-covered Mayfield on a trick play.</p><p>___</p><p>2:10 p.m.</p><p>Patrick Mahomes has broken the Kansas City Chiefs record for touchdown passes in a season.</p><p>The first-year starter threw his 31st of the season &mdash; and second of the game to Tyreek Hill &mdash; to pass Len Dawson. The Hall of Famer threw 30 in 1964.</p><p>The record-setter came on third-and-goal from the Arizona 14. Hill celebrated by leaping into the stands, just as he did on his first TD catch, then playing with the TV cameras.</p><p>That last bit earned Hill an unsportsmanlike conduct penalty.</p><p>&mdash; Dave Skretta reporting from Kansas City</p><p>___</p><p>2 p.m.</p><p>Atlanta receiver Julio Jones has reached 10,000 yards receiving faster than any player in NFL history.</p><p>Jones reached the plateau in his 104th career game, catching a 30-yard pass in the second quarter from Matt Ryan. Calvin Johnson held the previous mark, getting to 10,000 yards in his 115th game. Torry Holt and Antonio Brown got there in 116 games.</p><p>Jones caught a short pass over the middle and broke a couple tackles on his first reception of the game. He came in with 933 yards receiving this season.</p><p>Moments later, Jones caught a 1-yard TD pass from Ryan to give the Falcons a 10-7 lead.</p><p>___</p><p>1:50 p.m.</p><p>The Buffalo Bills have scored twice in the first quarter against the New York Jets to match their combined total from their previous four games.</p><p>LeSean McCoy opened the scoring with a 28-yard run, 5 more than he totaled in his previous two games. And then tight end Jason Croom recovered teammate Zay Jones&#8217; fumble in the end zone to put the Bills ahead 14-0.</p><p>Buffalo&#8217;s 14 points are the most they&#8217;ve scored in seven games, since a 27-6 victory at Minnesota on Sept. 23. And the Bills are doing this with Matt Barkley making his debut at quarterback less than two weeks after signing with Buffalo.</p><p>___</p><p>1:40 p.m.</p><p>New Orleans quarterback Drew Brees has thrown two touchdown passes against Cincinnati to up his regular-season total to 508 and match Brett Favre for second on the NFL career list.</p><p>Brees first TD was a 7-yarder to Michael Thomas midway through the first quarter. Mark Ingram II then turned a screen pass into a 28-yard touchdown</p><p>Peyton Manning holds the record with 539.</p><p>___</p><p>1:25 p.m.</p><p>Six teams reached the end zone on the opening possession of their games Sunday to get Week 10 off to a high-scoring start.</p><p>Kansas City, which lost the coin toss for the first time all season, went 75 yards in 56 seconds. Three plays were needed, with Patrick Mahomes connecting with Tyreek Hill for 38 yards, then for a 37-yard touchdown.</p><p>Tennessee&#8217;s Darius Jennings returned the opening kickoff 58 yards, then the Titans needed seven plays to go 40 yards, capped by Marcus Mariota 4-yard TD pass to Jonnu Smith against New England.</p><p>Chicago&#8217;s Tarik Cohen had a 3-yard TD run to cap an eight-play, 75-yard drive vs. Detroit. But Cody Parkey missed the extra point.</p><p>Indianapolis covered 75 yards in seven plays and Andrew Luck found Eric Ebron for a 53-yard scoring pass against Jacksonville.</p><p>Buffalo used a mere two plays against the Jets, with newcomer Matt Barkley throwing 47 yards to Robert Foster before LeSean McCoy broke from a lengthy slump for his first touchdown this season, on a 28-yard run.</p><p>And Drew Brees threw his 507th career touchdown pass, leaving him one behind Brett Favre for second place on the career list, capping a 15-play, 75-yard drive that consumed 8 minutes, 30 seconds. It ended with Michael Thomas&#8217; diving 7-yard catch.</p><p>___</p><p>1:15 p.m.</p><p>Chiefs quarterback Patrick Mahomes needed only 56 seconds to throw his first touchdown pass against Arizona, moving him into a tie with Hall of Famer Len Dawson for the single-season franchise record.</p><p>Mahomes hit Tyreek Hill down the sideline for 38 yards on the game&#8217;s first play. Then, after an incompletion, Mahomes found Hill again for a 37-yard touchdown reception.</p><p>It was the 30th thrown by Mahomes this season. Dawson threw 30 during the 1964 season.</p><p>&mdash; Dave Skretta reporting from Kansas City.</p><p>___</p><p>1:10 p.m.</p><p>The Indianapolis Colts honored kicker Adam Vinatieri, the NFL&#8217;s new career scoring leader, with a brief highlight show during pregame introduction before their game against Jacksonville.</p><p>Vinatieri received a roaring ovation from the Lucas Oil Stadium crowd when he was announced as the final starter. The 45-year-old waved to the crowd and slapped hands with a group of fans gathered around the American flag on the field.</p><p>Vinatieri broke Morten Andersen&#8217;s record two weeks ago at Oakland, but the Colts had a bye last week and Sunday marked the first time Indy could celebrate the record-breaking moment on its home turf.</p><p>___</p><p>1 p.m.</p><p>Three-time Pro Bowl defensive lineman Jurrell Casey was the last of the Titans defense introduced before kickoff for Tennessee&#8217;s game against New England.</p><p>Casey took the field carrying an American flag, and first shaking hands with a soldier as part of the NFL&#8217;s Salute to Service being held on Veteran&#8217;s Day. A soldier accompanied each Titans starter onto the field for a few steps.</p><p>Country artist Little Big Town performed the national anthem, which featured a flyover by military helicopters.</p><p>___</p><p>11:30 a.m.</p><p>Drew Brees and Tom Brady enter Week 10 of the NFL&#8217;s schedule neck and neck in closing in on matching Brett Favre for second place on the career regular-season list.</p><p>Brees has 506 touchdowns passing, two behind Favre, as the New Orleans Saints play at Cincinnati. And Brady has 505 with his New England Patriots playing at Tennessee. Both are a little more than 30 behind Peyton Manning&#8217;s record of 539.</p><p>Brady does have chance to pass Manning on the career touchdowns passing list, including playoffs. Manning has 579, only three more than Brady.</p><p>On the other end of the quarterback matchup spectrum Sunday, the Buffalo Bills and New York Jets will feature a battle of the backups rather than far more intriguing AFC East showdown of two rookie first-round picks.</p><p>Matt Barkley is starting in place of Buffalo&#8217;s Josh Allen, who will miss his fourth straight game with a sprained throwing elbow. For New York, Josh McCown is starting in place Sam Darnold, who is sidelined by a strained right foot. Darnold was drafted third overall, four spots ahead of Allen.</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','The Latest: Packers&#8217; RB Jones tops 100 yards in 1st half');return false;"><span class="op-btn">Read More</span> <span class="count">2475 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fthe-latest-packers-rb-jones-tops-100-yards-in-1st-half%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=The Latest: Packers’ RB Jones tops 100 yards in 1st half+http://nfp.news/yof" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=The Latest: Packers&#8217; RB Jones tops 100 yards in 1st half&#32;&#32;http://nfp.news/yof" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yof"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/vrabels-titans-rout-new-england-34-10-snap-pats-streaks/" rel="bookmark" title="Vrabel&#8217;s Titans rout New England 34-10, snap Pats&#8217; streaks">Vrabel&#8217;s Titans rout New England 34-10, snap Pats&#8217; streaks</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/vrabels-titans-rout-new-england-34-10-snap-pats-streaks/"/><meta itemprop="datePublished" content="2 hours ago"/><meta itemprop="dateModified" content="2 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>NASHVILLE, Tenn. (AP) — Tom Brady added another big chunk of NFL history to his resume.</p> <p>The Tennessee Titans made sure the Patriots quarterback didn't finish his 300th game by hitting him over and over again.</p> <p>The Titans sacked Brady three times and hit him six more times as they beat New England</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>NASHVILLE, Tenn. (AP) &mdash; Tom Brady added another big chunk of NFL history to his resume.</p><p>The Tennessee Titans made sure the Patriots quarterback didn&#8217;t finish his 300th game by hitting him over and over again.</p><p>The Titans sacked Brady three times and hit him six more times as they beat New England 34-10 Sunday, snapping a seven-game skid against the Patriots in Mike Vrabel&#8217;s first game as head coach against the team he helped win three Super Bowls.</p><p>It was the most sacks allowed in a game this season by the Patriots (7-3), and coach Bill Belichick pulled Brady for Brian Hoyer midway through the fourth quarter.</p><p>&#8220;You got to make Tom blink, and if you make him blink and have to go to a second read you got a chance,&#8221; Vrabel said of his former teammate. &#8220;But if you let him rip it to the first guy he looks at, it&#8217;s going to be a long day.&#8221;</p><p>Asked if he thought Brady was effective, Belichick said to ask Brady.</p><p>&#8220;It was just a bad day for all of us,&#8221; Brady said.</p><p>Only Brett Favre (326) has played in more games, both regular season and postseason, as a quarterback than Brady. The three-time NFL MVP also needed only three touchdown passes to tie Peyton Manning (579) for the NFL record for most TD passes all time for both the regular season and postseason.</p><p>Brady left having thrown for 254 yards and no TD passes. The Titans outgained the Patriots 385-284, holding New England to just 40 yards rushing. Linebacker Wesley Woodyard, who had 1&frac12; sacks, said that allowed them to get after Brady.</p><p>&#8220;Coach Vrabel said make them pay for everything,&#8221; Woodyard said. &#8220;Tackle him, hit him and make him feel it.&#8221;</p><p>Marcus Mariota capped each of the first two drives with TD passes, and Derrick Henry ran for a pair of TDs. Ryan Succop also added two field goals as the Titans (5-4) scored a season high in points after jumping out to a 17-3 lead in the first quarter. They now have beaten both of last season&#8217;s Super Bowl teams in Nashville.</p><p>The loss snaps a six-game winning streak going into New England&#8217;s bye. The Patriots, who routed the Titans 35-14 in January, also lost to Tennessee for the first time since Dec. 16, 2002.</p><p>Darius Jennings opened the game with a 58-yard kickoff return, and Mariota capped the drive with a 4-yard TD pass to Jonnu Smith. The Titans never trailed again.</p><p>The Titans came in with the NFL&#8217;s stingiest scoring defense and also leading the league in fewest touchdowns allowed in the red zone. They held the Patriots to a pair of 52-yard field-goal attempts by Stephen Gostkowski, who missed his second wide left. James Develin scored on a 1-yard TD run early in the second, which pulled New England within 17-10.</p><p>Brady looked ready to pull off another amazing comeback, driving the Pats to the Titans 37. The Titans stopped Brady a yard shy of the first down after catching a pass from Julian Edelman. A false start followed, then Logan Ryan, a former New England cornerback, broke up a Brady pass to Edelman to turn the ball over.</p><p>On the very next play, Vrabel called his own trick play with Jennings throwing to a wide-open Mariota for a 21-yard gain.</p><p>Hoyer replaced Brady on the next drive.</p><p>EX-PATS CONNECTIONS</p><p>Tennessee fired coach Mike Mularkey after the January playoff loss and hired Vrabel to try to recreate the Patriots&#8217; winning ways with the Titans. Vrabel hired Dean Pees, a former Patriots linebackers coach and defensive coordinator, as his defensive coordinator. General manager Jon Robinson, who started in New England, signed cornerback Malcolm Butler and running back Dion Lewis in free agency.</p><p>&#8220;That&#8217;s what happens when you go cheap,&#8221; Lewis said. &#8220;You get your (expletive) kicked.&#8221;</p><p>RARE BRADY CATCH</p><p>Brady&#8217;s catch was just the third of his career and first since Dec. 6, 2015, when he caught a 36-yarder from Danny Amendola against Philadelphia. At 41, Brady became the oldest player with a catch since Jerry Rice had 30 at the age of 42. Brady slipped at the end and said he didn&#8217;t know what happened.</p><p>&#8220;It was &#8216;fish out of water,'&#8221; Brady said.</p><p>Mariota also has three receptions, including catching his own pass in the playoffs last January. Vrabel said Mariota got up faster than Brady did. Mariota said he had one thought on his reception: &#8220;Just catch it.&#8221;</p><p>INJURIES</p><p>Patriots left tackle Trent Brown missed the final drive of the first half and was announced as questionable to return because of illness. LaAdrian Waddle replaced him for that series, but Brown returned for the first start of the third quarter. Brown left later in the third quarter with an injured back. Edelman hurt an ankle and didn&#8217;t return. Tight end Dwayne Allen also hurt a knee in the third quarter.</p><p>Titans running back David Fluellen picked up 16 yards on back-to-back runs, then went down untouched on the next play with a knee injury.</p><p>UP NEXT</p><p>Patriots: Bye, then visit Jets on Nov. 25.</p><p>Titans: Visit Indianapolis.</p><p>___</p><p>Follow Teresa M. Walker at www.twitter.com/teresamwalker</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Vrabel&#8217;s Titans rout New England 34-10, snap Pats&#8217; streaks');return false;"><span class="op-btn">Read More</span> <span class="count">801 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fvrabels-titans-rout-new-england-34-10-snap-pats-streaks%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Vrabel’s Titans rout New England 34-10, snap Pats’ streaks+http://nfp.news/yoe" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Vrabel&#8217;s Titans rout New England 34-10, snap Pats&#8217; streaks&#32;&#32;http://nfp.news/yoe" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yoe"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/the-latest-rams-todd-gurley-scores-in-10th-straight-game/" rel="bookmark" title="The Latest: Rams&#8217; Todd Gurley scores in 10th straight game">The Latest: Rams&#8217; Todd Gurley scores in 10th straight game</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/the-latest-rams-todd-gurley-scores-in-10th-straight-game/"/><meta itemprop="datePublished" content="2 hours ago"/><meta itemprop="dateModified" content="2 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>The Latest on Week 10 in the NFL (all times EST):</p> <p>5:50 p.m.</p> <p>Los Angeles Rams running back Todd Gurley has become the fourth NFL player to score a touchdown in each of his team's first 10 games of a season.</p> <p>Gurley scored on a 17-yard run to put the Ram up 17-14</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>The Latest on Week 10 in the NFL (all times EST):</p><p>5:50 p.m.</p><p>Los Angeles Rams running back Todd Gurley has become the fourth NFL player to score a touchdown in each of his team&#8217;s first 10 games of a season.</p><p>Gurley scored on a 17-yard run to put the Ram up 17-14 with under three minutes left in the second quarter against Seattle. His 10-game streak matches former Rams player Elroy &#8216;Crazylegs&#8217; Hirsch, who did it in 1951.</p><p>Baltimore&#8217;s Lenny Moore, in 1951, and Buffalo&#8217;s O.J. Simpson, in 1975, share the record in having scored in each of their teams&#8217; first 14 games of the season.</p><p>The touchdown was Gurley&#8217;s league-leading 17th of the season. And he&#8217;s scored in 13 consecutive regular-season games since being held out of the end zone in a 32-16 win at Arizona last Dec. 3.</p><p>___</p><p>5:35 p.m.</p><p>Los Angeles Rams defensive end Aaron Donald set a career-high with his 12th sack of the season and second of the game against Seattle&#8217;s Russell Wilson.</p><p>Donald entered the day second on the NFL list with 10 sacks this season, 11 1/2 behind Minnesota&#8217;s Danielle Hunter.</p><p>The fifth-year player passed his previous high of 11 sacks set in both 2015 and last season, and increased his career total to 61.</p><p>___</p><p>5:15 p.m.</p><p>Miami Dolphins running back Frank Gore has topped 500 yards rushing for a 14th consecutive season to set an NFL record.</p><p>Gore entered the game against Green Bay tied with Hall of Famers Emmitt Smith and Walter Payton, who had topped 500 yards in 13 straight seasons. Gore topped the milestone with a 9-yard run with about 3 1/2 minutes left in the first quarter.</p><p>The 14-year veteran ranks fourth and leads active players with 14,464 yards rushing.</p><p>Green Bay leads Miami 14-6 early in the second quarter. For the Packers, running back Aaron Jones has 96 yards on four carries, including a career-long 67-yarder.</p><p>___</p><p>5 p.m.</p><p>Arizona Cardinals receiver Larry Fitzgerald has passed Hall of Famer Terrell Owens to move into second place on the career yards-receiving list.</p><p>The 15th-year player had six catches for 50 yards to up his total to 15,952 &mdash; moving 18 ahead of Owens &mdash; in a 26-14 loss at Kansas City.</p><p>Jerry Rice holds the record with 22,895 yards.</p><p>___</p><p>4:50 p.m.</p><p>The Los Angeles Rams held a moment of silence before their game against Seattle for the 12 victims of the mass shooting in Thousand Oaks last week.</p><p>The Rams&#8217; training complex in less than five miles from the Borderline Bar and Grill. The team is donating proceeds from its stadium raffle and a jersey auction to a relief effort, and left tackle Andrew Whitworth has pledged his game check.</p><p>___</p><p>4:45 p.m.</p><p>The Green Bay Packers have cashed in on a turnover on the Miami Dolphins&#8217; game-opening drive.</p><p>Aaron Rodgers hit Davante Adams for a 7-yard touchdown pass with 6:07 left in the first quarter to give Green Bay a 7-0 lead. Running back Aaron Jones accounted for 54 total yards on the drive. The Packers capitalized after Dolphins&#8217; quarterback Brock Osweiler mishandled a shotgun snap that was recovered by Reggie Gilbert at the Green Bay 30.</p><p>___</p><p>4:20 p.m.</p><p>The Tampa Bay Buccaneers had very little to show for gaining 501 yards offense in a 16-3 loss to Washington.</p><p>The Buccaneers became just the second team since 1940 to top 400 yards and score 3 or fewer points, according to Pro Football Reference. They join the then-St. Louis Rams, who had 424 yards offense in a 24-3 loss to Green Bay in 2011.</p><p>Four turnovers, including two interceptions thrown by Ryan Fitzpatrick, didn&#8217;t help. Neither did kicker Chandler Catanzaro missing field-goal attempts from 30 and 48 yards, both wide right.</p><p>___</p><p>3:50 p.m.</p><p>The New England Patriots have pulled quarterback Tom Brady while trailing the Titans 34-10 in the fourth quarter.</p><p>The Titans sacked Brady a season-high three times, and former New England cornerback Logan Ryan broke up a Brady pass to Julian Edelman on fourth down with 10:48 left to end a Patriots&#8217; scoring threat.</p><p>Edelman went to the locker room after that pass was broken up. He is questionable to return with an injured ankle.</p><p>Brian Hoyer replaced Brady after Derrick Henry&#8217;s 10-yard run out of the wildcat put the Titans up 34-10 with 7:13 left.</p><p>The Patriots also were playing without left tackle Trent Brown, who left in the third quarter with an injured back. Tight end Dwayne Allen is questionable to return with an injured knee.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>3:10 p.m.</p><p>Buffalo Bills running back LeSean McCoy has plenty to talk about now while enjoying his best game of the season.</p><p>Three quarters into Buffalo&#8217;s game at the New York Jets, McCoy has already topped 100 yards rushing for the first time since gaining 156 on a snow-covered field in a 13-7 overtime win over Indianapolis on Dec. 10.</p><p>He has also scored two touchdowns rushing for the first time since scoring twice in a 30-27 win over Tampa Bay on Oct. 22, 2017.</p><p>The touchdowns were the first of the season for McCoy. And the come two days after the 10th-year player broke nearly two weeks of silence by telling reporters he was frustrated with his lack of production.</p><p>McCoy entered the game with 267 yards rushing this season, and had 103 midway through the third quarter.</p><p>McCoy also surpassed 500 career points, and vaulted into 26th place on the career yards rushing list by moving ahead of Marshawn Lynch (10,379), Eddie George (10,441) and Tiki Barber (10,449).</p><p>___</p><p>2:50 p.m.</p><p>Cleveland Browns rookie Nick Chubb broke a club record and maybe Atlanta&#8217;s back with a 92-yard TD run.</p><p>The running back took a handoff at Cleveland&#8217;s 8, cut right and avoided a few tacklers before streaking to the end zone to give Cleveland a 28-10 lead midway through the third quarter.</p><p>Chubb&#8217;s 92-yard run is the longest in team history, topping the 90-yard run by Bobby Mitchell in 1959 against Washington.</p><p>It was Chubb&#8217;s second touchdown of the game. He also caught a 13-yard pass from Baker Mayfield in the second quarter.</p><p>___</p><p>2:45 p.m.</p><p>The Tennessee Titans are following up their big win in Dallas with a strong first half against the Patriots.</p><p>Tennessee scored a season-high 28 points to beat the Cowboys on Monday night, and they now lead New England 24-10 at halftime.</p><p>The Titans scored a season-high 17 points in the first quarter with touchdown passes by Marcus Mariota on each of their first two possessions. Mariota is 11 of 16 for 152 yards.</p><p>The Titans have been getting plenty of pressure on Tom Brady. Former Patriots cornerback Logan Ryan sacked Brady on the final play of the first half, the Titans&#8217; second sack of the first half.</p><p>James Develin has run for a TD, and Stephen Gostkowski connected on one of his two 52-yard field goal attempt for New England.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>___</p><p>2:40 p.m.</p><p>Rams left tackle Andrew Whitworth is donating a game check to the families of the victims of the mass shooting in Thousand Oaks.</p><p>Whitworth will give his check from Los Angeles&#8217; game against Seattle to the Ventura County Community Foundation&#8217;s Conejo Valley Victims Fund. The fund was set up to help the families of the 12 people killed by a gunman in Thousand Oaks, the home of the Rams&#8217; training complex.</p><p>Whitworth is in the second season of a three-year, $36 million deal with the Rams. He has played a major role in the Rams&#8217; transformation into an elite NFC team under Sean McVay.</p><p>Whitworth, Todd Gurley, Jared Goff, Michael Brockers and other players are also auctioning off their game jerseys to benefit the victims&#8217; fund and American Red Cross Southern California Wildfire Relief.</p><p>Two wildfires are also burning in the same general area of the western Los Angeles suburbs.</p><p>2:30 p.m.</p><p>New Orleans Saints quarterback Drew Brees has moved ahead of Brett Favre for second place on the career regular-season touchdown list with a sensational first half at Cincinnati.</p><p>He&#8217;s thrown three TD passes as the Saints have raced ahead 35-7, reaching the end zone on all five possessions. Brees has 509 career TD passes, one more than Favre.</p><p>Peyton Manning holds the record with 539.</p><p>The Saints have piled up 311 yards, and they have 21 first downs on 40 plays. Brees is 18 of 20 for 214 yards.</p><p>___</p><p>2:15 p.m.</p><p>Baker Mayfield enjoyed a perfect half.</p><p>Cleveland&#8217;s rookie quarterback completed 12 of 12 passes for 165 yards and two touchdowns in the first half against Atlanta. Mayfield connected on a 28-yard TD with Rashard Higgins and threw a 13-yard scoring pass to Nick Chubb.</p><p>Mayfield finished the half with a 158.3 quarterback rating, the highest possible score. The Browns did have one interception in the half, but it was thrown by running back Dontrell Hilliard, who attempted to hit a well-covered Mayfield on a trick play.</p><p>___</p><p>2:10 p.m.</p><p>Patrick Mahomes has broken the Kansas City Chiefs record for touchdown passes in a season.</p><p>The first-year starter threw his 31st of the season &mdash; and second of the game to Tyreek Hill &mdash; to pass Len Dawson. The Hall of Famer threw 30 in 1964.</p><p>The record-setter came on third-and-goal from the Arizona 14. Hill celebrated by leaping into the stands, just as he did on his first TD catch, then playing with the TV cameras.</p><p>That last bit earned Hill an unsportsmanlike conduct penalty.</p><p>&mdash; Dave Skretta reporting from Kansas City</p><p>___</p><p>2 p.m.</p><p>Atlanta receiver Julio Jones has reached 10,000 yards receiving faster than any player in NFL history.</p><p>Jones reached the plateau in his 104th career game, catching a 30-yard pass in the second quarter from Matt Ryan. Calvin Johnson held the previous mark, getting to 10,000 yards in his 115th game. Torry Holt and Antonio Brown got there in 116 games.</p><p>Jones caught a short pass over the middle and broke a couple tackles on his first reception of the game. He came in with 933 yards receiving this season.</p><p>Moments later, Jones caught a 1-yard TD pass from Ryan to give the Falcons a 10-7 lead.</p><p>___</p><p>1:50 p.m.</p><p>The Buffalo Bills have scored twice in the first quarter against the New York Jets to match their combined total from their previous four games.</p><p>LeSean McCoy opened the scoring with a 28-yard run, 5 more than he totaled in his previous two games. And then tight end Jason Croom recovered teammate Zay Jones&#8217; fumble in the end zone to put the Bills ahead 14-0.</p><p>Buffalo&#8217;s 14 points are the most they&#8217;ve scored in seven games, since a 27-6 victory at Minnesota on Sept. 23. And the Bills are doing this with Matt Barkley making his debut at quarterback less than two weeks after signing with Buffalo.</p><p>___</p><p>1:40 p.m.</p><p>New Orleans quarterback Drew Brees has thrown two touchdown passes against Cincinnati to up his regular-season total to 508 and match Brett Favre for second on the NFL career list.</p><p>Brees first TD was a 7-yarder to Michael Thomas midway through the first quarter. Mark Ingram II then turned a screen pass into a 28-yard touchdown</p><p>Peyton Manning holds the record with 539.</p><p>___</p><p>1:25 p.m.</p><p>Six teams reached the end zone on the opening possession of their games Sunday to get Week 10 off to a high-scoring start.</p><p>Kansas City, which lost the coin toss for the first time all season, went 75 yards in 56 seconds. Three plays were needed, with Patrick Mahomes connecting with Tyreek Hill for 38 yards, then for a 37-yard touchdown.</p><p>Tennessee&#8217;s Darius Jennings returned the opening kickoff 58 yards, then the Titans needed seven plays to go 40 yards, capped by Marcus Mariota 4-yard TD pass to Jonnu Smith against New England.</p><p>Chicago&#8217;s Tarik Cohen had a 3-yard TD run to cap an eight-play, 75-yard drive vs. Detroit. But Cody Parkey missed the extra point.</p><p>Indianapolis covered 75 yards in seven plays and Andrew Luck found Eric Ebron for a 53-yard scoring pass against Jacksonville.</p><p>Buffalo used a mere two plays against the Jets, with newcomer Matt Barkley throwing 47 yards to Robert Foster before LeSean McCoy broke from a lengthy slump for his first touchdown this season, on a 28-yard run.</p><p>And Drew Brees threw his 507th career touchdown pass, leaving him one behind Brett Favre for second place on the career list, capping a 15-play, 75-yard drive that consumed 8 minutes, 30 seconds. It ended with Michael Thomas&#8217; diving 7-yard catch.</p><p>___</p><p>1:15 p.m.</p><p>Chiefs quarterback Patrick Mahomes needed only 56 seconds to throw his first touchdown pass against Arizona, moving him into a tie with Hall of Famer Len Dawson for the single-season franchise record.</p><p>Mahomes hit Tyreek Hill down the sideline for 38 yards on the game&#8217;s first play. Then, after an incompletion, Mahomes found Hill again for a 37-yard touchdown reception.</p><p>It was the 30th thrown by Mahomes this season. Dawson threw 30 during the 1964 season.</p><p>&mdash; Dave Skretta reporting from Kansas City.</p><p>___</p><p>1:10 p.m.</p><p>The Indianapolis Colts honored kicker Adam Vinatieri, the NFL&#8217;s new career scoring leader, with a brief highlight show during pregame introduction before their game against Jacksonville.</p><p>Vinatieri received a roaring ovation from the Lucas Oil Stadium crowd when he was announced as the final starter. The 45-year-old waved to the crowd and slapped hands with a group of fans gathered around the American flag on the field.</p><p>Vinatieri broke Morten Andersen&#8217;s record two weeks ago at Oakland, but the Colts had a bye last week and Sunday marked the first time Indy could celebrate the record-breaking moment on its home turf.</p><p>___</p><p>1 p.m.</p><p>Three-time Pro Bowl defensive lineman Jurrell Casey was the last of the Titans defense introduced before kickoff for Tennessee&#8217;s game against New England.</p><p>Casey took the field carrying an American flag, and first shaking hands with a soldier as part of the NFL&#8217;s Salute to Service being held on Veteran&#8217;s Day. A soldier accompanied each Titans starter onto the field for a few steps.</p><p>Country artist Little Big Town performed the national anthem, which featured a flyover by military helicopters.</p><p>___</p><p>11:30 a.m.</p><p>Drew Brees and Tom Brady enter Week 10 of the NFL&#8217;s schedule neck and neck in closing in on matching Brett Favre for second place on the career regular-season list.</p><p>Brees has 506 touchdowns passing, two behind Favre, as the New Orleans Saints play at Cincinnati. And Brady has 505 with his New England Patriots playing at Tennessee. Both are a little more than 30 behind Peyton Manning&#8217;s record of 539.</p><p>Brady does have chance to pass Manning on the career touchdowns passing list, including playoffs. Manning has 579, only three more than Brady.</p><p>On the other end of the quarterback matchup spectrum Sunday, the Buffalo Bills and New York Jets will feature a battle of the backups rather than far more intriguing AFC East showdown of two rookie first-round picks.</p><p>Matt Barkley is starting in place of Buffalo&#8217;s Josh Allen, who will miss his fourth straight game with a sprained throwing elbow. For New York, Josh McCown is starting in place Sam Darnold, who is sidelined by a strained right foot. Darnold was drafted third overall, four spots ahead of Allen.</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','The Latest: Rams&#8217; Todd Gurley scores in 10th straight game');return false;"><span class="op-btn">Read More</span> <span class="count">2384 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fthe-latest-rams-todd-gurley-scores-in-10th-straight-game%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=The Latest: Rams’ Todd Gurley scores in 10th straight game+http://nfp.news/yod" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=The Latest: Rams&#8217; Todd Gurley scores in 10th straight game&#32;&#32;http://nfp.news/yod" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yod"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/the-latest-rams-aaron-donald-gets-season-best-12th-sack/" rel="bookmark" title="The Latest: Rams&#8217; Aaron Donald gets season-best 12th sack">The Latest: Rams&#8217; Aaron Donald gets season-best 12th sack</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/the-latest-rams-aaron-donald-gets-season-best-12th-sack/"/><meta itemprop="datePublished" content="2 hours ago"/><meta itemprop="dateModified" content="2 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>The Latest on Week 10 in the NFL (all times EST):</p> <p>5:35 p.m.</p> <p>Los Angeles Rams defensive end Aaron Donald set a career-high with his 12th sack of the season and second of the game against Seattle's Russell Wilson.</p> <p>Donald entered the day second on the NFL list with 10 sacks this season,</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>The Latest on Week 10 in the NFL (all times EST):</p><p>5:35 p.m.</p><p>Los Angeles Rams defensive end Aaron Donald set a career-high with his 12th sack of the season and second of the game against Seattle&#8217;s Russell Wilson.</p><p>Donald entered the day second on the NFL list with 10 sacks this season, 11 1/2 behind Minnesota&#8217;s Danielle Hunter.</p><p>The fifth-year player passed his previous high of 11 sacks set in both 2015 and last season, and increased his career total to 61.</p><p>___</p><p>5:15 p.m.</p><p>Miami Dolphins running back Frank Gore has topped 500 yards rushing for a 14th consecutive season to set an NFL record.</p><p>Gore entered the game against Green Bay tied with Hall of Famers Emmitt Smith and Walter Payton, who had topped 500 yards in 13 straight seasons. Gore topped the milestone with a 9-yard run with about 3 1/2 minutes left in the first quarter.</p><p>The 14-year veteran ranks fourth and leads active players with 14,464 yards rushing.</p><p>Green Bay leads Miami 14-6 early in the second quarter. For the Packers, running back Aaron Jones has 96 yards on four carries, including a career-long 67-yarder.</p><p>___</p><p>5 p.m.</p><p>Arizona Cardinals receiver Larry Fitzgerald has passed Hall of Famer Terrell Owens to move into second place on the career yards-receiving list.</p><p>The 15th-year player had six catches for 50 yards to up his total to 15,952 &mdash; moving 18 ahead of Owens &mdash; in a 26-14 loss at Kansas City.</p><p>Jerry Rice holds the record with 22,895 yards.</p><p>___</p><p>4:50 p.m.</p><p>The Los Angeles Rams held a moment of silence before their game against Seattle for the 12 victims of the mass shooting in Thousand Oaks last week.</p><p>The Rams&#8217; training complex in less than five miles from the Borderline Bar and Grill. The team is donating proceeds from its stadium raffle and a jersey auction to a relief effort, and left tackle Andrew Whitworth has pledged his game check.</p><p>___</p><p>4:45 p.m.</p><p>The Green Bay Packers have cashed in on a turnover on the Miami Dolphins&#8217; game-opening drive.</p><p>Aaron Rodgers hit Davante Adams for a 7-yard touchdown pass with 6:07 left in the first quarter to give Green Bay a 7-0 lead. Running back Aaron Jones accounted for 54 total yards on the drive. The Packers capitalized after Dolphins&#8217; quarterback Brock Osweiler mishandled a shotgun snap that was recovered by Reggie Gilbert at the Green Bay 30.</p><p>___</p><p>4:20 p.m.</p><p>The Tampa Bay Buccaneers had very little to show for gaining 501 yards offense in a 16-3 loss to Washington.</p><p>The Buccaneers became just the second team since 1940 to top 400 yards and score 3 or fewer points, according to Pro Football Reference. They join the then-St. Louis Rams, who had 424 yards offense in a 24-3 loss to Green Bay in 2011.</p><p>Four turnovers, including two interceptions thrown by Ryan Fitzpatrick, didn&#8217;t help. Neither did kicker Chandler Catanzaro missing field-goal attempts from 30 and 48 yards, both wide right.</p><p>___</p><p>3:50 p.m.</p><p>The New England Patriots have pulled quarterback Tom Brady while trailing the Titans 34-10 in the fourth quarter.</p><p>The Titans sacked Brady a season-high three times, and former New England cornerback Logan Ryan broke up a Brady pass to Julian Edelman on fourth down with 10:48 left to end a Patriots&#8217; scoring threat.</p><p>Edelman went to the locker room after that pass was broken up. He is questionable to return with an injured ankle.</p><p>Brian Hoyer replaced Brady after Derrick Henry&#8217;s 10-yard run out of the wildcat put the Titans up 34-10 with 7:13 left.</p><p>The Patriots also were playing without left tackle Trent Brown, who left in the third quarter with an injured back. Tight end Dwayne Allen is questionable to return with an injured knee.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>3:10 p.m.</p><p>Buffalo Bills running back LeSean McCoy has plenty to talk about now while enjoying his best game of the season.</p><p>Three quarters into Buffalo&#8217;s game at the New York Jets, McCoy has already topped 100 yards rushing for the first time since gaining 156 on a snow-covered field in a 13-7 overtime win over Indianapolis on Dec. 10.</p><p>He has also scored two touchdowns rushing for the first time since scoring twice in a 30-27 win over Tampa Bay on Oct. 22, 2017.</p><p>The touchdowns were the first of the season for McCoy. And the come two days after the 10th-year player broke nearly two weeks of silence by telling reporters he was frustrated with his lack of production.</p><p>McCoy entered the game with 267 yards rushing this season, and had 103 midway through the third quarter.</p><p>McCoy also surpassed 500 career points, and vaulted into 26th place on the career yards rushing list by moving ahead of Marshawn Lynch (10,379), Eddie George (10,441) and Tiki Barber (10,449).</p><p>___</p><p>2:50 p.m.</p><p>Cleveland Browns rookie Nick Chubb broke a club record and maybe Atlanta&#8217;s back with a 92-yard TD run.</p><p>The running back took a handoff at Cleveland&#8217;s 8, cut right and avoided a few tacklers before streaking to the end zone to give Cleveland a 28-10 lead midway through the third quarter.</p><p>Chubb&#8217;s 92-yard run is the longest in team history, topping the 90-yard run by Bobby Mitchell in 1959 against Washington.</p><p>It was Chubb&#8217;s second touchdown of the game. He also caught a 13-yard pass from Baker Mayfield in the second quarter.</p><p>___</p><p>2:45 p.m.</p><p>The Tennessee Titans are following up their big win in Dallas with a strong first half against the Patriots.</p><p>Tennessee scored a season-high 28 points to beat the Cowboys on Monday night, and they now lead New England 24-10 at halftime.</p><p>The Titans scored a season-high 17 points in the first quarter with touchdown passes by Marcus Mariota on each of their first two possessions. Mariota is 11 of 16 for 152 yards.</p><p>The Titans have been getting plenty of pressure on Tom Brady. Former Patriots cornerback Logan Ryan sacked Brady on the final play of the first half, the Titans&#8217; second sack of the first half.</p><p>James Develin has run for a TD, and Stephen Gostkowski connected on one of his two 52-yard field goal attempt for New England.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>___</p><p>2:40 p.m.</p><p>Rams left tackle Andrew Whitworth is donating a game check to the families of the victims of the mass shooting in Thousand Oaks.</p><p>Whitworth will give his check from Los Angeles&#8217; game against Seattle to the Ventura County Community Foundation&#8217;s Conejo Valley Victims Fund. The fund was set up to help the families of the 12 people killed by a gunman in Thousand Oaks, the home of the Rams&#8217; training complex.</p><p>Whitworth is in the second season of a three-year, $36 million deal with the Rams. He has played a major role in the Rams&#8217; transformation into an elite NFC team under Sean McVay.</p><p>Whitworth, Todd Gurley, Jared Goff, Michael Brockers and other players are also auctioning off their game jerseys to benefit the victims&#8217; fund and American Red Cross Southern California Wildfire Relief.</p><p>Two wildfires are also burning in the same general area of the western Los Angeles suburbs.</p><p>2:30 p.m.</p><p>New Orleans Saints quarterback Drew Brees has moved ahead of Brett Favre for second place on the career regular-season touchdown list with a sensational first half at Cincinnati.</p><p>He&#8217;s thrown three TD passes as the Saints have raced ahead 35-7, reaching the end zone on all five possessions. Brees has 509 career TD passes, one more than Favre.</p><p>Peyton Manning holds the record with 539.</p><p>The Saints have piled up 311 yards, and they have 21 first downs on 40 plays. Brees is 18 of 20 for 214 yards.</p><p>___</p><p>2:15 p.m.</p><p>Baker Mayfield enjoyed a perfect half.</p><p>Cleveland&#8217;s rookie quarterback completed 12 of 12 passes for 165 yards and two touchdowns in the first half against Atlanta. Mayfield connected on a 28-yard TD with Rashard Higgins and threw a 13-yard scoring pass to Nick Chubb.</p><p>Mayfield finished the half with a 158.3 quarterback rating, the highest possible score. The Browns did have one interception in the half, but it was thrown by running back Dontrell Hilliard, who attempted to hit a well-covered Mayfield on a trick play.</p><p>___</p><p>2:10 p.m.</p><p>Patrick Mahomes has broken the Kansas City Chiefs record for touchdown passes in a season.</p><p>The first-year starter threw his 31st of the season &mdash; and second of the game to Tyreek Hill &mdash; to pass Len Dawson. The Hall of Famer threw 30 in 1964.</p><p>The record-setter came on third-and-goal from the Arizona 14. Hill celebrated by leaping into the stands, just as he did on his first TD catch, then playing with the TV cameras.</p><p>That last bit earned Hill an unsportsmanlike conduct penalty.</p><p>&mdash; Dave Skretta reporting from Kansas City</p><p>___</p><p>2 p.m.</p><p>Atlanta receiver Julio Jones has reached 10,000 yards receiving faster than any player in NFL history.</p><p>Jones reached the plateau in his 104th career game, catching a 30-yard pass in the second quarter from Matt Ryan. Calvin Johnson held the previous mark, getting to 10,000 yards in his 115th game. Torry Holt and Antonio Brown got there in 116 games.</p><p>Jones caught a short pass over the middle and broke a couple tackles on his first reception of the game. He came in with 933 yards receiving this season.</p><p>Moments later, Jones caught a 1-yard TD pass from Ryan to give the Falcons a 10-7 lead.</p><p>___</p><p>1:50 p.m.</p><p>The Buffalo Bills have scored twice in the first quarter against the New York Jets to match their combined total from their previous four games.</p><p>LeSean McCoy opened the scoring with a 28-yard run, 5 more than he totaled in his previous two games. And then tight end Jason Croom recovered teammate Zay Jones&#8217; fumble in the end zone to put the Bills ahead 14-0.</p><p>Buffalo&#8217;s 14 points are the most they&#8217;ve scored in seven games, since a 27-6 victory at Minnesota on Sept. 23. And the Bills are doing this with Matt Barkley making his debut at quarterback less than two weeks after signing with Buffalo.</p><p>___</p><p>1:40 p.m.</p><p>New Orleans quarterback Drew Brees has thrown two touchdown passes against Cincinnati to up his regular-season total to 508 and match Brett Favre for second on the NFL career list.</p><p>Brees first TD was a 7-yarder to Michael Thomas midway through the first quarter. Mark Ingram II then turned a screen pass into a 28-yard touchdown</p><p>Peyton Manning holds the record with 539.</p><p>___</p><p>1:25 p.m.</p><p>Six teams reached the end zone on the opening possession of their games Sunday to get Week 10 off to a high-scoring start.</p><p>Kansas City, which lost the coin toss for the first time all season, went 75 yards in 56 seconds. Three plays were needed, with Patrick Mahomes connecting with Tyreek Hill for 38 yards, then for a 37-yard touchdown.</p><p>Tennessee&#8217;s Darius Jennings returned the opening kickoff 58 yards, then the Titans needed seven plays to go 40 yards, capped by Marcus Mariota 4-yard TD pass to Jonnu Smith against New England.</p><p>Chicago&#8217;s Tarik Cohen had a 3-yard TD run to cap an eight-play, 75-yard drive vs. Detroit. But Cody Parkey missed the extra point.</p><p>Indianapolis covered 75 yards in seven plays and Andrew Luck found Eric Ebron for a 53-yard scoring pass against Jacksonville.</p><p>Buffalo used a mere two plays against the Jets, with newcomer Matt Barkley throwing 47 yards to Robert Foster before LeSean McCoy broke from a lengthy slump for his first touchdown this season, on a 28-yard run.</p><p>And Drew Brees threw his 507th career touchdown pass, leaving him one behind Brett Favre for second place on the career list, capping a 15-play, 75-yard drive that consumed 8 minutes, 30 seconds. It ended with Michael Thomas&#8217; diving 7-yard catch.</p><p>___</p><p>1:15 p.m.</p><p>Chiefs quarterback Patrick Mahomes needed only 56 seconds to throw his first touchdown pass against Arizona, moving him into a tie with Hall of Famer Len Dawson for the single-season franchise record.</p><p>Mahomes hit Tyreek Hill down the sideline for 38 yards on the game&#8217;s first play. Then, after an incompletion, Mahomes found Hill again for a 37-yard touchdown reception.</p><p>It was the 30th thrown by Mahomes this season. Dawson threw 30 during the 1964 season.</p><p>&mdash; Dave Skretta reporting from Kansas City.</p><p>___</p><p>1:10 p.m.</p><p>The Indianapolis Colts honored kicker Adam Vinatieri, the NFL&#8217;s new career scoring leader, with a brief highlight show during pregame introduction before their game against Jacksonville.</p><p>Vinatieri received a roaring ovation from the Lucas Oil Stadium crowd when he was announced as the final starter. The 45-year-old waved to the crowd and slapped hands with a group of fans gathered around the American flag on the field.</p><p>Vinatieri broke Morten Andersen&#8217;s record two weeks ago at Oakland, but the Colts had a bye last week and Sunday marked the first time Indy could celebrate the record-breaking moment on its home turf.</p><p>___</p><p>1 p.m.</p><p>Three-time Pro Bowl defensive lineman Jurrell Casey was the last of the Titans defense introduced before kickoff for Tennessee&#8217;s game against New England.</p><p>Casey took the field carrying an American flag, and first shaking hands with a soldier as part of the NFL&#8217;s Salute to Service being held on Veteran&#8217;s Day. A soldier accompanied each Titans starter onto the field for a few steps.</p><p>Country artist Little Big Town performed the national anthem, which featured a flyover by military helicopters.</p><p>___</p><p>11:30 a.m.</p><p>Drew Brees and Tom Brady enter Week 10 of the NFL&#8217;s schedule neck and neck in closing in on matching Brett Favre for second place on the career regular-season list.</p><p>Brees has 506 touchdowns passing, two behind Favre, as the New Orleans Saints play at Cincinnati. And Brady has 505 with his New England Patriots playing at Tennessee. Both are a little more than 30 behind Peyton Manning&#8217;s record of 539.</p><p>Brady does have chance to pass Manning on the career touchdowns passing list, including playoffs. Manning has 579, only three more than Brady.</p><p>On the other end of the quarterback matchup spectrum Sunday, the Buffalo Bills and New York Jets will feature a battle of the backups rather than far more intriguing AFC East showdown of two rookie first-round picks.</p><p>Matt Barkley is starting in place of Buffalo&#8217;s Josh Allen, who will miss his fourth straight game with a sprained throwing elbow. For New York, Josh McCown is starting in place Sam Darnold, who is sidelined by a strained right foot. Darnold was drafted third overall, four spots ahead of Allen.</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','The Latest: Rams&#8217; Aaron Donald gets season-best 12th sack');return false;"><span class="op-btn">Read More</span> <span class="count">2260 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fthe-latest-rams-aaron-donald-gets-season-best-12th-sack%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=The Latest: Rams’ Aaron Donald gets season-best 12th sack+http://nfp.news/yoc" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=The Latest: Rams&#8217; Aaron Donald gets season-best 12th sack&#32;&#32;http://nfp.news/yoc" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yoc"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/the-latest-dolphins-gore-tops-500-yards-for-14th-season/" rel="bookmark" title="The Latest: Dolphins&#8217; Gore tops 500 yards for 14th season">The Latest: Dolphins&#8217; Gore tops 500 yards for 14th season</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/the-latest-dolphins-gore-tops-500-yards-for-14th-season/"/><meta itemprop="datePublished" content="2 hours ago"/><meta itemprop="dateModified" content="2 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>The Latest on Week 10 in the NFL (all times EST):</p> <p>5:15 p.m.</p> <p>Miami Dolphins running back Frank Gore has topped 500 yards rushing for a 14th consecutive season to set an NFL record.</p> <p>Gore entered the game against Green Bay tied with Hall of Famers Emmitt Smith and Walter Payton, who had</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>The Latest on Week 10 in the NFL (all times EST):</p><p>5:15 p.m.</p><p>Miami Dolphins running back Frank Gore has topped 500 yards rushing for a 14th consecutive season to set an NFL record.</p><p>Gore entered the game against Green Bay tied with Hall of Famers Emmitt Smith and Walter Payton, who had topped 500 yards in 13 straight seasons. Gore topped the milestone with a 9-yard run with about 3 1/2 minutes left in the first quarter.</p><p>The 14-year veteran ranks fourth and leads active players with 14,464 yards rushing.</p><p>Green Bay leads Miami 14-6 early in the second quarter. For the Packers, running back Aaron Jones has 96 yards on four carries, including a career-long 67-yarder.</p><p>___</p><p>5 p.m.</p><p>Arizona Cardinals receiver Larry Fitzgerald has passed Hall of Famer Terrell Owens to move into second place on the career yards-receiving list.</p><p>The 15th-year player had six catches for 50 yards to up his total to 15,952 &mdash; moving 18 ahead of Owens &mdash; in a 26-14 loss at Kansas City.</p><p>Jerry Rice holds the record with 22,895 yards.</p><p>___</p><p>4:50 p.m.</p><p>The Los Angeles Rams held a moment of silence before their game against Seattle for the 12 victims of the mass shooting in Thousand Oaks last week.</p><p>The Rams&#8217; training complex in less than five miles from the Borderline Bar and Grill. The team is donating proceeds from its stadium raffle and a jersey auction to a relief effort, and left tackle Andrew Whitworth has pledged his game check.</p><p>___</p><p>4:45 p.m.</p><p>The Green Bay Packers have cashed in on a turnover on the Miami Dolphins&#8217; game-opening drive.</p><p>Aaron Rodgers hit Davante Adams for a 7-yard touchdown pass with 6:07 left in the first quarter to give Green Bay a 7-0 lead. Running back Aaron Jones accounted for 54 total yards on the drive. The Packers capitalized after Dolphins&#8217; quarterback Brock Osweiler mishandled a shotgun snap that was recovered by Reggie Gilbert at the Green Bay 30.</p><p>___</p><p>4:20 p.m.</p><p>The Tampa Bay Buccaneers had very little to show for gaining 501 yards offense in a 16-3 loss to Washington.</p><p>The Buccaneers became just the second team since 1940 to top 400 yards and score 3 or fewer points, according to Pro Football Reference. They join the then-St. Louis Rams, who had 424 yards offense in a 24-3 loss to Green Bay in 2011.</p><p>Four turnovers, including two interceptions thrown by Ryan Fitzpatrick, didn&#8217;t help. Neither did kicker Chandler Catanzaro missing field-goal attempts from 30 and 48 yards, both wide right.</p><p>___</p><p>3:50 p.m.</p><p>The New England Patriots have pulled quarterback Tom Brady while trailing the Titans 34-10 in the fourth quarter.</p><p>The Titans sacked Brady a season-high three times, and former New England cornerback Logan Ryan broke up a Brady pass to Julian Edelman on fourth down with 10:48 left to end a Patriots&#8217; scoring threat.</p><p>Edelman went to the locker room after that pass was broken up. He is questionable to return with an injured ankle.</p><p>Brian Hoyer replaced Brady after Derrick Henry&#8217;s 10-yard run out of the wildcat put the Titans up 34-10 with 7:13 left.</p><p>The Patriots also were playing without left tackle Trent Brown, who left in the third quarter with an injured back. Tight end Dwayne Allen is questionable to return with an injured knee.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>3:10 p.m.</p><p>Buffalo Bills running back LeSean McCoy has plenty to talk about now while enjoying his best game of the season.</p><p>Three quarters into Buffalo&#8217;s game at the New York Jets, McCoy has already topped 100 yards rushing for the first time since gaining 156 on a snow-covered field in a 13-7 overtime win over Indianapolis on Dec. 10.</p><p>He has also scored two touchdowns rushing for the first time since scoring twice in a 30-27 win over Tampa Bay on Oct. 22, 2017.</p><p>The touchdowns were the first of the season for McCoy. And the come two days after the 10th-year player broke nearly two weeks of silence by telling reporters he was frustrated with his lack of production.</p><p>McCoy entered the game with 267 yards rushing this season, and had 103 midway through the third quarter.</p><p>McCoy also surpassed 500 career points, and vaulted into 26th place on the career yards rushing list by moving ahead of Marshawn Lynch (10,379), Eddie George (10,441) and Tiki Barber (10,449).</p><p>___</p><p>2:50 p.m.</p><p>Cleveland Browns rookie Nick Chubb broke a club record and maybe Atlanta&#8217;s back with a 92-yard TD run.</p><p>The running back took a handoff at Cleveland&#8217;s 8, cut right and avoided a few tacklers before streaking to the end zone to give Cleveland a 28-10 lead midway through the third quarter.</p><p>Chubb&#8217;s 92-yard run is the longest in team history, topping the 90-yard run by Bobby Mitchell in 1959 against Washington.</p><p>It was Chubb&#8217;s second touchdown of the game. He also caught a 13-yard pass from Baker Mayfield in the second quarter.</p><p>___</p><p>2:45 p.m.</p><p>The Tennessee Titans are following up their big win in Dallas with a strong first half against the Patriots.</p><p>Tennessee scored a season-high 28 points to beat the Cowboys on Monday night, and they now lead New England 24-10 at halftime.</p><p>The Titans scored a season-high 17 points in the first quarter with touchdown passes by Marcus Mariota on each of their first two possessions. Mariota is 11 of 16 for 152 yards.</p><p>The Titans have been getting plenty of pressure on Tom Brady. Former Patriots cornerback Logan Ryan sacked Brady on the final play of the first half, the Titans&#8217; second sack of the first half.</p><p>James Develin has run for a TD, and Stephen Gostkowski connected on one of his two 52-yard field goal attempt for New England.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>___</p><p>2:40 p.m.</p><p>Rams left tackle Andrew Whitworth is donating a game check to the families of the victims of the mass shooting in Thousand Oaks.</p><p>Whitworth will give his check from Los Angeles&#8217; game against Seattle to the Ventura County Community Foundation&#8217;s Conejo Valley Victims Fund. The fund was set up to help the families of the 12 people killed by a gunman in Thousand Oaks, the home of the Rams&#8217; training complex.</p><p>Whitworth is in the second season of a three-year, $36 million deal with the Rams. He has played a major role in the Rams&#8217; transformation into an elite NFC team under Sean McVay.</p><p>Whitworth, Todd Gurley, Jared Goff, Michael Brockers and other players are also auctioning off their game jerseys to benefit the victims&#8217; fund and American Red Cross Southern California Wildfire Relief.</p><p>Two wildfires are also burning in the same general area of the western Los Angeles suburbs.</p><p>2:30 p.m.</p><p>New Orleans Saints quarterback Drew Brees has moved ahead of Brett Favre for second place on the career regular-season touchdown list with a sensational first half at Cincinnati.</p><p>He&#8217;s thrown three TD passes as the Saints have raced ahead 35-7, reaching the end zone on all five possessions. Brees has 509 career TD passes, one more than Favre.</p><p>Peyton Manning holds the record with 539.</p><p>The Saints have piled up 311 yards, and they have 21 first downs on 40 plays. Brees is 18 of 20 for 214 yards.</p><p>___</p><p>2:15 p.m.</p><p>Baker Mayfield enjoyed a perfect half.</p><p>Cleveland&#8217;s rookie quarterback completed 12 of 12 passes for 165 yards and two touchdowns in the first half against Atlanta. Mayfield connected on a 28-yard TD with Rashard Higgins and threw a 13-yard scoring pass to Nick Chubb.</p><p>Mayfield finished the half with a 158.3 quarterback rating, the highest possible score. The Browns did have one interception in the half, but it was thrown by running back Dontrell Hilliard, who attempted to hit a well-covered Mayfield on a trick play.</p><p>___</p><p>2:10 p.m.</p><p>Patrick Mahomes has broken the Kansas City Chiefs record for touchdown passes in a season.</p><p>The first-year starter threw his 31st of the season &mdash; and second of the game to Tyreek Hill &mdash; to pass Len Dawson. The Hall of Famer threw 30 in 1964.</p><p>The record-setter came on third-and-goal from the Arizona 14. Hill celebrated by leaping into the stands, just as he did on his first TD catch, then playing with the TV cameras.</p><p>That last bit earned Hill an unsportsmanlike conduct penalty.</p><p>&mdash; Dave Skretta reporting from Kansas City</p><p>___</p><p>2 p.m.</p><p>Atlanta receiver Julio Jones has reached 10,000 yards receiving faster than any player in NFL history.</p><p>Jones reached the plateau in his 104th career game, catching a 30-yard pass in the second quarter from Matt Ryan. Calvin Johnson held the previous mark, getting to 10,000 yards in his 115th game. Torry Holt and Antonio Brown got there in 116 games.</p><p>Jones caught a short pass over the middle and broke a couple tackles on his first reception of the game. He came in with 933 yards receiving this season.</p><p>Moments later, Jones caught a 1-yard TD pass from Ryan to give the Falcons a 10-7 lead.</p><p>___</p><p>1:50 p.m.</p><p>The Buffalo Bills have scored twice in the first quarter against the New York Jets to match their combined total from their previous four games.</p><p>LeSean McCoy opened the scoring with a 28-yard run, 5 more than he totaled in his previous two games. And then tight end Jason Croom recovered teammate Zay Jones&#8217; fumble in the end zone to put the Bills ahead 14-0.</p><p>Buffalo&#8217;s 14 points are the most they&#8217;ve scored in seven games, since a 27-6 victory at Minnesota on Sept. 23. And the Bills are doing this with Matt Barkley making his debut at quarterback less than two weeks after signing with Buffalo.</p><p>___</p><p>1:40 p.m.</p><p>New Orleans quarterback Drew Brees has thrown two touchdown passes against Cincinnati to up his regular-season total to 508 and match Brett Favre for second on the NFL career list.</p><p>Brees first TD was a 7-yarder to Michael Thomas midway through the first quarter. Mark Ingram II then turned a screen pass into a 28-yard touchdown</p><p>Peyton Manning holds the record with 539.</p><p>___</p><p>1:25 p.m.</p><p>Six teams reached the end zone on the opening possession of their games Sunday to get Week 10 off to a high-scoring start.</p><p>Kansas City, which lost the coin toss for the first time all season, went 75 yards in 56 seconds. Three plays were needed, with Patrick Mahomes connecting with Tyreek Hill for 38 yards, then for a 37-yard touchdown.</p><p>Tennessee&#8217;s Darius Jennings returned the opening kickoff 58 yards, then the Titans needed seven plays to go 40 yards, capped by Marcus Mariota 4-yard TD pass to Jonnu Smith against New England.</p><p>Chicago&#8217;s Tarik Cohen had a 3-yard TD run to cap an eight-play, 75-yard drive vs. Detroit. But Cody Parkey missed the extra point.</p><p>Indianapolis covered 75 yards in seven plays and Andrew Luck found Eric Ebron for a 53-yard scoring pass against Jacksonville.</p><p>Buffalo used a mere two plays against the Jets, with newcomer Matt Barkley throwing 47 yards to Robert Foster before LeSean McCoy broke from a lengthy slump for his first touchdown this season, on a 28-yard run.</p><p>And Drew Brees threw his 507th career touchdown pass, leaving him one behind Brett Favre for second place on the career list, capping a 15-play, 75-yard drive that consumed 8 minutes, 30 seconds. It ended with Michael Thomas&#8217; diving 7-yard catch.</p><p>___</p><p>1:15 p.m.</p><p>Chiefs quarterback Patrick Mahomes needed only 56 seconds to throw his first touchdown pass against Arizona, moving him into a tie with Hall of Famer Len Dawson for the single-season franchise record.</p><p>Mahomes hit Tyreek Hill down the sideline for 38 yards on the game&#8217;s first play. Then, after an incompletion, Mahomes found Hill again for a 37-yard touchdown reception.</p><p>It was the 30th thrown by Mahomes this season. Dawson threw 30 during the 1964 season.</p><p>&mdash; Dave Skretta reporting from Kansas City.</p><p>___</p><p>1:10 p.m.</p><p>The Indianapolis Colts honored kicker Adam Vinatieri, the NFL&#8217;s new career scoring leader, with a brief highlight show during pregame introduction before their game against Jacksonville.</p><p>Vinatieri received a roaring ovation from the Lucas Oil Stadium crowd when he was announced as the final starter. The 45-year-old waved to the crowd and slapped hands with a group of fans gathered around the American flag on the field.</p><p>Vinatieri broke Morten Andersen&#8217;s record two weeks ago at Oakland, but the Colts had a bye last week and Sunday marked the first time Indy could celebrate the record-breaking moment on its home turf.</p><p>___</p><p>1 p.m.</p><p>Three-time Pro Bowl defensive lineman Jurrell Casey was the last of the Titans defense introduced before kickoff for Tennessee&#8217;s game against New England.</p><p>Casey took the field carrying an American flag, and first shaking hands with a soldier as part of the NFL&#8217;s Salute to Service being held on Veteran&#8217;s Day. A soldier accompanied each Titans starter onto the field for a few steps.</p><p>Country artist Little Big Town performed the national anthem, which featured a flyover by military helicopters.</p><p>___</p><p>11:30 a.m.</p><p>Drew Brees and Tom Brady enter Week 10 of the NFL&#8217;s schedule neck and neck in closing in on matching Brett Favre for second place on the career regular-season list.</p><p>Brees has 506 touchdowns passing, two behind Favre, as the New Orleans Saints play at Cincinnati. And Brady has 505 with his New England Patriots playing at Tennessee. Both are a little more than 30 behind Peyton Manning&#8217;s record of 539.</p><p>Brady does have chance to pass Manning on the career touchdowns passing list, including playoffs. Manning has 579, only three more than Brady.</p><p>On the other end of the quarterback matchup spectrum Sunday, the Buffalo Bills and New York Jets will feature a battle of the backups rather than far more intriguing AFC East showdown of two rookie first-round picks.</p><p>Matt Barkley is starting in place of Buffalo&#8217;s Josh Allen, who will miss his fourth straight game with a sprained throwing elbow. For New York, Josh McCown is starting in place Sam Darnold, who is sidelined by a strained right foot. Darnold was drafted third overall, four spots ahead of Allen.</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','The Latest: Dolphins&#8217; Gore tops 500 yards for 14th season');return false;"><span class="op-btn">Read More</span> <span class="count">2194 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fthe-latest-dolphins-gore-tops-500-yards-for-14th-season%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=The Latest: Dolphins’ Gore tops 500 yards for 14th season+http://nfp.news/yob" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=The Latest: Dolphins&#8217; Gore tops 500 yards for 14th season&#32;&#32;http://nfp.news/yob" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yob"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/mayfield-throws-3-tds-chubb-has-record-run-in-browns-win/" rel="bookmark" title="Mayfield throws 3 TDs, Chubb has record run in Browns&#8217; win">Mayfield throws 3 TDs, Chubb has record run in Browns&#8217; win</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/mayfield-throws-3-tds-chubb-has-record-run-in-browns-win/"/><meta itemprop="datePublished" content="3 hours ago"/><meta itemprop="dateModified" content="3 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>CLEVELAND (AP) — Before he rolled out of bed, Baker Mayfield knew he'd have a good game.</p> <p>"When I woke up this morning, I was feeling pretty dangerous," the Browns rookie quarterback said with a smile and a hint of arrogance. "Real dangerous."</p> <p>Someone should have warned the Atlanta Falcons.</p> <p>Mayfield threw a</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>CLEVELAND (AP) &mdash; Before he rolled out of bed, Baker Mayfield knew he&#8217;d have a good game.</p><p>&#8220;When I woke up this morning, I was feeling pretty dangerous,&#8221; the Browns rookie quarterback said with a smile and a hint of arrogance. &#8220;Real dangerous.&#8221;</p><p>Someone should have warned the Atlanta Falcons.</p><p>Mayfield threw a season-high three touchdown passes and rookie Nick Chubb streaked 92 yards for a TD as the Cleveland Browns ended a four-game losing streak with their best game in years, a stunning 28-16 win over the Falcons on Sunday.</p><p>The Browns (3-6-1) played their most complete game this season under interim coach Gregg Williams, their defensive coordinator who improved to 1-1 since replacing the fired Hue Jackson.</p><p>Mayfield outplayed Falcons star quarterback Matt Ryan with a performance that further justifies Cleveland&#8217;s decision to take the QB with the No. 1 overall pick in this year&#8217;s draft.</p><p>&#8220;The plan was to put the ball in Baker&#8217;s hands, so he could make quick decisions,&#8221; guard Joel Bitonio said. &#8220;He did a great job doing that and making plays for us. With Baker doing his thing and the way Chubb was running the ball, it was a great day for our entire offense.</p><p>&#8220;Sometimes, the ball bounces your way. Sometimes, it doesn&#8217;t. Today, it was definitely bouncing our way.&#8221;</p><p>Mayfield completed his first 13 passes and finished 17 of 20 for 216 yards. He threw a 28-yard scoring pass to Rashard Higgins, a 13-yarder to Chubb and 11-yarder to Duke Johnson.</p><p>Ryan and the Falcons (4-5) had their three-game winning streak &mdash; and any playoff momentum &mdash; stopped cold.</p><p>&#8220;It is disappointing because we had been playing better than this the last couple of weeks. We&#8217;re better than what we put out there today, but you&#8217;re only as good as your last performance. Today was not good enough.&#8221;</p><p>And while Mayfield did damage, Chubb&#8217;s record run was the backbreaker.</p><p>With the Browns backed up at their 8, Chubb, who had 176 yards on 20 carries, took a handoff and headed right. He cut toward Atlanta&#8217;s sideline, picked up a block and then showed his surprising breakaway speed while finishing the longest run in team history.</p><p>Chubb&#8217;s run broke the previous team mark held by Bobby Mitchell, who had a 90-yard TD run against Washington on Nov. 15, 1959.</p><p>The score put the Browns ahead 28-10, an unexpected and unescapable hole for the Falcons, who blew a chance to get closer in the fourth when they were stopped inches short of the goal line.</p><p>Ryan completed 38 of 52 passes for 330 yards and two TDs.</p><p>Atlanta receiver Julio Jones had 107 yards and became the fastest player to reach 10,000 yards receiving with a 30-yard catch in the second quarter. Jones reached the 10,000-yard plateau in his 104th game, 11 quicker than Calvin Johnson got to the milestone.</p><p>Moments later, Ryan completed a 1-yard TD pass to Jones to give the Falcons a 10-7 lead.</p><p>Mayfield, who lamented his accuracy issues in last week&#8217;s loss to Kansas City, went 12 of 12 for 165 yards and two TD passes in the first half, finishing with a 158.3 rating.</p><p>Mayfield didn&#8217;t throw his first incompletion until 11:14 remained in the third quarter, but two plays later, he connected with Johnson to put the Browns ahead 21-10.</p><p>The score came after cornerback T.J. Carrie jarred the ball away from Falcons receiver Mohamed Sanu.</p><p>Plagued by slow starts, the Browns took a 7-0 lead in the first quarter on Mayfield&#8217;s pass to Higgins, one of the QB&#8217;s favorite targets who was playing his second straight game after missing three weeks with a knee injury.</p><p>It was Cleveland&#8217;s first TD in the opening quarter this season.</p><p>WISHBONE WISH</p><p>New Browns offensive coordinator Freddie Kitchens joked earlier in the week he might bring back the &#8220;wishbone&#8221; &mdash; a three-back formation popular with college teams in the 1970s.</p><p>Cleveland used a variation of the wishbone on several plays.</p><p>STRANGE CALL</p><p>While Mayfield was sublime in the first half, the Browns did have one interception.</p><p>Running back Dontrell Hilliard took a pitch and threw an ill-advised pass back toward Mayfield, who was well covered and the ball was picked by Falcons safety Damonte Kazee.</p><p>NEW TACKLE</p><p>The Browns started Greg Robinson at left tackle for the second straight week in place of rookie Desmond Harrison.</p><p>The No. 2 overall pick in 2014, Robinson is getting a fresh start with the Browns, who signed him as a free agent before training camp. He previously played for the Los Angeles Rams and Lions.</p><p>UP NEXT</p><p>Falcons: Host the Dallas Cowboys on Nov. 18.</p><p>Browns: Bye week.</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','Mayfield throws 3 TDs, Chubb has record run in Browns&#8217; win');return false;"><span class="op-btn">Read More</span> <span class="count">702 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fmayfield-throws-3-tds-chubb-has-record-run-in-browns-win%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=Mayfield throws 3 TDs, Chubb has record run in Browns’ win+http://nfp.news/yo8" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=Mayfield throws 3 TDs, Chubb has record run in Browns&#8217; win&#32;&#32;http://nfp.news/yo8" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yo8"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article>
<article style="overflow: hidden;margin-bottom: 30px;">
<header class="fl-post-header">
<h2 class="fl-post-title" itemprop="headline">
<a href="https://nationalfootballpost.com/the-latest-fitzgerald-passes-to-on-yards-receiving-list/" rel="bookmark" title="The Latest: Fitzgerald passes TO on yards receiving list">The Latest: Fitzgerald passes TO on yards receiving list</a>
</h2>
<div class="fl-post-meta fl-post-meta-top"><span class="fl-post-author">By <a href="https://nationalfootballpost.com/author/national-football-post/"><span>National Football Post</span></a></span></div><meta itemscope itemprop="mainEntityOfPage" itemid="https://nationalfootballpost.com/the-latest-fitzgerald-passes-to-on-yards-receiving-list/"/><meta itemprop="datePublished" content="3 hours ago"/><meta itemprop="dateModified" content="3 hours ago"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization"><meta itemprop="name" content="National Football Post"><div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject"><meta itemprop="url" content="https://nationalfootballpost.com/wp-content/uploads/2018/05/NFPlogo-400.png"></div></div><div itemscope itemprop="author" itemtype="https://schema.org/Person"><meta itemprop="url" content="https://nationalfootballpost.com/author/national-football-post/"/><meta itemprop="name" content="National Football Post"/></div><div itemprop="interactionStatistic" itemscope itemtype="https://schema.org/InteractionCounter"><meta itemprop="interactionType" content="https://schema.org/CommentAction"/><meta itemprop="userInteractionCount" content="0"/></div></header>
<div class="fl-post-content clearfix" id="content-outter" itemprop="text"> <div id="content-less"><p><block id="Main"></block></p> <p>The Latest on Week 10 in the NFL (all times EST):</p> <p>5 p.m.</p> <p>Arizona Cardinals receiver Larry Fitzgerald has passed Hall of Famer Terrell Owens to move into second place on the career yards-receiving list.</p> <p>The 15th-year player had six catches for 50 yards to up his total to 15,952 — moving 18</p></div><div class="clearfix" style="clear:both"></div><div id="complete-single"><p><block id="Main"></p><p>The Latest on Week 10 in the NFL (all times EST):</p><p>5 p.m.</p><p>Arizona Cardinals receiver Larry Fitzgerald has passed Hall of Famer Terrell Owens to move into second place on the career yards-receiving list.</p><p>The 15th-year player had six catches for 50 yards to up his total to 15,952 &mdash; moving 18 ahead of Owens &mdash; in a 26-14 loss at Kansas City.</p><p>Jerry Rice holds the record with 22,895 yards.</p><p>___</p><p>4:50 p.m.</p><p>The Los Angeles Rams held a moment of silence before their game against Seattle for the 12 victims of the mass shooting in Thousand Oaks last week.</p><p>The Rams&#8217; training complex in less than five miles from the Borderline Bar and Grill. The team is donating proceeds from its stadium raffle and a jersey auction to a relief effort, and left tackle Andrew Whitworth has pledged his game check.</p><p>___</p><p>4:45 p.m.</p><p>The Green Bay Packers have cashed in on a turnover on the Miami Dolphins&#8217; game-opening drive.</p><p>Aaron Rodgers hit Davante Adams for a 7-yard touchdown pass with 6:07 left in the first quarter to give Green Bay a 7-0 lead. Running back Aaron Jones accounted for 54 total yards on the drive. The Packers capitalized after Dolphins&#8217; quarterback Brock Osweiler mishandled a shotgun snap that was recovered by Reggie Gilbert at the Green Bay 30.</p><p>___</p><p>4:20 p.m.</p><p>The Tampa Bay Buccaneers had very little to show for gaining 501 yards offense in a 16-3 loss to Washington.</p><p>The Buccaneers became just the second team since 1940 to top 400 yards and score 3 or fewer points, according to Pro Football Reference. They join the then-St. Louis Rams, who had 424 yards offense in a 24-3 loss to Green Bay in 2011.</p><p>Four turnovers, including two interceptions thrown by Ryan Fitzpatrick, didn&#8217;t help. Neither did kicker Chandler Catanzaro missing field-goal attempts from 30 and 48 yards, both wide right.</p><p>___</p><p>3:50 p.m.</p><p>The New England Patriots have pulled quarterback Tom Brady while trailing the Titans 34-10 in the fourth quarter.</p><p>The Titans sacked Brady a season-high three times, and former New England cornerback Logan Ryan broke up a Brady pass to Julian Edelman on fourth down with 10:48 left to end a Patriots&#8217; scoring threat.</p><p>Edelman went to the locker room after that pass was broken up. He is questionable to return with an injured ankle.</p><p>Brian Hoyer replaced Brady after Derrick Henry&#8217;s 10-yard run out of the wildcat put the Titans up 34-10 with 7:13 left.</p><p>The Patriots also were playing without left tackle Trent Brown, who left in the third quarter with an injured back. Tight end Dwayne Allen is questionable to return with an injured knee.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>3:10 p.m.</p><p>Buffalo Bills running back LeSean McCoy has plenty to talk about now while enjoying his best game of the season.</p><p>Three quarters into Buffalo&#8217;s game at the New York Jets, McCoy has already topped 100 yards rushing for the first time since gaining 156 on a snow-covered field in a 13-7 overtime win over Indianapolis on Dec. 10.</p><p>He has also scored two touchdowns rushing for the first time since scoring twice in a 30-27 win over Tampa Bay on Oct. 22, 2017.</p><p>The touchdowns were the first of the season for McCoy. And the come two days after the 10th-year player broke nearly two weeks of silence by telling reporters he was frustrated with his lack of production.</p><p>McCoy entered the game with 267 yards rushing this season, and had 103 midway through the third quarter.</p><p>McCoy also surpassed 500 career points, and vaulted into 26th place on the career yards rushing list by moving ahead of Marshawn Lynch (10,379), Eddie George (10,441) and Tiki Barber (10,449).</p><p>___</p><p>2:50 p.m.</p><p>Cleveland Browns rookie Nick Chubb broke a club record and maybe Atlanta&#8217;s back with a 92-yard TD run.</p><p>The running back took a handoff at Cleveland&#8217;s 8, cut right and avoided a few tacklers before streaking to the end zone to give Cleveland a 28-10 lead midway through the third quarter.</p><p>Chubb&#8217;s 92-yard run is the longest in team history, topping the 90-yard run by Bobby Mitchell in 1959 against Washington.</p><p>It was Chubb&#8217;s second touchdown of the game. He also caught a 13-yard pass from Baker Mayfield in the second quarter.</p><p>___</p><p>2:45 p.m.</p><p>The Tennessee Titans are following up their big win in Dallas with a strong first half against the Patriots.</p><p>Tennessee scored a season-high 28 points to beat the Cowboys on Monday night, and they now lead New England 24-10 at halftime.</p><p>The Titans scored a season-high 17 points in the first quarter with touchdown passes by Marcus Mariota on each of their first two possessions. Mariota is 11 of 16 for 152 yards.</p><p>The Titans have been getting plenty of pressure on Tom Brady. Former Patriots cornerback Logan Ryan sacked Brady on the final play of the first half, the Titans&#8217; second sack of the first half.</p><p>James Develin has run for a TD, and Stephen Gostkowski connected on one of his two 52-yard field goal attempt for New England.</p><p>&mdash; Teresa M. Walker reporting from Nashville, Tennessee.</p><p>___</p><p>2:40 p.m.</p><p>Rams left tackle Andrew Whitworth is donating a game check to the families of the victims of the mass shooting in Thousand Oaks.</p><p>Whitworth will give his check from Los Angeles&#8217; game against Seattle to the Ventura County Community Foundation&#8217;s Conejo Valley Victims Fund. The fund was set up to help the families of the 12 people killed by a gunman in Thousand Oaks, the home of the Rams&#8217; training complex.</p><p>Whitworth is in the second season of a three-year, $36 million deal with the Rams. He has played a major role in the Rams&#8217; transformation into an elite NFC team under Sean McVay.</p><p>Whitworth, Todd Gurley, Jared Goff, Michael Brockers and other players are also auctioning off their game jerseys to benefit the victims&#8217; fund and American Red Cross Southern California Wildfire Relief.</p><p>Two wildfires are also burning in the same general area of the western Los Angeles suburbs.</p><p>2:30 p.m.</p><p>New Orleans Saints quarterback Drew Brees has moved ahead of Brett Favre for second place on the career regular-season touchdown list with a sensational first half at Cincinnati.</p><p>He&#8217;s thrown three TD passes as the Saints have raced ahead 35-7, reaching the end zone on all five possessions. Brees has 509 career TD passes, one more than Favre.</p><p>Peyton Manning holds the record with 539.</p><p>The Saints have piled up 311 yards, and they have 21 first downs on 40 plays. Brees is 18 of 20 for 214 yards.</p><p>___</p><p>2:15 p.m.</p><p>Baker Mayfield enjoyed a perfect half.</p><p>Cleveland&#8217;s rookie quarterback completed 12 of 12 passes for 165 yards and two touchdowns in the first half against Atlanta. Mayfield connected on a 28-yard TD with Rashard Higgins and threw a 13-yard scoring pass to Nick Chubb.</p><p>Mayfield finished the half with a 158.3 quarterback rating, the highest possible score. The Browns did have one interception in the half, but it was thrown by running back Dontrell Hilliard, who attempted to hit a well-covered Mayfield on a trick play.</p><p>___</p><p>2:10 p.m.</p><p>Patrick Mahomes has broken the Kansas City Chiefs record for touchdown passes in a season.</p><p>The first-year starter threw his 31st of the season &mdash; and second of the game to Tyreek Hill &mdash; to pass Len Dawson. The Hall of Famer threw 30 in 1964.</p><p>The record-setter came on third-and-goal from the Arizona 14. Hill celebrated by leaping into the stands, just as he did on his first TD catch, then playing with the TV cameras.</p><p>That last bit earned Hill an unsportsmanlike conduct penalty.</p><p>&mdash; Dave Skretta reporting from Kansas City</p><p>___</p><p>2 p.m.</p><p>Atlanta receiver Julio Jones has reached 10,000 yards receiving faster than any player in NFL history.</p><p>Jones reached the plateau in his 104th career game, catching a 30-yard pass in the second quarter from Matt Ryan. Calvin Johnson held the previous mark, getting to 10,000 yards in his 115th game. Torry Holt and Antonio Brown got there in 116 games.</p><p>Jones caught a short pass over the middle and broke a couple tackles on his first reception of the game. He came in with 933 yards receiving this season.</p><p>Moments later, Jones caught a 1-yard TD pass from Ryan to give the Falcons a 10-7 lead.</p><p>___</p><p>1:50 p.m.</p><p>The Buffalo Bills have scored twice in the first quarter against the New York Jets to match their combined total from their previous four games.</p><p>LeSean McCoy opened the scoring with a 28-yard run, 5 more than he totaled in his previous two games. And then tight end Jason Croom recovered teammate Zay Jones&#8217; fumble in the end zone to put the Bills ahead 14-0.</p><p>Buffalo&#8217;s 14 points are the most they&#8217;ve scored in seven games, since a 27-6 victory at Minnesota on Sept. 23. And the Bills are doing this with Matt Barkley making his debut at quarterback less than two weeks after signing with Buffalo.</p><p>___</p><p>1:40 p.m.</p><p>New Orleans quarterback Drew Brees has thrown two touchdown passes against Cincinnati to up his regular-season total to 508 and match Brett Favre for second on the NFL career list.</p><p>Brees first TD was a 7-yarder to Michael Thomas midway through the first quarter. Mark Ingram II then turned a screen pass into a 28-yard touchdown</p><p>Peyton Manning holds the record with 539.</p><p>___</p><p>1:25 p.m.</p><p>Six teams reached the end zone on the opening possession of their games Sunday to get Week 10 off to a high-scoring start.</p><p>Kansas City, which lost the coin toss for the first time all season, went 75 yards in 56 seconds. Three plays were needed, with Patrick Mahomes connecting with Tyreek Hill for 38 yards, then for a 37-yard touchdown.</p><p>Tennessee&#8217;s Darius Jennings returned the opening kickoff 58 yards, then the Titans needed seven plays to go 40 yards, capped by Marcus Mariota 4-yard TD pass to Jonnu Smith against New England.</p><p>Chicago&#8217;s Tarik Cohen had a 3-yard TD run to cap an eight-play, 75-yard drive vs. Detroit. But Cody Parkey missed the extra point.</p><p>Indianapolis covered 75 yards in seven plays and Andrew Luck found Eric Ebron for a 53-yard scoring pass against Jacksonville.</p><p>Buffalo used a mere two plays against the Jets, with newcomer Matt Barkley throwing 47 yards to Robert Foster before LeSean McCoy broke from a lengthy slump for his first touchdown this season, on a 28-yard run.</p><p>And Drew Brees threw his 507th career touchdown pass, leaving him one behind Brett Favre for second place on the career list, capping a 15-play, 75-yard drive that consumed 8 minutes, 30 seconds. It ended with Michael Thomas&#8217; diving 7-yard catch.</p><p>___</p><p>1:15 p.m.</p><p>Chiefs quarterback Patrick Mahomes needed only 56 seconds to throw his first touchdown pass against Arizona, moving him into a tie with Hall of Famer Len Dawson for the single-season franchise record.</p><p>Mahomes hit Tyreek Hill down the sideline for 38 yards on the game&#8217;s first play. Then, after an incompletion, Mahomes found Hill again for a 37-yard touchdown reception.</p><p>It was the 30th thrown by Mahomes this season. Dawson threw 30 during the 1964 season.</p><p>&mdash; Dave Skretta reporting from Kansas City.</p><p>___</p><p>1:10 p.m.</p><p>The Indianapolis Colts honored kicker Adam Vinatieri, the NFL&#8217;s new career scoring leader, with a brief highlight show during pregame introduction before their game against Jacksonville.</p><p>Vinatieri received a roaring ovation from the Lucas Oil Stadium crowd when he was announced as the final starter. The 45-year-old waved to the crowd and slapped hands with a group of fans gathered around the American flag on the field.</p><p>Vinatieri broke Morten Andersen&#8217;s record two weeks ago at Oakland, but the Colts had a bye last week and Sunday marked the first time Indy could celebrate the record-breaking moment on its home turf.</p><p>___</p><p>1 p.m.</p><p>Three-time Pro Bowl defensive lineman Jurrell Casey was the last of the Titans defense introduced before kickoff for Tennessee&#8217;s game against New England.</p><p>Casey took the field carrying an American flag, and first shaking hands with a soldier as part of the NFL&#8217;s Salute to Service being held on Veteran&#8217;s Day. A soldier accompanied each Titans starter onto the field for a few steps.</p><p>Country artist Little Big Town performed the national anthem, which featured a flyover by military helicopters.</p><p>___</p><p>11:30 a.m.</p><p>Drew Brees and Tom Brady enter Week 10 of the NFL&#8217;s schedule neck and neck in closing in on matching Brett Favre for second place on the career regular-season list.</p><p>Brees has 506 touchdowns passing, two behind Favre, as the New Orleans Saints play at Cincinnati. And Brady has 505 with his New England Patriots playing at Tennessee. Both are a little more than 30 behind Peyton Manning&#8217;s record of 539.</p><p>Brady does have chance to pass Manning on the career touchdowns passing list, including playoffs. Manning has 579, only three more than Brady.</p><p>On the other end of the quarterback matchup spectrum Sunday, the Buffalo Bills and New York Jets will feature a battle of the backups rather than far more intriguing AFC East showdown of two rookie first-round picks.</p><p>Matt Barkley is starting in place of Buffalo&#8217;s Josh Allen, who will miss his fourth straight game with a sprained throwing elbow. For New York, Josh McCown is starting in place Sam Darnold, who is sidelined by a strained right foot. Darnold was drafted third overall, four spots ahead of Allen.</p><p>___</p><p>More AP NFL: https://apnews.com/NFL and https://twitter.com/AP_NFL</p><p> </block></p></div><a href="#" id="btn-more" onclick="ga('send','event','Posts','click','The Latest: Fitzgerald passes TO on yards receiving list');return false;"><span class="op-btn">Read More</span> <span class="count">2094 Words</span></span></a></div><div class="post-bot"> <div class="fl-post-meta fl-post-meta-bottom"><div class="fl-post-cats-tags"><a href="https://nationalfootballpost.com/category/news/" rel="category tag">NFL and College Football Articles</a></div></div><div class="share-social"> <a class="icon icon-facebook icon-replacement" href="http://www.facebook.com/sharer/sharer.php?s=100&p[url]=https%3A%2F%2Fnationalfootballpost.com%2Fthe-latest-fitzgerald-passes-to-on-yards-receiving-list%2F" target="_blank"><i class="fa fa-facebook" aria-hidden="true"></i></a> <a class="icon icon-twitter icon-replacement" href="https://twitter.com/intent/tweet?text=The Latest: Fitzgerald passes TO on yards receiving list+http://nfp.news/yo9" target="_blank"><i class="fa fa-twitter" aria-hidden="true"></i></a> <a href="mailto:type email address here?subject=I wanted to share this post with you from National Football Post&body=The Latest: Fitzgerald passes TO on yards receiving list&#32;&#32;http://nfp.news/yo9" title="Email to a friend/colleague" target="_blank"><i class="fa fa-envelope" aria-hidden="true"></i></a> <button class="btn btn-primary" data-clipboard-text="http://nfp.news/yo9"><i class="fa fa-link" aria-hidden="true"></i></button></div></div></article></div></div></div></div></div></div><a href="#" id="fl-to-top"><i class="fa fa-chevron-up"></i></a><style>[class*="fa fa-"]{font-family:FontAwesome !important;}</style>
<noscript id="wpfc-google-fonts"><link rel='stylesheet' id='sab-font-css' href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,700,400italic,700italic&#038;subset=latin' type='text/css' media='all'/>
<link rel='stylesheet' id='fl-builder-google-fonts-a0dc0f37a2c19d739b7445c77d065820-css' href='https://fonts.googleapis.com/css?family=Open+Sans%3A300%2C400%2C700%7CRoboto+Condensed%3A700%7COpen+Sans+Condensed%3A700&#038;ver=4.9.8' type='text/css' media='all'/>
</noscript>
<link rel='stylesheet' id='font-awesome-css' href='https://maxcdn.bootstrapcdn.com/font-awesome/4.7.0/css/font-awesome.min.css?ver=2.1.4.3' type='text/css' media='all'/>
<script>var posts_table_params={"ajax_url":"https:\/\/nationalfootballpost.com\/wp-admin\/admin-ajax.php","ajax_nonce":"3d494c1ccc","wrapper_class":"posts-table-wrapper bb-theme","language":{"info":"Showing _START_ to _END_ of _TOTAL_ entries","infoEmpty":"Showing 0 entries","infoFiltered":"(_MAX_ entries in total)","lengthMenu":"Show _MENU_ entries","emptyTable":"No data available in table.","zeroRecords":"No matching records found.","search":"Search:","paginate":{"first":"First","last":"Last","next":"Next","previous":"Previous"},"thousands":",","decimal":".","aria":{"sortAscending":": activate to sort column ascending","sortDescending":": activate to sort column descending"},"filterBy":"Filter:","resetButton":"Reset"}};</script>
<!--[if lt IE 9]><script src="//nationalfootballpost.com/wp-content/cache/wpfc-minified/8z16d3ot/bny98.js"></script><![endif]-->
<!--[if lt IE 9]><script src="//nationalfootballpost.com/wp-content/cache/wpfc-minified/lbeld6mi/bny98.js"></script><![endif]-->
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/nationalfootballpost.com\/","sameAs":["http:\/\/facebook.com\/nationalfootballpost","https:\/\/twitter.com\/footballpost"],"@id":"https:\/\/nationalfootballpost.com\/#organization","name":"National Football Post","logo":"http:\/\/footballpost.wpengine.com\/wp-content\/uploads\/2018\/05\/NFPlogo-400.png"}</script>
<script src='//nationalfootballpost.com/wp-content/cache/wpfc-minified/qlb18u0t/bny8x.js' type="text/javascript"></script>
<script async src="https://www.googletagmanager.com/gtag/js?id=UA-5166086-1"></script>
<script>window.dataLayer=window.dataLayer||[];
function gtag(){dataLayer.push(arguments);}
gtag('js', new Date());
gtag('config', 'UA-5166086-1');</script>
<script type='text/javascript' src="https://wlsugarhouseaffiliates.adsrv.eacdn.com/S.ashx?btag=a_367b_182c_&affid=185&siteid=367&adid=182&c="></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/clipboard.js/1.5.10/clipboard.min.js"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/2.1.1/jquery.min.js"></script>
<script>jQuery(function($){
$('button').tooltip({
trigger: 'click',
placement: 'bottom'
});
function setTooltip(btn, message){
$(btn).tooltip('hide')
.attr('data-original-title', message)
.tooltip('show');
}
function hideTooltip(btn){
setTimeout(function(){
$(btn).tooltip('hide');
}, 1000);
}
var clipboard=new Clipboard('button');
clipboard.on('success', function(e){
setTooltip(e.trigger, 'Link copied to clipboard');
hideTooltip(e.trigger);
});
clipboard.on('error', function(e){
setTooltip(e.trigger, 'Failed!');
hideTooltip(e.trigger);
});
});</script>
<script defer src='//nationalfootballpost.com/wp-content/cache/wpfc-minified/2m36h6do/bny8x.js' type="text/javascript"></script>
<script>document.addEventListener('DOMContentLoaded',function(){function wpfcgl(){var wgh=document.querySelector('noscript#wpfc-google-fonts').innerText, wgha=wgh.match(/<link[^\>]+>/gi);for(i=0;i<wgha.length;i++){var wrpr=document.createElement('div');wrpr.innerHTML=wgha[i];document.body.appendChild(wrpr.firstChild);}}wpfcgl();});</script>
<script >document.addEventListener('DOMContentLoaded',function(){
jQuery(document).ready(function($){
$(window).scroll(function(){
var footerPos=$('footer').last().position().top;
var pos=$(window).scrollTop();
if(pos+(screen.height*4) > footerPos){
if($(".centil-infinite-scroll").first().hasClass('working')){
return false;
}else{
$(".centil-infinite-scroll").first().addClass('working');
}
var centilNextPostId=$(".centil-infinite-scroll").first().text();
var data={
'action': 'centil_is',
'centilNextPostId': centilNextPostId
};
jQuery.post('https://nationalfootballpost.com/wp-admin/admin-ajax.php', data, function(response){
$(".centil-infinite-scroll").first().replaceWith(response);
}, 'html');
}
var currUrl=$(".centil-post-header").first().attr("url");
var currTitle=$(".centil-post-header").first().attr("title");
if($(".centil-post-header").length > 1&&history.pushState){
for (var i=0; i<$(".centil-post-header").length; i++){
if(pos+(screen.height/2) >=$(".centil-post-header").eq(i).next().position().top){
currUrl=$(".centil-post-header").eq(i).attr("url");
currTitle=$(".centil-post-header").eq(i).attr("title");
}}
}
if(location.href!=currUrl){
history.pushState({}, currTitle, currUrl);
}});
});});</script>
</body>
</html><!-- WP Fastest Cache file was created in 1.8439810276 seconds, on 11-11-18 20:41:34 --><!-- need to refresh to see cached version -->